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Welcome to Keynote

 

With Keynote, impressive presentations are just the 
beginning. This preface provides an overview of 
Keynote features and lists resources for learning 
more.

 

Keynote is a robust program for creating professional-quality presentations. Powerful, 
simple tools make it easy for you to deliver compelling presentations, create studio-
quality storyboards and portfolios, and build interactive slideshows. You can 
incorporate photos, movies, or music from your iLife libraries, as well as Safari web 
snapshots.

Present your data using any of the charts and tables built right into Keynote. Use the 
handsome and versatile themes that come with Keynote, or customize themes to suit 
your specific needs. Add engaging animations to text and tables, and save your ideas 
with comments.

Your Keynote presentation can be viewed in several ways. You can watch it on a 
computer, project it from a computer to a large screen, or print it. You can also export 
your presentation as a set of image files or to Flash, QuickTime, PowerPoint, HTML, or 
PDF format so that it can be viewed on other computer platforms. (For more 
information about viewing options, see Chapter 8, “Viewing, Printing, and Exporting 
Your Slideshow.”)

 

Keynote Features at a Glance

 

The next few pages provide a quick overview of Keynote features. The remainder of 
the book gives step-by-step instructions for using Keynote to create, revise, and share 
your slideshows.
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Professional-Quality Designs

 

Keynote provides a wide variety of themes—including HD themes—you can use to 
quickly create stunning presentations. Every theme includes coordinated colors, text, 
charts, and tables. You can easily change a slideshow’s theme at any time, and you can 
modify themes to suit your needs. You can even set off sections of your slideshow by 
using multiple themes in the same presentation.
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Animated Text and Slide Transitions

 

Bring your text to life with studio-quality text animations. Choose from an array of text 
and word animations. Animate text so that lines enter the slide one at a time or in 
groups. Add interest by using two or more text columns on a slide and by using 
special styles of text and image bullets. Transition between slides with dramatic 
transition effects such as swoosh, droplet, and reflection.
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Powerful Animation Tools

 

Create complex slide animations quickly and easily—any element can be moved and 
animated. Mix charts, tables, and graphics on the same slide. Fine-tune animations by 
changing the order in which elements appear and how they enter and exit a slide.

Create sophisticated 
animations (“object 
builds”) and slide 
transitions. Synchronize 
the entry and exit of 
multiple objects on a slide.
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Easy-to-Use Media Tools

 

Find items you’ve stored in your iPhoto or iTunes library, or in your Movies folder, and 
drag photos or tunes right to a slide. Add images and adjust brightness, contrast, 
exposure, saturation, hue, sharpness, and light cutoff levels right within Keynote.

Select the album where 
your picture is located.

Choose iPhoto, iTunes, 
or Movies.

Drag a thumbnail to the 
slide or to an image well 
in one of the inspectors.

Search for a file by name.
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Free-Form Curves, Shapes, and Masks

 

Create any shape using Bézier curves. Crop images by using masks of different shapes. 
Choose from predrawn shapes or create your own custom shape to use as a mask. 
With a mask, you reveal only the part of an image you want to show on a slide, 
without altering the original file.

Create a custom mask to 
frame part of a photo.

Position the mask over 
the image, and then 
optionally edit the mask. 
Here, it’s rotated and 
resized.

The original image is 
framed by the mask.
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Realistic 3D Charts

 

Show off 2D data in 3D-rendered bar, line, and area charts. Choose realistic wood-
grain, metal, and other textures. Apply multiple different lighting styles for interesting 
reflections.

 

Tables with Calculation and Sorting

 

Automate calculation in any cell in a table using arithmetic formulas and values from 
other cells. Sort by row or column, in ascending, descending, numerical, or 
alphabetical order. Format numbers with currency formatting and dates with 
international standards.
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Easy-to-Use Inspectors

 

Keynote inspectors makes it easy to format your slides as you work. You use the ten 
inspectors to format most elements in a slideshow.
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Tools for Advanced Presenters 

 

Set up a projector display for the audience and your laptop screen as the presenter 
display, or rehearse your presentation by viewing the show on only one display. While 
you give your presentation, you can view information such as the current and next 
slide, elapsed time or time remaining, a clock, and slide notes. Control movie playback 
during a presentation using keyboard shortcuts. Jump to any slide by typing its slide 
number.
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What’s New in Keynote 3

 

Keynote 3 provides new features that help you create attractive, compelling 
slideshows.

Â

 

New themes

 

Use Apple-designed themes for presentations, storyboards, and self-running 
presentations. Apply new HD themes with 16 x 9 aspect and pixel dimensions of 
1920 x 1080.

Â

 

3D-rendered charts with animations

 

Show off results in realistic and beautiful 3D charts, apply multiple different light 
styles for different reflections, and create beautifully 3D-rendered bar, line, and area 
charts of 2D data. View charts in wood grain, metal, and other textures. Use the 3D 
Rotation Angle wheel for complete control of chart viewing angle.

Â

 

Cinematic animations with interleaved builds

 

Captivate the audience with cinematic slide transitions, interleaved graphic builds, 
and text animations. Create a cinematic experience with new, animated slide 
transitions. Draw attention to tables, charts, images, and text with new build 
effects:  blinds, swoosh, and speedy. Interleave builds of bulleted text, tables, and 
even charts in any sequence and by groups of items, such as bullets or bullet 
groups, table rows or columns or cells, images, and more.

Â

 

iPhoto-like image adjusting

 

Obtain the perfect visuals by fine-tuning image appearance. Adjust brightness, 
contrast, exposure, saturation, hue, sharpness, and light cutoff levels separately on 
any image right within Keynote. View immediate changes to image settings and 
easily revert to your original.

Â

 

New shapes and Bézier drawing with smooth curves

 

Add shapes like polygons or stars, or draw custom shapes with curves, right within 
Keynote. Draw completely custom shapes with smooth paths using Bézier curves, 
and fine-tune Bézier shapes by changing curve angles or even by adding new curve 
points. Add predrawn shapes such as stars and editable polygons.
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Â

 

Image masking with any shape

 

Focus on any part of an image using any shape or custom Bézier curves. Mask 
images with any shape to remove a background or any other unwanted object. 
Create your own mask using Bézier curves in any shape.

Â

 

Enhanced iLife integration

 

Share your presentation with iDVD and iPhoto. Export your presentation into iDVD 
with chapter breaks between slides and active hyperlinks. Export your slides directly 
into iPhoto with variable compression and into HTML for adding slide content on 
the web. See all your export options in a new, easy-to-use export window.

Â

 

Tables for organizing information

 

Organize information and graphics in tables with calculations and automatic sorting. 
Easily add tables with coordinated look-and-feel for each theme. Automate 
calculation in any cell in a table using arithmetic formulas and values from other 
cells; create summary row and columns with value sums, averages, count, and more. 
Sort by row or column, ascending or descending, numerical or alphabetical, and 
format numbers with currency formatting and dates with international standards.

Â

 

Tools for advanced presenters

 

Enjoy more control over your presentations. Use practice view to rehearse your 
presentation using a single screen to show current and next slides, notes, elapsed 
time, and a clock. Use light table view to display slides in multiple rows and columns 
for an at-a-glance view and sorting of your presentation. Control movie playback 
during a presentation using a video scrubber. Lock a kiosk presentation with a 
password to a slideshow playing in Keynote. Add comments directly on the slide 
canvas as reminders that are neither printed nor projected.

Â

 

Text in multiple columns and bullets in multiple text boxes

 

Use multiple columns for text on a slide, and add text boxes where you need them.
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How to Use Menus

 

To complete many of the tasks in this book (and in Keynote Help), you use menu 
commands. The instructions look like this: 

m

 

Choose Help > iWork Tour.

The first term after 

 

Choose

 

 is the menu you click; the next term is the item you choose 
from that menu.

 

Resources for Learning More

 

To get the most out of Keynote, consult the following resources:

 

Tour

 

For an onscreen demonstration of what you can do with Keynote, view the tour. Open 
the tour by choosing Help > iWork Tour.

 

Keynote 3 User’s Guide

 

This full-color PDF document provides detailed information about Keynote features 
and instructions for working with slides.

Chapter 1, “Overview of Keynote,” describes the tools for creating presentations. 
Chapter 2, “Creating a Presentation,” shows the basic step-by-step workflow. For more 
detailed information about each step, refer to Chapters 3 through 8. To learn how to 
create your own themes, read Chapter 9, “Designing Your Own Master Slides and 
Themes.”

 

Onscreen Help

 

To see the help, open Keynote and choose Help > Keynote Help. You can browse 
through the table of contents to find a specific topic, or enter a question in the search 
field to find an answer about how to accomplish a task.
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Help tags are also available for many onscreen items. To see a help tag, let the pointer 
rest over an item for a few seconds. Help tags in the Inspector window are useful for 
learning about the effects of various options.

 

Web Resources

 

Go to www.apple.com/keynote to get the latest software updates and information. 
You can also purchase Keynote products on the web.

 

Technical Support

 

A variety of support options are available to Keynote users. For more information, see 
the AppleCare Software Service and Support Guide that comes with your Keynote 
documentation or choose Help > Service and Support.

To display a help tag, rest 
the pointer over an item.
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Overview of Keynote

 

This chapter introduces you to the windows and 
tools you use to create presentations with Keynote.

 

When you create slides in Keynote, you create a Keynote document. The entire 
slideshow—including all the graphics, media, and chart data—is contained within this 
one document. This means that you can easily move the presentation from one 
computer to another. If you add movies or sounds to your document, you can save 
them as a part of your Keynote document so that you don’t have to transfer those files 
separately.

 

The Keynote Window

 

The Keynote window contains three sections:

Â

 

The slide canvas

Â

 

The slide organizer

Â

 

The notes field

These sections show detailed views of your slides and slideshow as you work. It’s easy 
to organize your slides and navigate through them, even with long slideshows.
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The Slide Canvas

 

The slide canvas is where you create each slide. You can easily drag graphics files, 
movie files, and sound files to the canvas to add them to your slideshow. 

The slide canvas:  Create 
each slide by typing text 
and adding media.

The toolbar:  Customize it 
to include the tools you 
use most often.

The notes field:  Add text about 
individual slides. You can refer 
to these notes during your 
presentation—the audience 
won’t see them.

The slide organizer:  View a 
visual outline of your slide 
presentation. You can view a 
thumbnail of each slide or a 
text outline.
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You create a slideshow using a theme—a family of master slides—to ensure a 
handsome and cohesive look throughout your presentation. Master slides provide 
predesigned layouts for various kinds of slides, with coordinated fonts, textures, chart 
properties, and more. Each theme contains a variety of master slides, making it easy to 
add titles, bulleted text, and graphics.

As you work on your slides, you may want to zoom in or out to get a better view of 
what you are doing.

To zoom in or out on the slide canvas:
m Choose a magnification level from the pop-up menu at the bottom left of the slide 

canvas. Or choose View > Zoom > [zoom level]. 

Different Views
Keynote gives you a choice of four views to streamline the way you work.

Â Navigator:  In navigator view, use the slide organizer at the left side of the Keynote 
window to organize the slides in your presentation. This view displays a thumbnail 
image of each slide. You can rearrange slides by dragging them, and you can indent 
slides to group them. Navigator view is good for graphics-rich presentations. 

Â Outline:  Use outline view to see a text version of your slides in the organizer. This is 
a good view for presentations that contain mostly text. As in navigator view, you can 
rearrange and indent slides. 

Â Slide Only:  Switch to slide only view when you want to hide the slide organizers 
and concentrate only on slides.

Â Light Table:  Light table view shows your slides as if they were arranged on a 
photographer’s light table. You can move slides around until you have the sequence 
you want.

To change from one view to the other:
m Click View in the toolbar and choose an option (or choose View > Navigator, Outline, 

Light Table, or Slide Only).
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To hide the slide organizer:
m Click the View button and choose Slide Only or Light Table (or choose View > Slide 

Only).

Navigator View
In navigator view, the slide organizer displays a thumbnail image of each slide in your 
presentation, making it easy to see the flow of graphics-rich presentations.

To help you organize your presentation as you work, you can group slides by 
indenting them, creating a “visual outline” of the slideshow. You can show or hide 
groups of slides by clicking the disclosure triangles. You can also skip slides so that 
they will not appear when you present your slideshow.

To show navigator view:
m Click View in the toolbar and choose Navigator (or choose View > Navigator).

You can see your master slides in navigator view by dragging the bar at the top (or by 
clicking View in the toolbar and choosing Show Master Slides). Use the master slides 
to design your own themes and master slide layouts. (For information about 
designing your own themes and master slide layouts, see Chapter 9, “Designing Your 
Own Master Slides and Themes.”)

Drag the bar at the top 
of navigator view to 
display the master slides.

See the graphics on each 
of your slides at a glance.

Organize slides by 
indenting them. To 
indent a slide, drag it or 
select it and press Tab.

Click the disclosure 
triangles to show or 
hide groups of 
indented slides.
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Working With Slides
When you create a new slideshow, Keynote automatically creates a title slide for you. 
When you add the first slide after that, Keynote automatically switches to a “Title & 
Bullets” slide layout, unless you choose a different master for the first slide. You can 
change the master used for that or any other slide by clicking Master in the toolbar 
and choosing a different layout.

If you choose a different master for the first slide, the next slide you insert will use the 
master you chose. When you add a new slide, it uses the same master as the selected 
slide (except in the case described above).

To add a slide, do one of the following:
Â Select a slide and press Return.

Â Click the New (+) button in the toolbar (or choose Slide > New Slide). 

To duplicate a slide:
m Press Option and drag a slide in the navigator until you see a blue triangle (or choose 

Edit > Duplicate). 

To copy a slide:
m Select a slide, choose Edit > Copy, select another slide, and choose Edit > Paste.

To indent slides:
1 In navigator view, select the slide you want to indent. 

To select multiple slides, hold down the Shift key and select the first and last slides in 
a range.

2 Press Tab (or drag the selected slide to the right until a blue triangle appears).

You can create more indent levels by pressing Tab again. You can indent a slide only 
one level deeper than the previous slide (known as the “parent” slide).

To move slides to a higher outline level:
m Select the slides and press Shift-Tab (or drag the selected slides to the left).

To show or hide a group of slides:
m Click the disclosure triangle to the left of the first slide in the group.

To skip a slide when you play your slideshow:
m Select the slide and choose Slide > Skip Slide.
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To display a skipped slide:
m Select the slide (it looks like a line in the slide organizer) and choose Slide > Don’t Skip 

Slide.

To delete a slide:
m Select the slide in the slide organizer and press the Delete key.

If the slide had subordinate slides grouped below it (known as “children”), they are 
moved up by one outline level.

To delete a slide and all the slides grouped below it:
m Collapse the group of slides (click the arrow to the left of the top slide) and press the 

Delete key.

If you accidentally delete slides, you can recover them immediately by choosing Edit > 
Undo Delete.

To move a group of slides:
m Select the first slide in the group and drag the group to a new location in the slide 

organizer.

Outline View
Outline view displays the title and bullet-point text of each slide in your slideshow. 
This view is most useful for seeing the flow of text-rich presentations. All the titles and 
bullet points appear legibly in the slide organizer.

Outline view provides an easy way to order and reorder your bullet points as you 
organize your presentation. You can add bullet points to existing text directly in the 
slide organizer. You can also drag bullets from one slide to another, or drag them to a 
higher or lower level within the same slide.
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To show outline view:
m Click View in the toolbar and choose Outline (or choose View > Outline).

To change the font used in outline view:
1 Choose Keynote > Preferences and click General.

2 Choose a font and size from the Outline View Font pop-up menus.

To select a bullet and its text in outline view:
m Click the bullet.

To select a bullet (or bullets) and its subordinate bullets:
m Click between a bullet and its text, and then drag down.

To move a bullet to a lower outline level on the same slide:
m Click anywhere in the text and press Tab, or drag the bullet to the right, until a blue 

triangle appears.

You can also select (highlight) any number of bullets and press Tab.

As in navigator view, you can skip 
slides so that they don’t appear 
when you play your slideshow.

Double-click a slide icon 
to hide its bulleted text 
in the slide organizer.

Drag bullets left or right 
to move them to a higher 
or lower outline level.

Drag bullets to another slide 
or drag them to create a 
new slide.

In outline view, you see the 
text in titles and bullet points. 
You can add or edit text 
directly in outline view.
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To move a bullet to a higher outline level on the same slide:
m Click anywhere in the text and press Shift-Tab, or drag the bullet to the left until a blue 

triangle appears.

To move bullets to another slide:
m Drag the selected bullets out of the current slide to a different slide.

To move bullets from one slide and create a new slide:
m Drag the bullets to the left of the other bullets on the slide until a blue triangle 

appears above the slide.

To place all slide bullets subordinate to the bullets on the previous slide:
m Drag the slide icon to the right.

All bullets on the slide are moved to the previous slide, with the first bullet at the 
same level as the last bullet on the previous slide.

To print the outline view:
1 Choose File > Print.

2 In the Print dialog, choose Keynote from the Copies & Pages pop-up menu.

3 Select Outline.

The Notes Field
Use the notes field to type or view notes for each slide. You can print these notes or 
view them on an alternate display that only you see while you give your presentation.

To see the notes field:
m Click View in the toolbar and choose Show Presenter Notes (or choose View > Show 

Presenter Notes).

To learn how to view your notes during slideshow playback, see Chapter 8, “Viewing, 
Printing, and Exporting Your Slideshow.”

The notes field is an area 
where you can keep track of 
what you want to say as you 
show each slide.
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Comments
Comments provide an easy way to save your ideas and place them on slides as 
reminders. You can move comments anywhere on the slide canvas. Your comments 
appear on the display while you’re editing, and they appear on the presenter display, 
but they don’t appear to your viewers when you play the presentation.

If you use comments frequently, you may want to add the Comments button to the 
toolbar. To do so, choose View > Customize Toolbar and drag the Comments button to 
the toolbar.

To add a comment:
1 Choose Insert > Comment.

2 Type a note, idea, or reminder.

3 Drag the comment wherever you want to place it on the canvas.

Note:  Because comments are always on top of the slide canvas, they may obscure 
parts of your slide content. Simply drag the comments out of the way or hide them to 
reveal the content beneath.

To hide or show comments:
1 Click the View button in the toolbar and choose Hide Comments (or choose View > 

Hide Comments).

2 To bring the comments back, click the View button and choose Show Comments.

To resize a comment:
m Drag the lower-right corner.
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To close a comment:
m Click the x in the upper-right corner.

To change text styles and background colors:
Â Text:  See “Editing Text and Text Properties” on page 45 for details on changing text 

style and format.

Â Color and fill:  See “Using Color and Image Fills” on page 80 for details on changing 
the background color in comments. 

To print with comments showing:
1 Make sure the comments appear on the slide canvas, as described earlier.

2 Print the document.

Your comments, along with standard slide content, are printed as they appear on the 
screen.

Keynote Tools
Keynote tools give you one-click access to many of the actions you’ll use as you create 
presentations.

The Toolbar
As you work in Keynote and get to know which commands you use most often, you 
can customize the toolbar by adding, removing, and rearranging toolbar buttons.
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To customize the toolbar:
Â Press Control and click the toolbar, and choose Customize Toolbar. You can also 

choose View > Customize Toolbar.

Â To add an item to the toolbar, drag its icon to the toolbar at the top.

Â To remove an item from the toolbar, drag it out of the toolbar.

Â To rearrange items in the toolbar, drag them.

Â To make the toolbar icons smaller, select Use Small Size.

Â To display only icons or only text, choose an option from the Show pop-up menu.

You can restore the default set of toolbar buttons by dragging the default set to the 
toolbar. This restores the original group of icons that appeared the first time you 
opened Keynote.

If you’re not sure what a button does, drag it to the toolbar (in the Customize dialog) 
and click Done. You can now hold the pointer over the icon in the toolbar to see the 
button’s description.

Keynote Inspectors
Keynote inspectors make it easy to format your slides as you work. Most elements of 
your slideshow can be formatted using the ten inspectors. Each inspector controls one 
aspect of slide formatting. For example, you use the Document Inspector to choose 
slideshow settings.

Click to choose a
new view, theme,

or master slide.

Click these buttons to 
add or delete slides or to 
play the slideshow.

Add a free text box, shape, 
table, chart, or comment.

Turn a group of objects into
one object (or one into its

components); move an
object on top of or

underneath other objects.

Adjust images.

Open the Inspector window 
and Media Browser.

Open the Colors 
window; click the 
arrow to open the 
Fonts window.
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To open the Inspector window:
m Click Inspector in the toolbar (or choose View > Show Inspector).

Click one of the buttons at the top to display an inspector. Clicking the second button 
from the left, for example, displays the Slide Inspector. You can have several Inspector 
windows open at the same time.

To open more than one Inspector window at the same time:
m Choose View > New Inspector.

Media Browser
The Media Browser gives you quick access to music, photo, and movie files that you 
may want to use in a presentation.

To open the Media Browser:
m Click Media in the toolbar (or choose View > Show Media Browser).

To view your media files:
m Choose iTunes, iPhoto, or Movies from the pop-up menu at the top of the Media 

Browser window.

To add a media file to your presentation:
m Select a music file, photo, or movie file, and then drag it to a slide.

Click one of these buttons 
to display a different 
inspector.
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To search for a media file:
m Type the title or filename in the search field at the bottom of the Media Browser 

window.

If you’ve added a title to an image, Keynote won’t find the image. Keynote searches on 
whatever name is visible in the Media Browser. For details about the Media Browser, 
see “Using the Media Browser” on page 68.

The Colors Window
You use the Mac OS X Colors window to choose colors for text, shapes, or shadows.

To open the Colors window:
m Click Colors in the toolbar (or choose View > Show Colors).

The Font Panel
Keynote uses the Mac OS X Font panel, so you can use any of the fonts on your 
computer in your presentations.

To open the Font panel:
m Click Fonts in the toolbar (or choose Format > Font > Show Fonts).

Note:  If you use special fonts in a Keynote document and you send it to others, make 
sure the recipients have those fonts installed on their computers.

Shortcuts
You can use the keyboard to perform many of the Keynote menu commands and 
tasks. A comprehensive list of keyboard shortcuts is available in onscreen help.

To see the list of keyboard shortcuts:
m In Keynote, choose Help > Keyboard Shortcuts.

Many commands are also available in shortcut menus that you can access directly 
from the object with which you are working. Shortcut menus are especially useful for 
working with tables and charts.
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To open a shortcut menu:
m Hold down the Control key while you click an object.
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22 Creating a Presentation

This chapter outlines the basic tasks and steps for 
completing a professional-quality slide 
presentation.

Step 1:  Select a Theme
Use Keynote themes to create an attractive presentation without having to do a lot of 
design work. Each Keynote theme includes a set of templates (called master slides) 
with styled text, bullets, layouts, and other formatting features already set for you. 
Keynote themes come in various textures and moods to suit different kinds of 
presentations.

Starting a New Project
Whenever you create a new Keynote document, you must select a theme in the 
Theme Chooser. You can easily change the theme of a Keynote slideshow at any time 
and specify a particular theme for any new documents you create.

To start a new project:
1 Double-click the Keynote icon and select a theme.

Importing a PowerPoint or AppleWorks Presentation
If you already have a slide presentation that you created in Microsoft PowerPoint or 
AppleWorks, you can import it into Keynote and continue to work on it. Simply drag 
the PowerPoint or AppleWorks document icon to the Keynote application icon. The 
document opens in Keynote, and you may apply a theme to the document if you 
wish.

You can export Keynote documents to PowerPoint. For more information, see 
“PowerPoint” on page 167.
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2 Choose a slide size from the Slide Size pop-up menu. 

For highest quality playback, your slide size should match the screen resolution of the 
display on which the slideshow will appear. Keynote offers an HD resolution of 1920 x 
1080 (not all themes offer this resolution). Most projectors work best with slides set at 
the 1024 x 768 size; newer projectors can display slides at a higher resolution. All 
Keynote themes come optimized for 800 x 600 and 1024 x 768 sizes. 

If your display is larger than one of the sizes mentioned here, you can set a custom 
slide size for your Keynote presentation. For more information, see “Changing the 
Slide Size” on page 162.

Note:  Higher resolutions require more memory and faster processing.

3 Click Choose.

Changing the Theme
You can change the theme for a slideshow at any time.

To apply a different theme to a slide presentation:
m Click Themes in the toolbar and scroll to select a theme (or choose File > Choose 

Theme and select a theme).

You can choose to apply the new theme to the selected slide or to all the slides when 
you use the Theme Chooser.

Setting a Theme to Use for New Documents
You can specify a particular theme to be used for any new documents you create. This 
means that you bypass choosing a theme each time you create a new slideshow. You 
can still change the theme for a slideshow at any time.

To specify the theme used for new documents:
1 Choose Keynote > Preferences and click General.

2 Select “Use theme” and click Choose.

3 Select the theme you want, choose a slide size from the Slide Size pop-up menu, and 
click Choose.
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To modify themes or create your own, see Chapter 9, “Designing Your Own 
Master Slides and Themes.” You can use more than one theme in a presentation; see 
“Using Multiple Themes” on page 42. 

Step 2:  Create Your Slides
When you select a theme, a single slide appears in the slide organizer. You can begin 
working in this first slide, adding text, graphics, movies, and sound. You can add new 
slides to the document as needed.

To add a slide, do one of the following:
Â Click the New (+) button in the toolbar (or select a slide in the slide organizer and 

press Return). You can also choose Slide > New Slide to insert a slide. 

Important:  Save your work often by choosing File > Save. For more details about 
saving Keynote documents, see “Step 4:  Save Your Slideshow” on page 42.

Using Master Slides
As you work, you’ll want to use different slide layouts to place text and graphics on 
individual slides. Master slides provide the layouts you are most likely to need.

Kinds of Slideshows
You can make three different kinds of presentations in Keynote, depending on how 
the presentation will be used. It’s a good idea to keep the kind of presentation in 
mind as you design it. Note that hyperlinks are available in a normal presentation, 
not just in a hyperlinks-only presentation.
Â Normal:  These presentations are controlled by clicking the mouse or using the 

keyboard. By default, a slideshow is normal (interactive) unless you make it a self-
playing or hyperlinks-only slideshow.

Â Self-playing:  These presentations advance automatically, the way a movie plays 
(no user interaction is possible). You can use this option, for example, to play a 
presentation in a kiosk setting. To learn about creating these kinds of 
presentations, see “Creating Self-Playing Presentations” on page 153.

Â Hyperlinks only.:  Viewers navigate through these presentations by clicking 
hyperlinks. For more information about creating these kinds of presentations, see 
“Hyperlinks-Only Presentations” on page 155.
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Each Keynote theme includes a family of master slides. Each master slide has a 
different layout that may include title and body placeholder text, as well as object 
placeholders for graphics, tables, and charts.

Most themes come with the master slide layouts described here:

When you create a new slide, it uses the master slide of the selected slide (except 
when the selected slide is the first slide, Title & Subtitle). You can change a slide’s 
master slide layout at any time.

To change the master for a slide:
1 Select the slide whose master slide layout you want to change.

2 Click Masters in the toolbar.

3 Select a master slide in the list.

For more information about modifying themes and master slides, see Chapter 9, 
“Designing Your Own Master Slides and Themes.”

Master slide Recommended use

Title & Subtitle Title page or section titles within your presentation

Title & Bullets Content

Title & Bullets—2 Column Content you want to appear side by side

Bullets General content pages that require bulleted text; the text area 
fills the entire slide

Blank Graphics-rich layouts

Title—Top or Center Title page or section titles within your presentation

Photo Horizontal Horizontal photo with title below

Photo Vertical Vertical photo with title and subtitle on the left

Title, Bullets & Photo Title page or section title with text and photo

Title & Subtitle Title page or section titles requiring a subtitle

Title & Bullets—Left or Right Content slides on which you can place bulleted text on the left or 
right and a graphic on the other side of the slide
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Adding Text
Master slides provide placeholder text (which you replace with your text) for slide 
titles and body text. Choose a master slide with the combination of title text and body 
text that best suits the slide’s content.

Title text is larger than body text. Most body text is bulleted (preceded by a “dot” or 
other ornament), but you can change from bulleted to non-bulleted text. To learn 
more about text formatting, see See “Using the Text Inspector” on page 46.

If the slide you’re working on doesn’t have title text or body text, you can either 
choose a different master or select the Title or Body checkboxes in the Appearance 
pane of the Slide Inspector.

To add title text to a slide:
m Double-click in a title text box on the slide canvas and type your text.

To add text:
m Click in a body text box on the slide canvas and begin typing. 

Â To move to the next line, press Return.

Â To indent a line, press Tab.

Â To move a bulleted line to a higher indent level, press Shift-Tab.

For information about creating text boxes, see “Adding Text Boxes” on page 45.
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You can change the look of the text and bullets in any of your slides using the Text 
Inspector and the Graphic Inspector. For more details about how to use inspectors to 
change text, including how to change the style of bullets, see Chapter 3, “Working 
With Text, Graphics, and Other Media.”

Adding Graphics
You can easily add photos, sound files, and movies to your presentation. For details, 
see “Including Sound and Other Media” on page 68.

To add a graphic to a slide, do one of the following:
Â Click Media in the toolbar to open the Media Browser (or choose View > Show 

Media Browser), choose iPhoto, and drag a photo to the slide canvas.

Double-click in a title text box and 
type a title. The font and text size 
are already set for you.

Drag a graphics file from 
the Media Browser or 
Finder to your slide.

Double-click in a body text 
box and type to create text. 
The style, font, and text size 
are already set.
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Â Drag a graphics file from the Finder to the slide canvas. 

Â Choose Insert > Choose, select the graphics file, and click Insert.

Â To create a new slide with the graphic on it, drag the graphics file from the Finder to 
the slide organizer.

You can modify a graphic’s colors, alignment, orientation, and other properties by 
using the inspectors. Images can be adjusted with the Adjust Image window. You set 
object placement, size, and orientation in the Metrics Inspector. Shadow, fill color, and 
opacity are set using the Graphic Inspector. For more information about setting 
attributes using the inspectors, see Chapter 3, “Working With Text, Graphics, and Other 
Media.”

To present complex or numerical data in an easily understandable visual format, you 
can use a table or chart; Keynote supplies tables and charts for each theme. For more 
information about adding tables and charts, see Chapter 5, “Creating Tables,” and 
Chapter 6, “Creating Charts.”

Using Alignment Guides and Rulers
As you move text and graphics around on the slide canvas, you will notice yellow 
alignment guides. These pop-up guides help you center and align objects on the 
canvas. They appear whenever the center or edge of an object aligns with the center 
or edge of another object, or with the center of the slide canvas. You can create your 
own alignment guides to help you place slide elements precisely in the same position 
from one slide to the next. Alignment guides (even those you create) don’t appear 
during a presentation; they are visible only when you are editing a slide.

Keynote also displays the X and Y coordinates of an object’s top-left corner as you 
move the object around the slide canvas, or the object’s angle as you rotate it. When 
you resize an object, size tags display the object’s height and width.

You can turn on rulers to help you align objects on the slide canvas. Rulers show you 
how far (in increments you specify) an object is from the edge of the slide.

To turn on rulers:
m Click the View button in the toolbar and choose Show Rulers (or choose View > Show 

Rulers).
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To change the unit of measure in the rulers:
1 Choose Keynote > Preferences and click Rulers.

2 Choose an item from the Ruler Units pop-up menu.

Make sure that “Display ruler units as percentage” is deselected. Selecting this option 
displays measurements as a percentage of the distance across the slide, rather than in 
the chosen unit of measure.

To place the ruler’s horizontal origin point at the left edge of the slide:
m In the Rulers pane of Keynote preferences, deselect “Place origin at center of ruler.”

After you’ve placed graphics exactly where you want them on the slide, you can lock 
them to the slide canvas to prevent them from being accidentally moved as you work.

To lock an object to the slide canvas:
m Select the object and choose Arrange > Lock.

You cannot modify an object that has been locked to the slide canvas. To unlock an 
object, select the object and choose Arrange > Unlock.

Note:  If you often lock and unlock objects, you can add buttons to the toolbar for 
these commands. Choose View > Customize Toolbar.

Changing the Appearance and Behavior of Alignment Guides
You can place your own alignment guides on any slide to help you line up objects 
where you want them. 

To place alignment guides on a slide:
1 Click the View button in the toolbar and choose Show Rulers (or choose View > Show 

Rulers).

The rulers appear at the top and left side of the slide canvas.

2 Place the pointer on a ruler and drag to the slide canvas. 

3 Drag the yellow guide wherever you wish on the slide canvas.

You can add alignment guides to a master slide so that they appear on any new slide 
based on that master. For more information, see “Adding Alignment Guides” on 
page 176.

To remove alignment guides that you have placed on a slide:
m Drag the alignment guide off the edge of the slide canvas.
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If alignment guides are getting in the way as you work, you can temporarily hide 
them.

To temporarily hide pop-up alignment guides:
m Hold down the Command key while dragging an object.

You can turn off pop-up alignment guides and size and position tags in the Rulers 
pane of Keynote preferences. You can make alignment guides appear only when 
object edges are aligned, or only when object centers are aligned.

To change the behavior of alignment guides and tags displayed when you move 
objects:

1 Choose Keynote > Preferences and click Rulers.

2 To turn off the guides that appear when an object’s center aligns with another object 
or the center of the slide canvas, deselect “Show guides at object center.”

3 To turn on the alignment guides that appear when an object’s edges align with 
another object or the center of the slide canvas, select “Show guides at object edges.”

4 To turn off size and position tags, click General and deselect “Show size and position 
when moving objects.”

If you change the alignment guides frequently, you may want to add the Guides 
button to the toolbar. To do so, choose View > Customize Toolbar and drag the Guides 
button to the toolbar.

To change the color of alignment guides:
m In the Rulers pane of Keynote preferences, click the Alignment Guides color well and 

select a color in the Colors window.

Step 3:  Organize Your Slides
Change the order of slides in your presentation by dragging them in one of the slide 
organizer views.

You can organize your slides into an outline by indenting related sets of slides and by 
showing or hiding individual slides or groups of slides as you work. Indenting or 
hiding slides in the slide organizer does not affect the flow of the final presentation. It 
is only a tool to make it easier to organize and navigate through large sets of slides.
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For more information about indenting and organizing slides, see “Different Views” on 
page 21.

Using Multiple Themes
As your presentation takes shape, you may want to use different themes for different 
slides within the same presentation. For example, you could have one look for slides 
about past business performance and another for sales projections.

To use multiple themes in a document:
1 In the slide organizer, select the slide or slides you want to have a different theme.

2 For simple theme changes on selected slides, click Themes in the toolbar and choose 
a new theme. 

3 For additional options, choose File > Choose Theme. 

4 Choose Selected Slides from the Apply Theme To pop-up menu.

If you want to apply the new theme to all the slides, and not just to the selected 
slides, choose All Slides from the Apply Theme pop-up menu.

5 If you’ve modified theme defaults on individual slides, and you want to incorporate 
these overrides into the new theme, select “Retain changes to theme defaults.”

For example, if you change the background fill on a few slides, and you want to use 
the same fill in the new theme, select this option. If you don’t select this option, the 
slides will use the new theme’s background fill.

6 Click Choose.

Moving Around in Your Presentation
You can easily go to the first or last slide in your presentation or to the previous or 
next slide.

To jump quickly to a particular slide:
m Choose Slide > Go To > [option].

Step 4:  Save Your Slideshow
You should save your slideshow often. Keynote provides some special options for 
saving your slideshow, including saving a previous version and saving audio and 
movie files as part of the presentation. (For more information, see “Kinds of 
Slideshows” on page 35.)
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To save a Keynote file:
1 Choose File > Save.

2 Type a name for the slideshow and choose where you want to store it.

3 Click Save.

Keynote provides advanced saving options for special circumstances. To see these 
options, click the disclosure triangle (to the right of the filename) in the Save dialog.

Â When you add sound or movies to your slideshow, Keynote automatically saves 
them with the file. This is helpful if you plan to transfer the slideshow to another 
computer. If you don’t want to save the file this way, click Advanced Options, and 
then deselect “Copy audio and movies into document.” (This option is on by 
default.)

If you deselect this option, and then transfer the slideshow to another computer, 
you need to transfer the sound and movie files as well. Selecting this option makes 
the file larger, so you may want to include media files (using Save As) only when 
you’re ready to move the slideshow to another computer.

Â If the presentation will be opened on a computer that doesn’t have the theme 
installed, select “Copy theme images into document.” 

This option ensures that all theme components appear correctly even if the theme is 
missing. Selecting this option makes the document file larger.

As you make changes to your slideshow, you can save one previous version.

To save a copy of the previous version when you save a Keynote document:
1 Choose Keynote > Preferences and click General.

2 Select “Back up previous version.”

3 Choose File > Save.

With this preference selected, each time you save your document, the previously 
saved version of your document is renamed “Backup of <document name>” and is 
saved in the same folder as your document. This backup file does not include the 
changes made since the last time you saved; the document that includes the latest 
changes remains open. (Even if this option is selected, you won’t get a backup version 
the first time you save a document.)
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Step 5:  Play Your Slideshow
You can show your finished presentation on your computer’s display or project it onto 
a screen for a larger audience.

To play the presentation on your computer:
1 In the Finder, double-click the Keynote document icon.

2 Click Play in the toolbar (or choose View > Play Slideshow).

Note:  Clicking Play plays the slideshow starting with the currently selected slide. To 
play the slideshow from the beginning (if the first slide is not selected), hold down the 
Option key while you click Play.

3 Click to advance to the next slide.

4 To stop the slideshow, press Q or Esc.

Keynote provides many options for sharing your slideshow. You can: 

Â Play the slideshow on a large screen or secondary display

Â Save and share as a QuickTime or Flash movie, PDF file, or PowerPoint presentation

Â Print the presentation

For more details about viewing and sharing your slideshow, see Chapter 8, “Viewing, 
Printing, and Exporting Your Slideshow.”
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33 Working With Text, Graphics, 
and Other Media

By incorporating text, graphics, sound, and movies, 
you can create compelling presentations with 
Keynote.
It’s easy to add and modify text and the other elements you use in a presentation. This 
chapter describes in detail how to add various media to your presentations.

Editing Text and Text Properties
To add text to a text box or shape, simply click to select the text box or shape and 
start typing.

To enter and edit text in a text box:
1 Select the text box, or double-click the text, and start typing.

2 Adjust the text color, alignment, and font using the Text Inspector or Font panel, as 
described in “Formatting Bulleted Text and Numbered Lists” on page 46.

Adding Text Boxes
Various master slides provide text boxes, but you can add a “free text box” to a slide 
and move the box wherever you want it. Free text boxes are similar to the text boxes 
provided in various master slides. The main difference is that text in free text boxes 
does not appear in outline view.

To create a free text box:
1 Click Text in the toolbar (or choose Insert > Text).

2 In the text box that appears, double-click the text and type.

Note:  You can add bullets to paragraphs in free text boxes. To create formatted bullets 
(in which all text aligns and the bullet “hangs”), you use the Bullets pane of the Text 
Inspector. For details, see “Formatting Bulleted Text and Numbered Lists” on page 46.
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3 When you’ve finished typing, click outside the text box. Or, to stop editing text and 
select the text box, press Command-Return. 

4 Drag the handles on the text box to change its width.

Free text boxes automatically grow or shrink vertically to accommodate the length of 
your text. You cannot make them taller by dragging. To make a free text box taller 
without expanding its contents, drag the selection handles to make the box narrower 
(that is, force the box to grow vertically).

You can drag text boxes anywhere on a slide. For more information about modifying 
text boxes, see “Resizing, Moving, and Layering Objects” on page 62.

Note:  You can type text within a shape. See “Adding Text to Shapes” on page 59.

Formatting Bulleted Text and Numbered Lists
You can change the properties—including the font, color, or spacing of lines and 
words—of text at any time. For bulleted text, you can select from a range of bullet 
and numbering styles. You can even use an image of your own as a bullet. You make 
most text changes using the Text Inspector and Font panel.

Changing the Font
You can create engaging visual effects with text by changing its color, shadow, 
opacity, and orientation on the screen. To learn more about these options, see 
Chapter 4, “Changing Object Properties.”

To change the font:
1 Select the text you want to change and click Fonts in the toolbar (or choose Format > 

Font > Show Fonts). 

2 In the Font panel, select a collection, family, typeface, and size.

Using the Text Inspector
In the Text Inspector, you can adjust all basic text properties in your slides. Use it to 
change the color, alignment, and spacing of selected text. If you select bulleted text, 
you can change the bullet style.
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To open the Text Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector, and then click the 

Text Inspector button).

To change text color:
1 Select the text you want to change (or click in the text to place the insertion point).

2 In the Text Inspector, click the color well.

3 In the Colors window, select a color.

Changing Text Alignment and Spacing
You can align text within a text box left, right, center, or both right and left (called 
“justified”). You can also align text at the top, center, or bottom of the text box.

To adjust text alignment:
1 Select the text you want to change.

2 Click the horizontal or vertical alignment buttons at the top of the Text Inspector.

Note:  A text box with more text than can be displayed always aligns at the top. 
Vertical alignment has no effect on free text boxes.

Click the color well to 
change the color of 
selected text.

The Text Inspector button

Use these buttons to 
align text.

Drag the sliders to adjust 
character, line, and 
paragraph spacing for 
selected text.

Change the space 
between text and the 
text box, table cell, or 
shape that contains it.
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To adjust the spacing between lines of text within a paragraph or bullet:
1 Select the text you want to change (or select a text box).

2 In the Text Inspector, drag the Line slider to adjust the line spacing. 

Dragging the slider to the left brings the selected lines closer together; dragging it to 
the right moves them farther apart.

You can set precise point values for spacing between lines of text in a paragraph or 
use preset measurements, which you can choose from the Line pop-up menu.

To set precise values for spacing between the lines of text in a paragraph:
1 Select the text you want to change.

2 In the Text Inspector, type a value in the Line Spacing field.

3 Choose an option from the Line Spacing pop-up menu.

Â Single:  Standard space between lines of text.

Â Double:  Adds an extra line space between lines of text.

Use the vertical alignment 
buttons to align text at 
the top, center, or bottom 
of the text box.

Use the horizontal 
alignment buttons to 
align text on the left, 
center, right, or both left 
and right (justified).

Line pop-up 
menu:  Click the text 
below the Line field 
and choose a line 
spacing option.

Line field:  Type a value 
(or click the arrows) to 
specify the space 
between lines of text in 
a paragraph.



Chapter 3    Working With Text, Graphics, and Other Media 49

Â Multiple:  Sets line spacing values between single and double, or greater than 
double.

Â At Least:  The distance between lines is never less than the value you specify
and may be more, to prevent larger fonts from overlapping. Use this setting when 
the distance between lines should remain fixed, but you don’t want overlap if the 
text becomes large.

Â Between:  Increases the space between the lines, instead of increasing the height of 
the lines. In contrast, double-spacing doubles the height of each line.

To adjust the amount of space before or after a paragraph or bullet:
1 Select the text you want to change.

2 In the Text Inspector, drag the Before Paragraph or After Paragraph slider. Or, type a 
specific amount (5 points, for example) in the text box.

To adjust the amount of space between characters:
1 Select the text you want to change.

2 In the Text Inspector, drag the character spacing slider. 

Dragging the slider to the left brings the letters closer together; dragging it to the 
right moves them farther apart.

Setting Tabs and Text Indents 
All text boxes have default indents and tabs. You can see indent and tab markers on 
the horizontal ruler when you choose View > Show Rulers and select some text on a 
slide. You can drag these markers to change text indents and tabs.

To create a tab:
1 Click in the text you want to adjust.

2 Click the horizontal ruler and drag the tab where you want it.

Click the ruler to 
create a tab. Double-
click the tab icon to 
change its type.

These markers indicate 
the left alignment of a 
bullet, the first line of 
text, and subsequent 
lines of text.
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To change a tab to a different type:
m Control-click the tab icon and choose a tab type from the shortcut menu. Or double-

click the tab icon in the ruler repeatedly until the type of tab you want appears.

To insert a tab in bulleted text or table text:
m Press Option-Tab.

Adjusting Indents in Unbulleted Text
You can adjust the indents of unbulleted text by specifying where to put the left edge 
of the text, the amount of space between the left margin and the first line, and the 
amount of space from the right margin. 

To set the indents for unbulleted text:
1 Select the text whose indentation you want to adjust.

2 To set the left edge of the text, drag the left indent marker.

3 To set where to begin the first line of text, drag the rectangular icon (“First line 
indent,” shown above).

4 To set the right margin, drag the right indent marker.

Adjusting Indents in Bulleted Text
You can set indents for bulleted text using the Bullets pane of the Text Inspector.

To set the indents for bulleted text:
1 Select the text you want to adjust.

2 In the Text Inspector, click Bullets.

3 Type a number in the Bullet Indent or Text Indent field, or click the arrows.

Choose from among 
these tab types.

First line indent Right indent

Left indent
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Changing the Inset Margin
You can change the amount of space between text and its container (a text box, 
shape, or table cell). This measurement is called the “inset margin.” The amount you 
specify is applied equally around the text on all four sides.

Note:  You can’t adjust the inset margin for bulleted text.

To adjust the amount of space around text:
1 Select the text.

2 In the Text Inspector, drag the Inset Margin slider, type a number in the Inset Margin 
box (or click the arrows), and press Return.

Working With Bullets and Numbers
You can change text bullets to image bullets, use your own graphic for bullets, or 
choose not to use bullets for text. You can change bullets to numbers to create a 
numbered list.

Note:  You can use bulleted text in both body text boxes and free text boxes.

To change the symbol used for bullets:
1 Select the text whose bullet you want to change, or select a body text box to change 

all bullets.

2 In the Text Inspector, click Bullets.

Specify how much space 
there is around text.

Select the bullet type, 
style, color, position, 
and size.

Click to format bullets.
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3 Choose an option from the pop-up menu. For some options, you can adjust the size 
and vertical alignment using the fields on the right.

Â No Bullets:  Use this option to create plain text without bullets. 

Â Text Bullets:  Choose an option from the pop-up menu or type the character(s) you 
want to use in the text box. You can use any keyboard character. To change a text 
bullet’s color, click the color well and choose a color in the Colors window.

Â Image Bullets:  Choose from one of the images provided.

Â Custom Image:  Select one of your own image files or drag an image from the 
Finder or Media Browser to the image well. Use only small images as text bullets, or 
the images may not retain their clarity when they are reduced. 

Â Numbers:  Choose the number style (Arabic or Roman, for example) from the pop-
up menu.

Â Tiered Numbers:  Indented (sub) paragraphs are numbered decimal style (2.1, 2.2, 
and so on).

Important:  Selecting the “Scale with text” checkbox maintains the bullet-to-text ratio 
specified in the Size field, even if you change the font size.

To adjust the vertical alignment of a bullet (relative to its text):
1 Select the text you want to change. 

2 In the Bullets pane of the Text Inspector, type a number in the Align box, or click the 
arrows.

To adjust the size of a bullet:
m In the Bullets pane of the Text Inspector, type a number in the Size field or click the 

arrows.

The bullets in the selected text grow larger or smaller than the text size, depending 
on how you set the percentage. The percentage is proportional to the text size.

Presenting Text in Columns
Sometimes you may want to create two text columns on a slide (for example, to 
present two concepts side by side). You can create columns in a text box by using the 
Columns pane of the Text Inspector.

To split text into columns:
1 Select the text box you want to change.
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2 Click Columns in the Text Inspector.

3 In the Columns field, type the number of columns you want, or click the arrows.

Text you type in the first column flows into the second column when the first column 
is full.

To set up different column widths:
1 Deselect the “Equal column width” checkbox.

2 To change width, double-click a column value in the column measurements list and 
type a new value.

3 To change the space between columns, double-click a gutter value in the column 
measurements list and type a new value.

Working With Graphics
Keynote accepts all standard graphics file formats, including the following:

Â GIF

Â TIFF

Â JPEG

Â PDF

Â PICT

In addition, Keynote provides the tools to add basic shapes to your slides, such as 
triangles, rectangles, and arrows, as well as custom shapes you design.

Note:  Some images may be protected under copyright law. Make sure you have 
permission to use the images you want to include.

Type the number of 
columns you want, or 
click the arrows.

Column measurements 
appear here.
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Adding Shapes
You can draw shapes—such as lines, rectangles, rounded rectangles, ellipses, triangles, 
and arrows—directly in Keynote. You can draw custom shapes with curves you adjust.

Working with the shapes you create is the same as working with predrawn shapes. 
Your shapes can contain text. They can be resized and repositioned and can have the 
line style, color, shadow, opacity, and orientation you choose.

This section tells you how to create your own custom shapes and how to edit the 
contour of both predrawn and custom shapes.

Adding a Shape
You can add a shape by selecting a predrawn shape or by drawing the shape directly 
on the slide.

To add a shape:
1 Click Shapes in the toolbar (or choose Insert > [shape]).

2 Drag the selection handles to resize the shape.

You can draw shapes at the desired size on the slide canvas.

To draw a shape on the slide canvas:
1 Hold down the Option key while you click Shapes in the toolbar and choose a shape. 

2 Release the Option key and move the pointer over the slide canvas until it becomes a 
crosshair.

To size the shape from the center, continue holding down the Option key in this step 
and drag across the canvas.

3 Drag across the slide canvas to create the shape.

To constrain the shape (for example, to keep triangles equal on all sides), press the 
Shift key as you drag.

Adding a Custom Shape
You can create custom shapes with a variety of curves that you can adjust as needed.

To create a custom shape:
1 Click Shapes in the toolbar, and then select the draw tool icon (or choose Insert > 

Shape > “Draw a Shape”).
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The pointer changes from an arrow to a small pen tip.

2 Click the cursor anywhere in the slide to create the first point of the custom shape.

3 To create a second point and connect it with the first point using a straight line, click a 
second location. 

To create a curved segment instead of a straight one, click the second location and 
drag the mouse to change the curve angle or extend the curve. Release the mouse 
when you’re satisfied with the curve.

The line that connects the two points has the default stroke style for the theme you’re 
using. You can change the line into another kind of line later by using the Stroke 
settings in the Graphic Inspector.

4 Repeat step 3 to create additional points as required. Every time you add a new point, 
Keynote connects it with the preceding point using a line with the current stroke and 
with the first point using no stroke. The shape is filled with the default fill color for the 
theme you’re using, but you can change the fill later.

To delete a segment you’ve just created, press Delete. Pressing Delete again removes 
the preceding segment, too.

5 To stop drawing and close the shape (add a solid line between the last and first 
points), click the first point.

To stop drawing and leave the shape open (no line between the last and first points) 
so that you can work with it more later, press ESC or double-click the last point 
created. 

Your shape is an object that you can work with as you would with any other object.

To finish and close an open shape:
1 Click once in the shape to select it, and then click a second time to show its points.

2 Double-click one of the two points at either end of the open segment.

Draw tool icon
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3 To add additional points, click other locations as needed.

4 To stop drawing and close the shape, click the point at the end of the open segment.

Editing Predrawn and Custom Shapes 
You can change the contour of predrawn and custom shapes by manipulating the 
points in the shape.

To make a predrawn shape editable:
m Select the shape, and then choose Format > Shape > Make Editable.

To make a custom shape editable:
m Click once in the shape to select it, and then click a second time to show its points.

To move one or more points:
m When the shape is editable, click a point and drag it to another location. To move 

several points at the same time, hold down the Shift key as you click multiple points, 
and then drag the points.

To delete one or more points:
m When the shape is editable, click a point and then press the Delete key. You can delete 

several points at the same time by Shift-clicking multiple points and then pressing 
Delete.

To add a point:
1 When the shape is editable, press the Option key and let the mouse hover over the 

shape’s border. The cursor changes into a pen tip.

2 Click the location on the border where you want to add a point. 

Click a point and drag it 
to change the shape.
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3 Move the point as needed.

To reshape a curve:
1 Make the shape editable.

2 Click a point on the curve you want to reshape. A control handle appears on both 
sides of the point.

3 To expand or contract the curve, drag the point or one of the control handles.

4 To change the angle of the curve, move the control handles clockwise or counter-
clockwise. You achieve different effects when you move the handles together or 
independently of each other. Experiment until you achieve the effect you want.

Â To move the handles together, press the Option key and drag one or the other of 
them. 

Â To move only one handle, press the Command key before dragging a handle.

To reshape a straight segment:
1 Make the shape editable.

2 Click a corner point.

3 Drag the point clockwise or counter-clockwise to change the angle between the two 
attached segments.

Drag the point out or in to change the length of one of the segments.

To transform corner points into curved points and vice versa, do one of the 
following:
Â To change a corner point into a curved point, make the shape editable, and then 

double-click the corner point.

Â To change a curved point into a corner point, make the shape editable, and then 
double-click the curved point.

Drag a control handle or 
rotate one or both 
control handles to 
change the curve.

You can also drag a point 
to modify the curve.
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Â To change all corner points in one or more shapes into curved points, select the 
shape(s) and choose Format > Shape > Smooth Path. 

Â To change all curved points in one or more shapes into corner points, select the 
shape(s) and choose Format > Shape > Sharpen Path.

Editing Specific Predrawn Shapes
Some predrawn shapes have special built-in editing controls that you can use in 
addition to those described above.

To edit a rounded rectangle:
m Drag the circular control to the left to straighten the corners and to the right to 

“round” them.

To edit single and double arrows:
m Use the three special controls to increase or decrease the tail’s length and width 

without changing the shape of the arrowhead.

Drag to straighten or 
round the corner.

Drag to change the 
tail length.

Drag to change the size 
(width) of the arrowhead. 
The cursor is a four-
directional arrow that 
you can move up or 
down (affects tail width) 
or to the left and right 
(affects arrowhead size).
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To edit a star:
m When you select a star shape, a slider appears. Drag the slider to increase or decrease 

the number of points in the star. 

To edit a polygon:
m When you select a polygon, a slider appears. Drag the slider to increase or decrease 

the number of sides in the polygon.

Adding Text to Shapes
You can add text to any shape.

To add text to a shape:
m Double-click the shape and type your text.

You can format the text within a shape the same way you format any other text. If 
there is more text than can show in the shape, the clipping indicator (+) appears. You 
can display the rest of the text by resizing the shape.

Drag to change the 
angles between points 
in the star.

View the number of 
points currently in 
the star.

Drag to increase or 
decrease the number 
of points in the star.

Drag to increase or 
decrease the number of 
sides in the polygon.

View the number of 
sides currently in 
the polygon.
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Changing Line and Fill Colors
You can change the line colors and fill colors of drawn objects. For more information, 
see Chapter 4, “Changing Object Properties.”

Adding Pictures From iPhoto
You can drag images directly from the Media Browser (or your iPhoto library) to a 
slide.

To add an image from the Media Browser:
1 Click the Media button in the toolbar (or choose View > Show Media Browser).

2 Choose iPhoto from the pop-up menu and navigate to the album you want.

3 Drag a photo to the slide.

Images can be placed in table cells as well as directly on the slide. For instructions, see 
“Adding Images or Background Colors” on page 105.

Adding Other External Graphics
You can easily add graphics files created in other applications to your Keynote slides.

To add a graphics file from another source:
m Choose Insert > Choose and select the file (or drag the file from the Finder to your 

slide).

You can adjust the opacity and shadow of graphic objects, as well as make precise 
adjustments to their location and orientation on the slide. To learn more, see 
Chapter 4, “Changing Object Properties.”

The “+” means the shape 
contains more text than can be 
seen. To display the rest of the 
text, resize the object.
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Using PDF Files as Graphics
If you intend to greatly enlarge or reduce a graphic’s dimensions, consider converting 
it to a PDF file before bringing it into Keynote. PDF files don’t lose their crispness 
when they are significantly resized. Other file types may not retain their clarity as well 
when they are enlarged or reduced.

PDF files also provide a great way to move tabular data from Excel or AppleWorks 
documents into Keynote. If you have extensively formatted tables in these 
applications that you want to display in your slideshow, you can save the spreadsheet 
as a PDF file and then place that PDF file on a slide as you would any other external 
graphics file.

To convert an AppleWorks or Excel file to a PDF file:
1 Open the Excel or AppleWorks document you want to convert.

2 Choose File > Print.

3 Click PDF, and then choose “Save as PDF” from the pop-up menu.

4 In the Save dialog, type a name for the PDF file, choose a location, and then click Save.

You can include other kinds of objects, such as movies, charts, tables, hypertext links, 
and webpages. To learn more, see “Adding a Movie” on page 71 and “Adding 
Webpages and Hyperlinks” on page 73, as well as Chapter 5, “Creating Tables,” and 
Chapter 6, “Creating Charts.”

Note:  You can copy a range of cells in an Excel document and paste the cells and their 
contents directly on a slide. Keynote creates a new table to hold the Excel data. Or, use 
the Grab utility (Finder > Services > Grab) to create a TIFF image of a selection in an 
Excel or AppleWorks document.
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Resizing, Moving, and Layering Objects
After you move text and graphics to the slide canvas, the text and graphics objects 
work much the same way. They can be moved in front or in back of one another and 
formatted or manipulated in similar ways. You work with grouped objects the same 
way you do with single objects. For more information, see “Grouping and Locking 
Objects” on page 65.

To move an object:
m Click the object to select it (make the selection handles appear), and then drag it.

Avoid dragging the object by the selection handles so that you don’t inadvertently 
resize the object.

To resize an object:
1 Click the object to select it. 

If text is selected, you can select the text box, shape, or table cell by pressing 
Command-Return.

2 Move the pointer close to a selection handle until it changes to a double-headed 
arrow.

3 Drag the selection handle to expand or shrink the object. 

Â To resize the object from its center, press the Option key as you drag. 

Â To constrain the object’s proportions as it expands or shrinks, press the Shift key as 
you drag.

To move an object in front or in back of another object on the slide canvas:
1 Select the object you want to move.

2 Choose Arrange > Bring Forward or Send Backward.

3 Repeat step 2 until the object is in the desired position.

4 To move an object to the top or bottom of the layered objects, choose Arrange > 
“Bring to Front” or “Send to Back.”

Move an object to 
the top layer.

Move an object to 
the bottom layer.
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To rotate an object:
1 Select the object.

2 Hold down the Command key and move the pointer toward a selection handle until it 
changes to a curved, double-headed arrow.

3 Drag the selection handle to rotate the object. Or, use the Rotate wheel or Angle field 
in the Metrics Inspector.

Masking (Cropping) Images
You can crop images without actually changing the image files by masking parts of 
them. The mask contains a window that defines the boundaries of the cropped image. 
This allows you to import full images but display only part of them within the 
document. You can still reposition and resize images that have been masked.

The default mask is a rectangle, which you can resize as required. You can crop an 
image using the default mask or use a shape as a mask.

To mask an image using the default (rectangular) mask:
1 Insert the graphic you want to mask. 

2 Select the object and choose Format > Mask. A mask appears over the image.

3 Drag the window to center it over the part of the image you want to feature. Drag the 
selection handles to resize the mask.

Â To constrain the window’s proportions, hold down the Shift key as you drag the 
selection handles.



64 Chapter 3    Working With Text, Graphics, and Other Media

Â To rotate the window, hold down the Command key as you drag the selection 
handles.

4 Double-click the window to make only the masked area visible. The masked image 
has a dotted line around its visible borders.

5 Drag the selection handles to resize or Command-drag to rotate the visible portion of 
the image, or drag the entire image to reposition it on the page. 

Drag the selection handles 
to resize the visible portion 
of the image.

Drag the selection 
handles to resize or 
rotate the visible portion 
of the image.
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Note:  If you often mask objects, you can add the Mask button to the toolbar by 
choosing View > Customize Toolbar. The Mask button switches to Unmask when you 
select a masked image.

To unmask an image (so that the whole image reappears):
m Select the image and choose Format > Unmask.

To crop an image using a predrawn or custom shape as a mask: 
1 Insert the image you want to mask.

2 Add a shape to the slide to use for the mask. 

3 Select both the image and the shape.

4 Choose Format > Mask With Shape. 

5 Drag the shape to center it over the part of the image you want to feature. Drag its 
selection handles to resize it.

6 Edit the mask as desired.

You can resize, rotate, and move the mask, and you can edit the contour of the mask 
after double-clicking the edge of the shape. For details, see “Editing Predrawn and 
Custom Shapes” on page 56.

7 Double-click the window to make the masked area invisible. 

To change the portion of a masked image that’s visible:
1 Double-click the masked image.

2 Click the dotted border of the resizable window to select it.

3 Drag the selection handles to resize or Command-drag to rotate the visible portion of 
the image, or drag the window to feature a different part of the image.

Grouping and Locking Objects
You can group objects together so that they can be moved, copied, resized, and 
oriented as a single object. You can edit text associated with a shape or text object in 
a group, but you can’t modify other attributes of individual objects in the group.

Lock objects to the canvas to avoid inadvertently moving them as you work.

To group objects:
1 Hold down the Command (or Shift) key as you select the objects you want to group 

on the slide canvas.
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2 Click Group in the toolbar (or choose Arrange > Group).

Note:  Locked objects can’t be grouped.

To ungroup a grouped object:
m Select the object and click Ungroup in the toolbar (or choose Arrange > Ungroup).

Note:  If you group an object that has a build effect assigned to it, the effect is 
removed. Ungrouping a grouped object with a build assigned to it removes the build 
effect.

To lock objects to the slide canvas:
1 Hold down the Command (or Shift) key as you select the objects you want to lock to 

the slide canvas.

2 Choose Arrange > Lock.

After you lock individual or grouped objects, you can’t edit them until you unlock 
them.

To unlock an object:
m Select the object and choose Arrange > Unlock.

Note:  If you often lock or unlock objects, you can add Lock and Unlock buttons to the 
toolbar by choosing View > Customize Toolbar.

Working With Photo Cutouts (Alpha-Channel Graphics)
Keynote themes provide photo “cutouts” in which you can place your own images. 
The result can look, for example, as if your image is in a picture frame. This effect is 
created by using a graphic (the picture frame part) that contains a transparent area 
where your image shows through. The transparent area is created using an alpha 
channel (a way of defining transparency); an alpha-channel graphic is an image that 
contains a transparent area.

Use alpha-channel graphics to create transparency around an irregularly shaped 
image, such as a tree, so that the image doesn’t have a rectangular white area 
around it. 
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To place an image behind a photo cutout window in a Keynote theme:
1 Drag your image from the Media Browser or the Finder to a cutout window on the 

slide canvas.

2 To resize the image within the cutout, drag one of the selection handles.

3 Drag the image to adjust its position in the window.

Importing Alpha-Channel Graphics Into Keynote
When you bring an alpha-channel image into Keynote, there’s nothing else you have 
to do to make the transparency work. Just place the image, manipulate it, and move it 
to the back or front as you would any other image.

Many PDF, TIFF, and PSD files contain alpha-channel graphics. You can use various 
applications to create alpha-channel images, including Adobe Photoshop, Corel Draw, 
Adobe Illustrator, and Adobe Acrobat. See the instructions that come with the 
application to learn how to create alpha-channel images. To learn how to create your 
own frame in Keynote with an imported alpha-channel graphic, see “Layering 
Background Objects and Objects on Slides” on page 175.

Your photograph is placed 
behind the alpha-channel 
graphic and can be seen 
through its transparent 
region, so it appears that 
the photo is in the 
photo-corner frame.

This textured foreground 
with photo corners and 
a white border is an 
alpha-channel graphic. 
The area between the 
photo corners is a 
transparent alpha 
channel.
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Including Sound and Other Media
You can add sound files to your project so that, for example, recorded music plays 
throughout your slideshow or a narration accompanies each slide. You can also add 
video or Flash movies that play within a slide.

Note:  Some media files are protected under copyright law. Also, some downloaded 
music may be played only on the computer where the download occurred. Make sure 
you have permission to use the files you want to include.

Keynote accepts any QuickTime file type, including the following:

Â MOV

Â FLASH

Â MP3

Â MP4

Â AIFF

Â AAC

Â MPEG-4 

Important:  When you add a media file to a slideshow, the file automatically becomes 
part of the Keynote document. Media files make your document much larger. You can 
save the document without media files by following these steps.

To save a document without media files:
1 Choose File > Save As, and then click Advanced Options.

2 Deselect “Copy audio and movies into document.”

3 Type a name and choose a location for the document, then click Save.

Using the Media Browser
The Media Browser lists all the media files in your iPhoto and iTunes libraries and in 
your Movies folder. You can drag images, music, and movies directly from the Media 
Browser to a slide or to an image well in one of the inspectors.
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To open the Media Browser:
m Click Media in the toolbar (or choose View > Show Media Browser).

To add an image from iPhoto:
1 Click Media in the toolbar (or choose View > Show Media Browser).

2 Choose iPhoto from the Media Browser pop-up menu and select the album you want.

3 Drag an image file directly to the Keynote document window. 

You can resize the image and move it backward or forward just as you would with 
other objects.

You can also drag an iPhoto file to an image well in the Graphic Inspector or Text 
Inspector to use it as an image fill or a custom bullet image (see “Using Color and 
Image Fills” on page 80 for more information).

Choose iTunes, iPhoto, 
or Movies.

Drag an audio file to a 
slide or to the Audio 
well in the Document 
Inspector.

Search for a file by name.

Select a playlist.
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To add sound to a slide, do one of the following:
Â Click Media in the toolbar, choose iTunes from the pop-up menu, select a playlist, 

and drag a file to the slide canvas.

Â Drag a sound file from the Finder to the slide canvas.

You can more finely control when music starts and stops by moving it on or off the 
screen in an object build. To learn more about producing object builds, see “Creating 
Object Builds” on page 145.

Adding Narration and Other Audio
You can add music—a file or playlist from your iTunes music library, or any other 
sound file—to a Keynote document. You can add sound as a soundtrack for the entire 
slideshow, or you can add sound to a single slide. 

If you add a soundtrack, the music starts playing when the slideshow starts. You can 
specify whether to play the audio once or repeatedly (or you can turn it off ). 

If you add a sound file to an individual slide, the sound plays when the slide appears 
and stops when you move to the next slide. You could, for example, record narration 
for each slide as an MP3 file; this technique is especially useful if you plan to export 
the slideshow as a self-playing QuickTime movie. (For more information, see 
“PowerPoint” on page 167.)

Note:  To make sure that the audio plays on other computers, “Copy audio and movies 
into document” must be selected in the expanded Save dialog. This option is on by 
default. 
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To add a soundtrack:
1 Open the Document Inspector.

2 In the Audio area, click iTunes Library.

3 Drag an audio file or playlist from the Media Browser to the Audio well in the 
Document Inspector.

Note:  You can also drag a sound file from the Finder.

4 To repeat the sound file as long as the presentation is playing, choose Loop from the 
pop-up menu in the Document Inspector.

Adding a Movie
You can include movies in your slide presentation. After you add a movie to a slide, 
you can resize and position the movie as you would any other object.

To add a movie to a slide, do one of the following:
Â Click Media in the toolbar, choose Movies from the pop-up menu, and drag a file to 

the slide canvas. (For movies to appear in the Media Browser, they must be in the 
Movies folder in the Finder.)

Â Choose Insert > Choose, select the file, and click Insert.

Â Drag a movie file from the Finder to the slide canvas.

The Document Inspector 
button

Preview your audio file.

Drag a sound file here to 
play it throughout the 
slideshow.
To repeat the sound file, 
choose Loop.

Set the volume for the 
soundtrack.
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Note:  To ensure that the audio plays on other computers, “Copy audio and movies 
into document” must be selected in the expanded Save dialog. This option is on by 
default. 

When your slideshow plays, the movie starts the moment the slide appears. A movie 
control panel appears on the presenter display, but its controls vary depending on the 
size of your movie. For details, see “Viewing Movies” on page 159.

Adjusting Media Playback Settings
In the QuickTime Inspector, you can set the playback volume for sound and movies in 
your slideshow, and specify whether to play media files once, continuously, or forward 
and backward (Loop Back and Forth).

To set media playback preferences:
1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

QuickTime Inspector button.

2 Click the movie to select it, then drag the Volume slider.

3 Choose an option from the Repeat pop-up menu.

You can also specify which frame of the movie to display on the slide (called the 
“poster frame”) until the movie starts playing.

Set playback repeat 
options.
Set the playback volume.

Select the frame to 
display until the 
movie starts playing.

The QuickTime
Inspector button

Use these controls to 
view the movie as you 
edit your slideshow.
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To set the movie poster frame:
1 Click the movie to select it.

2 In the QuickTime Inspector, drag the Poster Frame slider until the movie displays the 
image you want.

Adding Webpages and Hyperlinks
You can display a snapshot of a webpage (called a “web view”) on a slide. When the 
document is opened or the slideshow starts, Keynote can automatically update the 
snapshot with the current webpage. (The computer running the slideshow must be 
connected to the Internet.) By default, the snapshot is a hyperlink you can click during 
a presentation to open the webpage in a browser; you can turn off the link in the 
Hyperlink Inspector.

To add a webpage snapshot to a slide:
1 Choose Insert > Web View.

2 In the Hyperlink Inspector, type the page’s URL (www.apple.com, for example).

The homepage specified in your default browser is inserted as placeholder text.

3 To automatically update the webpage periodically, select “Update automatically.”

The blue arrow means 
that, during a 
slideshow, you can click 
the web view to open 
the webpage in a 
browser.

Insert a snapshot of a 
webpage that updates 
automatically when 
the slideshow plays.
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If you don’t select “Update automatically,” you can update the webpage at any time by 
clicking Update Now.

The webpage image is imported at full size, but you can resize and reposition it the 
same way you would with any other object. (The webpage image stays at the same 
resolution, but you can resize the web view to display less of the image.)

The webpage image is automatically a hyperlink, which you can click during a 
presentation to open the webpage in a browser. To turn off this feature, deselect 
“Enable as a hyperlink.”

You can create a web view by dragging a URL from a browser to the slide canvas. 

Text, images, and shapes can also be turned into hyperlinks. By clicking a hyperlink 
during a presentation, you can do any of the following:

Â Go to a particular slide

Â Open a webpage on the Internet

Â Open another Keynote document

Â Open an email message

Â Exit the slideshow

When this option is 
selected, you can click 
the web view during a 
presentation to open the 
webpage in a browser.
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To add a hyperlink:
1 Select the text, shape, image, or movie you want to turn into a hyperlink.

2 In the Hyperlink Inspector, select “Enable as a hyperlink” and choose an option from 
the Link To pop-up menu.

3 Enter the required information.

Turn text or images into 
hyperlinks that open 
another slide, a Keynote 
document, a webpage, or 
an email message. The blue 
arrow (visible only in edit 
mode) means the item is a 
clickable hyperlink.

Use this type of hyperlink To perform this action Notes

Slide Go to another slide in the 
presentation

Choose whether to display the 
next, previous, first, or last 
slide; the last slide viewed; or a 
specific slide number.

Webpage Open the webpage in a 
browser (Safari, for example)

Keynote opens your default 
browser (specified in Safari 
preferences).

Keynote File Open another Keynote 
document

If you transfer the presentation 
to another computer, 
remember to transfer the 
other document as well.

For text hyperlinks, if you 
want the slide to display 
text other than the URL, 
select the text first.
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Drag a URL from a browser to an object on the slide canvas to create a web view 
hyperlink. By default, any text you type or drag that begins with “www,” “ftp,” or “http” 
automatically becomes a hyperlink as well. 

To turn off automatic detection of URLs:
1 Choose Keynote > Preferences and click General.

2 In the Hyperlinks section, deselect “Automatically detect email and web addresses.”

By default, all new text hyperlinks are underlined automatically. If you turn off this 
setting, you can add an underline to existing text if you decide to enable it as a 
hyperlink later.

To turn automatic underlining of new text hyperlinks on or off:
1 Choose Keynote > Preferences and click General.

2 In the Hyperlinks section, select or deselect “Underline text hyperlinks on creation.”

To underline an existing text hyperlink:
1 Select the text you want to underline.

2 Click Fonts in the toolbar and choose Single from the Underline pop-up menu (or 
choose Format > Font > Underline).

To make a hyperlinks-only presentation, choose “Hyperlinks only” from the 
Presentation pop-up menu in the Document Inspector. For more information, see 
“Hyperlinks-Only Presentations” on page 155.

Email Message Open a new mail message 
with the specified subject and 
addressee

Keynote opens your default 
mail application.

Exit Slideshow Stop the slideshow Keynote opens in edit mode 
to the last slide shown.

Use this type of hyperlink To perform this action Notes
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During a presentation, the pointer appears only on slides with hyperlinks. You can 
change this default so that the pointer appears whenever the mouse moves.

To specify when the pointer appears during a presentation:
1 Choose Keynote > Preferences.

2 Click Slideshow.

3 Choose one of the “Show pointer” options.

Modifying Layouts
Certain slide elements—such as a body text box and object placeholders—are 
preformatted and located in specific places on each master slide. You can easily add 
these elements to individual slides. 

To change a slide’s layout:
1 Select the slide whose layout you want to change.

2 Choose View > Show Inspector and click the Slide Inspector button.

3 Click Appearance.

4 Select the elements you want to add.

Note:  If you delete one of these items from a slide, the checkbox in the Slide 
Inspector is automatically deselected.

To make new charts, 
tables, and images 
appear in a specific place 
on slides, select Object 
Placeholder. 

The Slide Inspector button

Select items to add 
them to a slide.
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If none of the available master slide layouts meets your needs, you can create your 
own master slide with whatever elements you want on it, and then create a new slide 
based on that master. If you are going to create a number of slides that include a 
graphic, you can add a “placeholder” box to contain it. You can also add a slide 
number. 

To learn how to design your own master slide layouts, see Chapter 9, “Designing Your 
Own Master Slides and Themes.”

Changing the Slide Background
You can use your own image as the background of any individual slide or change the 
slide’s background color. Make these changes in the Slide Inspector.

To change the slide background:
1 Click Inspector in the toolbar (or choose View > Show Inspector) to open the 

Inspector window, and then click the Slide Inspector button.

2 Click Appearance.

3 Choose a slide layout from the master slides pop-up menu.

4 Choose a background type from the Background pop-up menu.

Choose a background 
color or image.

Choose a slide layout 
from among the 
master slides.

Drag an image here 
from the Media Browser 
or the Finder.
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Â Color Fill:  Gives the background a single, solid color. Click the color well and choose 
a color in the Colors window.

Â Gradient Fill:  Colors the background with a color gradient. Click each color well and 
choose colors in the Colors window.

Â Image Fill:  Uses your own image as a background. Click Choose and select an 
image. 

Â Tinted Image Fill:  Uses your own image with a semi-opaque color tint over it. Click 
Choose and select an image.

5 If you chose either of the image fills, choose a scaling option from the pop-up menu 
(see “Filling an Object With an Image” on page 83).

To read more about working with image fills, color fills, and gradient fills, see “Using 
Color and Image Fills” on page 80.

Retaining or Undoing Your Style Changes
If you make style and formatting changes on a slide and then decide that you want to 
return to the theme’s default styles, you can reset the slide to the default styles.

To reset a slide to the default styles for the theme:
m Select the slide and choose Format > Reapply Master to Slide.

You can reset multiple slides at once by selecting them in the slide organizer.

If you make style and formatting changes throughout a Keynote document and then 
change the entire document to another theme, you can reset all styles to the theme 
defaults or keep the overrides you made. (For example, if you change the background 
fill on a few slides, you can keep the same fill in the new theme or use the new 
theme’s background fill.)

To retain style overrides when applying a new theme:
1 Click Themes in the toolbar and choose Theme Chooser (or choose File > Choose 

Theme).

2 Select a new theme.

3 Select “Retain changes to theme defaults.”

4 Click Choose.
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4 Changing Object Properties

This chapter describes more advanced features 
for enhancing graphics and other objects in your 
presentation.
You can directly manipulate object properties such as color, line style and thickness, 
shadow, opacity, and orientation using the inspectors and the Colors window. You can 
adjust the brightness, color, and other properties of images. You can also draw custom 
shapes and modify both predrawn and custom shapes. This chapter tells you how.

Using Color and Image Fills
You can create interesting effects with color in Keynote. A shape can be filled with 
solid color, color gradients, or even with an image, such as a photo or other graphic. 

You can also adjust an object’s opacity (transparency). You can even use fill and 
opacity effects to modify individual bars or pie wedges in charts.

Selecting Colors
You use the Colors window to select color for text, shapes, backgrounds, and shadows 
in Keynote.

To open the Colors window:
Â Click Colors in the toolbar (or choose View > Show Colors).

Â Click a color well in one of the inspectors.
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You can use the color wheel in the Colors window to select colors. Your color selection 
appears in the well at the top of the Colors window. You can save that color for future 
use by placing it in the color palette.

To open the color palette:
m Drag the handle at the bottom of the Colors window.

To save a color in the color palette:
m Drag a color from the color well to the color palette.

To apply a color in the Colors window to an object on the slide canvas, you must place 
the color in the appropriate color well of an inspector pane.

To remove a color from the color palette:
m Drag a blank square to the color you want to remove.

The color selected in the 
color wheel appears in 
this color well.

Use the slider to show 
lighter or darker hues 
in the color wheel.

Drag colors from the 
color well to store them 
in the color palette.

Click to select a color 
in the color wheel.

Drag the handle 
to open the color 
palette.
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To apply a color to an object on the slide canvas, do one of the following:
Â Select a color well in one of the inspectors, and then click a color in the color wheel.

Â Drag a color from the color palette or color box to a color well in one of the 
inspectors.

Â Drag a color from the color palette to an object on the slide.

Filling an Object with Color
Objects can be filled with a solid color or a color gradient, in which two colors 
gradually blend with each other. To change the color of an object, you use the 
Graphic Inspector. 

To open the Graphic Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Graphic Inspector button.

Using Colors and Gradients
Objects can be filled with a solid color or a color gradient, in which two colors 
gradually blend with each other.

Fill a drawn object with 
a solid color, a color 
gradient, an image, or 
a tinted image.

The Graphic 
Inspector button
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To set the solid fill color of an object:
1 On the slide canvas, select the object whose color you want to change.

2 In the Graphic Inspector, choose Color Fill from the Fill pop-up menu.

3 Click the color well below the Fill pop-up menu to open the Colors window.

4 Select a color in the Colors window.

To fill an object with a color gradient:
1 On the slide canvas, select the object whose color you want to change.

2 In the Graphic Inspector, choose Gradient Fill from the Fill pop-up menu.

3 Click each color well and choose a color in the Colors window to set the gradient.

4 To invert the gradient, click the double-headed arrow.

5 To change the direction of the gradient, use the Angle wheel and arrows.

Filling an Object With an Image
You can place an image inside a drawn shape or inside a table cell.

To fill an object with an image:
1 Select the object in which you want to place an image.

2 In the Graphic Inspector, choose Image Fill or Tinted Image Fill from the Fill pop-up 
menu, and select an image.

3 To change the image, click Choose, select the image, and click Open (or drag the 
image file from the Media Browser or Finder to the image well in the Graphic 
Inspector).

Set the direction of the 
gradient with the Angle 
wheel, or type in a value.

Click the double-headed 
arrow to invert the 
gradient.

Click each color well to 
make color selections.
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4 Choose a scaling option from the pop-up menu.

Â Scale to Fit:  Resizes the image to fit the object’s dimensions as well as possible. If 
the object’s shape is different from that of the original image, parts of the image 
may not appear; blank space may also appear around the image.

Â Scale to Fill:  Makes the image appear larger or smaller, sizing it to leave no space 
around the image, even if the object and image have different shapes.

Â Stretch:  Sizes the image to fit the object’s dimensions, but distorts it if the object 
has a shape different from the original image.

Â Original Size:  Places the image inside the object without altering its original 
dimensions. If the image is larger than the object, you see only a part of the image 
in the object. If the image is smaller than the object, there is blank space around it.

Â Tile:  Repeats the image inside the object, if the image is smaller than the object. If 
the image is larger than the object, you see only part of the image inside the object.

Use the pop-up menu to 
set a scaling option for 
the image within the 
object.

To change the image, drag 
a file from the Media 
Browser or the Finder into 
the image well.

Original Size

StretchScale to Fit

Tile (large image)

Scale to Fill
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Changing Border Style and Color
For drawn objects (shapes), chart elements, and table cells, you can choose a style and 
color for the object’s border, or you can specify no border. You can also put a border 
around imported images. You set border line style and color using the Graphic 
Inspector and the Colors window.

To set the line style and color of an object’s border:
1 Select the object that you want to modify.

2 In the Graphic Inspector, choose a line style (or None) from the Stroke pop-up menu.

3 To change the line thickness, type a value in the Stroke size field (or click the arrows).

4 To change the line color, click the color well and select a color.

5 To give a line endpoints, such as arrowheads or circles, choose left and right 
endpoints from the pop-up menus.

Note:  Keynote also provides shapes in the form of arrows and double-headed arrows. 
You can add one using the Insert menu or the Shapes button in the toolbar.

Tile (small image)

Tile (large image)

Choose line 
endpoints from these 
pop-up menus.

Click the color well to 
choose a line color.

Enter the line thickness 
in this field. (Note: “px” 
means pixels.)

Choose a solid line, dotted 
line, dashed line, or no line.
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Positioning Lines
You can set the precise position of a line using the Metrics Inspector.

To set the precise position of a line:
1 Select the line.

2 In the Metrics Inspector, enter the X and Y coordinates to specify where you want the 
line to start and end.

Adding Shadows
Shadows give your page an appearance of depth. An object’s shadow appears on any 
object behind it. You can create a variety of shadow effects, or remove the shadow 
from an object.

To create or remove a shadow for an object:
1 Select the object you want to modify.

2 In the Graphic Inspector, select the Shadow checkbox to add a shadow to the object. 
Deselect the Shadow checkbox to make the shadow go away.

3 Set the angle for the shadow using the Angle wheel.

Change the shadow color 
in the color well.

Select the checkbox to 
add a shadow to a 
selected object.

Change the angle of the 
shadow with the Angle 
wheel.

Offset, Blur, and Opacity 
values can change the 
look of the shadow.
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4 Adjust the shadow offset by typing a number in the Offset box. 

A high shadow offset value makes an object’s shadow appear longer and slightly 
separated from the object.

5 Set the shadow blur by typing a number in the Blur box. 

A high blur value makes the object’s shadow appear more diffuse; a low value gives 
the shadow more sharply defined edges.

6 Set the shadow opacity by typing a number in the Opacity field. (Shadow opacity is 
separate from object opacity, which is set using the Opacity slider at the bottom of 
the Graphic Inspector.)

7 To change the color for the shadow, click the color well and select a color.

This object has the default 
shadow properties.

This object’s shadow is set to 
a different angle.

This object’s shadow has 
a high offset value.

This object’s shadow has 
the lowest blur factor.

This object has a different 
shadow color.

This object’s shadow has a 
high blur factor.
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Adjusting Opacity
You can create interesting effects by making objects more opaque or less opaque. 
When you put a low-opacity object on top of another object, for example, the bottom 
object shows through the top object. Depending on how high or low you set the 
opacity, the objects beneath can be highly visible, partly obscured, or completely 
blocked from view (at 100-percent opacity). You can change opacity settings for any 
visual object on the slide canvas, including drawn shapes, pictures and other image 
files, and movies. Set object opacity using the Graphic Inspector.

To change an object’s opacity:
1 Select the object.

2 In the Graphic Inspector, drag the Opacity slider.

Note:  For drawn shapes, you can set fill-color opacity separately from object opacity. If 
you move the Opacity slider in the Colors window to modify a fill color, the opacity 
value becomes equivalent to 100-percent object opacity. Then, when you change the 
object opacity in the Graphic Inspector, you are changing it relative to the opacity you 
set in the Colors window.

The fill color was set to 50% 
opacity in the Colors window. 
The circle’s outline was set to 
100% opacity in the Colors 
window.

This circle is set to 100% 
opacity.

This circle is set to 
50% opacity.
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Adjusting Images
For images, including those you use to fill a shape, you can change the brightness, 
contrast, and other settings to improve the quality of an image or to create interesting 
effects. Adjustments you make don’t affect the original image; they affect only the 
image’s appearance in Keynote.

To adjust an image:
1 Select the image.

2 Click the Adjust button in the toolbar (or choose View > Show Adjust Image) to open 
the Adjust Image window.

3 Use the controls to make the following adjustments.

Â Brightness:  Makes the overall image lighter or darker.

Adjust the lightness.

Adjust the contrast of 
light and dark tones.

Change the color intensity.

Introduce more warmth or coolness.

Change the amount 
of red or green tones.
Sharpen or soften the focus.

Adjust shadows 
and highlights.
Observe the relationship 
between shadows and 
highlights.

Change the levels of 
dark and light tones.

Restore original settings.

Enhance colors automatically.
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Â Contrast:  Makes different parts of the image stand out. You can make shadows 
darker, sharpen the edges of objects, and make colors stand out more. If you 
increase the contrast for a photo a lot, it looks more like an illustration.

Â Saturation:  Adjusts color vibrancy by deepening or lightening colors.

Â Temperature:  Acts as a kind of “white balance” corrector. You can introduce more 
warmth (more orange tones) or coolness (more blue tones).

Â Tint:  Changes the amount of red or green tones in the image.

Â Sharpness:  Sharpens or softens the image’s focus.

Â Exposure:  Lightens an underexposed image or increases the details of an 
overexposed image.

Â Levels:  Shows the relationship between shadows (depicted on the left side of the 
display) and highlights (depicted on the right side) in your image. Use the sliders to 
change the tonal range by changing the amount of black (left slider) or white (right 
slider) in the image.

Â Auto levels:  Click the Auto Levels button to have Keynote enhance colors 
automatically.

4 To restore the original settings, click Reset Image.

5 To save any changes you made, save the document.

The settings you make are preserved (sliders remain at their altered positions).

Changing an Object’s Orientation
You can flip or rotate any object by using the Metrics Inspector. For instance, if you 
have an image of an arrow that you want to use in your slideshow, but you need it to 
point in a different direction, you can reverse its direction vertically or horizontally, or 
point it at any angle.

To open the Metrics Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Metrics Inspector button.
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To flip or rotate an object:
1 Select the object you want to rotate.

2 In the Metrics Inspector, use the Rotate wheel to set the orientation of the object, or 
click the horizontal or vertical Flip buttons to flip the object horizontally or vertically. 
You can also specify the angle by typing a number in the Angle field.

Note:  You can add Flip Vertically and Flip Horizontally buttons to the toolbar by 
choosing View > Customize Toolbar.

Flip an image sideways 
or upside down using 
these buttons.

Rotate an object with 
this wheel.

Resize objects to 
exact dimensions by 
specifying height 
and width.

Click to return a resized 
object to its original size.

Place an object precisely 
on the canvas by 
specifying X and Y 
coordinates.

The name of the selected 
image or movie appears 
here.
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Changing an Object’s Size and Position
In addition to dragging objects and their selection handles, you can use the Metrics 
Inspector to make precise adjustments to the size and position of objects on the 
canvas.

To set the precise size of an object:
1 Select the object you want to resize.

2 In the Metrics Inspector, type a number in the Width and Height fields (or click the 
arrows to increase or decrease the number).

To maintain the width/height ratio when you resize an object:
m Select “Constrain proportions,” or hold down the Shift key as you drag a selection 

handle.

To return an object to its original size:
m Select the object and click Original Size in the Metrics Inspector.

To set the precise position of an object:
1 Select the object you want to position.

2 In the Metrics Inspector, enter X and Y values in the Position fields.

The specified coordinates determine the position of the object’s upper-left corner.

Â The X value is measured from the left edge of the slide canvas.

Â The Y value is measured from the top edge of the slide canvas.

The X and Y coordinates specify the location of the upper-left corner of the object’s 
container box. If an object is rotated, the X and Y coordinates specify the location of 
the “new” upper-left corner. 

Select to maintain the 
aspect ratio when you 
resize the object.
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55 Creating Tables

Use tables to organize and sort information, create 
interesting layouts, and perform calculations on 
numeric data. This chapter covers basic table design 
and use.
Keynote provides powerful features for making attractive, compelling tables that can 
contain text or graphics. You can also use a table to present numeric data, complete 
with formulas and number formatting. 

Adding a Table
Add a table when you want to organize information or compare sets of data. When 
the table is complete, you can create interesting slide animations in which table 
elements appear cell by cell, row by row, or column by column.

To place a table on a slide:
1 Click Table in the toolbar (or choose Insert > Table). 

Keynote places a table on the slide, and the Table Inspector opens.

2 To resize the table, drag a selection handle. 

3 To reposition the table, drag it to where you want it.
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You can also draw a table on the slide canvas.

To draw a table on the slide canvas:
1 Hold down the Option key and click Table in the toolbar. 

2 Release the Option key, and then move the pointer over the slide canvas until it 
becomes a crosshair.

3 Drag across the slide canvas to create a table any size you want.

To size the table from the center, continue to hold down the Option key while 
dragging the crosshair pointer across the canvas.

As you drag, the number of rows and columns increases or decreases with the size of 
the table. To constrain the table’s proportions, hold down the Shift key as you drag.

To open the Table Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Table Inspector button. Use the Table pane for general table formatting. Use the 
Numbers pane when you want to use formulas (see “Using Formulas” on page 110) or 
formatted numbers (see “Formatting Numbers” on page 106).
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Working With Table Cells and Borders
You enter text in a table cell by selecting the cell and typing in it. You put graphics in 
tables by using a background fill in individual cells, the same way you fill an object 
with an image. (For information about adding graphics or setting background colors 
inside table cells, see “Adding Images or Background Colors” on page 105.) You can 
also apply formulas to table cells that contain numbers or Boolean values (TRUE or 
FALSE).

You can apply changes to an entire table at once (by selecting it) or to individual cells. 
To format text or graphics inside table cells or groups of cells, you select only the cells 
you want to work with.

Select to add a specially 
formatted header row or 
column.

The Table Inspector button

Select to make rows resize to 
accommodate content.

Type the number of table 
rows and columns.

Add or delete rows or 
columns, merge cells, split 
rows, or split columns.

Specify column width 
and row height.

Select table columns, 
rows, and borders.
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Use the steps described here to select cells and to move from cell to cell. You can also 
use the selection buttons in the Table Inspector. To read about the Table Inspector, see 
“Formatting Tables” on page 98. To learn about selecting cells when using formulas, 
see “Using Formulas” on page 110.

To select the entire table, do one of the following:
Â Click the table.

Â If a table cell is already selected, press Command-Return to select the entire table.

Selection handles appear on the edges of the table. Drag the handles to resize the 
table.

Selecting Table Cells
When a single cell is selected, you can move between cells by pressing the arrow keys 
on your keyboard. If you type text after doing so, you replace any text that is already 
in the cell. You can also use the Tab key to navigate through cells.

To select a single table cell, do one of the following:
Â If the table or a cell in it is selected, click once in the cell. 

Â If the table or a cell in it isn’t selected, double-click in the cell.

The border of the selected cell is highlighted in yellow. You can enter text in the cell 
by typing. Any text in the cell is replaced.

Â To select the cell itself, Command-click the cell or press Command-Return.

To navigate using the Tab key, do one of the following:
Â Press Tab to move to the right and downward.

Â Press Shift-Tab to move the selection to the left or upward.

If you press the Tab key when the bottom-right cell of the table is selected, a new row 
is added to the table.

To select a contiguous (rectangular) group of table cells:
m Select the table, double-click a single cell, and hold down the Shift key as you select 

adjacent cells.
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To select a discontinuous group of table cells:
m Hold down the Command key as you select cells. Use Command-click to deselect a 

cell in the group.

To select an entire row or column:
1 Click the Inspector button in the toolbar (or choose View > Show Inspector), and then 

click the Table Inspector button.

2 Select a cell in the row or column you want to select.

3 Click Row or Column (at the bottom of the Table pane).

Selecting Table Cell Borders
Follow these steps to select table cell borders.

To select multiple borders:
1 Select the table cells whose borders you want to change.

2 Click the Inspector button in the toolbar (or choose View > Show Inspector), and then 
click the Table Inspector button.

3 Click one of the borders buttons in the Table pane to select all borders, or only the 
inside, outside, horizontal, or vertical borders of the selected cells.

To select an individual border:
Â If the table is selected, click the border.

Â If the table is not selected, double-click the border.

To select one segment of a cell border:
1 Select the table.

2 Option-click to select a single border segment.

3 To select additional border segments, hold down the Shift key as you Option-click the 
border segments.

Note:  If the table isn’t selected, Option–double-click to select a single border 
segment.
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Entering and Editing Content in Table Cells
You enter text by typing in a cell. You can then edit the text by selecting it and 
making any changes you want.

To type content in a table cell:
m If the cell is empty, select it and begin typing.

To replace specific text already in the cell:
m Select the cell, and then double-click what you want to change. Begin typing.

To replace everything in the cell:
m Select the cell and begin typing. You can also press Return or Enter, which selects 

everything in the cell, and then start typing.

To place the insertion point within text content:
m Select the cell and then where you want to place the insertion point. Begin typing.

To switch the contents of two cells:
m Select a single cell and drag it to another cell. A blue border appears when you begin 

to drag the cell, and the cell contents are switched.

To copy the contents of one cell into another:
m Select the cell and begin to drag it. A blue border appears when you begin to drag 

the cell. Hold down the Option key as you drag it to another cell.

To delete the contents and background fill of table cells:
m Select the cells and press the Delete key.

To edit a cell that uses a formula or contains a formatted number:
m Select the cell, and then click in the cell or press Return or Enter to open the Formula 

Editor.

See “Formatting Numbers” on page 106 and “Using Formulas” on page 110 for 
additional instructions.

Formatting Tables
You can design tables in a variety of creative ways simply by changing the thickness 
and color of cell borders, selectively removing cell borders, or merging and splitting 
cells to create useful asymmetries within the table.
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Using Table Formatting Controls
You can do basic table formatting—including merging and splitting cells, adding and 
deleting rows and columns, and adding or removing the header row and column— 
using a table formatting menu or the Table Inspector.

To open table formatting menus, do one of the following:
Â Select a table or cell(s), and then open the Table Inspector and use the Edit Rows & 

Columns pop-up menu in the Table pane.

Â Select a table or cell(s), and then choose Format > Table.

Â Select a table or cell(s), and then hold down the Control key as you click the table 
again to open the table’s shortcut menu.

Adding and Deleting Rows and Columns
You can use the Edit Rows & Columns pop-up menu in the Table Inspector to add, 
delete, or otherwise change the arrangement of columns and rows. You can also add 
rows and columns to only specific cells (see “Merging, Splitting, and Resizing Table 
Cells” on page 100).

To add a new row to a table:
1 Select a table cell or row.

2 Click the Edit Rows & Columns pop-up menu in the Table pane of the Table Inspector, 
and then choose Add Row Above or Add Row Below. 

You can also Control-click the table to show the table formatting menu, and then 
choose Add Row Above or Add Row Below.

To add a single row to the end of the table:
m Select the last cell in the table and press Tab.

To add a new column to a table:
1 Select a table cell or column.

2 Click the Edit Rows & Columns pop-up menu in the Table pane of the Table inspector, 
and then choose Add Column Before or Add Column After.

To change the number of rows or columns in a table:
1 Select the table.

2 Open the Table Inspector, and then click Table to open the Table pane.
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Â To add or remove rows, type the total number of rows you want in the table in the 
Rows field and press Return. Rows are added to or removed from the bottom of the 
table.

Â To add or remove columns, type the number of columns you want in the Columns 
field and press Return. Columns are added to or removed from the right side of the 
table.

To delete table rows or columns:
1 Select the row or column or a cell in it.

2 Click the Edit Rows & Columns pop-up menu in the Table pane of the Table Inspector, 
and then choose Delete Row or Delete Column. Alternatively, you can choose Format 
> Table or hold down the Control key as you click to open a table formatting menu 
(choose Delete).

Note:  If you select cells and press the Delete key, only the cell contents are deleted.

Adding Table Header Rows and Columns
Header rows and columns contain special formatting to set them off from the rest of 
the table text (header text might be boldface and bigger, for example). Header rows 
and columns look different from the rest of the table cells, but you can change their 
style. You cannot split a header row into multiple rows, or header columns into 
multiple columns.

To add a header row or column:
1 Select the table.

2 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Table Inspector button. In the Table pane, select Header Row and/or Header Column.

You can also choose Add Header Row or Add Header Column from the table 
formatting menu, choose Format > Table, or Control-click a table to open a formatting 
menu. 

Merging, Splitting, and Resizing Table Cells
Merging table cells combines adjacent cells into one, eliminating the border so that 
the cells work as a single cell:
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Splitting cells divides each selected cell into two equal parts, horizontally (rows) or 
vertically (columns). Both of the new cells have identical background colors or images. 
Any text that was in the original cell remains in the topmost or leftmost cell.

You can split and merge cells using the Edit Rows & Columns pop-up menu in the 
Table Inspector or any table formatting menu. To resize table cells, use controls in the 
Table pane of the Table Inspector.

To merge table cells:
1 Select a group of two or more adjacent table cells. 

The group of cells you choose must form a rectangle.

2 Click the Edit Rows & Columns pop-up menu in the Table pane of the Table Inspector, 
and choose Merge Cells. Alternatively, you can choose Format > Table or hold down 
the Control key as you click the table, and choose Merge Cells from the table 
formatting menu.

Â Merging horizontally contiguous cells containing only text—or a mixture of text, 
numbers, formatted numbers, and formulas—joins the content from all the original 
cells as text separated by tabs.

Â Merging vertically contiguous cells that contain only text—or a mixture of text, 
numbers, formatted numbers, and formulas—joins the content from all the cells as 
text separated by a carriage return.

Â When merging cells, the cell background takes on the image or color that was in the 
leftmost cell.

Â When a cell containing text, a number, a formula, or a formatted number is merged 
with empty cells, the new cell retains the content of the non-empty cell.

Â When a cell containing a formatted number is merged with empty cells, the new 
cell retains the formatted number.

Splitting cells divides each selected cell into two equal parts, horizontally (rows) or 
vertically (columns). Both of the new cells have identical background colors or images. 
Any text that was in the original cell remains in the leftmost cell.

To split cells horizontally or vertically:
1 Select a table cell or cells. Or, to split an entire row or column, select all the cells in the 

row or column. 

2 Click the Edit Rows & Columns pop-up menu in the Table pane of the Table Inspector.
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You can also Control-click the table to show the table menu and choose Split Into 
Rows or Split Into Columns (or choose Format > Table > Split Into Rows or Split Into 
Columns).

Â To split cells into rows, choose Split Rows.

Â To split cells into columns, choose Split Columns.

You can repeat the split operation to create smaller and smaller units within a table 
cell.

To rejoin split cells:
m Select the cells and choose Merge Cells from the Edit Rows & Columns pop-up menu 

in the Table Inspector. Or, choose Format > Table > Merge Cells.

To resize table cells, do one of the following:
Â Select the cells and enter values in the Column Width and Row Height fields in the 

Table pane of the Table Inspector, and then press Return.

Â Select cell borders and drag to resize.

To make all table cells the same size:
m Select the table and choose Format > Table > Distribute Rows Evenly and Distribute 

Columns Evenly.

If there is too much text in a table cell, a clipping indicator (+) appears at the bottom 
of the cell.

To avoid clipping, you can drag the cell borders to resize them, or select the table and 
drag a selection handle to resize the entire table. You can also make table rows 
automatically shrink or expand in height to accommodate the text inside them.

To make table rows automatically grow or shrink to fit their contents:
1 Select the table.

2 In the Table pane of the Table Inspector, select the checkbox labeled “Automatically 
resize to fit content.” 

The clipping indicator 
appears when a table cell 
contains more text than 
can be seen.
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Note:  With this option selected, table rows automatically get bigger when text 
extends beyond a cell boundary, and adding rows or columns increases the outside 
dimensions of the table. As text is removed from a cell, the row height may decrease 
(if the cell determines the row height). If “Automatically resize to fit content” is not 
selected, Keynote tries to keep the outside dimensions of the table the same when 
you add rows and columns. 

Aligning Text in a Table Cell
You can align text horizontally and vertically in a table cell. To align text, use the Text 
pane of the Text Inspector.

To align text horizontally within cells:
m Select one or more cells or the entire table, and click one of the horizontal alignment 

buttons in the Text pane of the Text Inspector.

To align text vertically within cells:
m Select the cell and click one of the vertical alignment buttons in the Text pane of the 

Text Inspector.

You can specify the amount of space between text and its cell border using the Inset 
Margin slider or field. The amount you specify is applied equally around the text on all 
four sides.

Align text right.

Justify text 
(align text right and left).

Center text.

Align text left.

Grow text from the 
bottom of the cell.

Place text at the top 
of the cell.

Begin text in the 
center of the cell.
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To adjust the space around text within a table cell:
1 Click in the cell (or select the table to apply the same setting to all cells).

2 In the Text pane of the Text Inspector, drag the Inset Margin slider to the right to 
increase the space, or enter a value in the field and press Return.

Formatting Cell Borders
You format cell borders the same way you format other graphics. You can change the 
line thickness and color of cell borders, or you can hide the cell border of any cell.

To set line thickness and color:
1 Select a cell border or set of cell borders.

For more information, see “Selecting Table Cell Borders” on page 97.

2 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Graphic Inspector button.

3 Type a value in the Stroke size field (or click the arrows).

4 Click the Stroke color well and select a color in the Colors window.

To hide a cell border:
1 Select a cell border or set of cell borders.

2 In the Graphic Inspector, choose None from the Stroke pop-up menu.

Choose to show or hide 
the selected cell borders.

Choose a color for 
selected cell borders.

Enter a line thickness for 
selected cell borders.



Chapter 5    Creating Tables 105

To create a table with no outside borders:
1 Select the table.

2 In the Table pane of the Table Inspector, click the second Borders button to select the 
outside borders.

3 In the Graphic Inspector, choose None from the Stroke pop-up menu.

Adding Images or Background Colors
You add images or color to a table cell using the Fill pop-up menu in the Graphic 
Inspector. You can add images or color to individual table cells, or to the entire table.

To add an image to a table cell:
1 Select a table cell, a group of cells, or the whole table.

2 In the Graphic Inspector, choose Image Fill or Tinted Image Fill from the Fill pop-up 
menu. (If there’s already an image in the cell, click Choose.)

3 Select an image and click Open.

4 Use the Scale pop-up menu to fill the cell the way you want.

Note:  If you add an image to the entire table, the Fill pop-up menu in the Graphic 
Inspector displays None when you select an individual table cell.

For more details about working with image fills, see “Filling an Object With an Image” 
on page 83. For more details about working with color and gradient fills, see “Using 
Color and Image Fills” on page 80.

Set the scale of the 
image within the cell 
or table.

Drag a new image to the 
well to change it, or click 
Choose.

Choose an image fill, 
color fill, tinted image fill, 
or gradient fill for any cell 
or the whole table.
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To add a background color or gradient fill:
1 Select a table cell, a group of cells, or the whole table.

2 In the Graphic Inspector, choose Color Fill or Gradient Fill from the Fill pop-up menu.

3 Click a color well and select a color in the Colors window.

Note:  If you add color to the entire table, the Fill pop-up menu in the Graphic 
Inspector displays None when you select an individual table cell. 

For more details about working with color and gradient fills, see “Using Color and 
Image Fills” on page 80.

Formatting Numbers
When cells in a table contain or will contain numeric data, you can apply a number 
format to them so that values in the cells appear in a particular way. For example, you 
can format cells that hold monetary values so that a currency symbol (such as $, £, or 
¥) appears in front of numbers.

Defining Number Formats
To define a number format for one or more cells:

1 Select the cell or cells. 

When a selected cell is empty, values entered into it later will appear in the number 
format you define. When a selected cell already contains a number, the format is 
applied to the number as you define it.

2 In the Numbers pane of the Table Inspector, select Number Format, and then use the 
fields below it to define the number format.
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When you use the % suffix, data in the cell is followed by the % symbol. If the data in 
the cell is used in a formula, it’s converted into a decimal number. For example, 3% 
becomes 0.03. See “Using Formulas” on page 110 for details.

After you define a number format, you can associate the format with multiple cells 
after defining the format by using autofilling. See “Autofilling” on page 109 for 
instructions.

Applying Number Formats
To add a value to an empty cell that has a number format:

m Select the cell and type a number. The number format is applied when you press 
Return or click outside the cell.

To apply a number format to an existing value:
1 Select one or more cells that contain numbers.

2 In the Numbers pane of the Table Inspector, select the Number Format checkbox, and 
then use the fields below to define the number format. The format you define is 
applied to values in the selected cell(s).

Select to define a display 
format for numbers in 
selected cells. 

Choose or type a symbol 
to precede numbers. 

Select whether to use a 
thousands separator.
Choose or type a symbol 
to follow numbers.

Set the number of 
decimal places to display. 

Select a style for displaying 
negative numbers.



108 Chapter 5    Creating Tables

To edit a value in a cell that has a number format:
1 Select the cell.

2 Click in the cell or press Return or Enter. The Formula Editor opens, displaying the 
value but not its formatting.

3 Change the value displayed in the Formula Editor.

4 To retain the new value, click the Accept button in the Formula Editor, press Return, or 
click outside the editor.

5 To cancel your change, click the Cancel button in the Formula Editor or press Escape.

To remove a number format from a cell:
m Select the cell, and then deselect the Number Format checkbox in the Numbers pane 

of the Table Inspector.

Sorting Cells
You can sort some or all the rows in a table based on the data in one of the columns. 
Header cells aren’t sorted.

To sort rows:
1 If you want to sort all the rows in a table, select the column whose values you want to 

sort, or a cell in the column, or a column header (if it’s visible).

If you want to sort only some of the rows, select those cells in the column whose 
values you want to sort.

2 In the Table Inspector, click Numbers to open the Numbers pane.

3 Use the Sort Columns buttons to indicate whether you want to sort in ascending or 
descending order.

Cancel button 
Discard changes.

Accept button 
Save changes.

Make changes.
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The following table describes how different types of data are sorted in ascending or 
descending order. 

Autofilling
You can use the Autofilling feature to paste the contents of the upper-left cell in a 
contiguous selection of cells to all other cells in the selection. Any text, number 
formatting, or formula associated with the upper-left cell is pasted into all cells in the 
selection. Background formatting is not affected. (See “Using Formulas” on page 110 to 
learn about using formulas in table cells.)

If the upper-left cell is empty, autofilling clears all data from cells in the selection. Any 
number formats or formulas associated with cells in the selection are changed to 
match those of the upper-left cell.

Sort selected column 
cells in ascending order. 
Rows containing the cells 
will be reordered.
Sort selected column 
cells in descending order. 
Rows containing the cells 
will be reordered.

Type of data Ascending order Descending order

Text aA–zZ Zz–Aa

Numbers –2, –1, 0, 1, and so on 1, 0, –1, –2, and so on

Cells containing only text, 
mixed with cells containing 
only numbers

–2, –1, 0, 1, and so on, then
aA–zZ

Zz–Aa, then 1, 0, –1, –2, and so 
on

Cells containing a mixture of 
text and numbers

Values starting with numbers 
first (1z, 1Z, a1, A1)

Values starting with text first 
(A1, a1, 1A, 1z)

Empty cells At the bottom At the bottom

Boolean (TRUE, FALSE) Above text Below text
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Autofilling doesn’t set up an ongoing relationship among cells in the selection. After 
autofilling, you can change the data, number formatting, or formula in any of the cells 
in the selection. 

To autofill a range of cells:
1 Select the cell whose data, number formatting, or formula you want to paste into 

other cells.

2 Select adjacent cells to autofill, making sure that the cell whose contents you want to 
paste is the upper-left cell in the group. Cells in the selection can be in the same row 
or column and in adjacent rows or columns, but they must be contiguous. See 
“Selecting Table Cells” on page 96 for selection instructions.

3 In the Numbers pane of the Table Inspector, click the Fill button.

Using Formulas
You can add a formula to a table cell to display a value derived using values in other 
table cells. A formula is a set of operations for deriving a value.

For example, you can add a formula to the bottom cell of a column that sums the 
numbers in all the other cells in the column. If any of the column values change, the 
total in the bottom cell changes automatically.

Formulas derive values by using operators or functions.

Â Operators perform operations such as addition (+) and multiplication (*).

Â Functions are predefined, named operations, such as SUM and AVERAGE.

Paste the contents of the 
upper-left selected cell into 
the other selected cells.
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Following are guidelines for using basic formulas in tables. See “Operators and 
Functions for Advanced Users” on page 118 for information about working with more 
advanced formulas.

Adding a Quick Formula
The easiest way to perform a basic calculation using values in a range of adjacent 
table cells is to add a quick formula using the Table Inspector’s Quick Formula pop-up 
menu.

Â Sum:  Totals the values in the cells.

Â Average:  Calculates the arithmetic mean of the values in the cells.

Â Min:  Determines which value in the cells is the smallest.

Â Max:  Determines which value in the cells is the largest.

Â Count:  Determines how many of the values in the cells are numbers.

Â Product:  Multiplies all the values in the cells.

To perform a basic calculation using column values:
1 Select a range of adjacent cells in a column. 

2 Click Inspector in the toolbar, click the Table Inspector button, and click Numbers.

3 Choose a formula from the Quick Formula pop-up menu.

Keynote places the formula and its result in the first empty cell below the selected 
cells. If there is no empty cell, Keynote creates a new row to hold the result.

If the column has a header cell and you want the formula to use all the values in the 
column, click the header cell before choosing the quick formula.

To perform a basic calculation using row values:
1 Select a range of adjacent cells in a row. 
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2 Click Inspector in the toolbar, click the Table Inspector button, and click Numbers.

3 Choose a formula from the Quick Formula pop-up menu.

Keynote places the formula and its result in the first empty cell to the right of the 
selected cells. If there is no empty cell, Keynote creates a new column to hold the 
result.

If the row has a header cell and you want the formula to use all the values in the row, 
click the header cell before choosing the quick formula.

To remove a formula from a cell:
1 Select the cell.

2 Press the Delete key.

Using the Formula Editor to Add and Edit Formulas
The Formula Editor lets you control the content of your formulas. 

The Formula Editor
You use the Formula Editor to enter or modify formulas.

To open the Formula Editor, do one of the following:
Â Select a table cell and type an equal sign (=).

A green selection border appears around the cell to indicate that you’re in formula 
mode.

Insert Function button 
Click and hold to choose a 
predefined function from 
the pop-up menu.

An equal sign is always 
the first element in a 
formula. Text field

View or edit a 
formula in this field.

Cancel button 
Discard changes.

Accept button 
Save changes.
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Â Select a table cell that contains a formula, and click in the cell or press Return or 
Enter.

Â Select a table cell, click Inspector in the toolbar, and click the Table Inspector button. 
In the Numbers pane, click the Formula Editor button (=).

To add a new formula using the Formula Editor:
1 Select the cell in which you want to display the result of the formula.

2 Open the Formula Editor. For example, type the equal sign (=).

3 Type a formula in the text field, or click the Insert Formula button to use a predefined 
function. 

See “Using Cell References” on page 114 to learn techniques for including cell 
references in your formulas.

See “Using Predefined Functions” on page 116 to learn how to insert a function into a 
formula by using the Formula Editor’s Insert Formula button.

See “Performing Arithmetic Operations” on page 116 to learn how to add a formula 
that performs arithmetic.

See “Operators and Functions for Advanced Users” on page 118 for detailed 
information about using specific operators and functions in formulas.

4 Click the Accept button to save your formula.

To edit an existing formula:
m Double-click a table cell that contains a formula. The Formula Editor opens, with the 

formula displayed in the text field. You can use the arrow keys to move the insertion 
point around in the text field.

To save a formula, do one of the following:
Â In the Formula Editor, press Return, press Enter, or click the Accept button.

Â Click outside the table.

To discard changes you’ve made to a formula, do one of the following:
Â In the Formula Editor, press Esc or click the Cancel button.

Â To close the Formula Editor and discard changes, click the Close button.

To remove a formula from a cell:
m Select the cell and press the Delete key.
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Using Cell References
When the Formula Editor is open, cell reference tabs appear on the table’s top and left 
sides. 

The reference tabs help you quickly create a cell reference. A cell reference identifies a 
column (using letters) and a row (using numbers). For example, A1 is the upper-left 
cell. A4 is the cell in the fourth row of the first column.

Adding cell references to the Formula Editor’s text field
To refer to a specific cell:

m Click to place the insertion point in the text field where you want the reference to 
appear, and then click a cell in the table. The Formula Editor inserts a reference to the 
cell. 

You can also type a cell reference (A4) in the text field, using the reference tabs as 
guides.

To add a reference to a list of individual cells:
m Click each cell. The formula Editor automatically inserts an addition operator (+) 

between them.

You can also type multiple cell references separated by a comma (or a semicolon if 
you’re in a locale where the decimal separator is a comma). For example, to sum 
values in three cells, you could type SUM(C2,D2,E2) in the text field of the Formula 
Editor.

Columns are referenced 
alphabetically.

Rows are referenced 
numerically.

This is cell D4.
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To add a reference to a range of cells:
m Select a function from the Insert Formula button in the Formula Editor. Drag over the 

cells you want to add. The Formula Editor inserts the first and last cell references of 
the range, separated by a colon (A2:A4). See “Using Predefined Functions” on page 116 
for more information about the Insert Formula button.

You can also type or click the first cell, type a colon, and then type or click the last cell.

To refer to all the cells in a column:
m Type the column’s letter. If the column has a header row, you can click the column 

header cell instead. 

To refer to all the cells in a row:
m Enter 1:1 for the first row header, 2:2 for the second row header, and so on. If the row 

has a header column, you can click it instead.

Adding a Formula to Multiple Cells
When a table has header cells, you can use them to quickly add a formula to multiple 
rows or columns.

To use a column header to sum the values in each row:
1 Select the header for the column whose cells you want to contain the formula. We’ll 

use column header C1 as an example.

2 Open the Formula Editor. For example, type the equal sign (=).

3 To add a formula that sums the values in columns A and B, click the column header 
cell for column A, and then click the column header cell for column B. The Formula 
Editor text field displays =A+B.

You could also type A+B in the text field.

4 Click the Accept button or press Return or Enter to save the formula.

Every cell below the header in column C now contains a version of the formula that 
refers to cells in only its row. For example, if you select C2 and type the equal sign (=) 
to open the Formula Editor, you’ll see =A2+B2 displayed in the text field.

As this example illustrates, you can type a cell reference instead of clicking a header 
cell. To refer to all the cells in a column, type the column’s letter, as in the example. To 
refer to all the cells in a row, type 1:1 for the first row header, 2:2 for the second row 
header, and so on.
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Performing Arithmetic Operations
To create a formula that performs an arithmetic operation, you use arithmetic 
operators. For example, to add the values in two columns, you could create a formula 
that looks like this:  A2 + A3 + A5.

Here are the basic arithmetic operators. For complete information about operators in 
Keynote, see “Defining Formulas That Use Operators” on page 118. 

To add an arithmetic formula to a cell:
1 Select an empty cell for displaying the results of the formula.

2 Open the Formula Editor. For example, type an equal sign (=).

3 Enter the formula in the text field following the equal sign. For example, to enter the 
formula A3 * B5 + B6, in the text field following the equal sign you could:

a Click or type A3.

b Type * (the multiplication operator).

c Click or type B5.

d Click B6 (if you don’t type an operator before clicking, the Formula Editor adds a plus 
sign (+) automatically).

4 Click the Accept button or press Return or Enter to save the formula.

Using Predefined Functions
The Insert Function button in the Formula Editor lets you quickly add a function to a 
formula.

When you use a function, you name the function and, in parentheses following the 
name, you provide the arguments it needs. Arguments specify the data the function 
will use when it performs its operations. 

To perform this operation Use this arithmetic operator For example

Sum two values + A2 + B2

Subtract one value from 
another value

– A2 – B2

Multiply two values * A2 * B2

Divide one value by another 
value

/ A2 / B2
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Here are some examples of formulas that use functions:

Â SUM(A2:A10):  This formula uses the SUM function to add values in nine cells of the 
first column. There is one argument, A2:A10. The colon means the function should 
use the values in cells A2 through A10.

Â AVERAGE(A2,B2,C2):  This formula uses the AVERAGE function to compute the 
arithmetic mean of three values in the second row. There are three arguments:  A2, 
B2, and C2.

Here’s a summary of the functions you can add using the Insert Formula button. 

You can also type these and other functions into the text field of the Formula Editor. 
For complete information about all the functions that Keynote supports, see “Defining 
Formulas That Use Functions” on page 120.

To use a predefined function in a formula:
1 Select an empty cell for displaying the results of the formula.

2 Open the Formula Editor. For example, type the equal sign (=).

3 Click the Insert Formula button, and select a function from the pop-up menu.

Keynote inserts the function into the text field, followed by a pair of parentheses.

4 Within the parentheses, insert references to cells whose values you want the function 
to use. 

To perform this operation Use this function For example

Sum the values in two or more 
cells

SUM SUM(A2:A5)

Average the values in two or 
more cells

AVERAGE AVERAGE(A2:A5)

Determine the smallest value 
in two or more cells

MIN MIN(A2:A5)

Determine the largest value in 
two or more cells

MAX MAX(A2:A5)

Determine how many values 
in two or more cells are 
numbers

COUNT COUNT(A2:A5)

Multiply the values in two or 
more cells

PRODUCT PRODUCT(A2:A5)
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For example, to refer to nine cells in column A (A2 through A10), you could drag from 
cell A2 to cell A10. You can also:

a Click or type A2.

b Type a colon.

c Click or type A10.

5 Click the Accept button or press Return or Enter to save the formula.

Operators and Functions for Advanced Users
After becoming familiar with the Formula Editor and cell references, you can create a 
wide variety of formulas. 

This section fully describes the operators and functions that you can include in your 
formulas when you type them in the text field of the Formula Editor.

Defining Formulas That Use Operators
You use operators in formulas when you want to perform arithmetic or comparison 
operations:

Â A2 + A3:  This formula adds the values in two cells of the first column.

Â A2 > B6:  This formula determines whether the value in cell A2 is larger than the 
value in cell B6. If it is, the result is TRUE; otherwise, it is FALSE.

Arithmetic operators perform arithmetic operations and return numerical results.  

This operator Returns
Example (A2 contains 20 and 
B2 contains 2)

+ The sum of two values A2+B2 returns 22

– The difference between two 
values

A2–B2 returns 18

* The product of two values A2*B2 returns 40
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Comparison operators compare two values and return TRUE or FALSE.  

/ The result of dividing one 
value by another value

A2/B2 returns 10

^ The result of raising one value 
to the power another value

A2^B2 returns 400

% The result of dividing a value 
by 100

A2% returns 0.2 

Notes:
Â When a cell reference points to an empty cell, 0 is the value used. 
Â When a cell reference points to a cell containing FALSE, 0 is used. If the cell

contains TRUE, 1 is used. For example, TRUE + 1 returns 2.
Â Using a text string with an arithmetic operator returns an error. 

For example, 3 + “hello” is not a correct arithmetic operation.

This operator Returns
Example (A2 contains 20 and 
B2 contains 2)

This operator Returns
Example (A2 contains 20 and 
B2 contains 2)

= TRUE if two values are equal A2=B2 returns FALSE

<> TRUE if two values aren’t equal A2<>B2 returns TRUE

> TRUE if the first value is 
greater than the second value 

A2>B2 returns TRUE

< TRUE if the first value is less 
than the second value

A2<B2 returns FALSE

>= TRUE if the first value is 
greater than or equal to the 
second value

A2>=B2 returns TRUE

<= TRUE if the first value is less 
than or equal to the second 
value

A2<=B2 returns FALSE

Notes:
Â Text strings are larger than numbers. For example, “hello” > 5 returns TRUE.
Â TRUE and FALSE can be compared with each other, but not with numbers 

or text strings. TRUE > FALSE, and FALSE < TRUE. 
Â To type a Boolean value (TRUE or FALSE), type an equal sign, type the value 

in the Formula Editor, and press Return.
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Defining Formulas That Use Functions
The following tables provide information about the three kinds of 
functions:  statistical, numerical, and logical. In the tables, these conventions are used 
to describe arguments:

Â The argument placeholders—x, x1, and so forth—represent places where input to 
the functions (such as cell references or constants) should go.

Â The ellipsis (...) following a list of arguments means you can use additional 
arguments if needed. Place a comma between arguments; if you’re in a locale where 
the decimal separator is not a period, place a semicolon between arguments.

Â Functions that don’t require a specific number of arguments (such as AVERAGE) can 
include cell range references (such as A4:A6) instead of or in addition to other 
arguments.

Statistical functions perform statistical calculations. 

This function Returns Examples

AVERAGE(x1 ...) The arithmetic mean of the 
arguments

AVERAGE(2, 3) returns 2.5

COUNT(x1 ...) The number of arguments that 
are numeric

COUNT(1, 2, ”hello”) returns 2
COUNT(A1:A4) returns 2 if A1 
and A2 contain numbers, but 
A3 and A4 are empty

MAX(x1 ...) The value of the largest 
argument

MAX(–1, 42, 7) returns 42

MIN(x1 ...) The value of the smallest 
argument

MIN(–1, 42, 7) returns
–1

Notes:
Â If an argument is a reference to a cell that doesn’t contain a number, the argument is ignored. 

TRUE is interpreted as 1, FALSE is interpreted as 0, 
and text strings result in an error.
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Numerical functions perform arithmetic calculations. 

This function Returns Examples Notes

ABS(x) The absolute value of 
the argument

ABS(3.6) returns 3.6
ABS(–3.6) returns 3.6
ABS(TRUE) returns 1

Interprets TRUE as 1 
and FALSE as 0

INT(x) The whole number 
nearest the argument 
that is no larger than 
the argument

INT(3.1) returns 3
INT(3.7) returns 3
INT(–3.1) returns –4
INT(42) returns 42

Interprets TRUE as 1, 
and FALSE and 
references to empty 
cells as 0

MOD(x, y) The remainder after 
dividing x by y

MOD(5,2) returns 1
MOD(–1.2,7) returns 
5.8

The sign of the 
returned value is the 
same as the sign of y. 
Also see note at end 
of table.

PRODUCT(x1 ...) The product of the 
arguments

PRODUCT(2, 4) returns 
8

See note at end of 
table.

ROUND(x, y) The number that 
results after rounding 
x to y decimal places

ROUND(3.1415, 2) 
returns 3.14
ROUND(3.1415, –7) 
returns 0
ROUND(3.1415, 2.7) 
returns 3.14

Rounds y toward 0 to 
the nearest integer. If 
y, after rounding, is 
negative, returns 0.
Also see note at end 
of table.

SIGN(x) 1 if x is greater than 0
0 if x is equal to 0
–1 if x is less than 0

SIGN(42) returns 1
SIGN(0) returns 0
SIGN(–42) returns –1

Interprets TRUE as 1, 
and FALSE and 
references to empty 
cells as 0

SUM(x ...) The sum of the 
arguments

SUM(1, 2) returns 3
SUM(1, TRUE) returns 
2

Also see note at end 
of table.

Notes:
Â If an argument of MOD, ROUND, or SUM is a reference to a cell that 

doesn’t contain a number, the argument is ignored. TRUE is interpreted as 1, 
FALSE is interpreted as 0, and text strings result in an error.
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Logical functions determine whether a particular condition is TRUE or FALSE. 

This function Returns Examples Notes

AND(x1 ...) TRUE if all the 
arguments are TRUE, 
otherwise returns 
FALSE

AND(TRUE, TRUE) 
returns TRUE
AND(TRUE, FALSE) 
returns FALSE
AND(TRUE, 0) returns 
FALSE

See note at end of 
table.

ISERROR(x) TRUE if x is erroneous, 
otherwise returns 
FALSE

ISERROR(1/0) returns 
TRUE

NOT(x) TRUE if x is FALSE
FALSE if x is TRUE

NOT(TRUE) returns 
FALSE
NOT(FALSE) returns 
TRUE

Interprets 0 as FALSE 
and all other numbers 
as TRUE

OR(x1 ...) TRUE if any argument 
is TRUE, otherwise 
returns FALSE

OR(TRUE, FALSE) 
returns TRUE
OR(FALSE) returns 
FALSE

See note at end of 
table.

Notes:
Â If an argument of AND or OR is a reference to a cell that doesn’t contain 

TRUE or FALSE, the argument is ignored. When you type arguments, rather 
than referring to cells for values, zero is interpreted as FALSE, any other number 
is interpreted as TRUE, and text strings result in an error.
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66 Creating Charts

You can turn spreadsheet data into attractive 
charts. This chapter outlines the basics of creating 
charts in Keynote.
Keynote provides tools for creating your own visually appealing charts to present 
numerical data. You can copy and paste data from a spreadsheet or type it directly 
into the Chart Data Editor to create and edit your charts right on the slide canvas. By 
default, Keynote coordinates the appearance of your charts with the theme you’re 
using.

About Charts
Charts show the relationship of two types of data with respect to each other. For 
example, if you chart business growth over time, you are showing the relationship 
between the size of the business and the passage of years. If you chart voting results 
among different demographic groups, you are showing the relationship between the 
number of people who voted a certain way and their demographic affiliation. When 
you enter data for a chart, the two different types of data are represented as data 
series and data sets.

Data Series and Data Sets
In a business chart, an example of a data series could be one region’s profits over four 
successive years; the data sets could be all of the regions’ profits for only one of those 
years. In the illustration below, the data series (each region’s profits) are in rows, and 
the data sets (each year’s profits) are in columns. Each individual value (for example, 
17 for Region 1, 2005) is a data point.
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The colored squares next to the row labels (Region 1 and Region 2) show which color 
represents each data series in the chart.

The illustration below shows how this data looks as a column chart.

In this chart, called a column chart, the data series are represented by rows in the 
Chart Data Editor. The data points are represented as a series of dark-colored bars and 
a series of light-colored bars.

Most charts have three-dimensional (3D) versions. Here’s what the 3D column chart 
looks like for the data series above.

These squares indicate 
which color represents 
each data series.

The data sets contain 
one data point (one bar) 
from each of the data 
series.

These four bars represent 
one data series.

The chart legend denotes 
the two data series.
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Transposing Data Series and Data Sets
You can easily switch the data series and data sets in your charts—without having to 
retype the data—by using the Plot Row vs. Column button in the Chart Data Editor.

The column chart below shows the same data, but with the data sets and data series 
transposed.

This button makes the rows 
of data in the Chart Data 
Editor the data series.

This button makes the 
columns of data in the Chart 
Data Editor the data series.
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For this chart, the data series are represented by columns in the Chart Data Editor 
pictured on page 124. There are now four data series represented as four different-
colored bars.

Data series are represented differently in the different kinds of charts provided by 
Keynote.

Â Column charts and bar charts:  A data series is represented by a series of bars in the 
same color (as shown above). 

Â Line chart (also called a graph):  A data series is represented by a single line. 

Â Area chart:  A data series is represented by an area shape. 

Â Pie chart:  Only a single data set—the first data point in each series—is represented 
on the chart (whichever is listed first in the Chart Data Editor).

Â Scatter chart:  Two columns of data are used to plot values for a single data series. 
Each pair of values determines the position of one data point.

These two bars represent 
one data series.

The data sets contain 
one data point (one bar) 
from each of the four 
data series.
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Adding a Chart
You can add a chart by inserting it on the slide canvas or by drawing it. After you add 
a chart, you can change the chart type and appearance with the Chart Inspector.

To place a chart on the slide canvas:
1 Click Chart in the toolbar (or choose Insert > Chart). 

A chart containing placeholder data appears on the slide, and the Chart Inspector and 
Chart Data Editor open.

To resize the chart:
m Drag an active selection handle.

To reposition the chart:
m Drag the chart where you want it (avoid placing the pointer on a selection handle).

You can also draw a chart on a slide.

To draw a chart on the slide canvas:
1 Hold down the Option key and click Chart in the toolbar. 

2 Release the Option key, and then move the pointer over the slide canvas until it 
becomes a crosshair.

3 Drag across the slide canvas to create a chart any size you want.

To constrain the chart’s proportions, hold down the Shift key as you drag.

Changing a Chart Type
Keynote provides numerous types of charts to choose from, including bar charts, 3D 
bar charts, line charts, 3D line charts, pie charts, and more. Once you’ve placed a chart 
on a page, you can change its type and format it using the Chart Inspector.

To open the Chart Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector, and then click the 

Chart Inspector button).

To select a chart type, do one of the following:
Â Choose Format > Chart > [chart type].

Â In the Chart Inspector, choose a chart from the pop-up menu that appears when 
you click the chart icon in the upper left.
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To change a chart from one type to another:
1 Select the chart.

2 In the Chart Inspector, choose a different chart type from the pop-up menu. You can 
also choose Format > Chart > Chart Type > [chart type].

Â If you switch to a pie chart, Keynote charts only the first data set in the Chart Data 
Editor. See “Pie Charts” on page 136.

Â If you switch to a scatter chart, each point in the chart requires two values, so every 
series uses two columns in the Chart Data Editor. See “Scatter Charts” on page 140.

Â If you switch to a bar, column, area, or line chart, each series in the new chart 
corresponds to a row in the Chart Data Editor.

Â If you switch to a 3D version of a chart, the Chart Inspector provides controls for 
managing object depth and lighting style. See “3D Charts” on page 141.

Formatting you’ve applied to the chart you’re changing may not be applied to the 
new chart. For example, the color fill attribute has a different default value for each 
type of chart. If you’ve changed a column fill color and then change the chart to be a 
bar chart, the fill color change isn’t retained. 

The Chart Inspector 
button

Choose a chart type from the 
pop-up menu. 2D charts are 
on the left, and 3D charts are 
on the right.
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Â Depending on the type of chart, the attributes that may change when you change a 
chart’s type are as follows:  show value label, value label position, text style, series 
stroke, series shadow, series fill, data point symbol, and data point fill. 

Â Bar/column charts and stacked bar/column charts share attributes except for value 
label position. Also, bar/column charts have separate fills.

Â 3D chart shadows are shared across chart types.

When you change a chart’s type and the new type has some of the same attributes, 
those attributes don’t change. Shared attributes include axes, gridlines, tick marks, axis 
labels, show minimum value, number format, borders, rotation, shadows, and 3D 
lighting style.

You’ll learn more about these attributes throughout the remainder of this chapter.

Editing Chart Data
To edit chart data, open the Chart Data Editor and enter your data by typing it or 
copying and pasting from Excel, AppleWorks, or another spreadsheet application.

To open the Chart Data Editor:
1 Select a chart on a slide.

2 Click Edit Data in the Chart Inspector (or choose Format > Chart > Show Data Editor).

Click these buttons to 
add another row or 
column for data.

Type chart data directly 
into these spreadsheet 
cells.

Drag labels to reorder 
them.
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To copy data from another spreadsheet into the Chart Data Editor:
1 Open the spreadsheet with the data you want, and select all the relevant cells.

2 Choose Edit > Copy (or press Command-C).

3 Select the top cell in the first column of the Chart Data Editor.

4 Choose Edit > Paste (or press Command-V).

To edit the names of rows and columns, or the data in a cell:
m Double-click a cell or a row or column label and type.

To reorder rows or columns in the Chart Data Editor:
m Drag a row or column label to a new position.

To add rows or columns in the Chart Data Editor, do one of the following:
Â Click Add Row or Add Column to place a row above the selected row or a column to 

the left of the selected column. If no row or column is selected, the new row or 
column appears at the bottom or right edge of the table. (To see the new row or 
column, you may have to press the Return or Tab key or expand the Chart Data 
Editor window.)

Â Select any blank cell, type your data, and press Return. A new row or column is 
automatically created.

To delete rows or columns:
m Select the row or column header label and press Delete.

Formatting Charts
You can resize and reposition charts and chart legends the same way you work with 
other objects. You can format chart elements—fonts, colors, axis labels, and tick 
marks—to suit your preferences. You can hide the chart legend and adjust the angle 
and lighting style of 3D charts. You can also hide the chart legend. Most chart 
formatting tasks are done using the Chart Inspector. You can also accomplish many of 
the tasks described in this section using shortcut menus.

To open the Chart Inspector:
1 Click Inspector in the toolbar (or choose View > Show Inspector).

2 In the Inspector window, click the Chart Inspector button.
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To open the shortcut menu for a chart:
m Hold down the Control key and click a chart.

To hide the chart legend:
1 Select the chart.

2 In the Chart Inspector, deselect the Show Legend checkbox.

You can also select the legend and press Delete; you can always display the legend 
again by selecting Show Legend in the Chart Inspector.

Setting Chart Colors
You can format the bars, wedges, and area shapes that appear on each type of chart 
just as you format any other drawn object. You can give them color fills, gradient fills, 
image fills, shadows, opacity, or different line styles. You set these attributes in the 
Graphic Inspector.

To change the color or image in a bar, wedge, or area shape:
1 Select the item (bar, wedge, or area shape). 

If you select one bar in a bar chart, all the bars in that data series are selected.

2 Change chart properties as you would for any drawn object using the Graphic 
Inspector. 

The Chart Inspector 
button
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For more information about changing object properties, see Chapter 4, “Changing 
Object Properties.”

Changing Chart Fonts
You can change the fonts and text colors used for axis labels, data point labels, and 
legends.

To change chart fonts:
1 Select the text you want to change. 

To change the font on all chart elements, click the chart to select it. If you select the 
text for one data point or axis label, all the text of that kind is also selected. You 
change the font for a chart legend separately.

2 Click Fonts in the toolbar (or choose Format > Fonts > Show Fonts) to open the Font 
panel.

3 Select a font.

For information about changing text colors, see “Formatting Bulleted Text and 
Numbered Lists” on page 46.

Adding Labels and Axis Markings
Use the Axis pane in the Chart Inspector to format the grid and general look of the 
axes for bar charts, line charts, and area charts. You can set the range of values to be 
displayed along the value axis, the axis on which you read the data point values.

For column charts (vertical bars), line charts, and area charts, the Y-axis is the value 
axis. For horizontal bar charts, the X-axis is the value axis. For scatter charts, both axes 
are value axes. (Pie charts don’t have a value axis. To read about formatting pie charts, 
see “Pie Charts” on page 136.)
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To show or hide axes and chart borders:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.

3 Choose one or more items in the Axes & Borders pop-up menu to select it.

A selected item has a checkmark next to it; choose the item again to deselect it.

To set the range of numerical values displayed on the chart grid:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.

3 To set the value at the chart origin, type a number in the Minimum field (below Value 
Axis Format).

The Minimum value cannot be higher than the minimum value of your entire data set.

4 To set the highest number displayed on the value axis, type a number in the 
Maximum field.

The Maximum value cannot be lower than the maximum value of your entire data set.

5 To specify the number of axis markings between the minimum and maximum values, 
type a number in the Steps field.

To display the minimum data value on the value axis:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it’s not already selected.

3 Select Show Value Labels and Show Minimum Value from the value axis pop-up menu 
(the X- or Y-axis pop-up menu, depending on the chart).

An item is selected when it has a checkmark next to it.

Place tick marks along 
the X-axis.

Show or hide the 
X-axis gridlines.

Set the text direction for 
the series axis labels.

Show or hide axes and chart borders 
(2D charts only).
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To specify units for axis values:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.

3 Below Number Format, type text in the Prefix or Suffix field (or choose a symbol from 
the pop-up menus).

Placing Grid Labels and Tick Marks
The X-Axis and Y-Axis pop-up menus in the Axis pane of the Chart Inspector provide 
an array of options for placing tick marks, labels, and gridlines along the value axis or 
the series axis. The options in these pop-up menus vary depending on the kind of 
chart you select.

For vertical bar charts (column charts), line charts, and area charts, the Y-axis is the 
value axis and the X-axis is the series axis; for horizontal bar charts, the X-axis is the 
value axis. For scatter charts, both axes are value axes. For 3D charts, the X and Y axes 
are the same as their 2D counterparts.

Pop-up menus are pictured below as they appear when a column chart is selected.

To add grid labels and tick marks along an axis:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.

3 To add grid labels and tick marks along the X-axis, choose an option from the X-Axis 
pop-up menu. The menu for a column chart looks like this:

4 To add grid labels and tick marks to the Y-axis, choose an option from the Y-Axis pop-
up menu. Here’s what the menu looks like for a column chart:

Place tick marks along 
the X-axis.

Show or hide the 
X-axis gridlines.

Set the text direction for 
the series axis labels.

Show or hide series 
axis labels.
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Formatting the Elements in a Data Series
You can use a variety of visual effects to enhance the appearance of data series 
elements.

To add data point labels:
1 Select the chart or an element in a data series.

For all chart types except pie charts, selecting one element (such as a bar) of a series 
automatically selects the full series. For pie charts, you can select individual wedges.

2 In the Chart Inspector, click the Series button. 

3 Choose Show Value from the Data Point Settings pop-up menu.

4 To specify the number of decimal places you want to display, type a number in the 
Decimals field (or click the arrows to increase or decrease the number).

5 To change the position of data point values, choose an option from the Data Point 
Settings pop-up menu.

6 Use the Font panel (Format > Font > Show Fonts) to choose a font, font size, and style 
for the data point labels.

For pie charts, you can show data point labels as a percentage of the whole or as 
absolute values by selecting or deselecting “Show Pie Values as Percentages” in the 
Data Point Settings pop-up menu. You can also show the series names.

Some chart types offer further options for formatting series elements. See the 
following sections for information about special formatting options for pie charts, bar 
and column charts, line charts, scatter charts, and 3D charts. 

Place tick marks along 
the Y-axis.

Show or hide the Y-axis 
gridlines.

Show or hide value axis 
labels.
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Pie Charts
For pie charts, Keynote charts only the first data set in the Chart Data Editor (the first 
data point for each data series). If the data series are in rows in the Chart Data Editor, 
only the first column is charted; if the data series are in columns in the Chart Data 
Editor, only the first row is charted. Thus, one pie chart represents a single data set, 
and each wedge is one element in that set. Other data sets in the Chart Data Editor 
are maintained, but they are not displayed in the pie chart. You can chart any data set 
by moving it to the first position in its row or column.

To select individual pie wedges:
1 Select the chart, and then click to select a single wedge.

2 To select additional wedges, do one of the following:

Â To select all the wedges, choose Edit > Select All (or press Command-A).

Â To select noncontiguous wedges, hold down the Command key as you select each 
wedge.

Â To select a continuous range of wedges, select the first wedge, and then hold down 
the Shift key as you select the last wedge.

On pie charts, in addition to showing values for wedges, you can display the series 
name.

To show a series name in a pie chart:
1 Select the chart or individual pie wedges.

2 In the Chart Inspector, click the Series button. 

3 Choose Show Series Name from the Data Point Label pop-up menu (an item is 
selected when it has a checkmark next to it).

4 Choose Inside or Outside from the Data Point Label pop-up menu.

To separate individual pie wedges:
1 Select the individual pie wedges. (To select more than one pie wedge, hold down the 

Command key as you click each wedge.)

2 Drag the pie wedges or the Explode slider until the pie wedges are separated as far as 
you want.

You can also type a number in the Explode field, or use the arrows to increase or 
decrease the number.
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You can put shadows on individual pie wedges or on the pie as a whole. Putting 
shadows on individual wedges makes it look like the wedges are in different layers.

To put shadows on individual pie wedges:
1 Select the chart or individual wedges.

2 In the Chart Inspector, click the Series button.

3 Choose Individual from the Shadow pop-up menu.

4 In the Graphic Inspector, set shadow attributes. (For more information, see “Adding 
Shadows” on page 86.)

To put a shadow on the whole pie:
1 Select the chart.

2 In the Series pane of the Chart Inspector, choose Group from the Shadow 
pop-up menu.

3 In the Graphic Inspector, set shadow attributes. 

For more information, see “Adding Shadows” on page 86.

You can also change the opacity of the chart and individual chart elements, such as 
the legend. For more information, see “Adjusting Opacity” on page 88.

Add shadows to 
individual wedges or 
the whole pie.

Separate individual pie 
wedges.

Set a pie wedge apart by 
using the Explode slider 
and giving it a series 
name.
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To rotate a pie chart:
m Select the chart and drag the Rotation Angle wheel in the Series pane of the Chart 

Inspector, or type a value in the Rotation Angle field.

Bar and Column Charts
You can apply shadows to individual data series or to the entire chart. You can adjust 
the opacity for the chart as a whole or for individual series (not individual bars). You 
can also adjust the spacing between data sets or individual bars.

To adjust spacing between individual bars or data sets:
1 Select the chart.

2 In the Chart Inspector, click the Series button if it is not already selected.

3 To change the space between bars, type a value (or click the arrows) in the “Gap 
between bars” field.

4 To change the space between data sets, type a value in the “Gap between sets” field.

The value is the percentage of the bar thickness. Decreasing the space between the 
bars makes them thicker. You can also move the pointer near a bar edge until it 
becomes a double-headed arrow, then drag to make the bars thicker or thinner.

To put a shadow on each bar:
1 Select the chart or a bar (the whole data series is selected).

2 In the Series pane of the Chart Inspector, choose Individual from the Shadow pop-up 
menu.

If you select one data series and choose an item from the Shadow pop-up menu, the 
choice applies to all series in the chart.

3 In the Graphic Inspector, set shadow attributes.

For more information, see “Adding Shadows” on page 86.

Separate the individual bars 
in the chart.
Separate the data sets in 
the chart.

Add shadows to bars or 
data sets.
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To adjust the opacity of a chart:
m Select the chart and drag the Opacity slider in the Graphic Inspector.

For more information, see “Adjusting Opacity” on page 88.

Area Charts and Line Charts
In area and line charts, you can use symbols—circles, triangles, squares, and 
diamonds—to represent data points.

To use a symbol for the data points in a series:
1 Select a data series (area shape or line).

2 In the Series pane of the Chart Inspector, choose a symbol from the Data Point 
Symbol pop-up menu.

3 Fill the symbol with color or an image by choosing one of the options in the Symbol 
Fill pop-up menu.

For more information about using image fills, see “Using Color and Image Fills” on 
page 80.

To set the line color and shadow:
m Use the Stroke and Shadow controls in the Graphic Inspector.

The data points in this 
series are represented 
with circles.

The data points in this 
series are represented 
with triangles.

Choose a symbol to use 
for data points.

Fill data point symbols 
with color or images.
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For more information about using the Graphic Inspector to set line color, shadow, and 
the fill for data point symbols, see Chapter 4, “Changing Object Properties,” on 
page 80.

Scatter Charts
Scatter charts display data differently from the other kinds of charts. They require at 
least two columns of data to plot values for a single data series. To show multiple data 
series, you use additional two-column pairs. 

Each pair of values determines the position of one data point. The first data value in 
the row is the X-axis of the point. The second data value is the Y-axis of the point.

Here’s what the default scatter chart looks like.

You can view the data for this chart in the Chart Data Editor.
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To control the appearance of a scatter chart, do one of the following:
Â To format a symbol for a data series, choose a symbol from the Data Point Symbol 

pop-up menu in the Series pane of the Chart Inspector. You can adjust the stroke 
and fill settings of a scatter plot data point symbol by using the Graphic Inspector.

Â To specify axis settings, use the Axis pane of the Chart Inspector. Because both axes 
of scatter charts have values, value axis format settings apply to both X-axis and Y-
axis. Each axis can have its own number format.

3D Charts
You can display all the chart types except scatter charts as 3D-rendered charts. 

Here are 2D and 3D versions of the default pie chart.

Here are 2D and 3D versions of the default line chart.

To select a 3D chart type:
m In the Chart Inspector, choose a chart type from the Type pop-up menu. You can also 

choose Format > Chart > Chart Type > [3D chart type].
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To define 3D scene settings:
m Select a 3D chart, click the 3D Scene button in the Chart Inspector, and modify the 

chart’s viewing angle and lighting style using the 3D Scene controls.

To resize a 3D chart:
m Select the chart and drag the active selection handles. The chart is resized through all 

three dimensions.

Rotating Charts
You can rotate charts by dragging a selection handle (see “Changing an Object’s 
Orientation” on page 90). Pie charts can also be rotated using the Chart Inspector (see 
“Pie Charts” on page 136).

You can’t rotate or flip 3D charts. If a 3D chart is grouped with 2D charts, you can 
rotate the group, but only the 2D charts in it will rotate.

Click the intersection of the 
arrows and drag to move 
the chart both ways.

Drag an arrow to adjust the 
viewing angle. Click one arrow 
at a time to move the chart in 
a single direction (left-right or 
up-down).

Choose an item from the 
Lighting Style pop-up 
menu to adjust the 
lighting effect.
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77 Slide Transitions 
and Object Builds

This chapter describes how to add motion and 
visual appeal to your slideshow using slide 
transitions and object builds.
After you’ve designed and organized your slides, you can put the whole presentation 
together. Add animation to text to captivate your audience. Add transitions to move 
smoothly from one slide to the next. Use object builds within each slide to reveal data 
as you present it.

Adding Transitions Between Slides
Keynote provides a variety of transition styles. Some examples are described below.

Transition style What it looks like

Cube Slides rotate on and off screen as if they are sides of a revolving 
cube.

Doorway Slide appears as if doors were opening, and then the full slide 
appears.

Fall Slide appears to fall forward, and then the full slide appears.

Flip New slide appears as if it is on the other side of a flipped page.

Mosaic flip Slide appears as rotating mosaic pieces.

Page flip Slide appears as a page peeling back.

Move in Slide moves in from a specified direction to cover the contents of 
the previous slide.

Push New slide appears to push old slide off the screen in the specified 
direction.

Twirl Previous slide spins and shrinks toward center, and then next 
slide spins outward.
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You can change the duration of a transition, and you can specify when to start the 
transition (automatically or on click). You set slide transitions in the Slide Inspector.

To add a transition from one slide to the next:
1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Slide Inspector button.

2 Click Transition.

3 Choose an option from the Effect pop-up menu.

4 If applicable, choose an option from the Direction pop-up menu.

5 To set how much time it takes to complete the transition, type a value in the Duration 
field (or click the arrows).

Important:  Each transition you specify applies only to the selected slide. To apply a 
transition to another slide, select it and repeat the procedure above.

Click to preview 
the transition.

Set how much time it 
takes to complete the 
transition.
Set how much time to 
wait until transitions 
that start automatically 
begin playing.

Set the transition direction.

Choose how to 
initiate the transition.

Choose a transition.

The Slide Inspector button
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6 Choose an option from the Start Transition pop-up menu.

Â On Click:  Initiates the transition when you click to move to the next slide.

Â Automatically:  Initiates the transition after the amount of time specified in the 
Delay field.

Note:  If you select “Scale slides up to fit display” in the Slideshow pane of Keynote 
preferences, parts of Cube or Flip transitions may not be visible. To ensure that Cube 
or Flip transitions are not clipped during your slideshow, choose Keynote > 
Preferences, click Slideshow, and then select the “Reduce to avoid clipping” options.

If you see “Effects that can’t play on this computer” in the Effect pop-up menu, these 
transitions require your computer to have an advanced graphics card. 

Creating Object Builds
Object builds make slide elements appear (build in) or disappear (build out) from the 
slide one at a time, or in groups, in any order you like. For example, an image could 
move in from the left side of the screen, and then accompanying bulleted text could 
appear line by line. You could have a slide element move in from the left and move 
out on the right. Or you could display parts of a chart one at a time to build suspense.

You can develop object builds that animate several different objects on the same 
slide, in the order you specify. For example, a slide might contain a table and a chart 
that you want to present in a certain order. You can intersperse the parts of different 
objects on the slide. You can also build only some of the parts of an object.

Use Build In animations to move slide elements onto the screen, and Build Out 
animations to move elements off the screen.

Setting Up an Object Build
To create builds, you begin with a completed slide and specify build settings for each 
element you want to appear over time.

To set up an object build:
1 Click Inspector in the toolbar (or choose View > Show Inspector).

2 In the Inspector window, click the Build Inspector button, and then click Build In or 
Build Out.
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3 Select an item on the slide and choose an option from the Effect pop-up menu.

You can select graphic objects, bulleted text, tables, or charts, as well as sound files 
placed on an individual slide (represented by an audio icon).

4 If appropriate, choose an option from the Direction pop-up menu.

5 Choose an option from the Delivery pop-up menu.

6 To set how much time it takes to complete the transition, type a value in the Duration 
field (or click the arrows).

After you select an effect for each item you want to animate, you can easily reorder 
the items. You can also specify whether you want each animation to begin 
automatically (after a specified time) or on click.

Note:  If you group an object that has a build effect assigned to it, the effect is 
removed. Ungrouping a grouped object with a build assigned to it removes the build 
effect.

Set how long it takes to 
complete the build.

Click to preview 
the build.

Use Build In animations to 
move slide elements onto 
the screen, and Build Out 
animations to move 
elements off the screen.

Open the Build Order 
drawer to reorder objects.

Set the animation style, 
direction, and build order 
for each object.

Move objects onscreen or 
offscreen in specific groups.
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Working With Object Builds
After you’ve set up object builds on a slide, you can create various effects by changing 
the order of builds and by specifying timing for the appearance of builds.

To build objects in a different order:
1 In the Build Inspector, click the More Options button.

2 In the Build Order drawer, drag the items to change their order.

You can also use the Order pop-up menu to change the order of builds.

To specify when to animate each object:
1 In the Build Order drawer (click More Options if the drawer isn’t open), select an item 

in the list.

2 Choose an option from the Start Build pop-up menu.

Â On Click:  Initiates the build when you click.

Â Automatically after build [number]:  Initiates the build after the build number 
indicated, which is always the previous build, and after the amount of time specified 
in the Delay field.

Â Automatically with build [#]: Makes two objects appear at the same time and after 
the amount of time specified in the Delay field. Put the two builds next to each 
other in the Build Order list.



148 Chapter 7    Slide Transitions and Object Builds

You can also make several objects appear and move at the same time, by first 
grouping them (see “Grouping and Locking Objects” on page 65).

3 To specify how long to wait after the previous build finishes to start the next object’s 
build, type a value in the Delay field (or click the arrows).

You can specify a delay up to 60 seconds. You can specify a delay only if you choose to 
start the build automatically (rather than on click).

Moving Objects Off the Screen
You can make objects exit the slide in any order by making selections in the Build Out 
pane of the Build Inspector. If you have elements on a slide that build in and elements 
that build out, you can mix the build in and build out orders, so that any individual 
element might move on and off the screen before another one moves on the screen.

Drag items to 
reorder them.

Choose how to initiate 
the selected build.

Specify how long to wait 
after the previous build 
finishes to start the object 
build.
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Interspersing Build Elements
After you’ve set up object builds on a slide, you can create various effects by changing 
the order of builds and by specifying timing for the appearance of builds. For 
example, you can set up a build that brings the first text bullet onto the slide, then the 
first wedge of a pie chart, and then the second bullet. You can do the same to move 
objects off the slide. You can also specify a range of elements to be used in a build, 
such as only the second and third text bullets.

To intersperse an object's elements in a build:
1 In the Build Inspector, set Delivery options so that the build occurs by parts (by bullet, 

by wedge, and so on).

2 Select “Set separate timings for elements.” This option appears when the Delivery 
pop-up menu is set to anything but “All at Once.” Selecting “Set separate timings for 
elements” opens the Build Drawer if it's not already open.

3 In the Build Order drawer, drag the items to set the order in which the items occur.

4 Specify when and how to animate each object:

Â In the Build Order drawer, select an item in the list.

Â Choose an option from the Start Build pop-up menu. “On Click” Initiates the build 
when you click. “Automatically after build [#]” initiates the build with the build 
number indicated and after the amount of time specified in the Delay field.

Â Specify how long to wait after the previous build finishes to start the next object’s 
build by typing a value in the Delay field (or click the arrows). You can specify a 
delay up to 60 seconds. You can specify a delay only if you choose to start the build 
automatically (rather than on click).

Creating Text Builds
You can use builds to make text move onto or off of slides. Keynote provides options 
for building text line by line, word by word, or character by character. You can create 
text builds for bulleted or plain body text.

To set up a body text build:
1 Select the text and assign it a build effect, direction, duration, and order, using the 

Build Inspector as described earlier.

2 Choose a delivery style from the Delivery pop-up menu.

Â All at Once:  Moves all text in the text box at the same time.
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Â By Bullet:  Moves text bullet by bullet.

Â By Bullet Group:  Moves each bullet and its subordinate bullets together.

Â By Highlighted Bullet:  Highlights each bullet as it moves, leaving only the most 
recent bullet highlighted.

Creating Table Builds
You create object builds for slides with tables the same way you create any other 
object build. With tables, however, you can animate the table itself by making it 
appear onscreen row by row, column by column, cell by cell, or in a variety of other 
ways.

To set up a table build:
1 Select the table and assign it a build effect, direction, duration, and order, using the 

Build Inspector as described earlier.

2 Choose an option from the Delivery pop-up menu.

Â All At Once:  Moves the whole table as a single object.

Â By Row:  Moves the table onto the screen row by row.

Â By Column:  Moves the table onto the screen column by column.

Â By Cell:  Moves the table onto the screen one cell at a time.

Choose how to move 
text on or off the slide.

Choose an effect to 
make text appear or 
leave the slide.
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Â By Row Content:  Moves the entire empty table onto the screen, and then inserts 
the content row by row.

Â By Column Content:  Moves the entire empty table onto the screen, and then 
inserts the content column by column.

Â By Cell Content:  Moves the entire empty table onto the screen, and then adds the 
content cell by cell.

Note:  All elements of a table use the same build style.

Creating Chart Builds
Like table builds, chart builds offer a variety of ways to move chart elements on and 
off the screen during your presentation.

To set up a chart build:
1 Select the chart and assign it a build effect, direction, duration, and order, using the 

Build Inspector as described earlier.

2 Choose a delivery style from the Delivery pop-up menu.

Â All At Once:  Moves the whole chart as a single object.

Â Background First:  Moves each chart axis onto the screen, followed by all the data 
elements at once (bars, lines, or area shapes).

Â By Series:  Moves each chart axis onto the screen and then the data elements, one 
entire series at a time.

Â By Set:  Moves each chart axis onto the screen and then the data elements, one 
entire set at a time.

Â By Element in Series:  Moves the chart axes onto the screen, and then each 
separate data element, one series at a time.

Â By Element in Set:  Moves each chart axis onto the screen, and then each separate 
data element, one set at a time.

Note:  All elements of a chart (except the legend) use the same build style.
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You can assign a chart legend its own build style and order. To make the legend 
appear with the chart, group it with the chart before you set the chart’s build style 
(see “Grouping and Locking Objects” on page 65).

Creating Builds on Master Slides
You can add object builds to a master slide so that build effects appear on every slide 
you create using that master. For example, if you plan to create a number of slides 
with bulleted text, and you want each slide to build in bullet by bullet, create a master 
slide with the build you want. Then use that master to create the rest of your slides.

To create a build on a master slide:
1 Choose View > Show Master Slides.

2 Select the master slide for which you want to create a build.

3 Add text, objects, or images you want to include in the build.

4 Follow the steps in “Creating Object Builds” on page 145.
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88 Viewing, Printing, and 
Exporting Your Slideshow

This chapter describes the various ways to share 
your Keynote presentation. 
You can view a Keynote presentation from your computer on your own display or 
projected on a large screen. You can make the slideshow a self-running “movie” for a 
kiosk. You can share it across platforms by exporting it to formats such as a QuickTime 
movie, PowerPoint presentation, Flash file, or PDF document. You can also print 
directly from Keynote in a variety of page layouts.

Customizing a Presentation for Your Audience
You can make three different kinds of presentations in Keynote, depending on how 
the presentation will be used. 
Â Normal:  Presentations are controlled by clicking the mouse or using the keyboard. 

By default, a slideshow is normal (interactive) unless you make it a self-playing or 
hyperlinks-only slideshow.

Â Self-playing:  Presentations advance automatically, like a movie (no user interaction 
is possible). You can use this option, for example, to play a presentation in a kiosk 
setting. Instructions for creating these kinds of presentations follow.

Â Hyperlinks-only:  Presentations advance when viewers click hyperlinks. Instructions 
for creating these kinds of presentations follow.

Creating Self-Playing Presentations
If you want your presentation to run by itself, for example, as a kiosk demonstration, 
you can make it a self-playing presentation.
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In a self-playing presentation, transitions or builds set to begin automatically occur 
just as they do during a normal presentation. If a self-playing presentation includes 
transitions and builds set to begin on click, they will also occur automatically, after 
waiting the amount of time specified in the Delay fields in the Document Inspector. 
The values you specify in the Delay fields apply to all transitions and builds set to 
begin on click.

Although users can’t interact with these kinds of presentations, self-playing 
presentations can be stopped in the same way as other presentations (using the 
Escape key, for example). To prevent users from stopping a self-playing presentation, 
don’t provide a keyboard, or require a password to exit the presentation.

To make a slideshow self-playing:
1 Click the Inspector button in the toolbar (or choose View > Show Inspector), click the 

Document Inspector button, and then click Document.

2 Choose Self-playing from the Presentation pop-up menu.

3 To specify how much time to wait until transitions that start on click begin playing, 
type a value in the Transitions field (or click the arrows).

4 To specify how much time to wait until builds that start on click begin, type a value in 
the Builds field (or click the arrows).

You can also make a Keynote document begin playing as soon as it’s opened, so that 
the Keynote window doesn’t appear. 

To make a document play when it’s opened:
1 Open the document.

The Document 
Inspector button

Specify when to 
begin effects that 
begin “on click.”

Choose the kind of 
slideshow you want.
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2 In the Document pane of the Document Inspector, select the checkbox labeled 
“Automatically play upon open.”

3 To make the presentation play repeatedly (until the viewer quits by pressing the 
Escape key, for example), select “Loop slideshow.”

4 Choose File > Save.

To require a password to exit a slideshow:
m In the Document pane of the Document Inspector, select the checkbox labeled 

“Require password to exit show.”

The required user name and password are those of the current user or the 
administrator for the computer on which the slideshow is playing. 

To make a presentation start if it’s inactive for a specified period of time:
m Select “Restart show if idle for __” and type the number of minutes in the field.

Hyperlinks-Only Presentations
Using hyperlinks, you can create controls for navigating through a slideshow. The 
iWork Tour is an example of a hyperlinks-only presentation.

To make a hyperlinks-only presentation:
1 Set up your slideshow using hyperlinks to navigate to particular slides.

For more information about creating hyperlinks, see “Adding Webpages and 
Hyperlinks” on page 73.

2 In the Document pane of the Document Inspector, choose “Hyperlinks only” from the 
Presentation pop-up menu.

Using Exposé and Dashboard During a Presentation
To use Exposé, Dashboard, or other applications while you’re playing a slideshow, you 
need to set a Keynote preference so that those applications work during a 
presentation.

To allow Exposé, Dashboard, and other applications to work during a presentation:
1 Choose Keynote > Preferences.

2 Click Slideshow.

3 Select “Allow Exposé, Dashboard, and others to use screen.”
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Note:  Selecting this option may cause your slideshow to run more slowly and 
animations to display poorly.

Viewing Full-Screen Presentations
Full-screen presentations make the most of the crisp graphics and smooth animations 
made possible by Keynote. You can show full-screen presentations directly on your 
computer’s display, on a secondary display, or projected onto a large screen.

Viewing on Your Display
The simplest way to view a slideshow is by watching it directly on your computer’s 
display. This format works best for a very small audience.

To view a full-screen presentation on a single display:
1 Open the Keynote document.

2 Click Play in the toolbar (or choose View > Play Slideshow).

3 To advance to the next slide (or object build), press N or the Space bar, or click the 
mouse.

4 To end the show, press the Esc key or Q key.

Note:  Clicking Play starts the slideshow at the currently selected slide. To start the 
slideshow from the beginning (even if the first slide isn’t selected), press the Option 
key while you click Play.

Rehearsing Your Presentation
You can rehearse a slideshow to review presenter notes and fine-tune the timing of 
your presentation.

To rehearse your slideshow:
1 Choose View > Rehearse Slideshow.

Rehearsal view shows two slides at a time:  the current slide and the next slide. The 
clock below the current slide shows the time of day. The clock below the next slide 
shows time elapsed since you started playing the show.

2 Specify the information you want to appear in the presenter display (see “Customizing 
the Presenter’s View” on page 160). 

3 If your presenter notes don't appear, choose Keynote > Preferences > Presenter 
Display, and then select Notes. 
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When you’re rehearsing with a single display, the presenter display shows the 
information you specified in Presenter Display preferences. Comments are visible in 
the presenter display if they’re visible on the slide while editing.

Viewing on a Projector or Second Display
If you have a larger audience, you may want to play the slideshow on a second display 
or project it onto a large screen. That way, you can see presenter information (your 
slide notes and a clock, for example) on your display while viewers see only the 
slideshow on the second display. To do this, you set up your displays in a dual display 
configuration.

You can also play the identical slideshow on both screens. This setup is called video 
mirroring.

Important:  Attach the second display or projector according to the instructions that 
came with the display or projector, and the instructions that came with your 
computer (search Keynote Help for video mirroring, displays, or dual monitors). You 
may need to connect the second display or projector before you complete some of 
the following steps.

Note:  iBook computers with a second display connected work only in mirroring 
mode.

Dual Displays
With a dual-display configuration, you can play the slideshow on one screen while 
controlling the slideshow and viewing presenter information on another display.

To set up dual displays:
1 Choose Apple () > System Preferences.

2 In System Preferences, click Displays.

3 Click Arrange and follow the onscreen instructions.

If there is no Arrange button, your computer detects only one display.

4 Deselect the Mirror Displays checkbox.

To play a slideshow on a dual-display system:
1 Choose Keynote > Preferences, and then click Slideshow.
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2 Select “Present on primary display” or “Present on secondary display.” 

The primary display is the one with the menu bar. If you choose “Present on secondary 
display,” you can customize what the presenter sees on the primary display. See 
“Customizing the Presenter’s View” on page 160.

3 Click Play in the toolbar (or choose View > Play Slideshow).

4 Advance through the slides (and object builds) in the presentation by clicking the 
mouse or by pressing the Space bar.

Â To pause the presentation and show a black screen, press B. Press any key to 
resume.

Â To pause the presentation and show a white screen, press W. Press any key to 
resume.

Â To switch the primary and presenter display, press X.

For a complete list of movie and other presentation keyboard shortcuts, choose 
Help > Keyboard Shortcuts.

Video Mirroring
Some computers have video mirroring built in. If yours does not, you must configure 
it in the Displays pane of System Preferences.

To set up video mirroring:
1 Choose Apple () > System Preferences.

2 In System Preferences, click Displays.

Choose where slides display 
during a slideshow with a 
dual-display setup.
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3 Choose the same settings for both displays from the Resolutions field and the Colors 
pop-up menu.

4 Click Arrange and select Mirror Displays.

To play your slideshow on a mirrored system:
1 Open the Keynote document.

2 Choose View > Play Slideshow (or click Play in the toolbar).

3 To advance to the next slide or object build, press the Space bar or click the mouse.

Note:  Keynote generally plays back very smooth animations. However, because the 
two displays used in a video mirroring configuration may have different refresh rates, 
one of the screens may appear to “stutter”; Keynote can synchronize with the refresh 
rate of only one screen.

Viewing Movies
When you play a movie during a presentation, a movie control panel appears on the 
presenter display. The controls vary depending on the size of your movie. 

Finding Presentations With Keywords
You can add the author's name, the title, keywords, and comments to a Keynote 
presentation. You can then use Mac OS X Spotlight to search for presentations that 
contain that information.

To note author's name, title, keywords, and comments:
1 Open the Document Inspector window and click Spotlight.

2 Type the information you want to use for searches.

Later, when you want to find a certain presentation, use the Spotlight application to 
search for author's name, title, keywords, or comments.

If the movie is this size... These controls are available

Bigger than 380 pixels Play, pause, fast-forward, rewind, time track with timer, volume

260 to 379 pixels Play, pause, time track with timer, volume

160 to 259 pixels Play, pause, time track with timer

100 to 159 pixels Play, pause, time track without timer

0 to 99 pixels No controls
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Setting Presentation Options
You can set many options for your presentation, such as whether the pointer appears 
and what happens after the last slide. You can also set up the presenter’s display to 
show such information as elapsed time and the next slide.

Customizing the Presenter’s View
If you have a dual-display configuration for your presentation, or if you want to 
rehearse using a single display, you can select the information shown on the 
presenter’s display, and you can arrange the information however you want.

To turn on the presenter display:
1 Choose Keynote > Preferences and click Presenter Display.

2 Select “Use alternate display to view presenter information.”

To customize the presenter’s view:
1 Choose Keynote > Preferences and click Presenter Display.

2 Select the show options you want to appear on the presenter’s display.

3 To rearrange the windows on the presenter display, click Edit Presenter Layout.

Note:  Comments are visible in the presenter display if they’re visible on the slide while 
editing.

Select the show options 
that appear on the 
presenter’s display.

Select to view presenter 
information on an 
alternate display (during 
a slideshow with a 
dual-display setup).

Click to rearrange the 
windows on the 
presenter’s display.
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Controlling a Presentation With the Keyboard
You can use the keyboard to navigate through a presentation. (For a complete list of 
presentation keyboard shortcuts, choose Help > Keyboard Shortcuts.)

During a presentation, you can see a list of keyboard shortcuts that work in 
presentation mode. 

To show (or hide) the Presenter Keyboard Shortcuts window:
m During a presentation, press the Help or question mark (?) key on your keyboard.

During a presentation, you can easily move between slides using the slide switcher.

To open the slide switcher during a presentation:
m Type a slide number, or press the plus sign (+), equal sign (=), or hyphen (-).

When the slide switcher is open, you can navigate through slides in several ways:

Â To move forward or back through slides, press the Right or Left Arrow key, or click 
the arrows in the slide switcher to jump three slides.

Â To go to the first slide, press the Up Arrow key; to go to the last slide, press the 
Down Arrow key.

Â To close the switcher and go to a particular slide, click a thumbnail in the slide 
switcher, or type the slide number and press Return.
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Â To close the slide switcher without changing the current slide, press Escape.

When an object build is running on a slide, a red line appears on the display to warn 
you not to move to the next slide. The line turns green when the build is complete.

Pausing and Resuming a Presentation
There are several other ways to pause a presentation.

To pause a presentation, do one of the following:
Â To pause (freeze) the presentation and display the current slide, press F. To resume 

the presentation, press any key.

Â To pause the presentation and display a black screen, press B. To resume the 
presentation, press any key.

Â To pause the presentation and hide the application, press H. To resume the 
presentation, click the Keynote icon in the Dock.

During a presentation, clicking a hyperlink that opens a webpage, email message, or 
file also pauses the presentation. While a presentation is paused in this way, the 
Keynote icon in the Dock displays a green Play button. To resume the presentation, 
click the Keynote icon in the Dock. (You can also quit the presentation by pressing the 
Dock icon and choosing Exit Slideshow.)

For a complete list of presentation keyboard shortcuts, see the “Keyboard Shortcuts” 
topic in Keynote Help.

Changing the Slide Size
For highest-quality playback, your slide size should match the screen resolution of the 
default size, 800 x 600. Newer projectors may display slides at a resolution of 1024 x 
768. If your presentation includes movies, you may want to choose a higher 
resolution. Choose an HD theme with a resolution of 1920 x 1080 in this case; note 
that not all themes offer the higher resolution.

If your slide size is too large to fit the display, Keynote automatically scales it down to 
fit the screen. Note also that higher resolutions require more memory and faster 
processing.

To change the slide size of your Keynote document:
m In the Document Inspector, choose an option from the Slide Size pop-up menu.
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You can also specify a custom size by choosing “Custom slide size” in the Slide Size 
pop-up menu and then typing the dimensions you want in the Width and Height 
fields.

Note:  You must use the “Custom slide size” pop-up menu to specify a custom slide 
size. You cannot specify a custom size in the Theme Chooser.

If you’re not sure of the best slide size or you don’t want to change the original slide 
size in your document, Keynote plays the slideshow at its original size, centered on 
your display and surrounded by a black border. Or you can have Keynote scale the 
slideshow up to fit your screen when the slideshow plays. 

To fit the presentation to the display only during slideshow playback:
1 Choose Keynote > Preferences.

2 Click Slideshow.

3 Select the “Scale slides up to fit display” checkbox.

This option does not actually change the slide size of your Keynote document; it 
scales the document to fit the display. Some video quality may be lost during 
playback with this option. If you select this option and use the Cube or Flip transition, 
make sure to select “Reduce to avoid clipping,” or part of the transition may not be 
visible.

Changing Pointer Behavior During a Presentation
You can set up your slideshow so that the pointer appears only on slides containing 
hyperlinks, or only when the mouse moves.

To specify presentation options:
1 Choose Keynote > Preferences and click Slideshow.

2 Choose one of the “Show pointer” options.

During a slideshow, you can show or hide the pointer by pressing the C key.

Printing Your Slides
You can print your Keynote slideshow in a variety of ways to meet different needs. You 
can print slides with or without notes, or you can print the slideshow in outline form.
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To print slides:
1 Choose File > Print.

2 In the Print dialog, choose Keynote from the Copies & Pages pop-up menu.

3 Select a print option.

Â Individual Slides:  Prints one slide per page.

Â Slides With Notes:  Prints one slide per page with slide notes.

Â Outline:  Prints only the slide titles and bulleted text in the presentation (what you 
see in outline view in the slide organizer).

Â Handout:  Provides options for putting more than one slide on a page.

Note:  To speed up the printing of handouts, select “Draft-quality printout.”

4 Select the print formatting options that apply.

Â Don’t print slide backgrounds or object fills:  Doesn’t print color in the background 
or in an object; light text prints as black. This option is especially useful for printing 
colorful slides on black-and-white printers. On black-and-white printers, color 
images print in grayscale. On color printers, imported graphics files on each slide still 
print in color. 

Select print 
formatting options.

Choose Keynote from 
this pop-up menu.

Select which layout of 
slides and handouts you 
want to print.

Convert the set of 
slides to a PDF file.
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Â Print each stage of builds:  Prints one slide image for each stage of an object build. 
(A slide with a three-stage object build prints as three slides.)

Â Include skipped slides:  Prints all the slides in the slide organizer, even if they are 
marked as skipped.

Â Add borders around slides:  Prints a line around the edges of each slide.

Â Include slide numbers:  Prints the number at the bottom of each slide.

Â Include date:  Prints the date on each slide.

Â Print High Resolution 3D Charts:  Enhances print quality for 3D charts.

To print one slide or a specific range of slides:
1 Click Print.

2 Use the From and To text fields to enter the slide number or range you want to print.

You can see the slide number in the slide organizer.

Exporting to Other Viewing Formats
Other viewing options allow you to share your presentation across different platforms.

QuickTime
You can turn your slideshow into a QuickTime movie that includes all transitions and 
animated object builds. You can create a self-running QuickTime movie, with 
transitions and builds timed just as you set them. You can also create an interactive 
movie that allows viewers to advance through the movie at their own paces.

To create a QuickTime movie of your slideshow:
1 Choose File > Export.

2 In the Export dialog, select QuickTime.
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3 Choose an option from the Playback Control pop-up menu:

Â Interactive Slideshow:  Enables viewers to advance the slideshow by clicking Play in 
the QuickTime controls, clicking the mouse, or pressing the Space bar on the 
keyboard.

Â Hyperlinks only:  Viewers advance through the slideshow by clicking hyperlinks.

Â Self-Playing Movie:  Viewers have no control over the speed at which the slideshow 
advances. You determine the speed of object builds and how long slides linger on 
the screen by typing values in the Slide Duration and Build Duration fields.

Â Slide Duration:  Specifies how long the fully built slide remains on the screen after 
the last object build is complete.

Â Build Duration:  Specifies the number of seconds between the beginning of one 
build stage and the next in each object build. There is no delay between the 
moment a slide first appears on the screen and the first stage of an object build.

For self-playing movies, 
set slide and object 
build durations.

Play the movie once, 
repeatedly (loop), or 
forward and backward.

Choose an interactive 
movie or a self-playing 
movie.

Choose a compression 
format to optimize movie 
size and playback quality.

Select if the slideshow 
includes transparency 
you want to preserve.
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Â Repeat:  Sets the way self-playing slideshows continue to play. Choose Loop to play 
the show continuously. Choose “Back and Forth” to have the slideshow run to the 
end, run backward toward the beginning, and then run forward again. Choose None 
if you want the slideshow to play only once.

Â Enter full screen mode when opened:  Sets the slideshow to appear on the whole 
screen, rather than in a window.

4 For a self-playing movie, you can choose an option from the Repeat pop-up menu.

5 Choose a playback quality and file size from the Formats pop-up menu.

Â Full Quality, Large:  Preserves the best playback quality, but these movies are large 
and are therefore more difficult to transfer through email or the web.

Â CD-ROM Movie, Medium:  Best if you are using a CD to send the slideshow to 
another viewer. These movies are high in quality but have somewhat smaller file 
sizes than full-quality movies.

Â Web Movie, Small:  Movies generally have poorer playback quality but are small 
enough to be shared across the web or through email.

Â Custom:  Choose your own QuickTime compression settings for video and audio so 
that you can control the tradeoff between file size and quality.

6 If you don’t want to include audio files in the movie, deselect “Include audio.”

7 If your slideshow has a transparent background you want to preserve in your 
QuickTime movie, select “Include transparency.”

Note:  Some transitions might not work correctly with this option selected.

8 Click Next.

9 Type a name for your movie, choose a location in which to store it, and click Export.

PowerPoint
You can convert Keynote documents to PowerPoint files that can be viewed and 
edited by PowerPoint users on Windows or Mac OS computers.

To create a PowerPoint slideshow:
1 Choose File > Export.

2 Select PowerPoint and then click Next.

3 Type a name and choose a location for the file.

4 Click Export.
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Note:  Windows and Mac OS X don’t handle graphics in the same way, so you may 
notice slight variations in your slideshow graphics when you open an exported 
PowerPoint document on a Windows computer.

PDF Files
Your slideshow can be converted to a PDF file, which can be viewed or printed in 
Adobe Acrobat Reader or any PDF application. There are two ways to save your 
Keynote slides as PDF files. If you intend to view the PDF file online, use the Keynote 
Export command. If you intend to view the file on a hardcopy printout, you might get 
better results using the Print command.

If your slideshow contains hyperlinks, they are exported as active links in the PDF 
document.

To create a PDF file of your slides using Export:
1 Choose File > Export.

2 Select PDF.

3 Select Slides or Slides With Notes, and select the options you want for exporting build 
stages, skipped slides, borders, and slide numbers.

4 Click Next, type a name, and choose a location for the file.

5 Click Export.

To create a PDF file of your slides using Print:
1 Choose File > Print.

2 Click PDF, and choose “Save as PDF” from the pop-up menu.

3 In the Save dialog, type a name, choose a location for the file, and then click Save.

Image Files
You can export all your slides as image files in JPEG, PNG, and TIFF formats.

To export slides as image files:
1 Choose File > Export.

2 Click Images and specify whether you want to create a separate file for all the slides or 
for a range of slides.

3 To create a separate image for each build stage, select “Create an image for each stage 
of builds.”
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4 To export images to iPhoto 5 or later, select “Export images into iPhoto,” name the 
new album, and click OK.

5 Choose an option from the Format pop-up menu to specify the image quality you 
want.

The better the quality, the larger the file size. If you choose “Variable quality” (JPEG 
only), use the Quality slider to specify a percentage between low and high quality.

6 Click Next, type a name, specify a location for the image files, and click Export.

The files will use your typed name with a sequential number appended at the end 
(filename.001, filename.002, and so on).

Flash
You can turn your slideshow into a Flash document that can be viewed with the Flash 
viewer.

To convert your slideshow to a Flash document:
1 Choose File > Export, and then click Flash.

2 If you don’t want to include the slideshow’s soundtrack, deselect “Include the 
slideshow audio file (soundtrack).” This option is on by default.

3 Click Next, type a name, and choose a location for the file.

4 Click Export.

iDVD
You can export a slideshow as an iDVD project that can be viewed and edited with 
iDVD 6 or later.

To export slides to iDVD format:
1 Choose File > Export.

2 Select iDVD and specify the video size.

Â Standard:  Exports the slides for viewing on a standard video display.

Â Widescreen:  Exports the slides for viewing on a widescreen video display.

3 Choose the quality you want from the Video Quality pop-up menu.

4 Type the number of seconds you want for slide and build durations.

5 Click Next, type a name, specify a location for the exported file, and click Export.
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HTML
You can export your slides to an HTML document that can be viewed with Safari or 
another web browser. Viewers click hyperlinks to advance the presentation.

To export slides to an HTML document:
1 Choose File > Export.

2 Click HTML and specify whether you want to export all the slides or a range of slides.

3 To create a separate image for each build stage, select “Create an image for each stage 
of builds.”

4 To include the Home, Previous, and Next navigation controls, select “Include 
navigation controls.”

5 Choose an option from the Format pop-up menu to specify the image quality you 
want.

The better the quality, the larger the file size. 

6 Drag the Compression slider to increase or decrease the compression factor used for 
the export (JPEG only).

7 Click Next, type a name, specify a location for the exported file, and click Export.

iWork ‘05 Format
You may want to export a presentation to iWork ‘05 format so that the slideshow can 
be viewed by others working with an earlier version of Keynote. New features 
included in iWork ‘06, such as 3D charts and table formulas, will be converted or not 
saved when the presentation is opened in iWork ‘05. Other elements, such as audio 
and movie files, will work the same.

To export a presentation to iWork ‘05 format:
1 Open the slideshow you want to export.

2 Choose File > Save As.

3 Type a name for the file and select a location.

4 Select “Save a copy in iWork ‘05 format.”

You may need to click the disclosure triangle next to the Save As field to see this 
option.
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5 If you don’t want to include audio and movie files in the export, click Advanced 
Options, and deselect “Copy audio and movies into document” (this option is on by 
default).

6 Click Save.
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9 Designing Your Own 
Master Slides and Themes

This chapter is for designers who want to use the 
powerful graphics capabilities in Keynote to create 
their own master slides and themes.
This chapter assumes you are already familiar with the Keynote design and formatting 
features described in previous chapters.

The themes that come with Keynote are sets of master slide layouts, backgrounds, 
charts, tables, and text styles. Within each theme, master slides define the following 
slide attributes:

Â Default position of title and body text

Â Background graphics

Â Default fonts

Â Default bullet styles

Â Default position for charts, tables, and images (the object placeholder)

Â Object fills and line styles for drawn objects and tables

Â Chart style

Â Slide transition style

Â Alignment guides

You can modify any of these attributes to customize any master slide within a theme. 
When you change a master slide, the changes appear on every slide that uses that 
master. You can modify a master slide without affecting the default themes available 
in other Keynote documents. 
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You can also modify and save a whole set of master slides to create your own theme, 
customizing it with your company logo or styling it with your own designs. If you 
want to save a set of customized master slides to use in other presentations, you can 
save the set as described in “Saving a Custom Theme” on page 180.

To work on a master slide:
m Open the master slide organizer and select a master slide.

To open the master slide organizer:
m Click View in the toolbar and choose Show Master Slides (or choose View > Show 

Master Slides).

An easy way to get a modified slide layout is to import a single slide or master slide 
from another slideshow into the current slideshow.

To import a single slide or master slide:
1 Open the Keynote document that contains the slide you want.

2 Select the slide and drag it from the source document to the slide organizer of the 
document you are working in.

A new master slide is created in your Keynote slideshow. You can find the new master 
slide in the master slide organizer.

Note:  You can create builds for objects on a master slide. For information, see 
“Creating Builds on Master Slides” on page 152.

Modifying Master Slide Backgrounds and Layouts
The easiest way to design a new master slide is to start with an existing master that 
closely resembles what you want. Scroll through the slides in the master slide 
organizer and duplicate the one you want to start with.

To duplicate a master slide:
1 Select the master slide in the master slide organizer.

2 Do one of the following:

Â Click New (+) in the toolbar.

Â Choose Slide > New Slide.

Â Press Return on the keyboard.
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Â Choose Edit > Duplicate.

You can modify master slides using the Master Slide Inspector.

To open the Master Slide Inspector:
1 Select a master slide in the slide organizer.

2 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Slide Inspector button.

3 Click Appearance.

Changing the Background
One way to create groups of related slides within a presentation (for example, to 
distinguish or unify different topics) is to incorporate a subtle difference in the 
background of each set of slides. To do so, you create a set of master slides with each 
of the different backgrounds.

To modify a master slide background:
1 In the master slide organizer, select the master slide you want to modify.

Choose a background 
color or image.

Create a place for tables, 
charts, web views, and 
imported graphics to appear.

Place title and body text 
boxes on master slides.

Select to allow objects on 
slides to interleave with 
objects on the master.
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Â If you are building a completely new background, you may want to begin with a blank 
master.

Â If you want to retain a copy of the original master, do one of the following to create a 
duplicate of the master slide:

Â Choose Slide > New Slide.

Â Click New in the toolbar.

Â Choose Edit > Duplicate.

2 Select unwanted elements and press the Delete key.

3 Make your changes to the master.

Â Use Keynote tools to place background elements on the master slide.

Â Drag external objects (movie files, sound files, and so on) from the desktop or the 
Media Browser to the slide canvas.

4 After you place an element where you want it, you can choose Arrange > Lock to 
prevent the element from being accidentally moved as you work.

Any changes you make (including external files you add) to this master slide will 
appear on every slide based on this master.

Layering Background Objects and Objects on Slides
When you edit a master slide, you can move objects forward and backward just as you 
can on slides. All objects on a master stay in their own master slide layer, which, by 
default, is on the bottom. Objects you add to slides sit on top of any object on the 
master. You can, however, place each object you add to individual slides on top of or 
behind all master layer objects.

A common use of background layers is for alpha-channel graphics in which slide 
objects show through part of the background image. For more information, see 
“Working With Photo Cutouts (Alpha-Channel Graphics)” on page 66.

To make objects on a master slide layer with slide objects:
1 Place objects on the master slide canvas, positioning and layering them as you want.

2 In the Master Slide Inspector, select “Allow objects on slide to layer with master.”

Note:  You can move placeholders forward or backward on a master or a slide. For 
more information, see “Resizing, Moving, and Layering Objects” on page 62.
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Adding Alignment Guides
You can create your own alignment guides to help you place your text and graphics 
consistently on each slide. Alignment guides created on a master slide are available 
when you are placing objects on any slides based on that master.

To create alignment guides on a master slide:
1 In the Appearance pane of the Slide Inspector, select the master slide to which you 

want to add the alignment guides.

2 Click View in the toolbar and choose Show Rulers.

3 Place the pointer on a ruler and drag the yellow alignment guide wherever you want 
on the slide canvas.

Â To place a horizontal guide, drag from the ruler at the top of the slide.

Â To place a vertical guide, drag from the ruler on the left side.

Designing Title and Body Text Layout and Styles
Default styles for title and text boxes are defined by a slide’s master. To set the title or 
text defaults on a master slide, you place text boxes on the master slide and then 
select the text and set its attributes using the inspectors, as you would set text 
attributes on any slide. As you change the text settings, you can preview the new 
settings by creating a slide in the slide organizer, applying the new master slide 
settings, and trying them out with some text.

To place title and body text boxes on a selected master slide:
1 Open the Master Slide Inspector and click Appearance (if it is not already selected).

2 To add a title text box, select the Title checkbox.

3 To add a body text box, select the Body checkbox.

Depending on the theme and master, the default text style may be bulleted. To set a 
default style without bullets, see “Formatting Bulleted Text and Numbered Lists” on 
page 46.

4 To include subtitle text, resize the body text box and place it under the title text box.

5 Resize and rearrange the text boxes as desired.

6 Select the placeholder text and format it with your preferred styles. 

In the text box, you can define attributes for up to five levels of text.



Chapter 9    Designing Your Own Master Slides and Themes 177

For information about setting line spacing, text indents, and tabs, see “Changing Text 
Alignment and Spacing” on page 47 and “Setting Tabs and Text Indents” on page 49.

Applying Your Changes as You Work
As you work on a master slide, you can try out your changes on a normal slide to get a 
better sense of how the new layout will look. By going back and forth between the 
“test” slide and the master slide, you can make fine adjustments, such as making lines 
longer or shorter or adding multiple indent levels. Seeing a slide with text on it is 
especially useful when adjusting tab stops and line spacing.

To create a test slide in the slide organizer, create a slide based on the master; if you 
make changes to the slide that override the master, reapply the master to the test 
slide each time you make a change. 

To reapply the master slide to a slide in the slide organizer:
m Select the slide in the slide organizer, then choose Format > Reapply Master to Slide.

Setting Default Slide Transitions
You can specify a default transition style for any master slide. Slides based on this 
master use the specified style to go to the next slide.

To set the default transition style for a master slide:
1 Select the master slide in the master slide organizer.

2 In the Transition pane of the Master Slide Inspector, choose a transition effect, 
duration, and direction.

3 Use the Start Transition pop-up menu to choose where the transition should occur on 
click or automatically.

4 Type a number to specify the delay for the transition.

For more information about slide transitions, see “Adding Transitions Between Slides” 
on page 143.
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Changing Default Styles for Text and Objects
You can modify the default attributes of objects such as shapes, text boxes, tables, and 
charts. For example, you can set it up so that every time you click Table in the toolbar, 
the default table contains a certain number of rows and columns, has header and 
body text in a particular font, and has borders formatted with specific colors and line 
thicknesses. 

For text boxes and shapes, you can set up the defaults with your preferred fonts, 
colors, opacity, shadows, and so on. For charts, you can specify which chart type (pie, 
line, and so on) to make the default. (You must set default attributes for each chart 
type separately.)

First you design the object so that it has the desired default attributes. Then you 
define the properties as the default for the current master or for all masters in the 
theme.

To set default attributes for text boxes, shapes, and graphics:
1 In the slide organizer, create a new slide based on the master slide you are designing.

2 Place a text box, shape, or graphic on the slide canvas.

3 Set the item’s attributes with the properties you want to incorporate into the default.

Â For a text box, type text into the box, select the text, and set its attributes.

Â For a shape or graphic, select it and set its attributes.

4 When the item is formatted as you wish, make the new properties the defaults by 
selecting the item and doing one of the following:

Â To assign new defaults for only the master slide you’re working on, choose Format > 
Advanced > Define [object] for Current Master.

Â To assign new defaults for all the master slides in the theme, choose Format > 
Advanced > Define [object] for All Masters.

5 Delete the text box, shape, or graphic from the slide.

To set default table attributes:
1 In the slide organizer, create a new slide based on the master slide you are designing.

2 Place a table on the slide canvas.

3 Select the table and set its attributes. (For more information, see Chapter 5, “Creating 
Tables.”)
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Important:  A table has four distinct formatting areas:  header row, header column, 
inside borders, and outside borders. To make changes, you must set all the elements 
in a formatting area. For example, to set a new default for header rows you must 
change all the cells in the header row (not just one cell).

4 When the table is formatted as you wish, make the new properties the defaults by 
selecting the table and doing one of the following:

Â To make the table’s attributes the default for the current master, choose Format > 
Advanced > Define Table for Current Master.

Â To make the table’s attributes the default for all the masters in the current theme, 
choose Format > Advanced > Define Table for All Masters.

5 Delete the table from the slide.

To set default chart attributes:
1 In the slide organizer, create a new slide based on the master slide you are designing.

2 Place a chart on the slide canvas.

3 Select the chart and set its attributes. (For more information, see Chapter 6, “Creating 
Charts.”)

4 To define defaults for another chart type, copy the chart and paste it on a new slide, 
change the chart type, and set the chart attributes. Repeat this step for each chart 
type.

5 When all the charts are formatted as you wish, select each of them, one at a time, and 
make the new properties the default by doing one of the following:

Â To make the chart’s attributes the default for the current master, choose Format > 
Advanced > Define [chart] for Current Master.

Â To make the chart’s attributes the default for all the masters in the current theme, 
choose Format > Advanced > Define [chart] for All Masters.

Â To make the chart’s type the default for all master slides in the current theme, 
choose Format > Advanced > Make [chart] the Default Chart Type.

6 In the dialog that appears, specify the total number of series for which you are 
defining attributes.

7 Delete the charts from the slides.
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Saving a Custom Theme
If you modify master slides in a theme and you want to use these modifications again 
in other slide presentations, you can save the modified theme as a custom theme. 
After you save your custom theme, it appears in the Theme Chooser. When you select 
your custom theme, it comes with all the master slides you defined.

To save the current theme as a custom theme:
1 Choose File > Save Theme.

2 Type a name and choose a location for the theme.

3 If you added sound or movies that you want to include in the theme, select “Copy 
audio and movies into document.” (You may need to click the disclosure triangle in 
the Save dialog to display this checkbox.)

Note:  Saving media files with a document makes the file much larger.

4 Click Save.

Unless you specify another location, custom themes are saved in the Themes folder on 
your hard disk ([home]/Library/Application Support/iWork/Keynote/Themes). Only 
themes in this folder appear in the Theme Chooser. If you store your theme in another 
location, you can still open it as a blank Keynote document and work directly in it to 
create a slideshow.

Restoring Original Theme Defaults
If you modify master slides in a document and later want to return to the original 
theme defaults, you can do so by reapplying the theme to your document.

To restore the theme defaults:
1 Choose File > Choose Theme, and then select the original theme and presentation 

size.

2 Make sure “Retain changes to theme defaults” is not selected.

3 Click Choose.
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Creating a Custom Theme
If you want to create an entirely new theme that is not based on any of the existing 
Keynote themes, the easiest way is to start in a new Keynote document with only a 
single, blank master slide. Delete all other master slides from the document. Keep the 
following tips in mind:

Â Design and place shared background elements and body and title text first.

Â On a sample slide, test your text layouts to be sure they work with wrapped text 
lines. Consider how many bullets you want to fit in a body text box when you set its 
size and placement.

Â Set up all text and background attributes before creating new master slides.

Â Create a variety of body and title text layouts using copies of the original master 
slide. New master slides made from copies of that first one automatically inherit all 
of its text and background attributes. Then you only have to adjust the text box 
layouts (for example, remove the title text box and expand the body text box for a 
“body only” master slide).

Â Create sample slides in the slide organizer based on each master you design and 
place free text boxes, shapes, tables, and images on each one, if you want the 
default object attributes to be different on different master slides. (If you want to set 
the same default object attributes for all masters, you need to do this for only one 
master slide.)

Â Create eight sample slides in the slide organizer based on each of your master slides. 
Design a chart on one slide, and then copy and paste it onto each of the slides. Then 
convert each chart to a different chart type, and set its size and position. Do this 
step before you define default chart styles using the Format menu.
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page numbers. See slide numbers
pausing a presentation  162
PDF files  61, 168
photo cutouts  66
pie charts  136–137
playback volume  72
playing a slideshow  44, 161
pointer  77
pointer, appearance during presentation  163
poster frame  73
PowerPoint

exporting to  167
importing from  33

Preferences
General pane  25, 34, 43, 76
Rulers pane  40–41
Slideshow pane  77, 157
System  157, 158

presentations
controlling with keyboard  162
hyperlinks only  35, 155
self-playing  35, 153
setting up displays for  156–160
showing or hiding the pointer during  77

presentation size  34, 162
presenter display  160–162
printing  163–165

notes  163–165
outline view  26

Q
QuickTime  165
QuickTime Inspector  72

R
rehearsing a slideshow  156
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resizing objects  92
resuming a paused presentation  162
Retain changes to theme defaults  180
rotating objects  63, 91, 138
rulers  39–41

changing unit of measure used  39
setting tabs  49

Rulers preferences  40–41

S
saving

a previous version  43
documents  43
sound and movies  43, 68
theme images  43

“Scale slides up to fit display” checkbox  145, 
163

Scale to Fill  84
Scale to Fit  84
scatter charts  140
self-playing presentations  35, 153
Send Backward command  62
shadows  86
shapes  54–60

creating custom  54
editing a polygon  59
editing a rounded rectangle  58
editing a star  59
editing shape contours  56
editing single and double arrows  58
using as masks  65

shortcut menu  99
shortcut menus  32
shortcuts, keyboard  31, 162
size of slides  34, 162
skipping slides  23
slide canvas  20
Slide Inspector  78, 144
slide numbers  75, 78, 161, 165
slide organizer  21
slides

adding  23, 35
backgrounds  78

deleting  24
indenting  23
layouts  77
masters  36
moving  23
organizing  21
printing  163–165
showing and hiding  23
skipping  23

Slideshow preferences  77, 157
slideshows, kinds of  35, 153
slide switcher  161
sorting table rows  108
sound  68, 72
space around text (Inset Margin)  51
spacing, of text  48
Spotlight  159
spreadsheets  129
Stretch  84
Stroke pop-up menu  85, 104
Symbol Fill pop-up menu  139
System Preferences  157, 158

T
Table  94
table

adding rows and columns  99
delete rows and columns  100
formulas  110
number of rows and columns  99

table cells
aligning text in  103
autofilling  109
automatically fit contents  102
deleting contents  98
formatting numbers  106
merging or splitting  100
resizing  102
selecting  96
splitting  101

Table Inspector  93–95, 97–103
tables  93–105

building in stages  150
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selecting  96
tabs  49–50
technical support  18
text

adding bullets  37
adding to a master slide  176
adding to shapes  59
adjusting indents  50
adjusting spacing  48
aligning  47
animating  149
building in stages  149
changing color  47
changing font  46
free text boxes  45
in charts  132
in tables  103

text columns  52
Text Inspector  46–51
Theme Chooser  34, 180
themes

changing  34, 172–181
copying theme images into a document  43
resetting default  79
saving custom  180
selecting  33
setting default for new documents  34
using multiple in a document  42

three-dimensional charts  141
Tile  84
titles

adding to a master slide  176
adding to a slide  37, 77

toolbar
about  28
customizing  29

tour  17
transitions

between parts of a slide (object builds)  145
between slides  143
setting default  177

transparency  66, 88, 166, 167

types of slideshows  35

U
undoing  79
units of measure

changing  40
unmasking images  65
URLs  73, 75, 76
“Use alternate display to view presenter infor-

mation” checkbox  160

V
video mirroring  158
volume  72

W
webpages  73–77
web view  73

X
X and Y coordinates  92

Z
zooming  21
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