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COPYRIGHT AND LICENSE AGREEMENT
THIS IS A CONTRACT. BY OPENING ANY OF THE SEALED SOFTWARE CONTAINERS, YOU ACCEPT ALL THE TERMS 
AND CONDITIONS OF THIS AGREEMENT. If you do not agree with the terms and conditions of this Agreement, return 
this entire package and the UNOPENED software containers to your place of purchase for a full refund.

1. Definitions
(a) “Deneba” means Deneba Systems, Inc., a Florida Corporation d/b/a Deneba Software.
(b) “Software” means the software programs included in this package.
© “Fonts” means all font software included in this package.
(d) “Clip Art” means all art, templates, and photos included in this package.
(e) “Product” means all Software, Fonts, Clip Art, manuals and other related documentation included in this package as 
well as all future related updates supplied by Deneba.

2. License - Deneba grants to you and you hereby accept a license to use the Product and all related materials delivered 
with this AGREEMENT as follows:
(a) The Software and Clip Art may be installed in one computer and may be used by more than one person on that com-
puter; however, in no event shall two or more persons use the Software and Clip Art at the same time. This restriction 
applies regardless of how many operating platform versions (e.g. Macintosh® and Windows®), language versions (e.g. 
English, German, French, Italian or Japanese) or media copies (e.g. diskette or CD-ROM) may be included in this Product.
(b) You may make one copy of the Software, Clip Art and Fonts in machine-readable form for archival backup purposes 
only. As an express condition of this allowance you must reproduce on each backup copy any copyright notice or other 
proprietary notice that is on the original copy supplied by Deneba.
© You may transfer the entire Product and all rights granted herein on a permanent basis provided you retain no copies, 
the recipient agrees to the terms of this Agreement, and you notify Deneba in writing of the transfer of ownership.
(d) You may use the Fonts on a single computer and printer. A printer includes any output device such as, but not limited 
to, dot matrix, ink jet or laser printers, film recorders and image-setters. When using an outside service bureau, one copy 
of the Fonts may accompany the document in which the Fonts have been used. You must remove this copy from the ser-
vice bureau's storage media upon completion of the service.
(e) You have the right to use, modify, and include Clip Art as illustrative or decorative material that is included as part of a 
total original graphic of your own design for use in print, film or computer media communications.

3. Restrictions
(a) You may not make or distribute copies of the Product. You should be aware that it is unlawful to copy, reproduce, or 
transmit any part of the Product in any form or by any means (including translation to another language, computer lan-
guage, or format) except as permitted by the Copyright Act of the United States (Title 17, United States Code). You are 
permitted to write the contents of the Software into the machine memory of your computer so that the software can be 
executed.
(b) You are not permitted to give, lend, or distribute your Product serial number to any individual or group.
© You may not install this program on a network server nor lend usage of a copy of this software with metering software. 
These types of usage require a special license, unless a copy of this software is owned for each user on that network or 
each computer connected to that network. For information on this expanded license usage see section 4, Supplementary 
Licenses in this agreement.
(d) In order to protect Deneba trade secrets contained therein which may be revealed by such action, you may not reverse 
engineer, decompile, disassemble or otherwise reduce the Software or Fonts to any human readable or perceivable form.
(e) You may not modify, rent, resell for profit, distribute or create derivative works based on the Software or any part 
thereof.
(f) You may not resell or otherwise distribute the Clip Art contents, whether by themselves or as part of another collection, 
whether as computer images, printed images or any other medium. These restrictions apply to modifications of the Clip 
Art, whether or not they constitute derivative works under U.S. copyright laws, as well as to the original Clip Art.
(g) You agree not to modify, adapt or create derivative works based on the Fonts. Unauthorized copying of the Fonts, 
even if modified, merged, or included with other software is expressly forbidden.
(h) You agree not to export or reexport the Product into any country prohibited by the United States Export Administration 
Act.

4. Supplementary Licenses - If you wish to enter into a site license, network license or concurrent-use license agreement, 
or for more information on licensing the Fonts for additional printers, please contact Deneba.

5. Termination - Any failure to comply with the terms and conditions of this Agreement will result in automatic termination 
of this license. Upon termination of this license for any reason, you agree to destroy all copies of the Product.

6. Software Updates - Deneba may from time to time, at its own discretion, provide you with updates to the manuals and/
or Software. Deneba reserves the right to provide these updates for a fee. You may refuse to accept the updates. By 
accepting the updates, you agree to destroy all prior copies and versions of the Software and manuals (if applicable). Only 
then will the License granted to you by this Agreement transfer to the updated Software.

7. Ownership - This license gives you limited rights to use the Software, Fonts and Clip Art. Although you own the disks 
and CDs on which these are recorded, you do not become owner of the Software, Fonts and Clip Art, to which Deneba 
and/or its licensors retain all title to. All rights not specifically granted herein, including but not limited to Federal and Inter-
national Copyrights, are reserved worldwide by Deneba.

8. Limited Warranty and Disclaimer, Limitation of Remedies and Damages - You hereby acknowledge that you are solely 
responsible for selecting the Product and that the Product may not satisfy all your requirements or be free from defects. 
Deneba specifically does not warrant that the Software will operate uninterrupted or error free. You therefore agree to 
license the Product “AS IS.” Notwithstanding the foregoing, Deneba warrants to you (the original purchaser), that if you 
discover physical defects in the media on which the Software, Fonts and Clip Art is recorded, or in the manuals distributed 
with the Product, Deneba will replace the media or manuals at no charge, provided you return the defective items, post-
age prepaid and with proof of purchase, within 90 days of the date of original purchase. Your exclusive remedy for breach 
of warranty will be the replacement of the diskettes, CDs or manuals or the refund of the purchase price.
iii



 

iv

  
Deneba reserves the right to revise the Product without obligation to notify any person of such revision. In no event shall 
Deneba or its developers, directors, officers, employees or affiliates be liable to you for any indirect, special, incidental, or 
consequential damages (including damages for loss of business profits or goodwill, business interruption or loss of busi-
ness information), resulting from any defect in the Product whether foreseeable or not, arising out of the use or inability to 
use the Product. Deneba's liability to you or others for actual damages for any cause whatsoever, will in no event exceed 
the lesser of US $500 or the amount paid by you for the Product that caused the damages. In particular, Deneba shall have 
no liability for any data stored in or used with Deneba Products, including the cost of recovering such data.

EXCEPT AS SPECIFICALLY STATED HEREIN, DENEBA MAKES NO OTHER WARRANTIES, EXPRESSED OR IMPLIED, 
WITH RESPECT TO THE SOFTWARE, MEDIA, CLIP ART, FONTS OR MANUALS INCLUDING (BUT NOT LIMITED TO) 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE WARRANTY AND 
REMEDIES SET FORTH ABOVE ARE EXCLUSIVE AND IN LIEU OF ALL OTHERS, ORAL OR WRITTEN, EXPRESSED OR 
IMPLIED. IF APPLICABLE LAW IMPLIES ANY WARRANTIES WITH RESPECT TO THE PRODUCT, ALL SUCH WARRANTIES 
ARE LIMITED TO NINETY DAYS (90) FROM THE DATE OF DELIVERY. No Deneba dealer, agent, or employee is autho-
rized to make any modification, extension, or addition to this warranty.

Some states do not allow limitations on how long an implied warranty lasts or the exclusion or limitation of implied warran-
ties or liability for incidental or consequential damages, so the above limitation or exclusion may not apply to you. This 
warranty gives you specific legal rights and you may also have other rights which vary from state to state.

9. U.S. Government Restricted Rights - This Deneba Product is “Restricted Computer Software.” Use, duplication, or dis-
closure by the Government is subject to restrictions as set forth in subparagraph ©(1)(ii) of the Rights in Technical Data and 
Computer Software clause at DFARS 252.227-7013 or subparagraphs ©(1) and (2) of the Commercial Computer Software 
- Restricted Rights at 48 CFR 52.227-19, as applicable. The manufacturer is Deneba Systems, Inc., 7400 S.W. 87th Avenue, 
Miami, Florida 33173.

10. General - This agreement shall be governed by the laws of the State of Florida. This document contains the entire 
agreement between you and Deneba with respect to the subject matter hereof and supersedes all prior agreements 
between you and Deneba. All questions concerning this agreement should be sent to: Deneba Systems, Inc., Attn. Chief 
Financial Officer, 7400 S.W. 87th Avenue, Miami, Florida 33173.

LICENSES, TRADEMARKS AND COPYRIGHTS

Canvas Software was designed, programmed and is Copyright © 1985-1999 Deneba Systems, Inc. All Rights Reserved. 
Canvas and Deneba are trademarks of Deneba Systems, Inc. and may be registered in certain jurisdictions. Contains an 
implementation of the LZW algorithm licensed under U.S. Patent 4,558,302 and foreign counterparts. The Proximity/Mer-
riam-Webster Hyphenation System ©1990 Merriam-Webster, ©1990 All rights reserved Proximity Technology, Inc. Image 
Stream® Graphics & Presentation Filters Copyright © 1991-1998 Inso Corporation All Rights Reserved. Portions of the 
graphics filters © 1998 Access Softek. Trumatch 4-Color Selector © 1998 Trumatch, Inc. Toyo Color Finder and Color Data 
Copyright © 1998 Toyo Ink Mfg. Co., Ltd.

Windows®, Windows 95, Windows 98, Windows NT, Windows 2000 are trademarks of Microsoft Corp. Mac OS, Quick-
Draw, QuickDraw 3D, QuickTime, and TrueType are trademarks, and Apple, LaserWriter, Macintosh and Power Macintosh 
are registered trademarks of Apple Computer, Inc. Adobe, Adobe Illustrator, Adobe Photoshop, and PostScript are trade-
marks of Adobe Systems, Inc. which may be registered in certain jurisdictions. QuickHelp is a trademark of Altura Software, 
Inc. Toyo is a trademark of Toyo Ink Manufacturing Co., Ltd. Trumatch is a registered trademark of Trumatch Inc. MacPaint 
is a registered trademark of Claris Corp. Photo CD is a trademark and KODAK is a registered trademark of Eastman Kodak 
Co. PANTONE®* Computer Video simulations used in this product may not match PANTONE-identified solid color stan-
dards. Use current PANTONE Color Reference Manuals for accurate color. *PANTONE Color Computer Graphics © Pan-
tone, Inc. 1986, 1988. Pantone, Inc. is the copyright owner of PANTONE Color Computer Graphics and Software which 
are licensed to DENEBA SOFTWARE to distribute for use only in combination with Canvas. PANTONE Color Computer 
Graphics and Software shall not be copied onto another diskette or into memory unless as part of the execution of Canvas. 
All other brand and product names are the property of their respective holders.

FONTS Copyright © 1992 URW++ GmbH Hamburg, Germany and URW America, Nashua, NH. All Rights Reserved.

CLIP ART   Copyright © 1986-1999 Deneba Systems, Inc.

© Copyright 1999 Deneba Systems, Inc.
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INTRODUCTION

Welcome to Canvas 7, a completely integrated environment for il
tration, page layout, imaging, presentations, and web publishing. 

Canvas lets you work with vector objects, images, type, and impor
graphics without having to switch to other applications. Whether y
are a beginner or an experienced designer, the tools and features
Canvas can make you more productive. 

Canvas provides a complete solution for home, small business, 
school, and corporate users:

• An array of tools for illustration, layout, editing, proofing, 
and final output, so you can take projects from start to fini
in Canvas.

• A flexible interface, including a Toolbar you can configure
with commands, tools, and styles; a Docking bar to store
palettes; and customizable keyboard shortcuts. 

• A cross-platform solution that lets you share Canvas doc
ments across Mac OS and Windows platforms, and suppo
all standard file formats.

About the documentation
Please take a few minutes to read the following information about
Canvas documentation.

This book, the Canvas User’s Guide, describes the commands, tools
and features of Canvas for Mac OS and Windows operating syste

Certain terms and abbreviations are used in this manual to descr
procedures. In most cases, Canvas works exactly the same under
OS and Windows. The documentation points out functional differ-
ences when necessary. 

Mac OS refers to the Mac OS operating system. When a procedu
applies to Mac OS only, the instructions say “(Mac)”. 

Windows refers to 32-bit Windows, including Windows 98 and Win
dows NT. When a procedure applies to Windows only, the instruc
tions say “(Windows)”.

✔Tip
Throughout this book you’ll 
find tips for working efficiently 
and exploring creative possibil-
ities. Items labeled “Impor-
tant” provide information to 
help you avoid problems.
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Keyboard keys
This manual uses standard names and abbreviations for keyboar
keys; your keyboard might use different labels.

Choosing commands
When a procedure tells you to choose a command, the instruction
written: 

Choose Edit > Paste 

This tells you to open the Edit menu and choose the Paste comm
You can use a keyboard shortcut if the command has one.

Some menu items open a submenu of related commands. When
documentation tells you to choose a submenu command, the ins
tion is written: 

Choose Object > Arrange > Bring To Front

This tells you to open the Object menu, choose Arrange to open 
submenu, and then choose the Bring To Front command.

Choosing commands in the context menu

You can choose commands from a menu that pops up wherever 
pointer is in Canvas. The commands in the menu are based on w
you are doing, so this is called the context menu.

Key name Description

Alt The Alternate key, usually labeled “Alt” on Windows 
keyboards

Command The key labeled “Command” or marked with a pro-
peller symbol on Mac keyboards

Ctrl The key labeled “Control” or “Ctrl” on Mac and Win-
dows keyboards

Option The key labeled “Option” on Mac keyboards

Shift The key used to type uppercase characters

Enter The key labeled “Enter” on Mac keyboards. This key 
has a different function than the “Return” key

Return On Mac keyboards, the key labeled “Return.” On 
Windows keyboards, the key labeled “Return” or 
“Enter.”
INTRODUCTION
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To choose a command from the context menu, do the following:

Mac: Press the Ctrl key and press the mouse button at the same 

Windows: Press the secondary (right) mouse button.

Using modifier keys

For some actions, you need to press a keyboard key while you cl
or drag the mouse. For example, to select several objects, press 
Shift key while you click each object. This can be written as Shift-
click. If you press the Command key, for example, while you drag
the mouse, the action can be written as Command-drag.

When referring to Canvas for Windows, some instructions say to 
“right-click” an object. This means to click the object using the sec
ondary button, usually the right button, on the mouse.

Using on-line Help
Canvas includes a comprehensive on-line Help system that lets y
refer to the documentation while you work. 

To view Help in Canvas (Mac) Press the Help key on an extended
keyboard, or choose Help > Contents. 

When you press the Help key and a dialog box is open, the Help 
tem displays help for the dialog box. Otherwise, the Contents top
appears. You can also search for topics in the Help window.

To view Help in Canvas (Windows) Press the F1 key to display 
Help, or choose Help > Contents.

When you press F1 and a dialog box is open, the Help system di
plays help for the dialog box. Otherwise, the Contents topic appe
You can also search for topics in the Help window.

Viewing Deneba’s web site

The Deneba Home Page command in the Help menu will display
Deneba Software home page in your web browser.

If you have a web browser open, Canvas switches to the browser
loads the Deneba home page. Otherwise, Canvas looks for an 
installed browser, launches it, and loads the Deneba home page.

It’s a good idea to visit the Deneba web site often. You can find ti
to help you get the most out of Canvas, plus program updates, te
cal notes, profiles of users, and contact information. The library a
lets you download free plug-ins, palette files, and other extras.

✔Tip
For the latest information on 
Canvas, be sure to view any 
“Read Me” files included with 
the program.
Using on-line Help 1.3
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USING SPRITEEFFECTS

Canvas 7 introduces a new technology for applying effects to obje
Called SpriteEffects, this technology lets you apply image filters an
adjustments to vector objects, images, text, and grouped objects.

Before SpriteEffects, commands such as Blur, Hue/Saturation, 
Invert, Emboss, Twirl, and many others could be applied to paint 
objects (images) only. SpriteEffects technology offers new power
and flexibility for creative art, technical illustration, and graphics pr
duction.

About SpriteEffects
In Canvas, you could always modify objects with image-editing te
niques — if you converted the objects to images. However, you lo
the ability to edit vector paths and text. Also, applying filters and 
adjustments would change an image permanently.

SpriteEffects technology overcomes these problems. You can ap
effects temporarily, adjust effects settings, change the order of 
effects, and hide or remove effects individually. 

For example, you can apply a blur filter, emboss, and contrast ad
ment to an object. You can later change the blur settings, turn off
emboss effect, and re-order the effects. You don’t have to use Un
or save intermediate versions to preserve an original illustration.

The biggest benefit of SpriteEffects is that objects remain editable
After you apply effects, you can edit object paths, insert and dele
text, and change inks and strokes. In edit mode, you see the obje
without effects. When you finish editing, Canvas reapplies the 
effects. 

When SpriteEffects are printed or exported to file formats outside
Canvas, the effects are rendered as images. This is like taking a 
shot of the objects and printing the resulting image.In your Canva
documents, the objects keep their original editing features.

Direct effects and lens effects
There are two ways to use SpriteEffects: apply effects commands
directly to objects, or apply effects commands to lens objects.
2.1
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Direct effects

You can apply image filters and adjustment commands directly to
vector, text, paint, and group objects. You could apply the Blur co
mand to a text object, then use the Hue/Saturation command to h
light the text edges with color for example. 

When you apply effects directly, an entire object, including its fill 
ink, pen ink, and stroke, is affected. 

Lens effects

Another way to use SpriteEffects is to create a lens object from a vec-
tor or text object. Then, you apply effects to the lens. The effects w
appear on objects that are viewed through the lens.

Lenses can magnify objects and view objects in other locations. I
you move the viewpoint of a lens, whatever is behind the viewpoint
will appear in the lens. If you move the lens, the viewpoint can 
remain fixed or move with the lens.

Applying effects
Commands and options for SpriteEffects include the following: 

• Commands in the Object > SpriteEffects submenu, which
let you apply and edit effects. 

• The SpriteEffects palette, which lets you apply, edit, and 
remove SpriteEffects, and select lens options.

Because many types of filters and adjustments can be applied 
through SpriteEffects, general procedures are given here. You ca
locate specific information for effects commands by looking up th
commands in the index.

Using plug-in filters

You can use third-party plug-ins with SpriteEffects. Plug-ins must 
Adobe Photoshop 4.0. compatible and also support Photoshop 
Actions to be used with SpriteEffects.

Plug-ins can be installed by copying them to the Plug-ins folder in 
Canvas Tools folder. For information on settings and options for a
plug-in, refer to the documentation from the manufacturer.

Note: Effects commands in the Image > Filter and Image > Adjust
submenus are available for traditional image editing. These com-
mands are not available when other types of objects are selected
USING SPRITEEFFECTS
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To apply an effect 

Use this basic procedure to apply one effect using a filter or adjus
ment command.

1 Select an object. You can select any type of object, includin
lens.

2 Choose Object > SpriteEffects > Add Effect. A submenu of f
ters and adjustment commands appears.

3 In the Add Effect submenu, choose the command to apply.

4 If the selected command has no options, Canvas applies th
command to the object, which remains selected. If there are opti
for the command, a dialog box appears. Do the following:

• Choose the settings and options you want to use.

• If there is a Preview option, select it to see the effect of th
current settings. 

• Click OK to apply the current settings.

Applying multiple effects

You can repeat the procedure above to apply more than one effe
an object. However, it might be easier to use the SpriteEffects palette. 
The palette lets you apply and edit effects, and set other options.
“Using the SpriteEffects palette” on page 2.5.

Transferring SpriteEffects
The Detach and Attach commands will transfer filters and adjust-
ments between objects and lenses.

Detach removes effects from a selected object and applies the effe
to a new lens that is the same size as the object’s bounding box. 

Attach applies effects from a lens directly to an object. Attaching is
way to apply multiple effects to an object at once.

You can also use the Load Effects, Save Effects, and Append Eff
commands in the SpriteEffects palette to transfer sets of effects.

To detach effects

1 Select an object (not a lens) that has effects applied to it. 

2 Choose Object > SpriteEffects > Detach.
Applying effects 2.3
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3 Canvas removes the object’s effects and applies them to a n
lens, which appears offset from the original object and is selecte

To attach effects

1 Select a lens that has effects you want to apply, and a non-
object to receive the effects. The objects do not have to be the s
size or overlap; either can be in front in the stacking order.

2 Choose Object > SpriteEffects > Attach. Canvas applies the
effects to the selected object. The lens object is not changed.

Pasting effects
You can use the Paste Attributes command to transfer effects fro
one object to another. 

1 Copy an object that has effects to the Clipboard. 

2 Select an object to transfer the effects to. 

3 Choose Edit > Paste Attributes. In the Paste Attributes dialo
box, select the SpriteEffects option and click OK. Canvas will 
apply the effects (except lens settings) to the selected object.

Saving and loading effects
You can save effects that have been applied to an object as a se
After saving an effects set, you can apply the set to other objects

To save effects

1 Open the SpriteEffects palette by choosing Window > Palet
> SpriteEffects, or Object > SpriteEffects > Show Palette.

2 Select an object or lens that has effects you want to save.

3 Choose Save Effects from the SpriteEffects palette’s menu.

4 A directory dialog box appears. Enter a name and select a l
tion to save the effects set. Click Save to save the set in a file.

To apply saved effects

1 Open the SpriteEffects palette by choosing Window > Palet
> SpriteEffects, or Object > SpriteEffects > Show Palette.

2 Select the object you want to apply the effects set to. You c
select an object with no effects, one that has effects, or a lens.

3 Do either:
USING SPRITEEFFECTS
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Replace effects: To replace the selected object’s effects with
the effects set, choose Load Effects in the palette’s menu.

Merge effects: To add the effects set to the effects on the 
selected object, choose Append Effects in the palette’s men

4 A directory dialog box appears. Select an effects set file and
click Open. Canvas applies the effects to the selected object.

Editing SpriteEffects
To modify SpriteEffects objects, you can do the following:

• Add and remove effects

• Change settings for the effects 

• Change the order of effects

• Adjust the size of the effects area

• Show or hide effects

• Change lens magnification and viewpoint 

To edit SpriteEffects (not objects), you use the SpriteEffects pale

Note: To edit an underlying object (not its effects), double-clicking
the object, or selecting it and choosing Object > Edit > Object, wi
place the object in the appropriate edit mode. This is true whethe
not the object has SpriteEffects. Techniques for editing objects ar
described in the chapters on drawing, text, and painting.

Using the SpriteEffects palette
The SpriteEffects palette is the control center for SpriteEffects. Al
SpriteEffects features are available in the palette, except Attach a
Detach, which are in the Object > SpriteEffects submenu.

To display the SpriteEffects palette

Choose Object > SpriteEffects > Show Palette to open the 
SpriteEffects palette. Or, choose Window > Palettes > SpriteEffec
to open the palette.

The SpriteEffects palette is a floating palette. You can keep it ope
while you work, and dock it on the Docking bar. If an object is 
selected, its SpriteEffects settings are shown in the palette. When
object is selected, the controls in the palette are not available.
Editing SpriteEffects 2.5
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Using the effects list
When you select an object that has effects, you can use the list a
top of the SpriteEffects palette to arrange the order of effects. Yo
can also show or hide effects, and change the mask setting.

Effects that are applied to the selected object are listed in order o
application, with the first effect at the top. If no effects appear in th
list, the selected object has none, or more than one object (or no 
object) is selected.

You can select an effect by clicking in the list. The selected effect
highlighted. Double-clicking an effect is the same as selecting it a
choosing Edit Effect Settings in the palette’s menu.

Arranging effects

To change the order in which effects are applied, drag an effect u
down and drop it in the list.

Showing and hiding effects

Click the eye symbol to erase it from the effect you want to hide. 
Hiding an effect temporarily removes the effect from the object. 

To restore a hidden effect, click to make the eye symbol appear f
the effect. Canvas then re-applies the effect to the selected objec

Palette menu

SpriteEffects palette

The SpriteEffects palette is 
the control center for apply-
ing effects, creating lenses, 
and editing effects on 
objects.

Effects list

A Show effect
B Mask

A B
USING SPRITEEFFECTS
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Selection masks
In the Effects list, a symbol to the left of each effect name shows 
state the selection mask for the effect. You can click the symbol to 
toggle the mask on ( ) and off ( ).

An active selection mask defines a selection for an effect. The se
tion will include objects, not empty space. The mask can preserve
transparent areas, such as empty space in a group object, and sp
between text characters. 

• When the selection mask is on, the effect is based on the
selection area. 

• When the selection mask is off, the effect is based on the
entire bounding box area.

For example, if you apply the Add Noise command to a circle, the
selection includes only the circle, so the noise affects only the circ
if the mask is on. If the mask is off, the noise appears in the entire
bounding box area.

For a built-in effect, Canvas uses the best selection mask setting.
third-party effects, you might need to change the mask setting for
best results.

Blur effects usually require the selection mask to be off, so the blu
can extend beyond the outline of an object. Other effects look be
when they are based on a selection. For example, a flame effect 
cover an entire bounding box if the selection mask is off. If the ma
is on, flames will rise from just the objects or text characters in the
selection. This does not mean that flames can’t rise above the se
tion, just that the effect will be based on the selection, not the ent
bounding box.

Mask offMask on

Noise applied to vector graphic
Editing SpriteEffects 2.7
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When you edit the settings for an effect, Canvas displays a borde
the selection, the same as the selection border that appears in im

Modifying an object’s effects
You can use the SpriteEffects palette to modify a selected object
effects. You can add, remove, and duplicate effects, and change 
settings for the effects applied to the object.

Adding effects

1 Select an object to apply effects to. You can select an objec
that has no effects, one that has effects, or a lens.

2 In the SpriteEffects palette, click the New button ( ) or 
choose New Effect in the palette’s menu. 

3 A dialog box appears. Select an effect command from the p
up menu and click OK. 

4 If there are no options for the command, Canvas applies the
effect. If there are options for the command, a dialog box appea
Configure the options and click OK to apply the effect.

Each effect that you apply appears in the Effects list at the top of 
SpriteEffects palette.

Changing effects settings

To change the settings for an effect, double-click the effect name
the Effects list in the SpriteEffects palette. Or, select the effect na
and choose Edit Effect Settings in the palette’s menu. Then, use 
dialog box to adjust the settings for the effect and click OK to app
the current settings.

Some filter and adjustment commands (including include Blur, 
Desaturate, Invert, and Sharpen) do not have editable settings, s
choosing Edit Effect Settings or double-clicking the effect does no
ing.

Duplicating or removing effects

You can use the SpriteEffects palette to duplicate or remove effe
that have been applied to a selected object.

Removing an effect deletes it from the Effects list. If you just want
temporarily hide an effect, click the eye symbol in the Effects list.

1 Select the object whose effects you want to edit.
USING SPRITEEFFECTS
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2 In the SpriteEffects palette, do any of the following:

Duplicate Effect: Select an effect in the list and choose Dupl
cate Effect in the palette’s menu. 

Delete Effect: To remove an effect, select the effect in the lis
Click the trash can or choose Delete Effect in the palette’s 
menu.

Clear All Effects: To remove all effects from the selected 
object, choose Clear All Effects in the palette’s menu.

SpriteEffects options
In the SpriteEffects palette, you can set the color mode, resolutio
and anti-aliasing for the effects applied to a selected object. Thes
options control how SpriteEffects are rendered for printing and 
export, as well as the display of SpriteEffects in Canvas. 

When you change a setting, the change is applied immediately to
selected object.

Mode

From the Mode menu, select the color mode to use for rendering
SpriteEffects. 

The SpriteEffects Mode is used for rendering all the effects applied
an object. If you choose Grayscale, for example, the object and 
effects applied to it will appear in gray shades on screen and when
object is printed or exported.

Select a mode that is appropriate for the medium you use. RGB is best 
for web graphics, screen display, and output to a film recorder. 
CMYK is appropriate for process-color printing and color separatio
for commercial printing. Grayscale is appropriate for black-and-
white publishing.

None is available in the mode menu only when the selected objec
a lens that has no effects commands applied to it. The lens can ha
magnification value and a remote viewpoint, however. 

If you select None, the lens object is not rendered for printing or 
export. This can be more efficient and produce better output whe
lens displays vector objects or high-resolution images. This option
useful if you use lenses without effects to show close-ups or call-o
of diagrams.
SpriteEffects options 2.9
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Resolution

Enter the resolution in pixels per inch for rendering SpriteEffects. 
The higher the resolution, the smoother effects will appear. Howev
higher resolution requires more memory and slows down printing

For web graphics and screen display, 72 ppi is the recommended
olution. For office printing, 100 to 200 ppi is usually sufficient. For
commercial printing, a range of 150 to 300 ppi is recommended f
halftone images, depending on the paper and press requirements

Anti-Alias

Select this option if you want to smooth the edges of objects in th
rendering of SpriteEffects.

Sizing the effects area
When you apply effects to an object, Canvas defines a rectangula
effects area. Usually, the effects area is slightly larger than the 
bounding box of the object the effects are applied to. 

There is one effects area for all effects applied to an object. Canv
tries to keep the effects area as small as possible, without croppin
out any visible objects. 

You can adjust the effects area using the SpriteEffects palette. Th
palette lets you set the effects area manually or automatically.

You might need to enlarge the effects area to see effects that ext
beyond an object’s edge. For example, Motion Blur and plug-in 
effects like bevel, glow, and fire usually need to extend beyond a
object’s outline. Also, if text characters extend outside the text obj
border, an effect applied to the text could be cut off. 

If you make the effects area smaller than an object’s bounding bo
the object and the effects will be cropped by the effects area bord

To size the effects area automatically

1 Select the object whose effects area you want to adjust.

2 In the SpriteEffects palette, click the smart-crop icon ( ).

3 If the resolution of the effect is greater than 72 ppi, a Canva
message asks you to confirm that you want to proceed. Click O

4 Canvas estimates the correct size of the effects area and m
it as small as possible.
0 USING SPRITEEFFECTS
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To size the effects area manually

Some effects need to extend far outside an object’s bounding box
these cases, the auto-size option might not extend the effects are
enough. If this happens, you can enlarge the effects area yoursel

1 Select the object whose effects area you want to adjust.

2 In the SpriteEffects palette, click the crop icon ( ).

3 A box appears on the selected object. The box indicates the
effects area and has hollow handles (the object’s bounding box 
solid handles). 

4 Drag a handle to enlarge or reduce the effects area. When 
box is the size you want, click inside it.

To size the effects area precisely

You can enter values to precisely size the effects area.

1 Select the object whose effects area you want to adjust.

2 In the SpriteEffects palette, choose “Size of Effects Area” fro
the palette’s menu.

3 A dialog box appears. Do either:

• Set the size of the effects area by entering the distance fr
the rulers’ zero point to the left, top, right, and bottom side
of the effects area rectangle.

• Click a button to enlarge ( ) or reduce ( ) the size of 
the effects area. When you click a button, the distance va
ues in the text boxes show the new effects area size.

4 Click OK to apply the setting to the effects area.

Effects area box
SpriteEffects options 2.11
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Lens effects
You can apply effects to a lens the same as you apply effects to o
objects (see “Applying effects” on page 2.2). You also can set a m
nification value and viewpoint location for a lens. These options a
available in the SpriteEffects palette. 

You can use the magnification and viewpoint options after you cre
a lens with the Object > SpriteEffects > Convert to Lens comman
or by selecting the Lens option in the SpriteEffects palette.

To create a lens 

You can create a lens from any object (except a lens). If you wan
preserve an object, make a copy and convert the copy to a lens.

1 Select one object.You can select any type of object (except
lens).

2 Choose Object > SpriteEffects > Convert to Lens.

3 The object becomes a lens and remains selected.

Fill inks are removed when vector or text objects are converted to
lenses. The stroke on a lens is not affected by the effects applied
the lens.

The default lens effect is normal (100%) magnification. To add ad
tional effects, see “To apply an effect” on page 2.3; you can repe
the procedure to apply additional effects.

Viewpoint

Basic lens

With the magnification set to 
300% and its viewpoint set 
about 2 inches to the right, a 
lens made from a circle 
shows a detail view of an 
illustration.

✔Tip
If you are a Photoshop user, 
you can use lenses as you 
would adjustment layers in 
Photoshop. Lenses are actually 
more powerful because they 
are not limited to a few adjust-
ment commands.
2 USING SPRITEEFFECTS
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Other ways to create lenses

You can convert a selected object to a lens by selecting the Lens
option in the SpriteEffects palette. 

You can create copies of lenses the same ways that you copy oth
objects. For example, you can use the Duplicate command or the
Copy and Paste commands to create a copy of a selected lens.

Magnification in lenses
You can set the magnification level of a lens so objects will appea
magnified (or reduced) in the lens. You can set the magnification
level with or without other effects applied to a lens.

Magnification affects the view through the lens to the lens viewpoi
If the default viewpoint (at the center of the lens) is used, the lens
plays a magnified view of objects behind the lens. If the viewpoin
has been moved, the lens shows a magnified view of objects beh
the viewpoint. See “Setting a lens viewpoint” on page 2.14.

To set magnification

1 Select a lens object. (To create a lens, see page 2.12.)

2 In the SpriteEffects palette, enter the magnification value in t
“Mag” text box. You can set magnification from 4 to 3,200 perce

When you change the magnification value, the lens view changes
unless the Frozen option is selected in the SpriteEffects palette. 
When Frozen is selected, the lens view does not change until you
deselect the Frozen option.

Lens options

A Select to create a lens
B Magnification percentage
C Freeze lens view
D Viewpoint settings

A

B

D

C

Lens effects 2.13
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Setting a lens viewpoint
The viewpoint of a lens is a point in the document that appears in t
lens. The default viewpoint is at the center of the lens, so the lens
plays whatever is directly behind it.

You can move the viewpoint of a lens to make any location appea
the lens. This is useful for displaying close-ups of illustrations.

The center of a lens is focused on the lens viewpoint. If you move
viewpoint, the new location appears centered in the lens object.

The viewpoint of a lens can be set anywhere on the same page, s
sheet, or frame as the lens object. Lenses can display objects on
visible layers on the same page, sheet, slide, or frame. Lenses wil
display objects on other pages, sheets, slides, or frames.

To set a viewpoint visually

Use this procedure when you want to click in the document to set
viewpoint for a lens. 

1 Select the lens object.

2 In the SpriteEffects palette, select Relative or Absolute; thes
options are described next.

3 Click Choose.

4 Move the pointer in the document and click to set the view-
point. The point you click appears centered in the lens.

Absolute and relative viewpoints

To set the relationship of the viewpoint to a lens object, select Ab
lute or Relative in the SpriteEffects palette. 
4 USING SPRITEEFFECTS
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Absolute An absolute viewpoint is set at a specific location in a 
document and does not move. The lens shows the same absolut
point no matter where the lens is placed on the page.

Relative A relative viewpoint is set at a specific distance from the
center of the lens. If you move the lens, the viewpoint moves the 
same distance and direction. Unless the Frozen option is selected
view in the lens changes to show the new viewpoint. When Froze
selected, the view in the lens does not change; if you deselect the
zen option, the view then changes to the current viewpoint.

To set a viewpoint precisely

Use this procedure to enter values to position a viewpoint. 

1 Select a lens object.

2 Use one of the following options:

Absolute position: Select Absolute and enter horizontal (X) 
and vertical (Y) distances from the rulers’ zero point to the 
viewpoint. For example, enter 0 in the X and Y boxes to set t
viewpoint at the zero point. The viewpoint will not move if you
move the lens.

Relative position: Select Relative and enter horizontal (X) an
vertical (Y) distances from the center of the lens to the view
point. Positive values move the viewpoint down and right of th
lens center. Negative values move the viewpoint up and left o
the lens center. To set the viewpoint 1 ruler unit left of the len

Lens 

Absolute viewpointRelative Viewpoint 

Lens 
Lens effects 2.15
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center, for example, enter -1 (X) and 0 (Y). The viewpoint wil
move if you move the lens.

To reset a viewpoint

Select a lens and click the Reset button in the SpriteEffects palet
reset the viewpoint to the center of the lens object. This resets the
location values to 0, 0 if Relative is selected. If Absolute is selecte
the location is measured from the rulers’ zero point to the lens cen

Lenses and stacking order
The view through a lens depends on the stacking order of the len
well as the position of the viewpoint.

Only objects that are behind a lens in the stacking order can be see
through the lens. A lens and its viewpoint are at the same level in
stacking order. 

Because of stacking order, objects that you create after you create a 
lens can not appear in the lens. Also, objects that you move to th
front of the stack after you create a lens can not appear in the len

You can select a lens, and then choose Object > Arrange > Bring
Front to move the lens and viewpoint to the front of the stack. Wit
the lens in front, any object at the viewpoint can appear in the len

You can use stacking order to change a lens view. You can send
lens to the back of the stack so nothing appears in it. You can brin
to the front so all the objects at the viewpoint appear in the lens.

You can use a lens to display layered views. For example, you ca
draw a map and create a lens to show a close-up of an area. If you
text after you create the lens, the text is higher in the stacking ord
The text will not appear in the lens close-up of the map.

Freezing a lens
You can select the Frozen option in the SpriteEffects palette to 
“freeze” the current view in a lens. This is like taking a snapshot o
rendering the image in the lens; the view won’t change unless yo
deselect the Frozen option. For example, if you change the fill co
of an object, the lens will not show the change. If you deselect the
Frozen option, Canvas updates the lens view.
6 USING SPRITEEFFECTS
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Selecting Frozen overrides a lens relative viewpoint; the lens will 
show the same view after being moved. If you deselect Frozen, th
lens will display the new viewpoint location.

To use the Frozen option

1 Select a lens.

2 In the SpriteEffects palette, click the Frozen option to select
The lens is frozen when a check mark appears in the Frozen bo

3 To update the view in a lens to show the current viewpoint, 
click the Frozen option to clear the check mark.

Sharing SpriteEffects
Because SpriteEffects are “live” effects that can be edited and 
updated, there are a few issues to consider if you plan to share d
ments that contain SpriteEffects.

Effects that are applied to an object need to be available to other 
vas users if they share the document and need to edit the effects
you use only built-in Canvas effects, this is not a problem. If you u
third-party plug-ins to apply effects, other users must have the sa
plug-ins installed. Without the plug-ins, they can not edit effects 
applied in a Canvas document.

This issue is similar to the issue of font availability in shared docu
ments. If a document contains text, the same fonts must be insta
by all users who share the document.

If you export a document using an image file format, the effects w
be rendered into an image (as described below), and the effects 
ins will no longer be needed. Rendering is necessary because ot
file formats do not support SpriteEffects on objects.

Platform considerations

When it comes to using effects plug-ins, you should not have a p
lem when sharing documents on the same platform (Mac OS or W
dows), as long as everyone who views the document has the sam
plug-ins installed. 

If you share documents across platforms, however, compatibility 
among third-party plug-ins — even ones with the same names —
not guaranteed.

✔Tip
Freezing lenses can avoid slow 
performance when you edit 
objects shown in lenses. When 
you finish editing, select the 
lenses and deselect the Frozen 
option to update the lens 
views.
Sharing SpriteEffects 2.17
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Printing effects

When you print from Canvas, preserving effects should not be a 
problem, as long as effects plug-ins are available in Canvas when
document is printed. Whether you print directly to an output devic
or to a PostScript file, Canvas renders effects before printing. Thi
true unless, in the Print dialog box, you set Transparency Render
to “Don’t Render Transparent Objects.” When this setting is select
the only SpriteEffects that will be printed are lens objects that hav
no effects except magnification and viewpoints. 

Rendering effects
You can preserve the appearance of effects by rendering objects
before sharing a Canvas document. Rendering converts 
SpriteEffects and objects into static images. Effects and objects
not editable after conversion to images.

You can use several methods to render SpriteEffects:

• Use the Camera tool to take a snapshot of an illustration
This renders the area you select.

• Select objects that have effects, including lenses, and 
choose Image > Area > Render. 

• Save a document in an image file format, such as BMP, 
GIF, JPEG, PCX, or TIFF. Canvas will render the docume
as an image before saving the file. 
8 USING SPRITEEFFECTS
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RUNNING CANVAS

This chapter explains how to start and end a Canvas work sessio
also provides an overview of the Canvas interface and describes
following basic procedures: 

• Selecting tools from the Canvas toolbox

• Using and arranging palettes

• Using information displayed in the Status bar

• Undoing, redoing, and repeating actions

Starting and exiting Canvas
To start Canvas, do one of the following:

• Double-click the Canvas program icon. 

• Double-click a Canvas document to start Canvas and op
the document.

• Double-click a Canvas template file to start Canvas and c
ate a new document based on the template.

• Choose the Canvas shortcut in the Start menu (Windows

When you start Canvas, it displays a start-up screen and a status
cator as it loads. Then Canvas opens a blank document, or the d
ment you used to start the program. 

◆ To view start-up screen information: When Canvas is running, 
Choose About Canvas in the Apple menu (Mac) or the Help men
(Windows). Do this when you want to check your serial number, v
sion number, and other program information.

To stop running Canvas

Choose File > Quit (Mac) or File > Exit (Windows). If you try to qui
without saving a document that has changed, Canvas asks if you
want to save it first. 

Checking optional software at start up

Canvas displays a message if it encounters a problem, such as m
ing system software components, as it starts. If a message appea
click OK to continue loading Canvas.
3.1
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Canvas depends on some system software components for impo
and exporting certain types of files, managing colors, and working
with some graphics formats. The Canvas installer places some so
ware called “extensions” (Mac) or “Dynamic Link Libraries” (Win-
dows) on your system if needed. If Canvas can’t find the required
component later, it’s possible the file was moved or disabled. 

If you encounter a problem when starting Canvas, refer to the “Re
Me” file and to the on-line Help system; these include the most up
to-date information on required software.

Overview of the Canvas interface
Canvas appears nearly identical on screen whether you use the M
OS or Windows operating systems. Some operations differ slight
across platforms, but these operations are very familiar to most us

For example, on Mac OS systems, you press an icon in the toolbo
open a toolbar or palette and drag to the tool you want to select. 
Windows systems, you click or press an icon to open a toolbar or
pop-out palette, and then click again on the icon for the tool you w
to select.

Canvas has four types of documents: Illustration, Publication, An
mation, and Presentation. These documents share some commo
ments, while some specialized controls apply to particular docume
types.
RUNNING CANVAS



The Canvas window

Major parts of the Canvas 
interface are shown here. 

Some of these items might not 
be displayed in your Canvas 
configuration. For example, 
you can hide the Toolbar and 
the Docking bar. You can dock 
the toolbox and other palettes. 

And you can add your own 
shortcuts to the Toolbar.

Each Canvas document 
appears in its own floating win-
dow. Each document window 
has a Zoom bar and scroll bars. 
All documents share the tool-
box and Status bar. 

A Menu bar
B Toolbar
C Docking bar
D Toolbox
E Layout area
F Zoom bar
G Status bar

A
B

C

D E

F

G

Overview of the Canvas interface 3.3
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Layout area

The rectangle centered in the Canvas document window is the Layo
area. This rectangle is the main working area for creating illustration
page layouts, presentations, and animations. 

The white space around the Layout area is additional working space
where you can place objects before using them in an illustration. Obj
in this outside area are saved with the document, but objects that ar
completely outside the Layout area are not printed.

The Layout area represents different things in the different Canvas d
ment types.

Illustrations The Layout area is one page, called a “sheet,” with laye

Publications The Layout area is one single-sided page or two facin
pages with layers. 

Presentations The Layout area is one “slide” with layers.

Animations The Layout area is one frame of an animation. If you 
select “onion-skinning” (click the onion in the Document Layout pal-
ette), you can see objects on adjacent frames.

You can change the color of the Layout area to represent the color o
tinted paper. You can set the Layout area color by choosing Layout 
Document Setup.

Document navigation controls

Buttons that represent pages, slides, sheets, or frames appear belo
document. You can click buttons to move through a document.

You can also use the navigation buttons to select layers. When you p
a page button, for example, a pop-up palette lists the layers on that p
You can select a layer in the pop-up palette. If you drag away from t
button, the Document Layout palette appears.

Layout area

Slide / Frame buttons Page buttonsSheet buttons
RUNNING CANVAS
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Using the toolbox
The toolbox contains tools for drawing, painting, creating objects,
editing, and viewing. The toolbox is a floating palette. You can pla
it anywhere on screen by dragging its title bar, and you can dock i
the Docking bar.

◆ To display the toolbox: If the toolbox is hidden or closed, 
Choose Window > Palettes > Show Toolbox to display it.

Selecting tools

In the Canvas toolbox, tools are represented by icons. The toolbo
displays 10 tools arranged in two columns at the top of the toolbo
The tools that aren’t displayed are available on toolbars, which ar
like drawers that slide out from the toolbox. 

A toolbar opens from each icon displayed in the toolbox. The dis-
played icons are called the home icons for the toolbars. Home ico
have small arrows at their upper-right corners. The last tool selec
on each toolbar appears as a home icon.

◆ To select a tool displayed in the toolbox: Click the tool. The 
selected tool is shaded, like a recessed button. 

◆ To select a tool from a toolbar: Press the home icon to open 
the toolbar. On Mac, drag to the tool you want to select; on Windo
click the tool icon. 

Press to select layers

Drag away to display 
the Document Layout 
palette

Tools

Palettes 

Opacity slider
Using the toolbox 3.5
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Using the Toolbar
The Toolbar contains buttons you can click to choose commands
tools, inks, strokes, and styles. The Toolbar appears above the d
ment, under the menu bar.

◆ To display the Toolbar: Choose Window > Palettes > Show 
Toolbar. To hide the Toolbar, choose Window > Palettes > Hide 
Toolbar.

◆ To select an item on the Toolbar: Click its button.

A standard set of commands appears on the Toolbar when you fi
run Canvas. You can use the Customize command to change the
tons on the Toolbar. You can add buttons to the Toolbar for com-
mands, tools, and custom colors and styles. See “Customizing th
keyboard and Toolbar” on page 9.15.

Tool palettes

This diagram identifies the tool 
palettes in the toolbox. Press 
the home icon of a palette to 
open the palette.

A Selection tools
B Line tools
C Rectangle tools
D Oval and arc tools
E Object tools

F Paint tools
G Text tools
H Path tools
I View tools
J Effects tools
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The toolbox
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You can identify Toolbar items by displaying tool tips. Point to an
icon and a tool tip appears with the name of the command or tool
tool tips don’t appear, choose File > Preferences, and select “Com
mand Information Tool Tips” on the General tab.

Using palettes
Canvas organizes tools, special effects, object attributes, and oth
functions in palettes. Palettes can remain open on screen, and th
can be docked on the Docking bar. 

Instead of an OK button, a palette has an Apply button. Click App
to implement the current settings. A palette stays open until you c
its close box or use a command to close it.

Using the Palettes submenu

All Canvas palettes are listed in the Window > Palettes submenu
display a palette, choose the name of the palette in the submenu
palette is behind other palettes, it comes to the front. If a palette i
docked, the palette comes off the Docking bar and opens.

Some palettes are also associated with commands in other menu
For example, the Object > Object Specs command opens the Ob
Specs palette. The Image > Show Channels/Hide Channels com
mands open and close the Channels palette. 

A pair of commands in the Palettes submenu control the Canvas 
box. Choose Window > Palettes > Show Toolbox to open the too
box. Choose Window > Palettes > Hide Toolbox to remove the 
toolbox from the screen.

Palette icons in the toolbox

Three icons at the bottom of the toolbox provide access to the Ink
Strokes, and Brushes palettes. You can use these icons to select
set colors and other attributes. During image editing, the Brushes
ette icon replaces the Strokes palette icon.

You can “pop” open these palettes from the toolbox, and then dra
them away to keep them open. Do this when you want to use a c
figuration manager to create custom attributes.

Procedures for selecting inks and strokes are covered in the chap
“Inks: colors and patterns” on page 12.1, and “Strokes: outline 
effects” on page 13.1. Information on selecting and using brushes
in the chapter “Painting and image-editing” on page 24.1.

Strokes palette

Fill Ink palette

Pen Ink palette
Using palettes 3.7
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Organizing palettes on screen

To move a palette, drag its title bar. To roll up a palette so only its
title bar is visible, double-click the title bar (Mac) or click the box a
the right end of the title bar (Windows). 

◆ To arrange palettes: Choose Window > Palettes > Clean Up 
Palettes. Canvas moves all open palettes except the toolbox and 
ing toolbars to the upper-right corner of the document. On Windo
systems, Canvas also rolls the palettes up to their title bars. With M
OS 8, Canvas can roll up palettes if the option labeled “System-w
Platinum appearance” is selected in the Appearance control pane
Otherwise, Canvas moves the palettes to the upper-right corner o
screen, but doesn’t roll them up.

◆ To close all palettes: Choose Window > Palettes > Put Away 
Palettes. Canvas closes all open palettes, including the toolbox a
floating toolbars.

Using the Docking bar
You can use the Docking bar to customize the Canvas interface. 
Docking bar can be displayed near the top of the screen under th
Menu bar. If the Toolbar is displayed, the Docking bar appears be
it. 

◆ To display the Docking bar: Choose Window > Docking Bar > 
Show Docking Bar. When you display the Docking bar, the palett
that were docked the last time it was displayed will remain docke
To hide the Docking bar, choose Window > Docking Bar > Hide 
Docking Bar.

Docking palettes

You can “dock” Canvas palettes on the Docking bar. When you do
a palette, a tab with the palette’s name appears on the Docking b
The tabs of docked palettes give you quick access to features tha
use often. Docked palettes also leave more space available on sc

You can dock most Canvas palettes, including tool palettes that y
drag away from the toolbox, such as the Painting, Rectangles, an
Text palettes. You can dock other palettes from the toolbox, inclu
ing the Inks, Strokes, Transparency, and Brushes palettes. You c
also dock command palettes such as Align, Blend, Envelope, Ob

Drag a palette to the docking 
bar to dock it
RUNNING CANVAS
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Specs, and Type. Dialog boxes that require you to click OK or Ca
cel before continuing can’t be docked.

You can dock as many palettes as you want on the Docking bar, 
depending on the size of your screen. If you dock all available pa
ettes, their tabs will probably overlap. 

◆ To dock a palette: Drag its title bar onto the Docking bar and 
drop the palette when a tab outline appears. To dock a palette of t
from the toolbox, first drag the palette away from the toolbox and
drop it onto the desktop so its title bar appears, and then drag the
ette onto the Docking bar to dock it.

◆ To change the position of a docked palette: Drag the pal-
ette’s tab to another position on the Docking bar. 

◆ To remove a docked palette: Drag its tab away from the 
Docking bar.

◆ To dock all open palettes: Choose Window > Docking Bar > 
Dock All Palettes

◆ To arrange docked palettes: Choose Window > Docking Bar 
> Clean Up to arrange the tabs of docked palettes evenly on the 
Docking bar.

◆ To arrange tabs by name: Choose Window > Docking Bar > 
Clean Up By Name to arrange the tabs of docked palettes in alph
betical order.

To adjust the size of tabs on the docking bar

1 Choose Window > Docking Bar > Set Tab Length. A dialog 
box appears. 

• To display the full name of docked palettes, select Auto. 

• To set a specific tab size, select “No. of Characters” and 
enter the number of characters to display. A smaller numb
results in smaller tabs. 

2 Click OK.

Using docked palettes

To make a selection from a docked palette, click the palette’s tab
the Docking bar. The palette pops open and you can click a tool o
other item in the palette to select it. When you click in the docume
or the toolbox, the palette closes again. To close the palette witho
selecting anything, click anywhere outside the palette.

✔Tip
Click an empty area of the 
Docking bar to display a menu 
of common commands: Clean 
Up, Clean Up By Name, Dock 
All Palettes, and Tab Size.
Using palettes 3.9
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Palettes that are docked when you quit Canvas will be docked th
next time you launch Canvas. The settings for the Docking Bar ar
stored in the Canvas 7 Settings file in Mac OS and the Canvas7.s
file in Windows.

You can use docked palettes as if they are floating, with one exce
tion: You cannot drag objects into docked palettes. 

Using the Status bar
The Status bar is at the bottom of the screen (Mac) or the bottom
the Canvas window (Windows). The Status bar provides informat
about commands, tools, objects, and program operations.

You can select the number of information fields to display in the S
tus bar, and the function of each field.

◆ To set the number of information fields: Point to the Status 
bar, open the context menu, and choose from the Number of Fiel
submenu. 

◆ To add fields: Point to the Status bar, open the context menu
and choose a function in the Add to Right or Add to Left submenu

◆ To remove a field: Point to the field, open the context menu, 
and choose Remove.

New fields that you add to the Status bar are blank until you assig
function to each field. If you reduce the number of fields, Canvas 
removes fields from the right end of the status bar.

To adjust the width of a field, drag its border right or left.

During certain actions, such as saving a document, Canvas displa
progress bar in the Status bar.

You can hide the Status bar (Mac OS only) by choosing Window 
Palettes > Hide Status Bar. You can display the Status Bar by ch
ing Window > Palettes > Show Status Bar.
0 RUNNING CANVAS
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Assigning functions to fields
To assign a function to a field in the Status bar, point to the field, 
open the context menu, and choose a function in the Show subm

Hintline The Hintline area displays tool names, tips, and status 
messages. When you move the pointer over a tool icon or other it
the Message area shows the tool’s name and function. You can u
this feature to take a tour of the Canvas tools and interface.

Mouse position When you move the pointer, draw, resize, or rota
objects, Canvas displays the coordinates of the pointer. 

Object Measures Displays the XY coordinates of the object’s 
upper-left corner, and the object’s width and height.

To change the unit of measurement for this data, use the Rulers 
mand in the Layout menu. 

If you set a drawing scale in the Rulers dialog box, position and m
surement data conform to the drawing scale. For example, if you s
drawing scale of 1 centimeter = 1 meter, and you draw an object 
centimeters square on screen, the Status bar displays the scaled
dimension.

When a single object is selected, you can press the pointer on th
Object Measures field to open a pop-up menu showing the heigh
width, area, and perimeter of the selected object. To paste a mea
ment from the data pop-up menu, choose an item in the menu. C
vas pastes the measurement you select as text next to the object

Object Details Displays various details about selected objects, 
such as the position of points on the bounding box of a rectangle
measured from the rulers’ zero point) and the number of points in
path object. For other objects, the field displays data such as the 
diameter of ovals and the angle of arcs.

Object Information Displays information about selections. When
one object is selected, the field displays the type of object selecte
When multiple objects are selected, the field shows the number o
objects selected. When you select an object group, the field displ
“Group of n objects,” with n as the number of objects.

Layer Information Displays the current page number and layer 
number. Symbols indicate layer options, including non-printing, 
locked, and color override. When an object is selected, the field d
plays the object’s number in the sequence of objects on the layer
Using the Status bar 3.11
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Undoing, redoing, and repeating actions
You can easily correct mistakes, restore your work to an earlier st
and repeat commands using the Undo, Redo, and Again comma

◆ To cancel an action: Choose Edit > Undo. Or, press Com-
mand+Z (Mac) or Ctrl+Z (Windows).

The minimum and maximum number of times you can undo chan
can be changed on the General tab in the Preferences dialog box
“General preferences” on page 9.1.

Not all actions can be canceled with the Undo command. Actions
that cannot be canceled include scrolling; closing or reverting to a
earlier version of a document; selecting and deselecting objects; 
deleting settings in palettes; and saving documents.

◆ To restore actions you canceled using Undo: Choose Redo in 
the Edit menu. You can choose Redo multiple times to reinstate c
celed actions in reverse order.

◆ To repeat a command or other action: Choose Again in the 
Edit menu. When an action can be repeated, the Again command
includes the name of the action. For example, after you rotate an
object, the Again command appears as “Rotate Again.”

Not all actions can be repeated. The Again command isn’t availab
if the previous action can’t be repeated.

Using expressions for numeric values
You can type basic mathematical expressions to specify numeric
ues in Canvas dialog boxes and palettes. You can use addition, s
traction, division, and multiplication operators in simple expression

For example, you can type a fractional value, such as 2/3, in plac
a decimal value.

To type an expression

To enter operators in expressions, type a plus sign (+) for additio
minus sign (-) for subtraction; a slash (/) for division; and an aster
(*) for multiplication. 

You can type parentheses to nest values and operators in expres
You do not type an equal sign in an expression.
2 RUNNING CANVAS
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Canvas calculates the result of a mathematical expression when 
press Tab or Enter, or click an Apply button, or move to another 
value in a dialog box.

To modify a value

To use an existing value in an expression, click after the number 
place an insertion point. Then, type the remainder of the express
For example, to make the width of an object 3 times larger, click a
the existing value and type * 3, and then press Enter. To make th
value one-third as large, type / 3. 

By entering expressions after existing values in the Transform pa
ette, you can move objects incrementally. For example, to move 
object 3/4 inch to the right, type + 3/4 after the X value.

Specifying measurement units
In most dialog boxes, you can type abbreviations to specify meas
ment units. You can use this feature to override a document’s me
surement units or the specific measurement units used in these d
boxes. 

For example, when inches is a document’s unit of measurement, 
can type 1 cm to specify 1 centimeter. Canvas converts 1 cm and d
plays it as .3937 inches.

The following are the abbreviations you can type to specify a unit
measurement.

Abbreviation Unit of measure

in inches 

ft f feet 

y yards 

mi miles 

p picas 

pt points 

mm millimeters 

m meters 

km kilometers 

cm c centimeters 
Using expressions for numeric values 3.13
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To use an abbreviation for a measurement unit

In a text box that accepts numerical values, type a value followed
the abbreviation for the measurement unit. Canvas converts the 
numerical value to the measurement units you are using in the do
ment when you press Tab or Enter, or click an Apply button, or cl
in another edit box.

You can even type a mathematical expression using more than o
measurement unit. For example, you can type 1p+1cm.

Using context-sensitive menus
Canvas has context menus that you can pop up in the drawing area
giving you quick access to common commands. The menus are c
text-sensitive; the available commands depend on the current op
tion.

You can choose common editing commands, such as Cut, Copy 
Paste, when an object is selected. Other commands are available
when an object is in edit mode. For example, image-editing com-
mands appear in the context menu when you edit a paint object. P
editing commands appear when a vector object is in edit mode. 

When no objects are selected, you can choose view commands s
as Zoom In, Zoom Out, Show Rulers, and Show Guides. If the Cl
board contains objects or text, you can choose Paste. You can ch
Undo after performing an action that can be undone.

To use context menus

To apply a command to an object, select the object first. To use o
commands, you do not need to select an object before displaying
context menu.

Windows: Click the right mouse button. A context menu appears.
Click a command in the menu to choose it.

Mac OS: Press Control and the mouse button. A context menu 
appears. Highlight a command in the menu and release the mous
button to choose the command.

When you are editing an object, you can point to a specific item t
display commands for editing that item. For example, if you point
an anchor point on a path, you can choose commands to modify 
anchor point in the context menu.

For information on specific commands that appear in the context 
menu, refer to the command name in the Index.

Context menu for a paint object 
selection
4 RUNNING CANVAS
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Using the Display Options command
The Display Options command lets you configure most of the 
options for screen display in a single dialog box. You can change
play options, and set the default display options for new documen

All of the options in the Display Options dialog box are described
elsewhere. For information on an option, locate the item in the Ind

To use Display Options

1 Choose Layout > Display Options. 

2 A dialog box appears. To activate a display option, select its
checkbox so a check mark appears. To turn off an option, clear
checkbox. 

3 To make the current setup the default for new documents, 
select “Make default for new documents.” 

4 Click OK.
Using the Display Options command 3.15
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DOCUMENT BASICS

Canvas documents are the containers for your work. You can cre
and save vector drawings, text, raster images and effects in Illust
tion, Publication, Presentation and Animation documents. 

This chapter describes the basics of working with Canvas docume
including how to open, save, view, and print them.

Opening Canvas documents
You use the Open command to open Canvas documents stored 
disk. The general procedure is the same for opening Canvas doc
ments and any other type of file that Canvas supports. See on-lin
Help for complete information on options for other file formats.

To open a file

1 Choose File > Open. Canvas displays a standard dialog box
you to select a file to open. 

2 Select a file format to display one type of file in the current 
folder.

3 Select the file to open and click Open. Canvas displays a pr
view if the selected document contains a preview. 

◆ To open a document you worked with recently: Choose the 
document name from the list of recently opened documents in the
File menu.

◆ To start Canvas and open a document simultaneously: Dou-
ble-click a Canvas document icon in a folder or directory on your 
system. The program starts and the document opens.

Options for opening Canvas files

When you choose Open, a directory dialog box lets you select a f
in the scroll list and see a preview. On Mac, previews require Qu
Time.

You can select “Show All Files” to list all the files in a folder. This i
different than Selecting “All” in the File Format pop-up menu, whic
lists all files that Canvas can open.

1 C:\Documents\Floor1.CNV

2 C:\March\Orgchart.CNV

3 D:\Bob\Plotplan.CNV

4 C:\Canvas\Map.CNV

Documents opened recently are 
listed in the file menu.
4.1
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If you highlight a QuickTime movie or Sound file in the list, the pre
view area lets you play a movie or sound preview. In addition, the
button below the preview area lets you manage preview images.

• When the button says Create, click it to make a preview f
a file that doesn’t have one.

• When the button says Update, the file and its preview are
not consistent. Click Update to make the preview match t
file.

If you need additional help working with files, folders, and directo-
ries, refer to your Mac OS or Windows documentation.

You can open more than one document at a time in Canvas. Whe
you open a document, Canvas loads the document into your syste
memory. You need to have enough memory available to hold the
document’s contents. Documents that contain many complex obje
or large high-resolution images require more memory than simple
documents.

When you work with a document, changes you make to the docu
ment are not saved until you use the Save or Save As command

Substituting fonts when opening documents
If a document you open uses fonts that aren’t available on your s
tem, Canvas displays a dialog box before opening the document. 
can use the dialog box to review which fonts are required by the d
ument and to select substitute fonts, or you can let Canvas select
stitutes.

1 Select a font listed under Original Font, or Shift-click to sele
multiple fonts. This column lists fonts that are specified in the do
ument but are not available.

2 Choose a substitute font in the “With” pop-up menu. The nam
of the font appears in the list under Substitute Font. Canvas disp
the font name in its corresponding typeface so you can preview
font substitution.

3 Select the checkbox to permanently replace the missing fon
with the fonts you choose in this dialog box.

4 After you select substitutes for the missing fonts, click OK to
open the document. To cancel the changes, click Clear Change
let Canvas choose a substitute and open the document.
DOCUMENT BASICS
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Opening documents that require specific tools
When you open a Canvas document that depends on one or mor
external tools to display and print correctly, Canvas alerts you if th
necessary external tools aren’t available. To load the required too
quit Canvas, restart Canvas, and press the Spacebar to open the
Picker dialog box. Select the tools you want, or click All Tools. 

Placing documents
You can use the Place command to incorporate a document store
disk into an open Canvas document. You can insert a Canvas do
ment or a non-Canvas document with this command. For exampl
you can place a document containing your company logo within a
document in which you are preparing a sales brochure.

The Place command lets you visually set the location and dimens
of the incorporated document. 

When placing Canvas documents, you can control which layers, 
pages, or slides to place, and whether to place them on the curre
layer, page, or slide, or on new ones, depending on the documen
type (Illustration, Publication, or Presentation).

The Place command is available when a Canvas document is op

To place a file in an open Canvas document

1 Choose File > Place. A directory dialog box appears.

2 In the directory dialog box, select the file that you want to 
place, and then click Place. If the file has more than one page o
layer, the Place Options dialog box appears. Configure the optio

Choose substitute fonts

Select a font for which you 
want to specify a substitute

Select to permanently 
replace the missing font

Substitute fonts are listed 
here
Placing documents 4.3
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in the dialog box, and then click OK. See “Options for placing 
files,” next.

3 If you selected “Show Place Cursor” in the dialog box, the 
Place cursor appears. Position the Place cursor in the open doc
ment where you want the top-left corner of the placed file to be.
you did not select “Show Place Cursor,” Canvas inserts the file 
after you click OK.

4 Click to place the file at its original size; Canvas inserts the 
upper-left corner of the file at the point you click. To define the 
dimensions of the file you’re placing, drag to create a bounding 
box. Canvas inserts the file and scales it to fit the bounding box

Options for placing files

When you place a file, the Place Options dialog box lets you spec
how the placed file should be added to the current document.

When you place one Canvas document type (Illustration, Publicat
Animation, or Presentation) into another document type, Canvas 
verts the placed pages, sheets, or slides to the format of the curre
document.

Document pages (and sheets or slides) can be added to the curre
document, along with their layers. 

In the Place Options dialog box, you can select the following optio
and then click OK to place the document.

Place on Current Layer Places the file’s objects on the current 
layer of the current page. No pages or layers are created in the cu
document.

Show Place Cursor Select this option if you want to set the positio
or size of placed items on the current page. After you click OK in t
Place Options dialog box, a place pointer appears. Click to set th
position of the upper-left corner of the placed items, or drag to 
enclose an area in which you want the placed items to fit.

Add Layers to Current Page Places the document’s layers as new
layers on the current page in the current document.

Add New Pages Places the document’s pages and layers as new
pages and layers in the current document. 

Select Click to choose specific pages or layers to place. A dialog
box lists the available items. Shift-click two items to select a rang
Command-click (Mac) or Ctrl-click (Windows) to select multiple 
items and toggle selected items. Click OK to close the dialog box

Place pointer
DOCUMENT BASICS
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Using Canvas clip art

The Canvas clip art collection is stored in Canvas documents on 
ROM. For details, see “Using Canvas clip art” on page 11.1.

Because it is a locked storage medium, you can’t save document
a CD-ROM. If you open a document from the CD-ROM and want
save an edited version, you can store it elsewhere using the Save
command. You can also copy files from a CD-ROM to a hard disk
you can work with them without having the CD-ROM loaded.

Saving Canvas documents
The Save and Save As commands store a document on disk.

• The Save command updates a document file on disk and
overwrites the previously saved version.

• The Save As command lets you create a new file on disk
from an open document, save documents as templates, 
use other graphics and text file formats.

When you use these commands, the default format for storing do
ments is the native Canvas format.

To save a new Canvas document

1 Choose File > Save As. A directory dialog box opens.

2 Select a location to store the document and type a file name

3 Click Save to store the document on disk.

◆ To save changes to a document as you work: Choose Save in 
the File menu to update the document file on disk.

◆ To save a document with a different name or in a new loca-
tion: Choose Save As in the File menu, type a new name or sele
new location in the directory dialog box, and then click Save.

Saving selections and layers
You can use the Save As command and options in the Save direc
dialog box to save selections or layers, and create previews.

Save Entire Document. The default setting tells Canvas to save a 
complete document.

Save Selection. Choose this option after you select the objects in t
document that you want to save as a new document. If you don’t 
select anything, this option is not available. 

✔ Important
To avoid losing your work in 
the event of a power failure or 
system failure, use the Save 
command frequently as you 
work to store changes on disk.
Saving Canvas documents 4.5
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Save Layers. Select this option to save one or more layers in a new
document. Then, click Layers to specify which layers to save. Thi
option isn’t available if the document has only one layer.

Use Compression. Check this box to reduce the size of files saved 
disk.

Preview. Select the “Preview” option to save a low-resolution pre-
view of the document. In applications that support previews, you c
see a thumbnail image of the document before opening the file.

Use Preview Icon (Mac only). Canvas creates a finder icon with a 
preview of the document if you select this option.

Use Extensions (Mac only). Adds a three-character filename exten-
sion. Use this if you use Mac files on Windows systems.

Reverting to the saved version of a document
The Revert command lets you discard changes made to a docum
since it was last saved. This is the same as closing the documen
without saving changes, and then opening the original from disk.

Be certain that you want to discard all changes to a document be
choosing the Revert command, because you cannot use the Und
command to restore your work after using the Revert command. 

Keep in mind that you can use the Save As command to save a d
ment with a new name. If you are not certain that you want to disc
changes to a document, use Save As to store a new version on d
then open the original document and compare the two.

◆ To revert to a document’s saved version: Choose File > 
Revert. Before performing the command, Canvas asks you to con
firm that you want to discard all changes.

Closing documents
When you close a document, Canvas removes the document win
from the screen. Closing a document doesn’t save it (Canvas will
warn you if you try to close a document that has changed).

◆ To close a Canvas document: Choose File > Close. You can 
also click the Close box (Mac), or the Close button (Windows) in t
document’s title bar to close the document. 

Close box

Close button
DOCUMENT BASICS
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Working with document windows
Each document you open appears in its own window. You can w
with Canvas document windows the same as other windows. You
can resize a window, expand it to fill the screen, and minimize or r
it up. Canvas provides commands to organize and select docume
windows when more than one is open.

Selecting among open documents

When you open several documents at once, only one is active. T
Window menu displays the names of open Canvas documents. T
name of the active document has a check mark.

◆ To change the active window: Choose the document’s name 
in the list at the bottom of the Window menu. You can also click a
document’s window to make the document active. 

When you open more than one document, information in the Stat
bar, such as the pointer’s location, applies to the active documen
The same is true of floating palettes; palette settings apply to the 
active document and they change when you switch documents.

Arranging windows
When you open more than one document window, you can stack
distribute them on screen so they are easier to work with. 

When Canvas arranges document windows, it resizes them if nec
sary so they fit within the main program window or screen area.

◆ To arrange windows in rows: Choose Window > Tile Down.

◆ To arrange windows in columns: Choose Window > Tile 
Across.

◆ To arrange windows in a grid (Mac only): Choose Window > 
Tile.

◆ To stack all windows: Choose Window > Stack.

◆ To arrange icons of minimized windows (Windows only):

Choose Window > Arrange Icons.

Viewing documents
This section describes how you can adjust your view of a docume
Viewing options in Canvas let you
Working with document windows 4.7
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• control when Canvas redraws objects

• scroll to any area with the Hand tool or scroll bars

• increase or decrease the view magnification

• restore any view magnification and location

• display wireframe and process-color views

Controlling when Canvas refreshes the display
Canvas refreshes the display, which redraws all visible objects, w
you scroll or change magnification. When you work with complex
images, you can interrupt the redraw to save time, then refresh th
display when you’re ready.

◆ To interrupt display redraw: Press Command+Period (Mac) 
or Esc (Windows) during normal redraw. 

◆ To refresh the display: Choose Layout > Display > Refresh. 
You can refresh the display after interrupting screen redraw, or w
you want to refresh the display.

Scrolling documents
You can use scroll bars or the Hand tool to move to areas of a do
ment that aren’t displayed in the document window.

Using scroll bars

Document scroll bars represent the full document area. The posit
of the scroll box within a scroll bar indicates the current view area

To scroll using scroll bars, do one of the following:

• Click one of the arrows to move in the arrow direction.

• Drag the scroll box toward the part of the document you 
want to see. For example, drag up to see more of the top

• Click the scroll bar to scroll one screen length toward the
side of the scroll box that you clicked. For example, click 
the right of the scroll box to move one screen to the right

Using the Hand tool

Using the Hand tool to scroll a document is like sliding a piece of 
paper on a desktop.

Scroll box

Horizontal scroll bar

Vertical scroll bar
DOCUMENT BASICS
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To scroll with the Hand tool

1 Select the Hand tool from the toolbox. The pointer becomes
hand.

2 Drag to make the document follow the pointer. For example,
move a document up so you can see the bottom, drag toward the
of the screen.

Changing the view magnification
You can change your view of a document by changing the view m
nification. This is called “zooming,” and you can zoom in to make
objects appear larger or zoom out to see a larger area. Zooming 
changes the view on screen, but doesn’t change the actual size o
anything in the document.

You can zoom with the Magnifying Glass tool, the Zoom bar, the 
Zoom palette, and Zoom commands. You can use magnification 
els from 3.12 to 3,200 percent. Normal magnification is 100 perce

◆ To use a command to zoom: Choose Layout > Views > Zoom 
In or Zoom Out. Zoom In increases magnification to the next high
preset level; Zoom Out decreases magnification to the next lower
preset level.

◆ To enter a zoom percentage: Choose Layout > Views > 
Zoom, or press Command (Mac) or Ctrl (Windows) and the slash 
(/). Enter a zoom percentage from 3.12 to 3,200 in the dialog box 
press Enter or click OK.

Using zoom shortcuts
You can use keyboard shortcuts to access the Magnifying Glass 
and to zoom directly.

Mac To zoom in with the Magnifying Glass tool, press Option+Ta
or Option+Spacebar or Command+Spacebar and click or drag a 
around an area; to zoom out, press Option+Tab+Shift or 
Option+Shift+Spacebar or Command+Shift+Spacebar and click o
drag a box around an area.

To zoom in directly, press Command+Option+Plus (+). To zoom o
directly, press Command+Option+Minus (-).

Windows To zoom in with the Magnifying Glass tool, press 
Ctrl+Spacebar and click or drag a box around an area; to zoom o
press Ctrl+Shift+Spacebar and click or drag a box around an are

✔Tip
To temporarily switch to the 
Hand tool while using another 
tool, press the Spacebar and 
drag with the Hand pointer.
Changing the view magnification 4.9
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To zoom in directly, press Ctrl+Alt+Plus (+). To zoom out, press 
Ctrl+Alt+Minus (-).

Using the Zoom bar and Zoom palette
You can use the Zoom bar at the bottom left of the document wind
to adjust the view magnification. The Zoom bar displays the curre
magnification and lets you change magnification. You can also us
the Zoom bar to open the Zoom palette.

◆ To zoom to the next preset magnification level: Click the 
Zoom-in or Zoom-out button on the Zoom bar. The Zoom-in butto
increases magnification. The Zoom-out button decreases magnif
tion.

◆ To enter any magnification percentage: Type the magnifica-
tion percentage in the center of the Zoom bar.

If you open the Zoom palette, you can click the preset magnificat
levels or click anywhere on the slider bar. For example, click the 
slider bar between 50 and 100 to set the magnification level to 
approximately 75 percent.

Using the magnifying glass
You can use the Magnifying Glass tool to zoom in and out from a
area that you select in the document.

1 Select the Magnifying Glass tool in the toolbox. The pointer
becomes a magnifying glass with a plus sign. 

2 Click the center of the area you want to magnify. Canvas 
zooms to the next higher preset magnification level and centers
view at the point you clicked.

3 To reduce rather than magnify, Shift-click the area you want
center on screen at reduced magnification.

◆ To magnify an area to fill the screen: With the Magnifying 
Glass tool, drag a box around the area you want to magnify.

100%

A Zoom out
B Magnification level
C Zoom palette button
D Zoom in

BA C D

Zoom bar

Zoom palette

To open the palette, click 
the arrow on the Zoom bar 

Drag the slider to any magnification value

Click a magnification value

✔Tip
To quickly magnify an object, 
select the object and click the 
Zoom-in button.
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Using Views commands
You can use Views commands to quickly change your view of the
current document. Choose the following commands in the Layou
Views submenu.

Home view Displays the upper-left corner of the document at no
mal (100 percent) magnification. 

Fit to Window Reduces or increases magnification to the maxi-
mum magnification level for the layout area to fill the document w
dow.

Fit to Selection Reduces or increases magnification to the maxi-
mum magnification level for the selected objects to be visible in th
document window.

Fit to Objects Reduces or increases magnification to the maximu
magnification level for all objects on the current page, sheet, slide
frame to be visible in the document window.

Using custom views
You can create custom views to save the current magnification le
and position in the document. After you create a custom view, yo
can select its name in the Layout > Views submenu under Home
View. A check mark appears next to the view name when a custo
view is selected. Canvas assigns shortcut keys (which appear in 
menu) so you can quickly select the custom views you have crea

To remove a custom view

1 Choose Layout > Views > Delete View. If only one custom 
view exists, Canvas deletes it. 
Using Views commands 4.11
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the Delete Views dialog box opens. Select a view and click OK.
Canvas removes the selected view from the Views submenu.

Using the Navigator palette 
The Navigator palette provides an overview of a document. You c
use this floating palette to scroll the document and zoom in and o

◆ To display the Navigator palette: Choose Window > Palettes 
> Navigator. You can also click the small triangle button on the 
Zoom bar to open the Navigator palette.

Zooming and scrolling

The window in the Navigator palette shows a reduced-size view o
the entire layout area. A red rectangle, the view box, represents the 
current zoom level and view position in the document. The box is
small when you zoom in to view details, and becomes large (rela
to the layout area) as you zoom out.

Scrolling In the Navigator window, you can move the view box to
change your view:

Drag the view box to the part of the layout area you want to see. 
see the top of a page, for example, drag the box to the top of the 
out area.

Click in the Navigator window to quickly change views. The view 
box moves and the view is centered where you clicked.

Navigator palette window

Layout area

Zoom box
2 DOCUMENT BASICS
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Zooming You can use the zoom buttons and the text box to chan
the magnification level. These controls are also in the Zoom bar a
the bottom of the document window.

Type a zoom percentage in the text box to change the magnificat
level. Type a higher number to zoom in or a lower number to zoo
out. Normal magnification is 100%.

Click the Zoom-in button on the right to double the magnification 
level. Click the Zoom-out button on the left to reduce magnificatio
by half.

Rotating the layout area

To rotate the layout area, choose one of the four rotation options f
the pop-up menu to the left of the Zoom-out button. The rotation 
options are also available from the pop-up menu at the left end of
Zoom bar.

Note: Rotating the layout area can help you when you create doc
ments, but it does not change a document’s orientation; rotating t
layout area does not affect the printer setup or document setup.

View options

You can choose view options from the Navigator palette’s pop-up
menu. This menu contains the same commands as the Layout > 
Views submenu. You can choose Home View, Zoom In and Zoom
Out, custom views that you have saved, and commands that mak
objects or the entire layout area visible in the window.

Display modes
The normal Canvas display mode shows all objects with their ink
strokes, and other attributes as they are in the document.

Canvas provides several special-purpose display modes: Gamut
Warning, Wireframe and Ink Coverage.

When a special display mode is active, a check mark appears ne
the command in the Layout > Display submenu. To turn the displ
mode on or off, choose the command.

Gamut Warning

This mode highlights colors that are outside the CMYK color gam
It replaces out-of-gamut colors with a special indicator color. By 
default, the indicator color is bright green.
Display modes 4.13
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◆ To select Gamut Warning mode: Choose Layout > Display > 
Gamut Warning. 

To change the Gamut Warning color, choose Edit > Calibration >
Gamut Warning.

Wireframe

Wireframe mode shows vector objects in position without their 
assigned ink or stroke attributes. When Wireframe is selected, ve
objects are hollow and have 1-point black pen strokes. Text chara
ters appears solid black. Paint objects appear as usual. 

Wireframe mode speeds up the screen display and lets you see 
through vector objects.

◆ To select Wireframe mode: Choose Layout > Display > Wire-
frame.

Caching objects for faster display
The Cache Object command can be used to speed up the displa
complex objects. This is useful when a document contains compl
objects that you do not need to edit often. When you cache an ob
Canvas stores a low-resolution preview in memory. The preview c
be displayed quickly when you move the object or change views.
You can cache any type of object for faster display.

To cache an object

1 Select the object to cache.

2 Choose Object > Options > Cache Object. 

3 A dialog box appears. Enter a preview resolution value, from
to 300 pixels per inch, in the text box. Lower resolutions produc
rougher previews.

4 Click OK. Canvas displays a preview of the cached object a
the resolution you entered.

To uncache an object

The Uncache Object command replaces the preview of a cached
object with the actual object at normal resolution.

1 Select a cached object.

2 Choose Object > Options > Uncache Object. Canvas displa
the object at its normal resolution.
4 DOCUMENT BASICS
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Cache display options
Two options in the Display Options dialog box let you control cac
ing and display of cached objects. Caching in Canvas is a techniq
that can dramatically increase display speed. 

When an object is cached, Canvas creates a low-resolution versio
the object to display on screen. This can make it much easier to w
in documents that contain complex vector objects or high-resoluti
images, which can significantly slow down zooming and scrolling

When you are not editing cached objects, it usually won’t matter t
they are displayed at lower resolution. You’ll enjoy significantly 
faster display without losing any capabilities. When you do want t
edit a cached object, Canvas loads the original; you do not need 
take any special action or uncache the object.

To set caching options

1 Choose Layout > Display Options.

2 Select or deselect options in the Cache area (described nex
and click OK to implement the settings.

Draw with Cache option

Select this option to display low-resolution versions of cached 
objects for faster display. Cached objects are objects that have b
cached with either the Cache Object command or the Auto Cach
Images option (described next).

When Draw with Cache is not selected, Canvas retains any low-r
lution previews that it has created in memory, but displays the ful
paths of vector objects and displays paint objects at normal resol
tion.

Auto Cache Images option

Select Auto Cache Images to automatically cache paint objects 
whose resolution is above a threshold that you specify.

To set the resolution threshold, enter a value from 72-2540 ppi in
first text box. When the resolution of a paint object is equal to or 
greater than the specified resolution, Canvas caches the paint ob

Cached paint objects are displayed at low resolution for faster dis
play. Enter the desired display resolution in the second text box.
Caching objects for faster display 4.15
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Note: If Auto Cache Images is selected, but Draw with Cache is n
selected, Canvas will cache paint objects (if their resolution is abo
the threshold you set), but will not display the low-resolution ver-
sions.

To uncache all paint objects, deselect Auto Cache Images. A me
sage appears. Click Yes to uncache all paint objects. This is equi
lent to using the Uncache Object command on each paint object 
individually.

Note: If you want to uncache paint objects and Auto Cache Image
already cleared, use the Uncache Object command instead.

Viewing and editing document properties
With the Properties command, you can view the properties of doc
ments. You can view standard data and add your own meta data
document.

To view or edit properties

1 Choose File > Properties. The Properties dialog box contains
following tabs: General, Statistics, Summary, and Custom. 

2 Click a tab to display its options. Use the procedures later in t
section to edit the options, where applicable, then click OK to imp
ment the settings.

Note: The document must be saved for some of its properties to b
displayed.

Choosing a property

To view or customize a property, select a tab from the Properties
log box.

General Describes general information about a saved documen
such as type, location, size, attributes, when it was created, and w
it was last modified.

For Mac only, the Finder Comments box lets you view the comme
that appear in the Finder’s Get Info comment window for the docu
ment.

Statistics Displays when the document was created and when it
was last modified. It also shows the last time the document was 
printed, the name of the person it was last saved by, the number 
revisions, and the total editing time.
6 DOCUMENT BASICS
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The Statistics box contains information about the document and t
objects contained in it.

Note: The creation time can be different on the General and Statis
tabs. The Statistics tabs displays the date and time the document
created as a new document. The General tab displays the time it
first saved.

Summary Lets you customize information about the document. 
You can enter a title, subject, author, manager, and company.

In the Category and Keyword boxes, you can type data to catego
the document. 

The Comments box lets you type comments about the document

Custom Lets you add custom data to the document. You can 
choose names and data types for these entries, as described nex

To enter custom data

1 Choose a name from the list for the data entry, or to create a 
data name, type a name in the Name text box. 

2 Choose a data type from the Type menu. You can choose Te
Date, Number, or Yes or No. Then, depending on the type, enter 
value in the Value box.

• For Text, type any text value. 

• For Date, type a date from 1/1/1601 through 12/31/9999.

• For Number, type a numeric value. 

Pre-defined data names
Viewing and editing document properties 4.17
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• For Yes or No, click Yes or No.

3 Click Add to add the data entry to the Properties box.

To modify a data entry

Click the entry in the Properties box, then change the type or valu
You cannot change the name of the entry. Click Modify to apply t
change.

To delete a data entry

Click the entry in the Properties box, then click Delete.

Printing documents 
Canvas works with all standard desktop printing devices, includin
PostScript and non-PostScript printers. You can print Canvas doc
ments using black-and-white or color devices. 

This section focuses on printing to desktop printers. For complete
information on printing options and special printing situations, 
including color separations, refer to on-line Help in Canvas. For 
information on installing, setting up and selecting a printer to use,
refer to your operating system documentation. 

How Canvas prints documents

A few key factors affect how Canvas prints a document. Canvas 
decides which objects to print based on the following:

• Document boundary. Canvas does not print objects that ar
outside the layout area (the rectangle that represents the
document on screen). Objects that are partly inside and 
partly outside the layout area will be cropped in the printo

• Visible layers. Objects on layers that are not visible are no
printed.

• Printable layers. If a layer’s print option (in the Document 
Layout palette) is off, nothing on the layer is printed.

• Printable objects. If an object is made non-printable (in the
Document Layout palette or the Trap tab in Object Specs
the object will not print.

Using Page Setup
To set page options, choose File > Page Setup. The settings affec
document’s layout area in Canvas and the way a document is prin
8 DOCUMENT BASICS
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It’s best to set these options when you create a document so you
see page breaks correctly on-screen.

Center On Paper Centers a document on the printed page. If 
you’re printing selected objects only, Canvas shifts the selected ite
to the center of the printed media. This option can be useful when
you have selected objects that you want to print in the center of th
page, but they are not centered in the document itself.

Fit To Paper Scales a document to fit within the page’s printable
area. Keep in mind that objects that are outside the layout area, w
not be printed.

Tile Prints a large document by dividing it among “tiles” of printe
pages. Type an overlap amount in the text box so part of the doc
ment repeats at the edge of adjoining tiles; the overlap makes it ea
to assemble the complete document after printing.

Previewing and printing
Choose File > Print Preview to check print settings and the comp
tion of a document before printing.

Print preview reflects the current print settings and the page setu
These settings include the type of output (composite or color sep
tions), the pages to print, tiling, centering, printing blank pages, a
printing in color.

In the preview, you can see which objects, layers, and pages will
printed. You can make sure the layout fits in the printable area of 
paper. When you use the Tile option, the preview shows the tiles
separate pages. 

When you finish previewing a document, click Print to send it to th
current printer. Click Done to return to the document without print
ing.

Click the zoom buttons to increase or decrease the magnification
the preview. Click the arrow buttons to cycle through the pages. I
you are previewing separations, click the plate buttons to cycle 
through the plates that will be printed for each page.

To print a document 

1 Choose File > Print. The Print dialog box appears.

2 Enter the number of copies and the pages to print, and then s
other options. Click Print (Mac) or OK (Windows). 
Printing documents 4.19
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Desktop printing options
This section describes the primary options you can use for printin
documents on desktop printers.

Printing multiple scaled pages

In the Thumbnails pop-up menu, you can select an option to print
multiple document pages on each printer page.

Choose 1/Page to print a document at actual size, with one docum
page on each printer page. If the document is larger than the prin
paper, the document will not be scaled; you can select the Tile op
to print the document on multiple sheets of paper.

To scale and print multiple document pages on each printer page
choose an option to set the number of document pages to print. T
document pages will be scaled as necessary to fit the printer pag
The amount of scaling depends on the size of the document page
and the size of the printer pages.

For example, if you want to print six document pages as thumbna
images on a printer page, choose 6/Page.

Output options
Collate Copies Prints all pages of the document in order based o
the number of copies requested, rather than printing all copies of
page 1, all copies of page 2, and so on.

Skip Blank Pages Does not output document pages (or separatio
plates) that are completely blank.
0 DOCUMENT BASICS
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Reverse Order Prints from the last page to the first, keeping page
in the correct order if the printer stacks pages face-up in the outp
tray.

Print Facing Pages If the document is formatted for spreads, Can
vas prints facing pages on a single page. This option is available 
printing Publications only.

Color Mode

Choose an option from the Color Mode menu to control color acc
racy when using a color printer. In general, when you print to a co
printer, it’s best to choose a color specification that matches the c
ors in the document you’re printing. For example, choose CMYK 
your document contains CMYK colors only.

RGB Outputs colors using RGB color specifications. A non-color
printer will convert the color values to print as shades of gray.

Black & White Prints all colors as black or white.

Colors As Grays Canvas converts color values to shades of gray 
printing on any printer, including color printers.

CIE L*a*b Uses color calibration to try to match printed colors to 
their appearance on screen. Keep in mind that many on-screen h
cannot be reproduced on paper with printing inks. For example, c
ors that look bright and saturated on screen, such as hot pink, cy
and brilliant orange, will appear muted in printed materials.

CMYK Outputs colors using CMYK color specifications. A non-
color printer will convert the color values to print as shades of gra

Image compression 
In the Image Compression menu, choose a format for output of 
image data to a PostScript device or file. The format you choose 
affects the amount of data transmitted and the size of a PostScrip
file. This setting can affect compatibility with networks and Post-
Script printers.

Note: Rendered transparency effects are also transmitted as imag
data when printing to PostScript printers.

ASCII Outputs image data as plain text. This is the most compati
format, but it transmits (or saves in files) the largest amount of da

✔Tip
Some documents can be larger 
than the paper in your printer. 
To print the entire document, 
select the Tile option in the 
Page Setup dialog box. Canvas 
will “tile” (divide) the docu-
ment into a series of pages 
matching the paper size of your 
printer.
Printing documents 4.21
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Binary Outputs images as binary data, which might not be comp
ble with all printers and networks. Binary data is half the size of 
ASCII data.

Level 2 ASCII Outputs images in an ASCII format that is compat
ble with PostScript Level 2 devices. This produces files that are 
approximately 20% smaller than regular ASCII PostScript files.

RLE Outputs images using Run Length Encoding compression. 
This format is compatible with PostScript Level 2 devices. This for
of compression is most efficient when documents contain images 
have large areas of flat color. 

JPEG Outputs images using JPEG compression. This format is 
compatible with PostScript Level 2 devices. JPEG compression 
requires more system memory and more processing time at the 
printer than other compression methods. However, this format 
achieves the fastest printing results with continuous-tone (photo-
graphic) images and documents containing transparency effects.

Note: By default, Canvas uses JPEG compression for printing 
images. This can reduce the amount of data sent to the printer. If
network print spooler reports errors with a JPEG data stream, sel
Images: ASCII or Level 2 ASCII and try printing again. The Image
setting affects printing of images and rendered effects only.

Printing proxies 
Print Proxied Images at Full Resolution Prints the high-resolution 
images that are linked to the proxies in the document. Canvas out
the images from the linked files on your computer. If you do not 
select this option, Canvas prints proxy images rather than the hig
resolution images. This is faster and could be adequate when you
proofing other parts of a document.

Transparency Rendering 
Choose an option in the Transparency Rendering menu to specif
how transparency and SpriteEffects will be rendered (converted t
pixels for printing).

Smallest Area Renders the area inside the bounding box of all 
transparent objects. This generates the least amount of additional
to print transparency effects. Do not choose this option if you are
printing in color on non-PostScript printers and the document has
vector and transparent objects that share the same color, becaus
these printers will not match the colors precisely. In some cases, 
2 DOCUMENT BASICS
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standard PostScript printers might produce a slight pixel shift 
between a transparent and non-transparent area of a vector obje
this happens, select Complete Area.

Complete Area Renders the area within the bounding boxes of a
transparent objects, as well as objects that are overlapped by tran
ent objects (or intervening objects). This is the best setting to use
when you print to a non-PostScript printer, such as a Windows G
printer, to avoid color-matching problems

Entire Document Renders all objects in the document as one or 
more images that are sent to the printer. This is equivalent to proc
ing the document in an internal RIP (raster image processor) in C
vas. This option produces the greatest amount of image data. 
However, this option can be useful if you experience problems pr
ducing accurate output of transparency or other effects when you
a particular printer or printer driver.

Don’t Render Transparent Objects Does not render any transpar-
ency effects in the document. If you select this option, transparen
(SpriteLayer) and image (SpriteEffects) effects will not be printed
transparent objects will be printed as opaque objects. 

The one exception to this rule involves vector objects that have a
transparency Scope setting of Fill only when printing to a PostScr
printer, because PostScript can print transparent fill inks in vector
objects without rendering. For information on the Scope setting, s
“To set an object’s transparency scope” on page 14.5.

You might want to select Don’t Render Transparent Objects if you
need to quickly print a proof of a complex document. This allows y
to check the positioning of objects without seeing the final transpa
ency effects.

Printing text with effects

Because of the way that Canvas renders SpriteLayer effects, text
is not in front of all other objects can be output as rendered image
rather than text. If you want to avoid rendering of text for printing,
select Text Always In Front. Canvas will print the text objects in 
front of all other objects.

If you have text that has special effects or is behind transparent 
objects, you should not select this option, so the text will be rende
and printed as it appears in the document.
Printing documents 4.23
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Placing crop marks
For print production, you can place crop marks around specific 
objects in your document. This is useful when you want to control 
exact placement of crop marks, or you want to output several illus
tions with crop marks around each illustration on one page.

Crop marks are short vertical and horizontal lines that indicate the
border where an illustration or page can be trimmed.

When you use the Crop Marks commands, Canvas draws the cro
marks as vector lines on the current layer in the document. Each 
mark consists of two lines. You can select the lines and perform o
ations on them as you would other vector objects.

To place crop marks

1 Select the objects you want to place crop marks around. Yo
can select one or more objects of any type.

2 Choose Object > Options > Crop Marks. 

3 The Crop Marks dialog box appears. In the Outset box, ente
the distance you want the crop boundary to be from the selectio

• If one object is selected, the selection boundary is the 
object’s bounding box.

• If more than one object is selected, the selection boundar
the smallest rectangle that would enclose all the selected
objects.

4 Select the Use Registration Ink option to assign Registration
ink color to the crop marks. Registration ink appears black, but 
prints on all plates when you output color separations. This opti
should be selected if you want the crop marks to print on all pla

5 Click OK to create the crop marks.

Crop marks
4 DOCUMENT BASICS



CHAPTER

5

nt 

et 

-
nta-

t 
the 
ew 
 tem-

ents 
 time 
.

 
. 
DOCUMENT SETUP

When you create a new Canvas document, you select a docume
type. Then you specify the document size and other options.

This chapter explains how to create new documents and how to s
up document rulers, drawing scales, guides, and alignment grids.

Creating new documents
When you want to create a new document, you use the New com
mand and tell Canvas to create an Illustration, Publication, Prese
tion, or Animation document. 

When you start Canvas the first time, a new Illustration documen
appears. When you start the program after that, Canvas creates 
same type of document you selected the last time you used the N
command. If you also selected a template, Canvas uses the same
plate for the document it creates at startup.

If you start Canvas by double-clicking a document icon, Canvas 
opens the document without creating a new document. 

You can create new documents any time, even with other docum
open. The number of documents you can have open at the same
is limited only by the amount of memory available on your system

To create a new document

1 Choose File > New. 

2 Select options for the new document (described next)

3 Click OK to create the document.

Options for new documents
In the New dialog box, you can choose a document type, select a
template, specify document size, and choose measurement units
5.1
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Type of Document Select Illustration, Publication, Animation, or 
Presentation. These types are described next.

Use Template To base the new document on a template, select 
template from the menu. See “Using document templates” on 
page 5.3.

Document size Select a document size from the menu. You can 
select preset sizes, or set the document size to the printer paper,
enter a custom size. To set up a custom size, choose Custom an
enter the width ( ) and the height ( ).

Orientation To change the orientation of the document, click the
 button. This swaps the width and height values. 

Document units Choose the general measurement units for the 
document from the menu.

Facing pages For a Publication document, select this option to 
specify a document with facing (two-sided) pages. A facing-page
document has a master page with left and right pages.

Wizard Click the Wizard button if you want the New Document 
Wizard to guide you through the options for setting up a new doc
ment.

Choosing a document type
When you create a new document, you can select an Illustration,
Publication, Presentation or Animation document. 

Options based on
document type
DOCUMENT SETUP
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Illustration documents 

Illustration documents are general-purpose documents for all type
illustrations and graphics. You can specify a custom document si
and the document can have multiple pages (called “sheets”), with
multiple layers on each sheet. 

When the active document is an Illustration, the icons at the botto
of the window represent the document’s sheets. You can click an
icon to move to that sheet.

Publication documents 

Publication documents are designed for publications printed with 
two-sided (facing) pages, although you can also create a Publica
that has pages with single sides. You can use master pages to ho
items that you want to appear throughout the publication. You ca
also use multiple layers on each page.

When the active document is a Publication, you can use page ico
the bottom of the window to move among the document’s pages.

Presentation and Animation documents 

Presentation documents are designed for on-screen “slide show”
sentations. Animation documents are designed for creating anima
files.

In Presentation documents, you can use multiple layers and a ma
slide to hold background elements. You can use more than a doz
transition effects, including wipe and dissolve, during slide show 
playback. 

When the active document is a Presentation, you can use slide ic
at the bottom of the window to easily move among the slides.

An Animation document is designed for creating and editing web 
(GIF) animation files. An animation is composed of multiple frames, 
which are equivalent to the image frames of film-based animation

You can use “onion-skinning” in an Animation document. When yo
select onion-skinning, frames adjacent to the current frame appea
the background. This is helpful for setting up object movement in
animation. 

Using document templates
Templates are special Canvas documents that you can use as th
basis for new documents. When you select a template in the New

D o l o r o l u m o u s
Creating new documents 5.3
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log box, Canvas creates a new document containing the graphics
text in the template and uses the template’s settings for layers, sli
pages, rulers, grids, guides, views, and default object attributes.

How is a template different than a regular Canvas document? Wh
you choose a template in the New dialog box, Canvas creates a n
document based on the template, but doesn’t actually open the te
plate file. When you make changes to the new document and sav
to disk, the changes don’t affect the template.

Canvas treats a template in a similar way when you open one by 
ble-clicking its icon or using the Open command. In either case, 
rather than open the actual template document, Canvas makes a
document based on the template’s document type and contents.

Templates, like regular Canvas documents, are various types: Illu
tration, Presentation, Publication, and Animation. In the New dialo
box, the templates listed in the “Use Template” pop-up menu mat
the document type selected in the “Type of Document” area.

Setting up documents
After you create a document, you can use the Document Setup di
box to change the document’s measurement units, size, orientati
and other options.

The Document Setup dialog box presents similar options for each
type of document, with some specific options for a particular docu
ment type. For example, in a Publication document, you can set f
ing pages and page margins. In a Presentation document, you ca
specify screen size.

To set up a document

1 Choose Layout > Document Setup. 

2 The Document Setup dialog box appears. Select the option
you want and click OK.

Document Setup options
The following options are available in all document types, except 
noted.

Document Units

To specify measurement units, choose an option in the Documen
Units pop-up menu. 
DOCUMENT SETUP
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Select Inches, Points, Centimeters, or Picas to see the size of the
ument in these units in the boxes in the Illustration size area. Sele
Ruler Units to use the units specified in the Ruler dialog box. To 
change the units specified in the Ruler dialog box, choose Layou
Rulers.

Document Size

You can set the document size to match the paper in your printer
set up a document based on a standard or custom size. The con
for document size are labeled according to the type of document 
(Illustration, Publication, and so on).

To use a standard size, choose an option from the pop-up menu.
can choose standard sizes based on the document type.

From Printer To base the dimensions of the layout area on your 
printer’s page size, choose From Printer. The layout area will ma
the settings in the Page Setup dialog box. For more information, 
“Matching documents to printer pages” on page 5.6.

Custom To specify custom dimensions, choose Custom. Type th
width in the first box and the height in the second box.

From Screen In Presentations and Animations, you can base the
size of the layout area on the monitor’s size. To do this, choose F
Screen.

Orientation 

To change the orientation of the document, click the button in the
Orientation area. This swaps the width and height values of the d
ment.

Margins

To set margin size for two-sided Publications, enter the Inside, O
side, Top, and Bottom margins in the text boxes in the Margins a
For single-sided Publications, enter Right, Left, Top, and Bottom 
margins. The margin is measured from the edge of the paper. Ma
gins are not available in other document types.

On screen, the document’s margins appear as a dashed line. The
printable area appears as a solid line around the edge of the layo
area. Make sure the margins are not outside the printable area.

Page Layout 

To specify multiple pages per sheet in a Publication, choose Ten
Card or Greeting Card in the Sheet Layout pop-up menu.

✔Tip
For illustrations larger than the 
current paper size, you can use 
the Display> Show/Hide Page 
Breaks command in the Layout 
menu to see or hide page divi-
sions. A line around the layout 
area indicates page bound-
aries.
Setting up documents 5.5
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Facing Pages

To create double-sided pages, select Facing Pages. When you s
this option, a message appears. Click OK to proceed. Once you s
Facing Pages for a Publication, it cannot be deselected. In additio
when Facing Pages is on, the document has a left and a right ma
page that you can apply to its left-hand and right-hand pages. Th
option is available in Publication documents only.

Paper Color Lets you apply a solid color to the document layout 
area. The paper color is for display purposes only and does not 
print.To apply a paper color, select a color from the pop-up palett

Note: When objects are partially transparent, the paper color is vis
ble through the objects. However, while the paper color is not visi
through solid objects, in the real world, the colors of objects will b
affected by the color of the paper they are printed on. For exampl
yellow circle printed on blue paper will appear green. This is not 
shown on screen in Canvas when you use the Paper Color option

Canvas includes the paper color when it renders transparent obje
so the paper color affects the rendered image the same as it doe
screen in Canvas.

Matching documents to printer pages
Selecting “From Printer” in the Document Setup dialog box tells 
Canvas to use the page information from the Page Setup dialog b
Canvas sets the orientation and dimensions In the Document Se
dialog box to match the selected page size. 

When From Printer is selected and you change the page settings
Canvas changes the dimensions of the document to match. You 
choose File > Page Setup to change the paper size, or its orienta
Canvas will update the dimensions of the document and you do n
have to choose Layout > Document Setup. 

When the document type is Illustration, and you select From Prin
the document size is equal to the printable area of the paper selected 
in the Page Setup dialog box. For all other document types, the d
ment size is equal to the paper size, rather than the printable area. 

Paper

Printable area
DOCUMENT SETUP
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On most printers, the printable area is smaller than the paper size
Illustration documents are sized to the printable area, so illustratio
will fit on the paper without being scaled. You should note that the
printable area on many printers is not centered exactly on the pap

Canvas takes scaling into account when it sets the document dim
sions and you specify a scaling factor in the Page Setup dialog bo
you specify 50% scaling, for example, the document size will be 
twice the page size (or twice the printable area size in an Illustrati

When From Printer is selected, Canvas checks the Page Setup in
mation each time you open the document. If necessary, it adjusts
document’s dimensions to match the page information.

Setting up rulers and the drawing scale
You can set up rulers for a document using various units of meas
and display the rulers at the top and left of the document window
Rulers help you track the pointer’s movement and let you create 
alignment guides in the layout area.

When you set up rulers, you also set the document’s drawing sca
Canvas bases the rulers and all object measurements on the dra
scale. 

For example, if you set the drawing scale to 1 inch = 1 foot, and dr
a line 1 inch long on screen, Canvas displays the line’s length as
foot. Canvas uses scale measurements in the Object Specs palet
information area of the Status bar, and in dimension objects.

You can use inches, points, centimeters, and picas as a documen
base unit of measurement. For the drawing scale, you can relate 
base unit to inches, feet, miles, picas, pixels, metric units, and yo
own custom units.

✔Tip
To see or hide the printable 
area, you can use the Display > 
Show/Hide Printable Area 
command in the Layout menu. 
Canvas indicates the printable 
area by a solid line around the 
border of the page.
Setting up rulers and the drawing scale 5.7
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To set up rulers and drawing scales

1 Choose Rulers in the Layout menu. In the Rulers dialog box
choose a ruler number in the Ruler pop-up menu. You can use 
default rulers or customize them.

2 To change the measurement units, choose the units in the U
pop-up menu. Canvas sets up the ruler’s major divisions based
the units you choose.

3 Set the drawing scale using the text boxes in the Scale area
the first box, type the base unit measurement. In the second bo
type the scaled equivalent. In the third box, enter the units for th
scaled measurement. You can type a custom unit here; Canvas
use the first two letters in dialog boxes and dimensions. The tabl
left shows examples of settings for various drawing scales.

4 Choose a setting for the ruler’s minor divisions in the pop-up
menu under the Scale boxes.

5 To establish the ruler’s major divisions, drag the double arro
between the two rulers. Drag to the unit of the top ruler that you
want to be the major division. The major division also determine
the major division of the alignment grid.

6 After you configure all ruler settings, click OK.

To display and hide rulers

When you want rulers to appear on screen, choose Layout > 
Display > Show Rulers. To hide the rulers, choose Layout > 
Display > Hide Rulers. The rulers must be displayed if you want t
create alignment guides in the layout area.

To change rulers

When the document rulers are visible, you can change the curren
ruler by pressing the button in the upper-left corner of the docume
and selecting a ruler from the pop-up menu that appears.

Scale values

1 inch = 6 inches 1 6 inches

5 inches = 1 mile 5 1 miles

10 cm = 1 meter 10 1 meters

Rulers menu

Ruler number

Press to open menu
DOCUMENT SETUP
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To change the rulers’ zero points

The default zero point for each ruler is at the top-left corner of the
illustration area. To change the zero point, drag from the intersec
of the rulers. As you drag the zero point, intersecting lines follow t
pointer. To return the rulers to the default zero point, click the box
where the rulers intersect.

To use ‘tear-off’ rulers

When rulers are displayed, you can move a copy of a ruler into th
layout area to measure specific areas of an illustration. When you
off a ruler and move it, Canvas takes a snapshot of the ruler and 
pastes it into the document as a paint object. A tear-off ruler isn’t 
active like the rulers displayed at the window edges. 

◆ To place a tear-off ruler in a document: Point to the ruler you 
want to tear off, press Option (Mac) or Alt (Windows) and drag a 
copy of the ruler into the document.

Using the alignment grid
You can display a grid of vertical and horizontal lines to aid in pos
tioning objects in a document. You can also turn on the snap-to-g
feature to make Canvas snap objects into alignment with the grid
when you drag near a grid line.

When snap-to-grid is active, the pointer movements snap to the g
according to the settings in the Grids dialog box.

◆ To display grid lines on screen: Choose Layout > Display > 
Show Grids. To turn off grids, choose Layout > Display > Hide 
Grids.

◆ To turn on snap-to-grid: Choose Layout > Snap To > Grid. 
Choose the command again to turn off snap-to-grid.

◆ To temporarily override the grid constraint: Press Tab as you 
create, resize, or move objects.
Using the alignment grid 5.9
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To set up the alignment grid

1 Choose Layout > Grids. The Grids dialog box appears.

2 Type a value in the Line Distance X: Units text box. This is th
distance from one vertical grid line to another. 

3 Type a value in the Line Distance Y: Units text box. This is th
distance from one horizontal grid line to another.

4 Type a value in the Snap Factor X: Fields text box. This val
sets the snap points along the horizontal lines of the grid. 

5 Type a value in the Snap Factor Y: Fields text box. This val
sets the snap points along the vertical lines of the grid. 

You can enter decimal or fractional values; Canvas converts frac
tional values to decimal values. For example, if the Line Distance 
inch, a Snap Factor of 1/2 Fields sets snap points every 1/2 inch.

6 Select Snap to X and Snap to Y to make objects snap to the
snap points on both sets of grid lines. 

7 Click OK to implement the grid settings.

Grid lines

X
Y

Snap points 
set at 1/2 of 
grid spacing

1/2

1/2

1/2 1/2

Illustration area
0 DOCUMENT SETUP
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Using alignment guides
You can create alignment guides and alignment objects. Other 
objects can “snap” to alignment guides and objects.

Alignment guides are horizontal and vertical lines you can drag int
document from the document rulers. When you create alignment
guides, Canvas places the guides on a guide layer. 

You can also create guide objects from any vector objects. Guide
objects are placed on a guide layer. If you draw a rectangle on a g
layer, for example, objects can snap to the sides of the rectangle

Alignment guides and objects normally do not print, because the 
guide layers are set to be non-printing.

◆ To activate snapping to guides: Choose Layout > Snap To > 
Guides. When the snap-to feature is active, objects you move wil
snap to alignment guides and objects on guide layers.

To set up alignment guides

1 To display the document rulers, if they are hidden, choose L
out > Display > Show Rulers.

2 Point to either ruler and drag a guide into the document are
To remove a guide, drag the guide back to its ruler.

◆ To show or hide guides: Choose Layout > Display > Show 
Guides or Layout > Display > Hide Guides.

◆ To move objects touching an alignment guide: Press Option 
(Mac) or Ctrl (Windows) as you drag an alignment guide. This 
method does not apply to alignment objects on a guide layer.

To set up alignment objects

1 Select one or more vector objects.

2 Choose Object > Arrange > Send to Guide Layer. Canvas 
moves the selected objects to the guide layer on the current pag

The ink and stroke attributes of guide objects are overridden by 
default on guide layers. Guide objects appear with a blue pen ink,
point stroke, and no fill ink. If you move an alignment object off a 
guide layer, its original attributes reappear.

You can edit guide objects without moving them off a guide layer
For example, you can select a guide object, drag its selection han
use freeform mode to transform it, and use edit mode to reshape
Using alignment guides 5.11
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To position guides numerically

After you place a guide line in a document, you can set its positio
numerically.

1 Double-click an alignment guide. 

2 A dialog box appears. 

• Select Horizontal or Vertical to set the guide’s orientation

• In the text box, enter the distance to place the guide from 
ruler’s zero point. Positive values go down and to the righ
from the zero point. Negative values go up and to the left

3 Click OK.

When you enter a value for the position of a guide, you can use t
current measurement units, or enter a unit abbreviation. For exam
to place a vertical guide 3 inches to the right of the zero point, typ
“3in” (without quotes) if the current units are not inches. To set a h
izontal guide 2 picas above the zero point, type “-2p”.
2 DOCUMENT SETUP
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DOCUMENT LAYOUT

Canvas provides great flexibility in document layout. You can use
multiple pages and layers in any document. You can set up mast
pages, shared layers, guide layers, and grid layers. Layout option
also include slide transitions and timing for GIF animations. 

This chapter describes document layout options and procedures,
including how to add, delete, and arrange pages and layers, and 
the Document Layout palette.

About document pages and layers
You can create four types of documents in Canvas: Illustrations, P
lications, Presentations, and Animations. The common elements 
all document types are pages and layers.

Pages

All Canvas documents can contain multiple pages. Here, “pages”
used as a general term for elements that make up a document. 

• Publications can have single or facing pages.

• Illustrations have pages, called “sheets,” which are single
sided.

• Presentations have pages, called “slides,” which can be 
played in sequence as “slide shows.”

• Animations have pages, called “frames,” which form ani-
mation sequences for animated GIF files.

In the Document Layout palette, pages are at the top level of the 
out hierarchy, followed by layers, groups, and objects. 

The Layout area in Canvas represents a document page. Page ic
below the document window show the sequence of pages in a do
ment. The icon for the current page is shaded.

Layers

A layer is a transparent level that objects are placed on. Pages a
made of one or more layers. When you place or draw objects on 
page, you actually place the objects on the page’s layers. 

Layout area
6.1
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In the Document Layout palette, a page’s layers are listed after th
page name. Objects are listed after the layer they are on. A new p
has one layer (Layer #1). You can add layers to any page, includ
master pages. 

Layers can help you work efficiently. You can organize objects on
layers, and you can display, print, and save layers individually.

You can save time and resources by sharing layers in a documen
shared layer is similar to a master page. As with a master page, 
objects on a shared layer appear on every page where the shared
is applied. You can update multiple pages by editing a shared lay

Master pages

Master pages are special types of pages. The objects on the mas
page’s layers can appear on every page in a document. 

In the Document Layout palette, the master page and its layers a
listed under each page where the master page is visible. The ma
master page is at the top of the list.

Master pages are available in Publication documents. Similar ele
ments called “master slides” are available in Presentation docume
and “master frames” are available in Animation documents.

By selectively hiding layers of the master page, you can control th
master page appearance throughout a document or on selected p
The master page at the top of the layout list can be locked.

Using the Document Layout palette
The Document Layout palette is the control center for working wit
pages, layers, and objects. The palette is available in all types of 
uments (some options are based on document type). 

◆ To open the Document Layout palette: Choose Layout > 
Document Layout. Or, press a page icon at the bottom of the doc
ment window, and drag the pop-up palette away.

The palette shows a list of the pages, layers, and objects in the cu
document. You can use the palette to add, delete, and move items
set layout options. You can select, move, copy, and delete object

The Document Layout palette floats, so you can place it anywhere
screen. You can dock the palette on the Docking bar. To expand 
palette, drag the grow box below the scroll bar.

Layer pop-up palette
DOCUMENT LAYOUT
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Setting options in the palette
The Document Layout palette has columns of settings for several 
options: master pages, visibility, locking, printing, layer override co
ors, and animation frame duration.

To display option columns, choose Palette Options in the palette’s
menu. In the dialog box, select the options that you want to appea
the Document Layout palette. Some options are not available in a
types of documents.

Options columns

The following are the options you can change by clicking options c
umns in the Document Layout palette. (You can also use dialog bo
to change options; see “Using options dialog boxes,” page 6.7).

Master page Click to show or hide the master page on a docume
page. If the master page is hidden, a hollow bullet appears in the 
umn. When the master page is visible, the bullet is solid. Master pa
are not available in Illustration documents.

You can hide master page layers using the Visible option. Hiding 
master page layers is the same as hiding the master page.

Visible Click to show or hide a page, layer, master page, or obje
Hiding a page hides all its layers (unless one is the current layer).

Locked Click to lock or unlock a page, layer, or object to prevent 
allow changes. A bullet indicates an item is locked and its content

The Document Layout 
palette lets you select and 
set options for pages, 
layers, and objects

A Layout list
B Options columns
C New page
D New layer
E Search box
F Trash
G Palette menu
H Grow box

C D E F G

A B

H

A C D EB

A Master page
B Visible
C Locked
D Printable
E Color override
Using the Document Layout palette 6.3
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can’t be selected, moved, edited, or deleted. Grid layers are alwa
locked. A padlock icon indicates an item is also password-protect

Printable A bullet indicates an item will print. When no bullet 
appears, the item will not print. If you change this option on a page,
setting is applied to all the page’s layers.

Color Override Click in the column to apply an override color to a
layer. A square with the override color appears in the column. To
select an override color in the Layer Options dialog box, double-cl
the layer name. To hide a layer’s override color, click in the colum
to remove the color square. 

Frame Duration In Animation documents, this column shows
the duration of a frame in hundredths of a second. To change the
frame’s duration, double-click the frame name, change the durati
value in the Frame Options dialog box, and click OK.

Using the layout list
You can use the list in the Document Layout palette to display an
select pages, layers, and objects. You can expand the list to disp
more detail, or collapse it to display fewer items.

Layout list

Items in a document are list-
ed in a tree format in the 
Document Layout palette.

Mac: Click to expand the 
list. Click to collapse it.
Windows: Click a plus to 
expand the list; click a minus 
to collapse it.

Ctrl-click an item to toggle 
the state of its sub-items. If 
you Ctrl-click a page, its 
expanded layers will col-
lapse, and its collapsed lay-
ers will expand.

(Mac) Publication (Windows) Illustration
DOCUMENT LAYOUT
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The layout list is a hierarchy. Pages are at the top level, followed 
layers, then group objects, then individual objects. Each level is 
indented to the right from the level above. The master page and i
layers are listed after a page’s regular layers.

The name of the selected item in the list is shaded. The active lay
name is bold. Names of master layers, shared layers and objects 
shared layers are italic.

◆ To expand or collapse one level in the list: Choose Expand 
All or Collapse All in the palette’s menu. The current level (pages
layers, or object groups) will expand or collapse. You can also 
Option-click (Mac) or Alt-click in the list to do the same thing.

Selecting items

You can select one or more items at once in the layout list. The na
of a selected item is shaded.

• Selecting a page makes it the current page. The last curr
layer of the current page will be the current layer.

• Selecting a layer makes it the current layer. 

• Selecting an object selects the object in the document.

• Selecting any item that is not visible makes the item visib

◆ To select one item: Click the name of the item in the list

◆ To select multiple items: Click the first item and Shift-click the 
last item. This selects a continuous range of pages, layers, or obj
To select or deselect individual items in a selection, press Ctrl an
click each item.

Searching for items

Canvas can find items in the layout list by searching their names.
This means you can go to pages and layers, and select objects in
document, by typing some or all of the text in an item’s name.

To select an item in the list, type the text to find in the searc
box in the Document Layout palette. When you stop or pre

Enter, Canvas searches the list from the current page. The searc
includes only items that are visible in the list (not collapsed pages

You can type text lower- or upper-case. If an object in the list is 
named “Rectangle Fill 0c 67m 45y 23k” and you type “23K” Canvas 
will select the object. Default object names are object type and in
values. Default page and layer names are item type and sequenc

List hierarchy
Using the Document Layout palette 6.5
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number. You can assign names to objects, layers and pages (exc
Publication pages); assigned names will appear in the layout list.

Adding, deleting, and moving pages and layers
To change a document’s layout, you can add, delete, and move p
and layers. You can do this in the Document Layout palette or us
commands in the Layout menu. In addition, you can arrange, cop
and delete objects in the Document Layout palette.

To add pages

In the Document Layout palette, click the New Page button.
Canvas adds a page, sheet, slide, or frame to the end of the

ument. In the list, the item’s name is the next number in sequenc

You can also add pages by choosing Add Page (Sheet/Slide/Fra
in the palette’s menu. A dialog box lets you change the page nam
(except in Publications).

To add multiple pages

Commands in the Layout menu let you insert multiple pages into 
document. 

1 Choose Insert in the Layout > Pages (Sheets/Slides/Frames
submenu. 

2 A dialog box appears. Enter the number of pages you want to
add, choose a location to insert the new pages, and then click OK

To add layers

In the Document Layout palette, select a page or layer and c

the Add Layer button. Canvas adds a new layer to the current pa

You can also add layers by choosing Add Layer in the palette’s 
menu. A dialog box lets you change the layer’s name and select o
options (see “Page and layer options” on page 6.7).

Arranging items

To move pages, layers, or objects, you can drag them in the layo
list. If you drag to a collapsed part of the list, the list expands.

Canvas does not rename layers if you change their order or move
them to other pages in the list. If you change the order of pages, 
vas will rename them, unless you have given them unique names

✔Tip
You can merge layers, which 
moves objects from a source 
to a destination layer and 
deletes the source layer. Click 
the source layer to select it in 
the layout list. Shift-click the 
destination layer. Choose 
Merge Layers in the palette’s 
menu.
DOCUMENT LAYOUT
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◆ To copy items: Select one or more items in the palette, and th
Ctrl-drag them to a new location.

To delete items

Drag the items from the list to the Trash icon. You can also delete
items by selecting them in the palette and then choosing Delete in
palette’s menu. 

To delete multiple pages

1 Choose Layout > Pages (Sheets/Slides/Frames) > Delete. 

2 In the dialog box, enter the page range to delete and click O

Page and layer options
In each type of document, you can set options for pages and laye
You can use the Document Layout palette to set some options (s
“Setting options in the palette” on page 6.3). Additional options ar
in dialog boxes. 

Using options dialog boxes
In the Document Layout palette, double-click a page, master page
layer to open an options dialog box. Or, select the item and choo
Options in the palette’s menu.

In the options dialog box, select from the following options and cli
OK to apply the settings. Some options, as noted, are not availab
for all items or document types.

Naming items

In the text box, type a name for the item. By default, Canvas nam
pages and layers based on their order in the list. In Publications, p
names cannot be changed.

Destination

✔Tip
You can set options for multi-
ple items by selecting them 
and choosing Options in the 
palette’s menu. Do this to set 
the duration for multiple 
frames of an animation, or to 
apply transitions to multiple 
slides.
Page and layer options 6.7



6.8

o 

ned 
ign a 
rac-

age 
age. 
ted. 

al-
 

 

at 

n a 

r 

on 
s 

the 

f 
 
th 
Locking items

Select the Locked option to prevent changes to a page’s layers, t
individual layers, or to individual objects.

Password protection You can select the Password option when 
Locked is selected. When the Password option is used, the assig
password must be entered to unlock or change the page. To ass
password, select the Password option and type at least three cha
ters in the text box. After you click OK, enter the password in the 
confirmation dialog box that appears and click OK.

Note: A locked page can be changed in some ways. If a master p
is visible, changes to the master page will appear on the locked p
Also, a locked page does not prevent a document from being dele
If a locked page is copied, the copy is also locked.

Hiding items

The Visible option can be changed only in the Document Layout p
ette list. In options dialog boxes, the Visible option is not available
because a current item can’t be hidden.

Layer colors
Grayed Select Grayed to make solid color inks of objects on the
layer appear to be grayed (desaturated).

Select Color Override to apply a color to a layer. Select White Fill to 
apply a white fill ink to vector objects and text objects on a layer th
has a color override.

When you apply a color override to a layer, you temporarily assig
color to vector and text objects on the layers you specify. A color 
override does not affect paint objects. When you turn off the Colo
Override option, all affected objects revert to their original colors.

The White Fill option lets you control how override colors appear 
vector objects. This option doesn’t change the way override color
appear on text.

When White Fill is selected, Canvas applies the override color to 
pen ink of vector objects and applies white as the fill ink color. In 
other words, the override color becomes the color of the stroke o
vector objects, while the inside of the object remains white. When
White Fill is not selected, Canvas applies the override color as bo
pen and fill inks. 
DOCUMENT LAYOUT
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If you use the White Fill option, objects without a visible stroke ar
not visible against the white layout area.

Using onion-skinning
In Animation documents, you can display more than one frame 
(page) at a time. Onion-skinning is the term for displaying multiple 
frames as if they are on tracing paper. This view can be helpful fo
positioning objects across frames of an animation.

To use onion-skinning, press the onion symbol in the Docu
ment Layout palette. Choose an option from the pop-up me

Next Frame displays the current frame and the frame after the cu
rent frame. Previous Frame displays the current frame and the fram
before the current frame. Next & Previous displays the current frame
and one frame before and after the current frame. 

To display any number of frames adjacent to the current frame, 
choose Custom and enter the number of frames to display.

To show just the current frame, choose No Onion Skinning.

When onion-skinning is active, names of the displayed frames ar
tinted in the layout list.

Sharing layers
Sharing a layer means applying a layer to more than one page in
document. The shared layers are linked together; changing one l
will change all the linked layers. This means that shared layers ca
used like additional master pages. 

The names of shared layers and objects on them are in italic type
the Document Layout palette.

To share a layer

1 Select the layer you want to share in the Document Layout p
ette.

2 Choose Share Layer in the palette’s menu. 

3 In the dialog box that appears, select the pages in the list that
want to share the layer. Click Select.

The shared layer name appears in the list of layers for each page
selected.

✔Tip
You can share a layer by press-
ing Shift and dragging the lay-
er to another page (except the 
master page). Repeat to add 
the shared layer to other pag-
es.
Page and layer options 6.9
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To unshare a layer

Unsharing a layer converts it from a shared layer into a regular, n
linked layer on one page or throughout a document.

1 Select the layer you want to unshare. 

2 Choose Unshare Layer in the palette’s menu.

3 In the message box that appears, do one of the following:

Unshare all instances: Click Yes to unshare all of the layers in
the shared group. Canvas disunites the layers and creates 
copy of each layer.

Unshare one instance: Click No to unshare the layer on the 
current page only. The rest of the layers remain shared.

Using master pages 
Master pages (slides/frames) hold common elements that you wa
appear on most pages. Objects on the master page’s layers appe
pages where the Master Page option is selected. 

Illustration documents do not use master pages.

You can unlink a master page. This lets you edit the page’s conte
like you would any layer that isn’t shared, without changing the 
appearance of the master page on other pages. Canvas also lets
re-link a master page.

To unlink a master page

1 Select the page where you want to unlink the master page. (D
not select the master page item or a layer).

2 Choose Unlink Master in the palette’s menu. The layers of th
master page become regular layers of the current page.

To link a master page

1 Select the page you want to apply the master page to.

2 Choose Link Master in the palette’s menu. Canvas links the 
master page to the current page. Other elements on the page are
affected.

Dispersing objects
You can use the Disperse command to quickly move objects to pa
throughout a document. This is useful for creating frames and slid
0 DOCUMENT LAYOUT
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For example, you can select a series of graphics, and use Disper
place one graphic on each frame in an Animation document. You 
spread objects over existing pages or Canvas will create pages fo
objects. Dispersed objects are placed on a new layer on each pa

To disperse objects

1 Select the objects to disperse. The objects should be on the
same layer and should not be grouped.

2 Choose Object > Arrange > Disperse.

3 In the dialog box, select an option:

Dynamic: Canvas will create pages to hold the selected obje

Selected: Click Select to display a list of pages. Shift-click 
pages to select them, and then click Select.

4 In the text box, type the number of objects to place on each
page (Canvas divides the number of objects evenly if you selec
pages; remaining objects go on the last selected page). Click O
disperse the selected objects.

Using guide and grid layers
In addition to general purpose layers, you can use special layers 
ignated to contain drawing aids called guides and grids. 

Like other layers, guide layers and grid layers appear in the Docu
ment Layout palette. You can arrange these layers by dragging th
in the list to place them in front of or behind other layers.

Guide layers
When the command Layout > Snap To > Guides is selected, obje
that you draw and move will snap to guides on the guide layer.

Guides that you drag from the rulers, and text sections you draw w
the Section tool will appear on the current page’s guide layer. Yo
can also draw on a guide layer to create “magnetic” guide objects

To add a guide layer

1 Select the page you want to add a guide layer to.

2 Choose Add Guide Layer in the Document Layout palette’s 
menu. 
Using guide and grid layers 6.11
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3 The New Guide Layer dialog box appears. Enter a name, a
select the visible option to display the layer, and click OK. 

By default, objects on guide layers are light blue. By changing the
guide layer override color, you can make the objects any color. T
change a guide layer’s name, override color, or other properties, 
can double-click the layer and use the options dialog box, or use 
another method for setting layer options as described in this chap

Grid layers
Grid layers display gray grids that can help you position objects p
cisely. When the command Layout > Snap To > Grid is selected,
bounding boxes of objects will snap to the grid.

When you create a grid it appears on a grid layer. Grid layers are
locked by default. You can configure the current page’s grid using
the Layout > Grids command.

To add a grid layer

1 Select the page you want to add a grid layer to.

2 Choose Add Grid Layer in the palette’s pop-up menu. The Ne
Grid layer dialog box appears. Configure the options as desired, 
then click OK. Canvas adds a new grid layer.

By default, grid layers are gray. To change a grid layer’s name an
other properties, you can double-click the layer and use the optio
dialog box, or use another method for setting layer options as 
described in this chapter.

Presenting slide shows
You can display Presentation documents as on-screen slide show
The term slide show is used because you build a presentation as a
series of screens, or “slides,” with illustrations and text. The meta
phor is based on the way traditional business presentations have 
assembled from photographic slides or transparencies and displa
with a slide or overhead projector. When you play back a Canvas
Presentation document, Canvas displays the document’s slides in
order, using the specified transition timing and effects.

A presentation slide show can be set to automatic mode, in which
slide show plays once and stops or repeats continuously. Slide 
changes also can be controlled by an operator. Canvas can show
2 DOCUMENT LAYOUT
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slides using a time interval that you specify, or you can control the
pace by clicking to switch to the next slide whenever you are read

You set up a presentation by first creating a Presentation docume
using the New command in the File menu, then adding additiona
slides and layers as described in this chapter. 

You can use a presentation document’s Master slide for backgrou
objects and text. Use the Document Layout palette to apply the M
ter slide to other slides, and to set options for slides.

Slide options
In the Slide Options dialog box, you can set up standard options 
“Page and layer options” on page 6.7) as well as transitions for sl
shows. You can select from more than a dozen transition effects.

To set up slide transitions

You can set transitions for the current slide or multiple slides. To 
apply a transition effect to multiple slides, select the slides in the 
Document Layout palette and use the Options command.

1 Double-click a slide in the Document Layout palette’s list, or 
select one or more slides and choose Options in the palette’s me

2 The Slide Options dialog box appears. To use a transition 
effect (such as Dissolve or Iris In), select “Transition to next slide
If you do not select this option, the slides simply appear in 
sequence. 

• Select a transition effect in the pop-up menu.

• If there are options for the transition effect, the Options b
ton is available. Click the button to change the settings. I
the dialog box that appears, drag the slider to adjust the 
speed of the transition from slower (Min.) to faster (Max).
Select a Direction option (if available) and then click OK.

• To preview the effect, click Try.

3 Click OK in the Slide Options dialog box to apply the settings 
the selected slides.

Setting up slide shows
To set up a Presentation for display as a slide show, choose Layo
Slide Show. The Slide Show palette opens. This is a floating pale
that can be kept open to configure and play slide shows.
Presenting slide shows 6.13
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You can select the following options in the Slide Show palette:

Fit to screen Reduces or enlarges the document’s slides so they
within the screen area of the system used to play the slide show. 
vas calculates a scaling factor based on the size of the system’s 
itor and the resolution setting.

Loop Causes the slide show to play continuously until you interru
it. When Canvas reaches the end of the document, it begins the s
show from the first slide.

Show Pointer Displays a pointer on screen during playback. Sele
this option and then select the pointer from the pop-up menu. You
can control the pointer with the mouse during the slide show, so y
can indicate important items in the presentation.

Auto Play QuickTime movies (Mac only) Causes any QuickTime 
movie files that have been placed in the Presentation document t
begin playing automatically. When a slide containing a movie is 
played, Canvas loads the movie and begins playing it if this option
selected. QuickTime is not currently supported in Canvas for Win
dows.

Advance Every _ Seconds Makes the slide show self-running by 
advancing from one slide to another after a specified interval, with
any intervention from the operator. Enter the number of seconds 
the text box. The exact timing between slides depends on the spe
the system used for playback and the complexity of the illustratio

Progressive Build Displays layers in sequence. Canvas will show
each slide’s master layers and Layer 1, and then the other layers
sequence. Otherwise, a slide’s layers are shown together.

Anti-Aliased Play Quality Select this option to anti-alias (smooth)
vector and text objects during playback. If you select “Draw Quali
Anti Aliased” in the Preferences dialog box, Canvas will anti-alias
objects in your documents except when playing slide shows.

To play a slide show

1 Choose Layout > Slide Show.

2 To start a slide show, click Play. If “Advance Every _ Sec-
onds” is selected, Canvas changes slides at the specified interv
Otherwise, click to change slides. Ctrl-click to go back one slide

3 To stop the slide show, press Esc (Mac) or right-click (Win-
dows).
4 DOCUMENT LAYOUT
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FILE AND DATA EXCHANGE

Canvas supports many standard formats for exchanging files and 
with other programs. This chapter explains how to use non-Canv
file formats, including web image formats. It includes information o
exchanging files on the Internet, and sharing data using Publish a
Subscribe and Object Linking and Embedding.

Exchanging files
Canvas lets you work with many file formats. With a common file 
format, you can bring a file generated in another program into a C
vas document, or transfer a Canvas document into another progr

Because the native Canvas 7 format saves all the objects, proper
and effects that your documents can contain, you should save all 
documents in this format. Still, you might want to export a docume
in a different format, or import graphics into a Canvas document.

When you use a non-Canvas file, you can avoid problems such a
lost information and printing errors if you know the capabilities an
limitations of the file format. For example, some formats support 
only one type of data (vector, raster, or text), while others suppor
multiple types. Image formats support certain image modes.

Importing files
You can use the Open and Place commands to import files. You 
choose the format you want to use in the format pop-up menus in
Open and Place dialog boxes. To import image files, you can also
the Acquire submenu (see “Acquiring images” on page 7.4).

To open or place a file

1 Choose File > Open or File > Place.

• Open creates a new Canvas document containing the file
you select.

• Place inserts the file in the current Canvas document. Pla
is available only if a Canvas document is open.
7.1
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2 Choose a file type in the File Format (Mac) or Files of Type 
(Windows) pop-up menu. The file list shows files that match the
selected format. 

• Select All Files (Windows) or Show All Files (Mac) to 
show every file in the folder. You can choose All in the Fil
Format menu (Mac) to show all files that Canvas can ope

3 In the file list, select a file and click Open or Place. You can
also double-click a file name. For some file formats, a dialog bo
presents options for opening files. Configure the options and cli
Open or Place.

• If you open the file, Canvas creates a new document.

• If you are placing the file, a Place pointer appears. Click 
where you want to place the top-left corner of the file.

Saving files in other formats
You can use the Save As command to export files in a variety of 
formats. However, be aware that most file formats do not support
every Canvas object or effect. For this reason, Canvas asks if you
sure when you select other file formats for saving files.

For example, a TIFF file can save only a single raster image; it do
not support text or vector objects. If you save a Canvas documen
containing vector objects or text in TIFF format, all the objects in t
document are changed into an image. If you then open the TIFF 
its contents appear as one raster image, so you can’t edit the orig
text or reshape the vector objects.

When you save a document in a non-Canvas format, Canvas crea
new file on disk, but does not close the document or change the n
of the document in the title bar. If you then try to close the Canva
document (without saving it in Canvas format), a message asks y
to confirm that you want to close the document without saving it.

To save a file

1 Depending on what you want to save, do one of the followin

• To save specific objects, select the objects.

• To save specific layers of a multi-layer document, make 
sure the layers you want to save are visible.

2 Choose File > Save As. A directory dialog box appears. 

✔Tip
Always save your work as a 
Canvas document, so you can 
edit your work later in Canvas if 
necessary.
FILE AND DATA EXCHANGE
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3 Select a file format in the pop-up menu labeled “File Format
(Mac) or “Save as type” (Windows). If a format or option is not 
available, be sure it is compatible with the document contents.

• On Windows, a message asks you to confirm that you wa
to save in a format other than Canvas. Click Yes to con-
tinue. On Mac OS, this message appears after you click 
Save; click Save in the message box to continue.

4 Select the Save Entire Document, Save Selection, or Save 
ers option at the bottom of the dialog box to specify what to sav
Some options that are available when you save in Canvas form
are not available when you select other file formats.

5 Type a name for the file, select a location, and click Save. 

If options are available when saving in the selected file format, a 
log box appears. Configure the options as you wish and click OK
For information on file options, see the sections on specific forma
in this chapter and in on-line Help in Canvas.

Rendering images

When you are saving objects and select a file format that support
images only, Canvas renders the document or selected objects. R
dering creates an image that can be saved in the selected forma

The Render Image dialog box lets you set options for rendering. S
“Rendering objects and images” on page 24.7 for more informatio

Acquiring and exporting images 
You can use the Acquire and Export commands in the Image men
work with raster image files. These commands are especially use
because you can add new file formats by installing Photoshop-co
patible plug-in modules.

Exporting images
When you use an Export command, you create a file on disk from
single selected paint object. Using Export is similar to using Save 
except that you must select a paint object before you choose Exp
Export is not available if a paint object is not selected.

To export an image

1 Select the paint object to export. Be sure the paint object is 
in edit mode.
Acquiring and exporting images 7.3
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2 Choose Image > Export > file format, where file format is the 
name of a file format in the Export submenu.

3 In the directory dialog box, type a file name, select a locatio
for the exported file, and then click Save.

If the image mode of the selected paint object is not supported by
format file you choose, the Render Image dialog box appears. In 
dialog box, you can select an image format supported by the file 
mat. If an image mode is not available in the Mode pop-up menu,
selected file format does not support that mode. See “Rendering 
objects and images” on page 24.7 for more information.

Acquiring images
You can use commands in the Image > Acquire submenu to impo
images from files on disk. You can also acquire images from scan
ners and digital cameras using the TWAIN interface or acquire pl
in modules.

Acquiring an image places it in the current document as a paint 
object. In most cases, Canvas stacks acquired images at the cen
the current view. 

Note: The Open and Place commands work with image files also.
The Open command opens a file as a new document. The Place 
mand places a file in the current document. These commands will
import an image file as a proxy or import multiple images at once

To acquire one or more image files

1 Choose Image > Acquire > file format, where file format is the 
name of an image file format in the Acquire submenu.

2 A directory dialog box appears. Navigate to the folder that co
tains the files to acquire. Files that match the format you selected 
appear in the files list.

3 Select one or more files to acquire. You can Shift-click to sele
multiple files in the list, and then click Open to acquire all the 
selected files. Or, you can add files from one or more folders to th
selected files list, and then click Done to open them.

To acquire an image from a TWAIN device

1 Choose Image > Acquire > TWAIN Acquire.

2 A dialog box appears. Refer to the documentation for the dev
or acquire module for information on options and settings.
FILE AND DATA EXCHANGE
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Acquiring images as proxies

You can use the Acquire as Proxy option to import a low-resolutio
proxy, rather than a high-resolution image, from an image file. Th
proxy image will be linked to the original image file.

The Acquire as Proxy option appears in the directory dialog box 
when you acquire TIFF, JPEG, and CVI files. 

Select the Acquire as Proxy option to place a proxy of the selecte
image file in the document. The proxy image will be linked to the 
image file. The option is selected by default for the CVI file forma
See the chapter “Image proxies” on page 29.1.

Internet file exchange 
You can import files into Canvas over the Internet, and save files
sites on the Internet directly from Canvas. 

When you use a directory dialog box, as with the Open, Place, 
Acquire, Export, and Save As commands, an Internet button lets 
access files and folders on the Internet. You can use the Internet
ton to select files to open and select folders to save files in. 

To exchange files on the Internet, your computer must have an ac
Internet connection, of course. 

The Internet button is also available in any situation when you op
or save a file. This includes Load and Save commands in palette

To use the Internet button

1 You can click the Internet button in any directory dialog box
after you choose a command to open or save a file.

2 A dialog box appears (described next). In the Host Address
box, enter the URL or IP address of the site you want to access

3 Click OK. 

4 A window displays a list of files in the default directory or a 
directory that you specified. To open a folder, double-click it. To g
to a higher directory, select it from the menu above the list.

• If you are saving a file, select the directory to save in. 

• If you are opening a file, select the file.

5 Click OK to upload or download the file.

✔Tip
If the Internet button is not 
available in directory dialog 
boxes, your system probably 
lacks the software needed to 
access the Internet, or the soft-
ware is not set up correctly.
Internet file exchange 7.5
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Internet protocols
You can use the two major Internet protocols in Canvas for savin
and uploading files, and for downloading (opening) files. To save
download files over the Internet, you need to know the address of
web or FTP site you want to access. Internet addresses are calle
Uniform Resource Locators (URLs).

Downloading files

You can use the Internet button to download files from File Trans
Protocol (FTP) sites, and from world wide web sites, which use 
Hypertext Transport Protocol (HTTP). To download web images,
you need to know the web page URLs and the image file names.

Internet dialog box

Click the Internet button 
and use the dialog box to 
specify Internet options.

Host Address: Type the 
Internet Protocol (IP) 
address or URL of the site 
you want to access. You 
can add the directory 
path here or in the Initial 
Path box.

Initial Path: Type the full path 
to a folder or file. Use a slash (/) 
between directory levels. 
Leave the box blank to use an 
FTP site’s default directory. 

To download an image from a 
web page, type the full path 
and file name. For uploading, 
you can leave this blank and 
browse the FTP site to select 
the upload directory.

File format: The selected for-
mat appears here. You can 
change the format (except 
when using Load commands). 

When opening files, the format 
limits which files on an FTP site 
are listed. To display all files, 
select All.

When saving files, Canvas uses 
the specified format.

Use HTTP Protocol: Select 
this to download web images. 
Type the complete URL, 
including the name of the 
image file. User Name and 
Password are not used. This is 
not available for saving files. 
(The URL Access extension is 

required for HTTP down-
loading on Mac). 

Login: Type your user 
name for accessing an 
FTP site. Some sites allow 
you to enter “anony-
mous.”

Password: If the site 
requires it, type your 
password. Sites that allow 
anonymous login expect 
an e-mail address here.

Using favorites

You can save and select 
settings for your favorite 

sites. Favorites include all set-
tings except file format. To 
save a favorite, choose Add 
Favorite, then click OK.

To use a favorite, choose its 
name. To delete saved set-
tings, choose Delete Favorite. 
Then, select a favorite and click 
Delete. Click Done to finish. 
FILE AND DATA EXCHANGE
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You can open web images in JPEG and GIF files. From FTP site
you can open most file formats that Canvas supports. Canvas do
loads and imports a file into the current document if you use Place
Acquire. If you use Open, Canvas opens the file in a new docume

Saving files

You can use the Internet button to save and upload files to FTP s
Web (HTTP) sites do not support uploading. Instead, to post files
web pages, you upload the files to an FTP site. If you have a web
hosted by an Internet Service Provider (ISP), the ISP will tell you 
FTP address and the path to use for storing you web files. Then y
can use Canvas to save and upload web pages to your web site.

You can save and upload all file types supported by Canvas. This
includes web pages and image files for web pages. You can use 
> Save As for all file formats, or use Image > Export for image for
mats. You can save web pages in HTML format or save images i
GIF or JPEG format using the File > Save to Web wizard. For mo
information on web formats, see “Web publishing” on page 8.1.

When you use the Internet button for saving files, Canvas saves a
in the format you specify and uploads the file to a location you sp
ify. Canvas does not save a local copy of the file. It’s always a go
idea to save your work in a Canvas file so you can edit it later. 

File format options
When you use other file formats that Canvas supports, you can se
options when you open, place, import, save, or export some type
files. The most common file formats and their options are describ
in this section. 

For more information on using file formats, refer to the online Hel
system in Canvas. New information that is not in the printed or onl
documentation will be provided in the “Read Me” file distributed 
with the Canvas software.

Saving in Acrobat PDF format
When saving in Acrobat format, you can select screen or printer r
lution for images saved in the file. Click an option in the dialog bo
that appears before the file is saved.

Screen saves images at a maximum 72 pixels per inch (ppi). If nec
sary, images are down-sampled to 72 ppi.
File format options 7.7
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Printer saves images at a maximum 300 ppi. If necessary, images
down-sampled to 300 ppi. An image’s resolution is not increased 
is less than 300 ppi.

Saving CGM files
Computer Graphics Metafile (CGM) format is a standard for 
exchanging 2-D graphics and text. Variations and extensions to t
“standard” format can create incompatibilities with the Canvas file
filter. When you save a Canvas document in CGM format, Canva
makes the following image color mode conversions:

Using AutoCAD DWG format
The AutoCAD DWG import filter lets you import native AutoCAD 
(r14) files into Canvas. This filter fits an AutoCAD drawing to a do
ument size of 8.5 by 11 inches. To use this filter, choose File > O
or File > Place and select AutoCAD DWG format in the directory 
dialog box.

Using Drawing Interchange Format (DXF)
Drawing Interchange Format (DXF) is a format developed by 
Autodesk, Inc., for exchanging data with AutoCAD and other draw
ing applications. DXF format provides platform-independent stora
of 2D and 3D technical drawings and supports multiple layers. Ca
vas supports DXF files containing ASCII data, but does not suppo
DXF files that contain data in binary format. 

Canvas image mode CGM image mode

CMYK, Duotone, Grayscale, and 
LAB color 

RGB cell arrays

Black & White CGM versions 1 and 2: RGB cell arrays

CGM version 3: Black & White

Multichannel First channel becomes an RGB cell array; 
other channels ignored
FILE AND DATA EXCHANGE
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Saving DXF files

When you save a document in DXF format, Canvas converts the
lowing Canvas objects and attributes to DXF objects and attribute

In the DXF export options dialog box, select the platform format t
use. You can also select options for exporting lines and circles.

Opening DXF files

The DXF import filter fits a DXF file to a document size of 8.5 by 1
inches.

When opening a DXF file, Canvas makes the following conversio
from DXF objects to Canvas objects: 

Canvas does not support 3D objects (3D lines and 3D Face objec
DXF files), so these objects are not imported into Canvas.

Using Encapsulated PostScript (EPS)
Encapsulated PostScript (EPS) is a file format used to save individ
PostScript graphics.

Canvas objects / attributes DXF objects / attributes

Paint object Not converted

Pen and fill patterns Solid pens and fills

Arcs Polylines

Calligraphic pen strokes Fixed-width pen strokes

Continuous dashes Dashes start in each segment

Layer names with spaces or non-
uppercase characters

Spaces removed and characters 
become uppercase

Grayed layers Objects appear in original colors

DXF objects Canvas objects

Blocks Groups

Traces, Solids, and Quadratic 
polylines

Polygons

B-spline Polylines Bézier curve paths

ATTDEF and ATTRIB Text objects
Using Encapsulated PostScript (EPS) 7.9
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Opening EPS files
When you open or place an EPS file, a dialog box asks you to cho
an import method. Choose an option and click OK.

Create EPSF Object Imports the EPS file as an EPS object. This 
object can be rotated or scaled, but you can’t select or edit parts o
graphic. Canvas displays a preview image if the file contains a pr
view in a supported format.

Create Canvas Objects Interprets the EPS file’s PostScript code t
convert the EPS graphic to editable Canvas objects. Raster imag
become Canvas paint objects and vector objects are maintained 
vector objects. Text is imported as one or more text objects. The E
preview image is not imported. Specialized objects and attributes 
have no Canvas equivalent might not be imported.

Place EPSF Reference Inserts a link to the EPS file and displays it
preview image in the Canvas document. This option is useful for 
keeping the size of the Canvas file smaller than if EPS files are 
imported directly into the document. If you use this option, the EP
file must be available when you print the Canvas document. If the
EPS file changes, the Canvas document is updated when you pr

Saving EPS files
To save a file in EPS format, choose File > Save As. In the direct
dialog box, select EPSF format. Select options in the dialog box t
appears (described next) and click OK to save the file.

When you save a Canvas document in EPS format, you could los
specialized objects and attributes that are not supported in EPS. 
vas transparency effects are rendered and stored as images in E
graphics, using the Transparency Rendering option and resolutio
that you select.

EPSF Type

Choose EPS to create a composite (non-separated) EPS file. 

Choose DCS Version 2 to create a single, pre-separated EPS file in
DCS version 2.0 format. You can use a DCS file to output color s
arations from programs that support this format.
0 FILE AND DATA EXCHANGE
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Current Page

Saves the current page, slide, sheet, or frame only. To save a ran
pages, enter the starting and ending page numbers in the From and 
To boxes.

Preview 

Select a format to store a preview image in the EPS file. Canvas 
other programs that support EPS previews will display the previe
when the EPS file is placed in a document. The image format and
color mode you select are applied to the preview image only.

Windows Choose None for no preview, or choose a color mode 
save a preview image. Preview images are saved in TIFF format
preview will not appear in programs that support only WMF or EM
previews.

Mac OS Choose None for no preview. Choose a color mode to sa
a preview in TIFF format. Or, choose a PICT option to save a pre
view in PICT format. Use PICT in EPS files for import into Word 9
on Mac OS, or any program that doesn’t support TIFF previews.

Use Compression

Select this option to compress TIFF preview images. Some progra
can display only non-compressed TIFF previews. If TIFF preview
images do not appear correctly, try deselecting this option.

Image Compression

Select a format for storing raster image data.

Binary is the most compact non-compressed format. ASCII encodes 
raster data as text, the least compact format. Level 2 ASCII is some-
what more compact than ASCII format. RLE compresses binary data
and makes the most compact EPS files. To save EPS files for Ph
shop or Illustrator, use Binary format.

Color Mode
For EPS format Select a color mode to apply to colors in the EPS
file. The available modes correspond to RGB, CMYK, Grayscale,
and Black & White modes for paint objects. 

• Colors created with RGB, HSL, CMYK, or grayscale value
will be converted to the selected mode in the EPS file. 

• Spot colors defined in Canvas with the Spot Color option 
the Color manager or a spot color library such as PAN-
Using Encapsulated PostScript (EPS) 7.11
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TONE spot colors will be saved in the EPS file as spot co
ors, and also with color values in the selected mode.

If you print color separations from an EPS file in another program
you can usually output process and spot color plates, or just proc
color plates, depending on whether you specify spot and process
arations or process-only separations.

For DCS Format Select a color mode for the separations stored i
the EPS file: 

• Select CMYK to separate all colors, including spot colors, a
process (CMYK) colors. 

• Select CMYK + Spot to separate all colors, except spot co
ors, as process (CMYK) colors. Spot colors will not be co
verted to process and will be separated as spot colors.

When you use DCS Format and print color separations, the prog
you use simply outputs the color separation plates as defined in t
DCS file; it does not apply its separation method or options to col
in the file. Therefore, if you want to be able to output process and
spot color plates, you should select CMYK + Spot Color Mode wh
you use DCS Format to save illustrations in EPS files.

Transparency Rendering

Select a method for SpriteLayer and SpriteEffects rendering into E
format. These options are similar to the rendering options that are
available when you print a document.

To render effects, choose Smallest Area, Complete Area, or Entir
Document. 

Smallest Area results in rendering the minimum area necessary to
show transparency and SpriteEffects. Complete Area renders the 
minimum area, plus any object that touches the rendered area. T
setting can prevent a slight color shift between rendered and non
dered areas within an object. Entire Document renders everything in 
the document (or selection) as an image to be saved in the EPS 

If you choose Don’t Render Transparent Objects, transparency and 
SpriteEffects won’t be rendered.

Rendering Resolution Select a resolution for rendering effects. In
general, you should specify a resolution based on the publication
requirements for images.
2 FILE AND DATA EXCHANGE
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Embed Fonts (Windows only)

Select this option to embed fonts in the file, so text can appear as
intended if the required fonts aren’t available.

Use Page Dimensions

Select this option to save the full area of the document page, she
slide, or frame in the EPS file. If this option is not selected, the EP
graphic will be only as large as the saved objects.

Converting EPS objects
After you import an EPS file, you can choose options from the co
text menu to convert the object or view information about it. 

You can view linking information if the file was imported as an 
EPSF reference. If the file was imported as an EPSF object, you 
convert it to an EPSF reference. If it was imported as an EPSF ob
you can create Canvas objects from it.

◆ To use EPSF Object commands: Select the EPS graphic and 
Ctrl+click (Mac) or right-click (Windows). In the context menu, 
choose one of the options described below.

Convert EPSF into Canvas Objects If you choose to create Canvas
objects from an EPSF object, the EPSF object is replaced in the 
ument by equivalent Canvas objects. Depending on the contents
the original EPS file, you might not be able to edit some objects a
you expect after the conversion. For example, you would not be a
to edit text if the EPS file contained outlines (paths) for text chara
ters, rather than the characters themselves; you could use path-ed
techniques to edit the objects.

Embed EPSF Into Document If an EPS graphic has been importe
with the Place EPSF Reference option, you can use the context m
to convert the graphic from a linked EPS graphic to an EPS graph
that is placed in the document. The result is the same as importin
EPS file and selecting Create EPSF Object.

EPSF Info… You can get information from an EPS graphic if it wa
imported with the Place EPSF Reference option. Canvas will disp
information on the location of the EPS file that is linked into the do
ument. If the file can’t be found in its original location, Canvas dis
plays a message. To re-link the file, click File, and use the directo
dialog box to select the EPS file. Then, click OK in the message b
Using Encapsulated PostScript (EPS) 7.13
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Saving web graphics (GIF/JPEG)
For saving graphics in GIF and JPEG formats (the standard web 
image formats), Canvas provides an integrated dialog box. You c
select either format and use multiple preview panes to compare h
the format and other settings will affect your images before savin

GIF format GIF is the best format for graphics that contain a sma
number of colors, such as vector art with flat colors. GIF format s
ports Black & White, Grayscale and Indexed color images, with 1
8 bits of color data for a maximum of 256 colors.

JPEG format JPEG format provides compression of high resolu-
tion, full-color (24- bit) RGB images. JPEG is designed for efficien
storage of continuous-tone images such as photographs. “JPEG” 
abbreviation of “Joint Photographic Experts Group,” a standards 
organization that promoted the format.

To save graphics in GIF or JPEG format

1 Select the objects to save, or Canvas will save the current d
ument page. Choose File > Save As. 

2 In the directory dialog box, select GIF/JPEG in the file forma
pop-up menu. Type a name for the file and select the save locat

• To save only the selected objects, click Save Selection. 

• To save the file on the Internet, see “Internet file exchang
on page 7.5.

3 Click Save.

4 Unless you are saving a single paint object, the Render Ima
dialog box appears. Select rendering options and click OK. For 
more information, see “Rendering images” on page 7.3.

5 The Export Preview dialog box appears. Use the dialog box
select the format and other options for saving the graphic. For c
plete instructions, see “Export Preview options” on page 7.15.

6 Click Export to save the file.

To export images in GIF or JPEG format

Exporting lets you save selected images, but not entire documen
The difference between Save As and Export is that Save As will r
der objects or an entire document to create an image that can be
saved. Export will save only a single paint object, without renderin

✔Tip
You can use a wizard to save 
graphics for the web. Select 
the images you want to save, 
and choose File > Save to 
Web. The wizard will help you 
save images in GIF and JPEG 
formats.
4 FILE AND DATA EXCHANGE
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1 Select a paint object to export. 

2 Choose Image > Export > GIF/JPEG. 

3 The Export Preview dialog box appears. Use the dialog box
select the format and other options for saving the graphic. For c
plete instructions, see “Export Preview options” on page 7.15.

4 Click Export to save the file.

5 A directory dialog box appears. Type a name for the file and
choose a location to save the file, and then click Save.

Export Preview options
The Export Preview dialog box shows one, two, or four previews o
graphic image when you choose Save As or Export and select GI
JPEG file format. You can select settings for each preview image
compare how the file format, palette options, and other settings w
affect the image you are saving.

A color tile shows the color you point to in a preview image. Two 
pairs of coordinates are displayed below the preview panes. One
are the X,Y coordinates of the pointer. The other pair are the coo
nates of the pixel at the upper-left corner of the preview panes.

Preview setup

Click a preview button to change the preview setup. You can sele
one preview, two previews (horizontal or vertical), or four preview

One preview pane is active and has a highlighted border. Click a p
to make it active. The settings in the dialog box apply to the active
preview. The settings in the dialog box can be different for each p
view. When you select a preview, Canvas updates the dialog box
show the settings for the active preview.

All panes show the image at the same view location and zoom le
Drag on a preview image to move the view location.

You can use the zoom menu to zoom in or out. Or, click the Magn
ing Glass button, then click a preview image to zoom in. To zoom
out, Shift-click a preview image. 

Without selecting the Magnifying Glass button, you can zoom in o
out by clicking in a preview image. On Mac, press Option or 
Option+Shift and click. On Windows, press Ctrl or Ctrl+Shift and 
click.
Saving web graphics (GIF/JPEG) 7.15
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Previewing the current settings

Each preview pane shows the original image. To view how the 
selected file format and other settings will affect the image, select
Show Preview option above a preview pane. Canvas will apply all
the settings in the dialog box to the preview image. If you change
setting, Canvas will apply the new setting.

Image file information When Show Preview is selected, the esti-
mated file size and the number of colors in the image appear abo
the active preview pane. The first value is the estimated file size i
kilobytes. The second value is the number of discrete colors that 
be saved in a GIF file; the value is not shown for JPEG format.

JPEG options
To use JPEG format, select JPEG from the Format menu. Canva
applies the JPEG format and settings to the active preview pane.

Quality Enter a percentage value from 1-100%. Higher Quality v
ues result in less compression and better retention of original ima
quality. 

Smoothing Enter a smoothing value from 1 to 6. JPEG compres
sion can cause color blocks to appear in an image. Smoothing so
the image to make color blocks less noticeable. Higher values pro
duce more smoothing.

Progressive Select this option to create a JPEG file that web brow
ers can display at increasing resolution as the image is loaded.

Downsampling This option can help improve compression. Down
sampling reduces the image resolution by averaging color values
while preserving luminosity details. Programs displaying the imag
will “upsample” to the original resolution, so greater compression
achieved without changing the display resolution of the image.
6 FILE AND DATA EXCHANGE
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Optimized This option can help produce smaller file sizes. When
Optimized is selected, some of the least important color informati
is discarded to produce more efficient compression.

GIF options
To use GIF format, select GIF from the Format menu. Canvas app
the GIF format and settings to the active preview pane.

Max colors Use the menu or type in the box to specify the maxi-
mum number of colors to be used in the image. Fewer colors can
result in a smaller file, but too few colors will degrade an image.

Palette A palette is a set of colors used in an image. To be save
GIF format, an image can contain no more than 256 colors. If the
image contains more colors, the original colors are mapped to the
colors in the palette that you choose.

Adaptive creates a palette that tries to match as close as po
ble all the colors in the image. This option is the best for pre
serving the original color range of an image.

Web uses a standard color palette supported by major web 
browsers. The range of colors in the web palette, however, 
cause color shifts in images with many shades of a few colo

Uniform uses a palette of colors that are uniformly distribute
through the range of possible RGB colors.

Exact creates a palette from the actual colors in the image, i
the image contains fewer than 256 colors. If the image conta
more than 256 colors, Canvas uses the Adaptive option.

Note: To apply a custom or system color palette to a paint object 
before saving in GIF format, select the paint object and choose Im
> Mode > Indexed. In the dialog box, select a palette option and c
OK. To modify an Indexed mode paint object, choose Image > 
Mode > Color Table. 

Optimized Select this option to merge single pixels into similar 
colored areas. This can produce smaller file sizes. However, in 
images with fine lines or detail, this can reduce the image quality.
This option is less effective when Dither is also selected and an 
image has a limited number of colors.
Saving web graphics (GIF/JPEG) 7.17
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Dither Select this option if you want Canvas to use dithering to 
simulate a greater range of colors. Dithering can make an image 
appear to have more colors than are in a limited color palette, bu
can also make an image appear grainy or noisy. To control the 
amount of dithering, enter a percentage from 1 to 100 in the text 

Interlaced Select the Interlaced checkbox to save the image as a
interlaced GIF. Interlacing divides the image data for faster initial 
display in web browsers that support interlaced GIF images. In ot
words, the image appears progressively on the web page.

Selecting transparent colors

The Dropper tools in the Export Preview dialog box let you make 
colors in a GIF image transparent. Click in the color palette or the
current preview image to select colors for transparency. When yo
select a color, it becomes highlighted in the grid.

Use the regular dropper to select one transparent color. If yo
click another color, it replaces the current transparent color.

Use the add/subtract dropper to select additional colors to be
transparent. Each color you click becomes transparent. To 
restore a transparent color, click it again.

A checkerboard pattern appears in areas of the preview image th
are transparent.

Color palette The area below the GIF options shows the current
color palette for the image. The palette changes when you change
Palette or Max Color option.

Saving settings
You can save the current options in the Export Preview dialog bo
and then apply the same setup to other images.

To save the current options in the dialog box, choose Save Settin
the pop-up menu above the current preview pane. Type a name 
the saved setting and click OK. This setting will be available in the
pop-up menu above each preview pane.

To use a saved setting, select the Show Preview option above a 
view pane and then select the saved setting in the pop-up menu.

To delete a saved setting, select the setting in the pop-up menu, 
then choose Delete Setting. Canvas will ask you to confirm that y
want to delete the setting.
8 FILE AND DATA EXCHANGE
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Importing Photoshop files
When you open or acquire a Photoshop file that contains layers o
paths, the Photoshop Import dialog box appears. Select options t
specify what to import and then click OK.

Layers You can select from three options. 

• “Load into separate Canvas objects” imports the file’s lay
ers as separate objects and stacks them in the documen
the current layer. 

• “Load into separate Canvas layers” places each Photosh
layer on a new Canvas layer. 

With either option, layers that have transparency are imported wi
visibility masks. Canvas creates an alpha channel and a channel m
for a Photoshop layer mask. Canvas also imports alpha channels

• “Load Merged Result” imports the file’s composite image
(if it contains one) rather than its layers. Layer masks, alp
channels, and transparency effects are not imported. The
imported paint object has an opaque background. 

Note: If the option “Include composited image with layered files” is
not selected when a file is saved from Photoshop, Canvas will imp
a black image containing a message that the layered file was not
saved with a composite image.

Paths When the Photoshop file contains paths, you can choose 
from three import options. 

• “Load All” will import a clipping path and other paths as 
Canvas vector objects.

• “Load only clipping path” is available if the file contains a
clipping path. Select this option to import the clipping pat
(but not other paths) as a Canvas clipping path object. Th
image will be clipped by the path in Canvas. 

• “Ignore paths” will import the file without any paths.

QuickDraw 3D Metafile (3DMF)
You can open, place and save QuickDraw 3D graphics in Canvas
documents. After you open or place a QuickDraw 3D graphic, yo
can use the QuickDraw 3D tool to rotate, light, and change its colo
The tool is located in the Object Tools toolbar in the toolbox.

QuickDraw 3D tool
Saving web graphics (GIF/JPEG) 7.19
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Note: To open, place, and save QuickDraw 3D graphics, you mus
have the QuickDraw 3D extensions installed and active on your M
OS system.

To use QuickDraw 3D graphics

1 Select the QuickDraw 3D tool in the Object Tools toolbar.

2 Click where you want to place the object in the document. A
directory dialog box opens.

3 Locate the QuickDraw 3D file that you want to place in the 
document and click Open. Canvas places the graphic in the doc
ment.

4 To change lighting and display options, double-click the 
QuickDraw 3D graphic with the Selection tool; four buttons appe
at the bottom of the object.

5 To move the 3D graphic, click a button and drag inside the 
bounding box of the graphic.

6 To use the options dialog box, click the Options button, or do
ble-click the QuickDraw tool. Configure the settings you want in
the dialog box and click OK.

You can also save QuickDraw 3D objects and Canvas extruded 
objects in QuickDraw 3D Metafile format. To do this, you must firs
select a QuickDraw 3D object, or an extruded object. Then choos
Save As in the File menu, select the Save Selection option, and 
choose QuickDraw 3D Metafile in the File Format pop-up menu.

QuickTime Movie (Mac)
Apple Computer’s QuickTime technology is included with the Ma
OS and is required to work with some graphic formats, including 
QuickTime movies and JPEG-compressed files in Canvas.

If you have QuickTime software installed, the QuickTime tool in 
Canvas lets you place and play QuickTime movies. You can also
save Presentation documents as QuickTime movie files. 

Front/back

Rotate Lateral motion

Options

QuickTime tool
0 FILE AND DATA EXCHANGE
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◆ To open a QuickTime movie file: Choose File > Open, select 
QuickTime™ Movie format, and click Open. Canvas imports the 
movie file into a new document.

◆ To place a QuickTime movie file in a document: Select the 
QuickTime tool in the Object toolbar. Click in the document where
you want to place the movie. In the directory dialog box, select th
movie file and click Open.

You can also use the File > Place command to place a QuickTim
movie file in the current document.

Playing QuickTime movies

To play a QuickTime movie in a Canvas document, double-click t
movie object. The movie controller below the movie becomes acti
Click the play button ( ) to play the movie.

Playback options

To set playback options for a placed movie, select the movie obje
then double-click the QuickTime tool. To set default options, doub
click the QuickTime tool when nothing is selected.

Use the following options in the QuickTime dialog box:

Loop Makes a movie repeat when you play it. To repeat the mov
from beginning to end, choose Normal. To repeat forward and the
backward, choose Back and Forth.

Play Selection Only Plays one selected QuickTime object at a tim

Show Controller Displays the QuickTime movie playback control
with the movie object.

Creating QuickTime movies

You can save a Presentation in QuickTime movie format, so the d
ument’s slides become the movie’s frames.

To save a Presentation document as a QuickTime movie, choose
File > Save As and select QuickTime™ Movie format. Click Save
Select options in the Export Options dialog box and click OK.

Seconds Per Frame The playback duration in seconds for each 
slide (frame) in the movie. The actual playback speed can vary 
depending on the system capabilities and movie file compression

Colors The color depth for the movie file. More colors result in 
larger file sizes. 
Saving web graphics (GIF/JPEG) 7.21
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Maximize Select an option for compression used in the movie fi

• Animation Quality makes slide transitions as smooth as 
possible at the expense of image resolution.

• Image Quality uses high image resolution that might slow
down the animation.

• Compression keeps the file size to a minimum, at the cost
of lower image quality.

Playable on non-Apple computers Makes the movie file compat-
ible with QuickTime for Windows.

Saving files containing movies

If you save a document that contains a QuickTime movie object, 
Canvas updates the link to the movie file. If it can’t find the movie
file, Canvas asks you to locate the file. In the directory dialog box
select the file and click Open. If you can’t locate the file, click Canc
to continue saving with only the movie’s “poster” (preview) image

Using Tag Image File Format (TIFF)
Tag Image File Format is a high-resolution raster image format. C
vas supports both RGB and CMYK TIFFs. Although TIFF is a com
mon format, many TIFF variations exist. Different resolutions, col
systems, previews, and compression schemes make the format f
ble, but can cause compatibility problems. 

When you save TIFF files, you can choose compression options 
the Export TIFF dialog box. Various compression options are ava
able, depending on the mode of the image you are saving.

Group 3, Group 4, and Huffman are available to compress images
that are in black-and-white mode. 

RLE and LZW compression can be applied to all image modes, exc
CMYK Color. 

To save an image without compression (the most compatible form
select None.

Using text files
Text is a standard format for files containing only ASCII (America
Standard Code for Information Interchange) encoded characters.
2 FILE AND DATA EXCHANGE
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Text format is available on nearly every computer platform; it’s th
“plain vanilla” format, the lowest common denominator for words 
and numbers. Text files don’t include proprietary or application-sp
cific character or formatting codes. Some punctuation marks, sym
bols, and all accented letters are non-ASCII characters that displa
incorrectly when used in text files. Still, ASCII text can be used to
transfer text among a variety of applications, including text editors
word processors, and databases. 

When you open a text file, Canvas creates one text object contain
the file’s contents, and assigns the default font and text formatting
attributes to it. If the file contains more text than can fit in the Canv
workspace, Canvas truncates the text object and displays an over
indicator. You can then flow the truncated text into other columns

Using Object Linking and Embedding (Windows)
In Windows, Object Linking and Embedding (OLE) lets you easily
exchange graphics among programs. Because Canvas provides 
OLE support, objects you exchange retain their full functionality a
are editable with all the tools of the original application.

Windows programs provide various levels of OLE support. In OLE
parlance, Canvas is a fully capable object and container application. 
Briefly, this means Canvas can transfer objects to and from other 
grams through OLE. 

In the world of OLE, objects created in Canvas are identified as 
“Canvas Drawing” objects. If you use the Insert Object command
another application, you should be able to select “Canvas Drawin
as a type of object to insert.

Inserting objects into Canvas documents
You can use three methods to insert objects in a Canvas docume
the Clipboard, drag-and-drop, and the Insert Object command. Th
objects you insert can be either linked or embedded.

Clipboard When you copy Canvas objects to the Clipboard, Can
vas places OLE formats, as well as lower-fidelity formats, on the 
Clipboard. When you paste into another program, that program 
receives the highest-fidelity format it can accept. If the other progr
is an OLE container, pasting creates an embedded OLE object. T
same applies when pasting into Canvas; Canvas creates an embe
OLE object if OLE formats are available on the Clipboard.
Using Object Linking and Embedding (Windows) 7.23
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Drag-and-drop In Windows, you can drag objects from Canvas 
documents to almost any destination on the Desktop (including lo
and network folders) to create a “scrap” file containing the objects
You can also drag Canvas objects into other documents, and dra
objects, such as scrap files and other program’s objects, directly 
Canvas documents. When you drag an object to another program
creates an embedding. 

You can copy an object when you drag it by pressing a modifier k
Normally, dragging moves the object. If you want to copy the obje
rather than move it, Ctrl-drag the object to another document. Th
copies the object and creates an embedding. 

Insert Object The Insert Object command in the Edit menu opens
dialog box in which you can choose any registered OLE object ty
to insert into a document. You can create a new object or choose
file as the source of the embedded object.

To embed objects

When you embed an object in another document, you can use th
original program’s tools and commands to edit the object.

Note: Not all programs support OLE and can create embeddings.

1 Select the objects you want to embed in another document.

2 Choose Copy in the Edit menu. Canvas puts the selection o
the Clipboard.

3 Switch to the document where you want to embed the select
and choose Paste in the Edit menu. The object is embedded into
document.

To link objects 

If you want an object to be updated when it changes in the origina
document, you can create a link to the object. The Canvas docum
from which you copy objects to be linked must have been saved 
before you copy the objects.

Note: Not all OLE programs support OLE linking.

1 Select the objects to link and choose Copy in the Edit menu

2 Switch to the document where you want to paste the linked 
object and choose Paste Special in the Edit menu. 

3 In the dialog box, Canvas Drawing format is selected and yo
can click Paste Link to link the object.
4 FILE AND DATA EXCHANGE
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To manage linked objects

You can use the Links command to check the source file of a link
object and repair a broken link if a source file has been moved.

1 Select a linked object in a document.

2 Choose Links in the Edit menu. The Links dialog box displa
the link type and update method. To change the update method
choose the Automatic or Manual option.

3 Use the buttons to update or change the linked object:

• To update the object from its source, click Update Now.

• To open the source document, click Open Source.

• To select a different source document, click Change Sou

• To remove the link so changes to the source do not affec
the linked object, click Break Link.

Differences between linking and embedding

When you insert an object into a Canvas document, or insert an 
object from Canvas into another program’s document, you create
association between the object and its application. Linking and 
embedding create different types of associations.

Linking When you link an object, the object remains in the file 
where it was created. Only a link (reference) to the source object
winds up in the document, which makes linking an efficient metho
of storing commonly-used objects and files. Linking makes a 
dynamic connection between an object and all documents in whic
appears. When you edit the object, changes are automatically se
linked instances of the object in all documents.

Because the object is linked by only a reference to another file, if 
of the linked files change locations, the link will be disrupted. To 
move linked files without disrupting the references, you must mov
all linked files as well as the entire directory structure so that the r
tive locations of the files don’t change.

When you edit a linked object, the object’s application opens in a
separate window. When you finish editing, you close the applicat
to return to the document containing the link.

Embedding When you embed an object in a document, the obje
itself (not just a reference) is copied into the document. Therefore
document can be moved to another computer without losing the 
object.
Using Object Linking and Embedding (Windows) 7.25
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Using Publish and Subscribe (Mac)
Publish and Subscribe is a Mac OS technology that lets you shar
information in Canvas and with other Mac OS programs.

Publish and Subscribe is useful when you want to be able to upd
an object in several documents whenever you change the origina

To share an object, you make it a publisher. This creates an interme-
diate file, called an edition. To place the object in other documents,
you subscribe to the edition file. Subscribing creates a subscriber, 
which is linked through the edition to the publisher. 

Publish and Subscribe creates dynamic links between document
unlike moving data through the Mac Clipboard. When you change
publisher, Canvas can update the edition automatically. When an
tion changes, its subscribers can be updated automatically. You c
also turn off automatic updating and then update changes manua

To publish a selection

When you publish a selection, Canvas creates an edition file con
ing a copy of the published selection. You can subscribe to the ed
tion from other documents. You can use the same procedure to 
publish information in another program and subscribe to it in Canv

1 Select the objects in Canvas that you want to publish.

2 Choose Edit > Publishing > Create Publisher. 

3 In the Create Publisher dialog box, select a location and typ
name in the text box for the edition file, and then click Publish. 
Canvas creates the edition file on disk and displays a rectangular
shaded border around the published selection.

Publisher Edition file Subscribers

You can share an object by 
publishing it, which creates an 
edition, and then subscribing to 
the edition. 

The arrows represent manual or 
automatic updates from the 
publisher to the edition, and from 
the edition to the subscribers.

Avante
6 FILE AND DATA EXCHANGE
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Publisher borders

The rectangular border Canvas displays around a publisher is like
window into the document. Canvas sends objects that are within 
border to the edition file. You can resize and move the border and
move objects into and out of it to change the contents of the editi

To set publisher options

The Publisher Options command lets you specify when to update
publisher’s edition file. It also lets you update the edition manually
and cancel the link between the publisher and edition. The comm
is available once you save the document containing the publisher

1 Click the publisher border to select it and choose Edit > Pub
lishing > Publisher Options.

2 To update the edition immediately, click Send Edition Now. 
Canvas updates the edition file. Whether subscribers to this edi
also get updated depends on their update setting; see “To set s
scriber options” on page 7.28. 

3 To specify when Canvas should update the edition file, choo
an option in the Send Editions area.

On Save Tells Canvas to update the edition file whenever you sa
the publisher document.

Manually Tells Canvas not to update the edition. If you select th
option, Canvas shows the time of the last publisher change.

4 When you finish setting publisher options, click OK.

◆ To break the link between publisher and edition: Click Can-
cel Publisher in the Publisher Options dialog box. This breaks the
link to the edition. However, canceling the publisher does not dele
the edition file or affect documents that subscribed to the edition.

To subscribe to a published selection

After you publish a selection, which creates an edition, you can s
scribe to the edition file to place the published selection in as man
documents as you want. 

1 In the document in which you want to place the published 
objects, choose Edit > Publishing > Subscribe To. 

2 In the directory dialog box, select the edition file for the pub
lished selection and click Subscribe. The published information 

Publisher border
Using Publish and Subscribe (Mac) 7.27
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appears in the subscriber document within a non-printing gray r
angle. You can move and resize the subscriber border.

To set subscriber options

You can make changes to an edition file appear automatically in 
scriber documents or update the subscriber manually. To set thes
and other options, use the Subscriber Options command.

1 Click the subscriber border to select it and choose Edit > Pu
lishing > Subscriber Options.

2 To update the subscriber now from the edition, click Get Ed
tion Now. To specify when the subscriber should get changes fr
the edition file, choose an option in the Get Editions area:

Automatically Tells Canvas to update the subscriber when you 
open the document and whenever the edition changes.

Manually Tells Canvas not to update the subscriber. If you selec
this option, Canvas shows the time of the last update.

3 When you finish setting subscriber options, click OK.

◆ To break the link between a subscriber and edition: Click 
Cancel Subscriber in the Subscriber Options dialog box.

◆ To open the publisher document: Click Open Publisher in the 
Subscriber Options dialog box.

Updating publishers and subscribers
When you work on a document containing publishers or subscrib
you can update all the linked items in the document at once.

◆ To update all edition files: Choose Edit > Publishing > Send 
All Now. Canvas updates all editions that are linked to the publish
in the document.

◆ To update all subscribers in a document: Choose Edit > Pub-
lishing > Get All Now. Canvas gets updates from all editions that a
linked to the subscribers in the document.
8 FILE AND DATA EXCHANGE



CHAPTER

8

rld 

cu-
s 

ou 

b 

s 
ny-
 the 
rred 

ng 
WEB PUBLISHING 

Canvas is an ideal tool for creating graphics and layouts for the wo
wide web. This chapter explores how to prepare graphics and do
ments for publishing on the web or a company intranet. It include
information on hyperlinks, animations, and web-page buttons.

About hyperlinks and hypertext
After you create illustrations and text for a web page in Canvas, y
can use the URL Attachment palette to link items in the layout to 
other web pages and resources on the Internet. 

Visible objects, such as buttons or graphics, that lead to other we
pages are called hyperlinks or simply links. Text that contains a 
hyperlink is called hypertext. Someone viewing your web page click
a hyperlink to jump to another web page located on your site or a
where on the Internet. The web browser searches the Internet for
address associated with the hyperlink. An internet address is refe
to as a URL, an abbreviation of Uniform Resource Locator.

You can make hyperlinks by assigning URLs to any object, includi
the following:

• vector objects, such as small illustrations 

• image objects, including photos and painted images

• text selections and entire text objects 

• Buttons and animations

Note: To prevent unintended changes, you can’t assign URLs to 
objects on locked layers, pages, or slides.

Hypertext Hyperlinked object Hyperlinked image

Examples of 
hyperlinks

✔Tip
To create invisible “hotspots,” 
you can assign URLs to objects 
that don’t have visible strokes 
or fill inks. This lets you desig-
nate any area of a web page as 
a hyperlink.
8.1
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Using the URL Attachment palette
The URL Attachment palette is a small floating window that lets yo
do the following:

• attach URLs to objects and text, or remove an attached U

• find objects that have a specified URL attached to them

• display the URL attached to a selected object or text

• attach sound and animation controls to objects or text

• apply colors and styles to hypertext

• designate selected text as searchable keywords

• specify the path to use for relative hyperlinks

Creating hyperlinks
Using the URL Attachment palette, you can create links to web pa
and other resources on the Internet. Your links can point to web 
pages with http URLs; to files with ftp URLs; and to e-mail 
addresses with mailto URLs. You can also make hyperlinks to web
pages that are on a local hard disk or company intranet.

URL formats

All URLs start with text that identifies the type of resource located
the URL address.

http:// A web page URL starts with “http” (for Hypertext Trans-
port Protocol), followed by the Internet address, path and name of
web page file. For example: http://www.deneba.com/index.html

ftp:// A file’s URL can start with “ftp” (for File Transfer Protocol) 
followed by the Internet address, path and name of a file. For exa
ple: ftp://ftp.deneba.com/public/Guide.pdf

mailto: An Internet e-mail URL starts with “mailto” followed by a 
username, @ symbol, and domain name. For example: 
mailto:support@deneba.com

Relative paths You can create hyperlinks to web pages by typing
relative paths, rather than complete URLs, in the URL Attachmen
palette. Canvas specifies links this way when you select local files
using the Browse button in the URL Attachment palette. See “Cre
ing links to other files” on page 8.8.
WEB PUBLISHING
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To assign a URL to an object

Use the steps below to create hyperlinks. Instructions for creating
various types of hyperlinks appear after this procedure.

1 If the URL Attachment palette is not displayed, choose 
Object > Options > URL Tag to display it.

2 Select the object to link. If the selection has a hyperlink, the
link text appears in the URL Attachment palette.

3 Do one of the following to enter the hyperlink URL:

• Type a URL (including http, ftp, or mailto), or a local web 
page file name in the text box at the top of the palette.

• Use the palette’s menu to enter a URL prefix or a previou
URL.

• Use the Browse button to select a web page file. See “Cr
ing links to other files” on page 8.8.

• Select a page from the list in the palette. See “Creating lin
to pages” on page 8.6.

4 Click Assign to assign the URL to the selection.

Note: You can’t assign a URL or action to objects on layers, page
or slides that are locked. For compatibility with all web servers, yo
should use lowercase letters when you type URLs. Some servers
(mainly Unix) have problems if URLs contain uppercase characte

URL Attachment palette

Use the palette to tag objects 
with URLs for hyperlinks.

A Type a URL.

B Select a URL or URL prefix.

C Select a page in the current 
document.

Assign: Click to assign the URL 
in the box to a selected object.

Browse: Click to select a web 
file to link to.

Find: Click to find a URL 

assigned to an object in the 
current document.

A

B

C

Using the URL Attachment palette 8.3
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To remove an assigned URL

1 Select the object that has a URL that you want to remove. T
object’s URL appears in the text box.

2 In the palette’s menu, choose “Unassign URL from selection
This command is available if the selected object has a URL tag.

Finding objects by URL
You can use the Find button in the URL Attachment palette to sea
for and select objects that have specified hyperlink text attached.

When objects are found, you can see the object type, object num
and whether an object assigned to a URL is part of a group. For t
objects, you can see the number of characters linked, where in a
object the linked characters start and end, and the linked text itse

1 Click Find in the URL Attachment palette. The URL Search 
dialog box appears (if the document contains at least one URL)

2 To specify the text to find, choose a URL in the URLs pop-u
menu or type a URL in the text box.

3 Click Find. The URL Search Results dialog displays informa
tion about objects that have the specified hyperlink text attached

4 To select an object listed in the URL Search Results dialog 
box, click the object’s name and then click Go To. 

Search options

You can select the following options in the URL Search dialog bo

Match Whole Word Select this option to match the specified text
exactly. If you type “home.htm” and this option is selected, you 
won’t find “/user/home.htm.” If the option is not selected, you will.

Search Whole Document Select this option to search beyond the
current page (slide/sheet/frame) in the document. 

...or select a URL in the document

Type the URL text to find…

Click to search 
WEB PUBLISHING
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Attaching hyperlinks to text
You can select any amount of text — from one character to whole
paragraphs or entire text objects — and use the URL Attachment
ette to make the text selection a hypertext link to a web page, ftp 
address, or e-mail address.

Hypertext styles Many web browsers display underlining or color
on hypertext. You can use the URL Attachment palette to apply 
styles and colors when you assign a URL to a text selection.

Text in images Making hypertext links in Canvas lets you design
the equivalent of image maps that can be easily edited. To do this, 
place text on images (or vector objects), and then link the text to 
appropriate URLs. Later, if you want to change the illustration, yo
can edit the text, images, and objects separately in the original C
vas document. 

To create a hypertext link

1 Choose Object > Options > URL Tag to open the URL Attac
ment palette, if necessary.

2 Make a text selection in the Canvas document. The selecte
text appears highlighted.

3 Do one of the following to define a link for the selected text:

• Type a URL (including http, ftp, or mailto) or a web page 
file name in the text box at the top of the palette.

• Use the palette’s menu to enter a URL. See “Using the UR
palette’s menu” on page 8.6. 

• Use the Browse button to select a web page file.

• Select a page in the palette’s list.

4 To apply styles or color to the text, select the Link Styles che
box. The text style buttons and a pop-up color palette appear.

• Click style buttons to apply text styles.

• Select a solid color ink from the color palette, or choose t
Custom button to use the Color Editor.

Anti-aliased 
vector 
objects and 
text 

Hyperlinked 
image

Hyperlinked 
invisible 
object

Hyperlinked 
vector and 
text 

Color palette
Select Link Styles to show the 
text style options

Text styles
Using the URL Attachment palette 8.5
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5 Click Assign to assign the URL and the selected Link Styles
the text selection.

Using the URL palette’s menu
A pop-up menu in the URL Attachment palette lets you choose U
prefixes and the text of links that have been assigned to objects in
document. You can choose commands to create sound and anim
control objects. Also, you can choose an “unassign” option to rem
a link from a selected object.

URL prefixes

In the palette’s menu, you can select prefix text for web sites, ftp 
sites, and e-mail addresses. 

• Choose http:// or http://www. to enter a web address. 

• Choose ftp:// to enter a file transfer protocol (FTP) addres

• Choose mailto: to create an e-mail link.

After selecting a prefix, type the rest of the link text in the text box

URL history

When you create a hyperlink in a Canvas document, the URL is 
added to the palette’s menu. Also, when you create a link using t
Play, Sound On, or Sound Off commands, the link text appears in
menu. 

After you assign a link to an object, you can assign the same link
other objects by choosing the link text from the palette’s menu. T
link text then appears in the text box at the top of the palette and 
can click Assign to assign it to a selected object.

Creating links to pages
The list in the URL Attachment palette lets you create hypertext lin
from one page to another in a Canvas document. After you link 
pages, you will want to export each page as a separate web page
“HTML options” on page 8.19). Using this technique, you can eas
convert a single Canvas document into a hyperlinked web site.

To create links within a Canvas document

1 In a document with multiple pages, select an object or text t
be a hyperlink.

✔Tip 
You can use the Document Lay-
out palette to assign meaningful 
names to pages before you cre-
ate links to them using the URL 
Attachment palette.
WEB PUBLISHING
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2 In the URL Attachment palette, choose the page to link to. T
page name (with the extension “htm”) appears in the text box.

3 Click Assign to assign the hyperlink to the selected object.

Invalid characters in page names

Because some special characters are invalid in web page names
vas converts these characters if they are in a page or slide name
you select in the URL Attachment palette.

If invalid characters appear in a page name, Canvas replaces the
acters with underscores when Canvas assigns a URL. Invalid cha
ters include a blank space and the characters in the following tab

Format of hyperlinks

Canvas creates links among pages using only file names, not com
plete URLs. The “Create Absolute URLs” option in the “Directorie
for Server Aliases” dialog box does not affect links to pages or slid
within a Canvas document. 

Therefore, when you create a series of linked web pages from a C
vas document, be sure to keep the resulting files together in the s
folder or directory on the web server so the links among the page
function correctly.

Invalid characters in assigned URLs

!
@
#
$
%
^

&
*
(
)
+
=

[
]
{
}
|
tab

` (grave accent)
~
<
>
?

Page names in the URL
Attachment palette
Using the URL Attachment palette 8.7
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Creating links to other files
You can use the Browse button in the URL Attachment palette to 
ate links to existing web pages. 

Creating links to web pages depends on their location in a directo
structure. You can use the Directories command (in the palette’s 
menu) to set a directory path for local web pages and the URL fo
web server. You need to do this before using Browse to link local
files. For details, see “Using the Directories command” on page 8

To use Browse to link to a local web page

1 Click Browse in the URL Attachment palette. 

2 Use the directory dialog box to select the web (HTML) file.

Note: By default, files that do not have an extension containing 
“htm” do not appear in the file list. To link to web pages, be sure t
select files that have the extension “htm.” 

3 To assign the link to the selected object, click Assign. Canv
makes the link based on the file’s location in the directory structu

Messages displayed when using Browse

Before you can use the Browse button, you must choose Directo
in the palette’s menu to define the Root URL of the web server an
the Equivalent Root folder on your local hard disk. You can also 
specify the Destination directory where you will save the current w
pages. 

If you haven’t specified the Root URL of the web server and the 
Equivalent Root, a message appears. If this happens, click OK in
message box to continue. Then, use the Directories command as
described next.

Using the Directories command

The Directories command lets you specify the root directory of yo
web server and the equivalent directory for web pages on your ha
disk. You need to do this to be able to use the Browse button to cr
links to local web page files.

1 Choose Directories in the URL Attachment palette’s menu. 
The “Directories for Server Aliases” dialog box appears.

2 In the Root URL text box, type the complete URL for the roo
directory of the web site. Usually, the root URL format is “http://” 
WEB PUBLISHING
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followed by the domain name (such as www.deneba.com), followed 
by a slash that indicates the root directory.

• When you assign a hyperlink in the URL Attachment pal-
ette, and the “Create Absolute URLs” option is selected i
the “Directories for Server Aliases” dialog box, Canvas 
constructs the complete URL by preceding the name of a
file you select with the text you enter in the Root URL tex
box.

3 In the Equivalent Root text box, type the name of the directo
or folder on your local hard disk that you use as the “root” folder
for storing your site’s web pages. Click the Browse button to use
directory dialog box to select a file that is in the folder you want 
specify as the Equivalent Root folder.

• Canvas uses the location of the Equivalent Root folder 
when it creates URLs for a file you select on disk as the t
get of a hyperlink. Canvas compares the file’s location 
within the directory structure to the location of the Equiva
lent Root. For example, if the file you select is one level 
below the Equivalent Root, Canvas includes the parent 
folder in the directory path when it constructs a complete
URL.

4 In the Destination folder text box, type the name of the folde
where you are saving the current document’s web pages, or use
Browse button to select a file in this folder.

5 Click OK to implement the directories.

Create Absolute URLs option

You can select the option “Create Absolute URLs” in the “Directo
ries for Server Aliases” dialog box to tell Canvas how to enter UR
when you use the Browse button in the URL Attachment palette.

If “Create Absolute URLs” is selected, and you use the Browse b
ton to select a file, the link to the file appears as a complete URL 
(beginning with http://) in the URL Attachment palette. If this option
is not selected, links to other pages appear as relative paths when
use the Browse button to select a file.
Using the URL Attachment palette 8.9
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About file locations and URLs
In most cases, web files are created on one computer and transfe
to a web server that is connected to the Internet. You might creat
web pages on your home or office computer, then transfer the file
over a network or the Internet to a web server.

Web pages often contain links to other web pages on the same w
server. Because these links are based on the names and location
the files on the web server, changing file names or locations can 
break the links among the pages.

To successfully create hyperlinks among web pages on your site,
should understand how to use relative directory paths, absolute d
tory paths, and Internet URL addresses.

Absolute paths An absolute path specifies a file’s location startin
at the top, or root, of the directory structure in which the file is store
For example, if a file named “Calendar.html” is stored in a folder 
named Events, inside a folder named Public, which is inside a fol
named Home at the root of the hard drive, the path to the file is: 

/Home/Public/Events/Calendar.html

Relative paths A relative path specifies the location of a file rela-
tive to the location of another file in the same directory structure. 
Rather than starting at the root of the directory structure, a relativ
path starts at the location of one file or folder and lists the relative
steps needed to get to the specified file. In a relative path, the sym 
../ (two periods and a slash) signifies a move up one step toward the
root level in the directory structure. 

Type the URL of the web 
server’s root directory

Type the equivalent folder 
on your local hard disk

Type the folder where you 
store web pages
0 WEB PUBLISHING
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Complete URLs Like an absolute path, a complete URL lists the 
directory path starting at the root to the location of a web page on
server. In addition to the path and file name, a complete URL 
includes a protocol (http or ftp) and an Internet domain name.

In the “Directory paths” diagram on page 8.11, if the folder named
Home is the root folder of a web site, the URL for the “Calen-
dar.html” page is:

http://www.domain.com/Home/Public/Events/Calendar.html

Entering file names and URLs When you create hyperlinks, you 
can specify the target as a relative path or a complete URL. 

• If the two pages are in the same folder or directory, the re
tive path is simply the name of the target file.

• A complete URL specifies the actual location of the file o
a web server on the Internet. 

Directory paths

In the directory diagram shown here, the rela-
tive path from the file “Local.html” in the Maps 
folder to the file “Calendar.html” in the Events 
folder is:

../../Public/Events/Calendar.html

In this case, the relative path starts on one 
branch of the directory tree, moves to the root, 
and then back down another branch. 

If two files are on the same branch of a directo-
ry, the relative path can be much shorter than 
the absolute path. For example, the relative 
path between the file “Calendar.html” in the 

Events folder and a file named “Schedules” in 
the Public folder (one level above Events) is:

../Schedules.html

The absolute path to the same file is:

/Home/Public/Schedules.html

Calendar.htmlLocal.html

PublicOffices

Maps Events

Home

http://www.deneba.com/default.html

Protocol Domain 

Root of directory

file name

A complete URL for a web page
Using the URL Attachment palette 8.11
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You can type a relative path or a complete URL in the text box at 
top of the URL Attachment palette.

When you use the Browse button in the URL Attachment palette,
Canvas can enter a relative path or a complete URL. See “Create
Absolute URLs option” on page 8.9 for more information.

Creating sound and animation links
The commands Play, Sound On, and Sound Off in the URL Attac
ment palette’s menu let you assign actions to objects on a web p

Play

The Play command lets you create “play” buttons for animations a
sounds on web pages. You assign the Play command to an objec
such as a web button, and specify the animation or sound object t
played. When you click the button, the specified sound or animat
plays on the web page.

Sound On / Sound Off

These commands let you disable or enable sound playback for a
mations that contain sounds. You can attach the Sound On or So
Off command to an object such as a web button, and specify the 
object number of the animation that you want to control. When yo
click the button on the web page, it enables or disables sound pla
back for the specified animation.

Sound On and Sound Off do not affect sound playback while an a
mation is running. If the sound is disabled, the Sound On comma
enables sound; the sound is heard the next time the animation is
played. If sound is enabled, the Sound Off command disables sou
the sound is not heard the next time the animation is played.

To create a sound or animation control object

Use the following procedure with the Play, Sound On, or Sound O
commands to create a control button.

1 Select the object you want to use as a control object, such a
web button, vector object, image, or text object.

2 In the URL Attachment palette, choose a command in the p
ette’s menu. The command appears in the text box.

• Choose Play to play a sound or animation.

• Choose Sound On to enable an animation’s sound.
2 WEB PUBLISHING
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• Choose Sound Off to disable an animation’s sound.

3 A dialog box lists the sound and animation objects in the do
ment. Select the object you want to control and click OK, or dou
ble-click the object name in the list.

Invalid link text

If you click Apply in the URL Attachment palette when the text in 
the text box isn’t valid for creating a link, an error message appea
If this happens, click OK to continue, and then change the text to
make a valid link.

Using web buttons
You can create and place dynamic buttons in web pages. Web b
tons can be linked to URLs, sounds, and animations. You can bu
buttons with text, vector objects, and images. A web button can 
change when the pointer touches it and when it is clicked.

The Web Button tool opens the Web Buttons palette and places b
tons in documents. The tool is in the Object Tools toolbar.

Creating web buttons
A dynamic web button has three states: when the pointer is not on
button, when the pointer touches the button, and when the button
pressed. When you create a button, you can use a separate obje
image for each of the button’s states. 

For example, to make a circular button that changes from red to b
when you point to it, and then changes to green when you click it
you could use circles filled with red, blue, and green.

Note: You can’t use a web button or sound as a component of a w
button. Also, null objects can’t be used in web buttons. A null obje
is an object that has its pen ink and fill ink set to “none.”

To create a web button

1 Double-click the Web Button tool to open the Web Buttons 
palette, if necessary. 

2 Drag the object for the button’s “Up” state (when the pointer
not on the button’s bounding rectangle) into the Up box in the W
Buttons palette. The object appears in the box.

3 Drag the object for the button’s “Over” state (when the point
is on its bounding rectangle) into the Over box. 

Web Button tool
Using web buttons 8.13
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4 Drag the object for the button’s “Down” state (when the butto
is clicked) into the “Down” box.

Note: You can drag objects into the boxes in any order.

◆ To add a web button to the palette: To store a button in the 
palette, drag from the preview box to the scrolling area at the top
the palette.

◆ To delete a web button from the palette: Drag the button 
you want to delete to the trash can in the palette. The button disa
pears from the palette.

Adding sounds to web buttons
You can attach sounds to the Over and Down states of a web bu
The Over sound plays when the user moves the pointer over the 
ton, and the Down sound plays when the user clicks the button. Y
can attach separate sounds to a button’s Over and Down states.

Use the pop-up menu over the Over or Down box to do one of th
following:

• Choose a preset sound. The menu contains a variety of 
built-in sounds you can assign to a button state.

• Choose Other and select an “AU” sound file, and then cli
Open.

• Choose None to remove a sound from a button state.

Placing web buttons in a document
Use this procedure to place web buttons in a Canvas document. 
you want to place multiple copies of the same button, use this pro
dure once, and then see “Placing copies of web buttons,” next.

1 Double-click the Web Buttons tool to open the Web Buttons
palette. If the palette is already displayed, select the tool.

2 At the top of the Web Buttons palette, select the button to 
place. The selected button appears in the preview box. 

3 Do one of the following to place the button:

• Click where you want to place the button’s top-left corner

• To scale the button, drag to create a bounding rectangle.

Note: When the Web Buttons palette is closed, you can use the W
Button tool to place the last selected button. Or, if the Web Button
4 WEB PUBLISHING
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tool is not selected but the palette is open, you can drag a button f
the palette into the document.

Placing copies of web buttons

To place multiple copies of the same button, it’s recommended th
you use the Web Button tool to place the first button in the docume
and then use the Edit > Duplicate command to create copies. Thi
method results in faster display of a web page than if you use the
Web Button tool to place several instances of the same button.

Editing web buttons 

When a web button has been placed in a document, you can sele
button and drag a handle to resize its bounding rectangle. You ca
edit its attributes, such as pen ink, fill ink, and stroke. You can 
change the objects in the button, and then replace the button. 

To change a button’s Up, Over, or Down object, drag the object fr
the palette into the document. Modify the object and drag it back i
the palette. Place a new copy of the button in the document, and s
the modified button in the palette if you want to use it again.

Testing web buttons
Before storing a new button in the palette, you can test it in the W
Buttons palette. When the pointer is not in the preview box, you c
see how the button will look on a web page when the pointer is no
the button’s bounding rectangle. To see the button’s appearance
when the pointer is on its bounding rectangle, move the pointer in
the preview window. To see the button’s appearance on a web p
when the button is clicked, click in the preview box.

Testing web buttons in a document

After you place a web button, you can test it before you save the 
ument in HTML format. To do this, you use the Web Buttons pal-
ette’s “play” mode.

When you click “Start Play Mode” in the palette, Canvas puts butt
objects in the document in “play” mode. When you move the poin
over a button, or click it, you see the effects in the document. Wh
you finish, click “End Play Mode.”

It’s recommended that you click “Start Play Mode” only to test we
buttons. You shouldn’t work in Canvas while play mode is active. 
sure to click End Play Mode before starting other work. Otherwise
you might not be able to select objects or change tools.
Using web buttons 8.15
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Linking web buttons

By using the URL Attachment palette, you can link buttons to URL
sounds and animations. For more information, see “Creating hyp
links” on page 8.2 and “Creating sound and animation links” on 
page 8.12.

Saving web buttons
Canvas stores information about web buttons in the Canvas Tool
tings file in the Preferences folder in the System Folder (Mac OS)
the cv7tool.set file in the User folder (Windows). When you add a
web button to the palette, it’s available in all Canvas documents.

Saving and loading buttons files

You can save in a file all the buttons that are stored in the Web B
tons palette. You can load buttons back into the palette from thes
files.

◆ To save buttons: In the palette’s pop-up menu, choose Save 
Buttons. Type a name for the file and click Save.

◆ To load buttons: To replace all buttons in the palette with thos
saved in a file, choose Load Buttons in the pop-up menu, select a
tons file, and click Open. To add to the buttons in the palette, cho
Append Buttons from the pop-up menu, select a buttons file and c
Open.

◆ To clear buttons: To remove all buttons from the Web Buttons
palette, choose Clear Buttons from the palette’s pop-up menu.

Using sounds
You can use the Sound tool to place sounds on web pages. Canv
supports AU (Sun Audio) sound files. Many utilities will convert 
sound files to AU format. Canvas supports sound files that are 
recorded with single-channel sound, sampling rate of 8,012 Hz 
(cycles per second), and µLAW compression.

To place a sound object

1 Select the Sound tool in the Object Tools toolbar, and then 
click where you want to place the upper-left corner of the sound
object. Or, drag to set the size of the sound object. 

2 In the dialog box, select an AU sound file and click Open.

Note: The sound file you assign must have an “AU” extension. 
6 WEB PUBLISHING
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To set sound options

After placing a sound object in a document, you can set options f
the object. You can control whether the object will be visible in the
web page and specify a playback method.

1 Double-click a sound object. 

2 Choose a playback method in the Play Type pop-up menu:

On Click plays the sound when the sound object is clicked.

On Load plays the sound one time when the web page load

URL Linked establishes no playback method for the sound 
object. Choose this method if you want to use another objec
such as a button, to play the sound.

3 Click OK to apply the settings to the sound object.

Linking to sound objects

You can create a link between an object, such as a button, and a
sound object. For information, see “Creating sound and animation
links” on page 8.12.

Using GIF animations 
You can work with web animations in Canvas using Animation do
uments and the Animated GIF tool.

Creating animations

You can create animations by assembling images in an Animatio
document and saving an animated GIF file. The Animation docum
consists of a series of frames, like individual pages. You add obje
to the frames to create an animation sequence. The Document La
palette lets you arrange the frames and set their duration.

For more information on Animation documents and using the Doc
ment Layout palette, see “Document layout” on page 6.1.

◆ To save an animated GIF file: Open the Animation document 
you want to save as an animation file. Choose File > Save As. Se
GIF Animated file format, enter a file name, and click Save.

Editing animations
You can use the Open command to import an animated GIF file f
editing. You can edit the frames and save a new animated GIF fil
Using GIF animations 8.17
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To import an animation

1 Choose File > Open. 

2 Select the animated GIF file and click Open. 

3 A dialog box appears. Enter the first and last frames to impo
Click OK to import the frames into a new Animation document. 

Placing animations

You can use the Animated GIF tool to insert animated GIF files in
web pages that you design in Canvas. When you save a docume
a web page, animations are exported and appear on the web pag

Whether you create animations using Canvas or have animated G
from other sources, the procedure for placing them is the same.

To place an animation

1 Select the Animated GIF tool. This tool is located in the Obje
Tools palette.

2 Click in the document where you want to place an animation

3 A directory dialog box appears. Select the animated GIF file
place and click Open. Canvas inserts the file as an animation ob

To preview an animation, double-click the animation object. You c
select, move, cut, copy, duplicate and apply other commands, inc
ing Rotate and Flip, to animation objects. 

You cannot apply some effects, including Envelope and Extrude.
Commands such as Scale and Shadow can be applied, but they a
only the bounding box, not the objects in an animation.

Saving Canvas documents for the web
To export a document as one or more web pages, you can save 
document in HTML format.

Note: You should always save your documents in Canvas format 
before you export web pages. Saving in Canvas format means yo
can edit the original and export again to change web pages. Can
does not support opening and editing of HTML web pages.

To save a document in HTML format

1 Open the Canvas document that you want to save as one o
more web pages, and then choose File > Save As.
8 WEB PUBLISHING
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2 In the directory dialog box, select HTML file format. Select a
location to save the files, type a file name, and click Save.

3 In the HTML Options dialog box, select options for saving th
web pages (described next), and click OK to save them.

How Canvas handles images

Canvas uses compression and color reduction to optimize image
faster display on web pages. When you select the Automatic Ima
Format option, Canvas exports RGB Color and CMYK Color imag
as RGB (24-bit) images using JPEG compression. Indexed mode
images, which use a maximum of 8 bits of color information per 
pixel, are exported in GIF format. Black and White images are 
exported as Indexed (8-bit) images. Canvas exports Grayscale 
images as Indexed 8-bit images or JPEG-compressed RGB imag
using the format that it determines will produce the best results.

Including document data

When Canvas creates an HTML file from a document, it uses me
tags in the HTML file header to include data has been entered in 
document Properties dialog box. This data includes information s
as Title, Subject Keywords, Author, and Category from the fields 
the Summary tab for the Canvas document.

HTML options
The HTML Options dialog box controls the saving of web pages.

Create new folder This option organizes files for a web page by 
placing them in a new folder in the location you specify. The nam
you enter for saving a web page file is used for the folder name. 

Separate pages This option is available when the Canvas docu-
ment you are saving contains multiple pages. Select Separate Pa
to create a web page from each page in the Canvas document. T
page names will become the web page file names. If you do not se
this option, Canvas exports all pages as one web page.

Put images in subfolder To help organize files, this option creates
a subfolder for the web page image files inside the web page fold

Generate Navigation File If there is more than one web page to b
created, select this option to generate an “index” page. The index
page has frames and hyperlinks to all the web pages you are sav
Saving Canvas documents for the web 8.19
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Use external style sheet Select this option to create an external 
style sheet for web pages that you are saving. An external style s
can make it easier to edit styles manually. This option can also red
the size of individual HTML files, because the complete style info
mation is not included in each web page file.

Render Text Rendering converts text objects to images to ensur
that text appears exactly the same on the web as it does in your d
ment. However, rendered text can’t be selected as text on a web p

Select Automatically to let Canvas decide when to render text. Sele
Always to render all text. Select Never to preserve all text.

Image Format Select Automatic if you want Canvas to choose the
file format for images. Select JPEG or GIF format to save all imag
in one or the other format.

JPEG Quality Select an image quality option based on the amou
of JPEG compression you want Canvas to apply to images. Best pro-
duces the best quality with the least compression (100% Quality)
Fine is equivalent to 90% Quality. Good is equivalent to 75% Qua
ity. Draft applies the most compression and is equivalent to 50% 
Quality.

Anti-aliasing

Select this option to smooth the edges of vector objects and text 
objects that are rendered for web pages. Choose an option from 
menu to control the amount of smoothing. 

Finest uses up to 256 shades for anti-aliasing between each pair 
colors. When images have more than 256 colors, they should be
saved in JPEG format to preserve the full range of shades. If nec
sary, Canvas will use JPEG format when it saves anti-aliased ima
if you select the Automatic Image Format option.

Fine option uses 64 shades per pair of colors. Medium uses 16 
shades per color pair. Coarse uses four shades per color pair. 

None does not apply anti-aliasing to rendered images.

Save this setting as default Select this option to save the current 
settings in the dialog box for all documents. Otherwise, Canvas sa
the settings for the current document only.

Default Click Default to apply the settings that were in effect the
last time “Save this setting as default” was selected and you click
OK. If you have never selected the save settings option, clicking 
default will apply the Canvas default settings to the dialog box.
0 WEB PUBLISHING
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CUSTOMIZING CANVAS

You can customize your Canvas work environment to best suit th
needs of a specific project and to maximize your productivity. Thi
chapter describes how to set preferences, customize keyboard sh
cuts and the Toolbar, save document templates, and create custo
sets of Canvas tools. 

Setting preferences
Preferences are options that let you customize the display, tools,
commands. You can set these options in the Preferences dialog 

To change preference settings

1 Choose File > Preferences.

2 In the Preferences dialog box, click a tab to display its option
Adjust the options you want to change. 

3 To implement the current settings, click OK. 

Note: For options that you turn on and off (as opposed to entering
number or choosing a menu option), the descriptions in this chap
refer to the way Canvas works when the option is on. An option is
when its checkbox is selected (has a check mark in the box); an 
option is off when its checkbox is not selected (has no check mar

General preferences
The options on the General preferences tab control various displa
and window behaviors.

Number of Undo Levels Enter a number in the Min box to set the
minimum number of actions that Canvas can reverse. The defaul
three. Enter a number in the Max box to specify the maximum nu
ber of actions that Canvas reverse. The default is 10.

To undo an action in Canvas, choose Edit > Undo.

Canvas uses memory to store operations so they can be undone
amount of memory depends on the operation. For example, undo
a filter applied to a 2 MB image requires significantly more memo
than reversing a change in type size. 
9.1
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Canvas allocates memory to ensure that you can undo the specif
minimum number of actions. Canvas tries to set aside enough m
ory so you can undo the specified maximum number of actions. I
uses this memory if it’s needed for other operations. Therefore, y
should be able to undo the specified minimum number of actions,
you might not be able to undo the specified maximum number of 
actions. The memory allocation ensures that you’ll have the most
memory available in Canvas.

Freeform Selection Lets you place objects in freeform mode by 
clicking already-selected objects. Otherwise, you must use the 
Effects > Freeform command to put an object in freeform mode.

Retain Selected Tool Keeps the current tool selected after you us
it, instead of reverting to the Selection tool.

No Background Updates Prevents Canvas from redrawing open
Canvas documents when you are working in another application.
This option lets other applications run faster when Canvas is in th
background.

Dither Colors Provides the best onscreen color representation, 
requires more system memory. If you are using Canvas for Mac O
this option requires 32-bit color capabilities.

Select Across Visible Layers Lets you select objects on all visible
layers in a document, rather than just the active layer.

Note: If this option is off, you can still select objects on other visibl
layers by pressing Tab and clicking the objects.

Fit to Window Opens documents so the full layout area can be se
in the center of the window. When this option is off, documents op
in Home View (100% magnification with the upper-left corner of th
page in the upper-left corner of the window).

Maximize on Opening Opens documents at full screen size. Oth
erwise, documents open at a standard size that fits any monitor, 
might not fill the screen completely.

Create backup when saving Saves a copy of the current documen
each time you save changes to the document. The backup copy 
the extension “.bak,” and Canvas saves to this same file each tim

Search selection on clicks When this option is on, you can drag a
selected object from behind another object. If this option is off, yo
can drag only the front object, because dragging deselects a bac
object.
CUSTOMIZING CANVAS



n 

 

 in 
Can-
t has 
he 
-
h 

s 

ll 

ea-

 

in 

 

gi-

-
l-
ll 
 

Canvas 6-style object locking When you lock an object or group 
of objects, you can select and copy locked object(s) by clicking o
the object or group of objects. Copied objects will not be locked.

Tool tips Displays information, tips and shortcuts in small boxes
that appear when you point at an item, such as a tool, button, or 
object. For example, if you move the pointer over the Copy button
the Tool Bar, Canvas displays the command name and shortcut. 
vas also displays user comments when you point to an object tha
comments, and displays information when you point to an ink in t
Inks palette. For color inks, Canvas displays color system informa
tion. For example, if you point to a CMYK ink, the color values suc
as “5c 2m 92y 0k” appear in a pop-up box. For other inks, Canva
displays the ink name.

Scale Stroke Weight When you scale an object by dragging its 
selection handles, if the object has a solid pen stroke, Canvas wi
scale the pen weight proportionately with the object.

Drawing preferences
The Drawing tab lets you select a coordinate system for angular m
surements and specify behavior for moving and copying objects. 

Coordinate System Choose the Standard or Engineering system
for angular measurements.

When dragging and resizing always show originals When you 
drag or resize an object, it will follow the pointer and also appear 
its original position until you release the mouse button.

Windows Selecting this option means that when you drag an
object, an outline of the object (without pen ink, fill ink, or 
stroke) will follow the pointer. 

Mac Selecting this option means you will always see the ori
nal object when you drag and resize. When dragging, if you 
pause after pressing the mouse button before you begin drag
ging, you will see the object (with ink and stroke attributes) fo
low the pointer. If you begin dragging without pausing, you wi
see an outline of the object (without pen ink, fill ink, or stroke)
follow the pointer.

EngineeringStandard 
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When duplicating objects offset Tells Canvas how far (in pixels) 
from the original to put object copies when you use the Duplicate
Paste commands in the Edit menu.

When moving objects offset Lets you specify the number of pix-
els objects move when you use a combination of modifier and arr
keys. For example, with the settings shown here (for Windows), 
Ctrl+Right Arrow moves a selected object 50 pixels to the right, a
Alt+Right Arrow moves it 10 pixels to the right. Canvas for Mac O
users can use the Command and Option keys in combination wit
arrow keys.

• Auto-scroll to selection keeps objects that you move using
the arrow keys in view by scrolling the document window

Painting preferences
The Painting tab lets you set preferences for displaying and editin
paint objects and images. 

Interpolation Tells Canvas how to fill new pixels created by resiz
ing a paint object or applying certain filters.

• Nearest Neighbor fills new pixels with the same color as 
an adjacent pixel.

• Bilinear fills new pixels with colors derived from the color 
values of adjacent pixels. This creates softer edges than
Nearest Neighbor.

Color Channels Makes channel previews in the Image Channels
palette appear in color rather than shades of gray.

Video LUT Animation (Mac only) Provides faster previews of 
some image filters by modifying the color lookup table of your mo
itor instead of redrawing the image. For example, with Video LUT
Animation turned on, changing the brightness of an image in the 
Brightness/Contrast dialog box with the Preview option off chang
the brightness of the entire screen and not just the image.

Anti-aliased Clipboard Anti-aliases vector and text objects pasted
from the Clipboard into a paint object.

Anti-aliased Canvas Objects Anti-aliases Canvas vector and text 
objects drawn in a paint object. For example, if you add text to a p
object in edit mode, Canvas rasterizes and anti-aliases the text.

Plug-ins Click the button to set the location of Photoshop-compa
ble plug-ins for use in Canvas. In the directory dialog box that 
appears, select the folder containing the plug-ins. The path name
CUSTOMIZING CANVAS
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the folder appears below the Plug-ins button on the Painting tab. 
Installed plug-in filters appear in the Image > Filters submenu.

Don’t Show Plug-in Host Warning Suppresses the message that 
Canvas displays if it tries to load a software plug-in that requires a
specific host program. Deselect this option if you want Canvas to 
play the message so you can choose whether to load the plug-in.

Separate Grayscales as Black Select to separate grayscale paint 
objects on the black plate only. Deselect this option for Canvas to
treat gray color values as RGB colors that will be separated as 
CMYK grays.

Brush pointers

These options let you change the pointer displayed for painting to
The default pointer is a symbol of the current painting tool.

Standard Pointer Displays the icon for the current painting tool. 

Precise Pointer Displays a cross hair pointer. The intersection o
the cross hair is the center of the current brush. 

Brush Size Pointer Displays an outline of the current brush as th
pointer. Note: You can use the context menu to change the pointe
while you edit a paint object.

Printing preferences
The Printing tab has several settings that let you control the appe
ance of printed output. These settings affect printed output when 
use the “Print as: Composite” setting in the Print dialog box, and 
not affect printing when you use the “Print as: Separations” settin

Output to maximum resolution Prints Canvas documents at the 
printer’s highest resolution.This setting disables image-reduction 
options and fast-printing features of QuickDraw® printers, which 
require a setting of 72 dpi.

If you print documents to a PostScript printer, it’s a good idea to 
select this option. However, if you are using Japanese fonts (two-
byte), you can deselect the “Output to maximum resolution” chec
box, and then use the pop-up menu to select 300 dpi, which will 
speed up printing.

When “Output to maximum resolution” is not selected, you can 
choose the resolution (from 72 to 2,540 dots per inch) to use in th
Resolution pop-up menu.
.5
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Halftone options

The options in this area let you set the halftone screen frequency
the halftone screen angle for composite printing. You can also cho
to use the printer’s default halftone settings. 

For most desktop publishing purposes, the printer’s default settin
are probably the best to use. For commercial printing, you might 
need to specify a particular frequency and angle for the best outpu
you are sending documents to a commercial printer, ask about th
appropriate halftone screen settings.

Use printer’s default Select this option when you often print to 
desktop devices such as laser printers, and the default halftone sc
frequency and angle are appropriate for your documents.

Frequency To specify a halftone screen frequency, clear the “Us
printer default” checkbox, and enter the frequency in lines per inch
the text box. A higher frequency requires a higher printer resolutio
to produce the same number of grayscale levels in printed halfton

Angle If you want to specify the angle of the screens used for ha
toning, rather than use the printer’s default setting, clear the “Use
printer default” checkbox, and enter the angle in the Angle checkb

Display preferences
Options on the Display tab let you customize the display. You can
control transparency effects, display speed and display quality.

Transparency display

The Transparency options let you control how transparency appe
when a paint object is in edit mode.

No Preview Displays a checkerboard pattern to represent transp
ency in an image. This isolates an image from background object
which can be helpful for editing complex compositions.

Background Preview Displays transparency in an image during 
editing. Objects behind the image are rendered realistically while y
edit. (If no objects are behind the paint object, the document’s wh
layout area shows through transparent areas.) Objects in front of
paint object are hidden during image editing.

Total Preview Displays both background and foreground transpa
ency during image editing. This is the most accurate preview.
CUSTOMIZING CANVAS
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Draw Quality

These options in this pop-up menu affect the entire screen displa
Canvas.

Draft Provides the fastest screen display by drawing vector obje
less smoothly. Choosing this option can increase display speed b
300%.   

Normal Provides fast screen display and draws smooth vector 
objects. This is the recommended setting and is selected by defa

Anti-aliased Significantly smooths all objects on screen, includin
text and vector objects, by anti-aliasing their edges. This setting i
especially useful when you create screen shots or display slide sh
on screen. However, this anti-aliasing slows the display compare
Draft or Normal settings.

Note: The effect of the Anti-aliased text option is independent of th
Anti-Aliased option on the Display tab. If either option is selected,
text is anti-aliased; if neither option is selected, text is not anti-
aliased.

Object Caching

Keeps screen images in memory so the display refreshes significa
faster when you move or edit objects. This is the recommended 
option. If you deselect this option, less memory (up to 4 MB) is us
for screen display, but displaying complex images might be very 
slow.

Type preferences
The Type tab in the Preferences dialog box lets you customize 
options for text and typography.

Note: Some options on the Type tab are different for Mac OS and
Windows versions of Canvas, as noted in this section.

Auto Word Select When you use the I-beam pointer to highlight 
specific text, this option ensures that you select only whole words 
characters between blank spaces). As you drag to highlight text, C
vas detects when you drag over a space. As you continue to drag
Canvas locates the next space and selects the characters in betw

Drag & Drop Text With this option on, you can highlight specific 
text, then drag the highlighted text to a new location within the sa
text object.
Setting preferences 9.7
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Smart Copy With this option on, if you copy and paste text that 
begins a paragraph, Canvas pastes the text as a new paragraph 
the original paragraph settings. With this option off, Canvas paste
text into the current paragraph using the existing paragraph settin

Use Smart Quotes Select this option if you want Canvas to insert
true typographical apostrophes (’), single quotation marks (‘’), and
double quotation marks (“”) when you type these characters with 
Text tool. Otherwise, these characters appear as straight tick ma
or foot (') and inch (") marks. Of course, the actual appearance of
characters depends on the design of the typeface in use.

The character that Canvas inserts when you type a quotation ma
depends on the position of the insertion point in the text, and its p
tion relative to other quotation marks. For example, Canvas alwa
inserts an open quotation mark (“) when you type a quotation ma
immediately following a space.

The “Use Smart Quotes” preference setting has no effect on text 
you type with the Path Text tool.

Anti-alias text Select this option to soften the onscreen appearan
of text based on a point size you specify. You can specify a point s
from 10 to 128 points. When the apparent point size of text you ty
is equal to or less than the point size you specify, Canvas softens
appearance.

Use Greeked text Select this option if you want Canvas to replac
lines of text characters with gray bars, which speeds up screen 
redraw. This preference does not affect printing. 

Enter a size in points in the adjacent text box. When “Use Greeke
text” is selected, Canvas replaces text at the specified size and 
smaller when the display magnification is 100% or less. 

For example, if you specify 12 points, and zoom to 200%, Canva
replaces any text that is 6 points or smaller. If you zoom to 50%, 
Canvas replaces text that is 24 points or smaller. It’s a good idea
set the size the same as most body text in your documents. This 
you view headlines and display type normally, while Canvas repla
the body text at 100% magnification. Then, when you zoom in to e
the body text, it will appear normally at the higher magnification.

Windows-only Type preferences
Draw Text as Béziers When using a 256-color display, Windows 
cannot dither colors in text to approximate a non-system color; 
CUSTOMIZING CANVAS
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instead, Windows uses the closest solid colors. Turning this option
tells Canvas to redraw text as objects, which lets Windows dither 
ors when necessary. This method is resource-intensive and can b
slow; turn this option on only if you need to see dithered color in te
on a system with a 256-color display.

Faster Text/Poor Color Turning this option on speeds up screen 
redraw of text at the expense of color fidelity.

Tools and options for two-byte and vertical text
A special preference option appears on the Type tab if your syste
capable of using two-byte languages. If your system is not equipp
for two-byte text, the option does not appear on the Type tab.

The option labeled “Enable two-byte script” tells Canvas to accom
modate text characters that require twice as much data (two byte
text characters in most Western languages. This makes it possib
create documents using specialized two-byte fonts, including Chi
nese, Korean, and Japanese. 

The “two-byte” preference also can make available several tools 
options that let you create vertical text objects (with or without two
byte fonts), and use an entry window for typing two-byte characte
These tools and options are described in this section.

You can select the “Enable two-byte script” option in any version 
Canvas. However, to use two-byte fonts in a document, you mus
have an operating system version that supports two-byte fonts. F
Mac OS, you must have a two-byte system version, or a software
package such as the Japanese Language Kit. On Windows, you 
have a two-byte version of the operating system.

Unlike other preferences, which take effect immediately, you mus
quit and restart Canvas to activate or deactivate the two-byte text
preference. If the two-byte text option is selected, after you start C
vas, you can use two-byte text characters. 

Depending on the amount of text in your documents, activating th
two-byte text preference might slow down text editing.

Two-byte text tools and options

When the two-byte text preference is active, the following items 
appear:
Setting preferences 9.9
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• “Vertical” options appear in the Column Guides dialog bo
and the Type palette; see “Options for vertical text and co
umns” on page 9.10.

• The Vertical Text tool appears in the toolbox; see “Vertic
Text tool” on page 9.12.

• The Vertical Text Object tool appears in the toolbox; see
“Vertical Text Object tool” on page 9.13.

• The Inline tab appears in the Preferences dialog box; see
“To set inline text-entry preferences” on page 9.13.

Measurement units

When you activate the two-byte text preference, Canvas selects t
metric measurement system by default. You can select another s
tem for measurement units by choosing Rulers in the Layout men
For more information on rulers, see “Setting up rulers and the dra
ing scale” on page 5.7.

Options for vertical text and columns
A checkbox labeled “Vertical” appears in two places: the Column
Guides dialog box and the Type palette.

In the Column Guides dialog box, you can create column guides 
vertical text in Publication documents. In the Type palette, you ca
specify horizontal or vertical orientation for text objects.

Note: The Vertical options described in this section, which appear
when “Enable two-byte script” is selected, are not related to the 
“Vertical” command that changes the alignment of text bound to a
path. 

To use vertical text column guides

You can use the Column Guides dialog box to set up horizontal 
guides for columns (text objects) that contain vertical text.

1 If necessary, select the “Enable two-byte script” preference.

2 Choose Column Guides in the Layout menu. The Column 
Guides dialog box appears.

3 Select the “Vertical” checkbox. The column guide buttons a
the top of the dialog box change to vertical orientation.
0 CUSTOMIZING CANVAS
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4 Use the preset column buttons or the other options to speci
guides for the number of columns that you want to use.

• To use preset column guides, click one of the buttons. Lin
on the first buttons show 1, 2, and 3 text columns. Numbe
on the last two buttons show that these make 4 and 5 co
umns.

• You can set up guides for any number of columns from 1
12 using the “# of columns” text box.

5 Click OK to create guides for the specified number of colum

To use the Vertical option for text objects

You can use the Vertical option in the Type palette to set up the T
tool for vertical text, and to orient text objects to contain vertical te

1 If necessary, select the “Enable two-byte script” preference.

2 Open the Type palette by double-clicking the Text tool or 
choosing the Type command in the Text menu.

3 Do one of the following to set up the Text tool, or to change t
orientation of existing text objects:

• To change the default operation of the Text tool, make su
that no objects are selected in the document.

• To change existing text objects, select the text objects.

4 Select the Vertical checkbox in the Type palette, and then cl
Apply to apply the current settings. Canvas applies the vertical 
option to the selected text objects, or to the Text tool.

When you set the Text tool to create vertical text, lines of text tha
you type are vertical, with text flowing from top to bottom and line
running from right to left. This is the same as the orientation of tex
within an existing text object when you apply the Vertical option. 

You can also create text objects with the same vertical text orient
tion using the Vertical Text tool.

◆ To change text orientation to horizontal in an object: Select 
a text object containing vertical text. In the Type palette, deselect
“Vertical” checkbox, and then click Apply.

Using vertical text in Publication layouts

To make it easy to create text layouts in Publication documents, 
choose the Column Guides command in the Layout menu, and cr
Setting preferences 9.11
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the number of column guides you want to use. Then, use the Ver
Text Object tool to click between column guides. This creates a te
column sized to fit the column guides. The column extends from t
point you click to the left margin of the page. If the column guides
are outside the printable area, the column text remains inside the
printable area. For more information, see “Vertical Text Object too
on page 9.13.

Vertical Text tool
The Vertical Text tool lets you type text in vertical columns that flo
from top to bottom and right to left. This makes it easy to create v
tical columns of text in languages that use vertical text, or when y
work on a publication in which text runs across a page.

When you type with the Vertical Text tool, the text characters flow
from top to bottom on screen; this looks the same as text created 
the Text tool and then rotated 90 degrees clockwise.

Note: If the Vertical Text tool isn’t available because the two-byte 
text preference isn’t selected, you can get the same effect by rota
text 90 degrees with the Rotate command in the Effects menu.

To create empty text objects, such as for a document template, to
contain vertical text, you can use the Vertical Text Object tool; se
“Vertical Text Object tool” on page 9.13.

To define a column for vertical text

1 Select the Vertical Text tool in the toolbox. The pointer 
changes to a horizontal I-beam. The horizontal I-beam indicates
that text will flow from top to bottom.

2 Drag the I-beam to set the size of the column, and then beg
typing. As you type, text characters run from top to bottom. Whe
the text reaches the bottom edge of the column, it wraps back to
top and onto the next line to the left.

3 To exit text-editing mode, press Esc.

To type vertical text directly

1 Select the Vertical Text tool in the toolbox. The pointer 
changes to a horizontal I-beam.

2 Click in the document to place the text insertion point, and th
begin typing. Because the text will flow from top to bottom, Canv
expands the bottom of the column to fit the longest line you type

Vertical Text tool
2 CUSTOMIZING CANVAS
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3 To exit text-editing mode, press Esc.

Vertical Text Object tool
The Vertical Text Object tool lets you create empty text blocks for
vertical text. Text objects created with the Vertical Text Object too
maintain their width and length. The tool is in the Text toolbar. 

To create text objects for vertical text

1 If necessary, select the “Enable two-byte script” preference.

2 Select the Vertical Text Object tool in the toolbox. The point
changes to a horizontal I-beam, which indicates that text in the t
object will flow from top to bottom.

3 Drag to define the width and length of the text object.You ca
then drag in other locations to create more text objects, or begin
typing in the new text object.

4 To exit text-editing mode, press Esc.

Preferences for two-byte text entry
The options on the Inline preferences tab let you specify whether 
want to always enter two-byte text directly into a document, or us
text-entry window when the apparent type size is outside a range 
you have set. This feature is available only when you are running 
tem software that supports two-byte fonts, and are using two-byte
fonts to enter text into a document. This preference does not affe
printing.

Using a low zoom level can make it difficult to see text as you typ
By using the text-entry window, you can see and edit text in the w
dow, regardless of the current view magnification level. 

To set inline text-entry preferences

1 Choose Preferences in the File menu.The Preferences dialo
box appears.

2 Click the Inline tab to bring it to the front.

3 Specify the following options, and then click OK to implemen
the current settings:

• If you always want to use a text-entry window, regardless
the size of the type, select the Never option.

Vertical Text Object tool
Setting preferences 9.13
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• If you want a text entry window to appear when you type
text at some apparent type sizes, select the “For text from
option. Type a number from 6 and 255 in each text box. 
These numbers set the range in which the text-entry wind
does not appear and you type directly into a document. 

A character’s apparent size is the size at which it appears on scre
based on the current view magnification level. For example, 12 po
type appears to be 12 points at 100%; at 200%, it appears to be 2
points; at 50%, it appears to be the size of 6 point type.

Using the text-entry window

If you choose the “For text from” option, and you type text in a doc
ment at an apparent point size that is outside the specified range
text-entry window appears at the bottom of the screen. You can t
and edit text directly in the window. To enter the text into the curre
document, press Return (Mac) or Enter (Windows).

If the apparent size of text changes because you change the view
magnification, actual point sizes that are beyond the specified “Fo
text from” range might not cause the text-entry window to open. I
this case, you can type the text directly into the document. 

Measurement units preferences
The Units tab lets you choose measurement settings, such as un
precision, and numerical format. Settings on this tab affect the un
displayed in the Strokes palette, the status bar of the Canvas wind
the measurements in dimension objects, and the precision of sett
in the Type palette.

Pen size units Choose inches, millimeters, points, or picas in the
pop-up menu to specify how you want to measure pen size in the 
tab of the Strokes palette.

Number form Set the precision and numerical format for numbe
in the status bar, the Type palette, Show Size display, and other 
numerical displays. You can choose whole integers, up to four-de
mal precision, or fractions. The setting you choose affects the me
surement precision only, and does not affect the drawing precisio

Virtual memory preferences (Mac)
The Virtual tab lets you choose a disk drive, and set other options
memory management. The memory management feature in Can
4 CUSTOMIZING CANVAS
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makes it possible to open images and files that require more mem
than the amount provided by physical RAM.

Disk Drive Choose a mounted hard disk in the pop-up menu. Ca
vas uses this disk for virtual memory. The amount of available sp
on the disk is shown below the pop-up menu.

Use available system memory Turning this option on instructs 
Canvas to use the allocated system memory first before resorting
its internal virtual memory.

Dynamic Disk Allocation Leave this option on to let Canvas claim
and release disk space as needed and available for particular file
you turn this option off, you can use the “Minimum disk space afte
allocation” text box to set a limit on how much space Canvas can
claim for virtual memory. For example, if you type 50 in the text bo
Canvas will leave at least 50 MB free on the disk.

User Info preferences
The User Info tab lets you specify a name and initials for object co
ments, which you can insert using the Comments command.

Name Type a name in the text box. When you attach a commen
an object, Canvas associates the name you enter with the comm
By default, Canvas uses the name entered when Canvas was 
installed.

Initials Type initials in the text box. When you attach comments 
an object, Canvas associates these initials with the comment.

Customizing the keyboard and Toolbar
With the Customize command, you can assign keyboard shortcut
commands, tools, attributes, object styles, and font styles. You ca
also place buttons for these items on the Toolbar at the top of the
screen. 

To select items to customize

1 Choose File > Customize. In the Customize dialog box, choo
items to customize. See “Choosing a category to customize,” ne

2 Use the procedures later in this section to customize keybo
shortcuts or place buttons on the Toolbar. When you finish cust
izing items, click Close to close the Customize dialog box.
Customizing the keyboard and Toolbar 9.15
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When you close the Customize dialog box, object styles you adde
the scrolling list will remain in the list. This lets you customize the
styles in any document. Outside of the Customize dialog box, obj
styles are available only in the document in which you create them

Choosing a category to customize

In the Category pop-up menu, you can choose which items you w
to assign shortcuts or add to the Toolbar.

Commands To select menu commands, choose Menus in the C
gory pop-up menu. In the Sub-Category pop-up menu, choose th
menu you want. The menu’s commands appear in the scrolling li

Tools To select tools, choose Tools in the Category pop-up men
The names of all tools and their icons appear in the scrolling list.

Attributes To select attributes, choose Inks or Strokes in the Ca
gory pop-up menu. Next to the scrolling list, a pop-up palette dis-
plays preset inks, or three pop-up palettes display pen strokes, 
dashes, and arrows. Select an ink or stroke from a palette. The it
you select appears in the scrolling list and as a button on the Too

To remove an ink or stroke from the scrolling list, select it and clic
the Remove Selection button; if the item is on the Toolbar, this 
removes it from the Toolbar also.

Styles To select styles, choose Object Styles in the Category po
up menu. The names of object styles appear in a pop-up menu b
the scrolling list. If no object styles have been created in Canvas,
pop-up menu will be empty.

Font Names and Sizes To select font attributes, choose Font 
Names and Sizes in the Category pop-up menu. A font size box 
appears. Select a size, then press the Add Size button. The font 
appears in the main scrolling list, and a font size button appears o
the Toolbar.

To choose a font, select a name from the pop-up menu. The font
appears on the scrolling list, and a font button appears on the Too

Inks pop-up palette Strokes pop-up palettes
6 CUSTOMIZING CANVAS
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To customize keyboard shortcuts

1 Select an item in the scrolling list in the Customize dialog bo
If the item has a keyboard shortcut, the Current Shortcut Key bo
shows the shortcut keys. 

2 To assign a keyboard shortcut, press the keyboard keys yo
want to use. The keys you type appear in the “Press New Short
Key” box. Click Assign to assign the new keys to the item. 

Certain keys are restricted, so pressing them will not display their
values. Other shortcuts are reserved by Canvas, so they can be 
assigned, but not applied to some procedures; for example, Ctrl+
Ctrl+2, and Ctrl+3 cannot be used in painting.

If the keys you type are assigned to another shortcut, the current
assignment appears under the “Press New Shortcut Key” box. 

You can’t assign single keys as shortcuts. For example, you can’
assign “H” or “F7” to an item.

• To remove shortcut keys from the selected item, click 
Remove.

• To restore the default shortcut keys to all commands, clic
Reset All.

• To restore the default shortcut keys to one command, se
the command in the scrolling list and click Reset. 

To assign shortcuts to inks

You can create shortcut keys for specific fill inks and pen inks. To
assign a shortcut key to a fill or pen ink, select the ink in the scroll
list in the Customize dialog box. Type the keyboard keys you wan
use. The keys you type appear in the “Press New Shortcut Key” b
Under the box, select whether you want the ink to be a Fill or Pen
ink. Click Assign to assign to the new keys to the ink.

To place buttons on the Toolbar

Select an item in the scrolling list in the Customize dialog box. Ink
Strokes, Object Styles, and Fonts appear on the Toolbar automa
cally when you add them to the scrolling list. For Menus and Tool
double-click the item in the scrolling list to add it to the Toolbar. A
button for the selected item appears on the Toolbar when it is dis
played.
Customizing the keyboard and Toolbar 9.17
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To remove an Ink, Stroke, Object Style, or Font button from the 
Toolbar, click the Remove Selection button under the scrolling lis
or double-click the item in the scrolling list. To remove a Menu or 
Tools button from the Toolbar, double-click the item in the scrollin
list.

Arranging buttons on the Toolbar

After you place buttons on the Toolbar using the Customize dialo
box, you can change their arrangement directly on the Toolbar. 

• To move a button, Shift-drag the button to a new location

• To remove a button from the Toolbar, press Shift and dra
the button away from the bar.

• To add a separator between Toolbar buttons, Shift-drag 
button on the right slightly to the right. A separator line 
appears between the button and the one to its left.

Using ink buttons

When you place buttons for inks on the Toolbar, you can use the
tons to apply fill inks and pen inks, or foreground colors and back
ground colors.

You can apply fill and pen inks to vector objects and text. You ca
select foreground and background colors for painting.

To apply a fill ink or select a background color for painting, click th
ink button on the Toolbar. If no objects are selected, the ink becom
the current fill ink or background color.

To apply a pen ink or select a foreground color for painting, press
Option (Mac) or Ctrl (Windows) and click the ink button. If no 
objects are selected, the ink becomes the current pen ink or fore-
ground color.

Saving and loading configurations

After you customize Canvas, you can save the current configurat
in a file. You can create other custom configurations and save the
in configuration files. You can load a configuration file to change t
Toolbar and the keyboard shortcuts.

A configuration file stores all the current keyboard shortcut assign
ments and the setup of buttons on the Toolbar.

Toolbar buttons
8 CUSTOMIZING CANVAS
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◆ To save the current configuration: Click Save Set. In the 
directory dialog box, type a file name, select a location, and click 
Save to save the file.

◆ To load a configuration: Click Load Set. In the directory dialog
box, select the configuration file and click OK.

Clearing customized settings

To clear all of the customized settings and Toolbar buttons, press
Clear All in the Customize dialog box. Canvas removes all of the 
customized settings from the scrolling list and all of the buttons fro
the Toolbar.

Customize dialog box
Use the options in the Customize dialog box to select items, and t
create keyboard shortcuts and place buttons on the Toolbar.

Category Choose the category of items to customize. The conte
of the scrolling list depend on the Category selection.

Sub-Category For commands, choose the menu containing the 
commands to customize. The commands in the selected menu ap
in the scrolling list.

Scrolling list Displays all tools or styles in the selected category o
subcategory (for commands). For inks and strokes, the list contai
the inks or strokes you select from the pop-up palettes.

Select an item in the scrolling list to assign a shortcut to it or to pla
a button for it on the Toolbar. The selected item is highlighted. 

Scrolling list
Customizing the keyboard and Toolbar 9.19
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Current Shortcut Key Displays the current keyboard shortcut for 
the selected item, if a shortcut exists.

Press New Shortcut Key With an item selected in the scrolling list,
press the keyboard keys you want to assign to the item. To use a
modifier key, press and hold Shift, Ctrl, Option, or Command (Ma
or Shift, Ctrl, or Alt (Windows). Press a letter, number, or function
key. The new shortcut keys appear in the box.

Assign Click to assign the keystrokes in the Press New Shortcut
Key box to the selected item. 

Remove Click to remove the current shortcut keystrokes from th
selected item.

Reset All Click to restore the default shortcut keys to all items.

Reset Click to restore the default shortcut keys to the item selec
in the scrolling list.

Palettes A pop-up palette appears when the Category selection 
Inks; three palettes appear when the Category is Strokes. Select 
ink or stroke from the palette. The selected item appears in the sc
ing list and on the Toolbar. 

Remove Selection When the Category selection is Inks, Strokes,
Object Styles, or Font Names and Sizes, click the Remove Selec
button to remove a selected item from the scrolling list. This also 
removes a button for the item from the Toolbar. 

Save Set Click Save Set to create a file of all current shortcut key
and Toolbar buttons. In the directory dialog box, type a name for 
file and click Save.

Load Set Click Load Set to import a file of shortcut keys and Too
bar buttons. In the directory dialog box, select the file to load and
click OK. Canvas resets the shortcut keys and the Toolbar accord
to the configuration stored in the file.

Clear All Click Clear All to clear all of the customized settings in 
the scrolling list and all of the buttons on the Toolbar.

Close Click to close the Customize dialog box. Inks or strokes 
added to the scrolling list remain in the list when you close the dia
box.
0 CUSTOMIZING CANVAS
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Saving document templates
You can use a special kind of Canvas document, called a templat
the basis for new documents. Canvas includes many ready-made
templates, and you can create your own template documents. Th
when you use the New command, you can select a template — e
one supplied with Canvas or one you have created — to create a
document based on the contents and configuration of the templat

A template document stores almost all preferences settings, as we
the settings you specify with the Document Setup command, and
other document setup options, including the following:

• Document type

• Configuration of layers, slides, pages, sheets and frames

• Settings for rulers, grids, guides, and views

• Current inks and strokes settings

• Text styles and default text settings

Canvas stores some settings with the application and not in partic
documents, so these settings are not included in a template docum
The settings that aren’t stored in a template include the position o
palettes on the screen and the current set of external tools. 

To save a template document 

1 Use the New command in the File menu to create a new Illu
tration, Presentation, Animation, or Publication document.

2 Use the Document Setup command in the Layout menu to 
select measurement units, document size and orientation, and, 
Publications, the margins and column layout.

3 Use the Preferences command in the File menu to set up p
erences for the document.

4 Create or import objects that you want to store in the templa

5 Choose Save As in the File menu. In the “File Format” (Mac
or “Save as type” (Windows) pop-up menu, choose Canvas Tem
plate and click Save.

For more information, see “Saving Canvas documents” on page 4

✔Tip
If you create a template with a 
small amount of type, such as 
for a letterhead, convert the 
type to paths so the template 
can be used without particular 
fonts being available.
Saving document templates 9.21
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WORKING WITH OBJECTS

This chapter explains how to work with objects in Canvas. It tells y
how to select objects with selection tools or the Find command. It
describes common actions, including how to copy, group, lock, 
move, arrange, flip, and align objects, plus effects you can apply 
all objects, including scaling, rotation, and skew. It also tells you h
to use the object position data in the Object Specs palette.

Types of objects
An object is a distinct item such as a circle, an image, or a paragr
of text. There are different types of objects with unique properties
and some commands apply only to some types of objects. But obj
in Canvas also share many properties. You can perform common
operations, including selecting, moving, rotating, copying, and de
ing, using the same methods for all types of objects.

The following object categories are used in Canvas:

Vector objects Geometric shapes such as lines, circles, rectangl
polygons, and smooth curves. Canvas defines them internally by
mulas, and they print smoothly on all printers.

Paint objects Rectangular containers for pixel-based images, su
as photos, screen captures, and scanned artwork. Each pixel tha
makes up an image has a color (or grayscale) value. 

Text objects Containers for text that can be formatted at the cha
acter and paragraph levels. Text objects can be empty or contain
to a page of text, and they can be linked together.

Group objects Collections of objects that have been united with 
the Group command. A group object can be made from more tha
one type of original object.

Selecting objects 

When you select an object, you distinguish it from other, unselect
objects, so that when you choose a command or apply a color, C
vas knows to apply it to the selected object. In most cases, you se
objects first, then apply a command or attribute. If you can’t apply
10.1
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attribute, or a command is not available, check to be sure you ha
correctly selected an object first.

Canvas provides several tools and commands for you to select 
objects. You can use the most convenient method for each situat
The Selection tools in the toolbox are the primary object-selection
tools. You can also use the Select All and Find commands to sele
objects. Refer to the table “Selection options” for a list of selection
tools and commands.

In some cases, you can select parts of objects. For example, you
select an anchor point within a vector object, a word within a text 
object, and an image area within a paint object. Selection techniq
for various types of objects are described in the drawing, text editi
and image editing sections of the manual.

Selection options

To select Do this

A single object Click the object with a Selection tool.

Multiple objects Shift-click each object with a Selection tool. Canvas for Windows users can 
also hold down the right mouse button while clicking objects with the left 
mouse button.

Objects using a selection box Drag a box around the objects with a Selection tool.

All objects touched by a selection 
box

With a selection tool, press Option (Mac) or Ctrl (Windows) and drag out a 
box that touches the objects.

One object within a group object Click the object with the Direct Selection tool (hollow arrow).

No objects (deselect all objects) Click a Selection tool in a blank area, or press Enter (Mac) or Esc (Windows).

All objects Choose Select All in the Edit menu.

An object behind another object Tab-click the object’s location until it is selected.

Unfilled object Click the object’s border, or press Tab and click inside the object.

An object on a layer other than the 
current layer, or an object on a master 
page

Tab-click the object with a Selection tool.

All objects created by a particular tool Select the tool, then choose Select All in the Edit menu.

Objects based on their attributes Use the Find command in the Edit menu.
.2 WORKING WITH OBJECTS
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◆ To select all objects: Choose Select All in the Edit menu. This
command selects every object in a single-layer document. To sel
all objects on all visible layers in a multi-layer document, change 
default selection setting in the Preferences dialog box; see “Gene
preferences,” page 9.1.

Selection indicators

Canvas indicates that an object is selected by displaying the obje
bounding box. The bounding box is a rectangle with solid squares
called handles, at each corner and side midpoint. When an objec
selected, its bounding box is visible even if it has attributes (the sa
color as the background, for example) that make the object itself 
invisible. Also, a selected object’s bounding box is visible even if i
covered by other objects.

When one object is selected, Canvas displays the object type at t
right end of the Status bar. When more than one object is selected
Status bar shows the number of selected objects.

Selecting objects with selection tools
The Selection tool (a filled arrow) selects any object you click. Th
Direct Selection tool (a hollow arrow) lets you select individual 
objects within a group object, without first ungrouping.

The Selection tool is the default tool when you start Canvas. Both
selection tools are in a toolbar at the top-left of the toolbox. If anot
tool was selected and you need to return to the Selection tool, clic
icon in the toolbox. 

◆ To select one or multiple objects: With the Selection tool, 
click an object. To select multiple objects, Shift-click each object y
want to select. For Windows only, you can also hold down the rig
mouse button and click multiple objects to select them.

With the Selection tool, you can drag a selection box around obje
to select them. Canvas selects all objects inside the selection box

Editing objects
All types of objects in Canvas can be easily modified. In general, y
place an object in edit mode when you want to modify it. 

Edit mode lets you use various features to edit each type of objec
For example, when a text object is in edit mode, you can use wor
processing features to select, cut, copy, paste, and edit text. Whe

A bounding box with handles 
surrounds a selected object

Selection tool

Direct Selection tool
Editing objects 10.3
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vector object is in edit mode, you can modify anchor points and s
ments to reshape its path. When a paint object is in edit mode, yo
can use painting tools and commands to modify the image it conta

Some other objects, including spirals, EasyShapes, objects that h
transparency masks, and SpriteEffects, have special editing mod
(besides their standard edit modes). For example, if you place a v
tor object in edit mode, you can edit the object’s path. If the objec
also has a transparency mask, you can edit its path in path edit m
or use the Sprite tool to edit its transparency mask in mask edit m

To place objects in edit mode

Do one of the following:

• Select an object and choose Object > Edit > Object to pla
it in object edit mode. To edit an object’s transparency 
mask, choose Object > Edit > Transparency.

• Double-click the object.

• Point to a selected object, open the context menu and 
choose Edit. If the object has a transparency mask, choo
Edit > Object to edit the object, or choose Edit > Transpa
ency to edit the mask.

• Point to an object that is not selected, open the context m
and choose the object’s name in the Edit submenu.

• For a vector object, select it and choose Object > Path >
Edit Path.

• For a text object, click in the text with the Text tool.

• For a paint object, select a painting tool and click the obje

• For an object with a transparency mask, click the object 
with the Sprite tool.

◆ To exit edit mode: Press Esc.

Selecting and editing objects with the context 
menu
You can use the context menu to select an object or place an obje
edit mode. Using the context menu can make it easier to select a
edit objects that are covered by other objects. 

To display the context menu, press Control and press the mouse
ton (Mac) or right-click the mouse (Windows).
.4 WORKING WITH OBJECTS
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◆ To select objects using the context menu: When no objects 
are selected or in edit mode, point to the object you want to selec
the object is hidden behind other objects, point to its location. Cho
Select > Object Name in the context menu. Canvas selects the obje
whose name you choose in the Select submenu. You can choose
vector, text, paint, or group object.

◆ To edit objects using the context menu: When no objects are 
selected or in edit mode, point to the object you want to edit. If the
object is hidden behind other objects, point to its location. Choose
Edit > Object Name in the context menu. Canvas places the object
whose name you choose in the Edit submenu into edit mode. You
select a vector, text, or paint object.
Editing objects 10.5
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Selecting objects based on their properties

You can use the Find com-
mand in the Edit menu to 
select objects by type and 
attributes, such as rectangles 
with red fill ink. 

In the Find palette, use the 
Objects tab to set up selection 
criteria.

A To select objects by type, 
check Type and choose an ob-
ject type icon in the pop-up 
menu. Selecting text or paint 
objects makes Fill, Stroke, and 
Pen options unavailable.

B To select objects by fill or 
pen ink, check these boxes and 
choose the inks in the pop-up 
menus. Only inks used in the 
document, plus process colors 
and white, appear in the menus.

To select objects by stroke, 
check Stroke and choose the 
stroke in the pop-up menu. 
Only strokes used in the docu-
ment appear in the menu.

To select objects by name, 
check Object Name. Type the 
name in the text box. Select 
“Object #” and type a number 
in the box to select an object 
by its number.

SpriteLayers: Use this option 
to select objects that have 
transparency effects.

SpriteEffects: Use this 
option to select objects 
(including lenses) that 
have SpriteEffects.

Lens Objects: Use this 
option to select objects 
that have been converted 
to lenses.

Search all visible layers: 
To select objects in the 
current layer only, 
uncheck this option.

Add to Selection: Check 
to select additional 
objects without deselect-
ing objects that are 
already selected.

Use Selected Object’s 
Attributes: When an object is 
selected, select this option to 
enter the object’s properties in 
the Objects tab.

Select: Click to select objects 
based on the current settings.

Next Page: Click to advance 
to the next page and continue 
searching.

Using selection sets

Click to expand the palette 
to work with selection sets, 
which let you broaden a 
search.

C Selection criteria symbols 
make up a selection set. The 
current selection set is boxed. 
Changing selection options up-
dates this selection set. Click a 
set to make it the current selec-
tion set.

Or: Click to create an empty 
selection set.

Copy: Click to duplicate the 
current selection set.

Clear: Click to delete the cur-
rent selection set. With only 
one set, Clear is unavailable.

A

C

B

.6 WORKING WITH OBJECTS
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Copying, cutting, pasting, and deleting objects
Once you select one or more objects, you can perform a variety o
basic editing functions. The following are the basic editing com-
mands in the Edit menu:

Using the Clipboard to copy objects

The Clipboard is a part of the system that temporarily stores sele
objects when you choose the Copy or Cut command. The Clipbo
stores the results of one editing action (which can include multiple
objects). Whatever is on the Clipboard is replaced by the next se
tion you place there, including a selection placed by using the Cu
Copy command in another application. 

• You can bypass the Clipboard by using the Duplicate com
mand to quickly copy a selected object in the same docu
ment without replacing the Clipboard contents.

• Using the Clear command or the Delete keyboard key do
not replace the contents of the Clipboard.

When you paste objects into other programs, the Clipboard uses 
format that the receiving program understands. However, special
types of objects and special object attributes can be lost when pas
objects into other applications. If you can’t transfer an object succ
fully using the Clipboard, consider using a compatible file format 
import the object as a file into other programs.

Using Cut, Copy, and Paste commands
The Cut, Copy, and Paste commands let you make copies of obj
using the Clipboard. You use Cut or Copy to place objects on the

Command Result

Copy Copies a selection to the Clipboard

Cut Removes a selection and places it on the Clipboard

Clear Removes a selection without changing the Clipboard

Duplicate Copies a selection into the same document without 
changing the Clipboard

Paste Places the Clipboard contents into the active document

Paste and Place Places the Clipboard contents into the active document 
with the upper-left corner at the point where you click

✔Tip
You can display the contents of 
the Clipboard (Mac OS only) by 
choosing Show Clipboard in 
the Palettes submenu in the 
Window menu. Choose Hide 
Clipboard to close the Clip-
board window.
Copying, cutting, pasting, and deleting objects 10.7



10

cu-
s.

opy. 
zed 
 Cut 

t.

doc-
 the 
n-
 
.

e 

as 
nu.

 into 
ter of 

py 
to 
ro-

as 
rd. 

s.
Clipboard, and then choose Paste to place copies in the same do
ment, other open Canvas documents, and also into other program

You select one or more Canvas objects before choosing Cut or C
You can select text objects, paint objects, vector objects, speciali
objects such as dimensions, and group objects. When you choose
or Copy, the selected items appear on the Clipboard. 

• The Cut command removes selections from the documen

• The Copy command leaves selections in the document.

Using the Paste command to insert the Clipboard contents into a 
ument does not erase the Clipboard. You can use Paste to insert
Clipboard contents as many times as you want. The Clipboard co
tents remain intact until you use the Copy or Cut command in any
application to replace the Clipboard contents with a new selection

To copy objects by pasting

1 Select the objects that you want to copy.

2 Choose Edit > Copy. Canvas puts the selected objects on th
Clipboard.

3 If you want to paste the copied selection into another docu-
ment, switch to that document. You can switch to an open Canv
document by choosing its name at the bottom of the Window me

4 Choose Edit > Paste. Canvas pastes the Clipboard contents
the active document. Pasted objects appear selected in the cen
the document window.

Options for copying objects
The Copy Options command lets you select formats when you co
objects to the Clipboard. This command is useful when you want 
copy a selection using a format that can be pasted into another p
gram

You can select the program you want to paste objects into. Canv
will select the best format for copying the selection to the Clipboa
You can select common programs, such as Microsoft Word and 
Adobe PageMaker.

These options have no effect when you paste selections in Canva
.8 WORKING WITH OBJECTS
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To use Copy Options

1 Select the items to copy and choose Edit > Copy Special > C
Options.

2 Select options (described next) in the dialog box.

3 Click OK and Canvas will copy the selection to the Clipboar

Configuring copy options

In the Copy Options dialog box, you can select a program or conf
ure the options yourself.

Preset For Choose a program name. This sets up the dialog box
objects will be copied in the best format for pasting into the select
program.

If the program you want to use is not listed, you can use the othe
options to select the format for copying objects to the Clipboard.

Copy vector object(s) Uses the standard format to copy objects t
the clipboard in Mac OS (PICT) and Windows (WMF). In most 
cases, this option is the same as using the standard Copy comm
PICT and WMF do not support transparency; transparent Canvas
objects are not rendered and will appear opaque when pasted int
other programs.

Copy as Image Copies objects to the Clipboard as rasterized 
images. Select a resolution option, or select Other and enter the 
desired resolution. This option preserves transparency effects am
Canvas objects. However, most programs do not support transpa
ency, so Canvas objects pasted into other programs will not appe
transparent relative to objects in the other programs.

Anti-Alias Softens the edges of objects copied to the Clipboard 
using anti-aliasing. Anti-Alias is available when you select Copy a
Image. Anti-aliasing slightly blurs objects to reduce the jagged 
appearance of object edges.

Embed Canvas native data (Mac only) Embeds unique Canvas 
data in objects. This ensures that objects keep their Canvas prope
if they’re pasted into another program and then pasted back into C
vas.

Embed EPS (Mac only) Copies objects to the Clipboard with Post
Script information. 

• Color Mode: Select the color mode to be used in the Pos
Script information.
Copying, cutting, pasting, and deleting objects 10.9
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• Transparency Rendering: Select a method for rendering 
SpriteLayer effects.

• Rendering Resolution: Select a standard resolution or ente
the desired resolution in the text box.

Apply settings to normal copy command Applies the dialog box 
settings to the Copy command. When you select this option, you 
don’t have to choose Edit > Copy Special > Copy Options to use 
same settings again.

Copying selections in objects
Besides using Cut or Copy to place entire objects on the Clipboa
you can use these commands to place selected parts of Canvas 
objects on the Clipboard, so you can copy a selection by pasting.

You can cut or copy the following parts of objects:

• text selections made by highlighting text in a text object

• image selections made by defining areas, ranges of colo
or loading alpha channels in a paint object

• segment selections made by selecting anchor points of v
tor objects in path edit mode

Pasting selections and pasting into objects
When you paste a selection, the result depends on whether an ob
is in edit mode at the time: 

• Pasting with no object in edit mode creates a new, separ
object containing the selection.

Using Paste doesn’t erase the
Clipboard; you can choose the
Paste command again to copy
the Clipboard contents as many
times as you want. However,
using the Copy or Cut command
in any application does replace
the Clipboard contents with a
new selection

Using Paste doesn’t erase the
Clipboard

Using Paste doesn’t erase the
Clipboard

A selection copied from an image (left) 
creates a selected object (right) when 
pasted into a document

A text object (bottom) 
results from pasting a 
copied text selection (top)

A selected vector object (top) 
results from pasting copied 
segments of a path

Vector object

Selected segments

Selection rectangle
.10 WORKING WITH OBJECTS
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• Pasting with an object in edit mode usually pastes the se
tion into the object.

For example, if you copy a highlighted text selection, and then 
choose Paste when no object is in edit mode, you create a new te
object containing only the text you selected. If you choose Paste 
when a text object is in edit mode, the pasted text appears at the i
tion point in the text object. If you choose Paste when a paint obje
is in edit mode, the selected text appears as a floating image sele
in the paint object.

Pasting into text You can paste text into a text object in edit mod
This lets you insert new text cut or copied from another object, an
move text from one place to another while editing a text object.

Pasting pixels into images You can paste an image selection into
paint object in edit mode. The pixels that you paste become a floa
selection in the paint object.

Pasting objects into images You can paste a vector object or text
into a paint object in edit mode. Canvas converts the object into p
els pasted as a floating selection in the paint object. In other word
Canvas rasterizes the Clipboard contents and then pastes an ima
selection into the paint object.

Placing objects while pasting

You can use the Paste and Place command to copy objects and 
tion the copies anywhere in a Canvas document.

1 Copy the objects that you want to paste.

2 Press Option (Mac) or Ctrl (Windows) and choose Edit > Pa
and Place. The Paste and Place command appears in the Edit m
only when you press the special key.

3 After choosing Paste and Place, a Place pointer appears. P
tion the pointer in the document where you want the top-left corn
of the Clipboard contents to appear. Do one of the following to 
paste the selection:

• Click to place the Clipboard contents at full size. 

• To set the dimensions of the Clipboard contents, drag to c
ate a bounding box to contain the selection.

Place pointer
Copying, cutting, pasting, and deleting objects 10.11
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Transferring object attributes
You can transfer attributes from one object to other objects using
Paste Attributes command. Transferring attributes can help you 
maintain consistency between objects.

You can transfer attributes from a source selection — an object o
text that has been copied to the Clipboard — to a target selection
which is one or more objects selected in the document. Or, you c
retain the source selection attributes as the current attributes — th
attributes that you can apply to new objects.

You can use Paste Attributes to transfer inks and stroke settings,
object dimensions, effects, and text attributes. 

To transfer attributes

1 Select an object or text whose attributes you want to transfer

• If you select multiple objects, only the dimensions of a rec
angle encompassing all the objects will be available. 

• If you select a group object, only attributes that apply to th
entire group, including the bounding box size and transform
tions applied to the group object, will be available.

• If you select a text object, only the attributes common to th
entire object will be available.

2 Choose Edit > Copy to place the selection on the Clipboard.

3 Select the one or more target objects to receive the attributes
no objects are selected, the source attributes will be retained as t
current attributes and can be applied to new objects.

4 Choose Edit > Paste Attributes. In the Paste Attributes dialog
box, select the attributes to paste. Options that appear dimmed w
not available in the source selection or cannot be applied to the ta
selection.

5 Click OK to paste the attributes and close the dialog box.
.12 WORKING WITH OBJECTS
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Paste Attributes options

Depending on the source selection and the target selection, you c
choose options listed in the Paste Attributes dialog box. 

An option is available if the attribute was copied from the source 
selection and can be applied to the selected target objects. The e
tion to this rule is the Text Style option. The Text Style option is 
available whenever the source selection is text, even if the target
objects are not. In this case, no Text Style attributes will be applie
the target selection, but the Text Style attributes will be retained a
the current attributes and can be applied to new text objects.

Fill ink Transfers the source selection’s fill ink. You can transfer f
inks if the source selection is a vector object or text that has a fill i
and the target objects are vector or text objects. If no target is 
selected, the source fill ink becomes the current fill ink. 

Pen ink Transfers the source selection’s pen ink. You can transf
pen inks if the source selection is a vector object or text that has a
ink, and the target objects are vector or text objects. If no target is
selected, the source pen ink becomes the current pen ink. 

Stroke Transfers the source selection’s stroke, including pen, da
and arrow attributes. You can transfer strokes if the source selec
is a vector object or text that has a stroke, and the target objects 
vector or text objects. If no target is selected, the source stroke 
becomes the current stroke.

Dimensions Transfers the dimensions of a rectangle “bounding 
box” that encompasses the source selection. You can transfer bo
ing box dimensions from any source object to any selected objec
but not to text selected within a text object. This makes all target 
objects the same size as the source.

Vector object Text object Attributes pasted on text object
Copying, cutting, pasting, and deleting objects 10.13
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If the source object has been rotated or skewed, you can transfer
original dimensions by selecting Dimensions. To transfer its trans
formed dimensions, select Transform.

Transform Transfers rotation and skewing applied to the source 
selection’s bounding box. You can transfer these effects to any 
selected objects.

Transparency Transfers the transparency effects applied to the 
source selection. 

Text Style Transfers the following text attributes from a text sourc
selection to a text target selection: font, type size, text style (bold,
italic, and so on), leading, kerning, and justification. You can trans
text attributes when a particular attribute is uniform in the source 
selection. For example, if different kerning values are applied to 
characters in the source text, kerning will not be available for trans
to the target text. If no target text is selected, the source text attrib
become the current text attributes.

Sprite Effects Transfers filters and adjustments that have been 
applied with the SpriteEffects palette or Add effect command, from
the source to the target objects.

Special copy commands
Several commands let you perform special operations for copying
objects to the Clipboard. 

These commands are: 

• Copy With EPS (Mac only)

• Copy As Image

• Copy at 4X

• Copy at 8X

Copy With EPS

Use the Copy With EPS command in the Edit menu to include 
Encapsulated PostScript (EPS) information when you copy an ob
to the Clipboard. 

Including PostScript information can enhance the quality of illustr
tions. 

For example, when you paste an illustration generated in Canvas
from the Clipboard into documents created in other applications, 
.14 WORKING WITH OBJECTS
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such as Microsoft Word and Adobe FrameMaker, the EPS inform
tion will improve the quality of the illustration.

The Copy With EPS command is available on Mac OS only.

To copy objects with EPS information

1 Select the objects to copy.

2 choose Edit > Copy Special > Copy with EPS. 

Canvas places the selected objects on the Clipboard and include
PostScript formatting information.

Copy as Image

When you want to copy an object, and then paste it into a docum
created in another application, you can use the Copy as Image co
mand to enhance the printed appearance of the Canvas object yo
intend to paste. 

This procedure can smooth out jagged edges and help maintain 
object’s details. 

◆ To use the Copy as Image command: Select the objects you 
want to copy, and then choose Edit > Copy Special > Copy as Ima
When you choose Edit > Copy Special > Copy as Image, Canvas
places the selected objects on the Clipboard. You can then use 
another application’s Paste command to place the Clipboard cont
into a document. 

Copy at 4X, Copy at 8X

You can use the Copy at 4X command or the Copy at 8X comma
to place vector objects on the Clipboard as rasterized objects at s
cific resolution levels. You might want to do this if you are pasting
Canvas vector objects into another program and the objects appe
jagged when printed. This can happen when a program prints Can
vector objects at the low resolution of the screen display.

The Copy at 4X and Copy at 8X commands place selected object
the Clipboard at specific resolution levels: “4X” indicates resolutio
4 times greater than screen resolution and “8X” indicates resolutio
times greater than screen resolution. 4X approximates the resolu
of a 300 dpi printer; 8X approximates the resolution of a 600 dpi 
printer. Choose the resolution level based on the printing device y
are going to use. 
Special copy commands 10.15
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When copying and pasting within Canvas documents, these com
mands perform the same function as the standard Copy comman
Using these commands is not recommended for copying paint 
objects, which are already rasterized at a specific resolution.

◆ To copy vector objects at increased resolution: Select the 
objects to copy and choose Edit > Copy Special > Copy At 4X or 
Edit > Copy Special > Copy at 8X. Canvas places the selected 
objects on the Clipboard. You can then paste the Clipboard conte
into other applications. 

Creating links when pasting on Windows
With Canvas for Windows, you can use the Clipboard to place 
objects into other documents and create links to Canvas as the so
application. The Paste command creates a link between a pasted
object and the application that created it, using Object Linking an
Embedding (OLE), a technology built into the Windows operating
system.

Making multiple copies
You can use the Copy and Paste commands to make multiple co
of selected objects through the Clipboard. If you want more contr
over placement, number of copies, scaling or rotation, you can us
the Duplicate and Replicate commands to make multiple copies.

• With a selection on the Clipboard, choose Paste to insert 
selection in the center of the active document’s current 
view. Repeat the Paste command to make multiple copie

• The Duplicate command copies selections immediately a
lets you space copies evenly. The Replicate command le
you scale, rotate, and offset multiple copies.

Duplicating selections
The Duplicate command quickly copies selected objects into the 
same document, without affecting the contents of the Clipboard.

◆ To copy objects into the same document: Select the objects 
you want to copy and choose Edit > Duplicate. Canvas creates, o
sets, and stacks a copy of the selection in front of the original. To
make additional copies, choose Edit > Duplicate again.

The Duplicate command offsets copies a preset distance horizon
and vertically from the original. You can move the copy (without 
.16 WORKING WITH OBJECTS
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deselecting it) to adjust the offset distance and direction and then
repeat the Duplicate command to make more evenly-spaced cop

You can change the Duplicate command’s preset offset values; s
“When duplicating objects offset” on page 9.4.

To duplicate and space copies evenly

1 Select one or more vector, text, paint, or group objects to co

2 Choose Edit > Duplicate. Canvas duplicates the selection a
offsets the copy a preset distance from the original.

3 The copy must remain selected as you drag it or use the ke
board arrow keys to move it into position. The new position esta
lishes the offset distance and direction from the original selectio

4 Choose Edit > Duplicate again. Canvas creates the next co
using the offset defined from the original selection to the first cop
Repeat this step to create additional evenly-spaced copies.

Duplicating objects with the mouse

You can duplicate an object by pressing a modifier key as you dr
the object. When an object is selected, you can press a modifier 
to duplicate and resize it as you drag a handle. In Freeform mode
you can press a modifier key to duplicate while rotating or skewin
an object. 

◆ To duplicate objects by dragging: Select the objects you want
to duplicate. Press Option (Mac) or Ctrl (Windows) as you drag th
objects. 

◆ To make multiple copies while dragging: Select the objects 
you want to duplicate. Press Option+Command (Mac) or Ctrl+Alt
(Windows) as you drag the objects.

To duplicate while resizing

1 Select an object to duplicate. 

2 Begin to drag a handle on the object’s bounding box to the s
you want the duplicate to be.

3 As you drag, press and hold Option (Mac) or Ctrl (Windows
When you release the mouse button and the modifier key, the d
cate object appears in front of the original.

Duplicated objects are offset a 
preset amount (gray circles). By 
moving the first copy and 
repeating Duplicate, you can 
set a custom offset distance 
and direction (orange circles).

Original 
1

2

3

1

2

3

1st duplicate

Original 

2nd duplicate

Canvas offsets and stacks 
duplicates, placing the new-
est copy in front of the stack.
Making multiple copies 10.17
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To duplicate while rotating or skewing

1 Select an object and choose Effects > Freeform to put the 
object in Freeform mode. 

2 Point to a handle and press Option (Mac) or Ctrl (Windows) 
you drag the handle. 

• To rotate the object, drag one of the four corner handles.

• To skew the object horizontally, drag a horizontal skew 
handle to the left or right. To skew vertically, drag a vertic
skew handle up or down. 

The duplicated object rotates or skews depending on which hand
you drag. You cannot rotate and skew the object at the same tim
When you release the mouse button, the duplicate object is in fron
the original.

Creating multiple duplicates

After you duplicate an object using a modifier key, you can make
more copies with the same offset distance, angle of rotation, or sk
factor.

With a duplicated object still selected, choose Edit > Duplicate. C
vas creates another duplicate and applies the same offset distanc
angle of rotation, or skew factor.

Scaling, rotating, and offsetting copies
The Replicate command offers powerful capabilities for duplicatin
objects. You can use the Replicate dialog box to set the number 
copies and to rotate, scale, and position copies with one comman

To replicate a selection

1 Select one or more objects to copy and choose Edit > Repli
cate. 

2 In the Replicate dialog box, specify the number of copies. 
Enter the scaling, rotation, and offset values you want to apply. F
information on these settings, see “Options in the Replicate dial
box” on page 10.19.

• To preview the replication, click Apply. Canvas draws the
copies and the dialog box stays open. You can change s
tings and click Apply to preview the new settings.
.18 WORKING WITH OBJECTS
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• To cancel the replication, click Cancel. Canvas closes th
Replicate dialog box and erases preview copies.

3 Click OK to copy the selection and close the Replicate dialo
box. The original object is deselected and the copies are selecte

Grouping and ungrouping objects
You can use the Group command to unite objects that you want t
keep together as one unit. You can group individual objects as we
already-grouped objects. When you no longer want to keep a gro

Options in the Replicate dialog box 

The Replicate dialog box lets 
you rotate, scale, and dupli-
cate selected objects.

Copies. Enter the number of 
objects you want to create.

Rotate. To rotate each copy 
relative to the preceding 
object, select Rotate. Type the 
rotation amount from (minus) 
-359.0 to 359.0 degrees. The 
center of rotation is shown in 
the “Around” box by a hollow 
handle; click to select another 
handle as the rotation center.

Scale by. To incrementally 
change the size of each copy, 
select Scale by. In the pop-up 
menu, choose Percentage, 
Length, or Ratio. In the text 
boxes, enter horizontal ( ) 
and vertical ( ) scaling factors. 

Percentage scales each copy by 
the specified percentages of 
the proceeding object’s 
dimensions. Enter whole num-
bers from 1% to 999%.

Ratio lets you resize copies by 
fractional amounts. Canvas 
scales each copy to ratios of 
the previous object’s horizon-
tal and vertical dimensions.

Type ratios with whole num-
bers from 1 to 999. The left 
number represents the copy; 
the right number represents 
the previous object. A 1/1 
ratio maintains dimensions; 1/2 
halves dimensions; 2/1 dou-
bles dimensions. 

Length increases or decreases 
by a fixed amount each copy 
of the object using the values 
in the horizontal and vertical 
text boxes.

Proportional. If selected, Can-
vas makes the vertical value in 
the Scale by or Offset area 
equal to the horizontal value.

Offset. Check this option to 
place copies a specified dis-
tance from the previous object. 
In the text boxes, enter the 
horizontal and vertical offset 
distance. Positive numbers off-
set copies up and right; nega-
tive numbers offset objects 
down and left.

Object data. Displays the 
selection’s height and width. 
These values can’t be edited.
Grouping and ungrouping objects 10.19
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together, you can separate the original objects with the Ungroup 
command.

◆ To group objects: Select the objects that you want to group. 
Choose Object > Group. Canvas replaces the bounding boxes of
individual objects with a single bounding box. 

◆ To ungroup objects: Select one or more grouped objects that
you want to separate. Choose Object > Ungroup. Canvas separa
the group and leaves the individual objects selected. If any of the
objects are group objects, you can further ungroup them by choo
Object > Ungroup again.

When you apply a command to a group object, the effect in most
cases is the same as if you applied the command to each object i
group individually.

Grouping and stacking order

Grouping objects can change the stacking order of the objects rela
to objects outside the group. 

For example, you have three overlapping objects. If you group th
front and back objects, the group moves to the back and the midd
(not grouped) object becomes the frontmost object.

Moving objects
You can move objects by dragging them, by using the keyboard 
arrow keys, and by using the Transform palette. You can also use
Move command to specify a position change, and the Object Spe
palette to specify exact coordinates.

When you drag an object, the Status bar shows the change in the
object’s x- and y-coordinate position. You can specify the format a
precision of this data in the Preferences dialog box.

You can make precise positioning easier by turning on the autogr
so that objects you drag snap to preset ruler increments. You can
place alignment guides that objects will snap to in a document.

✔Tip
After you group objects, you 
can select individual objects in 
the group with the Direct 
Selection tool.

The black square is 
behind the gray 
triangle, which is 
behind the orange 
circle in the stacking 
order

After selecting the square 
and circle and grouping 
them, the group goes 
behind the triangle 
in the stacking order
.20 WORKING WITH OBJECTS
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◆ To move an object using the Selection tool: Position the 
pointer on the object and drag. If you drag as soon as you press 
mouse button, an outline of the object follows the pointer. To see 
entire object as you drag, pause after you press the mouse button
then drag.

You can press modifier keys as you drag objects to constrain mo
ments and perform other functions.

◆ Moving objects using the keyboard: To move objects left, 
right, up, or down, press the corresponding arrow key. You can u
the modifier keys shown in the following table to move greater dis
tances.

You can change the default distances that keyboard keys move 
objects; see “When moving objects offset” on page 9.4.

Moving objects a specified distance
Use the Move command to specify distance and direction.

1 Select the objects you want to move and then choose Objec
Move.

To Do this

Constrain movement to 45 
degree increments

Press Shift while dragging

Copy objects by dragging Mac: Press Option while dragging

Windows: Press Alt while dragging

Leave a trail of object copies Mac: Press Command + Option while 
dragging

Windows: Press Ctrl + Alt while dragging

To move objects Do this

1 pixel to the left, right, up or 
down

Press left, right, up or down keyboard 
arrow key

10 pixels to the left, right, up or 
down

Mac: Press Option and an arrow key

Windows: Press Alt and an arrow key

50 pixels to the left, right, up or 
down

Mac: Press Command and an arrow key

Windows: Press Ctrl and an arrow key
Moving objects 10.21
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2 In the Move dialog box, enter values in the first or second ro
of text boxes. Use negative numbers to move up and to the left. 
positive numbers to move down and to the right.

3 Click Apply to preview or OK to implement the Move setting

Arranging objects in the stacking order
Each object in a Canvas document is part of a stack of objects on
same layer. Each object has a position in the stack. Unless you r
range objects, the newest object is in front of the stack and the ol
object is in the back. An object that you create or paste appears a
front of the stack. 

Stacking order affects the appearance of objects when you view 
print them. Like actual objects placed in a stack, the front object i
the stack blocks objects behind it. An object’s position in the stac
also is a factor in alignment and combining operations. 

Commands in the Arrange submenu in the Object menu let you 
change an object’s position in the stack. You can move objects to
front or back, and you can move objects one level at a time towar
the front or back of the stack.

◆ To change an object’s position in the stack: Select the object 
and choose a command in the Object > Arrange submenu.

Command Result

Bring to Front Moves selected objects to the front of the stack

Send to Back Moves selected objects to the back of the stack

Shuffle Up Moves selected objects one step toward the front 

Shuffle Down Moves selected objects one step toward the back

Up/down value

Distance value

Left/right value

Angle value

✔Tip
You can specify angular move-
ment in 0.01 degree incre-
ments. The movement direction 
depends on the Coordinate 
System setting in the Preferenc-
es dialog box; see “Coordinate 
System” on page 9.3.
.22 WORKING WITH OBJECTS
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Arranging objects on layers and pages
Commands in the Arrange submenu in the Object menu let you m
and copy selected objects to other layers on the same page and t
ers on other pages.

To send or copy objects to another location

1 Select the objects, and then do one of the following:

• Choose Object > Arrange > Send to Layers to move objec
to new locations.

• Choose Object > Arrange > Copy to Layers to copy objects
new locations.

2 In the Layer Select dialog box, click one or more layers to des
nate them as the destination for the selected objects.

3 Click Select. Canvas copies or moves the selected objects to
destination layer or layers.

Note: The destination layer for the objects cannot be locked.

Locking and unlocking objects
When you want to secure objects from unintentional changes, yo
can lock them. Once an object is locked, it can only be selected b
Tab>clicking the object. However, if the “Canvas 6-style object loc
ing” option in the Preferences dialog box is selected, you can sele
locked objects by clicking on them. Locked objects can be copied
and the copies won’t be locked.

To lock or unlock objects:

Select the object(s) that you want to lock or unlock. Choose Objec
Lock or Object > Unlock (Unlock All, if no objects are selected). 

How commands affect locked objects

If you apply the Align command to several selected objects, and o
object is locked, the other objects align to the locked object. 

If you group several objects and one of the objects is locked, all t
objects are positioned behind the locked object in the stacking or

Aligning and distributing objects 

You can use the Align submenu and the Align palette to quickly a
precisely position objects. 
Arranging objects on layers and pages 10.23
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Using the Align submenu

The Align submenu lets you quickly align selected objects. The s
menu includes these common alignment commands: Top, Left, B
tom, Right, Center, Center Vertical, and Center Horizontal. 

The Align submenu is in the Object menu, and is also available in
context menu when multiple objects are selected. The submenu 
includes the Show Palette command, which displays the Align pa
ette.

To use the Align submenu, select two or more objects. Choose 
Object > Align and choose an alignment option. Or, open the cont
menu and choose an alignment option.

Using the Align palette

The Align palette is a floating palette that provides additional align
ment and distribution options. The palette can stay on screen as 
work, making it easy to access alignment features.

You can apply alignment and distribution options to vector object
group objects, paint objects, and text objects. You can align and 
tribute objects in separate or combined operations. As the referen
point for alignment and distribution, you can choose points on the
objects or the document. 

Aligning objects When aligning objects, Canvas lines up key 
points on the objects in relation to the reference point you choose
You can choose left, right, top, bottom, or center alignment.

Distributing objects When distributing objects, Canvas spreads 
them out over a specified area and equalizes the space between
key points. You can choose left, right, top, bottom, inside, outside
center as methods for distribution. For example, if you choose lef
edges for distribution, the left-most point in each object is an equa
distance from the leftmost point in each of its neighbors. 

If one of the objects you select for alignment is locked, other obje
align relative to it. When distributing objects, Canvas places all 
objects relative to each other.
.24 WORKING WITH OBJECTS
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Rotating, skewing, and flipping objects
You can rotate Canvas objects clockwise or counter-clockwise, fl
them on one or both axes, and skew their bounding boxes. You c
rotate and skew around an object’s center, or move the centerpoi
any location.

When you rotate an object, the object’s bounding box also rotates
you drag a selection handle of a rotated object, the bounding box
changes shape in the rotated orientation, so you can resize an ob
without distorting its basic shape. If you need to, you can also ret
the rotated bounding box to its original orientation by choosing 
Object > Paths > Convert To Paths.

Align palette

Choose Object > Align > Show 
Palette to open the palette. 
Select the objects you want to 
arrange. Click Apply to imple-
ment the current settings.

Align to: Choose the refer-
ence for alignment and distri-
bution: 

Each Other: With respect to 
the other selected objects.

Grid: To the nearest grid incre-
ment.

Printable Area: With respect 
to the printer page or tile.

Document: To a specified 
location in the document. If 
you center an object in a multi-
page illustration, portions can 
appear on multiple tiles.

In the Vertical and Horizontal 
areas, click buttons for align-
ment and distribution options. 
Active buttons are recessed. 

You can select an alignment or 
distribution option, but not 
both, in each area. 

A For no change in position, 
click the first button in either the 
Vertical or Horizontal area.

Vertical Align. (Left to right) 
None, top, center, and bot-
tom.

Vertical Distribute. Inside, 
top, center, and bottom.

Horizontal Align. None, left, 
center, and right.

Horizontal Distribute. Inside, 
left, center, and right.

Outside Pen. Check this 
option to use the outside edge 
of objects’ strokes when align-
ing or distributing objects. 
Otherwise, Canvas uses the 
center of the stroke.

A

AAlign to Each Other

Align to 
Page

Align to Grid
Rotating, skewing, and flipping objects 10.25
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◆ Removing effects: After you rotate, skew, or flip objects, you 
can return them to their original orientation and shape. Select the
objects and choose Effects > Remove Effects.

Rotating and skewing in freeform mode
When you put an object in freeform mode, you can rotate and ske
by dragging special handles.

◆ To put an object in freeform mode: Select the object and 
choose Effects > Freeform. Rotation and skewing handles and th
object’s centerpoint appear.

You can also put a selected object in freeform mode by clicking it
This depends on a setting in the Preferences dialog box; see “Gen
preferences” on page 9.1.

◆ To end freeform mode: Click away from the object, or press 
Enter (Mac) or Esc (Windows).

Rotating objects in freeform mode

In freeform mode, the circular handles at each corner of the bound
box are rotation handles. The circle and crosshair in the center of
object is the point around which the object rotates.

◆ To rotate an object in freeform mode: Drag one of the four 
corner handles. An outline of the object rotates as you drag a han

◆ To set the center of rotation: Drag the centerpoint to a new 
location anywhere on the screen. To make the centerpoint snap to
of the handles or the center, press Shift as you drag.

Skewing objects in freeform mode

When an object is in freeform mode, you can slant its shape by d
ging the horizontal and vertical skew handles. Skewing an object

Freeform mode
A Vertical skew handle
B Horizontal skew handle
C Rotation handle
D Rotation center

A

B

C

D

.26 WORKING WITH OBJECTS
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reshapes it by changing the relationship of the horizontal and vert
axes to the skew centerpoint.

Canvas skews objects around a centerpoint that you can position
achieve the effect you want. You can drag the centerpoint to any 
position inside or outside the object. The location of the skew cen
point changes the effect of dragging a skew handle on the object

To position the centerpoint on one of the freeform handles or in th
center of the object, Shift-drag the centerpoint to place it.

◆ To skew an object horizontally: Drag a horizontal skew handle
to the left or right. 

◆ To skew vertically: Drag a vertical skew handle up or down.

Freeform editing of floating image selections
Use the Freeform command to place floating image selections in 
freeform edit mode. When you put an image selection in freeform
mode, you can rotate and skew it by dragging special handles. 

To float a copy of a selection

1 With a paint object in edit mode, make a selection with the 
Marquee or Lasso tool. The selection can encompass the entire
paint object.

2 Do one of the following:

• Choose Image > Select > Float.

• Option-drag (Mac) or Ctrl-drag (Windows) the selection. 
This moves the selection and puts it in freeform mode.

You can also paste an object into an image in edit mode. The obj
pastes into the image as a floating selection.

For more information on image selections see, “Working with ima
selections” on page 26.9.
Rotating, skewing, and flipping objects 10.27
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◆ To put a floating image selection in freeform mode: While a 
floating image selection is active, choose Effects > Freeform. Han
dles appear on the corners and sides of the floating selection.

◆ To move a selection in freeform mode. Place the pointer 
inside of the selection. The pointer becomes an arrow head. Drag
move an outline of the selection.

Rotating selections in freeform mode

In freeform mode, while the pointer is outside of the selection, the
pointer is a curved line with an arrow at both ends. This is the rota
tion pointer.

Drag around the selection in the direction you want it to rotate. An
outline of the selection rotates as you drag.

• Press the Shift key to constrain the rotation to 15-degree
increments.

Scaling selections in freeform mode

You can scale a floating selection in freeform mode by dragging t
corner or side handles. 

◆ To scale a selection: Point to one of the handles at the edges 
the selection. The pointer changes to a straight line with an arrow
each end. Drag any of the handles. The selection scales as you d

• If you drag a side handle, the scaling is constrained to th
direction of the arrows in the pointer – the direction perpe
dicular to the handle side.

• If you drag a corner handle, the scaling is unconstrained 
unless you press the Shift key.

Rotation pointer
Scale pointer
.28 WORKING WITH OBJECTS
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• Press the Command key (Mac) or the Alt key (Windows) 
mirror the scale on the opposite side of the selection.

Skewing selections in freeform mode

When a selection is in freeform mode, you can slant its shape by
dragging the side handles with the Ctrl key pressed. Skewing a s
tion reshapes it by changing the relationship of the sides of the se
tion.

◆ To skew a selection: Press the Ctrl key and move the pointer 
over one of the side handles. The pointer changes to an arrow he
Drag the handle to skew the selection freely.

• Press the Shift key to constrain the skew along the axis o
the handle side.

• Press Command (Mac) or Alt (Windows) to have the opp
site side of the selection skew to maintain its relationship
the side you are skewing around the center of the selecti

The modifier keys can be combined to produce both skewing effe
simultaneously.

◆ To end freeform editing: Double-click inside the selection or 
press Enter twice. The floating selection is still active. Then doub
click outside the paint object or press Enter twice to paste the pix
as defined by the floating selection into the image. 

If you do not want to change your original image, press Esc to lea
freeform mode. Canvas makes no changes to the image.

Rotating objects with the Rotate command
For precise rotations, you can use the Rotate command to rotate
selected objects in 0.01 degree increments around a center of rot
you specify. This command is useful when you need to rotate mu
ple objects an exact amount.

1 Select the object you want to rotate.

2 Choose Effects > Rotate.

Skew pointer

Skew outline

Center of rotation edit box
Clockwise and counter-clockwise 
rotation buttons
Rotating, skewing, and flipping objects 10.29
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3 In the Rotate dialog box, click the clockwise or counter-cloc
wise button to choose a rotation direction.

4 Enter the rotation angle in degrees in the Angle text box.

5 The Center edit box shows the center of rotation as a gray h
dle. To change it, click one of the black handles on the boundin
box; the gray handle snaps to the new location.

6 Click Apply to preview the settings, or click OK to implemen
the settings and close the dialog box.

Editing rotated objects 

When you rotate an object, the object’s bounding box also rotates
you can reshape and resize the object in rotated space. If you dra
handle, the object’s sides keep their rotated orientation. This prev
distortion of the original shape.

Flipping objects
You can flip objects horizontally, vertically, and both horizontally 
and vertically, with the Flip commands in the Effects menu. You c
flip individual objects, multiple selected objects, or grouped objec
When you flip a group object, objects included in the group flip 
around the axes of the group’s bounding box.

The bounding box of a 
rotated square has the 
same orientation as the 
rotated object...

... so the object 
maintains its 
rectangular shape, 
shown by the dotted 
lines, when you drag 
the bounding box 
handles.

If you choose 
Convert to Paths, 
Canvas re-orients the 
bounding box of a 
rotated object...

... so the object’s 
rectangular shape 
distorts when you 
drag a handle on the 
bounding box, as 
shown by the dotted 
lines.

Rotated bounding box Unrotated bounding box
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◆ To flip a selected object from top to bottom: Choose
Effects > Flip > Vertical. The Vertical command flips the selection
vertical coordinates over its horizontal axis.

◆ To flip a selected object from left to right: Choose Effects > 
Flip > Horizontal. The Horizontal command flips the selection’s ho
izontal coordinates over its vertical axis.

◆ To flip a selection around both axes: Choose Effects > Flip > 
Both Axes. Canvas flips the selection’s horizontal coordinates ov
its vertical axis and its vertical coordinates over its horizontal axis

Scaling objects
The Scale command in the Object menu provides several options
enlarging or reducing objects. You can scale by a percentage or r
horizontally and vertically. You can also scale text and stroke 
weights when you scale objects.

To scale an object

1 Select one or more objects and choose Object > Scale to op
the Scale dialog box.

2 Select a scaling method in the Scale By pop-up menu. The c
figuration of the dialog box depends on which option you choos

Flip > Horizontal Flip > Vertical Flip > Both AxesOriginal

Depending on the Scale by 
method you choose, the Scale 
dialog box displays different 
options.
Scaling objects 10.31
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Percentage You can specify vertical and horizontal percentages
Scaling an object 150 percent is the same as increasing the obje
size by a factor of 1.5, for example.

Ratio You can specify horizontal and vertical scaling factors as 
ratios by entering numbers in each set of two boxes.

For example, to scale an object to one-third its original height, en
“1” in the first text box, and “3” in the second. 

3 To scale an object vertically and horizontally by the same 
amount, turn Proportional on.

4 To maintain the proportion between an object’s pen size an
the overall size of the object, turn Scale Pen on.

5 If one of the selected objects contains text, you can turn Sc
Text on to change the size of the characters. Otherwise, text 
remains the same size.

6 Click Apply to implement the settings.

7 Click OK to scale the object.

Using the Object Specs palette
The Object Specs palette provides several important features for
working with objects. 

The Object Specs palette displays data for selected objects and l
you modify settings for selected objects. It also lets you create obj
by specifying size, position, and object type. 

The Object Specs palette contains tabs labeled Data, Info, Trap, 
Style. 

• The Data tab lets you create objects, and edit the size, po
tion, and other data for a selected object. 

• The Style tab lets you create, modify, and apply object sty

• The Trap tab lets you set printing options, including over-
printing and trapping for color separations. 

• The Info tab lets you control the attributes (inks, pen strok
dash, arrow, opacity, and transfer mode) of a selected 
object.

✔Tip
You can also scale an entire 
document when you print it, 
without changing the objects in 
the document, by specifying a 
scaling factor in the Print dialog 
box.
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To display the Object Specs palette

Choose Object > Object Specs. The palette can remain open wh
you work. You can change coordinates, dimensions, or other setti
and then click Apply to implement them. 

To create an object

1 On the Data tab, choose an object type from the Object Type
palette. You can create rectangles, ovals, arcs, polygons, and lin

2 Enter values for the object’s size and position in the text boxe
The type of data you can enter depends on the object type. 

3 Click Create to create the object.

Editing object data

You can use the Data tab to create objects, and to view and edit 
for selected objects.

The Data tab displays information for a selected object or group 
object. If you select a group object, you can change the group’s s
and coordinates, but not an individual object within the group.

When more than one object is selected, the boxes on the Data ta
not available, because you can’t edit the position or dimensions o
multiple selected objects.

After you edit the values on the Data tab, click Apply to apply the
changes to the selected object.

Data display options

You can choose the type of data to display on the Data tab. You 
choose Height/Width or Top/Bottom for all objects except lines. F
lines, you can choose Start/End, Delta V/H, or Length/Angle.

Height/Width Type values in the text boxes to specify the vertica
and horizontal dimensions of the object. 

Top/Bottom Type values in the text boxes to specify the position
of the top, bottom, left, and right edges of the object, relative to th
document rulers.

Start/End Type values in the text boxes to specify the position o
the first and last endpoints of a line. 

Delta V/H Type values in the text boxes to specify the position o
the first endpoint, and the distance from the first endpoint to the la
endpoint of the line.

Object Type palette
Using the Object Specs palette 10.33
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Length/Angle Type values in the text boxes to specify the positio
of the first endpoint, and the length and angle of the line.

Data tab settings

The Data tab includes object 
size and position data and 
related options. The tab dis-
plays additional options when 
you select text. The text 
options let you change the 
shape of a text object or 
change the way text wraps in 
its bounding box.

A For a selected object, 
shows the object type, usually 
an icon of the tool that created 
the object. To create an object, 
select oval, rectangle, arc, line, 
or polygon.

B Select the type of data to 
display. You can choose Height/
Width or Top/Bottom for all ob-
jects except lines. For a line, you 
can choose Start/End, Delta V/
H, or Length/Angle. 

When an object is selected, 
you can change the values in 
the text boxes to resize or 
reposition the selected object. 
If Keep Proportions is checked, 
Canvas maintains the propor-
tion of the object if you change 
either the height or width (on 
Mac, the calculation occurs 
when you press the Tab key or 
click Apply).

C Displays the document’s 
measurement units.

D Position data. The type of 
data that appears in the boxes, 
and their labels, depends on 

whether you choose Height/
Width or Top/Bottom, Start/
End, Delta V/H, or Length/
Angle. 

Area. Shown when Canvas 
can calculate the area occu-
pied by a selected object’s 
bounding box. When you 
select text, the horizontal 
insets text box replaces the 
Area text box.

Perim. Shown when Canvas 
can calculate the perimeter, 
or distance around, a 
selected object’s bounding 
box. When you select text, 
the vertical insets text box 
replaces the Perim text box.

Object name. Type a name for 
the object.

Object #. The object number 
assigned by Canvas.

Keep Proportions. Select this 
option to keep an object’s 
height and width proportional 
when you are editing the 
object’s dimensions.

Apply. Click to apply the cur-
rent settings. The Apply button 
changes to Create when no 
object is selected and you 
choose an object type to cre-
ate.

Text object settings

Insets. Change the propor-
tions of a text object’s back-

ground. Type values, in pixels, 
in the text boxes to specify the 
horizontal and vertical size of 
the text object’s background. 

E Change the shape of the 
text object’s background to a 
rectangle, round rectangle, 
oval, or diamond. 

Caption. Select or deselect to 
change the way text wraps in 
its bounding box. Text that is 
not captioned wraps to the 
next line based on the bound-
aries of the text’s bounding 
box. 

You cannot use the Caption or 
Insets options with text that 
you created using the Path 
Text tool, or text that you con-
verted to paths. 

A

B

C

D

E

Text object settings
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Position data

The type of data that is displayed on the Data tab depends on whe
you choose Height/Width or Top/Bottom, Start/End, Delta V/H, or
Length/Angle.

Left Type the horizontal distance from the ruler’s zero point to th
left edge of the object. 

Top Type the vertical distance from the ruler’s zero point to the t
edge of the object.

Height Type the height of the object, relative to the top edge of t
object.

Width Type the width of the object, relative to the left edge of th
object.

Bottom Type the vertical distance from ruler’s zero point to the 
bottom edge of the object.

Right Type the horizontal distance from the ruler’s zero point to t
right edge of the object.

St V Type a value to position the first endpoint of a line, relative 
the vertical ruler’s zero point. 

St H Type a value to position the first endpoint of a line, relative 
the horizontal ruler’s zero point. 

End V Type a value to position the last endpoint of a line, relative
the vertical ruler’s zero point. 

End H Type a value to position the last endpoint of a line, relativ
to the horizontal ruler’s zero point. 

Delta V Type a value to position the last endpoint of a line, relati
(vertically) to the first endpoint of the line.

Delta H Type a value to position the last endpoint of a line, relati
(horizontally) to the first endpoint of the line.

Length Type a value to specify the length of a line.

Angle Type a value to specify the angle of a line.

X Type a value to position a handle of a polygon, relative to the h
izontal ruler’s zero point.

Y Type a value to position a handle of a polygon, relative to the v
tical ruler’s zero point.

Start Type a value to specify the starting point of an arc in degre
Using the Object Specs palette 10.35
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Delta Type a value to specify the length of an arc segment in 
degrees.

Diag Type a value to specify the roundness of the corners of a 
rounded rectangle.

Working with object styles
An object style is a set of attributes you can save and then apply 
objects. Object styles help you maintain consistency and make ap
ing attributes easier. You can edit and reapply styles to objects, ra
than editing each attribute.

To create an object style

1 Display the Object Specs palette and select the Style tab.

2 Select an object on which you want to base a style.

3 Click the Create button in the Object Specs palette. 

4 In the dialog box, type a style name in the Name text box. 

5 Select the check boxes for attributes you want to include in 
object style and click OK to save the style.

Object styles

The Style tab in the Object 
Specs palette lets you create, 
apply, and edit object styles.

Object style. This pop-up 
menu contains the names of 
object styles saved in the doc-
ument. To apply a style to 
selected objects, choose the 
style from the pop-up menu.

Previews of selected styles 
appear in the area under the 
Object Style menu.

Style descriptions are listed 
under the style preview. The 
list describes the fill, stroke, 

pen size, miter, dash, 
arrow, and arrowhead set-
tings for the selected style. 

Create. To create an object 
style from a selected 
object, click Create. In the 
Create Object Style dialog 
box, name the style and 
specify the attributes to 
include. Creating a style 
does not apply it to the 
selected object.

Edit. To change attributes 
of the current style, click Edit. 

Delete. To delete the current 
style, Click Delete.

Apply. To apply the current 
style to selected objects, Click 
Apply.
.36 WORKING WITH OBJECTS
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The following attributes of a selected object can be saved as a st

Fill Ink The fill ink of the object in the style. The name of the fill 
ink appears to the right of the check box.

Pen Ink The pen ink of the object in the style. The name of the p
ink appears to the right of the check box.

Stroke The stroke attributes of the object, such as pen size and
miter, in the style.

Dash The dash pattern of the object in the object style.

Arrow The arrowhead style of the object in the style.

To delete an object style

1 Display the Object Specs palette and select the Style tab.

2 Choose the Object Style to delete from the pop-up menu. A
preview and the style’s description appear on the tab.

3 Click the Delete button. Canvas removes the style’s preview
and description, and removes the style’s name from the Object 
Style pop-up menu.

To edit a saved object style

After you create an object style, you can modify it at any time. 

1 To edit an object style, choose the style to edit in the Objec
Style pop-up menu.

2 Click the Edit button to open the Edit Object Style dialog bo
which shows the selected style settings. You can change which
attributes are part of the style, and the attributes’ settings:

• To add or remove attributes from the style, select or dese
the Fill, Stroke, Pen, Dash, or Arrow checkboxes.

• To change attribute settings, use the Fill, Stroke, Pen, Da
or Arrow pop-up menus.

• To prevent creation of a new object style while you edit a
existing one, the Name text can’t be changed.
Using the Object Specs palette 10.37
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Setting print properties for objects
The Trap tab in the Object Specs palette lets you set overprinting
trapping options for color separations. You can apply the settings
selected objects by clicking Apply in the Object Specs palette.

Overprinting in color separations
When you output color separations in Canvas, you can specify tha
object should overprint, rather than knock out, objects behind it. 

In color separations designed for commercial printing, a front obje
usually “knocks out” a hole where it overlaps other objects. How-
ever, you can apply the Overprint Object option to an object to pr
vent it from creating knockouts in objects behind it. This can 
compensate for registration problems on some printing presses.

For example, if you draw a cyan circle on a yellow background, C
vas knocks the circle out of the background in color separations s
cyan and yellow do not mix in the circle. If you select the circle an
use the Overprint Object option, the circle will print over a solid ye
low background, and the cyan in the circle will mix with the back-
ground yellow, resulting in a green circle.

The effect of the Overprint Object option is not visible on screen. 
This effect is visible only in the printed output when you produce 
color separations. You can verify the settings for a particular obje
by viewing the Options tab in the Object Specs palette and then 
selecting the object.

Color mixing as described in the previous example is not the prim
reason for overprinting. It’s more common for designers to overpr
dark objects on lighter backgrounds as a way to prevent a gap fro
appearing between the colors if the press registration (alignment)
isn’t perfect.

To specify overprinting for objects

1 Select the vector or text objects to be overprinted.

2 Select the Overprint Object checkbox on the Trap tab in the
Object Specs palette. 

3 Click Apply. The appearance of the selected objects does n
change on screen, but the objects will be overprinted in color se
rations.

Overprinting produces a color 
mixture where the orange circle 
overlaps the gray circle. This 
effect isn’t visible on screen.

Without overprinting, the 
orange circle knocks out part of 
the gray circle.

knockout

Overprinted object
.38 WORKING WITH OBJECTS
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◆ To remove overprinting: Select the objects, clear the Overprin
Object checkbox on the Trap tab, and then click Apply.

Trapping in color separations
When objects of different colors touch, there is the potential for an
unsightly gap to appear between the colors if the piece isn’t printe
precisely aligned, or “in register.”

Trapping is a technique that purposely distorts the shapes of obje
in color separations where different colors meet. The slight distort
creates tiny areas called “traps” where colors overlap. The trap a
can help avoid the appearance of gaps if the page is printed sligh
out of register.

Before you use trapping in color separations, you should determi
how likely it is that the piece will not be printed in register. You 
should consider how beneficial it will be to distort the shape of so
objects to compensate for possible misregistration. For example,
trapping type can ruin the appearance of the text, and probably is
necessary.

Trapping choices

Canvas lets you specify two types of trapping, Choke and Spread

Choke trapping is used to make light background colors trap to da
foreground objects. Canvas creates a choke trap by slightly reduc
(“choking”) the knockout area in the light background object. 

For example, if a dark blue “A” is printed on a pale yellow back-
ground with choke trapping applied to the “A,” the “A” remains 
exactly the same, but the knockout area in the yellow background
becomes a slightly smaller “A” shape. The result is that some of t
yellow overlaps the edges of the dark blue “A.”

Spread trapping is used to make light foreground objects trap into
dark backgrounds. The trap is created by slightly enlarging the fo
ground object without changing the knockout in the background 
color. For example, if a light circle is printed on a dark backgroun
with spread trapping applied to the circle, the circle expands sligh
to overlap, or trap into, the circle knockout in the dark background

Trapping limitations

Whenever possible, you should design illustrations to avoid certa
trapping problems, and always discuss trapping with your service
bureau and printer to avoid unnecessary expense and inferior res

Choke trapping reduces the 
background knockout slightly 
to trap into a dark foreground 
object.

Spread trapping enlarges the 
stroke of a foreground object 
slightly to trap into a dark 
background object.
Setting print properties for objects 10.39
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In Canvas, trapping is best applied to vector objects that use a so
pen stroke and solid pen ink color. The following limitations apply 
trapping:

• Canvas will not create a choke trap for text.

• Canvas will not create a choke trap for a vector object th
has no stroke or has a stroke that is not a solid pen strok

• Canvas will not create a choke trap for an object that has
gradient pen ink.

• Canvas will not create a spread trap for a paint object.

To specify trapping for objects

1 Select the object you want to trap. In most cases, this will b
foreground object that touches a highly contrasting color.

2 Choose Object > Object Specs to open the Object Specs pa
and click the Trap tab, if necessary.

3 Click the Trap Object check box, and then select the Choke
Spread option button, depending on the type of trap to create.

4 Click Apply to set the trapping option for the selected object
No change is apparent in the object on screen, because the trap
created only when you print color separations.

◆ To apply trapping to selected text: You can apply trapping 
options to text that you select within a text object using the Overpr
and Spread options in the Text > Style submenu.

To adjust the trap size

Before printing color separations, you can specify the trap size. C
Separations Setup in the Print dialog box to change the trap size 
value.
.40 WORKING WITH OBJECTS
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Attaching comments to objects
You can attach written notes called comments to any object in a Can-
vas document. This can be useful for individuals and workers in 
groups who share documents. Anyone who works on a document
attach one or more comments to any object. 

You can attach comments to any type of object, including paint 
objects, vector objects, and text objects.

When you open a document, you can view all comments attache
objects. You can edit comments that you create, but you can’t cha
comments made by others.

When you select an object that has one or more comments attach
it, the object displays yellow selection handles (Windows) or gray
selection handles (Mac).

You can view comments by pointing to objects. When the pointer
on an object, the object’s comments appear in a pop-up window. 
comments do not appear when you point to commented objects, 
sure that “Show information tooltips” is selected on the General ta
in the Preferences dialog box. 

To attach comments

1 To attach a comment to an object, select the object.

2 Choose Object > Options > Comments to display the Comme
palette. In the Comments palette, click New. 

3 In the New Comment dialog box, type the comment text. Wh
you finish, click OK to attach the comment to the selected object.
The comment appears in the Comments palette.

You can click New in the Comments palette to attach additional co
ments to the selected object.

A comment can contain up to 64 kilobytes of text (about 65,500 ch
acters). The text appears in a fixed size and typeface.

When you create comments, you can select, copy, cut, and paste
using the standard keyboard shortcuts. Spell checking, text forma
ting, and text colors can not be applied to the text of comments.

J. Doe [JD] 
Check overprint setting on
this object.

Comments example
Attaching comments to objects 10.41
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Viewing and editing comments

You use the Comments palette to view, edit, and delete commen

1 Choose Object > Options > Comments to display the Comme
palette. All comments attached to objects in a document appear in
Comments palette. 

2 Select an author’s name in the pop-up menu to display only t
author’s comments in the list. To show all comments, choose All 
Reviewers.

The scrolling list displays the first lines and the author’s initials for
each comment. The initials preceding comments are from the use
name entered during Canvas installation. You can edit the initials
the User Info tab in the Preferences dialog box.

3 Click a comment to select it. When you select a comment, Ca
vas selects the commented object in the document. Yellow (Win-
dows) or gray (Mac) selection handles appear around the object 
indicate that the object has one or more comments.

4 To view, edit, or remove a selected comment, choose one of
following options:

View To view a selected comment, click View. The comment tex
appears in the View Comments dialog box. You can select text a
copy it to the Clipboard using standard keyboard shortcuts. You c
edit your own comments in the View Comments dialog box, but y
can’t edit or remove comments made by others. 

The pencil icon at the bottom-left corner of the dialog box indicate
that you can edit a comment. When you view a comment that you
can’t edit, a slash appears on the pencil icon.

When you finish viewing a comment, click OK or Cancel to close t
dialog box. If you have made changes to a comment, click OK to 
save the changes or click Cancel to discard them and close the d
box.

Remove Select a comment you created. Click Remove to delete 
comment from the object and the Comments palette.

Comments remain attached to objects until you remove the com-
ments. However, comments are not preserved by operations that
vert objects to different forms. These operations include Knife, 
Combine, Extrude, Fractalize, Join, Make Composite, Convert to 
Paths, and Insert Picture.
.42 WORKING WITH OBJECTS
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MACRO OBJECTS AND CLIP ART

You can speed up many projects by taking advantage of reusable
macro objects and ready-made illustrations. This chapter describ
how to use macro objects and the Canvas clip art collection.

Macro objects are illustrations that you store in the Macros palette
You can create a macro object from any vector, text, group, or pa
object. After storing a macro object, you can use the Macros tool 
place copies that are linked to the stored macro. If you change th
macro in the palette, all the copies in the document will also chan

Macro objects make it easy to place and change frequently used 
trations. You can save time by creating macro objects from eleme
you intend to use repeatedly, such as logos, symbols, and floor pl
For example, after designing a logo, you can make the illustration
macro object and use the Macros tool to place copies in your doc
ment. If you decide to change the logo, you can change all the co
at once by replacing the original macro object in the Macros pale

Using Canvas clip art 
The Canvas package includes an extensive collection of clip art. S
jects range from animals and plants to business images and tech
symbols. The clip art is stored in Canvas files on the Canvas distr
tion CD-ROMs.

The Clip Art palette lets you browse Canvas clip art files, select ill
trations and place them in your documents. In addition, because 
vas clip art files are indexed, you can perform keyword searches 
locate all clip art files pertaining to a particular topic.

◆ To display the Clip Art palette: Choose Window > Palettes > 
Clip Art.

To select a clip art file

One way to select clip art in the Clip Art palette is to enter the ID 
string printed beneath an illustration in the Canvas Clip Art book. 

The first digit in the ID string is the number of the CD that contain
the file. Insert the CD in your CD drive. Then, type the ID string in
the palette’s text box and press Enter. This will display and select

The Clip Art palette lets you 
browse, select, and place 
Canvas clip art
11.1
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file’s preview in the palette. Click in the document to place the file
or drag in the document to scale the file and place it.

Note: To use Canvas clip art CDs with Mac OS, the Foreign File 
Access and ISO 9660 File Access extensions are required.

To browse clip art 

If a Canvas clip art CD is in the CD drive, the Clip Art palette dis-
plays the preview images from the CD. If the previews don’t appe
choose Open Library in the palette’s menu. In the directory dialog
box, select the Canvas Index (.ndx) file on the CD and click Open

To browse a directory

1 In the Clip Art palette, choose View Directory from the pal-
ette’s menu.

2 In the directory dialog box, select any Canvas file in the fold
you want to browse and click Open. Previews of all Canvas doc
ments in the folder will appear in the Clip Art palette.

◆ To toggle between large and small previews: In the palette’s 
menu, choose Toggle Cell Size.

To search the clip art index using keywords

You can enter keywords to search the entire Canvas clip art colle
tion and locate clip art by subject.

1 Choose Search Options in the Clip Art palette’s menu. 

Browse and select clip art 
in the scrolling grid

Choose options from the 
palette menu

✔Tip
To save Canvas documents 
with previews, in the Save As 
dialog box, select “Create Pre-
view” (Mac) or “Save Preview” 
(Windows).
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2 In the Search Options dialog box, choose a search option.

3 You can tell Canvas to find art with all or any of the keywords 
with the “Search using AND criteria” option. When this option is
not selected, Canvas searches for clip art that matches any keyword 
in the text box. When this option is selected, Canvas searches f
clip art that matches all the keywords you type.

4 Click OK to apply the search options. These options will 
remain in effect unless you change them.

5 Type keywords in the text box in the Clip Art palette. You ca
type multiple keywords separated by spaces.

6 To begin searching, press Tab or Enter. Canvas displays 
thumbnail previews of all illustrations that meet the search criter

Placing clip art
After finding an illustration you want to insert, you can place the 
illustration at its original size, or scale it as you place it.

When you browse or search for clip art, the palette shows all file
regardless of which CD the files are stored on. If you select a fil
that isn’t on the current CD, Canvas tells you which CD to inser
when you click to place the file in the document.

To place clip art

Click a preview image in the Clip Art palette to select an illustratio
to place. A box appears around the selected illustration.

• To place the illustration at its original size, click in the doc
ument where you want to place the upper-left corner. 

• To scale the illustration, drag the pointer to set the boundi
box size. Canvas fits the illustration to the bounding box.

Choose To find

Matches Exact matches of the name you type

Contains Any name that contains the text you type

Starts With Any name that begins with the text you type

Ends With Any name that ends with the text you type

A Click an arrow to scroll 
the clip art index

B Click a subject to show 
previews

C Type keywords in the 
box to find clip art

A B

C

Click to place

Drag to scale
Using Canvas clip art 11.3



11

ons 
ri-
an-

ter 

 
aw-
le, 
, and 
sis-
rga-

lso 
, and 

 in 
ou 
t by 

le 
date 

 

’t 

ac-
rag 
Using commercial clip art packages 

You can purchase many commercial clip art packages of illustrati
and raster images. Commercial packages use standard and prop
etary file formats. If you want to use third-party clip art, ask the m
ufacturer about the file format and verify that Canvas can 
successfully open the files. For more information, refer to the chap
“File and data exchange” on page 7.1.

Using macro objects
Macro objects can help you create illustrations quickly, uniformly,
and precisely. Macro objects are especially useful for technical dr
ings, diagrams, and other frequently used illustrations. For examp
a landscape designer can create sets of macros for trees, shrubs
structures. An electrical engineer can create macros for gates, re
tors, and other circuit components. Project managers can build o
nizational charts with macros for shadowed text boxes.

You can create, delete, and modify individual macro objects, and a
save them as macro sets. You can store sets for specific projects
load sets as you need them.

You can store two categories of macros in the Macros palette. 

Document tab Macros stored on the Document tab are available
the current document only. The available macros change when y
switch documents. You can update macros placed in a documen
replacing the original macro in the palette.

Application tab Macros stored on the Application tab are availab
in all Canvas documents. These macros can not be replaced to up
copies that you have placed in documents.

To create a macro object 

You can convert nearly any Canvas object into a macro object by
dragging it to the Macros palette.

Note: If the Macros palette is docked on the Docking bar, you can
drag objects into it to create macros.

1 Create the illustration that you want to use as a macro.

2 To open the Macros palette, choose Window > Palettes > M
ros. Or, press the Macros tool in the Object Tools palette, and d
the Macros palette away from the toolbox.

Macros palette
.4 MACRO OBJECTS AND CLIP ART
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3 Drag the object into the Document or Application tab in the 
Macros palette. 

• If you drag the Macro onto a stored Macro in the palette,
Canvas asks if you want to replace the Macro.To create 
new Macro, click No.

4 A message requests a name for the new macro. Type a nam
and click OK. A preview of the macro appears in the palette.

◆ To delete a macro: In the Macros palette, select the macro yo
want to delete. Choose Delete in the palette’s menu. The macro i
removed from the palette, but copies in the document aren’t affec

◆ To toggle between large and small macro previews: Choose 
Toggle Cell Size in the palette’s menu.

Placing macro objects
After you create a macro, you can place it in a Canvas document
You can insert a macro at its original size, or scale the macro as 
place it. 

To place a macro object

Click a preview in the Macros palette to select the macro you wan
place. A box appears around the selected macro.

• To place the macro at its original size, click in the docume
where you want the top-left corner of the macro to appea

• To scale the macro as you place it, drag the pointer to set
size of the bounding box of the object you are placing. C
vas scales the object to fit the bounding box.

To find a macro in the palette

1 In the text box, type the text you want to search for. When y
perform the search, Canvas will find the macro in the palette that
starts with the text you type.

2 To begin searching, press Enter. Canvas selects the macro
the palette that starts with the text you typed. If more than one 
macro meets the criteria, Canvas selects the first macro it finds.

Editing macro objects 
If you want to update all copies of a macro in a document, you ca
replace the original on the Document tab in the Macros palette. If y

Click to place a macro, or drag to 
scale and place it. The object 
appears when you release the 
mouse.
Using macro objects 11.5
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want to replace a macro with a copy based on that macro, you m
first unlink the copy from the original.

To edit the path of a macro copy, first select the copy and then cho
Object > Path > Convert to Paths, or unlink the object. Both meth
let you edit the object as a path, but they also unlink the object fro
the original macro.

To replace a macro in the palette

1 Create the object you want to use to replace a macro.

2 Drag the object to the Document tab in the Macros palette a
drop it on the macro you want to change.

3 When Canvas asks if you want to replace the existing macr
click Yes to change all copies of the macro to the new object.

Unlinking macros

By unlinking placed macros, you can prevent them from changing
when the macro in the palette is modified. You also make it possi
to use a placed macro to modify its parent macro and to use path-
ing techniques. 

◆ To unlink a macro copy: In the document, select the macro 
copies you want to unlink from the original. In the Macros palette,
choose Unlink in the palette’s menu.

Using macro sets
You can save macros in named sets for use with specific projects
types of illustrations. Using this feature, you can load only the ma
ros that you need at the time.

◆ To save all macros as a set: In the Macros palette menu, 
choose Save Set. In the dialog box that appears, type a name for
set, specify a location to save the set, and click Save.

◆ To load a macro set into the palette: Choose Append Set in 
the palette’s menu. In the dialog box that appears, specify the file
name and location of the macro set you want to load, and click Op
The macro set is added to the current tab in the palette.
.6 MACRO OBJECTS AND CLIP ART
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INKS: COLORS AND PATTERNS

Inks in Canvas are solid colors, or multiple-color patterns that you
apply to vector and text objects. You can apply inks to the interior
and outlines of vector objects and text.

This chapter describes how to create and apply inks, from basic s
color inks to custom multicolored inks. It also explains how to use
various color systems to define inks.

The Inks palette
You use the Inks palette to apply inks to objects, select the curren
inks for new objects, and create new inks. To open the Inks palet
press the pen or fill ink icon at the bottom of the toolbox. For deta
see “Applying preset inks” on page 12.6.

The Inks palette contains five types of inks on separate tabs. Each
has inks and a manager you can use to customize inks.

Color inks Color inks (on the Color tab) are solid colors. You can
use CMYK, RGB, and commercial color reference systems to def
color inks.

Gradient inks Gradient inks (on the Gradient tab) are smooth 
blends between two or more colors.

Hatch inks Hatch inks (on the Hatch tab) are patterns of lines. 
Hatch inks can incorporate other pen and fill inks. 

Symbol inks Symbol inks (on the Symbol tab) are patterns of vec
tor objects. Symbol inks can include any other ink as a backgroun

Texture inks Texture inks (on the Texture tab) are patterns of ras
images. Texture inks can include other inks as backgrounds.

How inks apply to objects
You can apply inks to two areas of vector objects and text: Fill inks 
cover the interior of objects and text characters. Pen inks cover the 
outline stroke of objects and text characters. You can apply one f
ink and one pen ink to an object and to a text character.

Inks palette with Color tab 
selected
12.1
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You can apply different types of inks to an object — a gradient fill
ink and a texture pen ink, for example. If an object has neither a p
ink nor a fill ink, the object is not visible.

In addition, you can apply inks to the backgrounds and outlines o
text objects.

Remember that you don’t apply inks to paint objects. Instead, you
use painting tools to paint in a paint object and give it color.

Applying fill inks to open and closed paths

Whether a vector object path is open or closed affects the appear
of its fill ink. In a closed path, the ink completely fills the object’s 
interior; in an open path, the ink fills inside the path as if the path 
were closed by a straight segment between its endpoints.

Default and current inks 

By default, Canvas applies white fill ink, black pen ink, and a 1-po
pen stroke to new vector objects. For new text, Canvas applies b
fill ink, no pen ink, and no stroke to the text characters. 

The current inks are the inks that Canvas applies to new vector 
objects you draw. The squares in the pen ink and fill ink icons in t
toolbox display the current inks. When you apply inks to existing 
objects, the current inks do not change.

◆ To change the current pen or fill ink: Make sure no objects are
selected in the document, then press the pen ink or fill ink icon to
select a current ink in the Inks palette.

This object has a pen ink and a fill 
ink; both are basic color inks.

Pen ink

Fill ink

The triangle has a pen ink but no 
fill ink, so the circle in back is 
visible through it.

This path has a pen ink and no fill 
ink.

The path above has a pen ink and 
a fill ink.

Current pen ink

Current fill ink
.2 INKS: COLORS AND PATTERNS
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Using the Color Dropper
You can use the Color Dropper tool to select and apply colors. Th
Color Dropper tool is located in the toolbar containing Effects too
in the toolbox.

The Color Dropper can select colors from any object in a docume
and from anywhere on screen, even outside of the Canvas applica
window.

Colors you select with the Color Dropper become the current fore
ground or background colors for painting and the current pen inks
and fill inks for new vector objects.

The Color Dropper helps you use colors consistently throughout a
document. It can also help you identify colors from documents tha
you import into Canvas. By letting you match colors, the Color Dro
per can be useful for photo retouching. 

The Color Dropper has two modes: Object Ink and Pixel Color. T
tool selects the actual color at the point you click, taking into acco
transparency effects. Or, it selects the ink (in vector and text obje
or the paint color (in images). See “Color Dropper modes” on 
page 12.5.

To select an ink

In vector objects and text, the Color Dropper can pick up texture, 
dient, hatch, and symbol inks; in paint objects, the Color Dropper
selects the original color applied to the pixel you click.

1 Double-click the Color Dropper icon. In the dialog box, select
Object Ink and click OK.

2 Select the Color Dropper tool.

To set the fill ink, click an ink to make it the current fill ink. You ca
click a pen ink or a fill ink; in either case, the ink you click become
the current fill ink.

To set the pen ink, Option-click (Mac) or right-click (Windows) an
ink to make it the current pen ink. You can click a pen ink or a fill 
ink; in either case, the ink you click becomes the current pen ink.

When you click a vector object or text, you get the actual ink, not 
color at the point where you click. For example, if the object conta
a symbol ink of white stars on a blue background, this becomes t
current ink, whether you click a white or blue area.

Color Dropper tool
Using the Color Dropper 12.3
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To select a color

In all objects, the Color Dropper can pick up the color at the tip of t
pointer. In this mode, the tool selects apparent colors, which is th
color you actually see. 

1 Double-click the Color Dropper icon. In the dialog box, select
Pixel Color and click OK.

2 Select the Color Dropper tool. Click a color to set the current 
ink color and background color. Option-click (Mac) or right-click 
(Windows) to set the current pen ink color and foreground color.

To select colors outside Canvas

With the Color Dropper selected, you can drag from the Canvas w
dow to anywhere on screen. As long as you press the mouse but
the Color Dropper remains active; the ink icons in the toolbox sho
you the colors the tool can select. Release the mouse button to s
the color under the tip of the pointer.

The color you select becomes the current fill ink and background
color. You can’t use this method to select the pen color.

To apply colors to objects

You can apply the current inks to vector objects and text with the
Color Dropper. This makes it easy to quickly transfer inks from on
object to another. 

Mac Control-click a vector or text object to apply the current fill in
to the object. Control+Option-click to apply the current pen ink to t
object.

Windows Ctrl-click a vector or text object to apply the current fill 
ink to the object. Ctrl-right-click to apply the current pen ink to the
object.

Note: The Color Dropper mode does not affect the application of c
ors. Also, you cannot apply colors to paint objects using the Colo
Dropper tool. 

✔Tip
While editing an image with a 
painting tool, you can quickly 
switch to the Color Dropper. 
Press Option (Mac) or Alt (Win-
dows) to display the Color 
Dropper, and click to select a 
foreground color for painting.
.4 INKS: COLORS AND PATTERNS
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Color Dropper modes
The Color Dropper selects either actual colors where you click, o
selects the inks applied to vector or text objects. To set the mode
the Color Dropper, double-click the Color Dropper tool icon. In the
dialog box, select an option and click OK. The mode remains set 
unless you use the dialog box to change it.

Object Ink

Selects inks and actual colors, not the apparent color that you clic

In vector or text objects, the Color Dropper selects object inks —
color, gradient, symbol, texture, and hatch inks. It does not take in
account transfer modes or transparency effects.

If you click an object’s stroke, you select its pen ink; if you click an
object’s interior, you select its fill ink. In the case of paint objects, 
which do not have inks, the color you click is selected as a color i

For example, if you click a gradient ink with the Color Dropper, it 
selects the gradient ink, not the color under the pointer. If you clic
dotted symbol ink, the tool selects the symbol ink, not the color 
where you click. 

In paint objects, the Color Dropper selects applied paint colors, n
colors you see because of transfer modes, channel masks, or oth
transparency effects. For example, if you click a black area that is
50% transparent against a white background, you select solid bla
not the 50% gray that you see.

Pixel Color

Selects the apparent color that you click at the tip of the Color Dro
per pointer. This mode works the same whether you click a paint,
vector, or text object.

For example, if you click a gradient ink in a vector object, you sele
the exact color you click, not the gradient ink. If you click in an 
object that has transparency and transfer mode effects, you selec
exact color you see.

Selecting a color in Pixel Color mode lets you identify the color’s 
values. When you click a pixel, the Color manager in the Inks pale
shows the color values. 

Object Ink mode

Pixel Color mode

Selected
ink

Selected
color
Using the Color Dropper 12.5
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Color mode

When you select Pixel Color in the Dropper dialog box, you can 
choose a color system in the pop-up menu. You can select RGB,
CMYK, or Grayscale. 

The Color Dropper converts any color you click to the selected co
system. 

For best performance, choose the color system that matches the
ors you are sampling. For example, if you sample colors in comp
RGB images with CMYK selected, slight delays can occur becau
Canvas must convert the image’s RGB values to CMYK values. 

However, you might want to select a color system that differs from
an image. You might do this to see the effect of a color conversio
such as RGB to CMYK for printing, for example.

Applying preset inks 

Each tab in the Inks palette 
holds inks that you can apply as 
pen or fill inks.

A Pen ink icon. Press to select 
pen inks for object outlines.

B Fill ink icon. Press to select 
fill inks for the insides of objects.

C Ink tabs. Select the type of 
ink you want to apply. 

D Preset inks. Select an ink in 
the grid. Use the scroll bars if all 
the preset inks aren’t visible.

E No ink. Click this tile to ap-
ply no inks, or to make the cur-
rent ink for new objects “no 
ink.” 

• To apply inks to existing 
objects, select the objects and 
then choose pen and fill inks.

• To change the inks that Can-
vas applies to new vector and 
text objects, deselect all 
objects, then choose pen and 

fill inks. The ink icons in the 
toolbox show the current inks.

Because pen inks are applied 
to the strokes of objects, the 
appearance of an object’s pen 

ink is affected by the shape of 
the object’s stroke. For more 
information, see “How inks 
affect strokes” on page 13.1.

A

B

D

CE

Inks on the Color, Gradient, Texture, Symbol, and Hatch tabs

The Inks 
palette opens 
when you 
press either ink 
icon in the 
toolbox. Select 
a tab and then 
an ink in the 
grid.
.6 INKS: COLORS AND PATTERNS
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Creating and customizing inks
You can use the Inks configuration managers to create your own
inks. Managers are sets of controls at the bottom of the tabs in th
Inks palette. You can flip open the managers to create inks, adjus
inks in objects, and change the palette’s inks.

Described next are ways to change the Inks palette and use Inks 
agers in general. The rest of the chapter explains how to customi
color inks, gradient inks, hatch inks, symbol inks, and texture inks

Changing the Inks palette
You can do the following to customize the Inks palette:

• Delete inks you no longer want to use.

• Add new inks to the palette.

• Save the inks on each tab in an inks file.

• Load inks from a file to replace the current inks.

• Append inks from a file to add them to the palette.

When you add or delete inks in the palette, the changes are reco
in a Canvas Settings file, not in the Canvas document, so the pal
contents remain the same the next time you use Canvas.

◆ To save, load, or clear inks: Press the button at the bottom-
right corner of the palette and choose a command in the pop-up 

Using the Inks palette in a floating window

To keep the Inks palette open, press either ink icon in the toolbox 
and drag the palette away. The palette remains open in a floating 
window.

To apply inks to selected objects: Click the pen ink (A) or fill ink 
(B) icon, then click an ink. If you click an ink with no objects select-
ed, the ink becomes the current ink applied to new objects.

To drag and drop inks: Drag an ink from the grid to an object’s 
outline (for a pen ink) or the inside of the object (for a fill ink).

Names: Check this box (C) to show the names of inks in the grid.

To remove an ink from the palette: Drag it to the trash can (D). A C DB
Creating and customizing inks 12.7
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menu. The commands include the name of the current ink tab, so
command on the Color tab is Load Colors, for example.

You can save, load, and append inks on one tab at a time in the I
palette. When you load or append inks, if you select a file that doe
contain inks from the current tab, Canvas won’t load the inks.

Load... Loads inks from a palette file, replacing the tab’s inks. In
the dialog box, select a file and click Open.

Append... Adds inks from a palette file to the inks on the current
tab. In the dialog box, select a palette file and click Open.

Save... Saves the current tab’s inks in a palette file. In the dialog
box, select a location, type a file name, and then click Save.

Clear... Removes the inks (except “no ink”) from the current tab.
On the Color tab, Canvas restores black and white (CMYK) inks 
after clearing all the inks.

Setting the size of tiles
You can chose two sizes of tiles for the preset colors in the Inks p
ette. To change the tile size, choose Large Tiles or Small Tiles in
palette’s pop-up menu. The size setting affects the Color tab, but
the other tabs in the Inks palette.

Arranging ink tiles
To rearrange tiles in the Inks palette, drag an ink tile on any inks 
and drop it where you want to place it.

You can also move multiple ink tiles to a new location in the palet
Click an ink tile, and then Shift-click another color tile. Canvas hig
lights all tiles between the colors you click. To select non-contiguo
tiles, Ctrl-click the tiles you want to select. Drag the selected tiles t
new location in the palette.

Small color tiles Large color tiles
.8 INKS: COLORS AND PATTERNS



Using Inks managers

Open the Inks managers when 
you want to create inks or 
change the preset inks on the 
tabs in the Inks palette.

A Click to flip the managers 
open or closed. If the Inks pal-
ette isn’t open, first press either 
of the ink icons in the toolbox 
and drag the palette away.

B Preview. This box shows 
the current ink. The preview 
changes as you modify the ink. 
When you click the Apply but-
ton, Canvas applies this ink. 
You can also drag the ink from 
the preview box to objects and 
into the grid of preset inks. 

To edit an object’s ink:
Click the pen (C) or fill icon 
(D), then select an object; its 
ink becomes the current ink in 
the manager. Modify the ink, 
then click Apply to apply the 
modified ink to the object.

To make a new ink:
Use the manager to customize 
the current ink. To name it, 
type in the text box (E). Then 
do any of the following:

• To add the ink to the pal-
ette, drag from the preview 
box (B) to the grid of preset 
inks.

• To make the ink the current 
ink, click the pen (C) or fill (D) 
icon, then click Apply when no 
objects are selected.

• To apply the ink to a non-
selected object, drag from the 

preview box (B) to the inside 
or outline of the object.

When you create a new ink, be 
sure to add it to the palette or 
drag it to an object before 
selecting anything. Otherwise, 
the selection’s ink replaces the 

new ink in the manager.

A pop-up menu (F) contains 
commands that let you save 
inks and load inks on the cur-
rent tab. You can also clear the 
current tab’s inks to start with 
an empty palette.

Gradient manager

Symbol manager

Color manager

A

E

B

F

C

Hatch manager

B

B

D

E

E

Texture manager

B

E

B

E

Creating and customizing inks 12.9
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Getting inks from vector and text objects
Canvas lets you add inks from vector objects and text objects to t
Inks palette. If a text object contains more than one fill or pen ink,
colors will be added to the palette. You can also add the inks of m
tiple selected objects; however, the inks from group objects and 
macro objects cannot be added. 

◆ To add inks to the Inks palette: In the Inks palette, select the 
Pen Ink or Fill Ink icon, depending on the type of ink you want to 
add. Then, drag the vector or text object onto the preset inks area
the appropriate tab in the Inks palette. 

For example, to add an object’s gradient fill ink to the Gradient ta
click the Gradient tab to bring it to the front. Next, click the Fill Ink
icon, and then drag the object onto the gradient tiles.

Creating color inks
You can create new inks to expand the inks selection and conver
inks from one color system to another.

1 If necessary, select the Color tab and open the Color mana
in the Inks palette. The current ink appears in the preview box. 

2 Choose a color system and model in the pop-up menu. See
“Color systems” on page 12.11.

3 Use the Color manager controls to change the ink’s color va
ues. To restore the original ink, click the left preview box.

4 To name the ink, type the name in the text box. To define it 
a spot color, check the Spot Color box.

5 To apply the ink to non-selected objects, drag it from the pre
view box to the objects. To add the ink to the palette, drag it from
the preview box to the grid at the top of the tab. Canvas adds th
color at the end of the inks grid.
.10 INKS: COLORS AND PATTERNS
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Color systems
When you define colors in Canvas, you can use CMYK, RGB, an
Grayscale color systems. Or, you can use a color matching syste
select colors for commercial printing. 

CMYK colors

The CMYK color system is used in four-color process printing. In 
this system, you define colors as mixtures of Cyan (C), Magenta (
Yellow (Y), and Black (K) printing inks.

For example, to create green, you mix cyan and yellow.

The CMYK system is appropriate for illustrations that will be sepa
rated for commercial printing. 

RGB colors

The RGB color system is used in computer monitors. In this syste
you define colors as mixtures of Red (R), Green (G), and Blue (B
light. 

For example, to create purple, you mix red and blue.

The RGB system is appropriate for graphics displayed on a moni
such as presentations and web pages. 

You should avoid RGB colors in documents intended for commerc
printing. Canvas will convert RGB colors to CMYK colors if you 
output color separations.

The HSL models in the Color manager let you define RGB colors
using Hue (H), Saturation (S), and Lightness (L) values. This way
defining colors is familiar to artists. HSL models let you adjust sat
ration and lightness, without changing a basic hue, such as red o
green. 

Grayscale colors

The Grayscale model lets you define shades of gray. Grayscale co
are neutral when used with RGB or CMYK colors. For example, i
RGB Color images, grayscale colors are equal amounts of red, gr
and blue. In image channels, Grayscale colors are pure gray. In v
tor objects, text, or CMYK Color images, Grayscale colors are pe
centages of black. In color separations, Grayscale colors appear 
percentages of black.

✔Tip
Colors displayed on a monitor 
can only approximate the 
appearance of printed colors. 
Be sure to discuss color repro-
duction with your commercial 
printer and obtain accurate 
proofs for color projects.
Creating color inks 12.11
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Specifying tints

You can specify a tint color and amount in the CMYK or RGB sys
tem. Tinting with white screens the original color. The screen per
centage is 100 minus the tint value. For example, 80 percent whi
tint results in 20 percent of the original color.

For other tint colors, Canvas multiplies the tint values by the diffe
ence between the original and tint color values, and then adds th
result to the original color values.

Commercial color reference systems

You can use commercial reference system colors for process and
colors. You can choose PANTONE, Toyo, and Trumatch color sy
tems in the pop-up menu in the Color manager. See “Color refere
systems” on page 12.14.

Remember that the appearance of a commercial color on screen
differ from its appearance when printed. To view the printed appe
ance of a commercial color, consult your manufacturer’s referenc
documentation. For more information on process and spot color 
printing, see the Color Printing Guide.

PANTONE The PANTONE System includes hundreds of spot co
ors designed to be printed with special inks. You should select th
correct color group for the paper stock on which the colors will be
printed. For example, the PANTONE CVC colors are calibrated fo
printing on coated paper stock. The PANTONE Pro-Sim colors ar
not spot colors. These colors are designed to be printed with stan
process inks. 

Toyo The Toyo Ink system provides more than 1,000 colors in ni
sets for process-color printing on various paper stocks.

Trumatch Trumatch is a four-color process matching system, 
which means that its colors are not spot colors that must be printe
with special inks. Trumatch lets you select more than 2,000 color
based on 50 hues and tints and shades of each hue, in addition t
four-color grays.
.12 INKS: COLORS AND PATTERNS



Color manager controls

The Color manager controls 
depend on the selected color 
system and model. Some con-
trols are common among the 
different color models.

A Current ink.

B Last-applied ink.

C Bars. Use the sliders, or en-
ter values in the text boxes, to 
specify color values. 
• RGB values go from 0 to 255.
• CMYK values go from 0 to 
100 percent. 
• HSL values go from 0 to 360 
degrees (hue) and 0 to 100 per-
cent (saturation and lightness).

D Spot Color. Select to set 
up a spot color. Type a color 
name in the text box. Spot col-
ors print on separate plates 
when you make color separa-
tions.

E Tint Color. Select the color 
to apply to the current color. 

F Tint value. Enter the per-
centage of tint to be applied.

G Swatchbook. Shows colors 
made from 0-100% mixtures of 
two CMYK colors. To select a 
color, click in the swatchbook; 
the color values appear in the 
text boxes.

H Select the two colors for the 
swatchbook. To add a third or 
fourth color, enter percentages 
in the C M Y K text boxes. 

I Color wheel. Click in the 
wheel or drag the selector to 
pick a color, or enter values in 
the H S L text boxes.

J Lightness. Drag the slider, 
or enter a number in the L text 
box, to set the lightness for the 
entire color wheel.

K Gamut warning. When the 
current color can’t be printed 
with CMYK inks, a warning sym-

bol and color box appear. Click 
the color box to replace the cur-
rent color with the closest color 
that is within the CMYK gamut. 

Gamut warnings appear only in 
RGB and HSL systems.

C

D

E

F

H

H

I

J

B A

D

D

D

G

B A

B A

K
HSL Wheel

CMYK Swatch

CMYK Bars CMYK Tints

B

A
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Identifying colors

You can display symbols that identify the color inks that are store
on the Color tab in the Inks palette. To identify color inks, choose
Show Color Icons in the palette’s pop-up menu. To hide the symb
choose Hide Color Icons in the pop-up menu. 

Note: If the Color tab contains only CMYK colors, no symbols 
appear when you choose Show Color Icons.

The Color tab can contain color inks defined with RGB, CMYK, 
grayscale, and spot colors. 

The symbol that identifies RGB color inks has tiny red and blue tr
angles and a green square. The symbol appears at the upper-left
RGB color tiles. 

The symbol that identifies spot color inks is a white triangle. The 
symbol appears at the lower-right of spot color tiles.

No symbol appears on CMYK or Grayscale ink tiles.

Color reference systems

When you choose a PAN-
TONE, Toyo, or TRUMATCH ref-
erence system color set in the 
Color manager, you can 
search for and select colors by 
name.

A Color name. The selected 
color’s name. Names of refer-
ence colors can’t be changed.

B Color system. Choose the 
reference system you want to 
use in the pop-up menu. 

C Color list. Click a color in 
the list to select it. Use the scroll 
bar to scroll the list.

D Current color preview.

E Page. The page number of 
colors shown in the color list.
Type a number to go to the 
page.

F Find. Click to select a color 
by name. In the Find dialog box, 
type the color name or number 
and click OK. Canvas selects the 
color (if found) in the color list.

G Tint Value. For PANTONE 
colors (except process colors), 
enter a screen percentage to 
apply to the selected color. Use 
100% for solid color and lower 

values for screens of the solid 
color.

Spot Color option. Available 
with some color systems, this 
option lets you specify colors 
to use as spot colors in separa-
tions.

A

B

C

D

E

F

G

CMYK color 

Spot color 

RGB color 
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Creating blends of color inks

You can select two color tiles and create a blend of colors to add
the Inks palette.

To blend colors

1 In the Inks palette, click the Color tab to bring it to the front.

2 Click the tile you want to start the blend, then Ctrl-click the tile
you want to end the blend.

3 Choose Blend in the pop-up menu. A dialog box appears. En
the number of steps you want in the blend, and then click OK. Ca
vas creates the blend and adds the new tiles to the Color tab.

Creating custom colors in pop-up palettes

In Canvas, dialog boxes and palettes that let you choose colors ha
color icon that opens a pop-up palette. This color icon appears 
throughout the program, including the Channel Options dialog bo
the Extrude palette, and the Gradient manager.

When you press (Mac) or click (Windows) the color icon to open t
palette, you see the colors currently on the Color tab of the Inks p
ette. If the color you want isn’t in the pop-up palette, select the Cu
tom button to open the Color Editor dialog box, where you can cre
a new color without adding it to the palette. Use this method if yo
don’t need to use the color again.

The Custom box appears in pop-up color palettes in the following
dialog boxes and palettes:

Inks Gradient manager
Hatch manager (pen color pop-up only)

Strokes Neon manager
Parallel manager

Layers Layer Options dialog box

Color calibration Gamut Warning dialog box

Image editing Duotone Options dialog box
New Channel dialog box
Channel Options dialog box
Create Image dialog box

Effects Extrude palette

Blended colors

Color icon
Creating color inks 12.15
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To create a custom color in a pop-up palette

1 In the pop-up color palette, choose the Custom option to op
the Color Editor dialog box. This dialog box is almost identical to
the Color tab in the Inks palette.

2 To use a different color model or color system, choose an 
option in the pop-up menu. Depending on which option you 
choose, the dialog box shows a different set of controls; see “Co
manager controls” on page 12.13 for more information.

3 Use the color controls to create a custom color.

4 To specify that you want the color you define to be a spot 
color, make sure the color is named in the text box at the top, th
select Spot Color.

5 When you have the color you want, click OK. The color 
appears in the palette icon.

Gradient inks
A gradient is a gradual blending of colors. A Canvas gradient ink c
blend two or more colors in a variety of styles. Like other inks, gra
ent inks can be applied as fill inks or pen inks to vector objects an
text.

✔ Important 
If you plan to export a docu-
ment to another application in 
EPS format and make spot col-
or separations, be sure the 
spot color names match exactly 
in both applications. Any varia-
tion will cause problems.

Color Editor dialog box

You can choose the Custom 
button in a pop-up color pal-
ette to open the Color Editor 
dialog box.

A Type a name for the color 
in this text box.

B Choose a color model or 
reference system in this pop-up 
menu.

C Use the controls to specify 
a color. The available controls 
depend on the option you 
choose in the pop-up menu 
(B).

D Current selected color that 
appears in the color palette 
icon. Click to revert the settings 
in the dialog box to this color.

E Preview of the custom color 

that you are defining.

Spot Color. Select this option 
to define the custom color as a 
spot color.

A

B

C

E

D
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To create, customize, and apply gradient inks, you use the Gradi
tab in the Inks palette.

Gradient manager

To create a gradient ink, you 
choose a gradient style, colors, 
and other options using the 
controls in the Gradient man-
ager.

A The gradient color se-
quence appears in the bar. 
Each pointer below the bar 
represents a color and shows 
the color’s relative position in 
the gradient. One pointer is al-
ways selected, and the point-
er’s color appears in the color 
icon (D). A gradient can have 
two or more colors.

B The pointers at the ends of 
the bar represent the start and 
end colors of the gradient. 
These pointers can’t be moved 
or deleted, but you can change 
their colors.

C Click a pointer to select it; a 
selected pointer appears high-
lighted. To add an intermedi-
ate color, double-click in the 
bar and a new pointer appears 
that represents the color of the 
gradient where you clicked.

To adjust color spacing, drag 
an intermediate pointer. To 
delete a color, drag its pointer 
to either end of the bar.

D Choose a color for the se-
lected pointer from the pop-up 
palette. To select a custom col-
or, see “Creating custom col-

ors in pop-up palettes” on 
page 12.15.

Style. Choose a gradient style 
from the pop-up menu. See 
the table (next) for shape and 
editing information.

E You can drag handles in 
the box to adjust settings such 
as gradient shape, angle and 
center. See the table, next, for 
additional information.

F Gradient preview. Shows 
the current gradient. The ap-
pearance of the gradient var-
ies, depending on the gradient 
style. The preview changes as 
you edit the gradient. 

When you click the Apply but-
ton, Canvas applies this gradi-
ent. You can also drag the gra-
dient from the preview box to 
objects and into the grid of 
inks.

Angle. For Radial and Direc-
tional styles, enter the angle of 

the gradient axis, or drag the 
solid dot in the edit box to set 
the angle. 

360º. When Radial style is 
selected, select this checkbox 
to blend the gradient through 
360 degrees around the cen-
ter. If this option isn’t selected, 
the blend runs through 180 
degrees in both directions, 
creating a mirror image 
around the blend axis. 

In addition, when the 360-
degree option is selected, a 
button appears. Click the but-
ton to reverse the gradient 
direction.

Rainbow. Select this to add all 
hues on the color wheel 
between the colors you set in 
the gradient. Click a direction 
button to select a clockwise or 
counter-clockwise path around 
the HSL color wheel, which 
sets the sequence of hues.

A

B

E

D

F

C
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The appearance of a gradient ink depends on several factors. Gr
ents appear smooth on monitors that display millions of colors, bu
can appear coarse and dithered on monitors that display only 256
ors. The more extreme the difference in colors, the coarser a grad
can appear. When a gradient has large color transitions, it appea
smoother in an object that is large enough to show all the transitio

Gradient styles and editing features

Applying gradients interactively
The Gradient Vector tool lets you drag in a document to set the 
shape, angle, and center of a gradient. You can use the tool to ap
gradient inks interactively to selected vector objects and text. 

The Gradient Vector tool is located in the Effects toolbar.

The Gradient Vector tool applies gradients based on the settings 
the Gradient manager in the Inks palette. You can select gradient
ors and styles in the Gradient manager. The Gradient Vector tool
applies the gradient as a fill ink or a pen ink according to which ic
is selected on the Gradient tab in the Inks palette.

Style Appearance and edit controls Edit box

Radial Colors sweep in a circle around the center. To move the center point, 
drag the open dot. To set the starting angle, drag the solid dot or enter 
the angle (0 to 360 degrees) in the text box.

Directional Linear gradient in which colors blend in the direction you specify. To set 
the gradient orientation, drag the solid dot, or enter an angle from 0 to 
360 degrees in the text box.

Shape Gradient conforms to basic object shapes. To move the gradient cen-
ter, drag the rectangle. To resize the center area that contains the end 
color, drag the solid handle and resize the rectangle.

Rectangular Rectangular-shaped gradient. To move the gradient center, drag the 
rectangle. To resize the center area that contains the end color, drag 
the solid handle and resize the rectangle.

Elliptical Elliptical-shaped gradient. To move the gradient center, drag the oval. 
To resize the center area that contains the end color, drag the solid dot 
and resize the oval.

Gradient Vector tool
.18 INKS: COLORS AND PATTERNS
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The Gradient Vector tool applies gradient inks to selected objects
more than one object is selected, the gradient flows across the 
selected objects as if they were one object.

To use the Gradient Vector tool

1 Select the objects that you want to apply a gradient ink to.

2 On the Gradient tab in the Inks palette, select the pen ink or f
ink icon to specify which ink to apply. 

3 Use the Gradient manager to configure the gradient.

Note: You can apply the current settings without opening the Grad
ent manager.   

4 Select the Gradient Vector tool, and then drag in the documen
position the gradient. As you drag, a vector indicates the gradient
style and position, and the gradient appears on the selected obje

You can drag inside or outside selected objects. For example, if y
are applying a directional gradient, you can “stretch” the gradient
dragging across the object, starting and finishing outside the obje
This places the start and end colors farther apart than if you drag
shorter distance within the object only. 

Modifying gradients
To modify a gradient after you apply it with the Gradient Vector too
leave the object selected while you change the Gradient manage
tings, and then use the tool to apply the new gradient to the objec

If you configure settings in the Gradient manager and then select
object that has a gradient ink, the object’s gradient appears in the
Gradient manager, replacing the current settings. 

If you use the Retain Selected Tool option in the Preferences dia
box, be sure to select another tool when you finish applying a gra
ent to avoid accidentally changing the gradient. 

Gradient styles

The shape of a gradient ink vector and the visual indicators you s
when you drag the Gradient Vector tool depend on the ink’s style
You can select the following gradient styles in the Style pop-up me
in the Gradient manager. 

Radial The gradient vector is a line that sets the center and angl
the gradient. The place where you begin to drag is the center poin
the gradient. The vector extends from and rotates around the cen
Gradient inks 12.19
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point. The angle of the line establishes the angle of the gradient. 
length of the line does not effect the gradient. 

Directional The gradient vector is a line that sets the angle and 
length of the gradient. The place where you begin to drag has the 
color of the gradient. The vector line extends from and rotates aro
the start point as you drag away from it. The angle of the line esta
lishes the angle. The place where you stop dragging sets the end 
of the gradient.

Shape The gradient vector is a rectangle that sets the size and l
tion of the end color of the gradient. The rectangle contains the e
color. Drag diagonally from one corner of the rectangle to anothe
The rectangle expands or contracts as you drag away from or tow
the starting point. When you finish dragging, the gradient conform
to the object’s shape.

Rectangular The gradient vector is a rectangle that sets the size a
shape of the gradient. The rectangle contains the end color of the
dient. Drag diagonally from one corner of the rectangle to anothe
The rectangle expands or contracts as you drag away from or tow
the starting point. 

Elliptical The gradient vector is an ellipse that sets the size and 
shape of the gradient. The ellipse contains the end color of the gr
ent. Drag diagonally from one corner of the ellipse’s bounding box
another. The ellipse expands or contracts as you drag away from
toward the starting point.

Hatch inks 
You use the Hatch tab in the Inks palette to apply hatch inks. The
Hatch manager lets you customize hatch inks. For general instruc
tions, see “Using Inks managers” on page 12.9.

Hatch inks are patterns made of groups of lines. You can specify
number of line groups and the angle, offset, and origin of each gro
You can assign a pen size, color, and dash to each line group, and
can select a fill ink to be the background of the hatch ink.

Hatch inks are often used in illustrations to distinguish different 
materials in cross sections, machine diagrams, and maps. 

Hatch tab in the Inks palette
.20 INKS: COLORS AND PATTERNS



 the 
 the 

 
nge 
ter 

e 

o 
s. 

ed 
ue 

 in 
s 
To select a line group for editing

When you create a hatch ink in the Hatch manager, click a line in
edit box to select the line group. Selection handles appear where
selected line group intersects the edit box. 

Line group attributes

You can set the following attributes for each line group in a hatch
ink. To change an attribute, select the line group you want to cha
by clicking it in the preview box in the Hatch manager, and then en
a new value in the appropriate text box. 

Pen The width in points (1/72 inch) of each line in the selected lin
group.

Angle The angle in degrees of the selected line group relative t
vertical. When you add a line group, the angle is initially 0 degree

Offset The horizontal starting position of the line group, measur
in points from the left edge of the preview box. Increasing this val
moves the line group to the right.

Origin The vertical starting position of the line group, measured
points from the top of the preview box. Increasing this value move
the line group downward.

Hatch manager

When you create a hatch ink, 
you can set the number of line 
groups and other attributes.

A Preview. Click a line group 
in the preview box to select it. 
Tiny handles appear where the 
selected group meets the edge.

B Pen color. Choose a color 
for the selected line group in 
the pop-up menu. You can 
choose a preset color or define 
a custom color; see “Creating 

custom colors in pop-up pal-
ettes” on page 12.15.

C Fill ink. Select an ink to use 
as the hatch ink background.

D Dash. Choose a dash pat-
tern for the selected line group.

Add Line. Click to add a new 
line group to the preview box.

Clear. Click to delete the 
selected line group (unless 
only one group is present).

See the next section for infor-

mation on setting Pen, Angle, 
Offset, and Origin.

A

B CD

✔Tip
If a hatch pattern overlaps the 
edges of an object, change the 
Pen value in the Hatch manag-
er to make the width of the 
hatch lines smaller than the 
pen size of the object’s stroke.
Hatch inks 12.21
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Symbol inks
You use the Symbol tab in the Inks palette to apply symbol inks. T
Symbol manager lets you customize symbol inks. For general 
instructions, see “Using Inks managers” on page 12.9.

A symbol ink is a pattern of vector objects. You can control the sp
ing and position of the objects in a symbol ink.

Creating symbol inks

You can create a symbol ink from any vector objects, as well as t
objects, in a Canvas document. You can use any of the Canvas d
ing tools to create vector objects for a symbol ink. You can apply 
inks and strokes to the objects before bringing them into the Sym
manager to create a new symbol ink.

1 Select the vector or text objects you want to use in a symbo
ink. You can select more than one object, including group objec

2 Drag the selected objects from the document into the previe
box in the Symbol manager.

3 Adjust the settings for the symbol ink in the Symbol manage

4 To store the new symbol ink in the palette, drag the ink from
the preview box to the grid area at the top of the Symbol tab.

Symbol tab in the Inks palette

Symbol manager

When you create a symbol ink, 
you can adjust the position and 
spacing of the objects and 
apply a backdrop ink.

A Preview box. To create a 
new ink, drag vector or text ob-
jects to the preview box. Ob-
jects you drag to the box re-
place the current contents.

B Backdrop. Select a back-
ground ink in the pop-up menu. 
You can select any ink, including 
a color, gradient, hatch, texture, 

and symbol ink. The ink you se-
lect appears behind the objects 
in the symbol ink.

C Preview zoom. Click the 
left button to reduce or the right 
button to enlarge the preview.

Align To Object. Turn on this 
option to keep a symbol ink in 
the same position if the object 
moves. Turn it off to let over-
lapping objects share a symbol 
ink without a gap.

A

B C
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Symbol spacing and position settings

In the Symbol manager, you can adjust the following settings to fi
tune a symbol ink.

Spacing These values set the distance between objects in the s
bol pattern as a percentage of the size of the original objects. For
example, a spacing value of 100 percent makes the distance betw
the objects equal to their size.

X Spacing is the horizontal distance between objects.

Y Spacing is the vertical distance between objects.

Stagger A positive value offsets the even-numbered rows of 
objects horizontally relative to the odd-numbered rows. To keep a
objects aligned, set Stagger to zero. To align alternating rows of 
objects, enter a higher Stagger value. To create a pattern in which
objects are spread out and objects in alternating rows are aligned 
the gaps in the rows above, set the X Spacing and Stagger value
100 percent. 

Scale The percentage of the original object size for the symbol in
A value of 100 percent maintains the original object size. To redu
the objects, enter a value smaller than 100 percent. To enlarge th
objects, enter a value greater than 100 percent.

Rotation The amount of rotation, specified in degrees, that Canv
applies to the original objects. 

Texture inks
You use the Texture tab in the Inks palette to apply texture inks. T
Texture manager lets you customize texture inks. For general ins
tions, see “Using Inks managers” on page 12.9.

A texture ink is a pattern of raster images. You can control the sp
ing, scaling, rotation, and offset of the images in a texture ink.

Canvas assembles a texture ink by repeating an image in rows a
columns, as if it were a grid of rectangular tiles. If you enter spaci
values that spread the images apart, you create gaps between th
image tiles; you can also include a background ink that will show 
through the gaps.

Creating texture inks

You can create a texture ink from any raster image object.
Texture tab in the Inks palette
Texture inks 12.23
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1 Drag an image from the document into the preview box in th
Texture manager in the Inks palette.

2 Adjust the settings for the texture ink in the Texture manage

3 To store the new texture ink in the palette, drag the ink from
the preview box to the grid area at the top of the Texture tab.

Texture manager

When creating a texture ink, 
you can set the spacing and 
offset of image tiles and 
choose a background ink.

A Preview box. To create a 
new ink, drag an image to the 
preview box. The image replac-
es the current contents.

B Backdrop. You can choose 
a background ink in the pop-up 
menu. The ink appears only in 
gaps between the image tiles.

C Preview zoom. Click the 
left button to reduce or the right 

button to enlarge the preview.

Spacing. Enter the amount of 
space between tiles as a per-
centage of the tile size. X Spac-
ing is the space between col-
umns; Y Spacing is the space 
between the rows of tiles.

Stagger. Select the horizontal 
button (left) or vertical button 
(right) and enter the distance 
(as a percentage of tile size) to 
shift the tiles.

Align To Object. Turn on this 
option to keep a texture in the 

same position if the object 
moves. Turn it off to let over-
lapping objects share a texture 
without a gap.

A

B C
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STROKES: OUTLINE EFFECTS

When you create objects with drawing tools, Canvas applies a str
to the objects according to attributes set in the Strokes palette. A 
stroke is a line centered on the path of vector objects and the outli
of type. You can shape a stroke with standard and calligraphic pe
parallel lines, even neon tubes. You can also add dashes and arr
heads to strokes.

This chapter explains basic stroke settings, how to customize stro
and how to apply strokes to objects and text.

Types of strokes
Canvas has three basic types of strokes plus arrows and dashes
which you can use to create unlimited variations. The following typ
of strokes appear on tabs in the Strokes palette.

Pen Strokes made of a single line. You can specify the width, sha
(standard or calligraphic), type of line joins, and shape of end cap

Parallel Strokes made of two or more lines. You can specify widt
dashes, colors, and spacing.

Neon Strokes shaded like glowing tubes. You can specify width
colors, tube shape, line joins, and end caps.

Arrows and dashes can be applied to strokes for additional effect
Two tabs in the Strokes palette contain settings for these attribute

Arrow You can use preset or custom arrowheads that appear at
endpoints of each path segment. 

Dash You can apply preset or custom dash sequences that divid
solid strokes into solid and blank segments.

How inks affect strokes

You define the colors that apply to strokes separately from the str
settings. The pen ink (specified in the Inks palette) and the stroke
tings together produce the appearance of an object’s outline. The
ink is the color (or pattern) that “paints” the object’s stroke. There
fore, the object must have a visible pen ink for the stroke to be vis
ble. Conversely, the object must have a stroke for the pen ink to b
visible. 

Pen

Parallel 

Neon

Arrow

Dash
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Some inks can make strokes invisible. If the pen ink is set to “no 
ink,” the stroke won’t be visible. Also, if the pen ink is set to white o
a color that matches the background, the stroke could disappear 
against the background.

Applying strokes
The Strokes palette is the control center for all aspects of strokes
You can use the Strokes palette to apply strokes to objects, creat
custom strokes, add strokes to the palette, and save strokes in fil
that you can later load into the palette.

Preset strokes and controls for customizing strokes are on the Pe
Parallel, and Neon tabs in the Strokes palette. Presets and contro
customizing arrows and dashes are on the Arrow and Dash tabs.

Current stroke

The strokes icon in the toolbox shows a sample of the current stroke, 
the stroke that Canvas applies to new vector objects you create. 
example, if the current pen stroke is 3 points wide, new objects y
draw will have a 3-point pen stroke. Canvas does not apply the c
rent stroke to text; see “Applying strokes to text,” next.

To change the current stroke, deselect all objects and apply the st
you want; the stroke icon in the toolbox shows the new current 
stroke. If you select an object and change its stroke, however, the
rent stroke for new objects does not change. 

When you first install Canvas, the current stroke defaults to a 1-po
pen stroke without dashes or arrowheads.

Applying strokes to text

You can apply strokes to text the same as to vector objects, in m
cases. For information about selecting text objects and text chara
ters, refer to the Text and Typography chapters.

When you first type or import text into a document, Canvas applie
1-point pen stroke to the text, but does not assign a pen ink, so th
text is not visible. 

◆ To make text strokes visible: Select the text or text objects and
apply a visible pen ink using the Inks palette. If you select a text 
object, Canvas applies a stroke to all the text it contains. If you se
specific characters within a text object, Canvas applies the stroke
those characters only. 

Strokes icon
.2 STROKES: OUTLINE EFFECTS
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You can apply pen, parallel, and neon strokes to text. You can al
apply dashes to text that has a pen or neon stroke.

Note: The appearance of a parallel stroke applied to text might no
appear as you expect, especially on characters with hollow cente
(such as “O” and “P”) and characters with tight corners or paths t
meet or cross (including “G” and “X”).

Removing a neon or parallel stroke from text (by choosing “no 
stroke” on the Neon or Parallel tab) does not remove the stroke 
entirely. Instead, the stroke reverts to a 1-point pen stroke.

Using preset strokes
The Strokes palette contains preset strokes and properties that y
can apply to objects and to the current stroke. Using presets can 
you save time and ensure graphic consistency.

Presets for pens, parallel lines, neon strokes, arrows, and dashes
displayed in scrolling lists on the associated tabs in the Strokes p
ette. You can use the Strokes icon in the toolbox to apply preset 
strokes.

You can also create custom strokes, arrows, or dashes and add t
to the presets on the appropriate palette tab so you can use them
again. For information about creating and storing strokes, see “C
tomizing strokes” on page 13.8.

To apply preset strokes to objects

Use the following general procedure to apply a preset stroke to on
more objects.

1 Select the objects for which you want to change strokes.

2 Press the Strokes icon in the toolbox to open the Strokes pa
ette. You can use the palette when it’s attached to the toolbox, o

Calligraphic pen stroke Neon stroke

✔Tip
You can drag a stroke from the 
Strokes palette to an object to 
apply the stroke without first 
selecting the object.
Applying strokes 13.3
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you can drag the palette away from the toolbox to keep it open 
while you work. You can dock the palette on the Docking bar.

3 Depending on the type of stroke you want, choose the Pen, 
allel, or Neon tab.

4 Choose a stroke in the preset strokes list. If necessary, use
scroll bar or window resize button to view additional strokes. Ca
vas applies the stroke you choose to selected objects.

To make a preset stroke the current stroke

You can choose a preset stroke as the current stroke to apply to 
objects you create.

1 Deselect all objects in the current document. To deselect al
objects, press Enter (Mac) or Esc (Windows) a few times, or un
no bounding boxes are visible.

2 Press the Strokes icon in the toolbox and choose the Pen, P
lel, or Neon tab, depending on the type of stroke you want.

3 Choose a stroke in the preset strokes list. Use the scroll bar
view additional strokes. The Strokes icon in the toolbox shows t
current stroke.

Using standard pen strokes
The most common type of stroke is a standard pen stroke, a solid
of uniform width (unless you select the Calligraphic option). This 
type of stroke is used for many situations, such as technical illust
tions, flowcharts, callout lines, arrows, and dashes.

Preset strokes Use the scroll bars 
or the resize 
button to view 
more presets

Floating Strokes palette

The palette appears slightly dif-
ferent when attached to the 
toolbox; the title bar and the 
items below the scroll list are 
not displayed.

Current stroke
Pop-up menu
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By default, the width of pen strokes is measured in points (one po
is 1/72 of an inch). Pen stroke widths from 1 to 20 points appear 
the Pen tab’s presets list.

◆ To change the current pen width: Deselect all objects, then 
select a new stroke on the Pen tab of the Strokes palette.

◆ To change the stroke width of specific objects: Select one or 
more objects, then select a new stroke on the Pen tab.

To change the color of a pen stroke

The color of a pen stroke comes from the object’s pen ink color. T
pen ink can be a complex multi-color pattern or gradient, or a soli
color.

1 Select one or more objects whose pen ink you want to chan

2 Press the Pen Ink icon in the toolbox. The Inks palette open
from the toolbox; you can drag this palette away from the toolbo
to keep it open as you work.

3 On one of the tabs in the Inks palette, choose a color, gradi
hatch, symbol, or texture; see “Inks: colors and patterns” on 
page 12.1.

‘Invisible’ inks

A pen ink is one or more colors that Canvas uses to apply color t
pen strokes. The pen ink can be set to “no ink,” or to a color that 
blends into the background, which renders a pen stroke invisible.

In some situations, you might want to set an object’s pen ink to “n
ink,” rather than remove the object’s stroke. This can be useful to
temporarily hide the stroke without removing the dash, arrow, and
other stroke settings, for example. 

To set an object’s pen ink to “no ink”

This procedure removes the pen ink and makes the stroke invisib

1 Select the object and press the Pen Ink icon to open the Ink
palette. 

2 On the Color tab of the Inks palette, choose the first item, a b
crossed by a diagonal line. If colors are listed by name, select “n
ink” at the top of the list. 

Pen ink color changed from 
black to Pantone 123

“No ink” setting
Applying strokes 13.5
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Adding preset arrows to strokes
You can use preset arrowheads to create pen, parallel, and neon
strokes with arrows. You can apply strokes with arrows to lines a
open paths, such as those created with the Curve tool. Arrowhea
can appear at one or both endpoints of a path. 

You can also create custom arrowheads that you can add to the p
arrowheads; see “Customizing arrows” on page 13.14.

To add arrows to strokes

Use the following procedure to apply preset arrows to objects or t
current stroke:

1 Depending on how you want arrows to apply, do one of the f
lowing:

• To add an arrow to the current stroke, deselect all object

• To add arrows to specific objects’ strokes, select the 
objects. 

2 Press the Strokes icon in the toolbox to open the Strokes pa
ette; select the Arrow tab. 

3 The buttons at the top of the tab let you choose between sta
ing, ending, and double-sided arrowheads. To select a placeme
click a button; the chosen button appears recessed. The arrows
the scroll list preview the selected arrowhead.

4 In the scroll list, choose the arrow that you want to apply. Th
arrow applies to selected objects or to the current stroke.

Adding dashes to strokes
You can add a variety of preset dash sequences to pen and neon
strokes. You can apply a stroke with dashes to most objects, incl
ing lines, open and closed Bézier curves, polygons, rectangles, o
and stars.

Parallel line strokes can also include dashes. However, you selec
dashes for parallel lines when you customize the stroke on the Pa
lel tab. For details, see “Customizing parallel line strokes” on 
page 13.18.

Starting arrow Ending arrow Double-sided
.6 STROKES: OUTLINE EFFECTS
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To add dashes to pen and neon strokes

1 Depending on how you want dashes to apply, do one of the 
lowing:

• To apply dashes to the current stroke, deselect all object

• To apply dashes to an object that has a pen or neon stro
select the object.

2 Press the Strokes icon in the toolbox to open the Strokes pa
ette. Choose the Dash tab. 

3 Choose the dash sequence that you want in the list of prese

Removing arrows, dashes, and strokes
You can remove a selected object’s stroke, or set the current strok
“no stroke,” so you can create objects that have no stroke. An ob
that has no stroke has no visible outline. Objects drawn with the L
tool become invisible without a stroke; other objects are still visible
they have a visible fill ink. 

You can also remove dashes and arrows from a stroke. Because
arrows and dashes are attributes of strokes, you can remove them
without removing the entire stroke. 

Removing arrows, dashes, and strokes involves the same proced
as changing from one preset stroke to another.

To remove arrows or dashes

You can use the following procedure to remove arrows from pen,
parallel, and neon strokes, and to remove dashes from pen and n
strokes. For details about removing dashes from parallel strokes,
“Customizing parallel line strokes” on page 13.18.

1 Depending on how you want to remove arrows or dashes, d
one of the following:

• To remove stroke attributes from an object, select the 
object. 

• To remove stroke attributes from the current stroke, desel
all objects.

2 Press the Strokes icon in the toolbox to open the Strokes pa
ette. Choose the Dash or Arrow tab, depending on the attribute 
want to remove.
Applying strokes 13.7
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3 Choose “no arrow” on the Arrow tab to remove arrows from
stroke. Choose “no dash” on the Dash tab to remove dashes.

To use “no stroke” settings

You can remove strokes entirely from objects, or use “no stroke” 
the current setting for new objects.

1 Depending on how you want to remove strokes, do one of t
following:

• To remove the stroke from an object, select the object. 

• To make “no stroke” the current setting, deselect all objec

2 Press the Strokes icon in the toolbox and choose “no stroke”
the Pen, Neon, or Parallel tabs.

Customizing strokes
Each tab in the Strokes palette has a configuration manager, an area 
that can be rolled down at the bottom of the palette to reveal optio
for customizing strokes. 

You can use the configuration managers to

• display the strokes settings of selected objects

• create custom pen, parallel, and neon strokes

• create custom arrowheads and dash sequences

• apply custom settings to objects or the current stroke

• store custom strokes as presets in the palette

• save preset strokes in files on disk

• load preset strokes that have been saved in disk files

To use the configuration managers

You must tear off the Strokes palette from the toolbox to use the c
figuration managers, delete presets from the palette, and load, sa
or delete strokes saved to disk.

1 To open the Strokes palette, press the Strokes icon and drag
palette away from the toolbox.

The Strokes palette opens as a floating palette. You can drag the
ette by its title bar to move it.

2 Click the tab you want to use to bring it to the front, if neces
sary.
.8 STROKES: OUTLINE EFFECTS
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3 Click the triangle button at the bottom left corner of the palet
to open the configuration manager for the front tab.

The configuration manager stays open as you click other tabs in 
palette, and the display changes to reflect the available options fo
tab.

◆ To roll up the configuration manager: When the configuration 
manager is open, click the down-facing triangle button at the left 
the palette.

Choosing settings to customize

You can use the configuration managers to customize the setting
an object’s stroke, the current stroke, or one of the preset strokes
stroke attributes. You can also create custom strokes.

• To customize an object’s stroke, select the object and op
the appropriate manager in the Strokes palette.

• To use a preset stroke as the basis for a custom setting, 
apply the preset to an object and then select the object. T
displays the settings in the manager on the appropriate t
You can also simply choose the preset in the scroll list; 
however, this also changes the current stroke or the stro
of any selected objects.

To apply custom settings to objects

You can apply custom settings from the Strokes palette to an obj
in two ways:

• Select one or more objects before you begin adjusting th
settings in the configuration manager. To apply the settin
to the selected objects, click Apply.

• If you customize the settings before selecting any objects
you can apply the settings to objects by dragging from th
sample window at the bottom of the palette to an object.

Configuration manager button

✔ Important 
If you adjust the settings in a 
configuration manager, and 
then select an object, the set-
tings will change to reflect the 
object’s settings. If you don’t 
want to lose custom settings 
when no objects are selected, 
add them to the palette, or 
apply them to an object; see 
“Adding custom settings to the 
palette,” next.
Customizing strokes 13.9
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Adding custom settings to the palette

You can add custom strokes, arrows, and dashes to the Strokes 
ette. When you add custom items, they become presets that you
use the same as default preset items. You can apply a customize
set to objects or make it the current stroke.

◆ To add custom settings from the configuration manager to 
the palette: Drag from the sample window at the bottom of the pa
ette to the presets list at the top. The settings become a preset, w
graphic representation or description added to the end of the list.

◆ To add settings from an object to the palette: Select the 
object. Its settings appear in the appropriate configuration manage
the Strokes palette. Drag from the sample window at the bottom o
the tab to the presets list at the top.

When you end a Canvas session, the program stores each tab’s 
sets with the program. Because Canvas stores the preset strokes
inks, the same presets can always be available, whether you wor
with new documents, documents you created, or documents crea
by another Canvas user.

If you create a custom stroke and want to apply it to more than on
object, and especially if you want to use it in a later work session, 
should store the custom settings in the presets area of the palette

Deleting presets from the palette

You can remove default and custom presets from the Strokes pal
When you delete a preset, Canvas permanently removes it from 
palette, unless you save it to disk and load it again; see “Saving a
loading strokes settings,” next.

◆ To remove a preset from the palette: Drag the preset to the 
trash can icon below the presets scroll list. The trash can appears
when the Strokes palette is floating or docked on the Docking bar

◆ To remove all preset strokes from the tab: Choose “Clear 
Palette Strokes” in the pop-up menu.

Note: If you delete all arrowheads from the palette, dimension 
objects will not have arrows.

Saving and loading strokes settings
You can save preset strokes, arrows, and dashes in files on disk,
load the presets into the Strokes palette. You can use these strok
files to customize the Strokes palette for particular projects or typ

Drag from the sample window to 
the scroll list, as highlighted
.10 STROKES: OUTLINE EFFECTS
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of documents, and to exchange custom settings with other Canva
users.

Commands for saving and loading strokes files are in a pop-up m
on the Strokes palette. The menu icon appears only when the Str
palette is separated from the toolbox.

To save strokes in a file

Use the following procedure to save the presets from one tab in t
Strokes palette to a file on disk.

1 To open the Strokes palette, press the Strokes icon and drag
palette away from the toolbox. The Strokes palette opens as a f
ing palette.

2 Click the tab you want to use to bring it to the front.

3 Adjust the settings in the palette, if necessary, until you hav
the presets you want to save.

4 Press the right-triangle button on the right of the palette and
choose Save Strokes in the pop-up menu. A directory dialog bo
opens. 

5 Type a name for the palette file, select a location on a disk, a
click Save.

To load strokes from a file

Use the following procedure to load presets from a strokes file on
disk to a tab in the Strokes palette. When you load a strokes file, 
can replace a tab’s presets with the file’s presets or add the prese
saved in the strokes file to those currently in the palette.

1 To open the Strokes palette, press the Strokes icon and drag
palette away from the toolbox. The Strokes palette opens as a f
ing palette.

2 Click the tab you want to use to bring it to the front.

3 Press the right-triangle button on the right of the palette and
one of the following, depending on whether you want to replace 
current presets:

• To replace the tab’s presets with those in the strokes file
choose Load Strokes.

• To add the presets in the strokes file to those currently in 
palette, choose Append Strokes.

Right-triangle button 
pop-up menu
Customizing strokes 13.11
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4 A directory dialog box opens. Locate the strokes file you wa
to open and click Open.

Customizing pens
In the Pen manager, you can choose from the following options:

• standard or calligraphic pen styles, also known as “nibs.”
Standard pens have a uniform width. Calligraphic pens ha
a separate width, weight, and angle setting.

• bevel, miter, or round line joins

• flat, round, or square end caps

For basic information about setting pen size, see “Using standard
strokes” on page 13.4.

◆ To create a custom pen width: In the Pen manager, choose 
Standard in the pop-up menu, and set the width in the Width text b
The sample window at the bottom of the manager shows the curr
settings; drag from this window to the scroll list to add the pen stro
to the presets.

To create a calligraphic pen

The calligraphic option lets you create a pen stroke with a custom
weight, width, and angle. The shape of a calligraphic stroke varie
depending on the stroke’s path.

1 In the Pen manager, choose Calligraphic in the pop-up men
Weight, Width, and Angle text boxes and an editing box appear
the configuration manager.

2 To set the width of the pen, enter a value in the Width text bo
or drag the thin red arrow in the edit window. The width is the ma
imum thickness of the stroke when it is perpendicular to the pen
angle. 

3 To set the weight of the pen, enter a value in the Weight tex
box, or drag the thick blue arrows in the edit window. The weight
the maximum thickness of the stroke when it is parallel to the pe
angle.

4 To set the pen angle, enter a value in the Angle text box or d
an arrow in the edit window.

For the most calligraphic effect, the weight and width values shou
be dissimilar (at least by a factor of three or four) and the angle se
approximately 45 degrees.

✔Tip
You can choose millimeters, 
inches, or picas instead of 
points as the pen size unit 
using the Preferences com-
mand in the File menu. 
.12 STROKES: OUTLINE EFFECTS
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Choosing line joins and end caps
Pop-up menus in the Pen manager let you specify the type of line
joins and end caps. Line joins determine appearance of two path
ments that meet at a corner. End caps specify the shape of the e
points of an open path.

Line joins

Canvas has three types of line joins: miter, round, and bevel. For
set pen strokes, Canvas indicates the type of line join in the scroll
on the Pen tab.

Miter Joins path segments with sharp corners that extend to a si
point. When you choose miter joins, an additional pop-up menu le
you set the miter limit in degrees (5, 10, 30, 60, or 90 degrees). 

The miter limit setting tells Canvas which corners are too tight to 
miter; Canvas bevels these corners instead. In other words, if the
miter limit is set to 10 degrees, and two path segments join at an 
angle of 9 degrees, Canvas bevels the corner rather than creatin
miter join. The miter limit lets you prevent long, spiked corners tha
might result as a combination of a wide pen size and a small ang

Pen manager

These settings let you create 
Calligraphic pen types.

A Choose Calligraphic in the 
pop-up menu.

B Specify weight, width, and 
angle of the pen nib. You can 
set the units of measure for 
these settings using the Prefer-
ences command in the File 
menu.

C Configure line joins and end 
caps using the pop-up menus; 
see the next section for informa-
tion on these settings.

D Sample window of the cur-
rent pen settings.

E Edit the size and angle of 
the nib interactively in this edit 
window (see inset).

F Use the zoom buttons to in-
crease or reduce the size of the 
nib in the edit window. This 
does not affect the actual pen 
size.

In the edit window, you can 
drag control points to adjust 
the pen nib.

G Drag to change the width 
and angle of the nib.

H Drag to change the weight 
and angle of the nib.

A

B

D

C

F

G

H

E

Customizing pens 13.13
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Round Smooths corners, so the joint is rounded instead of point
or flat. 

Bevel Squares off path segment corners, so that the joint appea
flat rather than rounded or pointed. 

End caps

Canvas has three types of end caps. For preset pen strokes, Can
indicates the type of end cap in the scroll list on the Pen tab.

Flat The end of the stroke is flush and square with the end of an
open path or dash. By default, end caps use this setting.

Round A semi-circular cap extends half the pen width beyond th
endpoint of an open path or dash.

Square The stroke tip is square, similar to the Flat option, but 
extends half the line width beyond the endpoint, like the Round 
option.

Customizing arrows
You can create starting, ending, or double-sided arrowheads usin
the Arrow manager. You can create double-sided arrowheads tha
identical or entirely different. Canvas has several preset arrowhea
styles that you can use and edit, or you can use any vector, paint
text object as an arrowhead. 

To create a custom arrowhead

1 Create a vector, text, or paint object to use as an arrowhead
You can also edit a preset arrowhead or an arrowhead style of a
existing object by selecting the preset or object.

Round joinBevel joinMiter join, miter limit = 2˚ Miter join, miter limit = 10˚

Flush with endpoint

Rounded at endpoint

Square at endpoint
.14 STROKES: OUTLINE EFFECTS
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2 With the Strokes palette floating, select the Arrow tab and ro
down the Arrow manager, if necessary.

3 To choose whether you want to create a starting or ending 
arrowhead, or both, click a button at the top of the tab. The sam
windows at the bottom of the configuration manager show or hid
depending on the button you click.

4 For double-sided arrowhead styles, click a sample window t
choose which arrowhead you want to work with. To edit both sid
simultaneously, select Mirror.

5 Drag the object you want to use as an arrowhead to the edi
window in the configuration manager.

6 Configure the arrowhead settings described below.

A

B

DC

E

F

G

Arrow manager

Use these options to create a 
custom arrowhead or edit a 
preset arrowhead.

A You can drag objects to this 
edit window to use them as ar-
rowheads. A preview of select-
ed presets or objects also ap-
pears here.

B Use these zoom buttons to 
magnify the edit window view. 
Changing views does not 
change the arrowhead’s actual 
size.

C Shows the starting arrow-
head, and isn’t visible when us-
ing only ending arrowheads. 
When working with double-sid-
ed arrowheads, click this win-
dow to select the starting arrow.

D Previews the ending arrow-
head and isn’t visible when us-
ing only starting arrowheads. 
When working with double-sid-
ed arrowheads, click this win-
dow to select the ending arrow.

Arrow edit window

You can move and resize the 
object in the edit window to 
fine-tune the arrowhead.

E Drag these control points to 
resize the arrowhead.

F Indicates the horizontal axis 
of the path’s endpoint.

G Indicates the vertical axis of 
the path’s endpoint.

Center. Click the buttons to 
align the center of the arrow-
head horizontally and vertical-
ly on the path’s endpoint.

Flip. Click the buttons to flip 
the arrowhead horizontally and 
vertically.

Mimic Pen. Turn Size and Col-
or on to apply the pen width 
and ink of the path to the 
arrowhead.

Place on Segments. Turn this 
option on to add arrows to 
each segment of an object.

Mirror. Turn on to make dou-
ble-sided arrowheads mirror 
images of each other.
Customizing arrows 13.15
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Customizing dashes
Dashes are composed of alternating solid and blank segments. U
the Dash manager, you can customize the length of up to 13 seg
ments to create new, complex dash sequences.

You can design dashes interactively using the edit window. To pr
cisely set the length of each dash segment, you can also specify 
exact length. The ruler in the Dash manager displays inches; how
ever, you can enter dash lengths in inches, points, millimeters, or
picas; see “Measurement units preferences” on page 9.14 for det

Dashes in the Strokes palette always appear as 1-point wide, bla
and white segments. However, when you apply these dashes to 
object’s pen, the black segments adopt the color and size of the p
and the white segments become transparent.

◆ To create a custom dash sequence: With the Strokes palette 
floating, select the Dash tab and open the Dash manager, if need
Use the edit window and Length text box to design the sequence
described next. 

Dash stroke

Dash manager

Use these controls to create 
custom dashes.

A Click to move the edit win-
dow view left or right. 

B To change the length of a 
segment, drag a segment edi-
tor. You can type a number in 
the Length box. When you se-
lect or drag a segment, it high-
lights.

C To zoom in, click the right 
button. To zoom out, click the 
left button. You can change 
magnification in steps from 
100% to 1000%.

D To add a segment, drag to 
the left from the segment edi-
tor. The segment editor re-
mains at the right of the window 
until you create the maximum 
13 segments.

E The segment’s number (its 
order in the sequence) and its 
color. “Black” indicates it will 
appear in the color of the pen 
ink, and “White” indicates it will 
be transparent.

F Displays a sample of the 
current settings.

Proportional. Tells Canvas to 
scale the length of the seg-
ments to match the pen width 

of the object. The length of 
segments in the Dash manager 
are based on a 1-point line. 
Therefore, if the pen width is 6 
points and Proportional is 
selected, Canvas multiplies the 
lengths by six.

F

B

E

D

A A

CC
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Customizing neon strokes
You can create custom neon strokes using the Neon manager in
Strokes palette. You can specify the width, colors, line joins, and e
caps for neon strokes. You can create uniform and calligraphic ne
strokes.

To create custom neon strokes

1 In the Strokes palette, select the Neon tab and open the Ne
manager, if necessary. 

2 Select Standard or Calligraphic style and other options 
(described next).

3 The preview windows reflect the current settings. You can u
the magnification buttons below the preview window to get a clo

Neon manager

A Choose Standard or Calli-
graphic. Standard neon strokes 
are uniform thickness. Calli-
graphic strokes can vary de-
pending on the stroke angle.

Standard options

Weight: Enter the stroke thick-
ness in points.

B Select the line join type, mi-
ter limit angle (for miter line 
joins), and end cap shape.

C Select the color for the in-
side and outside parts of the 
neon stroke.

D Drag the stroke preview to 
an object to apply it, or drag it 
to the top of the palette to store 
it as a preset neon stroke.

E Preview the current stroke. 
Click the zoom buttons to zoom 
the preview in or out.

Partial: Select this option for a 
neon stroke with the outside 
color along only one edge.

Calligraphic options

In the text boxes, enter the 
Weight and Width values in 
points, and the angle in 
degrees. When the angle is 0 
or 180 degrees, Weight 
applies to vertical segments; 
Width applies to horizontal 

segments. At angles of 90 and 
270, the values are reversed. 
At Angles of 45, 135, 225, and 
315, vertical and horizontal 
segments are the same thick-
ness. 

F Edit the calligraphic stroke 
interactively. Drag a blue handle 
to change the Weight and An-
gle. Drag the red arrow to 
change the Width and Angle.

A

B

E

C

D

F

Customizing neon strokes 13.17
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look at the neon effect. Keep in mind that low width settings mig
make it difficult to see the neon effect.

4 Select colors for the neon stroke from the pop-up palettes. C
vas blends these colors to create the neon effect. To make the s
appear round, experiment with lighter inside colors and darker o
side colors.

5 Click Apply to apply the current stroke to selected objects or
make it the current stroke if no objects are selected.

Customizing parallel line strokes
You can create custom parallel line strokes using the Parallel ma
ager in the Strokes palette. You can specify the number of lines, 
color, dash pattern, and pen size of each line, and the spacing of 

◆ To create custom parallel line strokes: With the Strokes pal-
ette floating, click the Parallel tab to bring it to the front and open t
Parallel manager, if necessary. Configure the settings in the mana
described below.

Parallel manager

Use these controls to create 
custom parallel line strokes.

A Enter the number of parallel 
lines you want.

B Choose a number in the 
pop-up menu to select a line to 
edit (“1” is the bottom line). You 
can also click a line in the pre-
view window (C) to select it.

C Previews the current set-
tings and indicates which line is 
selected by displaying handles.

D Use these pop-up menus to 
apply pen width (Pen), pen color 
(Color), and dashes (Dash) to 
the selected line. The pop-up 
menus contain preset strokes 
and colors. You can also specify 

custom pen colors; see“Creat-
ing custom colors in pop-up 
palettes” on page 12.15.

Spacing. Enter a number to 
specify the distance between 
the selected line and the one 
below it. For Line #1, this set-
ting defines the space 
between this line and Line #2.

Use pen ink. Turn on this 
option to apply a color to the 
spaces between the parallel 
lines.

Equidistant. Turn on this 
option to apply the spacing 
setting for the selected line to 
all lines.

Identical. Turn this option on 
to give all parallel lines the 

same pen size, color, and dash 
as the selected line.

Orientation. Choose Center, 
Outside, or Inside to specify 
the placement of parallel lines 
relative to the path of the 
object.

C

B

A

D
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SPRITELAYER EFFECTS

SpriteLayer effects let you apply transparency to objects and text
You can use SpriteLayer transparency to create collages, web gr
ics, layered illustrations, “ghosted” text, vignettes, and texturing.

Using the Transparency palette
The Transparency palette is a control center for SpriteLayer effect
is a floating palette that can stay open on screen and can be dock
the Docking bar. The palette includes controls and options for op
ity, masks, transparency scope, and transfer modes. 

• Use the Opacity slider to set the opacity of a selected obje
The effect is the same as using the Opacity slider in the to
box. See “Opacity effects” on page 14.2.

• Use the Scope options to control transparency effects in 
vector objects. See “Controlling the scope of transparenc
effects” on page 14.5.

• Apply channel masks and vector masks using the Mask 
menu. See “Transparency masks” on page 14.6.

• Change the transfer mode of a selected object using the 
Transfer Mode menu. See “Using transfer modes” on 
page 14.19.

The palette works with a single selected object. The controls in th
palette are not available when more than one object is selected.

Opening the Transparency palette

Do any of the following to use the Transparency palette:

• Press the Opacity icon in the toolbox. When the Opacity 
slider pops open, drag it away from the toolbox. The pale
appears when you release the mouse button.

• Choose Window > Palettes > Transparency…. 

• Choose Object > SpriteLayers > Show Palette. 
14.1
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Opacity effects
Opacity is a basic transparency effect that can be applied to any 
object. 

When an object’s opacity is less than 100%, the object appears p
transparent. You can reduce the opacity of a text object, for exam
so a background image is visible through the type.

You use the Opacity slider to set the opacity of objects. The Opac
slider is available in the toolbox and in the Transparency palette. T
slider in the toolbox will set opacity for one or more selected objec
The slider in the Transparency palette is available only when a sin
object is selected.

Opacity affects the overall transparency of an object, so the Opac
slider is a master control for all transparency effects applied to an
object. 

For example, you can use a channel mask to make an oval vigne
from a photograph. At the edge of the oval, the photograph becom
completely transparent. If you then reduce the opacity, the visible
part of the image becomes partly transparent.

Transparency palette 
options

Options for opacity, transfer 
mode, scope, and masks 
appear in the Transparency 
palette. When an object is 
selected, the Transparency pal-
ette displays the object’s opac-
ity and transfer mode.

Opacity. Drag the slider or 
enter a percentage to set the 
opacity of a selected object.

Scope. Set the transparency 
scope for a selected vector 
object.

A Click to show or hide the 
mask options.

B Choose Channel to 
create a channel mask. 
Choose a vector mask 
style to create a vector 
mask. If the object has a 
mask, the menu shows the 
type of mask. Choose 
None to remove the ob-
ject’s mask.

Edit. When a selected 
object has a channel mask 
or vector mask, click Edit 
to edit the mask.

C When a masked object 
is selected, mask options 
appear in this area.

A

B

C

.2 SPRITELAYER EFFECTS
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When an object’s opacity is less than 100%, anything in the back
ground, including the illustration area, can affect the object’s appe
ance. The appearance of colors in an object can also be affected
the object’s transfer mode. See “Using transfer modes” on 
page 14.19.

To set the opacity of objects

1 Select the objects whose opacity you want to change.

2 Do one of the following to use the Opacity slider:

• Windows: Click the Opacity icon in the toolbox and the 
Opacity slider appears. Drag the slider or click in the sca
to adjust the opacity setting. 

• Mac: Press the Opacity icon in the toolbox and the Opaci
slider appears. Drag in the scale to adjust the opacity set
ting.

3 Drag the Opacity slider to the left to decrease opacity; drag 
the right to increase opacity. The opacity percentage appears a
right of the slider.

Defining opacity

“Transparency” and 
“opacity” are opposite 
terms that describe the 
ability to see through an 
object. 

Greater transparency 
means it is easier to see 
through something; 
greater opacity means it 
is harder to see though it.

In percentages, 100% 
opacity equals 0% trans-
parency. Those values 
describe objects you 
can’t see through. 1% 
opacity equals 99% trans-

parency. Those values 
describe almost com-
pletely clear objects.

All Canvas objects have 
an opacity. You can set 
opacity from 1% to 100% 
in 1% increments. The 
opacity of a new object is 
100%. When you copy an 
object, the copies have 
the same opacity as the 
original object.

In this manual, the word 
“transparency” is often 
used as a general term for 
several related effects. 

The word “opacity” is 
used to refer to a specific 
effect and a specific prop-
erty of objects. 

In other words, an 
object’s “transparency” 
can result from various 
factors, including ink set-
tings, the transfer mode, 
a channel mask, or anoth-
er effect. An object’s 
“opacity,” on the other 
hand, is a specific setting 
controlled by the Opaci-
ty slider.
Opacity effects 14.3
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If no objects are selected when you press the Opacity icon, the O
ity slider isn’t available.

The Opacity icon in the toolbox displays an opacity scale. When a
object is selected, a line in the scale indicates the object’s opacity
ting. The left end of the scale represents 1% opacity and the right
represents 100% opacity. 

In the Transparency palette you can adjust the opacity of a single
selected object. To set a selected object’s opacity, drag the Opac
slider or enter a percentage from 1% to 100% in the text box.

The Transparency palette also lets you specify the scope of an 
object’s opacity setting. See “Controlling the scope of transparen
effects,” next, and “Using the Transparency palette” on page 14.1

Setting opacity for multiple objects

You can use the Opacity slider in the toolbox to set the opacity fo
more than one object. In contrast, the Opacity slider in the Transp
ency palette is not available when more than one object is selecte

Using the Opacity slider in the toolbox when multiple objects are 
selected will apply the same opacity setting to each selected obje

To adjust the opacity of a group object, you can use the Opacity 
slider in the toolbox or in the Transparency palette, because a 
selected group object is considered one object.

Opacity applies to a group object as if it were a single object. This
different than changing the opacity of multiple selected objects th
aren’t grouped.

Drag the Opacity slider to set the opacity of selected objects

✔Tip
You can set opacity quickly by 
Tab-clicking the opacity scale in 
the toolbox. A line in the scale 
shows the setting. Click the 
middle of the scale to set opaci-
ty to about 50%. 
.4 SPRITELAYER EFFECTS
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When a group object is selected, changing the opacity applies to 
group as a whole. Objects that were opaque do not become trans
ent to other objects in the group if you reduce the opacity of the gr
object. 

If you ungroup an object, the group opacity setting is removed an
the opacity of each separate object is restored.

Consider a group of three objects whose opacities are 30%, 60%,
100%. If you set the opacity of the group object to 50%, the opaci
of the individual objects will appear to be 15%, 30%, and 50% rel
tive to the background. If you ungroup the objects, their opacities w
be restored to 30%, 60%, and 100%.

Controlling the scope of transparency effects
All vector objects have scope settings that control what parts of th
objects are affected by transparency. 

The scope setting can limit transparency to an object’s fill ink only
Or, it can apply transparency to the fill ink and the pen ink on the 
object’s stroke. 

The scope setting controls all transparency effects applied to vec
objects, including opacity, channel masks, vector masks, and tran
modes. 

Each vector object has a scope setting. Scope settings do not aff
text objects, paint objects, or group objects.

You can change the scope setting of a selected vector object usin
Transparency palette. An object’s scope setting remains the sam
unless you use the Transparency palette to change it. See “Using
Transparency palette” on page 14.1.

The scope setting can affect the time needed to print an object. W
an object has a reduced opacity setting (but no other transparenc
effects) and the scope is Fill, Canvas can print the object on Post
Script printers without rendering. If the scope is Fill & Stroke, Can
vas renders the object and prints it as an image. An image usuall
contains more data than a vector object, so this can increase the
required to print an object.

To set an object’s transparency scope

1 Select a vector object.

2 In the Transparency palette, select a Scope option:

Fill

Fill & Stroke
Controlling the scope of transparency effects 14.5
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• To apply transparency effects to the entire object, select F
& Stroke. 

• To apply transparency effects to the object’s fill ink only, 
select Fill. 

Transparency masks
Transparency masks let you create complex transparency effects
You can use transparency masks with vector, paint, text, and gro
objects.

Channel masks and vector masks are the two types of transparency 
masks available. You can apply either mask type to vector, text, 
paint, and group objects. An object can have only one mask, but 
can have a mask along with other effects such as opacity and tran
mode.

A channel mask creates transparency based on a grayscale imag
channel mask is part of an object, the same way an image chann
part of a paint object. You can use painting tools and image-editin
techniques in a channel mask. For example, you can make a vign
by painting an oval in a channel mask.

A vector mask creates transparency based on a vector gradient o
colors of a vector object. Vector masks can produce gradual trans
ency changes the same way that gradient inks produce gradual c
changes. You can drag a tool to create radial, linear, elliptical, an
rectangular vector masks, or you can use an object as a vector m

The following sections describe methods for using channel mask
and vector masks.

Changing the transparency preview

When you edit paint objects or channel masks, Canvas previews
transparency effects according to a preference setting. You can t
porarily change the preview when you are in channel mask edit 
mode. 

When you edit a channel mask with no preview, a checkerboard 
tern lets you focus on the transparent object. The checkerboard h
objects behind the transparent object, while showing the transpar
areas in the object you are editing.

Note: In Total Preview mode, Canvas shows objects that are in fro
and in back of a paint object or channel mask you are editing.

Paint object with a channel mask
.6 SPRITELAYER EFFECTS
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◆ To turn off the transparency preview: Press the Asterisk (*) 
key, or choose Hide Transparency Preview in the context menu. 

◆ To restore the transparency preview: Choose Show Transpar-
ency Preview in the context menu. If you don’t choose the comma
Canvas restores the preview setting each time you leave edit mo

◆ To set the Transparency preview: Choose File > Preferences. 
Click the Display tab in the Preferences dialog box and select an 
option in the Transparency area. Click Background Preview to pr
view background objects only. Click Total Preview to preview bac
ground and foreground objects. Click No Preview to display 
transparent objects against a checkerboard pattern for editing. 

Note: If you select the No Preview preference, you can’t use the c
text menu to change the preview while you edit an object.

The preview preference affects what you see when you paint in a
transparent paint object or edit any paint object. If objects are in fr
of the paint object, you can see the objects while editing if you se
Total Preview. If you select Background Preview or No Preview, 
foreground objects are not displayed when you edit a paint object 
channel mask.

Channel masks
A channel mask is a special channel that defines transparency in
object. While channels are typically associated with paint objects
you can apply a channel mask to any type of object.

Like an alpha channel in a paint object, a channel mask is basica
grayscale image. Channel masks can be edited using image-edit
tools and techniques, similar to alpha channels.

Transparency effect Channel mask Object with symbol ink
Channel masks 14.7
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You can think of a channel mask as a template for transparency. 
channel mask is the same size as the masked object and is align
with it. In the case of a paint object, the channel mask has the sa
resolution and number of pixels as the paint object.

Channel masks, like grayscale images, contain pixels that are 
assigned 256 possible lightness levels, or luminance values. Lum
nance values in a channel can range from 0 (black) to 255 (white

In an alpha channel, luminance corresponds to selection intensity
a channel mask, luminance values correspond to 256 levels of tra
parency, from 100% to 0% transparency, in the masked object. Bl
pixels (0 luminance) produce 100% transparency, while white pix
(255 luminance) produce 0% transparency. 

Therefore, when you paint in a channel mask, painting with black
produces clear areas and painting with white produces opaque a
in the masked object. Painting with gray produce partial transpare
relative to the gray value, with darker grays producing greater tra
parency than lighter grays.

Keep in mind that an object’s appearance can be affected by its t
fer mode, scope setting, and opacity, in addition to a channel ma
Changing the transfer mode can completely change the appearan
an object that has a channel mask. See “Using transfer modes” o
page 14.19.

Note: In Canvas 5, a channel mask was defined as a 1-bit (black-
white) channel. This type of channel produces either 100% transp
ent or 100% opaque areas. A channel mask in a Canvas 5 docum
will be converted to the current channel mask format if you open 
document in the current version of Canvas.

Black in a channel mask 
(left) produces 100% trans-
parency

A feathered edge produc-
es partial transparency

Channel mask and paint object Masked object
.8 SPRITELAYER EFFECTS
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Creating channel masks
You can create a blank channel mask, or create a channel mask 
a paint object. You create a channel mask when you render objec
you can use the Render command; see “Rendering objects and 
images” on page 24.7.

You can use the Transparency palette or the Channels palette to
ate blank channel masks. In the Channels palette, an object’s cha
mask is selected in the channel mask slot when the object is in ch
nel mask edit mode. In the Transparency palette, the Mask menu
shows “Channel” when a selected object has a channel mask.

To create a channel mask

This procedure creates a blank channel mask for an object.

1 Select a text, paint, vector, or group object to mask. 

2 Press Option (Mac) or Ctrl (Windows) and double-click the 
object. Or, choose Object > SpriteLayers > New Channel Mask.

• If the object to be masked is not a paint object, a dialog b
asks you to set the resolution of the mask. Enter a resolut
from 1 to 2,540 ppi and click OK. 

• If the object is a paint object, the channel mask’s resoluti
will be the same as the paint object’s resolution.

3 The object appears in channel mask edit mode, with the ob
visible and the channel mask selected. You can edit the channe
mask with painting tools. See “Editing channel masks” on 
page 14.11.

4 When you finish, press Esc to leave edit mode.

When you create a new channel mask, the channel is filled with w
pixels. At this point, the channel mask produces no transparency
because white pixels in the channel mask produce 0% transpare
in the masked object. As you edit the channel, painting with gray p
duces partial transparency, and painting with black produces 100
transparency.

To use the Transparency palette

You can use the Transparency palette to create a blank channel m
To open the Transparency palette, see “Using the Transparency 
ette” on page 14.1.

1 Select an object to mask. 
Channel masks 14.9
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2 In the Transparency palette, choose Channel in the Mask p
up menu. 

• If the object to be masked is not a paint object, a dialog b
asks you to set the resolution of the mask. Enter a resolut
from 1 to 2,540 ppi and click OK. 

• If the object is a paint object, the channel mask’s resoluti
will be the same as the paint object’s resolution.

3 The object appears in channel mask edit mode, with the ob
visible and the channel mask selected. You can edit the channe
mask with painting tools. “Editing channel masks” on page 14.1

4 When you finish, press Esc to leave edit mode.

Setting the channel mask scope

When you apply a channel mask to a vector object, the channel m
affects the vector object’s fill ink or its fill ink and stroke (pen ink).
To change the effect, change the Scope setting in the Transparen
palette. See “Controlling the scope of transparency effects” on 
page 14.5.

Masking with a paint object
You can create a channel mask by attaching a paint object to ano
object. If you have an existing paint object that you want to use a
channel mask, it’s quicker to use this procedure than to use the C
nels palette to place the paint object in a channel mask.

To attach a channel mask

1 Place a paint object to use as a mask in front of the object to
masked. The two objects do not have to overlap or touch, but th
paint object must be in front of the other object in the stacking 
order.

2 Select both objects.

3 Choose Object > SpriteLayers > Attach Mask. Canvas crea
a channel mask and both objects remain selected. The original p
object is not changed.

If the paint object and the object to be masked aren’t the same si
Canvas scales the image of the paint object to fit the masked obj
.10 SPRITELAYER EFFECTS
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A channel mask created from a paint object is the same as any c
nel mask. You can edit it the same as if you created a blank chan
mask.

Like any other channel mask, a channel mask created from a pai
object produces transparency relative to its gray values. If the cha
mask is solid white, it creates no transparency; if it is solid black, 
creates 100% transparency and makes the masked object invisib

Editing channel masks
You can use painting tools, filters, and image-editing commands 
modify the effect of a channel mask. To edit a channel mask, the
masked object must be in channel mask edit mode.

Editing a channel mask is similar to editing a channel in a paint 
object. You can paint in the channel mask with shades of gray. Y
can make selections with selection tools, commands, and alpha c
nels. You can apply image-adjustment commands and filters to th
entire channel mask or to just the selected areas.

To edit a channel mask

1 Select the masked object. 

2 Choose Object > SpriteLayers > Edit Channel Mask. The 
masked object appears in channel mask edit mode. 

In this mode, the channel mask is active and the object is also vis
You can paint in the channel or modify it to change the transpare
of the underlying object.

3 When you finish editing, press Esc to leave edit mode. The 
object remains selected.

◆ Options for channel mask editing: You can enter channel 
mask edit mode using any of the following methods.

With the mouse: Press Option (Mac) or Ctrl (Windows) and double
click a masked object. 

Note: If the object doesn’t have a channel mask, this creates a ch
nel mask and puts the object in channel mask edit mode.

In the Transparency palette: Click the Edit button when a masked
object is selected. This places an object with a channel mask in c
nel mask edit mode. If the object has a vector mask, it places the
tor mask in edit mode.
Channel masks 14.11
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In the Channels palette: When a paint object is in edit mode, click
the channel mask to select it for editing. When any other object is
channel mask edit mode, the channel mask is the only channel th
can be selected.

Selecting views for channel mask editing
You have a choice of view when you edit an object’s channel ma
You can display the object and the channel mask together, which
shows you the overall effect of the mask as you edit it. Or, you ca
hide the object to concentrate on the channel mask alone.

Selecting views in the Channels palette

An eye symbol in the Channels palette appears to the left of a cha
that is visible. The eye symbol disappears if a channel is hidden.

When you edit a channel mask, the top channel in the palette rep
sents the object itself. For a typical paint object this channel is labe
with the image mode, such as RGB or CMYK. For other objects, 
first channel is labeled “Object.”

The channel mask of an object in edit mode is shown in the Chan
Mask slot, which is below the channel list.

◆ To view the channel mask only: Click the eye symbol next to 
the object or composite channel at the top of the channel list. Thi
hides the object channel so only the channel mask is visible.

◆ To hide the channel mask: Click the eye symbol next to the 
channel mask. This hides the effect of the channel mask on the 
object.

At least one channel, either the composite/object channel or the c
nel mask, must be visible. If only one is visible, you can’t hide it b
clicking its eye symbol.

◆ To display a hidden channel: Click to the left of the channel to 
restore the eye symbol.

Note: When you edit paint objects you can edit pixels in the image
by selecting channels in the Channels palette. However, when yo
edit other objects, you can’t select the “object” channel. You can 
show or hide the object channel, but you can edit pixels only in th
channel mask.
.12 SPRITELAYER EFFECTS
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Selecting views in the Transparency palette

You can use the Transparency palette to change your view when
edit a channel mask. In channel mask edit mode, two buttons let 
select editing views. Click the triangle at the lower left to expand t
palette if necessary to display the buttons.

◆ To view the channel mask only: Click “Channel Mask Only” 
in the Transparency palette. This is the same as hiding the “objec
channel” in the Channels palette.

◆ To view the object and channel mask: Click “Image and 
Channel Mask.” This is the same as making the “object channel” a
the channel mask visible in the channels palette.

To remove a channel mask

Removing a channel mask from an object removes the transpare
effect produced by the channel mask.

1 Select the masked object. 

2 Choose Object > SpriteLayers > Detach Mask. Canvas 
removes the channel mask from the selected object. 

When you detach a channel mask, Canvas converts the channel 
to a paint object and places it in the document. The paint object 
includes the alpha channels from the masked object if it had alph
channels.

Click the eye symbol to hide 
the object or channel mask 
in the Channels palette

A Click to show the 
mask effect on the ob-
ject

B Click to show the 
channel mask alone

You can use the Transparen-
cy and Channels palettes to 
change your view when you 
edit a channel mask 

Click to show options

A

B

Channel masks 14.13
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Vector masks
A vector mask creates a transparency effect based on a style of g
ent ink, such as radial or rectangular. You can choose the style w
you apply a vector mask, or you can apply an existing vector obje
as a vector mask. 

A vector mask can be applied to any type of objects, including ve
tor, paint, text, and group objects.

It’s easy to apply vector masks. You can drag a vector transparen
tool to apply radial, directional, elliptical, or rectangular style mask
If you want to use precise values for position and transparency lev
you can enter numbers in the Transparency palette. You can app
mask quickly by selecting an object and choosing Object > 
 SpriteLayers and selecting a vector mask style in the submenu.

The styles of vector masks applied by the Vector Transparency to
are related to vector gradient styles. You can think of these tools 
applying a hidden gradient to a masked object. The transparency
effect is based on the hidden gradient; the transparency level is r
tive to the lightness of the gradient shading.

For example, a linear vector gradient blends colors along a straig
axis. A directional vector mask fades from opaque to transparent
along a linear axis. For linear vector gradients and directional vec
masks, you can specify the length and angle of the axis.

The relationship between vector gradients and vector transparen
masks can be seen if you detach a vector transparency mask. W
masked object selected, choose Object > SpriteLayers > Detach 
Mask. Canvas removes the vector mask and places it in the docum
as a separate vector object. If you examine this object, you see th
has a vector gradient. The gradient style is similar to the vector m
style. The vector gradient fades from black to white in the same w
that the vector mask caused the masked object to fade from trans
ent to opaque.

Vector mask styles

(Left to right) Radial, Directional, 
Rectangular, Elliptical
.14 SPRITELAYER EFFECTS
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The relationship between vector masks and vector gradients also
works in reverse: You use a vector gradient-filled object as a vec
mask; see “Masking with a vector object” on page 14.16.

Applying vector masks
You can apply a vector mask using the Vector Transparency tool
When an object is selected, you can drag one of these tools near
over the object to apply a transparency effect. 

The Vector Transparency tools provide the easiest way to create
transparency effects such as vignettes (image that appear in oval
other shapes) as well as linear, radial, or rectangular fades.

You can use the Transparency palette to apply vector transparen
effects. When you use the Transparency palette, you can specify
ues for the position and intensity of the effect.

In the Transparency palette, the Mask menu shows the vector ma
style when a selected object has a vector mask.

To create a vector mask

1 Select a text, paint, vector, or group object to mask. 

2 Select a Vector Transparency tool. These tools are in the 
Effects toolbar. Select the tool for the style of vector mask you wa
to apply: Radial, Directional, Rectangular, or Elliptical.

3 Drag the tool near or over the selected object. As you drag,
vector line or shape appears. This represents the position of the
tor transparency effect.

A vector mask is related to 
a vector gradient

If you detach a vector 
mask, you get an object 
with a gradient. The grays 
in the gradient correspond 
to transparency levels in a 
masked object.

Masked objectDetached mask Original object

Vector Transparency tools: 
Radial, Directional, Rectangular, 
Elliptical
Vector masks 14.15
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4 To adjust the effect, drag a handle to reposition the transpa
ency vector. When you finish, press Esc to leave edit mode.

To use the Transparency palette

You can use the Transparency palette to apply a vector mask. To
open the Transparency palette, see “Using the Transparency pal
on page 14.1.

1 Select an object to mask. 

2 In the Transparency palette, choose a mask style in the Ma
menu. 

Note: You can’t select “Object” in the pop-up menu. To use an obje
as a vector mask, see “Masking with a vector object” on page 14.

3 To adjust the effect, drag the handles to reposition the trans
ency vector. When you finish, press Esc to leave edit mode.

Setting the vector mask scope

When you apply a vector mask to a vector object, the mask affec
the vector object’s fill ink or its fill ink and stroke (pen ink). To 
change the effect, change the Scope setting in the Transparency
ette. See “Controlling the scope of transparency effects” on 
page 14.5.

Masking with a vector object
You can create a vector mask by attaching a vector object to ano
object. Like other vector masks, a vector mask created from a ve
object produces transparency relative to its color values. For exa
ple, if the vector object that you attach is solid white, it creates no
transparency; if it is solid black, it creates 100% transparency, ma
ing the masked object invisible.

To attach a vector mask

1 Place a vector object to use as a mask in front of the object
be masked. The two objects do not have to overlap or touch, but
vector object must be in front of the other object in the stacking 
order.

2 Select both objects.

3 Choose Object > SpriteLayers > Attach Mask. Canvas crea
a vector mask and both objects remain selected. The original ve
object is not changed.
.16 SPRITELAYER EFFECTS
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If the vector object and the object to be masked aren’t the same s
Canvas scales the vector object to fit the masked object. 

Editing vector masks
You can edit vector masks that have been applied with the Vecto
Transparency tools, and masks created by attaching gradient-fille
vector objects. Editing lets you change the boundary of the opaqu
and transparent areas of a mask. You can also add nodes for fine
control of transparency levels.

To edit a vector mask

To put a masked object in edit mode, select the object and click E
in the Transparency palette (see “Using the Transparency palette
page 14.1). Or, select the Vector Transparency tool that was use
apply the mask.

When the vector mask editing handles appear, you can drag the 
dles to adjust the position and boundaries of the vector mask. Th
handles correspond to the values in the Mask area in the Transpa
ency palette. When you drag a handle, the values in the Transpar
palette are updated to match the new position. When you finish e
ing, press Esc.

Adding nodes

The default handles that appear in vector mask edit mode indicate
start and end points of the transparency gradient. For a directiona
mask (the most basic style), a hollow handle represents the point
100% transparency, and the solid handle represents the point of 
100% opacity.

When a vector mask is in edit mode, you can add nodes to set ad
tional opacity levels. The default mask has a start and end point, w
a smooth transition from opacity to transparency between the sta
and end point. When you add nodes, you set the opacity level at e
node.

To add a node, select the masked object, and then click the vecto
transparency tool for the mask style to enter edit mode. Point to t
mask vector and press Ctrl and click (Mac) or right-click (Window
on the mask vector. An opacity slider appears. Use the slider to s
the opacity level of the new node. Set the slider to 100 to make th
mask opaque at the node. Set the slider to 0 to make the mask c
pletely transparent at the node. Select a value between 0 and 10
make the mask semi-transparent at the node.

Nodes (small circles) let you set 
several opacity levels in a 
directional vector mask
Vector masks 14.17
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When you edit rectangular or elliptical vector mask styles, you ca
add nodes to the horizontal vector that joins the inner box (which 
resents the area of 100% opacity) to the object’s bounding box. W
you edit radial mask styles, you can add nodes to the circle, whic
represents the 360 degree sweep of the mask.

Editing values in the Transparency palette

You can change values in the Transparency palette to make prec
changes to a vector mask. When you change the mask settings, 
vas updates the mask handles to match the current position value

To use the Transparency palette for editing, select the masked ob
and click Edit in the Transparency palette. You can change the fo
lowing values to modify the effect of the vector mask.

Transparency Start: The transparency percentage at the edge of th
vector effect. If this value is 100%, the object appears completely
transparent beyond this point. When you first apply a mask in rec
gular or elliptical style, this point is represented by the handle at t
edge of the object.

Transparency End: The transparency percentage at the end of the
vector effect. If this value is 0%, for example, the object is not tran
parent at this point. When you first apply a mask in the rectangula
elliptical style, this percentage corresponds to the area enclosed 
the center of the object, which is 0% transparent. For radial style,
start point is the handle on the perimeter of the circle. The end is a
opposite point on the circle.

Left. The distance of the first handle from the left edge of the obje
measured as a percentage of the object’s width.

Top. The distance of the first handle from the top edge of the obje
measured as a percentage of the object’s height.

Use the pop-up opacity slider to 
set the opacity level of a node. 
You can add a series of nodes 
for additional control of a trans-
parency mask.

Setting node opacity Directional Rectangular
.18 SPRITELAYER EFFECTS
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Width. The horizontal distance to the second handle from the firs
handle, measured as a percentage of the object’s width.

Height. The vertical distance to the mask’s second handle from th
first handle, measured as a percentage of the object’s height.

To remove a vector mask

Removing a vector mask from an object removes the transparenc
effect produced by the mask.

1 Select the masked object. 

2 Choose Object > SpriteLayers > Detach Mask. Canvas 
removes the vector mask from the selected object. 

When you detach a vector mask, the former mask appears in the
ument as a separate vector object filled with a grayscale gradient

Vector masks in paint edit mode
If a paint object has a vector mask, Canvas temporarily represents
vector mask as a channel mask if you edit the paint object. 

In paint edit mode, a temporary channel mask that represents the
object’s vector mask appears in the Channel Mask slot in the Cha
nels palette. The temporary mask lets you see the effect of the ve
mask as you edit the paint object.

If you click in the Channel Mask slot to try to select the temporary
channel mask for editing, Canvas asks if you want to convert the 
tor mask to a channel mask. Click Cancel to return to editing the 
paint object without destroying the vector mask. Click Yes if you 
want Canvas to convert the vector mask to a channel mask that c
be edited with painting tools.

Using transfer modes
All objects — vector objects, text objects, paint objects, and grou
objects — have a transfer mode. Transfer modes are like invisible fil-
ters that affect the appearance of colors. When objects overlap, t
transfer mode of the front object can change the appearance of th
back object. 
Using transfer modes 14.19
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Transfer modes work with transparency effects, including opacity
and transparency masks. However, transfer modes can make ob
appear to be transparent without reduced opacity or transparency
masks. For example, Multiply mode lets underlying colors show 
through an object.

To apply transfer modes, you select objects and choose modes f
the Transfer Mode menu in the Transparency palette. For vector 
objects, you can apply transfer modes to fill inks alone or to fill ink
and strokes together.

The default transfer mode is Normal. In Normal mode, the colors 
overlapping objects do not mix unless the front object is partially 
transparent.

In addition to interacting with background objects, transfer modes
can interact with the document’s white background. When an 
object’s transfer mode is Screen, for example, anything white 
replaces the object’s color, so the document’s white background 
make the object seem to be invisible.

To change an object’s transfer mode

1 Open the Transparency palette. See “Using the Transparen
palette” on page 14.1.

2 Select an object and choose a transfer mode in the Transfe
Mode pop-up menu in the Transparency palette. 

3 For vector objects, select a Scope option. Select Fill to appl
the transfer mode to the fill ink; select Fill & Stroke to apply the 
transfer mode to both the object’s fill ink and stroke.

Selecting transfer modes

The transfer modes available in the Transfer Mode menu in the 
Transparency palette are listed here. The following descriptions a
based on objects with RGB colors with no other transparency effe
Each mode is described in terms of the front object when the bac
object’s transfer mode is Normal.

Normal In Normal mode, colors do not blend; the color of a front
object hides the colors of all objects behind it.

Multiply In Multiply mode, overlapping colors become darker. 
Black produces black. White has no effect, the same as if a white
object were not visible. White text, for example, reveals the back-
ground.
.20 SPRITELAYER EFFECTS
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Screen The Screen mode lightens overlapping colors. Objects w
lighter colors increase the effect. White produces white. Black has
effect, the same as if a black object were not visible. Black text, fo
example, reveals the background. 

Overlay In Overlay mode, a front object’s color overlays colors i
the background, while preserving highlights and shadows. White a
black in the background are not affected.

Soft Light The Soft Light mode lightens or darkens underlying 
colors depending on the brightness of the front color. Colors in fro
that are lighter than 50% gray lighten the underlying object. Colors
front that are darker than 50% gray darken the underlying object.

Hard Light The Hard Light mode lightens or darkens underlying 
colors depending on the brightness value of the front color. Hard 
Light mode is similar to Soft Light. However, black in the front 
object produces black; white in the front object produces white.

Darken In Darken mode, the color values of the front color repla
the underlying color values if the front color value is darker than t
back color value. Black in the background appears unchanged; th
front color appears in place of white in the background.

Lighten In Lighten mode, the color values of the front color replac
the underlying color values if the front color value is lighter than th
back color value. White in the background appears unchanged; th
front color appears in place of black in the background.

Difference The Difference mode compares the color values of t
front and back colors and subtracts the darker value from the ligh
value. If the front and back colors are identical, the result is black
the front or back color is black, the other color does not change. If
front or back color is white, the other color is inverted.

Dodge Dodge mode compares the lightness values in each chan
of the front and back colors, and uses the lighter value from each
channel for the result color. However, black is not replaced by a 
lighter color. White in the front replaces all colors except black.

Burn Burn mode compares the lightness values in each channe
the front and back colors, and uses the darker value from each ch
nel for the result color. However, white is not replaced by a darke
color. Black in front replaces all colors except white.
Using transfer modes 14.21
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Color space and transfer modes
Canvas calculates transfer mode effects by applying formulas to 
color values. Canvas performs these calculations in RGB or CMY
color space. In other words, Canvas uses RGB color values or 
CMYK color values in its calculations.

For example, the formula for Multiply mode is Color 1 multiplied b
Color 2. Canvas applies the formula separately to each value tha
defines a color. In the case of RGB colors, Canvas applies the fo
mula separately to the red, green, and blue values. For CMYK col
Canvas calculates the effect on cyan, magenta, yellow, and black
ues.

The significance of the color space calculation is that the effect yo
see on screen could appear completely different if the effect is prin
in a different color space.

In particular, you must display transfer mode effects in CMYK if th
document will be separated for printing with process (CMYK) col-
ors. Otherwise, the color separations could produce colors that a
completely different from the colors you see on screen.

For an example of this effect, draw several overlapping objects w
different colors. Set the transfer mode of the front object to Differ-
ence. Choose File > Preferences. On the Display tab in the Prefe
ences dialog box, change the Screen Compositing setting from R
to CMYK. Click OK to close the dialog box. To refresh the screen
press Command+K (Mac) or F5 (Windows). You will probably see
significant change in colors when you switch from RGB to CMYK
compositing.

To set the color space for screen compositing

1 Choose File > Preferences.

2 Click the Display tab.

3 Select RGB or CMYK in the Screen Compositing menu on th
Display tab. Be sure to choose RGB for effects that will displaye
in RGB colors. Choose CMYK if you are using CMYK colors in a
document that will be printed with process colors.

Transparency and printing
You can use transparency effects to create stunning images and 
plex illustrations. As with any graphic effects, however, images th
appear perfect on screen can cause problems or produce unexpe
.22 SPRITELAYER EFFECTS
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results when you print a document. This section discusses some 
issues you should keep in mind to help ensure that your documen
print successfully.

Canvas uses special techniques to print some transparency effec
Canvas can send an instruction to print an opaque rectangle, for 
example, to most printers. However, to print a transparent rectan
Canvas usually converts the object to an image. This process is c
rasterizing or rendering. Canvas then sends the image data to the 
printer.

In the Print dialog box, you can select options for printing objects a
colors. The options can affect the time required to print a docume
and how well colors match among objects. See “Transparency R
dering” on page 4.22.

Output resolution of transparency effects
You can specify an output resolution for a transparent object. If y
don’t specify the resolution for Canvas to use, it selects the resolu
based on the following guidelines:

• If a transparent paint object overlaps other paint objects,
Canvas rasterizes all the objects at the same resolution a
the paint object that has the highest resolution.

• If a vector object is transparent or is behind a transparen
object, Canvas rasterizes the vector object at the resolut
specified for printing. You can set the resolution for printin
on the Printing tab in the Preferences dialog box.

To set the output resolution of an object

1 Select the object whose resolution you want to specify.

2 Choose Object > SpriteLayers > Output Resolution.

3 Do one of the following in the dialog box, and then click OK

• Select the Maximum Resolution checkbox to specify that
the object should be rendered at the maximum resolution
the output device.

• Deselect the Maximum Resolution checkbox and enter th
resolution you want Canvas to use. You can set the reso
tion from 1 to 2,540 dpi.
Transparency and printing 14.23
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To set the maximum output resolution

You can specify a maximum resolution for Canvas output. The re
lution you specify in the Preferences dialog box affects output of 
objects and rasterizing of transparency effects. This setting overr
settings you apply to objects with the Output Resolution comman

1 Choose File > Preferences.

2 Click the Printing tab.

3 Do one of the following:

• Select the “Output to maximum resolution” checkbox to 
specify that Canvas should output objects at the maximu
resolution of the output device.

• Deselect the “Output to maximum resolution” option if you
want to specify an output resolution. Select an output res
lution from the pop-up menu.

4 Click OK.
.24 SPRITELAYER EFFECTS
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DRAWING BASICS

This chapter describes how to draw and resize vector objects. Th
Canvas drawing tools let you easily draw basic shapes — lines, r
angles, ovals, and arcs — and create precise squares, circles, an
straight lines. Specialized tools let you draw grids, stars, polygons
concentric circles, cubes, spirals, and “smart” lines that link objec
and stay connected even when you move the linked objects.

Drawing basic shapes
You can use the same basic technique with most Canvas drawin
tools. See the table titled “Basic drawing procedures” on page 15
for the procedures you use to draw basic shapes. Instructions for
tools that let you draw grids, stars, polygons, concentric circles, 
cubes, spirals, and Smart Lines appear later in the chapter.

Applying inks and strokes 

When you draw a vector object, Canvas applies the current ink a
stroke settings to the objects you draw. The inks and stroke icons
the toolbox show a preview of the current settings. You can chan
these attributes before or after you draw an object. Refer to the c
ters titled “Inks: colors and patterns” on page 12.1, and “Strokes: 
line effects” on page 13.1, for more information.

Selecting tools in the toolbox

Tools for drawing lines, rectangles, ovals, and arcs are grouped i
toolbars that pop out from the toolbox. The current tool is visible i
the toolbox. To open a toolbar to select another tool, press the cur
tool icon. To keep a toolbar open while you work, drag it away fro
the toolbox.

Drawing objects from the center

You can draw many vector objects starting from the object’s cent
by pressing a modifier key as you draw. Position the pointer wher
you want the object’s center to be, press Option (Mac) or Ctrl (Wi
dows) and drag away from the center to draw the object. 

When you draw an object from the center, you can press Shift at 
same time if you want to also constrain the object’s bounding box

A

B C

D

E

A

B

D

C

Lines

Rectangles

Paths

Ovals and arcs

Object tools

E

15.1



15

ircle 

dius 
ints 
 

a square. You can use this technique to draw a perfect square or c
from the center outward.

Basic drawing procedures

Drawing arcs by radius and by 3 points
The Arc Radius tool draws an arc based on a center point and ra
that you set. The Arc 3 Points tool draws an arc through three po
that you set. Both tools draw arcs with the current fill ink, pen ink,
and stroke.

To edit arcs, see “To change the length of an arc” on page 15.5.

Object Tool Procedure

Lines Line tool Drag from the starting point to 
the end point in any direction

Lines at a 45˚ angle 
(horizontal, vertical, or 
diagonal)

Line tool Press Shift and drag from the 
starting point to the end point

Rectangles Rectangle tool Drag from one corner to the 
opposite corner

Squares Rectangle tool Press Shift and drag from one 
corner to the opposite corner

Rounded rectangles Rounded 
Rectangle tool

Drag from one corner to the 
opposite corner

Rounded squares Rounded 
Rectangle tool

Press Shift and drag from one 
corner to the opposite corner

Ovals Oval tool Drag from one corner to the 
opposite corner of the oval’s 
bounding box

Circles Oval tool Press Shift and drag from one 
corner to the opposite corner of 
the circle’s bounding box

Arcs Arc tool Drag from one corner to the 
opposite corner of the arc’s 
bounding box

Circle-segment arcs Arc tool Press Shift and drag from one 
corner to the opposite corner of 
the arc’s bounding box
.2 DRAWING BASICS
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The Arc Radius tool and Arc 3 Points tools are located with the o
and arc tools in a toolbar that pops out of the toolbox.

To draw arcs by 3 points

1 Select the Arc 3 Points tool. Click in the document to set one
endpoint of the arc. 

2 Move to the second endpoint of the arc. A line extends from t
first endpoint. Click to set the second endpoint. 

3 Move to a point on the perimeter of the arc. A line indicates th
chord from the second point, while the arc expands or contracts a
you move the pointer. 

4 Click to set the perimeter point and finish the arc.

To draw arcs by radius

1 Select the Arc Radius tool. Click in the document to set the c
ter of the arc.

2 Move to one endpoint of the arc. A line extends from the cen
and indicates the arc’s radius. Click to set the endpoint.

3 Move to the second endpoint of the arc. An arc segment exte
from the first endpoint and indicates the arc’s length. 

4 Click to set the second endpoint and finish the arc.

Drawing circles by radius and by 3 points
The Circle Radius tool draws a circle from a center point and a rad
that you set. The Circle 3 Points tool draws a circle through three
points that you set. 

Both tools draw circles with the current fill ink, pen ink, and stroke

The Circle Radius and Circle 3 Points tools are located with the o
and arc tools in a toolbar that pops out of the toolbox.

First click

Second click

Third click

First click
Second click

Third click

A Oval, B Arc, C Circle 3 
Points, D Circle Radius, E Arc 3 
Points, F Arc Radius

A B C

D FE
Drawing basic shapes 15.3
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To draw circles by 3 points

1 Select the Circle 3 points tool. Click in the document to set a fi
point on the circle’s circumference. 

2 Move to a second point on the circle’s circumference. A line 
indicates the chord from the first point as you move the pointer. Cl
to set the second point. 

3 Move to a third point on the circumference. A line indicates th
chord from the second point, while the circle expands or contracts
you move the pointer. 

4 Click to set the third point and complete the circle.

To draw circles by radius

1 Select the Circle Radius tool. Click in the document to set the
center of the circle.

2 Move to anywhere on the circumference of the circle. A line 
extends from the center and indicates the radius, while the circle 
expands or contracts as you move the pointer. 

3 Click to set the circumference and complete the circle.

Resizing and reshaping vector objects
You can resize and reshape a vector object by changing the size
shape of the object’s bounding box. You can also change the len
of arc segments and the corner radius of rounded rectangles. The
techniques are described in the following section.

You can also edit most vector objects by changing the anchor po
and segments that form their paths. For information on these edit
techniques, see “Editing object paths” on page 16.7.

To resize an object’s bounding box

When you drag a handle on a vector object’s bounding box, you 
change the height or width (or both) of the bounding box. This als
changes the size (and possibly the shape) of the object. For exam
if you select a circle and drag a side handle to make the bounding
wider, the circle becomes an oval that is wider than it is tall.

1 Choose a Selection tool at the top-left of the toolbox. 

• Use the filled arrow to select a single object (including a 
group object).

First click Second click

Third click

Second 
click

First 
click
.4 DRAWING BASICS
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• Use the hollow arrow to select an individual object within 
group object.

2 Click the object to select it. Handles appear on the object’s 
bounding box.

3 Drag a handle, as described below, to resize the object.

Maintaining object proportions

When you resize vector objects and want to maintain the object’s
height-to-width ratio, you have three options: 

• Press Shift and drag a corner handle to resize the object 
portionally.

• Use the Scale command and select the Proportional opti
in the Scale dialog box. This keeps the vertical and horiz
tal scaling factor in the dialog box equal.

• Use the Objects Specs command and select the Keep P
portions option in the Object Specs palette. Canvas keep
the object proportional if you change an object dimension
the Object Specs palette.

To change the length of an arc

1 Select the arc. Round handles appear near the beginning a
end of the arc segment.

2 To shorten the arc, drag the round handle back over the arc
lengthen the arc, drag the round handle to continue the arc segm

You can also adjust the length of an arc by changing its Start ang
and ∆ values in the Object Specs palette. 

To change Do this

Height Drag the top or bottom handle

Width Drag a side handle

Height and width Drag a corner handle

Height and width 
proportionally

Press Shift and drag a corner handle

Symmetrically 
(from center)

Press Option (Mac) or Ctrl (Windows) and 
drag a handle

Symmetrically and 
proportionally

Press Option-Shift (Mac) or Ctrl-Shift (Win-
dows) and drag a corner handle
Drawing basic shapes 15.5
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To change the corner radius of a rounded rectangle

1 Select the rounded rectangle. A round handle appears near
lower-right corner of the rectangle.

2 Drag the handle to change the corner diameter. You can als
use the “Diag” setting in the Object Specs palette to alter the sh

Drawing with Snap options
Snap options can help you draw objects in precise positions relat
to other objects. For example, you can use Snap options to draw 
that are parallel or perpendicular to other lines, to draw circles co
tained inside other objects, and to start drawing from the center 
points of objects. You can also draw guide lines that run to a van
ing point for illustrating perspective.

Snap options appear in the context menu, in a Snap submenu. Y
can select Snap options when you use the following tools: Line, 
Smart Lines, Oval, Circle 3 Points, Circle Radius, Rectangle, 
Rounded Rectangle, Arc, Arc 3 Points, Arc Radius, Curve, Polyg
Text, Spiral, GridMaker, and EasyShapes.

Snap options are most useful when you draw with the Line tool. Y
can draw lines to be parallel, tangent, or perpendicular to other 
objects. You can also snap lines to start at the center of an object
constrain lines to the interiors of objects.

Snap options (especially the Center and Included options) are als
useful for drawing ovals, rectangles, and arcs. For these objects,
some Snap options constrain the first point you draw; other Snap
options constrain the start and end points when you draw an obje

Objects drawn with Snap options

Included Perpendicular Parallel CenterTangent
.6 DRAWING BASICS
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To use Snap options

1 Select the Line tool or another tool. Tools that can use Snap
options are listed above.

2 Point to the object you want to snap to. (To use the Vanishi
Point option, skip this step; you do not need to point to an objec

• To draw parallel to a line, place the pointer anywhere on t
line. To draw parallel to a rectangle or polygon, point to th
side you want to draw parallel to.

• To draw perpendicular to an object, point to the side you
want to draw perpendicular to.

• To snap to the center of an object, place the pointer any-
where inside the object.

3 Open the context menu (Ctrl-click on Mac; right-click on Win
dows) and choose an option (described below) in the Snap sub
menu.

4 If you chose Parallel or Perpendicular, a reference line appe
Move the mouse and then click to set the reference line. 

• For the Parallel option, a dialog box appears. You can 
accept or change the indicated offset from the object, an
then click OK to continue.

5 Move the pointer to where you want to start drawing. Depen
ing on the tool you are using, either drag to draw an object, or cl
to set the points of the object.

Note: Objects that should be two-dimensional might appear one- 
dimensional if you try to draw using certain Snap options. If you sn
a rectangle to a line using the Included option, for example, two 
opposite corners of the rectangle will snap to the line. If the line is
vertical or horizontal, the rectangle will appear as a line.

Snap submenu options

You can choose the following options from the Snap submenu in 
context menu. To choose a Snap option, make sure the pointer is
the object or the object side that you want to use as a reference, 
open the context menu and choose an option in the Snap subme

Parallel Lets you set a reference line parallel to a line or the side
an object. After selecting this option, move the mouse to position 
reference line, then click to set it. In the dialog box that appears, y
can enter the distance you want the reference line to be offset fro
Drawing with Snap options 15.7
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the object. Click OK to continue. Begin drawing and the object wi
snap to the reference line.

Perpendicular Lets you set a reference line perpendicular to a lin
or the side of an object. After selecting this option, move the mou
to position the reference line, then click to set it. Begin drawing an
the object will snap to the reference line.

Tangent Lets you set a reference line tangent to a circle, an oval
an arc. After selecting this option, move the mouse to position the
reference line, then click to set it. Begin drawing and the object w
snap to the reference line.

Included Snaps an object’s start and end points to the outline of
object or to a line. For example, you can use this option to snap t
bounding box of a circle to the inside of a rectangle.

Center Snaps the first point you draw to the center of an object o
line.

Vanishing Point Snaps the first point of an object to the document
vanishing point. If you draw with the Line tool, the line will snap to
the vanishing point and run to the location of the pointer when yo
begin dragging.

There is one global vanishing point in a document. The vanishing
point is used by the commands in the Effects > Perspective subm
as well as the Snap > Vanishing Point command. The default van
ing point is at ruler coordinates 0,0. You can use the Effects > Pe
spective > Vanishing Point command to apply perspective to selec
objects and establish the vanishing point. Using the 1 Side and 2
Sides commands will also affect the location of the document’s va
ishing point.

Drawing by numbers
Several drawing tools give you the option of entering dimensions
draw objects precisely. This method can be easier than dragging
mouse and watching data in the Status bar to draw objects to pre
dimensions.

You can enter dimensions when you use the Oval, Arc, Rectangl
Rounded Rectangle, and Line tools. With these tools, you can sti
drag the mouse to draw interactively. Or, just click in your docume
When you click, a dialog box appears. You can enter the width, 
height, or other values, and then click OK to draw the object.

✔Tip
You can draw perspective lines 
with the Vanishing Point 
option, and make the lines into 
alignment guides with the 
Object > Make Guide com-
mand.
.8 DRAWING BASICS
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Note: You can also establish precise dimensions and locations fo
any object in a document by using the Object Specs palette.

To draw by numbers

1 Select a drawing tool. You can enter dimensions with the Ov
Arc, Rectangle, Rounded Rectangle, and Line tools.

2 Click in the document where you want to place an object.

3 A dialog box appears. 

• When you create ovals, rectangles, and rounded rectang
a point on the object’s bounding box will be at the point yo
clicked in the document. To select the point, click a hand
in the bounding box icon. To center an oval where you 
clicked in a document, for example, click the center hand
in the bounding box illustration.

• When you create arcs, the center of the arc will be at the
point you clicked in the document.

4 Enter dimensions or other values in the dialog box. 

Ovals and rectangles: Enter height and width values. For 
rounded rectangles, also enter the corner radius.

Lines: Enter the distance and angle from the point you clicke
to the second point. Or, enter the horizontal (X) and vertical
(Y) distance to the second point.

Arcs: Enter the width and height, the starting point in degree
and the angular length of the arc.

5 Click OK to draw the object.

Drawing with EasyShapes
You can draw all kinds of shapes, including arrows, flow chart box
dialog balloons, symbols, and banners, using EasyShapes™.

A wide variety of EasyShapes are available from the EasyShape
toolbar. This toolbar is in the Object Tools toolbar in the toolbox. 

Using EasyShapes is as simple as selecting a shape from the 
EasyShapes toolbar and dragging in your document. After you dr
EasyShapes, you can type text inside them. You can apply prope
to EasyShapes as you would any vector objects.

Click a handle
Drawing with EasyShapes 15.9
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Adding text

EasyShapes are especially useful because they can contain text.
Many are designed with “padding” (space) between the text and t
object outlines. Text wraps inside these EasyShapes without touc
the edges. If you use EasyShapes to create things like organizati
charts and process diagrams, you don’t have to create separate t
objects to enter text into your diagrams.

Ways to enter and edit text in EasyShapes are described later in 
section.

Smart editing

Some EasyShapes have “smart” edit modes. For example, an 
EasyShapes arrow can be edited by dragging handles that adjus
size and shape of the arrow head and arrow body. An EasyShap
“thought balloon” has a handle that extends the balloon without d
torting the overall shape.

To draw EasyShapes

1 Select an EasyShapes tool. To display the tools, open the 
Object Tools toolbar, then open the EasyShapes toolbar to selec
EasyShapes tool. Some EasyShapes are contained in toolbars 
pop out from the main EasyShapes toolbar.

Note: You can drag an EasyShapes toolbar away from the toolbo
make it a floating palette. You can dock these palettes on the Do
ing bar.

2 Place the pointer in the document where you want to begin 
drawing and drag diagonally. As you drag, you define a boundin
box for the object.

3 The new object appears with the current fill ink, pen ink, and
stroke properties, and is selected.

4 To enter text in the object:

You can select 
EasyShapes toolbars 
from the main 
EasyShapes toolbar in 
the Object Tools toolbar

EasyShapes tool
.10 DRAWING BASICS
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• If the EasyShapes tool you used is one that creates a pre
text object, an insertion point appears inside the shape. T
the text. When you finish, press Esc to end text edit mod

• If the EasyShapes tool you used does not create a preset
object, Canvas will create a text object if you begin typing
When you finish typing, press Esc.

Text you type into EasyShapes appears with the current ch
acter and paragraph settings and text color.

5 To deselect the EasyShapes object, press Esc.

Using text in EasyShapes
When you draw some EasyShapes, an insertion point appears in
the object so you can type text into it. Simply begin typing and the
text will wrap to the next line when it reaches the defined text bord

Some shapes do not have preset text objects. However, you can
text into all EasyShapes. Simply begin typing after you draw an 
object. When you finish typing, you can adjust the margins and si
like you would any text object.

When you enter text in EasyShapes (whether they contain preset
objects or not), the resulting text objects are dependent on the 
EasyShapes. The text objects and EasyShapes behave as a gro
though they are not actually grouped. When you drag EasyShape
their text objects move with them. However, you can select and ap
attributes to EasyShapes and their text objects separately.

To apply attributes or commands, you must select the object you
want to affect — the EasyShapes object or its text object. When 
EasyShapes have preset text objects with padding, you can click
space between the text object and the EasyShapes object edge t
select the EasyShapes object. When text objects and EasyShape
the same size, it can be difficult to select EasyShapes with the Se
tion tool. Instead, you can use the Select submenu in the context
menu to select objects, or use another selection method.

Editing EasyShapes
You can edit EasyShapes by selecting them and choosing Objec
Edit > Object. You can also double-click EasyShapes, or select th
and choose Edit in the context menu to go into edit mode. 

Editing methods vary for EasyShapes. Some have special editing
handles and others can be edited as regular vector paths.

✔Tip
When an object is selected, its 
object type is shown in the 
Object Information field in the 
Status bar. 
Drawing with EasyShapes 15.11
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EasyShapes handles For some EasyShapes, including arrows, sp
cial editing handles appear in edit mode. The handles let you eas
adjust the shape of the object. Drag a handle to modify the shape
When you finish, press Esc to leave edit mode.

Regular paths EasyShapes that do not have special editing hand
are like regular vector paths when you put them in edit mode. Yo
can use path-editing techniques to modify these shapes by addin
deleting, and moving the anchor points and segments that define
path.

Object editing You can modify EasyShapes when they are 
selected (not in edit mode) like any other objects. You can drag se
tion handles to change the bounding box shape. You can apply c
mands such as Rotate, Flip, and Freeform. You can apply ink and
stroke attributes, as well as SpriteLayer transparency and SpriteE
fects.

Converting EasyShapes to paths

EasyShapes that have special edit modes can be converted to pa
For example, if an arrow displays special EasyShapes editing han
in edit mode, and you want to edit its segments and anchor point
you can convert it to a path. 

To convert an object, select it and choose Object > Path > Conve
Paths. This converts the object to a standard vector object; speci
EasyShapes editing features will be removed. You can then choo
the Edit command to edit the object’s path in edit mode.

EasyShapes edit mode Path edit modeSelected
.12 DRAWING BASICS
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Using specialized drawing tools
Several specialized drawing tools let you quickly create complex 
shapes in Canvas. Drawing grids, stars, polygons, concentric circ
cubes, spirals, and Smart Lines is as easy as drawing rectangles

The tools shown in the following table create specialized vector 
objects. 

In most cases, you can treat these vector objects like all others. Y
can move them and resize their bounding boxes. They can be rota
flipped, and scaled. You can apply strokes, pen inks and fill inks t
them. However, most of these objects are compound objects, wh
means that they are made up of separate objects. Because of thi
some inks and other effects appear differently when applied to th
objects than to simple vector objects like rectangles and ovals.

Some of the specialized objects have unique editing features. Fo
example, you can twirl the points of a star, star outline, or framed 
by dragging special handles. You can also specify the number of
points of a star, the number of rows and columns in a grid, the nu
ber of rings in concentric circles, and the number of revolutions in
spiral. You can draw a cube with or without a perspective effect. 
Methods for drawing and modifying all of the specialized objects 
appear with the individual tool descriptions on the following pages

You can also convert most specialized vector objects to paths. Do
this lets you edit the objects’ anchor points and segments. For mo
information, see “Converting objects and text to paths” on 
page 16.21.

Use this tool to draw this

Concentric Circles Nested circles or ovals

Cube Square and rectangular boxes in iso-
metric views

GridMaker Rows and columns of boxes 

Multigon Stars and complex polygons

Smart Lines Linked lines for flow charts, diagrams

Spiral Lines in spiral patterns
Using specialized drawing tools 15.13
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Concentric circles
The Concentric Circles tool draws nested rings of ovals or circles
You can set the number and spacing of the rings before or after y
draw concentric circles.

To use the Concentric Circles tool

1 Select the Concentric Circles tool.

2 Drag to draw a bounding box that defines the size of the co
centric circles object. A rectangular bounding box creates conce
tric ovals; a square bounding box creates true circles.

3 When you finish, the concentric circles object is selected. 

◆ To draw true concentric circles: Press Shift to constrain the 
bounding box to a square when you drag the Concentric Circles t

◆ To draw from the center: Press Option (Mac) or Ctrl (Win-
dows) to draw from the center outward with the Concentric Circle
tool. Press Shift also to draw perfect circles outward from the cen

To edit concentric circles

You can change the number of rings of an existing object drawn w
the Concentric Circles tool.

1 Double-click the Concentric Circles object. The Concentric 
Circles dialog box appears. 

2 Adjust the settings as described in the next section. Click O
to close the dialog box and apply the settings to the object.

To configure the Concentric Circles tool

Before you draw an object, you can double-click the Concentric C
cles tool icon to open the Concentric Circles dialog box. Use the 
log box to configure the Concentric Circles tool before you draw 
with it, or to change the configuration of an existing concentric cir
cles object.

Concentric Circles tool

A Type the number of circles 
you want the tool to draw.

B Type the number of points 
between each circle. Type zero 
to evenly space the circles.

A

B

.14 DRAWING BASICS
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Drawing cubes
The Cube tool draws 2D cubes using the current object attributes

To draw a cube

1 Select the Cube tool. 

2 Drag to draw the rectangular back face of the cube. To con-
strain the faces of the cube to perfect squares, hold down the S
key while drawing the back face.

3 Release the mouse button when the back face of the cube i
as you want; an unanchored cube then follows the pointer. 

4 Position the cube so it appears at the length and angle you 
want, and then click to anchor it. 

• To give the cube a perspective effect by enlarging the fro
face, hold down the Command key (Mac) or the Alt key 
(Windows) before you anchor the cube.

Editing cubes

To change the height or width of a cube, click the cube to select i
and then drag a corner handle. To reshape a cube by moving a s
double-click the cube to place it in edit mode. A black circular hand
appears on each of the six faces of the cube. When you point to a
dle, the outline flashes on the corresponding side of the cube. Yo
can drag the handle to move that side. Click outside the cube to le
edit mode.

Cube tool

Drawing the back 
face of the cube

Positioning the front 
face of the cube

Finished cube 
selected

Pointer

A cube in edit mode

Front FaceHandle

Pointer
Using specialized drawing tools 15.15
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Drawing spirals
The Spiral tool draws a smooth, spiraling curve. You can set the 
number of spiral turns before or after you draw a spiral object.

1 Select the Spiral tool in the Object tools toolbar.

2 Drag diagonally to specify the size of the spiral curve. To cr
ate a circular spiral, press Shift and drag.

To configure the Spiral tool

Double-click the Spiral tool to open the Spiral dialog box. Set the 
number of spirals and click OK.

◆ To change the number of spirals in an object: Double-click 
the object to open the Spiral dialog box. Change the number of s
rals and click OK.

Drawing grids
The GridMaker tool draws grids of rows and columns. You can se
the number of rows and columns before or after you draw a grid 
object.

1 Select the GridMaker tool in the toolbox.

2 Drag diagonally to define the grid’s bounding box. To create
square grid, press Shift and drag.

To configure the GridMaker tool

Double-click the GridMaker tool to open the GridMaker dialog box
Set the number of boxes comprising the grid and click OK.

Spiral tool

Set the number of turns (maximum 35) 
in the spiral

GridMaker tool

Set the number of columns

Set the number of rows
.16 DRAWING BASICS
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If you set Boxes Across to 1, the grid has no vertical lines. If you 
Boxes Down to 1, the grid has no horizontal lines.

◆ To change the configuration of a grid object: Double-click 
the grid object to open the GridMaker dialog box. Change the num
ber of boxes and click OK.

To separate a grid into lines

You can adjust the individual lines that comprise a grid by convert
it to a path and then ungrouping it.

1 Select the grid object and choose Object > Path > Convert t
Paths.

2 Choose Object > Ungroup. The grid object separates into in
vidual lines.

Drawing with the Multigon tool
You can use the Multigon tool to draw all types of multi-sided 
objects, including triangles, hexagons, pentagons, octagons, star
circular starbursts, and similar shapes. To set the number of sides
the style of a multigon, configure the Multigon tool before you dra

◆ To draw with the Multigon tool: Select the Multigon tool. 
Drag diagonally to define the multigon’s bounding box. To make t
bounding box square, press Shift and drag.

◆ To configure the Multigon tool: Double-click the Multigon 
tool icon. In the dialog box, set the multigon style and other option
(described next) and click OK.

Style Appearance

Frame No interior lines

Framed Star Combination of Frame and Star objects

Spoke No sides connecting the spoke points

Star Points connected by interior lines

Star Outline Multiple points with no interior lines

Wheel Combination of Frame and Spoke objects

Multigon tool
Using specialized drawing tools 15.17
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Saving custom Multigon settings

You can save Multigon tool settings so you can use them later. In
Multigon dialog box, press the triangle at the lower-left to save, 
select, and delete custom multigon styles.

◆ To save multigon settings: Choose Save Shape. Type a name
for the shape and click OK. The name appears in the pop-up men

◆ To delete a style: Choose Delete Shape. In the dialog box, 
choose the shape name you want to delete and Click OK. You ca
delete any of the built-in styles.

Note: When you save and delete styles, they remain saved or del
whether you click OK or Cancel to close the Multigon dialog box.

Editing star multigons

You can interactively edit star multigons (framed star, star, and st
outline styles) to adjust the twirl and radius of the object’s points. T
following procedures do not apply to frames, spokes, or wheels.

1 Double-click the star multigon to put it in interactive mode. A
outer handle and an inner handle appear on one point of the sta

• To change the length of the star points, drag the outer ha
dle inward or outward from the center of the star.

Multigon dialog box

The available options depend 
on the selected multigon 
style.

A Choose a preset style in the 
pop-up menu.

B Click to choose a custom 
style or to save or delete one.

C Preview shows the style and 
other settings.

D For stars, framed stars, and 
star outlines, enter the number 
of star points from 3 to 100. For 
other styles, enter the number 
of sides from 3 to 100.

E Drag the slider to change 
the interior area of stars, framed 
stars, and star outlines.

F Turn this option on to 
smooth the object’s angles.

G For stars, enter a value of 
more or less than 0 degrees to 
bend the points. Negative val-
ues bend the points counter-
clockwise.

B

A

D

E

F 

G

C

Smooth option (left) 
and Pinwheel Angle 
(right)
.18 DRAWING BASICS
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• To twirl the points, drag the handle clockwise or counter-
clockwise.

• To change the position of the inner points, drag the inner
handle inward or outward from the center.

2 To end interactive editing, press Enter (Mac) or Esc (Win-
dows), or double-click outside the object.

Connecting objects with Smart Lines
The Smart Lines tool draws dynamic links between objects. Sma
Lines are useful for creating organizational charts, flow diagrams
and other illustrations with linked objects. 

You can use Smart Lines to link one or more objects to a single 
object. You can draw multiple Smart Lines between objects and y
can link Smart Lines to other Smart Lines. When you resize or mo
a Smart Line, the linked objects move according to the type of Sm
Line used.

1 Select the Smart Lines tools in the toolbox. The Smart Lines
tool is in a pop-out toolbar with the Line tool.

2 Press the Smart Lines tool to open the Smart Lines palette. Y
can drag the palette away from the toolbox to keep it open.

3 Select one of the Smart Lines types in the palette.

Type Characteristics

Basic 

Smart Lines change length and angle to maintain connection 
to the linked objects

Fixed Length

Maintains a set length and linked objects move to maintain the 
length

Fixed Angle

Maintains a set angle and linked objects move to maintain the 
angle
Using specialized drawing tools 15.19
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4 Drag from one object to another object. When you release t
mouse button, Canvas creates the Smart Line.

◆ To change the type of an existing Smart Line: Double-click 
the Smart Line to open the Smart Lines dialog box and choose a 
ferent type in the pop-up menu.

Type of link The link types correspond to the icons in the Smart 
Lines palette. 

Length For Fixed Length Smart Lines, you can specify the lengt
of the selected Smart Line by entering a number in this text box. 

Fixed Angle For Fixed Angle Smart Lines, you can type an angle
in degrees to specify the angle of the selected Smart Line.

Vertical Start/Vertical Stop For a Kinked link type, you can select
Vertical Start to make the Smart Line start with a vertical segmen
and select Vertical Stop to make the Smart Line end with a vertic
segment.

Kinked

Uses only horizontal and vertical segments. Linked objects 
move to maintain the segments. You can set the first and last 
segments to always be vertical.

Locked

Smart Lines do not change length or angle and linked objects 
move as a group

Type Characteristics
.20 DRAWING BASICS
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DRAWING AND EDITING PATHS

Path tools let you draw and edit vector object paths of any shape
This chapter explains how to draw paths, edit paths, and edit curv
segments using the control points that define them.

Drawing with the Path tools 
You can use the Curve, Polygon, Freehand, and Auto Curve too
draw vector objects as open or closed paths. When you use the 
Curve, Polygon, and Auto Curve tools, you set anchor points to 
define path segments. With the Freehand tool, you simply drag t
draw a path. The Reshape and Push tools let you edit paths.

The Polygon tool draws paths with straight segments. The Curve
and Auto Curve tools can draw paths with straight and curved se
ments. Paths drawn with the Freehand tool generally are made o
curved segments based on the movement of the pointer.

When you draw with the Path tools, Canvas uses the current pen
fill ink, and stroke settings for the vector objects you create.

Drawing polygons 
When you use the Polygon tool to draw an object, you set ancho
points that define a path of straight line segments. As with any p
object, you can later make the straight segments curved. For ed
information, see “Editing object paths” on page 16.7.

1 Select the Polygon tool in the Path Tools toolbar.

2 Click to set the first anchor point, shown as a small square.

3 Click where you want to place the second anchor point.

• You can press the pointer to display the segment, drag to
position it, and then release the mouse button.

• To constrain placement of a segment to 45-degree interv
press Shift while drawing the segment.

4 Repeat the last step to draw more segments. To remove the
segment you drew, press Delete.

5 To complete the polygon:

Path tools 

Curve, Freehand, Polygon, 
Auto Curve, Reshape, Push
16.1
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• For an open polygon, after you place the last anchor poin
press Enter (Mac) or Esc (Windows), or double-click to 
place the last anchor point.

• For a closed polygon, click the starting anchor point, and
then press Enter (Mac) or Esc (Windows), or double-click
the starting anchor point.

Smoothing polygons 

You can use the Smooth command to convert a polygon — a pat
made of straight segments — to a path with smooth curves. You 
smooth any paths made of straight segments, including rectangle
and paths drawn with the Curve tool, as long as they have only 
straight segments. The Smooth command is a convenient way fo
those who haven’t mastered curve drawing to create smooth sha

◆ To smooth a polygon: Select the polygon and choose Object 
Path > Smooth. Canvas converts the polygon’s corner points into
smooth points, which changes the path’s straight line segments in
curved segments. For more information about editing smooth poi
and curved segments, see “Reshaping paths by editing anchor po
on page 16.18.

You can use the Unsmooth command to restore the straight segm
of a polygon that was smoothed with the Smooth command. How
ever, you can use Unsmooth only if the smoothed polygon wasn’
edited after it was smoothed.

◆ To unsmooth a smoothed polygon: Select the smooth poly-
gon and choose Object > Path > Unsmooth. Canvas restores the
gon’s straight line segments. 

Click to place first point Click additional points, 
double-click last point

Completed polygon 
(selected)

Polygon finished with 
solid black fill ink 

Polygon

Smoothed
.2 DRAWING AND EDITING PATHS
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Drawing freehand paths 
You can draw objects with the Freehand tool by simply drag
ging the pointer. The Freehand tool creates paths with curv

segments based on the movement of the pointer.

As with any path object, you can later edit the path and reshape i
segments; see “Editing object paths” on page 16.7.

◆ To draw a freehand path: Select the Freehand tool in the Path
Tools toolbar. Position the pointer where you want the path to beg
Drag to create a path. To create a closed path, release the mous
ton when the pointer is on the starting point.

◆ To set the curve tolerance: You can tell Canvas to use rela-
tively more or fewer anchor points to represent a curve. Double-cl
the Freehand tool to open the Freehand Tolerance dialog box. In
text box, type a value from 1 to 5, where a value of 5 tells Canvas
use as few anchor points as possible.

If you have difficulty drawing smooth curves with this tool, try low-
ering the speed setting in your system’s Mouse (or other pointing
device) Control Panel. See your system documentation for inform
tion on these settings.

Drawing curved paths
The Curve tool is the most versatile of the path tools. You c
use it to draw precise paths with straight and curved segme

When you draw curved segments, you place an anchor point and
tangent line at the start of each segment. The position and length
the tangent line controls the shape of the curved segment.

Paths drawn with the 
Freehand tool
Drawing with the Path tools 16.3
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You can also draw straight paths by clicking with the Curve tool, 
similar to the way you use the Polygon tool; see “Drawing polygon
on page 16.1.

To draw a path with curved segments

1 Select the Curve tool in the toolbox.

2 Where you want the path to begin, do one of the following:

• Click to set the anchor point and, before releasing the mou
button, drag to position its tangent line.

• Click to set the anchor point without creating a tangent lin

When you release the mouse button, the anchor point appears.

3 Where you want the segment to end, do one of the following

• Drag to simultaneously set an anchor point and position 
tangent line.

• Click to set the anchor point without creating a tangent lin

This finishes the first curve segment.

4 Repeat the previous step to draw additional segments.

5 To complete the path, use one of the following options:

Anchor point

Tangent line

Defining curves

Anchor points determine 
where path segments (A and 
B) start and end. Tangent 
lines at each anchor point 
control the shape of curve 
segments.

A tangent line affects the 
adjacent segment. The tan-
gent line of a segment’s oth-
er anchor point (not shown) 
also affects the segment’s 
shape.

Handle

A

B

.4 DRAWING AND EDITING PATHS
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• For an open path, after you place the last anchor point, pr
Enter (Mac) or Esc (Windows). You can also double-click
to place the last anchor point.

• For a closed path, click the starting anchor point, and the
press Enter (Mac) or Esc (Windows). You can also doubl
click the starting anchor point.

Shaping and editing segments as you draw
As you draw with the Curve tool, you can use modifier keys to co
strain and edit the path segments.

◆ To place an anchor point at a 45-degree interval relative to 
the previous one: Press Shift as you set the second anchor point.

◆ To create a straight segment: Press Option (Mac) or Ctrl 
(Windows) as you click to set the segment’s endpoint.

◆ To remove the last segment: Press Delete. You can continue 
to remove segments in the reverse order you created them, until 
delete the entire object.

◆ To constrain a tangent line to 45-degree increments: Press 
Shift as you drag the tangent line.

Drawing auto curves 
The Auto Curve tool draws and edits curved paths. This too
makes it easy to draw smooth curves because it automatica

curves path segments as you simply click or drag the mouse.

When you use the Auto Curve tool, you don’t have to position tan
gent lines that control the shape of curves. Instead, you simply cl

To draw the curve shown in 
gray, press and drag to set the 
first anchor point and tangent 
line.

Press and drag to set the next 
anchor point and tangent line. 
The first segment (highlighted) 
grows as you draw out the tan-
gent line. 

Press and drag to set the third 
anchor point; the second seg-
ment (highlighted) grows as 
you drag the tangent line.
Drawing with the Path tools 16.5
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to set anchor points and smooth curve segments appear. You ca
drag the mouse to see how the path will curve before you set eac
anchor point.

Like the other path tools, you can use the Auto Curve tool to draw
new paths and to add segments to paths as you edit them. 

To use the Auto Curve tool

1 Select the Auto Curve tool. The tool is in the Path toolbar in
the toolbox.

2 Click in the drawing area to set the beginning point of a path
you are editing a path, click to set the path’s next anchor point.

3 Move the mouse and click to set the second anchor point. A
straight segment connects the first and second points. 

• You can press Shift when you click to snap the first segme
to a 45-degree angle.

4 To set the third anchor point, do either:

• Click to set the anchor point. This completes a smooth cur
from the first anchor point to the new anchor point.

• Hold down the mouse button and move the mouse to pre
view the curve. You can see the segments bend as you m
the pointer. Release the mouse to set the new anchor po

5 Repeat the previous step to continue adding anchor points 
the path. You can also select other path tools (Curve, Polygon, 
Push, and Reshape) to continue adding segments to the path.

6 To finish drawing the path, do either:

• Press Esc. 

• Double-click to set the final anchor point. You must doubl
click on the starting point to complete a closed path.

When you finish drawing, the path object is selected. Canvas app
the current pen ink, fill ink, and stroke to the path. You can use pa
editing tools and techniques to modify the path.
.6 DRAWING AND EDITING PATHS
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Editing object paths 
Most vector objects in Canvas are paths. Whether you draw with 
Path tools (Curve, Freehand, Polygon, Auto Curve) or other shap
tools (Rectangle, Oval, Line, Arc), you create paths, and you can 
the same path-editing techniques to modify them.

Of course, you can also change a path object by using handles o
bounding box when the object is selected (see “To resize an obje
bounding box” on page 15.4).

Displaying inks and strokes

Canvas has two display modes you can use when you edit paths.
can display the fill inks, pen inks, and stroke on paths, or you can
hide the attributes while you work in path edit mode.

◆ To display attributes on paths: Be sure that the command 
Object > Path > Live Curve Editing is selected and has a check m
in the menu. To hide attributes in path edit mode, select the comm
again.

You can change the path-editing display at any time. To use the L
Curve Editing command, objects do not have to be selected or be
path edit mode.

Click1

2

3

4
Click

Click

Drawing Auto Curves

With the Auto Curve tool, 
click to set anchor points 1 
and 2 to start a path.

Click to set point 3. The 
first and second segments 
bend to form a smooth 
curve.

You can click to set more 
anchor points and draw 
additional curved seg-
ments. Press Esc to finish 
the path.

Path with pen and fill inks
Editing object paths 16.7
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Editing paths with the Reshape tool
The Reshape tool provides an easy-to-use, interactive wa
edit paths. Using the tool is as simple as dragging the mou
The tool will reshape the parts of a path that you drag ove

To use the Reshape tool

1 Select an object to edit. To use the Reshape tool, one vecto
object can be selected or be in path edit mode.

2 Select the Reshape tool. The tool is in the Path toolbar in th
toolbox.

3 Move the pointer close to the path and a reshape symbol (~
will appear at the pointer. The symbol indicates that you can drag
reshape the path. 

4 Drag to draw a new segment in the shape you want. When 
release the mouse, Canvas applies the segment you drew to th
path. 

5 After you use the Reshape tool, the object remains selected
in edit mode. You can continue to use the Reshape tool to mod
the path.

Reshaping a straight line into a 
curved path

Changing the shape of a curve 
segment 

Dragging to reshape a segment 
and shorten the path
.8 DRAWING AND EDITING PATHS
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Reshape techniques

When you drag the Reshape tool, the direction that you drag affe
the way the tool modifies the path.

If you drag in one direction and finish on the path, the tool will 
reshape the path to match the line that you draw. 

If you finish dragging away from the path, the Reshape tool can c
ate a new segment that opens a closed path. If you drag the tool o
open path, you can draw a new segment that closes the path. You
also drag the tool so it reshapes part of a path and removes the r

In general, if you drag in one direction along a path, the tool will 
change the shape of a segment without removing the rest of the p
or opening the path. For example, if you follow the curve of a circ
as you drag from the top toward the bottom, you can make the ci
narrower. If you drag from one part of the circle and change direc
tion, you can create a segment that changes the circle to an open

Experimenting with the Reshape tool is the best way to learn the 
ious techniques you can use to modify paths.

Editing paths with the Push tool
The Push tool provides an alternative way of editing paths.
The tool lets you form curves without having to edit anchor

points and tangent lines. The Push tool is useful for people who a
not experts at editing paths and who want to simply drag on path 
ments to bend them into shape.

The Push tool bends a path where you “push” (drag) on it. Imagin
that a rope is laid out straight on a table. If you push your finger 
against the middle of the rope, you form a curve at that point. Usi
the Push tool has a similar effect on a straight segment of a path.

You can adjust the range of the Push tool effect. A smaller range
results in sharper bends, and a larger range results in smoother b

Dragging in one direction 
reshapes the circle

Changing direction adds a 
segment and opens the path

Dragging a path with the 
Push tool bends the path. 
The Range setting con-
trols the width of the 
effect.
Editing object paths 16.9
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To use the Push tool

1 Select an object to edit. To use the Push tool, one vector ob
can be selected or be in path edit mode.

2 Select the Push tool. The tool is in the Path toolbar in the to
box. If you want to change the Range of the Push tool, double c
the tool’s icon. Enter a value in the text box and click OK.

3 Drag on the path where you want to push a segment into a 
curve shape. When you release the mouse, Canvas reshapes t
path.

4 After you use the Push tool, the object remains selected or 
edit mode. You can continue to use the Push tool to modify the 
path.

Push tool Range 

To change the Range of the Push tool, double-click the tool icon 
the toolbox. A dialog box appears. The Range value is expressed
the rulers’ measurement units.

To specify the Range value, type a number in the Range text box
You can type an abbreviation for the measurement units following
the range value. For example, to set the Range to 10 picas when
ruler units are inches, enter “10p” in the text box. Click OK to imp
ment the new setting.

Depending on the Range setting, editing a path with the Push tool
add or remove anchor point from the path. For example, when th
Range value is small, the Push tool is likely to add anchor points 
where you push a path. However, when the range is large and a 
is not straight, the Push tool can smooth out a part of the path, wh
can result in fewer anchor points.

Working with objects in edit mode
To edit points and segments of a path, you place the path object 
edit mode. In edit mode, a path’s anchor points appear as small 
squares along the path. Every path has at least two anchor points

Range (top to bottom):
3 in., 2 in., 1 in.
.10 DRAWING AND EDITING PATHS
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When an object is in edit mode, you can select one or more anch
points. You can even select anchor points and segments on more
one object at once, as long as the objects are in edit mode.

To place an object in edit mode

Do one of the following to place a path object in edit mode:

• Double-click the object.

• Select the object and choose Object > Path > Edit Path o
choose Object > Edit > Object.

• Select the Selection tool after placing an anchor point wh
you are drawing a path.

◆ To place multiple objects in edit mode: You can place two or 
more objects in edit mode by selecting them, then choosing Obje
Path > Edit Path.

◆ To return from edit mode: When you finish editing an object, 
double-click outside the object, or press Enter (Mac) or Esc (Win-
dows) to leave edit mode.

Editing special vector objects

Some Canvas drawing tools create specialized objects. When yo
double-click one of these objects to place it in edit mode, Canvas
plays special editing handles or configuration options, rather than
anchor points and segments of a regular path object.

The tools that create special vector objects are the Concentric Circ
Grid Maker, Multigon, Spiral, and EasyShapes tools. Also, when y

Object path drawn with 
Curve tool

Object in edit mode, with 
anchor points visible
Editing object paths 16.11
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modify objects with the Envelope or Extrude commands, Canvas 
ates specialized objects.

If you want to use path-editing techniques to modify these objects
you can convert them to paths. This usually produces a group of 
objects. After you ungroup these objects, you will have regular pa
that can be edited using the techniques in this chapter. You can a
convert text characters to paths so that you can edit the shapes o
individual characters. For more information, see “Converting obje
and text to paths” on page 16.21.

Editing paths with the context menu
When a path is in edit mode, you can use the context menu to qui
add, delete, and change anchor points and tangent lines. To see 
menu, Ctrl-click (Mac) or right-click (Windows) with at least one 
object in path edit mode. The available options vary depending on
location of the pointer. Each option is described next.

Delete Point Available when the pointer is on an anchor point an
appears as a crosshair. Removes the anchor point from the path,
connects the adjacent anchor points with a new segment.

Add Point Available when the pointer is on a path segment and 
appears as a gray arrowhead. Inserts an anchor point with a tang
line where you click.

Break Available when the pointer is a grey arrowhead on a path
Splits the path segment at that location, and adds anchor points to
ends of the resulting segments.

Join Curves Available when you select two anchor points that are
not connected. Connects the selected points with a straight segm

Cusp Available when the pointer is on a tangent line handle or a
anchor point. On anchor points, this option deletes the point’s tang
lines. On tangent line handles, this option makes the path either 
smooth or cornered at the anchor point. To be smooth, the ancho
point must have both sides of a tangent line. When smooth, the 
halves of the tangent line are always 180 degrees from each othe
rotate around the anchor point like a propeller. When the anchor 
point is a corner, the tangent line segments can move independe
around the anchor point, like the hands of a clock.

Delete Handle Available when the pointer is on a tangent line ha
dle and appears as a crosshair. Removes the handle and the effe
the tangent line on the path.

Delete Point
Add Point
Break
Join Curves
Cusp
Delete Handle
Add Handle
Straighten

F Fillet

The path-editing Context menu
.12 DRAWING AND EDITING PATHS



d 
nt. 

 
y 

an 
or-
 box 
ger 
ars if 

or 
 you 
edit 

 the 
to a 

y 
ll 

h 
s.
Add Handle Available when the pointer is on an anchor point an
there are fewer than two tangent line segments at the anchor poi
Adds one or two tangent line segment to the anchor point.

Straighten Available when the pointer is on a path segment and
appears as a gray arrowhead. Makes the path segment straight b
removing tangent lines from the segment’s anchor points.

Fillet Available when the pointer is on a corner point (with less th
two tangent lines between two segments. Fillet creates a radius c
ner between the two segments. When you choose Fillet, a dialog
appears. Enter a radius value in the text box and click OK. The lar
the radius value, the larger the curved segment. A message appe
the radius value is too large for the angle of the segments.

Selecting anchor points and segments
When you edit paths, you need to select particular anchor points 
segments before you can delete, move, or reshape them. Before
can select anchor points and segments, a path object must be in 
mode (see “To place an object in edit mode” on page 16.11). 

When a path is in edit mode and you point to an anchor point with
Selection tool, the pointer becomes a crosshair. When you point 
segment, the pointer becomes a gray arrowhead.

You can select points in more than one path. When you move an
selected point, all points in the selection move the same way. (If a
the points in a path are selected and you drag one, the entire pat
moves.) This also works for segments belonging to separate path
Editing object paths 16.13
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◆ To select anchor points and segments: With the path object in 
edit mode, click an anchor point or segment to select it. To select
multiple points or segments, use the Selection tool to drag a selec
box around them, or Shift-click each point or segment.

◆ To select all anchor points: With the path object in edit mode, 
choose Select All in the Edit menu.

◆ To select parts of separate paths: Place the paths in edit 
mode, and Shift-click the point or segments.

When an anchor point is selected, it changes from a solid to hollo
square. If the anchor point has tangent lines, they appear when th
anchor point is selected. All tangent lines that affect the segments
touch the selected anchor point also appear. When you select a s
ment, the anchor point at each end is selected. 

Adding and deleting points and segments
If a segment’s anchor points are too far apart for you to adjust the
shape as needed, you can add more. If you create or add more a
points than you need, you can delete unnecessary ones.

Keep in mind that the more points on a path, the more complex a
system resource-intensive it becomes. In particular, too many anc
points can cause printing problems. It’s best to use the fewest po
ble anchor points placed as far apart as possible to create a path

◆ To add an anchor point: With an object in edit mode, Ctrl-
click (Mac) or right-click (Windows) a segment to which you want t
add an anchor point. In the path Context menu, choose Add Poin
You can also Option-click (Mac) or Ctrl-click (Windows) a segmen
to add a point.

◆ To delete an anchor point: With an object in edit mode, Ctrl-
click (Mac) or right-click (Windows) the point you want to delete. I
the path Context menu that appears, choose Delete Point. You c
also Option+Shift-click (Mac) or Ctrl+Shift-click (Windows) a poin
to delete it, or select points and press the Delete key.

◆ To delete a segment: Select the anchor points at each end an
press Delete. Deleting a segment of a closed path does not open
path; the remaining segments are joined and the path remains clo

To add segments to an open path

You can add segments to the end of an open path using the Curv
tool or Polygon tool.

You can use the Selection tool to 
select multiple anchor points.
.14 DRAWING AND EDITING PATHS
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1 With the object in edit mode, select the endpoint where you
want to add a segment.

2 Select the Curve tool (to add straight or curved segments) o
the Polygon tool (to add straight segments) in the toolbox.

3 Click to add a straight segment beyond the selected endpoi
With the Curve tool, you can add a curved segment by pressing
mouse button to establish the new anchor point and then dragg
to position the tangent line.

4 To add additional segments, repeat the previous step. Whe
you finish, press Enter (Mac) or Esc (Windows) to leave edit mo

Closing and opening paths
A closed path is one that starts and ends at the same anchor poin
open path has separate starting and ending points. You can close
open path by letting Canvas create a new segment to join the pat
two endpoints. You can open a closed path by splitting the path.

◆ To close an open path: With the path in edit mode and the 
Curve or Polygon tool selected, click one of the endpoints. Canva
closes the path by connecting the endpoints with a new segment
the adjacent segments are curved, the new segment follows the c

◆ To open a closed path: With the object in edit mode, Ctrl-
click (Mac) or right-click (Windows) an anchor point or segment to
open the path Context menu. In the menu, choose Break; Canva
inserts segment end points to open the object at that location.

Using the Scissors tool to open and divide paths 

You can use the Scissors tool to open a closed path and to divide
path into two objects. Splitting a path opens the path at the point 
where the scissors clip the path. 

1 Select the Scissors tool in the toolbox. The pointer changes 
pair of scissors.

2 Point to the path where you want to split it (you don’t need t
select the object first). The pointer becomes a crosshair when it
on a point or segment that can be split.

3 Click the path when the crosshair is displayed. Canvas add
two endpoints where you click the path and the path opens.

4 If the path is closed and you want to split it into two paths, 
click the path again where you want to split it.

Scissors tool
Editing object paths 16.15
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Dividing objects with the Knife tool
You can divide vector objects into separate pieces using the Knif
tool. The Knife tool is located in the Effects toolbar. 

When you drag the Knife tool, it draws a cutting path. If the cuttin
path divides an object into two parts, the result is two new objects
the cutting path crosses itself, the area inside the path becomes a
object.    

The Knife is similar to the Scissors tool; both tools divide vector 
objects. The Scissors tool divides an object with a straight line 
between the two points that you click. The Knife tool slices object
along a freeform cutting path. Therefore, you can use the Knife to
to cut curved edges.

You can use the Knife tool on open and closed vector objects. If y
slice one or more open paths, the resulting objects are open path

If you slice an open path that crosses itself, the path separates w
it crosses itself and where you slice it.

◆ To use the Knife tool: Select the Knife tool. Drag in the docu-
ment to draw a cutting path that intersects the objects you want to
divide. The cutting path must intersect at least two points on an 
object’s perimeter. To constrain the path of the Knife tool to 45-
degree increments, press Shift as you drag. Release the Shift ke
drag freely.

Partial cuts If you stop dragging before the cutting path intersects
second point on an object's perimeter, the cutting path appears bu
object stays intact. To use this cutting path to divide the object, yo
can drag a second cutting path so it intersects the perimeter of th
object and the first cutting path. Or, you can intersect the cutting p
with other cutting paths to create a closed shape. The part of the 
object that falls within the closed shape becomes a separate obje

Cutting holes You can cut out pieces of a vector object by drag-
ging inside of the object and creating a closed path. The parts of 
object that fall within the closed cutting path become separate 
objects. To create a closed cutting path, the path must cross itsel

Gradient inks If an object’s fill ink is a gradient, and the style is 
Radial, Directional, Rectangular, or Elliptical, the gradient remain
intact across the separated objects. However, if the gradient style
Shape, the gradient fills each divided object separately.

Knife tool

…to slice an object

Drag the Knife tool…
.16 DRAWING AND EDITING PATHS
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Knife tool options

To configure the Knife tool, double-click the Knife tool icon. In the
dialog box that appears, select an option and click OK.

Cut Only Selected Objects Select this option to make the Knife 
tool slice only vector objects that are selected and intersected by
cutting path. This setting can prevent unintentional changes to nea
objects. 

Cut All Objects Select this option to make the Knife tool slice any
vector objects that the cutting path intersects, whether the objects
selected or not.

Joining two paths

You can use the Join command to create one path from two sepa
open path objects.

◆ To join two paths: Select the two open path objects that you 
want to join (they should not be in edit mode). Choose Object > P
> Join. Canvas connects the two paths by extending the existing 
ments or creating a new segment, depending on the distance bet
the objects.

When you use the Join command to connect two objects that are
more than 15 pixels apart, Canvas creates a new line segment 
between the two closest endpoints. When you join objects whose
endpoints are 15 or fewer pixels apart, Canvas extends the two 
objects to a midpoint between the two closest endpoints.

When the two endpoints on the paths to be joined are 15 or fewe
screen pixels apart, you can add a segment by pressing Shift wh
you choose Join. When the distance between the endpoints is gr
than 15 pixels, you can extend the existing segments by pressing
Shift when you choose Join.

To join paths at selected endpoints

Canvas, by default, joins paths at the closest endpoints. Howeve
you can select which endpoints to join.

1 Place an open object or multiple open objects in edit mode; 
“To place an object in edit mode” on page 16.11.

2 Click an endpoint you want to join to another path. The end
point becomes hollow to indicate that it is selected.
Editing object paths 16.17
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3 Shift-click another endpoint. The endpoint also becomes ho
low to indicate that it is selected.

4 Choose Object > Path > Join, or Ctrl-click (Mac) or right-clic
(Windows) one of the selected points. In the context menu, cho
Join Curves.

Moving anchor points and segments
With a path in edit mode, you can move points and segments to a
the shape of the path. 

Drag an anchor point or segment to move it. You can also press 
keyboard arrow keys to move selected points and segments. Mo
reshapes the segments you drag or the segments attached to the
points that you move.

Pressing Shift while dragging points or segments will constrain th
movement to 45-degree intervals.

When you begin to drag a segment, the anchor points display the
tangent lines. You can control the movement of the tangent lines 
using modifier keys when you drag the segment.

Expand or contract curves Press Tab and drag a segment to 
change the length of its tangent lines without changing their angle
This is the way that segments could be reshaped (without pressin
Tab) in Canvas 3.5 and earlier versions.

Reshape adjacent segments To reshape a segment and adjacent
segments together (if they are joined with smooth anchor points),
press Command (Mac) or Alt (Windows) and drag the segment.

Reshaping paths by editing anchor points
A path can contain two kinds of anchor points: smooth points and
corner points. 

Smooth point An anchor point that connects two curve segment
where the curve flows smoothly through the anchor point without 
sharp change in direction. Circles and sine waves are examples o
paths that have only smooth anchor points. 

Corner point An anchor point where the path makes a sharp turn
the anchor point. Corner points can connect two straight segmen
two curved segments, or one curved and one straight segment. 
.18 DRAWING AND EDITING PATHS
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Tangent lines
All smooth points, and some corner points, have tangent lines pa
ing through them. Canvas displays the tangent lines when a poin
selected. 

A corner point can have one, two, or no tangent lines.When you 
select a corner anchor point with two tangent lines, each tangent 
can move independently. 

When you create paths with only straight segments, the anchor po
are corner points. When you draw curved paths with the Curve, F
hand, or Auto Curve tools, the anchor points are smooth points. A
ing anchor points to curved segments produces smooth points.

To change a smooth point to a corner point

You can edit, reshape, and resize two adjoining curve segments 
pendently by converting their smooth anchor point to a corner po

1 With the object in edit mode, click the anchor point to revea
its tangent lines.

2 Press Tab and drag one of the handles to move one of the 
gent lines. The tangent line pivots at the anchor point and affect
only one side of the anchor point.

To change a corner point to a smooth point

To smooth out a sharp turn in curved segments, you can change
corner point between them to a smooth point.

Note: The corner point must have two tangent lines for this proce-
dure. If it has fewer than two, first add tangent lines to the point.

1 With the object in edit mode, click the anchor point to displa
its tangent lines.

2 Tab-click the handle of the tangent line you want to keep in 
place; the other tangent line snaps into alignment.

Adding and removing tangent lines
An anchor point can have as many as two tangent line segments.
ner points can have one, two, or no tangent lines, and smooth po
must have two. You can quickly convert a smooth point to a corn
point by deleting one of its tangent lines. Also, to convert a corne
point with one or no tangent lines to a smooth point, you must ad
tangent lines.

A corner anchor point with 
independent tangent lines

Tab-click a corner point’s 
handle to snap the other 
tangent line into alignment 
and smooth the path
Reshaping paths by editing anchor points 16.19
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To add a tangent line

1 In path edit mode, select an anchor point with one or no tan
gent lines. The anchor point cannot be an endpoint with one tang
line, because endpoints can have only one tangent line.

2 Press Tab and drag away from the anchor point to place a n
tangent line segment. You can also Ctrl-click (Mac) or right-click
(Windows) and choose Add Handle in the context menu. As you
this, the new tangent line begins altering the segment based on 
you drag to position the tangent line.

3 Repeat the previous step to add a second tangent line.

To delete tangent lines

1 In edit mode, click an anchor point to display its tangent line

2 Depending on how you want to edit the anchor point, do one
the following:

• To delete one tangent line, Ctrl-click (Mac) or right-click 
(Windows) the tangent line handle and choose Delete Ha
dle in the context menu. You must use this method for 
anchor points with only one tangent line, and to delete on
of two tangent lines attached to an anchor point.

• To delete an endpoint’s tangent line, you can also Tab-cl
the anchor point.

• To simultaneously delete both tangent lines of an anchor
point, Tab-click the point.

Straightening curve segments
You can straighten a curved segment by selecting it and using th
Straighten command in the context menu. This command deletes
tangent line(s) that are curving the segment.

◆ To straighten a segment: With the object in edit mode, Ctrl-
click (Mac) or right-button click (Windows) the curved segment th
you want to straighten. Choose Straighten in the context menu.

Reshaping curve segments
To adjust the shape of a curve, in addition to moving points and s
ments along the path itself, you can adjust the tangent lines that c
trol the curve. The angle of the tangent line affects the curve shap
while the length of the tangent line affects the size of the segmen
.20 DRAWING AND EDITING PATHS
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At a smooth anchor point, adjusting the angle of a tangent line affe
the curves on both sides of the anchor point. At a corner anchor p
you can reshape the segments on each side independently. For m
information, see “Reshaping paths by editing anchor points” on 
page 16.18.

To reshape a curved segment

1 With the object in edit mode, click one of the segment’s anch
points to display its tangent lines.

2 Drag the handle of the tangent line to change the shape of t
associated curve. In the case of a smooth point, the tangent line
affects both adjacent curve segments.

Path editing shortcuts

Converting objects and text to paths
Some vector objects have specialized properties and unique edit
modes instead of the standard path edit mode. For example, you

To do this Shortcut (Mac) Shortcut (Windows)

Add an anchor point Option-click path Ctrl-click path

Delete an anchor point Option+Shift-click anchor point Ctrl+Shift-click anchor point

Change the length of the tangent lines on both 
sides of a smooth anchor point at the same time

Option-drag tangent line handle Ctrl-drag tangent line handle

Constrain tangent line to 45-degree increments Shift-drag tangent line handle

Move tangent line segment independently 
(change anchor point from smooth to cusp)

Tab-drag tangent line handle

Align tangent line segments (change corner 
point with two tangent lines to smooth point)

Tab-drag tangent line handle

Add tangent line to an anchor point Tab-drag an anchor point

Delete an anchor point’s tangent lines Tab-click the anchor point or endpoint

Close an open path Click an endpoint with a Path 
drawing tool 

Alt-click an endpoint

Reshape a segment without changing the tan-
gent line angles 

Press Tab and drag the segment

Reshape A segment and adjacent segments Press Command and drag a seg-
ment

Press Alt and drag a segment
Reshaping paths by editing anchor points 16.21
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not directly edit the path segments of macros, concentric circles, 
grids, multigons, spirals, and objects modified by the Envelope or
Extrude commands. However, you can convert these objects to p
so you can edit them the same as any other vector object.

If you create paths from a specialized vector object, the new shap
does not have the same unique editing capabilities as the original
example, if you convert a multigon star object to paths, you can n
longer use the edit handles that let you adjust the depth and twirl
the points. Similarly, placed macros are no longer linked to their p
ent macros in the Gallery palette after you convert them to paths.

You can also convert text so you can reshape characters as vect
objects. This has the benefit of making the characters independe
their fonts; the font is no longer required to view and print the char
ters properly. However, once you convert text to paths, you can n
longer perform text operations, such as editing, spell-checking, a
formatting, on the text. Also, characters with “holes” in them (such
a, b, d, e, g, o, p, r, and q) are converted to composite paths, whi
cannot be extruded.

◆ To convert an object to paths: Select the object you want to 
convert and choose Object > Path > Convert To Paths. Canvas c
verts the object to one or more paths.

Ungrouping objects made of multiple paths

When you convert multiple objects, characters, or specialized vec
objects to paths, Canvas creates a separate path for each shape
groups them. You can choose Object > Ungroup to separate them

For example, if you convert a five-letter word to paths, the resultin
object is a group of five paths. To edit just one of the five paths, fi
choose Object > Ungroup. Or, use the Direct Selection tool to sel
one path without ungrouping.

Making and breaking composite paths
You can create openings in a filled path by incorporating multiple
paths into a single, composite path. Areas between the paths and
areas where the paths intersect are transparent.

◆ To create a composite path from multiple paths: Select the 
paths you want to make into a composite path. Choose Object > P
> Make Composite.
.22 DRAWING AND EDITING PATHS
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◆ To separate a composite path: Select the composite path and
choose Object > Path > Break Composite.

Simplifying vector paths
The Reduce Points command lets you simplify vector paths by red
ing the number of anchor points in the path. 

Simplifying is a good practice when paths you import or create ha
a very high number of anchor points. These paths can cause slow
printing or printer errors, especially when memory is limited. If you
have problems printing a complex vector path, try simplifying it.

You can use the Reduce Points command when one vector objec
in path edit mode, or when one or more vector objects are selecte

Reduce Points works with objects created with the Curve, Auto 
Curve, Freehand, and Polygon tools. You can apply it to objects c
ated with other tools if you use the Object > Path > Convert to Pa
command to convert the objects to vector paths.

Reduce Points is not available when specialized vector objects (c
centric circles, Smart Shapes, multigons, and similar objects) are
selected or in edit mode. These objects must be converted to pat
you want to simplify them.

To use the Reduce Points command

1 Select one or more vector objects, or place one object in pa
edit mode (select it and choose Object > Edit). In edit mode, you
can select three or more anchor points and apply Reduce Point

2 Choose Object > Path > Reduce Points. 

3 A dialog box appears. Drag the slider to set the relative num
of anchor points to use for the path.

Loose leaves fewer points in the path by tracing the original path
more smoothly. Tight removes fewer points by tracing the origina
more closely. When more points are removed, the change in the
path can be greater.

4 Click OK to modify the path. 
Simplifying vector paths 16.23
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Converting polygons to Bézier objects
The Fit Bézier command changes a polygon to a Bézier curve pa
This command can be applied to a single selected polygon that is
in edit mode.

Using this command can have varied results, depending on the s
tings you use. You can convert a polygon without changing its sha
Or, you can use the command to smooth the straight segments o
polygon into gentle curves.

Fit Bézier is useful when you want to use handles attached to smo
anchor points to “bend” straight path segments into curves. Using
Bézier adds handles to all the corner points (which do not have h
dles) that define a polygon.

To use the Fit Bézier command

1 Select a polygon (open or closed). 

A polygon can be created with the Polygon tool, or with the 
Curve tool if the path has only corner points, not smooth 
points. Objects created with the Rectangle tool or Line tool c
be converted to polygons with the Object > Path > Convert 
Paths command.

2 Choose Object > Path > Fit Bézier. 

3 A dialog box with two sliders appears. Use these to adjust t
following conversion settings: 

Loose-Tight: Controls how closely the modified path will conform to
the original path. Tight results in little deviation from the original 
path. Loose allows the modified path to be smoother and deviate
ther from the original. 

Round-Sharp: Controls how many corners will become rounded in
the modified path. Sharp preserves corners where segments mee
acute angles. Round allows all corners to become rounded.

These settings can interact and produce similar results at differen
slider positions. For example, setting one slider at Tight and the o
at Round can produce a path that closely matches the original, bu
with all corners being rounded. Setting one slider at Loose and th
other at Sharp can result in a path that overall is smoother, but wh
has some corners that are not smoothed at all.

4 Click OK when you’re done. Canvas modifies the object bas
on the settings you specified.
.24 DRAWING AND EDITING PATHS
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PRECISION DRAWING AND 
DIMENSIONING

This chapter describes precision drawing tools and techniques th
can help you create scale drawings, floor plans, architectural desi
and other types of technical drawings. This chapter explains how

• display size information as you draw

• set up the scale for scale drawings

• add dimension objects to illustrations

• use Smart Mouse to align objects

Some of the techniques described elsewhere in this book also ap
to precision drawing. For information on document setup and usin
rulers, refer to Chapter 3, “Document Setup.”

Setting up a document’s measurement scale
Canvas offers a variety of options for creating scale drawings. Yo
can set up a ruler to control the scale of an entire document. You
also customize scale settings for individual dimension objects. Ot
settings affect the format of measurement and position data.

The following settings affect the measurement of objects in a doc
ment:

Rulers You set up a document’s overall drawing scale using the 
Rulers command and Rulers dialog box. The ruler scale affects a
object measurements, including those made with the dimensionin
tools. The ruler scale also affects data in the Object Specs palette
status bar. See “Setting up rulers and the drawing scale” on page

Number Form A setting in the Preferences dialog box affects the
format of data in the Status bar and other displays. This option co
trols the precision of data and the number format (decimal or frac
tions). See “Measurement units preferences” on page 9.14.

Dimensions You can create custom scale settings for dimension
objects using the Dimensioning dialog box. You can customize in
vidual dimension objects, or set a custom scale for all dimension 
objects created with a dimensioning tool. See “Customizing the 
dimensioning tools” on page 17.6 for more information.
17.1
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Displaying dimensions as you draw
Canvas can display the horizontal and vertical dimensions of an 
object as you draw it. The Show Size command makes dimensio
(in scale) appear at the pointer as you drag with any drawing tool
These dimensions do not remain in the document. 

◆ To display dimensions when you use drawing tools: Choose 
Layout > Display > Show Size. When you select a drawing tool a
drag the pointer in an illustration, the object’s vertical and horizon
measurements appear at the pointer.

When Show Size is on, the command changes to Hide Size.

◆ To turn off the dimensions display: Choose Layout > 
Display > Hide Size. This command only appears when Show Siz
on.

Using the Status bar display

The Status bar at the bottom of the screen displays dimensions a
position data that can assist you when you draw objects.

The data in the Status bar are based on the overall document sca
defined by the current ruler setting. When you draw a vector obje
the status bar displays the horizontal and vertical dimensions for m
objects. When you move an object by dragging it with the Selecti
tool, the status bar displays the horizontal and vertical distance th
the object has moved. The measurements are based on the over
measurement scale as defined in the Rulers dialog box.

Using the dimensioning tools
You can easily add formatted dimensions to documents with the C
vas dimensioning tools. These tools can measure horizontal, vert
oblique and perpendicular distances; measure diameter, radius, a
area, and perimeter; and mark the centers of arcs and ovals.

Some dimensioning tools create a single dimension, while others
you create baseline and chain dimensions. Baseline dimensions 
series of measurements made from a common starting point. Ch
dimensions are a series of measurements in a row.

When Show Size is active, 
Canvas displays the scaled size 
of the object as you draw.
.2 PRECISION DRAWING AND DIMENSIONING
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You can create dimension objects that conform to industry standa
including the ANSI, DIN and JIS standards. You can also custom
the standard settings — the size of lines, gaps, text, and toleranc
You can also save settings that you have customized as new sta
dards.

The 17 dimensioning tools are grouped in a palette. To open the 
ette, press the dimensioning tool that appears in the Object tools 
ette. You can drag the palette away from the toolbox to keep it op
while you work.

To add dimensions to an illustration

1 Select a dimensioning tool in the toolbox. When you move t
pointer into the document, a prompt appears at the pointer. 

2 To begin dimensioning, position the pointer and click as 
directed by the prompt. The prompt varies, depending on which
dimensioning tool you use. For example, if you use the Horizon
dimensioning tool, the prompt says “Click 1st Point.” 

Refer to the table “Dimensioning procedures” on page 17.5 for 
details on what you should do when each prompt appears.

3 When the “Anchor” prompt appears, move the pointer to po
tion the dimension. If you drag away from the measurement poin
the witness lines extend and the text follows the pointer.

4 To anchor the dimension in place, click once.

5 For chain and baseline dimensions, you can click additional
measurement points and anchor each part of the dimension obj
After you anchor the last part, press Enter (Mac) or Esc (Window
to finish the object.

✔Tip
The Smart Mouse can help 
ensure precise measurements. 
You can set the Smart Mouse 
so the pointer snaps to corners 
and anchor points when you 
use dimensioning tools. See 
“Using Smart Mouse for pre-
cise alignment” on page 17.11.
Using the dimensioning tools 17.3
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Types of dimensioning tools and measurements

You use the dimensioning tools 
to add measurements to illus-
trations. Different tools let you 
create different types of dimen-
sion objects.

Baseline and chain dimension-
ing tools create groups of 
dimensions. Baseline dimen-
sions contain several measure-
ments from a common starting 
point. Chain dimensions are a 
series of measurements.

A Vertical

B Oblique

C Radius

D Diameter

E Vertical Baseline

F Oblique (with aligned text)

G Vertical Chain

H Angle

I Horizontal

 19.3  ft. 

 11.7  ft. 

 16.7  ft. 

 13.9  ft. 

 28.3  ft. 

74.98°

 1
6.

7 
 ft

. 

A

B

D

C

E

F
GH

I

 2.80  cm. 

 5.75  cm. 

 0.90  cm. 

 2.86  cm. 
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Dimensioning procedures

Linking dimensions to measured objects
Because dimension objects aren’t attached to the objects they m
sure, dimensions do not change when you resize objects you hav
measured. However, you can group a dimension object and the ob
that it measures. When you do this and then you resize the object
dimension changes accordingly.

◆ To group an object and a dimension object: Select the 
dimension object and the measured object and choose 
Object > Group.

Attributes of dimension objects
When you create a dimension object, Canvas uses the current ink
stroke settings, which are shown by the Pen ink, Fill ink, and Stro

Dimensioning tool Prompts Procedure

Horizontal, Oblique, and Vertical

Click 1st Point, Click 
2nd Point

Click the start point for the measurement, then click 
the end point and anchor the dimension object.

Baseline and Chain (Horizontal, 
Oblique, and Vertical)

Click 1st Point, Click 
Next Point

Click the start point and then click the end point for 
the first measurement; anchor the first part of the 
dimension object. Click the next measurement point 
and anchor the next part of the dimension object. 
Continue until finished, then press Enter (Mac) or Esc 
(Windows).

Angle Click 1st Line, Click 
2nd Line

Click the start point for the angular measurement, 
then click the end point.

Perpendicular Click Line, Click 
Point

Click the line to measure from, then click a point any-
where to take a perpendicular measurement from the 
line to the point.

Object Side Click Object Side Click the side of the object to be measured.

Radius, Diameter, and Center

Click Arc/Ellipse Click anywhere on the arc or ellipse and then anchor 
the dimension object.

Area and Perimeter

Click Object Click anywhere on the object to be measured and 
then anchor the dimension object.
Using the dimensioning tools 17.5
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icons in the toolbox. The dimension text uses the current text settin
as indicated in the Text menu by a check mark. 

You can change the current ink, stroke, and text settings for new 
dimension objects, and you can change these settings for existin
dimension objects.

◆ To change the type attributes of a dimension object: Select 
the dimension object and use the Text menu or the Type palette 
choose the font, size, style, and other attributes of the text. 

◆ To change the appearance of a dimension object: Select the 
object and use the Inks and Strokes palettes to select ink color, p
size, and arrows for the dimension object.

◆ To change attributes for new dimension objects: Make sure 
that no objects are selected in the document, and then use the Te
menu (or the Type palette), and the Inks and Strokes palettes to 
change the current settings for new objects and text.

Customizing the dimensioning tools
You can customize the measurement units, scale, arrow position
erance text, and other settings for dimension objects. You use the
Dimensioning dialog box to configure these settings. You can set
different configurations for the three categories of dimensioning to
— angular, linear, and radial. You can also use the Dimensioning
dialog box to change existing dimension objects.

Using the Dimensioning dialog box

You can open the Dimensioning dialog box by double-clicking a 
dimensioning tool icon or a dimension object, depending on whet
you want to configure the tool or edit a dimension object. Use one
the following three methods to open the dialog box. 

◆ To change the properties of regular dimension objects:

Double-click the dimension object to open the Dimensioning dialo
box. To change multiple dimension objects, select them and then
double-click one of the objects.

◆ To change the properties of chain and baseline dimension 
objects: Select the dimension object and choose Ungroup in the 
Object menu. Then, double-click one of the dimension objects to 
open the Dimensioning dialog box. You can also double-click a 
dimension object with the Direct Selection tool to open the dialog
box without ungrouping the objects first.

✔ Important
Dimension objects can not dis-
play arrows if all the preset 
arrows have been deleted from 
the Arrow tab in the Strokes 
palette.
.6 PRECISION DRAWING AND DIMENSIONING
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◆ To change the settings for dimensioning tools: Make sure 
that no dimension objects are selected, then double-click a dimen
sioning tool icon to open the Dimensioning dialog box.

1 Choose the type of dimensions you want to configure in the
Dimension Type pop-up menu. (If a dimension object was select
the object type appears in the pop-up menu).

2 In the Style area, adjust the settings for arrow placement, te
position, and text framing.

3 Choose the text alignment method in the Text Display pop-u
menu.

4 To configure leaders for linear and radial dimension objects
select one of the following options in the Leading Character pop-
menu: 

5 To configure radius and diameter symbols for radial dimensi
objects, select one of the following options in the R,D Symbols 
pop-up menu:

Select this type To configure these dimensioning tools

Angular Angle

Radial Radius, Diameter, Center

Linear Horizontal, Vertical, Side, Horizontal Baseline, 
Vertical Baseline, Horizontal Chain, Vertical 
Chain, Perpendicular

Object Info Area, Perimeter

None Does not include a leader

Left Includes a left-pointing leader

Right Includes a right-pointing leader

Automatic Applies to radial dimension objects only. 
Includes a leader pointing left when dimension 
object is left of the object’s center, and a leader 
pointing right when dimension object is aligned 
with or right of the object’s center.

None Does not include any symbols

Leading Places symbols before the dimension text

Trailing Places symbols after the dimension text
Customizing the dimensioning tools 17.7
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6 To set the dimension precision, choose an option in the Pre
sion pop-up menu. The options tell Canvas to use fractions or th
specified number of decimal places in dimension text.

7 To specify the format of tolerance data in dimension objects
choose one of the following options in the Tolerance pop-up me
Type the tolerance numbers in the text boxes.

8 To set a custom scale for dimension objects, turn Custom Un
on. This overrides the measurement units specified for the docu
ment rulers. Choose a measurement unit in the adjacent pop-up
menu and type the actual measure in the first text box. Type the
scaled measurement in the second text box. Choose the scale m
surement unit in the adjacent pop-up menu.

For example, if you want to use a scale of 1 centimeter equals 1 
meter, do the following: turn on Custom Units; select Centimeter 
the first pop-up menu; type “1” in the first and second text boxes; a
choose “m.” in the second pop-up menu.

9 Click OK to close the dialog box and implement the settings

None Does not include any tolerance amount

One Prints the tolerance amount from the first text 
box, with “± “and the dimension text.

Two Prints tolerance numbers from both text boxes. 
To use a negative number, type a minus sign (–) 
before the number

Limit Prints two dimensions, calculated from the 
actual dimensions and the two tolerance values.
.8 PRECISION DRAWING AND DIMENSIONING
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Using industry standards for dimension objects
If you want to use industry standard settings for dimension object
click the Standards button in the Dimensioning dialog box to open
the Dimension Standards dialog box. You can choose several ind
try standards in the pop-up menu. You can also use the Dimensio
Standards dialog box to further customize dimension objects.

Style and Text Display settings

Use the following style options 
in the Dimensioning dialog 
box to customize the appear-
ance of dimension objects.

A Arrows Inside. Dimension 
arrows appear next to the di-
mension text when this option 
is on.

B Center Text. Must be off if 
you want to drag dimension 
text outside the witness lines.

C Frame Text. Turn this op-
tion on to frame the dimension 
text.

Use the following options in 
the Text Display pop-up menu 
to format the dimension text.

Horizontal. Text is always 
aligned horizontally in all 
dimension objects.

Horz/90º. Text is aligned hori-
zontally, except text is rotated 
90º vertically for vertical 
dimension objects.

Aligned. Text is always aligned 
with the angle of the dimen-

sion arrows.

Above. Text runs above the 
dimension arrows.

Below. Text runs below the 
dimension arrows.

A

B

C2.75 ft 2.75 ft

2.75 ft2.75 ft

2.75 ft 2.75 ft

Option on Option off
Customizing the dimensioning tools 17.9



17

ox, 
le but-
ox 

d 
s 

ox. 
 the 
w 
Saving and deleting settings

If you customize the settings in the Dimension Standards dialog b
you can save the settings as a custom standard. Press the triang
ton at the bottom-left corner of the Dimension Standards dialog b
to display a menu for saving and deleting dimension standards.

When you save or delete standards, they remain saved or delete
whether you click OK or Cancel to close the Dimension Standard
dialog box.

◆ To save the settings as a new standard: Press the triangle but-
ton at the bottom-left corner of the Dimension Standards dialog b
In the pop-up menu, choose “Save settings as.” Type a name for
custom standard in the dialog box that appears. Click OK. The ne
standard will appear in the Current Standard pop-up menu.

◆ To delete a custom standard: Press the triangle button at the 
bottom-left corner of the Dimension Standards dialog box. In the 

Dimension Standards settings

The settings in the Dimension 
Standards dialog box specify 
the length and position of vari-
ous elements of dimension 
objects, based on industry 
standards.

Current standard. Choose 
from five standard measure-
ment systems: ANSI (American 
National Standards Institute) 
DIN (Deutches Institut für Nor-
mung), BS-380 (British Stan-
dards Institute), ISO (Interna-
tional Organization for 
Standardization), and JIS (Jap-
anese Industrial Standard). 

Settings you create also 
appear in this pop-up menu.

Units. Choose the measure-
ment units you want to use for 

all settings in the dialog box.

A Extension. Set the length 
of the witness lines’ extensions 
and the center line extension.

B Gap. Set the size of the gap 
between the witness lines and 
measurement points on ob-
jects; the gap between the cen-
ter extension and center point 
mark; and the gap between the 
dimension text and dimension 
arrows.

C Length. Set the length of 
the arrow lines (applies only 
when arrows are outside the 
witness lines); the length of cen-
ter extension lines’ leader char-
acters; and the length of the 
center extension line.

D Tolerance scale. The size of 

tolerance text and space be-
tween tolerance text, as a per-
centage of the dimension text 
size and spacing.

A

B

C

D

.10 PRECISION DRAWING AND DIMENSIONING
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pop-up menu, choose “Delete standard.” In the dialog box that 
appears, choose a custom standard in the pop-up menu and click

Using Smart Mouse for precise alignment
Smart Mouse is a drawing aid that can help you align objects pre
cisely. Smart Mouse is particularly useful when using dimensionin
tools, because it can snap the pointer to the corners (and other po
of objects, so dimension objects are perfectly aligned.

You can use 12 types of Smart Mouse constraints. The constrain
make the pointer (and objects that you draw or drag) snap to 

• the corners or centers of objects

• even divisions (such as the midpoints) of object segment

• specified lengths or angles

• horizontal, vertical, or diagonal movement

• tangential or perpendicular alignment with objects

• the edges of vector objects

Types of Smart Mouse constraints
Relative constraints Indicate the relationship between the begin-
ning position and current position when you draw or drag an obje
These constraints can display pointers to indicate a constraint is 
The relative constraints are: Horizontal, Vertical, Diagonal, Angle
Multiple Angle, Length, and Tangent & Perpendicular.

Absolute constraints Indicate the relationship between the pointe
and objects. These constraints (except Object Edges) can display
source lines and pointers to show a constraint is met. The absolu
constraints are: Object Corners, Object Fractions, Polygon & Béz
Anchors, Polygon Fractions, and Object Edges.

To activate Smart Mouse constraints
To use the Smart Mouse, select the constraints and then turn on 
To Smart Mouse. Refer to the table “Smart Mouse constraints” on
page 17.12 to learn how each constraint works.

1 Choose Layout > Smart Mouse. This opens the Smart Mous
palette, which contains icons for all constraints. 

• To activate or deactivate a constraint, click its icon. Activ
constraint icons are highlighted. 

Constraint icons appear in the 
Smart Mouse palette. The active 
constraints are shaded.
Using Smart Mouse for precise alignment 17.11
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2 Choose Layout > Snap To > Smart Mouse to turn on the Sm
Mouse. A check mark shows that Smart Mouse is active.

Note: Be sure Snap To Grid (in the Layout > Snap To menu) is o
when you use the Smart Mouse. If Snap To Grid is on, the pointe
will snap to the grid and not to active Smart Mouse constraints.

Smart Mouse constraints

Identifying multiple constraints

Up to two Smart Mouse constraints can be met at the same time.
example, you can drag an object in such a way that it triggers both
horizontal constraint and object corner constraint. Although you c
activate several constraints, only two constraints can affect the 
pointer at once.

When this constraint is active Smart Mouse snaps objects and constrains the pointer to

Angle A specified angle

Diagonal Straight diagonal movement — all multiples of 45º

Horizontal Straight horizontal movement— 90º and 270º, or 0º and 180º, depending on 
the current coordinate system

Vertical Straight vertical movement — 0º and 180º, or 90º and 270º, depending on 
the current coordinate system

Length A specified length in points (based on 100% magnification)

Multiple Angle All multiples of the specified angle

Object Corners The corners of the bounding boxes of vector objects

Object Edges Edges of the paths of vector objects (not their bounding boxes); when Object 
Edges is active, other constraints don’t affect the pointer

Object Fractions A specified division of vector objects; for example, specify 1/2 to snap to the 
center of objects

Object Points Any anchor point on the paths of vector objects

Object Segments Specified divisions of the segments of vector objects; for example, the 
pointer snaps to the midpoints of segments if you specify 1/2

Tangent & Perpendicular Movement in a straight line, tangent or perpendicular to vector objects
.12 PRECISION DRAWING AND DIMENSIONING



ints 

t) 

nge 
val-

elete 

t 
o 

n-

K.

rt 
ts. 

the 
ge 

 
rti-

rag 

r to 

e 
int. 
Smart Mouse can display special pointers to indicate that constra
are met. You can toggle the pointer display if more than one con-
straint is active. The Pointer option (see “Constraint settings,” nex
must be active to see Smart Mouse pointers.

◆ To toggle the Smart Mouse pointer: Press Command (Mac) 
or Alt (Windows) when a constraint pointer is visible. If another 
pointer appears, both constraints are met. The symbols won’t cha
for different settings of one constraint type, such as two different 
ues for the Angle constraint. 

Customizing Smart Mouse constraints
You can activate constraints, change their values, and add and d
constraints in the Smart Mouse dialog box. 

1 Choose Smart Mouse in the Layout menu to open the Smar
Mouse palette if necessary, then double-click a constraint icon t
open the Smart Mouse dialog box.

2 To activate or deactivate a constraint, click to the left of the 
constraint name in the scrolling list. You can activate multiple co
straints, but only two can affect the pointer at once.

3 Configure the constraint settings described next and click O

Constraint settings

The settings in the Current Constraints area at the top of the Sma
Mouse dialog box affect the behavior of all Smart Mouse constrain
Select a constraint in the list to see its symbol in the Icon box.

Priority When multiple constraints are active, those at the top of 
scrolling list take precedence over those lower in the list. To chan
the priority of a constraint, drag it to a new position in the list.

Source Lines If checked, Canvas displays a line to show that the
pointer, or an object you are moving, is aligned horizontally or ve
cally with a snap point — such as the corner of an object.

Pointers If checked, constraint symbols appear as you draw or d
objects to indicate that a constraint is met. 

Constraint Range The maximum distance, horizontally or verti-
cally, from a target point at which the constraint causes the pointe
snap to the target point. 

Objects Within For absolute constraints only, specifies how clos
the pointer must be to an object for the object to trigger the constra

✔Tip
To temporarily hide Smart 
Mouse pointers, press the Shift 
key. Smart Mouse pointers 
reappear when you release the 
Shift key.

Constraints are listed at the top 
of the Smart Mouse dialog box, 
from High to Low priority. A 
check mark indicates active 
constraints. Constraints 
preceded by a delta symbol (∆) 
are relative constraints.
Using Smart Mouse for precise alignment 17.13
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Adding and deleting constraints

You can add new Smart Mouse constraints and delete ones you d
need. When you add a constraint, it appears in the Smart Mouse
dow; constraints you remove no longer appear.

1 Double-click an icon in the Smart Mouse window to open th
Smart Mouse dialog box. If the Smart Mouse Window isn’t open
choose Layout > Smart Mouse.

2 To add a constraint, choose one in the Type pop-up menu. 
a relative constraint, enter the constraint value in the Value box
and then click the Add button.

3 To delete a constraint, select the constraint in the scrolling l
at the top of the dialog box, and then click the Remove button.

4 Click OK to implement any changes and close the Smart 
Mouse dialog box.

For this Constraint Enter this value

Object Fractions, 
Object Segments

The number of divisions. For example, type 
2 if you want the constraint to snap to the 
middle (1/2 point) of an object or segment.

Angle The angular measurement in degrees.

Length The distance in points.
.14 PRECISION DRAWING AND DIMENSIONING
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VECTOR EFFECTS

Canvas provides several special effects that let you develop com
illustrations from basic objects. You can apply the effects describ
in this chapter to any vector object; some can be applied to text 
objects, too. These commands help save time by quickly generat
new objects and letting you easily modify the appearance of exist
objects.

As you apply effects to objects, keep in mind that some of these o
ations are system memory-intensive and might significantly increa
the resource and storage requirements of a document.

Perspective effects
Commands in the Object > Path > Perspective submenu can be 
to modify vector objects. The 1 Side, 2 Sides, and Vanishing Poin
commands let you slant the bounding boxes of vector objects to a
with vanishing points. By applying these commands, you can ma
vector objects appear to be drawn in perspective views. 

About the vanishing point

The Perspective commands apply perspective effects based on a
ishing point. There is one global vanishing point in a Canvas docu
ment. When you use the 1 Side or 2 Sides commands, you set th
vanishing point by dragging a control handle. When you use the V
ishing Point command, you can set the vanishing point by clicking
the document or entering coordinates.

Using the 1 Side and 2 Sides commands
The 1 Side and 2 Sides commands let you apply perspective effe
to vector objects by dragging control handles. To use these com-
mands, select a single vector object or a group of vector objects. 
These commands are not available if multiple objects are selected
if a paint or text object is selected.

To apply perspective with 1 Side or 2 Sides

1 Select a vector object or a group of vector objects.
18.1
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2 In the Object > Path > Perspective submenu, choose 1 Side
Sides.

3 Control handles appear at the corners of the bounding box 
the selected object. Drag any of the handles to apply the perspec
effect. As you drag a handle, guide lines indicate the position of 
vanishing point, which extend beyond the current view. 

• If you choose 1 Side, the side of the object’s bounding bo
where you drag a handle will slant to a vanishing point. Yo
can adjust the object’s sides independently. 

• If you choose 2 Sides, as you drag a handle, the opposit
sides of the object’s bounding box will slant equally towar
a vanishing point located along the object’s vertical or ho
zontal center axis.

• When the pointer is on a control handle, a four-arrow sym
bol indicates that you can drag horizontally or vertically. T
change directions, point to a control handle until the four-
arrow symbol appears again.

4 When you finish, press Esc to deselect the object.

Using the Vanishing Point command
The Vanishing Point command applies a perspective effect to one
more vector objects. The command slants the bounding boxes of
selected vector objects so the objects appear in perspective based
vanishing point that you select.

1 Side perspective 2 Sides perspective

Vanishing point

Vanishing point
.2 VECTOR EFFECTS
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The Vanishing Point command is available when vector objects o
groups of vector objects are selected. The command is not availa
if a paint or text object is selected.

To apply perspective using a vanishing point

1 Select one or more vector objects or groups of vector objec

2 Choose Object > Path > Perspective > Vanishing Point.

3 A dialog box appears. It displays the coordinates of the glob
vanishing point. You can change the coordinates to move the va
ishing point, or you can click in the document to set the vanishin
point.

• To enter coordinates, type coordinate values in the text 
boxes. Coordinates are based on the document’s rulers.

• To set the vanishing point visually, click Choose. Move th
pointer and click to set the vanishing point. The coordinat
of the point you click appear in the text boxes.

• To restore the previous vanishing point coordinates, click
Reset.

4 Click OK to apply the perspective effect.

Note: The Effects > Remove Effects command will not remove pe
spective effects that have been applied to objects.

Offsetting paths
You can use the Offset Path command to create new objects tha
low the path of a vector object. 

An offset object’s path follows the inside or outside of the original
object’s path. You can specify the offset distance and the numbe
objects to create. 

You can offset one vector object at a time. Composite objects cre
by the Concentric Circles, Spiral, Cube, GridMaker, or Multigon 
tools cannot be offset.

To offset an object

1 Select a vector object and choose Effects > Offset Path.
Offsetting paths 18.3



18

is-
. 

new 
e, 

 or 

 
osi-

 

the 

ge 
s or 

 on 
 

g 
g 
 

to 
val 

ipt 

n 
or 
 text 
2 In the Offset Path dialog box, type the offset distance in the D
tance box. In the Copies box, type the number of copies to make
Click OK to create the offset objects.

Canvas applies the current inks and stroke to offset objects. The 
objects appear in front of the original if they are smaller; otherwis
they appear behind it. 

The direction of the offset depends on whether you type a positive
negative Distance value.

When you offset an object that has an open path, type a negative
value to offset the new object to the inside of the curve. Type a p
tive value to offset the new object to the outside of the curve. 

When you offset an object that has a closed path, type a negative
number to offset the new object to the inside of the original path. 
Type a positive number to offset the new object to the outside of 
original path.

An offset object can differ in shape from the original object, if a lar
offset distance makes the path cross itself to follow narrow angle
tight curves of the original object.

Using clipping paths
A clipping path is a special object that creates a frame or window
an object. You can use text objects and vector objects as clipping
paths.

You can apply a clipping path to one or more objects. The clippin
path frames the objects it is applied to. Anything inside the clippin
path remains visible, while anything outside the path is hidden, or
“clipped.”

If you apply an oval clipping path to a photo, for example, the pho
is visible inside the oval, while any part of the photo outside the o
is not visible.

Because clipping paths are vector objects, clipping effects print 
smoothly at maximum resolution on any printer, including PostScr
and non-PostScript devices.

Clipping paths create hard-edged effects. Clipping paths are ofte
used to “cut” photos and illustrations into shapes such as circles 
curves. You can use text as a clipping path to create the effect of
characters filled with photos or other graphics. 
.4 VECTOR EFFECTS
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If you want to create feathered or graduated clipping effects, you 
use vector transparency masks and channel masks instead of clip
paths. For information, see “SpriteLayer effects” on page 14.1.

To apply a clipping path

1 Position a text or vector object in front of the objects to be 
clipped. (You can select an object and choose Object > Arrange
Bring to Front to put the clipping object in front of other objects.)

2 Shift-click the clipping object and the objects to be clipped t
select them all. 

3 Choose Object > Clipping Path > Make. Canvas clips the 
selected objects.

If you want to use a special object (such as a star created by the 
tigon tool) as a clipping path, the object must be converted to a ve
path first. Select the object and choose Object > Path > Convert t
Paths. If a selected object can’t be used as a clipping path, the C
ping Path > Make command is not available.

◆ To hide clipping paths: Choose Object > Clipping Path > Hide
Canvas makes the strokes of all clipping paths invisible. 

◆ To show clipping paths: Choose Object > Clipping Path > 
Show. Canvas shows the clipping paths with a 1-point black strok

◆ To remove a clipping path: Select the clipping path or a 
clipped object and choose Object > Clipping Path > Release. Can
restores the clipped objects to full view, and the clipping path obje
appears with its original attributes.

Editing clipping paths
After applying a clipping path, you can move it and the clipped 
objects independently. Dragging the clipping path frames a differe

Text in front of paint object Text clipping path
Using clipping paths 18.5
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part of the clipped objects. Dragging a clipped object changes its
position inside the frame of the clipping path.

You can apply several effects to a clipping path. Select the clippin
path and choose Effects > Freeform to display handles that you c
drag to skew and rotate the clipping path. You can also apply the
Fractalize, Rotate, and Flip commands to a selected clipping path

You can reshape a clipping path in several ways. Select a clippin
path and drag its handles to change the size or shape of its boun
box. To reshape a vector object path, double-click it, or select it a
press Command+E (Mac) or Ctrl+E (Windows). With the path in e
mode, you can use path-editing techniques to move, add, or dele
anchor points. When you finish editing, press Esc to reapply the c
ping path.

To edit a text clipping path, use the Text tool or double-click the te
to put it in edit mode. You can insert and delete characters in edit
mode. When you finish, press Esc to reapply the clipping path. 

To change the formatting of a text clipping path, select the clippin
path and use the Text menu or the Type palette to change its fon
style, size, or other attributes. When a text clipping path is selecte
you can use the Spell Check Selection command to check its spe

Because clipping paths are special objects, they do not display th
pen inks, fill inks, or strokes of their original objects. Canvas displa
clipping paths with 1-point black strokes (which the Clipping Path
Hide command makes invisible).

If you select a clipping path and change its inks or stroke, Canvas
applies the attributes to the object, but the attributes aren’t visible
unless you use the Release command to convert the clipping pat
back into a vector or text object. 

Combining objects
The Combine command makes new objects from the intersection
two or more vector objects. You can outline the overlapping objec
delete all except the overlapping area, subtract the overlapping a
and perform other combinations.

To combine objects

1 Select two or more objects that you want to combine. Each 
selected object must overlap at least one other selected object.
.6 VECTOR EFFECTS
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2 Choose Effects > Combine to open the Combine palette, if n
essary.

3 In the Combine palette, choose a combine method from the 
(the methods are described below). An example of the selected
combine method appears on the right.

4 Click Apply to implement the current settings.

Selecting a combine method
In the Combine palette, you can choose various methods for com
ing objects. Some methods require that the paths of overlapping 
objects intersect for the effect to be visible or work properly. In ad
tion, some methods work only with closed vector objects, and not
with lines and open curves.

Trim Trims intersecting lines or arcs by shortening them until the
meet at a vertex. You can trim a line to a line, an arc to an arc, or
arc to a line. In each case, Canvas trims the shorter segments of
intersecting lines and arcs. Trimmed lines and arcs remain separ
and retain their attributes.

Trim also trims lines or arcs where they intersect closed vector 
objects. The vector objects do not change. 

If Canvas can’t trim the selected objects, a message tells you tha
operation requires at least one open path.

Example of selected method

Choose a combine method

Original objects Trim applied
Combining objects 18.7
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Outline Creates one path around the selected objects and fills th
interior of the new shape with the ink of the front object.

Add Joins two objects where they overlap to create a compound
path, and fills the new shape with the ink of the front object. Com
pound paths can include multiple closed shapes that have holes 
them, unlike objects created with the Outline option.

Intersect Creates a new object from the intersection of all select
objects and fills the new object with the ink of the front object. All 
selected objects must be closed paths and share a common area

Punch Removes the area where selected objects intersect and f
the new object with the ink of the front object. If you select more th
two objects, Canvas starts with the back object and continues forw
through the stacking order. 

Subtract Front Removes from the back object the areas of overla
ping objects in front. The back object retains its ink attributes.

Subtract Back Removes from the front object the areas of overla
ping objects behind it. The front object retains its ink attributes.

Crop Removes areas of objects that are not behind the top obje

Original objects: 
two circles and a 
rotated square

Objects combined 
with the Outline 
method

Outline shape smoothed 
into a heart using path- 
editing techniques

With the Add method, Canvas 
merges the handle to the cup 
where they overlap, leaving a 
hole inside the handle

Original objects Combined with Add method

The Intersect method helps you 
create some useful, basic shapes. 
Here, the intersection of two 
circles (highlighted) results in an 
eye shape.
.8 VECTOR EFFECTS
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Divide Creates new objects where selected objects overlap. Thi
option lets you use lines to “cut” other objects in pieces.

Slice Cuts the path of an object where it intersects with objects in
front of it in the stacking order. Unlike other combine methods, sli
results in open-ended paths. For example, slicing a circle in half w
a line produces two arcs, as opposed to two closed semicircles.

Mix Creates new objects where selected objects overlap, simila
the Divide option. However, Canvas fills overlapping areas with a
new color (the original colors must be solid). To determine the ne
color, Canvas compares the CMYK values of all the overlapping 
objects and uses the highest value of each color. (If you are using
RGB colors, Canvas first converts the colors to CMYK.) For exam
ple:

Transparency Creates new objects where selected objects overla
and fills overlapping areas with a new RGB color (the original colo
must be solid). However, transparency lets you specify the level o
transparency. When you select the Transparency option, enter a 

Cyan Magenta Yellow Black

Color 1 50 30 25 5

Color 2 25 40 20 0

New Color 50 40 25 5

A gradient-filled oval provides 
a background 

An oval used to crop a vector 
drawing of pine trees
Combining objects 18.9
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centage in the text box that appears; 100 percent is completely tr
parent, and zero is opaque.

Note: If multiple overlapping objects are grouped, Canvas treats t
group as a single object and doesn’t apply the transparency or m
effect within the group.

Blending objects
Using the Blend effect, you can create gradual transitions in shap
color, and stroke width between two or more objects. Canvas gen
ates a series of objects (from back-to-front through the stacking 
order) that appear to transform one object into another. 

Artists often use blends to create highlights and shadows in vecto
drawings that provide the illusion of roundness and lighting. In ad
tion, you can use blends to copy and evenly distribute objects aro
shapes to create borders.

Canvas can blend solid color inks only. If you blend objects with 
hatches, symbols, textures, or gradients, Canvas generates the b
objects but doesn’t fill them with an ink.

Using the Transparency method, the artist created 
the illusion that you can see through the wine 
glass. Where the glass overlaps the wine bottle, 
you can faintly see the bottle’s label and shape.
.10 VECTOR EFFECTS
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Using blends for dimensional effects
By specifying a high number of blend objects, you can create grad
transitions between shapes and colors. With the appropriate setti
colors seem to fade and mix into each other, and the blend object
not appear as distinct objects. This effect is often used to add real
highlights and shadows to objects so they appear three-dimensio

When configuring the blend settings, keep in mind that the size of
final output affects the number of shapes required to make the bl
appear smooth. For large posters, you might need to use a lot of 
shapes, but fewer shapes are required for small illustrations.

In addition, objects that you blend must have the same number o
anchor points for the blend to appear smooth. Canvas uses the an
points to calculate the steps and shapes in a blend; an inconsiste
number of anchor points can cause unwanted twists and distortio

To blend objects

Select two or more vector 
objects. If necessary, choose 
Blend in the Effects menu to 
open the palette. Configure 
the settings and click Apply.

# of shapes. The number of 
objects Canvas creates for the 
blend. Higher numbers result 
in smoother blends.

Rainbow colors. Creates a 
rainbow-like blend of colors 
between objects. This intro-
duces more color variations 
than a standard blend, which 
uses only combinations of the 
original colors. When you turn 
on this option, two buttons 
appear; choose a clockwise or 
counter-clockwise path around 
the color wheel.

Bind to a path. Turn on to use 
the path of an object (not in 
the current selection) to 
arrange blend objects. When 
you click Apply, Canvas 
prompts you to Choose Path; 
click the object to which you 
want to bind the blend 
objects.

Point to point. Available when 
blending two objects. This 
option lets you rotate blend 
objects, creating the illusion 
that one object is twisting into 
another. When you click Apply, 
Canvas prompts you to Choose 
1st Point; click an anchor point 
on one object. Canvas then 
prompts you to Choose 2nd 
Point; click an anchor point on 
the other object. To reverse 
the blend direction, Option-

click (Mac) or Ctrl-click (Win-
dows) when you choose the 
two points.

Dynamic. Lets you use the 
Direct Selection tool (hollow 
arrow) to accelerate, deceler-
ate, expand, contract, and 
redirect the blend after Canvas 
creates it. Dynamic blends 
aren’t available for specialized 
objects, such as multigons, spi-
rals, concentric circles, and 
grids.

✔Tip
To ensure that blended objects 
have the same number of 
anchor points, copy an object, 
edit its shape, and blend 
between these objects. 
Blending objects 18.11
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Using blends to create patterns
Although blends are often used to create gradual, smooth transiti
between shapes and colors, you can also use the Blend comman
create and evenly space a pattern across a layout. By specifying a
number of shapes and widely spacing the front and back objects,
can make each blend object a distinct object. This effect can be us
for creating borders and other patterns.

Distorting shapes
The Envelope command lets you distort shapes and text, as if an
illustration was drawn on a rubber sheet and then stretched.

When an object is in envelope edit mode, its bounding box acts li
the rubber sheet. Canvas includes several envelope styles that o
various handles you can use to stretch an object’s bounding box.
Using this effect, you can create new shapes, add a sense of moti
an illustration, or arrange text so it appears to be painted on a thr
dimensional object.

The artist created this border by 
first creating a flower-like multigon, 
copying it, and drawing an oval. To 
distribute the flowers evenly 
around the oval, the artist selected 
the two multigons, turned on the 
“Bind to a path” option in the 
Blend palette, specified a relatively 
low number of shapes (15) for the 
blend, and chose the oval as the 
binding path. 

The Envelope command 
distorted the type to match the 
contour of the ship’s hull 
.12 VECTOR EFFECTS
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Using envelope templates
Canvas has several envelope templates that you can use to insta
distort shapes. The silhouettes in the template scroll list show the
tortion created by each template.

In addition, you can create your own envelope templates. After yo
apply the envelope effect to an object, you can acquire the shape
the envelope as a template.

To apply an envelope template

1 Select a vector object.

2 Choose Effects > Envelope to open the Envelope palette, if
necessary. 

3 In the palette, choose Template in the pop-up menu. 

4 Click a preview shape in the scroll list to select it, and click 
Apply. 

To save an envelope as a template

To store an object’s envelope as a template, you must first have u
the envelope effect on the object. (See “To apply an envelope effe
next.) You can’t acquire a standard vector shape, such as a circle
unless you first apply the envelope effect

1 Select an object that has been edited using the envelope ef
The object cannot be in envelope edit mode.

2 Choose Effects > Envelope to open the Envelope palette, if
necessary. 

3 In the pop-up menu, choose Template.

4 Click Acquire; a preview of the envelope shape appears in t
scroll box.

◆ To delete an envelope template: In the Envelope palette, 
choose Template in the pop-up menu. Click a preview shape in th
scroll box to select it, and click Delete.

Using envelope styles
In addition to envelope templates, Canvas has six envelope styles
let you edit shapes in different ways. Each style moves and chan
the bounding box in a particular way. See the table below for info
mation on the attributes of each style.
Distorting shapes 18.13
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To apply an envelope effect

1 Select a vector object.

2 If necessary, choose Effects > Envelope menu to open the 
Envelope palette. 

3 In the palette, choose an envelope style in the pop-up menu
click Apply. 

4 Drag the envelope handles that appear on the bounding bo
the object to edit the shape.

Envelope styles and editing options

Example Style Number of handles Envelope behavior

Warp Enter the number of hori-
zontal and vertical han-
dles in the text boxes.

Each handle behaves like a path anchor point and 
can move in any direction.

Distort Four Each side of the envelope edit box is a straight line; 
handles can move in all directions. This style is useful 
for creating perspective.

Straight Line Eight All handles are connected by straight lines. Corner 
handles are constrained to right-angle movements; 
side handles can move in all directions.

Single Cusp Eight Side handles form convex or concave curves between 
corner handles. Side handles can move in any direc-
tion; corner handles are constrained to right-angle 
movements.

Double Cusp Eight Side handles form S-shaped curves between corner 
handles. Side handles can move in any direction; cor-
ner handles are constrained to right-angle move-
ments.

Example of selected envelope style

Select an envelope style

Options for Warp style only
.14 VECTOR EFFECTS
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Extruding objects
The Extrude command lets you create objects that appear to hav
three dimensions. You can extrude vector and text objects in para
style, and vector objects in circular and semi-circular (“sweep”) sty

You can rotate and scale extruded objects in three-dimensional sp
You can set the placement, intensity, and color of a simulated ligh
source for shading extruded objects. Solid color fill inks can be 
applied to extruded objects. Strokes and other inks are not suppo

Note: Canvas extrusions resemble QuickDraw 3D objects, but 
QuickDraw 3D is not required to extrude objects. You can save 
extruded objects in QuickDraw 3D file format (3DMF) if QuickDraw
3D is installed (Mac only).

To extrude an object

1 Select an object for the extrusion you want to create:

• For parallel extrusion, select a text or vector object, or a 
group object containing one or both types of objects. 

• For circular or sweep extrusion, select a vector object.

2 Choose Effects > Extrude to display the Extrude palette. 

3 Select a preset or custom extrusion setting:

Using presets: From the preset extrusion pop-up palettes, 
select an extrusion icon to extrude the selected object. The 
icons show the angle and position of the extruded object. C
vas uses a default extrusion depth for parallel extrusions, an
default Steps setting for circular extrusions. 

Using custom settings: Click the arrow to expand the palette.
Choose an extrusion style, lighting color, and other options.
Click Apply to extrude the selected object. 

4 If you select Circular or Sweep style, an extrusion axis appea
See “Completing a circular or sweep extrusion,” next.

Bézier Eight All handles behave like smooth anchor points and 
can move in any direction.

Example Style Number of handles Envelope behavior
Extruding objects 18.15
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Completing a circular or sweep extrusion

When you set up a circular or sweep extrusion, you can specify th
number of steps you want Canvas to use. The more steps, the 
smoother and less “blocky” the extrusion appears.

◆ To specify the number of steps for a circular or sweep extru-
sion: In the Extrude palette, enter a number between six and 60 i
the “# of Steps” text box.

After you apply a circular or sweep extrusion to an object using th
expanded Extrude palette, you need to set the extrusion axis, whi
represented by a black bar. A mirror image of the selected object
shows the extrusion at 180 degrees. 

◆ To set the extrusion axis: Drag the black bar right, left, up, or 
down, depending on the direction you want to extrude. The mirro
image of the object moves as you drag the axis. Press Enter or d
ble-click to complete the extrusion.

Extrusion palette

A Parallel presets
B Circular presets
C Lighting presets
D Rotate buttons

A B C

Click to expand

D

.16 VECTOR EFFECTS
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Extrusion options
You can use pop-up palettes of extrusion and lighting presets in t
Extrusion palette to modify extruded objects. If you expand the 
Extrude palette, you can use options to control lighting and rotatio
of extrusions. You can set these options before you extrude an ob
or to edit an extruded object. 

• Before extruding a selected object, set up the options yo
want and click Apply to extrude the object. 

• After extruding an object, double-click it, change the set-
tings you want, and click Apply to apply the settings. 

You can control the color and position of the light source to chang
the shading of extruded objects. Canvas uses shades of gray to c
highlights and shadows. Canvas then mixes the highlights and sh
ows with the color of the light source and the fill color of the objec

Extrusion styles 

In the expanded Extrude palette, you can select the extrusion sty
from the pop-up menu. 

Parallel Adds depth to an object, as though the shape were cut o
of a slab of clay. You can create parallel extrusions with text obje
and vector objects.

Circular Extrudes a shape in a circular path. You can set the dia
ter of the extrusion path and the number of steps (6-60) in the ex
sion. You can apply circular extrusions to vector objects, but not t

Original object Axis 

Circular and sweep extrusions

Circular 
extrusion

Axis 180º sweep 
extrusion
Extruding objects 18.17
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Sweep Extrudes a shape along a circular path, and lets you spe
the number of degrees (10 to 360) to extrude. You can also set th
diameter of the extrusion path and the number of steps (6-60) in 
extrusion. You can apply sweep extrusions to vector objects, but 
text. 

Editing extruded objects
You can rotate extruded objects in several ways:

• Click the rotation buttons on the Extrude palette

• Enter values in the Rotation Angles text boxes in the 
expanded Extrude palette.

• Rotate and scale extruded objects interactively. 

To rotate and scale an extruded object, the object must be in extr
sion edit mode. To place an extruded object in edit mode, Double
click the extruded object.

Immediately after you extrude an object, the object is in extrusion
edit mode. To exit this mode, double-click outside the object or pr
Esc.

A Select an extrusion style 
from the pop-up menu. For 
Sweep style, also enter the an-
gular length, from 10 to 360 
degrees.

# of Steps: For Circular or 
Sweep style, the number of 
steps controls the number of 
facets on the surface of the 
extrusion. Enter a value from 6 
to 60.

Light color: Choose a light 
source color from the palette.

Back/Front: Drag the slider to 
specify the depth of the light 
source in three-dimensional 
space (along the Z axis).

Intensity: Drag the slider 
to adjust the overall bright-
ness of the light source.

B Drag the handle to set 
the horizontal (X) and verti-
cal (Y) position of the light 
source and preview the ef-
fect.

Light Source: Use the han-
dle (B) and Back/Front 
slider, or enter X, Y, and Z 
coordinates to set the posi-
tion of the light source.

Ambient Light: Drag the 
slider to adjust the highlight 
and shadow contrast.

Rotation Angles: Enter X, Y, 
and Z values in degrees to 
rotate the extruded object in 
3D space.

B

AExtrude palette options

Rotation buttons
.18 VECTOR EFFECTS
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In edit mode, Canvas displays three axes, representing the three
dimensions. Each axis has a handle, and when you roll the pointe
over a handle, it changes to an extrusion pointer. Otherwise, the 
pointer appears as a rotation pointer.

To rotate an extruded object interactively

When you first apply the Extrude effect, the object might appear f
if it is facing you (with the Z axis pointing directly at you). 

To see all dimensions, rotate an edge of the object toward you. W
the rotation pointer, drag a side in the direction you want to rotate
object. As you drag, Canvas displays a circle to show the space i
which the object can rotate. Dragging inside the circle rotates the
object in all three dimensions; dragging outside the circle rotates 
object on the plane that is facing you.

You can also rotate an extruded object in two dimensions, like oth
vector objects, using the Rotate or Freeform commands in the Eff
menu. The object can’t be in extrusion edit mode to use these co
mands. When you use the Rotate and Freeform commands, Can
does not reapply lighting effects as with three-dimensional rotatio
In other words, the light source appears to move with the object, 
instead of remaining in the same place as the object rotates.

Changing the shape of extruded objects

When an extruded object is not in edit mode, you can resize an
reshape it like other two-dimensional vector objects. You can

• drag a handle on the bounding box to resize the object

• place the object in freeform mode to skew the object

Rotation pointer appears when an 
object is in extrusion edit mode

Circle appears when you 
drag with the rotation pointer
Extruding objects 18.19
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• use the Scale or Object Info commands to resize the obje

• apply the Envelope effect to warp and distort the object

In addition to these two-dimensional editing functions, extruded 
objects have unique, three-dimensional properties. When an obje
in extrusion edit mode, you can make it thicker, wider, or taller, an
Canvas redraws the object to account for lighting changes.

Changing the color of extruded objects

When you extrude a vector object, Canvas uses combinations of
solid-color fill ink, shades of gray, and the light-source color to crea
a three-dimensional appearance. After you extrude an object, you
apply solid color fill inks and change the color of the light source i
the Extrude palette. When you change colors, Canvas redraws th
object to show the interaction of the new colors with the object’s 
shape and shading.

Colorizing objects
You can use the Colorize command to tint vector objects with sol
color fill or pen inks when you want to mix two colors, or shade on
color with another. Doing this in the Inks palette can be complicat
because you have to create a custom color and set the correct va
to approximate a two-color mixture. The Colorize command lets y
simply select two colors and choose the percentage of each.

To colorize a vector object

1 Select at least one vector object that has a solid color fill or p
ink. Colorize has no effect on gradient, hatch, texture, and symb
inks. 

HandleEditing extruded 
objects

When you drag a handle, 
Canvas extrudes the 
object outward, along the 
corresponding axis. In oth-
er words, dragging a han-
dle to the right extrudes 
the object to the right and 
the left simultaneously.

Extrusion symbol when 
pointer in on an extrusion 
handle

Rotation symbol when 
pointer in not on an 
extrusion handle
.20 VECTOR EFFECTS
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2  Choose Effects > Colorize.

3 In the Colorize dialog box, turn on the Fill and Stroke option
to colorize both, or select the one ink you want to colorize.

4 In the pop-up color palettes, select the colors you want to a
to the inks of the selected objects.

5 Use the sliders or enter a percentage in the text boxes to se
amount of color to mix with the object’s color.

6 Turn on Preview to see the effect or click OK to colorize the
object.

How colorization works

Canvas uses the percentages you specify to determine the new c
values for the selected object. For each color value (for example,
Red, Green, and Blue in the RGB color model), Canvas finds the
ference between the tint and the original color. Then, Canvas mu
plies the differences by the percentage you specify, and adds the
values to the original color values.

Fractalizing objects
Fractals are mathematical transformations that simulate the irreg
ities and patterns in natural shapes, such as coastlines and moun
ranges. When you fractalize a vector object, its outline becomes 
jagged. You can use the Fractalize command to add a fractal effe
any vector object except dimension objects and Smart Lines.

Colorization calculations

An object’s color has a red val-
ue of 40%. To tint 50% with a 
color that has a red value of 
100%, Canvas calculates a new 
red value of 70%. The same cal-
culations apply to the green 
and blue values for an RGB col-
or.

R=40% R=100%

Difference in red values: 100 - 40 = 60

Value difference multiplied by tint percentage: 60 * 50% = 30

Original color value plus tint value is new value: 40 + 30 = 70% red

R=70%

Original Tint color Result
Fractalizing objects 18.21
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◆ To fractalize an object: Select at least one object and choose 
Effects > Fractalize. Enter the Wiggle and Density values, and 
choose Curves or Polygon fractals. Click Apply to preview the effe
Click OK to apply the effect and close the dialog box.

Wiggle The amount a fractalized path can deviate from the origin
path. Enter a number between 0 and 20; higher numbers increas
amount of wiggle. 

Density The smoothness of the fractalized path. Enter a number
between 0 and 5. Higher values increase the number of anchor p
Canvas add to the path. Lower densities result in sharper angles.

Curves or Polygon Polygon fractals can be jagged and use many
anchor points, while curves fractals are smoother and require few
additional anchor points.

Note: Canvas fractalizes objects by adding several anchor points 
an object’s path. High wiggle and density settings and polygon fra
tals can add numerous anchor points, which require more memor
print. Lower settings and curves fractals can help to conserve sys
resources and eliminate problems you might have while printing.

Creating shadows for objects
The Shadow command lets you apply two types of offset (“drop”)
shadows to selected objects. You can use the command to apply
shadow made of vector objects or an image. Canvas places the 
shadow directly behind the selected object in the stacking order.

You can edit shadow objects independently from the objects they
shadowing. You can skew them to create oblique shadows, and u
filters to change their appearance. The original object and the sha
are not grouped, so editing or moving one doesn’t affect the othe

Vector objects Fractalized mountains
.22 VECTOR EFFECTS
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You can apply shadow effects to any vector or text object except 
dimension objects and Smart Lines. If you apply a vector shadow 
group of objects, Canvas groups the shadow objects and places 
shadow behind the original group. If you apply a shadow to a pain
object, Canvas creates a shadow of the paint object’s bounding b

◆ To create an offset shadow: Select an object and choose 
Effects > Shadow. In the Shadow dialog box, select options 
(described next). Click Apply to see the effect. To accept the setti
and close the dialog box, click OK.

Shadow options
Shadow type Select Object to create a vector object shadow. Sel
Image to create a paint object shadow. A vector shadow has a ha
edge and can be edited like any vector object. An image shadow
be softened using the Gaussian Blur option and can be edited like
paint object.

Shadow Color Select the color to apply to the shadow object from
the color palette. 

Offset You can specify the location of the shadow relative to the
original object. Enter the distance and angular direction to offset t
shadow in the first text boxes, or enter the horizontal and vertical 
tances to offset the shadow in the second text boxes.

Image Options These options are available when Image is 
selected. You can specify the amount of blur in the Gaussian Blu
box. Select the color mode of the paint object from the Mode men

Vector (left) and image type 
shadows with different offsets
Creating shadows for objects 18.23
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Set the image resolution in the “Res” box. To apply anti-aliasing, 
select an option from the menu.

Size The value shows the amount of memory required for the pa
object based on the current Image Options settings.

Binding groups
The Bind Group command in the Effects menu lets you align a gro
of objects to the path of a vector object, such as a curve or polyg

To use the Bind Group command, you must select an object grou
set of vector objects that have been united with the Group comm
in the Object menu). 

To bind an object group

1 Select the object group that you want to bind to a path and 
select the path to which you want to bind the object group. Both 
object group and the path must be selected.

2 Choose Effects > Bind Group.

Using the Transform palette
You can use the Transform palette to move, scale, rotate, and sk
selected objects. You can keep the palette open for easy editing 
positioning of objects.

To display the Transform palette, choose Effects > Transform. To
close the palette, click the Close box (Mac) or double-click the Co
trol menu box (Windows).

You can change the palette’s layout from horizontal to vertical by
dragging the lower-right corner.

You can change the size, location, and orientation of selected obj
by using options and entering values in the Transform palette. Ca
vas applies the current settings when you press Enter or tab to th
next box. 

Once an object has been transformed, it becomes a new object. 
Therefore, the reference point is reset to reflect its position on the
new object. The values in the text boxes display the size and pos
of the new object. The text boxes that show rotation and skew disp
0. And the scaling percentage text boxes display 100 percent.
.24 VECTOR EFFECTS
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Locating the reference point

The reference point is displayed on the transform palette. It is a p
on the selected object (or its bounding box) that position data are
based on. The reference point is also the fixed point used in an 
object’s transformation. For example, with a rectangle selected, c
the upper-left corner point. The X Y boxes show the coordinates 
the rectangle’s upper-left corner, if Absolute coordinates are spec
fied.

Transform menu options

You can choose different options to transform objects. The option
you choose determines the type of data that appears in the boxes
the palette. You can choose from one of the following options:

Relative Changes the position of the object relative to the curren
position, or height and width values. The value in the first boxes, 
Delta X and Delta Y, is 0 when you select an object. To move the
object, type the distance to move. The next two boxes, W and H,
play the object’s width and height. Type new values to resize the 
object.

Absolute Specifies X Y coordinates or height and width values. 
The first two boxes, X and Y, display the coordinates of a selecte
object’s reference point. To move an object, type new coordinates
the reference point. The next two boxes, W and H, display the 
object’s width and height. Type new values to resize the object.

Start/End Points The first two boxes, X and Y, show the coordi-
nates of the object’s reference point. To resize an object by movi
the reference point, type new coordinates for the reference point.

The next two boxes, X' and Y', show the coordinates of one of the
corner points on the object (or the object’s bounding box). The po
is the upper-right corner when the reference point is the lower-lef
corner. The point is the lower-right corner when the reference poin
the upper-left corner. The point is the lower-left corner when the r
erence point is the upper-right corner. The point is the upper-left c
ner when the reference point is the lower-right corner.

For a line, you cannot select a reference point. The X and Y boxe
always indicate the starting point of the line and the X' and Y' box
always indicate the end point of the line. To resize an object, type
new coordinates for this point.

Distance and Angle The first two boxes show the X Y coordinate
of a line’s start point. This is only available when a line is selected

Reference point
Using the Transform palette 18.25
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The second two boxes show the line’s length and angle. You can
change these values to change the length, angle, or position of th
line. A representation of the angle is given in the reference point b

Transform 
palette settings

You can select 
options and enter 
data in the Trans-
form palette to 
change the size, 
location, and ori-
entation of select-
ed objects.

A Reference point. Click a 
point in the box to set the refer-
ence point for the object. The 
location of the reference point 
depends on the object’s shape. 
With a rectangle selected, the 
corner points in the box corre-
spond to the rectangle’s cor-
ners. With an oval or other 
shape selected, the corner 
points in the box correspond to 
the corners of the object’s 
bounding box.

Rotation point. Shift-click a 
point in the box to set the rota-
tion point for the object. A red 
square in the box indicates the 
current rotation point. The rota-
tion point is a point on the 
object around which the object 
rotates if you enter a rotation 
angle.

B Position data. The type of 
data that appears in the boxes, 
and their labels, depends on 
whether you choose Relative, 
Absolute, Start/End Points, or 
Distance and Angle in the menu 
(C).  

C Choose an option for speci-
fying location and size data. You 
can choose Relative, Absolute, 
Start/End Points, or Distance 
and Angle.

Choose Relative to change 
position relative to the current 
position, or height and width 
values.

Choose Absolute to specify X 
Y coordinates or height and 
width values.

Choose Start/End Points to 
specify X Y coordinates.

Choose Distance & Angle to 
specify X Y coordinates, dis-
tance, and angle for lines.

D When this button is select-
ed, the palette constrains ob-
jects so they are resized propor-
tionally. For example, if you 
type a width value, Canvas cal-
culates the height value to keep 
the object’s proportions the 
same.

E The X and Y boxes show 
100% when you select an ob-
ject. You can resize an object by 
percentages by changing the 

values. For example, to resize a 
rectangle so it is twice as wide, 
type 200 in the X box. To make 
it one-half as tall, type 50 in the 
Y box.

The Y box is not available when 
the proportion option (D) is 
selected.

F Rotation. Click to select 
clockwise or counter-clockwise 
rotation. Type the angle of rota-
tion in the box to rotate the ob-
ject. 

G Skew. Click to select hori-
zontal or vertical skewing. Type 
the skew angle in the box to 
skew the object. 

H When this is selected, the 
Transform palette operates as if 
multiple selected objects were a 
group object. If this option is 
not selected, the palette affects 
selected objects individually. 

With multiple objects selected 
and the group option (H) not 
selected, coordinate values are 
0; you can enter new values, 
which Canvas applies to each 
object when you press Enter.

A

B C

D

E F

G

H
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TEXT ENTRY AND LAYOUT

Canvas has a full range of text and typography features that let y
integrate text with illustrations and images. You can enter, format
edit, and arrange text in Canvas. You can also import text files, a
use Publish and Subscribe or Object Linking and Embedding (OL
to place text in documents. To help you edit and proof text, Canv
provides spell-checking and text-searching tools. 

This chapter describes how to perform the following operations w
text:

• Create and work with text objects.

• Type text into new objects and flow text between text col
umns.

• Insert headers, footers, page numbers, the current date a
time in Publication documents.

• Create empty text objects for layout templates.

Text tools
The Text toolbar in the toolbox contains the tools you can use to 
ate text objects and to edit text. Each of these tools is described i
later sections in this chapter.

• Use the Text tool to create text objects and edit text.

• Use the Text Object tool to draw fixed text objects for pag
layouts.

• Use the Path Text tool to type text along a vector path.

• Use the Text Link tool to link text objects to create text 
flows.

• Use the Text Unlink tool to break text object links.

Text objects
All text in a Canvas document is contained in objects called text 
objects. Text objects can contain a single character or line of text
thousands of words, sentences, and paragraphs.

A Text B Section C Path Text, 
D Text Object E Text Link 
F Text Unlink G Text Info 

Press to open 
toolbar of text 
tools

A B C D E F G
19.1
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Note: Dimension objects contain dimension text. For more inform
tion on text in dimensions, see the description of Dimensioning to
beginning on page 17.2.

Selecting and editing text objects

A text object can be selected or be in edit mode. These states are
mutually exclusive. In other words, a text object can’t be in edit mo
and be selected at the same time.

When a text object is in edit mode, the Text tool is active and you 
add, move, and delete text in the text object. For text-editing proc
dures, see “Text edit mode” on page 20.1.

When a text object is selected, you can change its dimensions, d
it, move it, and apply commands and operations to it, the same as
would with other objects. For more information, see the chapter tit
“Working with objects” on page 10.1.

Typing text in a document
You use the Text tool or the Vertical Text tool to type text into a d
ument. This section describes using the Text tool for typing. 

The Vertical Text tool does not appear unless “Enable two-byte 
script” is selected in the Preferences dialog box. The Vertical Tex
tool is designed for Japanese and other languages with vertical te
For information on the Vertical Text tool and other features for wo
ing with two-byte languages, see “Tools and options for two-byte a
vertical text” on page 9.9.

A selected text object has 
handles at the corners and 
midpoints of its bounding 
box.

In edit mode, an insertion point appears 
in the text, and the Text tool pointer is an 
I-beam.

Insertion point
I-beam pointer
.2 TEXT ENTRY AND LAYOUT
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Using the Text tool
The Text tool is used to create new text objects, type text into a d
ment, and edit text. 

When you create text objects with the Text tool, you can choose 
whether or not to set the column width before typing.

• If you set the column width before typing, text will wrap to
the next line when it reaches the right boundary of the te
object.

• If you don’t set the column width before typing, the right 
margin expands indefinitely to accommodate the amount
text you type. This is called a “caption” text object.

In either case, you can change the size of the text object by selec
it and dragging a selection handle.

Whether you should set the column width before or after typing 
depends on the amount of text you want to type. For short labels 
callouts, you might find it easier to simply type and let Canvas adj
the right margin. However, for paragraphs or newsletter columns, 
probably easier to set the column width before typing.

To type text with the Text tool

1 Select the Text tool in the toolbox. The pointer displays an I
beam when moved into the document window.

2 Do one of the following to set the location and type the text:

• To enter one line of text, click in the document; an insertio
point appears where you click. Begin typing and the right
margin extends to fit the line of text that you type.

• To define a text column, drag diagonally to create a recta
gular text object. The object’s width matters, but not its 
length; Canvas contracts or expands the length to accom
date the text you type. An insertion point appears at the t
of the object. Begin typing, and when you reach the right
margin, Canvas wraps the text to the next line.

3 When you finish typing, press Esc to exit text-editing mode.
You can also end text editing by pressing Enter (Mac), or by sel
ing another tool. The text object remains selected.

4 When a text object is selected, you can change its dimensio
by dragging one of the selection handles on the edge of the obj

Text tool
Typing text in a document 19.3
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To deselect the text object, press Esc, select another object, or 
outside the object.

To type text in an object

When a vector object such as an oval is selected, you can use th
object as a text container and type text in it without selecting the T
tool. 

To type text in an object, select the object and simply begin typin
(without clicking in the object first). The text you type stays inside
the left and right boundaries of the object. When you finish typing
press Esc to end text editing.

If you start to type more text than can fit in the object, a text overflo
indicator appears. You can resize the object to fit the text, or flow
extra text to another text object; see “Flowing overset text into ne
text columns” on page 19.19 for more information.

Typing text in an object is the same as wrapping text inside an obj
See “Wrapping text inside an object” on page 23.1 for more inform
tion on how to work with this type of text.

Typing text on paths
You can use the Path Text tool to type text so it follows the path o
vector object, such as a circle, polygon, or open curve. You can a
use the tool to create text that flows along multiple paths.

To type text on a path

1 Select the Path Text tool in the Text toolbar. In the document
window, the pointer is an arrow. The arrow changes to an I-beam
when you point to a vector object path.

2 To set the insertion point, click the path. Begin typing and the
text follows the vector path. You can type multiple lines of text. To
start a new line, press Enter at the end of the previous line. 

3 When you finish typing, press Esc. The text object becomes 
selected.

Select a vector object and begin 
typing to wrap text inside the 
object.

Path Text tool
.4 TEXT ENTRY AND LAYOUT
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Flowing text

As you type text on a path, if you reach the end, you can flow tex
another path. Click the overset symbol at the end of the text obje
Then, click the next vector path at the point where you want the o
set text to start flowing. You can continue typing to enter addition
text.

If you don’t want to flow overset bound text, you can resize the pa
so that all the bound text can flow along it. If no text is overset, th
overset symbol does not appear at the end of the text object.

You can also use the Text Link tool to link text to another path. 
Select the Text Link tool in the Text toolbar. The pointer displays t
number “1.” Click the first text object. The pointer changes to the 
number “2.” Click the object you want the text to flow to. When yo
finish, press Esc.

Adjusting text on a path See the section about adjusting bound 
text, starting with “Binding text to vector objects” on page 23.5, fo
information on changing the text baseline, flipping the text, and 
adjusting the spacing between the text and the path.

Typing special characters
You can insert special characters using Keycaps (Mac) or Charac
Map (Windows). The table below shows key strokes for some spe
characters. On Windows, the numbers must be typed on the num
keypad. 

Character Mac Keystroke Windows keystroke

– (em dash) Option + - Alt + 0151

™ Option + 2 Alt + 0153

£ Option + 3 Alt + 0163

§ Option + 6 Alt + 0167

Vector path

Overset symbol
Typing text in a document 19.5
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Typographic quotes

You can set a preference so Canvas inserts typographic (“curly”)
quotation marks in text you type. For more information, see “Use 
Smart Quotes” on page 9.8.

To control line breaks 

“Soft” returns are forced line breaks which do not create new para
graphs.

To create a soft return, place the insertion point where you want t
soft return and press Shift+Return. Text to the right of the soft ret
moves to the next line.

◆ To view soft return symbols: Choose Layout > Display > 
Show Text Invisibles. To hide soft return symbols, choose Layout
Display > Hide Text Invisibles.

Attributes of new text
When you type text, Canvas applies the current attributes and the
rent type format settings to the characters you type.

Type formatting Canvas applies the current settings for the font,
style, type size, justification (alignment), leading, and kerning to th
characters you type. These settings are selected in the submenu
the Text menu or with the controls in the Type palette. For more 
information on formatting, see “Applying text formats” on page 21

Inks Canvas applies the current fill ink, if it’s a solid color fill ink, 
to the text characters. If the current fill ink is a gradient, hatch, sym
bol, or texture, Canvas applies 100% black to the text characters.
pen ink for text you type is always 100% black, and is not visible 
until you apply a pen stroke to the text.

Strokes Canvas applies no stroke to text characters you type. Th
means that no outline appears on the characters, and the pen ink

¶ Option + 7 Alt + 0182

• Option + 8 Alt + 0149

® Option + r Alt + 0174

© Option + g Alt + 0169

Character Mac Keystroke Windows keystroke

Fill ink

Pen ink

A text character that has a gray 
fill ink and a black pen ink, with a 
2-point pen stroke
.6 TEXT ENTRY AND LAYOUT
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applied to the text is not visible because the pen ink appears only
when an object or text has a visible stroke.

Creating text layouts
The Text Object tool lets you place empty text objects, or columns
page layouts. Empty text columns created with the Text Object to
keep their width and length, unlike text objects made with the Tex
tool, which shrink and expand to fit the amount of text you type. T
Text Object tool is especially useful for designing templates and m
ter pages, because you can set up text columns and add type lat

If you type or paste text into a column created with the Text Obje
tool, and there is more text than will fit in the column, Canvas hide
the overflow text and displays an overflow indicator. See “Flowing
overset text into new text columns” on page 19.19 for information 
flowing text from one object to another.

Note: The Text Object tool doesn’t select text or place a text objec
edit mode. For these operations, use the Text tool. 

To create an empty text column

1 Select the Text Object tool. When you move into the docume
window, the pointer is an I-beam with an arrow.

2 Drag to set the width and length of a rectangular text colum

3 Canvas deselects the Text Object tool and selects the Text t
The new text object is in edit mode, with an insertion point at the
top of the column.

• You can begin typing in the new text object immediately, o
press Esc to end text editing. The text object remains 
selected; press Enter (Mac) or Esc (Windows) to deselec

Positioning text objects
You can arrange text objects the same way you arrange other typ
objects. You can drag text objects with the mouse, resize them b
dragging a selection handle, “nudge” text objects with keyboard 
arrow keys, and set coordinates and dimensions in the Object Sp
palette.

Copying and removing text objects

You can use the Copy, Cut, Clear, Paste, Duplicate, and Replica
commands in the Edit menu to copy and delete text objects. Thes

Text Object tool

✔Tip
When the bounding boxes of 
text objects are visible, you can 
hide them by choosing Display 
> Hide Text Boxes in the Lay-
out menu. To show text boxes 
again, choose Display > Show 
Text Boxes in the Layout menu.

Text Object tool pointer

Drag the Text Object tool to 
create an empty text object.
Creating text layouts 19.7
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commands operate on text objects the same as on vector objects
more information on these commands, see “Copying, cutting, pas
ing, and deleting objects” on page 10.7.

Inserting headers and footers
In Publication documents, you can add header and footer text obj
using commands in the Text menu. Headers and footers are spe
text objects that can contain codes for the current date, current tim
and page number, in addition to text you type. Canvas updates th
date, time, and page number codes each time it redraws the scre

Canvas inserts headers at the top of the printable area (the top o
on screen page layout) and footers at the bottom of the printable a
Both types of objects initially span the width of the page, but you c
resize and move them just like other text objects.

To create header and footer text objects

1 Because you can’t add headers and footers in edit mode, p
Enter (Mac) or Esc (Windows) to end text editing, if necessary. 

2 Choose Text > Insert > Header or Text > Insert > Footer. Ca
vas creates the text object, and places it in edit mode.

Inserting dates, times, and page numbers

In Publication documents, you can insert date, time and page num
codes in header and footer text objects. Canvas will update the va
for these codes each time it redraws the screen. Canvas uses the
and time as set in the operating system. Refer to your system do
mentation for information on setting the current date and time.

You can insert the current date and time in standard text objects,
Canvas does not update this text; it is “stamped” into the documen
regular text.

◆ To insert the date, time, or page number in a Publication 
document: With a header or footer object in edit mode, choose an
option in the Insert submenu in the Text menu; refer to the table f
descriptions of the Insert submenu commands.

You can apply text formatting to the date, time, and page codes. 
example, you can change fonts, type sizes, and justification, as y
would apply formatting to normal text with the Text menu or the 
Type palette. 
.8 TEXT ENTRY AND LAYOUT
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Date, time, and page number commands

Creating column layouts
To create text columns in a document, you could manually arrang
separate text objects. However, the Section tool and column guid
make text layout almost automatic. This section describes how to
work with the Section tool and column guides to create text layou

Column guides and sections

A section is a rectangular area that arranges text in columns. A s
tion is made of column guides, which are non-printing lines that 
define the text columns and gutters (spaces between columns). 

Sections make it easy to arrange and modify text in columns. You
can place one or more sections on a page. After you place text in
section, you can change the number or the size of the columns in
section and Canvas will adjust the text to fit.

Displaying column guides

You can display or hide all the section column guides in a docum

◆ To show column guides: Choose Layout > Display > Show 
Guides when column guides are not displayed. To hide column 
guides, choose Layout > Display > Hide Guides when column gui
are displayed.

To insert In this type of object Do this

Updating date code Header or footer Choose Insert > Date, or type $d

Date stamp Any text object Choose Insert > Date Stamp

Updating time code Header or footer Choose Insert > Time, or type $e

Time stamp Any text object Choose Insert > Time Stamp

Current page number Header or footer (page 
count is static in normal 
text objects)

Choose Insert > Page #, or type $p

Total page count Header or footer (page 
count is static in normal 
text objects)

Choose Insert > Total Page #, or type $t

A 3-column section
Creating column layouts 19.9
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Creating sections
You can create sections with the Section tool or the Column Guid
command. 

• The Section tool lets you place multiple sections at specifi
locations on one or more pages. You can also use the too
modify sections.

• The Column Guides command lets you place sections on 
pages that don’t contain sections. If the current page has s
tions, the Column Guides command lets you change the s
tings for any section on the page.

Whether you are creating or modifying sections with the Section t
or the Column Guides command, the Column Guides dialog box 
the control center for configuring sections. 

When you create a section, the section’s column guides appear o
guide layer in the document. By default, guide layers are non-print
and have a bright blue override color. You can use the Documen
Layout palette to change the override color or make a guide layer
printable.

When you add text to a section, Canvas creates a text object in e
column in the section. The text objects are placed on the current 
layer. 

To create sections with the Column Guides command

1 Go to the page where you want to place a new section and 
choose Layout > Column Guides. 

2 In the Column Guides dialog box, you can select a preset col
umn arrangement or set up custom columns. In the Apply To me
choose where to place the new section. See “Column Guides set
tings” on page 19.12. 

3 Click OK to create a new section with the current settings.

If the document contains no sections, Canvas creates one or mor
new sections, according to the Apply To setting. 

Modifying sections
If you choose the Column Guides command, and the current pag
contains one or more sections, you can use the Column Guides d
box to modify or delete a section.
.10 TEXT ENTRY AND LAYOUT
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Enter the name of the section to modify in the Section Name box
You can use the menu to select the name of any section on the p
When you click OK, Canvas applies the settings in the Column 
Guides dialog box to the section specified in the Section Name b

If you choose the Delete Section command in the dialog box, Can
deletes the section specified in the Section Name box.

Using the Section tool
You can drag the Section tool in a document to create a section. 
can also use the Section tool to move and modify sections. The S
tion tool is in a toolbar with other text tools in the toolbox.

To create a section with the Section tool

1 Select the Section tool, and then drag in the document to set
width and height of the section. 

2 In the Column Guides dialog box, select options for the sectio
You can select preset column guides or specify a custom setup. S
“Column Guides settings” on page 19.12. 

3 Click OK to create a new section with the current settings.

Modifying sections with the Section tool
You can use the Section tool to move, resize, and modify section

Moving sections

To move a section, drag it with the Section tool. When you move 
section, text objects contained in the section move with the sectio

Note: You must use the Section tool to move or resize a section. 
Unlike vector, paint, and text objects, you can’t use the Selection t
to modify a section.

Resizing sections

To change the width of a section, drag one of its sides. To change
height of a section, drag the top or bottom border of the section. T
change both dimensions at once, drag a corner of the section.

To adjust the width of columns in a section, use the Section tool t
drag column guides. The Fixed Widths and Fixed Gutters options
the Column Guides dialog box limit how sections can be resized.
both options are selected, you can’t drag the sides, columns, or g

Section tool

Drag to create a section
Creating column layouts 19.11
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ters to resize a section; you can drag the top or bottom to make it
longer or shorter. 

Modifying sections

To change the configuration of a section, including the number of
columns and their widths, double-click the section with the Sectio
tool. This opens the Column Guides dialog box. Change the setti
in the dialog box and click OK to apply the settings to the section

◆ To delete a section: Double-click the section with the Section 
tool. In the Column Guides dialog box, choose Delete Section in 
pop-up menu and click OK.

Column Guides settings
The Column Guides dialog box appears when you create or mod
sections with the Section tool or the Column Guides command.

Section Name

Canvas applies a default name when you create a section. You c
type a new name in the text box to change a section’s name. 

To modify a section, enter its name. You can select a section nam
the Section Name menu. The menu contains names of sections o
current page or pages. 

When you modify a section, Canvas modifies all sections that hav
the same name if you select an option in the Apply To menu that 
refers to more than one section.

Apply To

When you create and modify sections, choose an option in the Ap
To menu to specify where you want to apply the column guides s
tings.

This Page Applies the settings to the current page only. In a Pub
cation with facing pages, it applies the settings to both (left and rig
current pages. 

All Pages Applies the settings to all pages in the document. 

All Left Pages Applies the settings to all left-hand pages in a Pu
lication with facing pages. 

All Right Pages Applies the settings to all right-hand pages in a 
Publication with facing pages. 
.12 TEXT ENTRY AND LAYOUT
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Left Page Applies the settings to the current left-hand page in a
Publication with facing pages. 

Right Page Applies the settings to the current right-hand page in
Publication with facing pages.

Section options

You can also delete sections, fit sections to a page, or fit sections
the top half or bottom half of a page. Choose an option from the tr
gle pop-up menu.

Delete Section Deletes the current section. If the Apply To settin
refers to more than one section, this deletes all matching sections

Fit to Page Creates a full-page section. 

Fit to Top Half or Fit to Bottom Half Creates a half-page section 
on the top half or the bottom half of the specified pages.

Preset column guides

These buttons let you select a preset column guides arrangemen
You can select 1, 2, or 3 columns of equal width, or 2 columns wit
wider column on the left or right.

Number of Columns

This setting specifies the number of columns; it overrides the pre
column guides. Type the number of columns. The maximum num
you can set depends on the width of a section.

Equal Widths This option makes the column widths equal to the 
value in the Column box, and makes the gutter widths equal to th
value in the Gutter box. 

Deselect this option to set the width of a specific column.

When Equal Widths is selected, you can’t set a specific column wi
(the Column box is not available), because the column width is ba
on the number of columns, the gutter width, and the section size.

Fixed Widths This option prevents changes to the width of the se
tion’s columns. If you use the Section tool to drag a column guide
the entire column moves, which changes the width of the gutters 
without changing the width of the column. 

Fixed Gutters This option prevents changes to the width of the c
umn gutters. If you use the Section tool to drag a column guide, t
gutter moves, which changes the width of the adjacent columns w
out changing the width of the gutter.
Creating column layouts 19.13
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If both Fixed Gutters and Fixed Widths are selected, you can’t dra
the column guides in a section to adjust the widths of columns or 
ters.

Horizontal This option appears if “Enable two-byte script” is 
selected in the Preferences dialog box. It creates horizontal colum
for text in a section.

Size

If Equal Widths is not selected, you can set widths for specific col
umns and gutters in the Size area.

Column # To adjust a specific column or the gutter to the right o
the column, select the column by number. The widths of the selec
column and gutter appear in the Size area. Columns are number
from left to right.

Column Enter the width of the column specified in the Column #
menu. If you select a preset column option, the Column value can
be changed unless Equal Widths is deselected first. This box is n
available if Equal Widths is selected.

Gutter Enter the width of the gutter to the right of the column spe
ified in the Column Number pop-up menu.

Text Flow

To change the direction of the text flow, click the button that indi-
cates left to right (the arrow points right) or right to left (the arrow 
points left). 

Applying section settings throughout a 
document
The Column Guides dialog box lets you create or modify multiple
sections at once. The Apply To setting controls how Canvas appl
the column guides settings. When you click OK, Canvas modifies
matching sections and creates new sections as necessary, depe
on the setting selected in the Apply To menu.

For example, if you choose All Pages while creating a section, Ca
vas creates a matching section on each page in the document.

In Publications with facing pages, you can apply the column guid
settings to left-hand or right-hand pages, or both.

Canvas will modify existing sections and create new matching se
tions, if necessary, based on the Apply To setting. For example, a
.14 TEXT ENTRY AND LAYOUT
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document with 10 pages has matching sections on five pages. If 
choose All Pages while modifying a section, Canvas will modify th
existing sections and create a new section on each of the pages 
out a matching section.

The Apply To setting can complement your actions. If you drag th
Section tool on a left page in a Publication, but choose Right Pag
the Apply To menu, Canvas creates a section on the left page an
the right page.

Placing text in sections
After you create a section, you can place text in the section by typ
or pasting text from the Clipboard. You can also place text using 
Place command. Canvas links the text objects in the section so th
text will flow from column to column.

If the last column in a section contains overset text, you can flow 
text to another column by clicking the overset symbol and then cl
ing in a column. 

If you create sections on multiple pages, Canvas links the column
the first section when you place text in the section. If you want tex
flow to another section, you can click the overset text indicator in 
last column in a section, and then click in the first column in anoth
section to flow text from one section to the other

To place text using the Place command

You can use the Place command to place text from a text file into
section.

1 Select the Text tool and click at the top of the first column in t
section. An insertion point appears in the column at the height wh
you clicked. 

2 Choose File > Place. Select the text file you want to place an
click Place. The text from the text file appears in the section and 
flows from column to column.

To type text in a section

You can use the Text tool to type text in a column in a section. 

1 Select the Text tool and click at the top of the first column in t
section. An insertion point appears in the column at the height wh
you clicked. Canvas creates linked text objects in the section whe
you click in the section with the Text tool.
Creating column layouts 19.15
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2 Begin typing. Text will wrap to the next line when it reaches th
column edge. If you continue typing to the end of the column, tex
will flow to the next column in the section.

If a section has multiple columns, you can skip one or more colum
by clicking in the section where you want the text flow to begin.

To paste text into a section

After you create a section, you can paste text from the Clipboard 
create text columns.

1 Use the Edit > Copy command to place text on the Clipboard

2 Select the Text tool and click at the top of the first column in t
section. An insertion point appears in the column at the height wh
you clicked. 

3 Choose Edit > Paste. The text on the Clipboard appears in th
section and flows from column to column. 

If the final column in a section contains overset text, you can flow 
text into another text object or section, or resize the section to con
the overset text. See “Flowing overset text into new text columns”
page 19.19.

Placing graphics in text objects
You can use the Insert Picture command to anchor graphics in a 
object. This feature lets you use custom bullets, special illustratio
for drop caps, and small logos within text.

An inserted picture behaves like a text character.

• Inserted pictures move with the surrounding text.

• Indent and justification settings apply to inserted pictures

• You can adjust an inserted picture’s baseline and kerning

• An inserted picture rotates and skews with the surroundin
text.
.16 TEXT ENTRY AND LAYOUT
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Some text formatting features do not apply to inserted pictures. 

• If you scale the surrounding text, an inserted picture doe
not distort or scale with the text. 

• Spread and Overprint commands do not affect inserted p
tures. 

• Strokes or inks applied to the text don’t affect inserted pic
tures.

• Inserted pictures might not be imported from the Clipboa
by other applications.

When the insertion point is in a text object and you choose the In
Picture command, Canvas inserts the contents of the Clipboard a
raster image into the text.

Because Canvas converts the Clipboard contents to a raster ima
when you use Insert Picture, you cannot edit objects that have be
inserted into text. For example, if you insert a multigon object into
text, you can’t use editing handles to reshape or scale it. 

If you insert text characters using the Insert Picture command, th
inserted text characters are not editable.

To insert a picture into text

The Insert Picture command is available when any object is on th
Clipboard and the insertion point is in a text object.

1 Select the object or objects that you want to insert into text.

2 Choose Edit > Cut or Edit > Copy to place the selection on t
Clipboard. If you selected multiple objects, they become a singl
composite graphic when inserted into text.

3 Select the Text tool in the toolbox. Click in the text where yo
want to insert the graphic. An insertion point appears where you
click.

4 Choose Text > Insert Picture. The Clipboard contents appea
the insertion point. 

How inserted pictures affect leading

When you use the Insert Picture command, the leading of the par
graph might change, depending on the Line spacing method:

Text with an inserted picture 

Insertion point
Placing graphics in text objects 19.17
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• If the Line spacing is defined by Percentage in the Leadin
area of the Type palette, Canvas adjusts the Line spacin
fit the picture based on the defined percentage, if necess

• If the Line spacing is defined by Points, the spacing 
between lines stays the same, regardless of the size of th
picture. 

Using macros for inserted pictures

If you want to be able to edit an inserted picture, you can insert a
macro object into text. A macro object is an object linked to an ed
able original in the Gallery palette. If you change the original in th
Gallery palette, the inserted picture macro object will change to 
match the original. 

For example, you can use the Insert Picture command to place sim
placeholder macro objects (such as small squares) where you wa
finished graphics to appear in text. When the final graphic is avai
able, replace the placeholder macro in the Gallery palette with the
finished graphic. With this method, you do not have to change ea
instance of a graphic individually or alter the publication’s layout.

Line spacing set to 100%

Line spacing set to 12 points
.18 TEXT ENTRY AND LAYOUT
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Flowing overset text into 
new text columns

You can flow text when all the 
text won’t fit in a text object. 

An indicator tells you when an 
object has overset text. If you 
select a text object and drag a 
handle to reduce its size so all 
the text does not fit, the over-
set indicator appears.

Click the overset indicator (A) 
to change the pointer to a text 
flow pointer (B). You can click 
or drag the pointer to create a 
new column for the overset 
text. 

To flow text into a column with 
the same margins as the origi-
nal column, click the text flow 
pointer where you want the 
upper-left corner of the new 
column to appear. To flow text 
into a column with different 
margins than the original col-
umn, drag the text flow point-
er to specify the column width.

You can flow text between as 
many columns as you want.

Resizing a text column can 
result in overset text

If you click the overset 
indicator (A), the text flow 
pointer (B) appears

Clicking with the flow pointer 
creates a new column the same 
size as the original, and flows 
the overset text into it. 

A plus sign replaces the 
overset sign on the first 
column, indicating that text 
flows to another column.

A

B

Placing graphics in text objects 19.19
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Flowing text from column to column
You can create text flows so that text runs from one text object to
another. You can flow text to a new text object when the text won
all fit in an existing text object; the term “overset text” is used to re
to the text that doesn’t fit in a text object or column. 

You can also link empty text objects to create a preset text flow wh
you create templates for page layouts.

Flowing overset text to a new object

If you reduce the size of a text object, or change the text formattin
and all the text no longer fits in the text object, you can create ano
text object to hold the overset text. Doing this creates a link betwe
the first and second text object, as shown in “Flowing overset tex
into new text columns,” above.

Displaying text flow bars

A text flow bar is a solid line with a flow symbol. Flow bars appear 
the bottom of text objects when they contain overset text or are p
of text flows. The symbol under a flow bar indicates the flow cond
tion.

• An arrow indicates that a text object contains overset text.

• A plus sign indicates that text flows to another text object.

• The last object in a text flow does not display a flow bar 
unless text is overset.

◆ To display flow bars: Choose Layout > Display > Show Text 
Flow Bars. To hide text flow bars, choose Layout > Display > Hid
Text Flow Bars.

Linking text objects
After you create text objects using the Text tool or Text Object too
you can use the Text Link tool to link the objects and create a tex
flow. When text you type or insert fills one object, it flows to the ne
linked text object. The linked text object can be on another page (
Publication document) or another slide (in a Presentation docume
You can link columns in a chain to create articles in a multi-page 
document such as a newsletter. The Text Link tool is especially u
ful for creating templates for publications.

Note: Text objects created with the Text tool expand as needed w
text is added. However, if you use the Text Link tool to link object

Text object has overset text

Text flows to another text object

Text Link tool
.20 TEXT ENTRY AND LAYOUT
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created with the Text tool, the objects no longer expand or contrac
hold the text. Instead, they remain a fixed length, the same as ob
created with the Text Object tool.

To link text objects

You can use this procedure to link an object containing text or an
empty text object to other text objects.

1 With the Text or Text Object tool, create at least two text 
objects. Select the Text Link tool in the Text toolbar. The pointe
displays the number “1”.

2 Click the first text object — the object you want to flow from. 
The text link pointer changes to the number “2”.

3 Click the next text object — the object you want to flow to. If 
you click anything but a text object, Canvas cancels the linking 
operation.

4 To link another text object to the chain, repeat the linking pr
cedure: Click the object text will flow from, and then click the 
object the text will flow to.

5 When you finish, press Enter (Mac) or Esc (Windows).

Unlinking text objects
You can use the Text Unlink tool to break the links between text 
objects that have been linked into a text flow. To unlink one text 
object from the next object in the flow, select the Text Unlink tool 
and click the first text object. 

Checking text flows
The Link Info tool lets you check text flows in a document. You ca
use the tool to display arrows showing the flow of text among link
text objects. 

The Link Info tool is in the Text toolbar.

✔Tip
If text boxes aren’t visible, 
choose Display > Show Text 
Boxes in the Layout menu; this 
makes it easier to find and link 
empty text objects.

Text Unlink tool

Link Info tool
Flowing text from column to column 19.21
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To check a text flow

1 Select the Link Info tool. 

2 Point to a text object. Press and continue holding down the 
mouse button to display flow arrows. 

If the text object is part of a linked text flow, arrows show the flow
sequence. Flow arrows are displayed until you release the mouse
ton. If the text object is not linked, no flow arrows appear.

A flow arrow starts at the lower-right corner of the first object in a 
flow, and points to the upper-left corner of the next object in the flo
and so on throughout the flow. 

Note: With the Link Info tool selected, you can use the same proc
dure to display flow arrows.

A

A Flow arrow
.22 TEXT ENTRY AND LAYOUT
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TEXT EDITING AND PROOFING

You can insert, search, replace, move, delete, copy, and spell ch
text in Canvas documents. This chapter describes how to naviga
through text for editing, how to make text selections, and how to u
spelling tools and the Find feature for text search-and-replace.

Text edit mode
To edit text, put a text object in edit mode. In edit mode, you can 
revise, delete, insert, and select specific text. Only one object is in
text edit mode at a time. You can put a text object in edit mode w
the Text tool or the Selection tool.

When you put a text object in edit mode, the text object becomes
opaque, the selection handles disappear, and a flashing insertion
point appears. Also, the Text tool becomes the active tool.

◆ To enter edit mode using the Text tool: Select the Text tool 
and click in a text object. An insertion point appears where you cli
and you can begin typing or editing.

◆ To enter edit mode using the Selection tool: With the Selec-
tion tool, double-click a text object. If you double-click on a word, 
the word becomes selected and is highlighted. The Text tool is 
selected, and you can begin typing or editing.

◆ To edit text bound to a path: With the Path Text tool or the 
Text tool, click the text. An insertion point appears in the bound te
and you can begin typing or editing.

Leaving text edit mode
When you finish text editing, you can leave edit mode by doing an
of the following:

• Press Esc (Mac or Windows) or Enter (Mac only). Canva
switches to the Selection tool from the Text tool. The text
object you were editing is selected.

• Select another tool in the toolbox. The text object you we
editing is selected.

In edit mode, an insertion point 
appears in the text object.

Insertion point
20.1
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• Click outside the text object. Canvas creates a new text 
object where you click. The text object you were editing i
not in edit mode and isn’t selected.

• Choose the Save command in the File menu. The text ob
you were editing is not in edit mode, and the Text tool 
remains active.

Text selection and navigation 
You can move the insertion point and select characters, words, li
and paragraphs using the mouse or the keyboard.

The mouse lets you quickly select text or text objects and move t
insertion point. However, if you work with a lot of text, you might 
find that the keyboard techniques let you move the insertion poin
more precisely to edit more quickly.

Making text selections
Before you can cut, copy, move, delete, type over, or perform oth
operations on text characters, you need to select the text within a
object. You can select text when a text object is in edit mode. For
information on putting a text object in edit mode, see “Text edit 
mode” on page 20.1.

The phrases “selected text,” “text selection,” and “highlighted text
all refer to an active selection of characters within a text object. 
Selected text appears highlighted; the highlight color depends on
your system’s color settings.

Keep in mind that a text selection is not the same as a selected te
object. When you select a text object, you can move, copy, delete
and perform other operations on the entire object. When you mak
text selection, the editing actions will affect only the highlighted 
characters within the object.

◆ To deselect all highlighted text: Click anywhere in the text 
object or layout. Clicking outside the selected text object creates 
another text object at that location.

Using the keyboard for text editing

While editing text, you can use the key combinations listed in the 
lowing table to move the insertion point and select text. 
.2 TEXT EDITING AND PROOFING
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Key combinations for text editing 

Using the mouse for text editing

Using the mouse and modifier keys, you can quickly place the ins
tion point, select specific words, and select sections of text in edit
mode. For information on putting a text object in edit mode, see 
“Text edit mode” on page 20.1.

Press this key and these keys to do this in edit mode

None Up arrow, Down arrow, Right 
arrow, Left arrow

Move insertion point 1 space right or 
left

Page Up, Page Down Move insertion point 3 lines up at the 
left margin (Page Up) or down at the 
right margin (Page Down) 

Home, End Move insertion point to the beginning 
(Home) or end (End) of the text object

Option (Mac)

Ctrl (Windows)

Right arrow, Left arrow Move insertion point to the next word 
end (Right arrow) or beginning (Left 
arrow)

Up arrow, Down arrow Move insertion point to the left margin 
of the line, or up 1 line at the left mar-
gin (Up arrow), or down 1 line to the left 
margin (Down arrow)

Home, End Move insertion point to beginning 
(Home) or end (End) of line

Shift Right arrow, Left arrow Extend selection 1 space right or left

Up arrow, Down arrow Extend selection 1 line up or down 

Page Up, Page Down Extend selection 3 lines up or down

Home, End Extend selection to the beginning 
(Home) or end (End) of the text object

Shift + Option (Mac)

Shift + Ctrl (Windows)

Right arrow, Left arrow Extend the selection 1 word right or left

Up arrow, Down arrow, Extend the selection to left margin (Up 
arrow) or right margin (Down arrow). 
From the margin, extend the selection 
to the other margin, or up or down 1 
line

Page Up, Page Down Extend selection 3 lines up or down
Text selection and navigation 20.3
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Mouse actions for text editing

Copying, pasting, deleting, and moving text selections
You can cut and copy a text selection, and then paste the selected
in the same document, in another Canvas document, or to and fro
non-Canvas document using the Clipboard. 

Whether pasted text retains its formatting depends on the operati
system and the source of the text. 

• Text pasted from the Mac OS Clipboard that originated in
another application will be formatted with the current Can
vas text formatting when pasted into a Canvas documen
regardless of the formatting applied in the originating app
cation. 

• In Windows, text pasted from another application can be
embedded into a Canvas document, using Object Linking
and Embedding (OLE) to preserve its formatting. See 
“Embedded text objects and editions containing text” on 
page 20.15.

If you copy and paste selected text (and not an entire text object)
within Canvas, the text retains its character attributes, but it adop
the paragraph formatting of the surrounding text. 

To delete text

1 Select the text you want to delete.

To do this in text Do this with the pointer

Select a continuous block of text Drag over the text you want to select

Select all text between the insertion point and 
another location

Press the Shift key and click where you want the selection to 
end. Windows users can use the right mouse button like the 
Shift key (hold down the right button and click with the left).

To deselect all highlighted text Click anywhere in the text object. (Clicking outside the text 
object creates a new text object at that location or puts 
another text object into edit mode.)

Deselect text between the insertion point and 
another location in the selection

Press Shift and click in the highlighted text

Select a word Double-click the word

Select a line of text Triple-click the line

✔Tip
To help you in editing text, you 
can display symbols for spaces, 
paragraph breaks, and indents. 
Choose Layout > Display > 
Show Text Invisibles. To hide 
these symbols, choose Layout 
> Display > Hide Text Invisi-
bles.
.4 TEXT EDITING AND PROOFING
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2 Choose an operation based on the results you want:

• To remove the text to the Clipboard, choose Edit > Cut.

• To delete the text from the document without saving it to 
the Clipboard, choose Edit > Clear, or press Delete. 

◆ To replace selected text: Begin typing, or use the Paste com-
mand, to replace a text selection with the text you type or paste fr
the Clipboard. This saves the step of deleting the selected text. 

◆ To replace all text in a text object: Select a text object and 
begin typing. The text you type adopts the formatting of the replac
text. If multiple text objects are selected, the text you type replace
the text in the object that was created first.

To copy selected text

When you copy selected text, you can create a new text object or
insert the text into an existing text object.

1 Select the text you want to copy.

2 Choose Edit > Copy. Canvas copies the selection to the Cli
board.

3 Depending how you want to paste the selection, do one of t
following:

• To paste text into an existing text object, put the insertion
point in the text where you want to paste the insertion.

• To paste text as a new text object, be sure no objects are
text edit mode by pressing Esc. You can set the width of t
new text object by selecting the Text tool and dragging. 
Otherwise, text will be pasted in one long line that might 
extend off the screen.

4 Choose Edit > Paste to insert the text from the Clipboard. 

Changing text attributes

While a text object is selected, you can change the formatting of 
the text it contains using the Text menu, the Type palette, or the t
ruler.

Finding and changing text
Use the Text tab in the Find palette to search for specific text in 
selected text objects and entire documents. You can replace or d
found text selections one at a time or all at once.
Finding and changing text 20.5



20

nd 

b 
an 
e 

 
ne 

f 
con-
an-

 the 
e 
ed 

f 
s 
es-

nd 

 
r 

 

t 
e 

es.
The Text tab also lets you search for text with specific font, size, a
style attributes, and change the attributes of found text.

To find and change text

1 Choose Edit > Find to open the Find palette. Click the Text ta
to select it. To search for text, type the text in the Find box. You c
specify that you want to find only whole words, or text matching th
capitalization (case) of the Find text. 

2 If you want to replace found text, type the replacement text in
the Change To box. When the Change To box contains at least o
character (including a space), the Change All button is available.

3 Click Find to locate the first occurrence of the specified text. I
one or more text objects are selected, Canvas searches the text 
tained in the first selected object. If no text objects are selected, C
vas searches the entire document.

4 If Canvas finds the specified text, it highlights the text in the 
document. You can click Find to search for the next occurrence of
specified text. If the Change To box contains replacement text, th
Change button is available. Click Change to replace the highlight
text with the Change To text.

5 To continue searching, click Find. Repeat the previous step i
Canvas finds another occurrence of the search text. When Canva
completes the operation, it displays a message. Click OK in the m
sage box to continue.

Note: You can click Change All to replace all occurrences of the Fi
text with the text in the Change To box, without first clicking Find.

Finding and changing text attributes

You can search for and change text attributes (whether or not you
also search for specific text). The text attributes you can search fo
and change are font, type size, and text style. 

1 To search for text attributes, click the arrow at the bottom-left
corner of the Find palette. 

2 In the Find Attributes section, select a font name from the fon
pop-up menu. Type a size (in points) or select a size from the siz
pop-up menu. Click the style buttons to set the styles you want. 

3 In the Change Attributes To section, you can specify replace-
ment attributes in the same way that you specify the Find attribut
.6 TEXT EDITING AND PROOFING
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4 Click Change or Change All to replace the attributes specified
the Find Attributes section with the attributes specified in the Chan
Attributes To section. If you have also typed text in the Find box, t
replacement text attributes can be applied only to text that match
the Find text. 

Clicking the Clear button removes all settings in the Find Attribute
and Change Attributes To areas.
Finding and changing text 20.7
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Text search options

The options on the Text tab in 
the Find palette let you specify 
criteria for text searching and 
replacement.

Find. Type the text you want to 
find. You can leave this box 
blank to search for text 
attributes only.

Change To. If you want to 
replace found text, type 
replacement text here. If you 
want to delete found text, leave 
the Change To box empty.

Whole Word. Select Whole 
Word to specify that the Find 
text is an entire word. For 
example, if you type “time” 
and select Whole Word, Can-
vas will not find “times,” 
“untimely,” or “timer.”

Match Case. Select Match 
Case to include the capitaliza-
tion of the Find text in the 
search criteria. For example, if 
you type “Time” and select this 
option, Canvas will not find 
“TIME” or “time.”

Change. If Canvas locates the 
text and attributes you speci-
fied, it highlights the text in the 
document. Click Change to 
replace the highlighted text 
with the Change To text and to 
apply the replacement 
attributes specified in the 
Change Attributes To section.

Change All. Click to replace 
all occurrences of the text 
and attributes you specified 
with the replacement text 
and attributes. Canvas 
makes the changes without 
highlighting found text.

Find button. Click to search 
for the next occurrence of 
text specified in the Find 
text box and attributes 
specified in the Find 
Attributes area.

Find Attributes

The text attributes that you 
specify here tell Canvas 
what to search for. 

A Click to display Attributes 
options. 

B To search for a particular 
font, select the font name from 
the pop-up menu.

C To search for a type size, en-
ter the size or select the size 
from the pop-up menu.

D To search for a type style, 
select a style button. You can 
select bold, italic, underline, 
outline, strikethrough, and 
shadow styles.

Change Attributes To

The text attributes that you 
specify here can be applied to 
text that matches the attributes 
specified in the Find Attributes 

area.

E Select the font from the 
pop-up menu.

F Enter the replacement size 
(in points) or select the size from 
the pop-up menu.

G Click style buttons to specify 
replacement styles. You can 
choose bold, italic, underline, 
outline, strikethrough, and 
shadow.

Clear.  Click to delete all the 
settings from the Find 
Attributes and Change 
Attributes To areas.

A

B
C

E

F

D

G
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Automatic text correction
Canvas can automatically fix typographical mistakes as you type.
The Auto Correct dialog box lets you select several automatic cor
tion options. It also lets you specify common misspellings, typing 
errors, and abbreviations that you want Canvas to replace as you
type. 

When any text replacement option is active, Canvas checks each
word you type. It corrects or replaces text as appropriate once yo
press the Spacebar.

To set up automatic correction

1 Choose Text > Spell Checker > Auto Correct. 

2 In the Auto Correct dialog box, select the replacement optio
you want to use. The options are described below.

3 Click OK to implement the current settings.

Auto Correct options 
Use the options in the Auto Correct dialog box to specify correctio
you want Canvas to make as you type.

Two Initial Capitals Corrects a word that you type beginning with
two capitalized letters.

Capitalize the First Letter of Sentences Capitalizes the first letter 
you type following typical sentence-ending punctuation, such as p
ods, question marks, or exclamation points, even if these marks a
followed by quotation marks or parenthesis. Canvas may or may 
capitalize the first letter following unusual punctuation, such as w
site addresses or abbreviations in the middle of sentences, so se
tences containing unusual punctuation should be checked.

Note: Auto Correct does not capitalize the next word if you insert 
sentence-ending punctuation in existing text.

Capitalize the Names of Days Capitalizes the full names of days 
of the week. For example, this option replaces “saturday” with “Sa
urday.” It does not expand abbreviations for day names, such as 
“wed.” or “Thurs.,” unless you add these abbreviations to the 
replacement list.

Correct Accidental Usage of the Caps Lock Key (Windows only)

Corrects non-standard word capitalization. If the first letter of a wo
is lowercase and the other letters are uppercase, this changes th
Automatic text correction 20.9
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letter to uppercase and the rest of the letters to lowercase. For ex
ple, this replaces “rEPEL” with “Repel.” If the first two letters of a 
word are uppercase and the rest are lowercase, this changes the
letter to uppercase and the rest of the letters to lowercase, replac
“REpel” with “Repel,” for example.

Replace Text as You Type Replaces text that you type with any 
specified replacement text. Each set of typed text and replaceme
text appears in the scrolling list in the Auto Correct dialog box. Yo
can add items to this list and delete selected items as described n

Setting up text replacement
You can specify abbreviations, common misspellings, and other t
that you want Canvas to replace as you type. 

You can use this feature to expand abbreviations for common phr
and long names that you type throughout a document. For examp
you often type “Department of Agriculture,” you can specify that th
abbreviation “DA” be replaced by the full name.

To set up text replacement 

1 Choose Text > Spell Checker > Auto Correct. In the Auto C
rect dialog box, be sure Replace Text as You Type is selected.

2 In the Replace box, type text that you want to be replaced. I
the With box, type the replacement text. Click Add to place the te
in the scrolling list. 
.10 TEXT EDITING AND PROOFING
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3 Repeat this procedure to specify more automatic replaceme
You can add as many items to the scrolling list as you want. Wh
you finish, click OK.

Note: Auto Correct does not remove specified text from a docume
if you type nothing in the With box. Also, Auto Correct won’t 
replace spaces with more or fewer spaces (such as replacing two
spaces with one space). However, you can use the Text tab in th
Find palette to find and replace spaces.

◆ To remove replacement entries: Select the entry in the scroll-
ing list and click Delete.

Automatic spelling correction

When you use the Spelling pop-up menu (page 20.12) to correct 
misspelling, Canvas adds the item to the Auto Correction list. The
misspelled word appears under Replace and the correction appe
under With. If you make the same spelling mistake again and 
“Replace Text as You Type” is selected in the Auto Correct dialog
box, Canvas corrects the error. If “Replace Text as You Type” is 
selected, Canvas won’t make these automatic corrections.

Checking the spelling of text
Canvas can check the spelling of all text in a document, including
text bound to a path by the Path Text tool or the Bind Text comma
Canvas can check the spelling of specific words, selections and e
documents. Canvas can also check the spelling of words as you 

Canvas checks the spelling of text by looking up words in the Can
Dictionary and the User Dictionary. The Canvas dictionary contai
100,000 words; this dictionary file can’t be modified. You can add
words to the User Dictionary to stop Canvas from marking unreco
nized words that are spelled correctly.

Showing and hiding unrecognized words
Canvas marks words that it can’t find in either the Canvas Diction
or the User Dictionary with a red wavy underline. Canvas can che
spelling while you type or after you finish entering text.
Checking the spelling of text 20.11
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When Show Spelling Errors is active, Canvas checks the spelling 
word after you type it and press the Spacebar, tab, or deselect the
object. Canvas marks an unrecognized word with a red wavy und
line.

◆ To mark unrecognized words: Choose Layout > Display > 
Show Spelling Errors. If you do not want Canvas to mark unrecog
nized words, Choose Layout > Display > Hide Spelling Errors. 

Using the spelling pop-up menu
While using the Text tool to edit text, you can choose suggested 
replacements for words marked as unrecognized.

The spelling pop-up menu lets you choose replacement words. Y
can also use the menu to add unrecognized words to the User D
nary.

To use the spelling pop-up menu

With a text object in edit mode, point to a word that Canvas has 
marked as unrecognized. Control-click the word (Mac) or right-bu
ton click the word (Windows). 

The spelling menu pops up. Do one of the following:

Replacement word To replace an unrecognized word with a sug
gested word, choose the suggested word in the pop-up menu. 

When you choose a replacement word in the Spelling menu, Can
adds the unrecognized word and the replacement word to the Au
Correct dialog box. The unrecognized word appears in the Repla
text box and the suggested word appears in the With text box. Se
“Checking the spelling of text” on page 20.11.

Add Word To add an unrecognized word to the User Dictionary,
choose Add Word. After you choose Add Word, Canvas adds the
word to the User Dictionary and will recognize any future use of t
word.

Ignore Word To ignore the spelling of the unrecognized word, 
click Ignore Word. If you choose Ignore Word, Canvas will ignore
the word in any document until you quit Canvas.

Cancel To close the spelling menu without making any changes,
choose Cancel or click outside the pop-up menu.

Unrecognized words marked

Spelling menu

Suggested 
words
.12 TEXT EDITING AND PROOFING
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Spell checking a selection or document
You can check the spelling of selected text, a selected text object,
an entire document using commands in the Spell Checker subme

1 To limit the spell checking to specific text or a text object, 
select the text or the text object. To spell check an entire docum
you don’t have to select anything.

2 To begin spell checking, choose Text > Spell Checker > Sp
Check Selection (if you selected text or a text object), or Text > 
Spell Checker > Spell Check Document. 

3 If Canvas finds an unrecognized word, the Spelling Checke
dialog box appears. For descriptions of the spelling options, see
“Spelling Checker,” next.

4 Canvas displays a message when the spell check is comple
Click OK to close the message box.

Note: Canvas deselects any selected objects (but not text) when 
use the Spell Check Selection or Spell Check Document comman

Spelling Checker

The Spelling Checker dialog 
box appears during spell 
checking of a selection or doc-
ument if Canvas finds a word 
that is not in its dictionaries.

A Canvas displays unrecog-
nized words in context. You 
cannot edit the text in this box.

B You can type a new spelling 
in this text box, or click the 
down-arrow to choose from the 
list of suggested spellings.

C The highlighted word in this 
box is the unrecognized word.

Replace. Click this button to 
replace the unrecognized word 
with the contents of the text 

box (B)and continue 
to spell check the 
document.

Add. If Canvas 
doesn’t recognize a 
word that is actually 
spelled correctly, you 
can add the word to 
the User Dictionary 
so that Canvas will 
recognize it in all 
future documents. After sav-
ing the word, Canvas contin-
ues to spell check.

Ignore. Allows an unrecog-
nized word in the current docu-
ment without adding the word 
to the dictionary. Canvas 
ignores all instances of the 

word until you close Canvas.

Skip. Allows the current 
instance of an unrecognized 
word, but Canvas alerts you 
the next time this word occurs.

Cancel. Interrupts the spell 
check and closes the dialog 
box. 

B

A

C

Checking the spelling of text 20.13
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Continuing a spelling check

If you cancel a spell check, you can choose Continue Spell Chec
the Spell Checker submenu to pick up where you left off. Canvas
remembers the words you chose to ignore.

Modifying the User Dictionary
In addition to more than 100,000 words in the Canvas Dictionary,
you can store an unlimited number of words in a personal user di
nary. By adding words to the User Dictionary, you can “teach” Ca
vas new words and special terms, and prevent Canvas from stop
unnecessarily while checking spelling.

To add words to the User Dictionary

1 Choose Text > Spell Checker > Show Added Words. The U
Added Words dialog box appears. 

2 In the dialog box, type a new word to add.

3 Click the Add button.

4 Click Done to close the dialog box when you are through ad
ing words.

To delete words in the User Dictionary

1 Choose Text > Spell Checker > Show Added Words. The U
Added Words dialog box appears. 

2 In the list, select a word to delete, and then click the Delete b
ton.

3 Click Done to close the dialog box when you are through de
ing words.

You can add words to the 
dictionary by typing the word in 
this text box and clicking Add

Words you add to the user 
dictionary appear in a scrolling list. 
To delete a word, select the word 
and click Delete.
.14 TEXT EDITING AND PROOFING
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Importing text from other applications
You can import text created in other applications into Canvas. Th
capability is especially useful if you are compiling documents from
different applications into a Canvas layout. For example, you mig
need to assemble a publication with contributions from several w
ers who each use different word processors.

Canvas supports several methods for importing text. You can ope
text file, place a text file, paste text from the Clipboard into a Canv
document, and use object embedding or Publish and Subscribe. 
Acquire command, however is used to import raster images, not 

Opening a text file with the Open command creates a new Canva
Publication document for the imported file. Placing, pasting, and 
embedding text inserts the text into the current document. For inf
mation on pasting text from the Clipboard, see “Copying, pasting,
deleting, and moving text selections” on page 20.4.

The formatting of imported text might differ from the formatting of
the original text in its native application. Although some software 
products might have similar capabilities, the methods used can v
significantly. It might be necessary to reformat imported text using
the typographic tools in Canvas.

To place a text file in an existing Canvas document

You can place text using the Place command. See “To place text
using the Place command” on page 19.15.

To place text using the same margins as the original file, click the
Place icon in the document. If the file you are importing contains t
only (no images or objects), you can also drag the Place pointer t
simultaneously import and set margins for the text. However, if th
file you want to import has images or objects, dragging the place i
scales the text, images, and objects as a group. 

Embedded text objects and editions containing text

In Windows, you can use Object Linking and Embedding (OLE) t
insert text in a Canvas document with the Paste Special comman
You can also use Publish and Subscribe in the Mac OS to subsc
to an edition that contains text.

However, Canvas treats embedded text objects and editions as 
objects, not text. You cannot apply effects, such as wraps or bind
text in these objects. In addition, Canvas cannot spell check, hyp

✔Tip

If you have difficulty opening or 
placing a text document 
because of the formatting, try 
converting the file to plain text 
before importing the file.

Also, try copying and pasting 
the text you want to import. 
This removes formatting that 
Canvas doesn’t understand.
Importing text from other applications 20.15
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ate, or format this text. All formatting and effects must be perform
in the original application or publisher.

For more details and procedures, see “Using Object Linking and 
Embedding (Windows)” on page 7.23 and “Using Publish and Su
scribe (Mac)” on page 7.26.

Exporting text from Canvas documents
You can copy text from Canvas and paste it into other application
using the Clipboard. In addition, you can use the Canvas file filters
save selections and documents in other file formats; see “File and
data exchange” on page 7.1. Keep in mind that if you save a doc
ment containing text, and use a format that supports only raster 
images, Canvas rasterizes the text before saving the file, so you c
edit it in the saved file.

Also, several Canvas typographic capabilities aren’t available in 
other applications. For example, character inks and strokes, text 
typed on a path, and wrapped text are unlikely to convert reliably
some cases, such as rotated text, the export filters might rasterize
characters, and you will not be able to edit them as text.

To export text to other file formats

1 Choose File > Save As. 

2 In the File Format (Mac) or Save as type (Windows) pop-up
menu, choose a file format. Type a name for the file, and then c
Save. 

Note: Canvas warns you that saving files in other formats might 
result in a loss of some information whenever you save using a fo
mat other than Canvas 6.

✔Tip
Always save a copy in Canvas 
format of files you want to 
export, in case the file conver-
sion doesn’t give the results 
that you expected.
.16 TEXT EDITING AND PROOFING
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FORMATTING TEXT

You can control all aspects of text formatting in Canvas. This chap
explains how to specify font, font styles, type size, character posit
and scaling, kerning, letter and word spacing, paragraph alignme
and spacing, and hyphenation. This chapter also explains how to
select text for formatting and how to apply format settings.

You can also save format settings as named character and parag
styles so you can use them again. 

Selecting text and objects
The following section is a review of some basic selection techniqu
used to format text. 

To select and deselect text objects

You can select text objects the same way you select other object
Canvas. 

• To select a single object, use a Selection tool to click the
text object or drag a selection rectangle around the objec

• To select multiple objects, hold down the shift key and clic
text objects with a Selection tool. You can also drag a se
tion rectangle around all the objects you want to select.

• To deselect an object, press the Shift key and click the 
object. Other objects remain selected.

• To deselect all objects, press the Enter key (Mac) or Esc k
(Windows) twice, or click an area of the screen where the
are no objects.

To select all text objects

To select all text objects with a single command, select the Text t
in the toolbox and then choose Edit > Select All. 

• In an Illustration document, this procedure selects all tex
objects on the current layer. 

• In a Publication document, this procedure selects all text
objects on the current page or current two-page spread. 

• In an Animation document, this procedure selects all text
objects on the current layer of the current frame. 
21.1
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• In a Presentation document, this procedure selects all te
objects on the current layer of the current slide. 

To select text within a text object

Before you can select specific characters, words, lines, or paragra
the text object must be in edit mode. 

1 To place an object in edit mode, use one of these methods:

• With a Selection tool, double-click the text object. The 
pointer becomes an I-beam and an insertion point appear
the text.

• Click the Text tool in the toolbox. The pointer becomes a
I-beam. Click the I-beam within the text. An insertion poin
appears.

• For bound text only, click the Path Text tool. The Path Te
tool is in a pop-out toolbar with the Text tool.

2 Use one of the following methods to highlight the text you 
want to select.

To Do this

Select a continuous block of 
text

Drag the I-beam over text.

Select all text between the 
insertion point and another 
location

Press the Shift key and click where 
you want the selection to end.

Deselect text between the 
insertion point and another 
location within the selection

Press the Shift key and click within 
the highlighted text.

Select a word Double-click the word with the I-
beam pointer.

Select a line of text Triple-click the line with the I-beam 
pointer.

Select all text in the text object Choose Edit > Select All.

Deselect all highlighted text Click anywhere in the text object or 
layout. Clicking outside the selected 
text object creates another text 
object at that location. Choosing 
another tool in the toolbox ends text 
edit mode.
.2 FORMATTING TEXT
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Working with linked text objects
When you link text objects so text flows from one column to anoth
you can select all of the text in the flow. This lets you apply forma
ting changes and text styles to all the text at once, even if the colu
are on separate pages or slides.

For information on linking text objects, see “Flowing text from col-
umn to column” on page 19.20.

To select all text in a flow

1 Select the Text tool and click one of the linked text objects; th
places the text object in edit mode and sets the insertion point in
text. You can also double-click a text object with the Selection to
to enter edit mode.

2 Choose Edit > Select All. Canvas highlights all the text in th
linked text objects.

To deselect the text, click outside any text object, or press Enter.

Note: When text is highlighted, anything you type replaces the hig
lighted text. If you select a long text flow across several columns, a
then type a single letter or press the Spacebar, all the highlighted
will be erased. If this happens, choose Edit > Undo.

Applying type formatting to a text flow

Once you select the text in a flow, you can apply formatting chang
using the Type palette, the commands in the Text menu, and the 
Ruler. Of course, changes that you make to selected text on othe
pages or slides will not be shown until you switch to the other pag
or slides.

Three linked text objects span three pages of a 
Publication document. The insertion point is in the 
first text object.

When you choose Select All, Canvas selects the text 
throughout the flow. 

Insertion point
Selecting text and objects 21.3
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Applying text formats
Canvas provides three ways to format text: the Text menu, the Te
Ruler, and the floating Type palette. The Text menu and Text Ru
provide basic formatting options, while the Type palette provides 
advanced controls and features. You might find that the Type pal
and Text Ruler are easier to use because you can keep them ope
you edit a document. However, using menu commands can help 
familiarize you with the hot-key command shortcuts and make tex
formatting quicker. 

When you use menu commands or the Text Ruler to apply forma
ting, the settings you choose affect the document immediately. H
ever, when you use the Type palette, the settings take effect whe
you click Apply. You do not have to click Apply before switching to
another tab within the Type palette; Canvas remembers all chang
and applies them simultaneously with one click. However, you mu
apply or save the new settings before clicking the pointer anywhere 
outside the Type palette. If you don’t, the settings will be lost. 

Depending on the text selection you make, the format settings yo
choose can be applied to existing text, stored as the preset for ne
text objects, or applied to text you are about to type. 

To format existing text

You can change the formatting of existing text by selecting a text
object or a portion of text within the object. 

◆ To apply character formatting to existing text: Select the 
characters you want to change. Using Text menu commands, the
Type palette, or the Text Ruler, choose the formatting you want to
apply. 

◆ To apply paragraph formatting to existing text: Select text in 
the paragraph you want to change, or place the insertion point an
where in the paragraph. Using Text menu commands, the Type p
ette, or the Text Ruler, choose the formatting you want to apply.

To establish formatting for new text objects

When you create a new text object, Canvas applies a preset form
text you type. You can define the preset format for new text objec
To establish or modify the preset, follow these steps:

1 Be sure you have not selected any text or text objects, and 
text objects are in edit mode. To deselect all objects, press Ente
(Mac) or Esc (Windows) twice.
.4 FORMATTING TEXT
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2 To change format settings, use Text menu commands, the T
palette, or the Text Ruler. If you use the Type palette, be sure to
click the Apply button after making changes.

Canvas uses the specified settings to format new text objects that
create.

To change formatting before typing new text

You can set the format for text you are about to type — without 
changing the preset format for new text objects. 

1 Place the text object in edit mode (see “To select text within
text object,” page 21.2). The pointer should appear as an I-beam
and an insertion point (a flashing vertical line) should appear in 
text. 

2 Place the insertion point by clicking the I-beam where you 
want the new formatting to begin.

3 Use the Text menu commands, the Type palette, or the Tex
Ruler to choose formatting options. If you use the Type palette, 
sure to click the Apply button after making changes.

4 Begin typing. The text will appear with the formatting you 
chose. If you begin typing in the middle of a paragraph, only the
new text will have the new settings.

Using the Text Ruler
You can use the Text Ruler to set fonts, sizes, styles, and other fo
matting. To set tabs, you must display the Text Ruler. 

◆ To display the Text Ruler: Choose Layout > Display > Show 
Text Ruler. The Text Ruler and document rulers appear. To hide 
Text Ruler, choose Layout > Display > Hide Text Ruler. This 
removes the Text Ruler, but leaves the document rulers. To hide 
document rulers and the Text Ruler, choose Layout > Display > H
Rulers.

Selecting text for formatting

You can use the Text Ruler to apply formatting to text objects, 
selected text characters, and text you are about to type. 

Text objects When you select text objects, any formatting you se
with the Text Ruler will apply to the entire text objects.
Using the Text Ruler 21.5
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Text selections When you make a selection by highlighting text, 
you can apply the following formatting to the selection: font, type 
size, type styles, fill ink, text frame ink, text background ink, text 
frame stroke, and character style. 

If you apply justification, leading, kerning, or paragraph styles, the
formatting applies to all paragraphs that contain selected text.

Before typing When you place the insertion point in a text object
you can use the Text Ruler to set formatting for the next text you 
type. For example, to apply bold style, click the Bold style button 
the Text Ruler before typing.

When the insertion point is in a paragraph (and no text is selected
you can set the following formatting: font, type size, text style, fill 
ink, text frame ink, text background ink, and character style. 

If you apply justification, leading, or paragraph styles, the formatti
applies to the paragraph that contains the insertion point.

To use the Text Ruler

1 Select the text you want to format.

2 Depending on the formatting you want to apply, do one of the
following:

• To adjust fonts, type styles, leading, and kerning, click the
“T” on the Text Ruler to put it in Type mode. 

• To apply paragraph and character formatting, click the “S” o
the Text Ruler to put it in Styles mode.

• To apply text attributes, set tabs, and specify leader chara
ters, the Text Ruler can be in either mode.

3 Select formatting options (see “The Text Ruler” next).

Type mode

Styles mode
.6 FORMATTING TEXT



The Text Ruler

The Text Ruler has two modes, 
Type and Styles. One mode is 
active at a time.

A Justification. Click a but-
ton to set the alignment of se-
lected text objects, the current 
paragraph, or all highlighted 
paragraphs. Select left, center, 
right, or full justification.

B Tabs. To select a type of 
tab to insert, choose the sym-
bol for left, center, right, deci-
mal, or comma tab in the pop-
up menu. Click in the ruler bar 
to set a tab.

C Tab menu. To edit a tab’s 
properties, select the tab in the 
pop-up menu when the inser-
tion point is in the paragraph 
that contains the tab.

D Text attributes. Use the 
pop-up palettes to apply (from 
left to right) a text character 
ink, text background ink, text 

frame ink, and text pen size to 
selected text or text objects. 

Type mode 

Click the “T” on the Text Ruler 
to use Type mode. The follow-
ing can be set in Type mode: 
font, size, styles, leading and 
kerning.

E Font. Type a font name in 
the box and press Enter or 
choose one from the pop-up 
menu. The font applies to se-
lected text objects, highlighted 
text, or the next text you type.

F Type size. Enter a type 
size in the box and press Enter 
or select one from the pop-up 
menu. The type size applies to 
selected text objects, high-
lighted text, or the next text 
you type.

G Type styles. Select but-
tons to apply standard type 
styles. To raise the baseline of 
selected characters, click the 
style button on the far right. 
This also reduces the type size 
by a fixed percentage.

H Leading. By default, 
“auto” appears in the Leading 
text box and leading is 120% 
of the type size. To change it, 
enter the leading in points and 
press Enter. Leading applies to 
selected text objects, the cur-
rent paragraph, or all highlight-
ed paragraphs.

I Kerning. Enter the amount 
of kerning in points and press 
Enter. To tighten kerning, type 
a negative number. To loosen 
kerning, type a positive num-
ber. 

Styles mode

Click the “S” on the Text Ruler 
to use Styles mode. You can 
select saved Character and 
Paragraph styles.

J Paragraph style. Type a 
paragraph style name in the 
box or select one from the 
menu.

K Character style. Type a 
character style name in the box 
or select one from the menu. 

Type mode

Styles mode

B DCA E F G H I

J K
Using the Text Ruler 21.7
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Positioning tabs
You can set tabs and indents by using the Ruler Bar in the Text Ru
The Ruler Bar appears below the formatting area of the Text Rule
when a text object is selected or in edit mode. The Ruler Bar is 
aligned with the selected text object.

A new text object has tab stops at half-inch intervals beginning at
left border of the text object. You can move the insertion point to 
each of these tab positions by pressing the Tab key. In addition, y
can edit a default tab by double-clicking it on the Ruler Bar.

Note: The Ruler Bar shows tab positions for one selected object. Y
cannot use the Text Ruler to set tabs for multiple selected text ob

To set tabs

1 Depending on how you want the tab settings to apply, do one
the following:

• To set a tab for one paragraph only, place the insertion po
anywhere in the paragraph.

• To set tabs before typing a new paragraph, place the inser
point at the beginning of the paragraph.

2 If necessary, display the Text Ruler by choosing Layout > Dis
play > Show Text Ruler. The Text Ruler and document rulers app

Ruler Bar

When you select a single text 
object, the Ruler Bar appears.

You can set the right and left 
indents of a selected text 
object by dragging the Right 
and Left Indent markers in the 
Ruler Bar. 

To indent the first line of a 
paragraph, drag the First 
Indent marker to the desired 
position in the Ruler Bar.

To set the distance between 
the left border of a text object 
and the left margin of a para-
graph, drag the Left Indent 
marker.

To set the distance between 
the right border of a text 
object and the right edge of a 
paragraph, drag the Right 
Indent marker.

Default tabs Right indent

Ruler Bar

First Indent

Left Indent
.8 FORMATTING TEXT
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3 On the Text Ruler, click the tab button to select a tab. You ca
select the following:

Left The left edge of the text is flush with the tab position. 

Center Text is centered around the tab position.

Right The right edge of text is flush with the tab position.

Decimal The first decimal (or period) in a string of text aligns 
directly under the tab position. For example, if you align 
“123.45.678” to a decimal tab, the decimal between the “3” and “4
will fall under the tab position.

Comma The first comma in a string of text aligns directly under th
tab position.

4 To set the position of the tab, click in the Ruler Bar at the tab
location. A new tab applies to selected text objects, the current pa
graph, or all highlighted paragraphs.

Setting a tab removes the default tab stops to the left. To move a
drag the tab marker to a new position.

Editing a tab
You can edit a tab two ways: Place the insertion point in the para
graph with the tab you want to edit, and then choose the tab in th
menu on the Text Ruler. Or, in the Ruler Bar, double-click the tab
you want to edit. The Tabs dialog box appears.

Configure the options in the Tabs dialog box. You can select a ne
tab type, or modify the numeric position and leader character of t
tab you’re editing. To apply the tab settings, click OK when you fi
ish.

Tab Position. Specify the distance between the tab and the left bor
of the text object.

Type of Tab. You can change the alignment setting of a tab by 
choosing one of these options.

Leader Character. You can use a character to fill tabbed space. To
adjust the spacing of the leader character, you can use kerning 
options. To specify a leader character, type a character in the tex
box.

Tab button

Left

Center

Right

Decimal

Comma

Select a tab in the menu on 
the Text Ruler. The Tabs 
dialog box appears so you 
can edit the tab you 
selected.
Positioning tabs 21.9
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Text inks and strokes
In Canvas, there are six attributes you can apply to text: fill inks, p
inks, strokes, frame inks, background inks, and frame strokes.

To apply these attributes, you can use the Fill inks icon, the Pen 
icon and the Strokes icon in the toolbox. Or, you can use the Tex
Ruler, which includes palettes that let you apply fill inks, frame ink
background inks and frame strokes. These palettes appear in bot
modes of the Text Ruler. 

Note: If your monitor resolution is 640x480, you can see the palet
on the Text Ruler only in Styles mode. 

Applying inks and strokes
You can apply the following attributes to one or more text objects
and to text selections.

Fill ink An ink applied to the inside, as opposed to the outline, of t
characters in a text object or a text selection. To apply a fill ink, yo
can use the Fill ink palette on the Text Ruler, or the Fill ink icon in
the toolbox.

Pen ink An ink applied to the stroke of text characters. To apply 
pen ink, you use the Pen ink icon in the toolbox.

Stroke The outline of text characters. To apply a stroke, you use 
Strokes icon in the toolbox.

Using the Type palette

When you adjust settings in 
the Type palette, the new set-
tings don’t take effect until you 
click Apply. Be sure that you 
don’t click outside the palette 
before applying the settings, 
or they will be lost.

To open the Type palette, 
choose Type in the Text menu. 
The Type palette contains six 
tabs: Character, Hyphens, 

Indents, Paragraph, Spacing, 
and Styles. 

A Click a tab to bring it to the 
front. The paragraph symbol 
(¶) on some tabs indicates that 
these are paragraph-level op-
tions.

B Configure the settings you 
want and click Apply to imple-
ment them.

A

B

A B C D

Inks and Strokes palettes 
on the Text Ruler

A Fill ink
B Frame Ink
C Background ink
D Frame stroke
.10 FORMATTING TEXT
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Text frame ink An ink applied to the stroke on the bounding box o
a text object, or a box around a text selection. To apply a frame in
you can use the Frame ink palette on the Text Ruler, or the Pen i
icon in the toolbox.

Text background ink An ink applied to the background of a text 
object or a text selection. To apply a background ink, you can use
Background ink palette on the Text Ruler, or the Fill ink icon in th
toolbox. 

Text frame stroke A stroke applied to the bounding box of a text 
object, or a box around a text selection. The text frame ink appear
the text frame stroke. To apply a frame stroke, you can use the Fr
stroke palette on the Text Ruler, or the Strokes icon in the toolbo

Current attributes

By using the icons in the toolbox, you can set the pen ink, fill ink a
stroke current attributes for text. You can’t, however, set frame in
background inks, and frame strokes to be “current” attributes; in 
other words, you can’t set a frame ink, background ink, or frame 
stroke that will be applied when you create new text objects. 

In addition, when you convert text to paths, Canvas keeps the pe
ink, fill ink and stroke, but any background inks, frame inks, or fram
strokes are removed.

To apply a fill ink

1 Select a text object, text characters, or place the insertion po
in existing text.

2 Select an ink from the Fill ink palette on the Text Ruler. Or, 
select an ink from the Fill ink icon in the toolbox. Canvas applies
the selected ink.

To apply a pen ink

1 Select a text object, text characters, or place the insertion po
in existing text. 

2 Select a pen ink from the Pen ink icon in the toolbox. Canva
applies the selected ink.

Fill ink
Text inks and strokes 21.11
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To apply a stroke

1 Select a text object or text characters.

2 Select a stroke from the Strokes icon in the toolbox. Canvas
applies the selected stroke.

To apply a frame ink

1 Select a text object or text characters.

2 Select an ink from the Frame ink palette on the Text Ruler. O
press Ctrl (Windows), or Option (Mac), and then select an ink fro
the Pen Ink icon in the toolbox. Canvas applies the selected ink

If a text selection spans more than one line of text, the ink appear
boxes around the selected characters on each line of text.

To apply a background ink

1 Select a text object or text characters.

2 Select an ink from the Background ink palette on the Text 
Ruler. Or, press Ctrl (Windows), or Option (Mac), and then sele
an ink from the Fill Ink icon in the toolbox. Canvas applies the 
selected ink. 

If a text selection spans more than one line of text, the backgroun
ink appears separately on each line of text.

To apply a frame stroke

1 Select a text object or text characters.

2 Select a stroke from the Frame stroke palette on the Text Ru
Or, press Ctrl (Windows), or Option (Mac), and select a stroke fro
the Strokes icon in the toolbox. Canvas applies the selected stro

If a text selection spans more than one line of text, the stroke outli
the selection separately on each line of text.

Applying character formatting
Canvas gives you precise control over the appearance of each ch
ter. You can set the font, type size, font style, kerning, capitalizati
style, scale, and baseline position using menu commands or the C
acter tab in the Type palette.

Character attributes are applied by selecting the specific characte
that you want to modify. You can select any portion of text — from

Frame ink and stroke

Background ink
.12 FORMATTING TEXT
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one character to entire text objects. For selection techniques, see
“Selecting text and objects” on page 21.1.

Specifying fonts
You can use any of the methods described next to specify fonts w
you type or format text.

To choose a font from the menu

1 Depending on how you want the font to apply, do one of the
following:

• To change existing text, select the text or text objects.

• To set the font before typing, place the insertion point whe
you want the font to change.

• To apply the font to the preset format, deselect all object

2 Choose Text > Font to open the Font submenu. A check 
appears next to the current font.

3 Choose a font in the submenu. The font setting changes.

Setting attributes in the Character tab

The Character tab lets you 
control all character attributes. 
Some attributes, such as type 
face, type size, font style, base-
line, and kerning, are also 
available in the Text menu.

Name. Choose a typeface in 
the pop-up menu.

Size. Choose a type size in the 
pop-up menu, or type a num-
ber in the text box.

Style. Click a button to select a 
font style.

Case. Choose a capitalization 
style in the pop-up menu.

Baseline. Specify subscript or 

superscript settings to one 
hundredth of a point preci-
sion.

Kerning. Tighten and loosen 
kerning by hundredths of a 
point.

Scaling. Specify percentages 
by which you want to scale 
the current type size. You can 
set individual horizontal and 
vertical scaling percentages.

A Locks. To prevent acci-
dental or unwanted changes to 
the type face, type size, or font 
style of specific text, you can 
set these locks. If you want to 
change locked text, you must 
first unlock the text.

A 
Specifying fonts 21.13
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To choose a font using the Type palette

1 Depending on how you want to apply the font, do either:

• To format existing text, select the text or text objects.

• To set the font before typing, place the insertion point whe
you want the font to change.

• To apply the font to the preset format, deselect all object

2 If necessary, open the Type palette by choosing Text > Typ
and click the Character tab to bring it to the front. Choose a font
the Name pop-up menu and click Apply.

Tips for font installation and use

On Mac OS systems, Canvas uses fonts installed 
in the Fonts folder of the System Folder. Fonts 
should be installed by dragging the font files to 
the closed System Folder icon. The system puts 
the fonts in the correct folder.

On Windows systems, Canvas uses fonts 
installed in the Fonts folder of the Windows 
folder. You can access the Fonts folder from the 
Fonts control panel. Use the Install New Font 
command in the File menu to add fonts to your 
system. You can also drag and drop font files or 
font file shortcuts to the Fonts folder. To specify 
that you want to see only TrueType fonts in your 
programs, you can use the Options command in 
the Views menu.

Canvas can use fonts that are properly installed 
as described above. If fonts that you use in 
another application are not available in Canvas, 
that application probably stores its fonts in a dif-
ferent location and has its own font manage-
ment capabilities.

Guidelines for choosing fonts

There are three types of fonts widely available: 
bit-mapped (or screen), PostScript, and True-
Type. You cannot distinguish the three types in 

the Canvas menus. However, you should be 
aware of the different types of fonts you have, 
because each font is best suited for particular 
purposes. 

Bit-mapped fonts are used by your computer to 
display text onscreen. A bit-mapped font is opti-
mized for a particular point size, and appears 
jagged at other sizes. These fonts are not scal-
able for printing.

PostScript Type 1 fonts are the standard for 
imagesetting. PostScript produces high-quality 
printed text. For onscreen display, however, 
PostScript needs screen fonts. If the screen font 
for a particular point size is not installed, the text 
appears jagged onscreen. To compensate for 
this, you can use Adobe Type Manager (ATM) 
software. If a screen font is unavailable, ATM 
uses the PostScript printer font for both screen 
display and printing. In addition, ATM lets you 
print PostScript fonts to non-PostScript printers.

TrueType fonts are suitable for most desktop 
publishing purposes when you are printing in-
house. TrueType fonts produce good quality 
printed text, and their onscreen appearance 
closely resembles the printed output, even 
when the screen font is unavailable.
.14 FORMATTING TEXT
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Using the Fonts palette
You can use a floating palette to view and select fonts. Choose Te
Font > View Fonts to open a palette that displays the available fo

When you point to a font name in the palette’s scrolling list, a sam
of the font appears at the top of the palette. 

To select a font, click the font name in the scrolling list. The resul
depends on whether text is selected or in edit mode.

• If no text object is selected or in edit mode, the selected fo
becomes the current font. 

• If text objects or a section of text is selected, the font is 
applied to the text objects or selection.

• If a text object is in edit mode and no text is selected, the
font is applied to the next text you type.

Specifying type size
You set the type size in either the Size submenu of the Text men
the Character tab of the Type palette. You can choose from stand
type sizes using either method. Using the Size submenu, you can
reduce or increase the size in 1-point increments. Using the Chara
tab, you can enter any type size with precision to one-hundredth 
point.

To set type size using menu commands

1 Depending on how you want the type size to apply, do one 
the following:

• To change existing text, select the text or text objects.

• To set the type size before typing, place the insertion poi
where you want the size to change.

• To set the type size of the preset format, deselect all obje

2 Choose Text > Size to open the Size submenu. A checkma
appears next to the current type size.

3 Choose one of the sizes in the submenu, or choose the Red
or Increase commands to change the type size in 1-point incre-
ments. The size setting applies immediately. 

To set the type size using the Type palette

1 Depending on how you want the type size to apply, do one 
the following:

Size submenu

6
8
9
10

✓ 12
14
18
24
36
48
72

Reduce Ctrl+Shift <
Increase Ctrl+Shift >
Specifying type size 21.15
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• To change existing text, select the text or text objects.

• To set the type size before typing, place the insertion poi
where you want the size to change.

• To set the type size of the preset format, deselect all obje

2 If necessary, open the Type palette by choosing Text > Typ
and click the Character tab to bring it to the front.

3 Choose one of the sizes in the Size pop-up menu, or enter 
number in the box to specify a type size.

4 Click Apply to implement the type size setting.

Applying font styles
Font styles are different character types, such as bold, italic, or su
script, as well as capitalization modes. You can apply font styles 
the Style submenu in the Text menu or the Character tab in the T
palette.

Font styles can be categorized into three groups: appearance, ca
ization, and baseline position. To the same text, you can apply m
ple appearance styles, but only one each of capitalization and 
baseline styles.

Types of font styles

Appearance styles

Appearance styles include plain, bold, italic, underline, outline, 
shadow, small caps, and strikethrough. With the exception of the
Plain option, you can use as many of these appearances as you li
the same text. Applying the Plain setting removes other font style
that have been applied to revert text to its standard appearance. 
Depending on the typeface, using certain styles might not have th

Underline
Outl ine
SShhaaddooww
StrikeThrough

Plain
Bold
Italic

UPPERCASE
lowercase

Title
SMALL  CAPS

CanvasTM

H20

Appearance styles Capitalization styles Baseline shift: 
“TM” superscripted
“2” subscripted
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desired effect, and can even make text appear ugly when printed.
example, applying bold to a heavy weight typeface can make cha
ters look too thick. Similarly, applying italic to an already italicized
font might exaggerate the slant of the characters.

Capitalization styles

Capitalization styles format text as uppercase, lowercase, or title 
(first letter of each word capitalized) styles. You can apply one of 
these capitalization styles to the same text: Normal, Upper, Lowe
and Title.

Baseline position

The baseline of text is the imaginary horizontal line on which char
ters sit. To position characters above (superscript) or below (sub-
script) the normal baseline, you can shift the baseline position.

Canvas does not change the type size of superscript and subscri
text. Unless you reduce the type size of shifted text, the line size 
increases by the amount of the baseline shift. As a result, the line
spacing might change, depending on the leading setting. If you do
want the line spacing to change, you can reduce the type size of 
shifted text by the same amount (or more) of the baseline shift, or 
can specify leading in points (see “Setting line and paragraph spa
ing,” page 21.23).

If you use the Style submenu to change baseline position, you ca
choose either Superscript or Subscript to shift text the baseline b
roughly 27 to 33 percent of point size of the line. For example, su
script text in a line of 12-point text appears 4.0 points above the n
mal baseline. 

If you use the Character tab of the Type palette to change the bas
position, you can specify the exact distance (in points) of the text 
above or below the normal baseline.

To apply font styles using menu commands

1 Depending on how you want the font style to apply, do one 
the following:

• To change existing text, select the text or text objects.

• To set the font style before typing, place the insertion poi
where you want the style to change.

• To apply the font style to the preset format, deselect all 
objects.
Applying font styles 21.17
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2 Choose Text > Style to open the Style submenu. Canvas pla
checkmarks next to the active styles in the submenu.

3 Choose the font style you want to apply. Choosing an active
style turns off the style. Canvas implements the setting immedi-
ately.

To apply font styles using the Type palette

1 Depending on how you want the font style to apply, do one 
the following:

• To change existing text, select the text or text objects.

• To set the font style before typing, place the insertion poi
where you want the style to change.

• To apply the font style to the preset format, deselect all 
objects.

2 If necessary, open the Type palette by choosing Text > Typ
and click the Character tab to bring it to the front.

3 To change appearance styles, click the Style buttons. Clicki
the Plain button turns off all active appearance styles. Clicking a
active appearance style button turns the style off.

4 To change the capitalization style, choose Upper, Lower, N
mal, Title or Small Caps in the Case pop-up menu.

5 To change the baseline elevation, choose Normal, Supersc
or Subscript in the Baseline pop-up menu. If you are applying 
superscript or subscript, specify the distance from the baseline 
points) in the text box. Normal baseline always has an elevation
zero points.

6 Click Apply to implement the font style settings.

Specifying spacing between characters
You can adjust the amount of space between text characters with
Kerning options. Kerning affects the amount of space to the right 
one or more characters. You can tighten kerning to place charact
closer together, and loosen kerning to space characters farther a
You can apply kerning settings before typing, or change the kern
for one character, a selection of text, or an entire text object.
.18 FORMATTING TEXT
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Canvas can also adjust letter and word spacing for paragraphs fo
lowing minimum, maximum, and desired guidelines that you set. S
“Adjusting letter and word spacing” on page 21.32.

Note: Canvas does not apply kerning to text characters based on
kerning pairs defined in a particular font. You can kern individual 
characters by placing the insertion point and using the Type palett
the Kerning submenu to tighten or loosen kerning.

The Kerning submenu lets you choose a standard kerning amoun
Very Tight, Tight, Normal, Loose, or Very Loose. You can interac
tively kern characters in half-point increments using the Tighten a
Loosen commands. You can also set a fine kerning amount using
Configure Fine Kern command, then use the Tighten Fine and 
Loosen Fine commands to kern characters by the specified amou

On the Character tab of the Type palette, you can use the Kernin
option to tighten or loosen kerning by an amount you specify.

To change character spacing using menu commands

1 Based on what you want to change, do one of the following

• To change existing text, select the text or text objects.

• To set the kerning before typing, place the insertion poin
where you want the kerning to change.

• To change the preset format, deselect all objects.

2 Choose Text > Kerning to open the Kerning submenu and 
choose one of the following options:

Option Result

Tight 8% less space than normal between 
characters

Very Tight 14% less space than normal between 
characters

Default kerning

Kerned manually

Headlines often need manual 
kerning for visual balance

Kerning submenu options

Very Tight
Tight

Normal
Loose

Very  Loose
Specifying spacing between characters 21.19
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◆ To set the fine kerning amount: Choose Text > Kerning > 
Configure Fine Kern. In the Kerning Specifications dialog box, sp
ify the amount of kerning (in points) for the Tighten Fine and Loos
Fine commands to apply.

To kern characters using the Type palette

1 Depending on how you want kerning to apply, do one of the
following:

• To change existing text, select the text or text objects.

• To set the kerning before typing, place the insertion poin
where you want the kerning to change.

• To apply the kerning setting to the preset format, deselec
all objects.

2 If necessary, open the Type palette by choosing Text > Typ
and click the Character tab to bring it to the front.

3 To set the kerning, choose Normal, Tighten, or Loosen in th
Kerning pop-up menu and specify the kerning amount (in points)
the text box. Normal always has a setting of zero.

4 Click Apply to implement the kerning setting.

Normal Default spacing 

Loose 8% more space than normal 
between characters

Very Loose 14% more space than normal 
between characters

Tighten Reduce kerning by 0.5 points. You 
cannot tighten kerning to less than 
the width of one character

Loosen Increase kerning by 0.5 points

Tighten Fine Reduce kerning by amount specified 
in the Kerning Specifications dialog 
box

Loosen Fine Increase kerning by amount speci-
fied in the Kerning Specifications 
dialog box

Option Result
.20 FORMATTING TEXT
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Preventing changes to character attributes
Using the Character tab in the Type palette, you can lock the curr
font, type size, and font style to prevent accidental changes. This
ture is especially useful when several people are using the same 
vas document. In addition, you can also use this feature to selecti
exempt sections of text from global formatting changes. Once you
lock a setting, no one can change it without first unlocking it.

To lock character attributes

1 Depending on how you want locks to apply, do one of the fo
lowing:

• To change the lock setting of existing text, select the text
text objects.

• To change the lock setting before typing, place the inserti
point where you want the locking to change.

• To apply a lock setting to the preset format, deselect all 
objects.

2 If necessary, open the Type palette by choosing Text > Typ
and click the Character tab to bring it to the front.

3 To lock an attribute, click the Lock button to the right of it. 
You can also change font attributes in this step. When you click
Apply, Canvas first applies the new font attributes, then locks the 
new attributes.

Horizontal and vertical text scaling
Canvas provides independent control of horizontal and vertical sc
ing of text. Using this feature, you can stretch characters to create
extended and condensed letterforms. 

Lock button

Horizontally scaled 200%

Horizontally scaled 50%

Vertically scaled 200%

Vertically scaled 50%
Preventing changes to character attributes 21.21
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To scale an entire text object, you can also select the text object, p
Command (Mac) or Alt (Windows), and drag a selection handle. 
Depending on the direction of the drag, Canvas scales text horizo
tally or vertically.

To scale characters using the Type palette

1 Depending on how you want scaling to apply, do one of the
following:

• To change existing text, select the text or text objects.

• To set the scale of text before you type it, place the insert
point where you want the scale to change.

• To apply scaling to the preset format, deselect all objects

2 If necessary, open the Type palette by choosing Text > Typ
and click the Character tab to bring it to the front.

3 To specify the vertical and horizontal scale of characters, en
percentages in the Scale boxes. If you enter the same percenta
both boxes, Canvas scales the text proportionately. Canvas will
apply these percentages to the point size displayed in the Size 

Canvas does not limit the percentage you can scale characters, h
ever, extremely high and low settings can distort some fonts and 
make them unreadable. In addition, scaling requires significant 
amounts of memory for text display, which might cause performan
problems for some systems.

4 Click Apply to implement the scaling settings.

Applying paragraph formatting
In Canvas, you can control paragraph attributes, such as justifica
and leading. Paragraph attributes affect entire paragraphs, even if
select a single character, or place the insertion point anywhere in
paragraph. If you select text in multiple paragraphs, all the para-
graphs will be affected.

Paragraph-level formatting includes the following:

• leading and paragraph spacing

• indents

• tabs

• alignment (justification)

• automatic letter and word spacing
.22 FORMATTING TEXT
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• hyphenation

• widow and orphan controls

Setting line and paragraph spacing
Using the Text menu, Text Ruler, or Type palette, you can adjust
spacing, or leading, between lines of text. You can also insert ext
space before and after paragraphs using the Type palette.

Canvas provides two methods of specifying leading: ratio (or per-
centage) and point size. 

• Ratio and percentage leading are based on the normal le
ing of the largest type size in the preceding line. The norm
leading is usually designed to be slightly larger than the 
point size of the type. For example, a single line of 12-poi
text usually occupies about 15 points of vertical space wh
you specify 100 percent or Single Space leading. Therefo
double spaced, or 200 percent, leading for 12-point text 
increases the line spacing to about 30 points.

• Leading specified in points is independent of the type siz
and normal leading of the typeface. The space from base
to baseline is exactly the number of points specified, rega
less of the size of the type. Using point size leading lets y
maintain consistent line spacing, and fit text to specific 
space requirements. For example, you have 10 lines of te
and exactly 120 points of vertical space to place the text. 
make the text fit, set the leading to 12 points.

The Leading submenu of the Text menu lets you set Single, 11/2, or 
Double Space leading. You can also choose the Tighten or Loos
commands to fine-tune the current leading in 0.5-point increment
You can tighten and loosen the leading repeatedly, but the line sp
ing cannot be less than zero. The Text Ruler provides the same 
options as the Leading submenu.

The Paragraph tab of the Type palette lets you adjust the leading 
percentage or point size that you specify. 

You can also add space between paragraphs by specifying additi
spacing in points on the Paragraph tab of the Type palette.
Setting line and paragraph spacing 21.23
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To set leading using menu commands

1 Depending on how you want the leading to apply, do one of t
following:

• To change existing text, select the paragraphs or text 
objects. To set leading for only one paragraph, place the
insertion point anywhere in the paragraph.

• To set the leading before typing a new paragraph, place 
insertion point at the beginning of the paragraph.

• To apply the leading setting to the preset format, deselect
objects.

2 Choose Text > Leading to open the Leading submenu. Can
places a checkmark next to the current leading setting.

3 Choose a standard leading in the submenu, or choose Tigh
or Loosen. Canvas applies the setting immediately.

To set leading using the Type palette

1 Depending on how you want the leading to apply, do one of t
following:

• To change existing text, select the paragraphs or entire t
objects. To set leading for only one paragraph, place the
insertion point anywhere in the paragraph.

A page of text with “after 
paragraph” spacing

A page of text that does not have 
paragraph spacing, but uses both 
“before” and “after paragraph” 
spacing for block quotes
.24 FORMATTING TEXT
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• To set the leading before typing a new paragraph, place 
insertion point at the beginning of the paragraph.

• To apply the leading settings to the preset format, desele
all objects.

2 Configure the leading settings as described next.

Setting indents
You can set the amount of space between the left and right borde
a text object and the edges of each paragraph using the Indents t
the Type palette or the Text Ruler. For text wrapped around an 
object, you can also use the Indents tab to set the distance betwe
the edge of the object and the text.

Setting leading in the Type palette

Open the Type palette by 
choosing Text > Type, if neces-
sary. Click the Paragraph tab to 
bring it to the front. After con-
figuring the settings, click 
Apply to implement them.

Percentage leading. To set 
the leading using a percentage 
of the line size, choose Per-
centage in the Line Spacing 
pop-up menu and enter an 
amount in the At box. A lead-
ing of 100% is the same as the 
Normal setting in the Leading 
submenu of the Text menu. 
Double space is 200%, and 
1.5 space is 150%. 

Point size leading. To specify 
leading in points, choose 

Points in the Line Spacing 
pop-up menu and enter an 
amount in the At box. 
Although each font’s standard 
leading might be different, 
normal leading is generally 
between 110% and 125% of 
the largest type size on the 
line. Therefore, for 10-point 
type, normal leading is approx-
imately 12 points.

Before paragraph. To insert 
space before the first line of a 
paragraph, specify the num-
ber of points in the Before 
Paragraph box. Before para-
graph spacing does not apply 
to the first paragraph in a col-
umn.

After paragraph. To insert 
space after the last line of a 
paragraph, specify the num-
ber of points in the After Para-
graph box. Canvas inserts 
space after every paragraph, 
including the last paragraph in 
a column.

Note: You can force a line 
break without creating a new 
paragraph by pressing Shift-
Return. See “To control line 
breaks” on page 19.6.
Setting indents 21.25
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Note: The Text Ruler shows indent positions for one selected obje
at a time. Therefore, you cannot use the Text Ruler to set indents
the preset format or for multiple selected objects.

To set indents using the Type palette

1 Depending on how you want the indent settings to apply, do
one of the following:

• To change existing text, select the paragraphs or text 
objects. To set indents for only one paragraph, place the
insertion point anywhere in the paragraph.

• To set the indents before typing a new paragraph, place 
insertion point at the beginning of the paragraph.

• To apply the indent settings to the preset format, deselect
objects.

2 Configure the indent settings as described below.

Left 1 in., Right 1 in.Left 1 in. First line 1.5 in., Left 1 in. First line 1 in., Left 1.5 in
.26 FORMATTING TEXT
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Paragraph alignment 
Canvas aligns text to the indents of a text object. Canvas has fou
alignment, or justification, settings: flush right, flush left, full (flush
with both right and left indents), or centered. You can set alignme
in either the Justification submenu of the Text menu, the Text Ru
or the Paragraph tab of the Type palette.

 

Settings on the Indents tab

If necessary, open the Type 
palette by choosing Text > 
Type. Click the Indents tab to 
bring it to the front.

Left. To specify the distance 
between the left border of a 
text object and the left indent 
of a paragraph, enter the dis-
tance in the Left box. 

Right. To specify the distance 
between the right border of a 
text object and the right indent 
of a paragraph, enter the dis-
tance in the Right box.

First Line. To specify a differ-
ent indent for the first line of a 
paragraph, enter the distance 
in the First Line box. Canvas 
measures the first line indent 
from the left border of the 
bounding box.

Object Wraps. To specify the 
distance between an object 
and the edge of text wrapped 
around or inside that object, 
enter the number of points in 
the Object Wraps box.

Click Apply to implement the 
indent settings.

Left-justified Right-justified Full-justified Center-justified
Paragraph alignment 21.27
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Note: Full justification may create wide letter or word spacing, esp
cially in narrow text columns. Other justification settings (without 
hyphenation) might appear too ragged on one or both sides. You
set letter- and word-spacing parameters to improve the appearan
text. For more information, see “Adjusting letter and word spacing
on page 21.32

To set justification using menu commands

1 Depending on how you want the justification settings to app
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set justification for only one paragraph, place
the insertion point anywhere in the paragraph.

• To set the justification before typing a new paragraph, pla
the insertion point at the beginning of the paragraph.

• To apply justification settings to the preset format, desele
all objects.

2 Choose Text > Justification to open the Justification submen
Canvas places a checkmark next to the current justification sett

3 Choose an alignment option in the submenu. Canvas applie
the justification setting immediately.

To set justification using the Text Ruler

1 Depending on how you want the justification settings to app
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set justification for only one paragraph, place
the insertion point anywhere in the paragraph.

• To set the justification before typing a new paragraph, pla
the insertion point at the beginning of the paragraph.

• To apply the justification settings to the preset format, de
lect all objects.

2 If necessary, open the Text Ruler by choosing Layout > Dis
play > Show Text Ruler.

3 Click a justification button. Canvas applies the justification 
setting immediately.

Justification buttons on 
the Text Ruler
.28 FORMATTING TEXT
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To set justification using the Type palette

1 Depending on how you want the justification settings to app
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set justification for only one paragraph, place
the insertion point anywhere in the paragraph.

• To set the justification before a new paragraph, place the
insertion point at the beginning of the paragraph.

• To apply justification settings to the preset format, desele
all objects.

2 If necessary, open the Type palette by choosing Text > Typ
and click the Paragraph tab to bring it to the front.

3 Click a Justification button.

4 Click apply to implement the justification setting.

Using vertical justification
Canvas can align text relative to the top and bottom borders of te
objects. Canvas has four vertical justification, or alignment, settin
Top, Bottom, Vertical Full, and Vertical Center. 

Vertical justification applies to an entire text object. To change the
setting, select one or more text objects. Choose Text > Justificati
and choose a vertical justification setting in the submenu. A chec
mark appears next to the selected setting. 

Note: There must be space in the text object to use vertical justific
tion, not including space created by empty paragraphs. The text 
objects must therefore be created with the Text Object tool, not th
Text tool.

Top vertical justification is the default setting for new text objects.
Copying or duplicating text objects preserves their vertical justific
tion settings. However, if you copy a text selection and paste it in
another object, the text follows the vertical justification of the text 
object in which you paste it.
Using vertical justification 21.29
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Vertical justification settings

You can choose vertical justification settings in the Justification su
menu.

Top Sets all lines of type starting from the top of a text object. Th
is the traditional vertical alignment for text objects. For example, i
text object contains three lines of type, they appear at the top of t
text object. Spacing between lines is controlled by the Line Spaci
Before Paragraph, and After Paragraph settings of the text.

Vertical Center Sets all lines of type so they are spaced evenly 
above and below the vertical center of a text object. If a text objec
contains three lines of type, for example, the lines appear at the ce
of the text object. Spacing between lines is controlled by the Line
Spacing, Before Paragraph, and After Paragraph settings of the t

Bottom Sets all lines of type at the bottom of the text object. If a
text object contains three lines of type, for example, the lines app
at the bottom of the text object. Spacing between lines is controlle
by the Line Spacing, Before Paragraph, and After Paragraph sett
of the text.

Vertical Full Sets all lines of type so they are evenly spaced 
between the top and bottom borders of the text object. If a text ob
contains three lines of type, for example, one line appears at the 
one appears at the center, and one appears at the bottom of the 
object. Because it distributes type from the top to the bottom of a t
object, Vertical Full justification can cause very wide spacing 
between lines if a large text object contains a little text. You can d
a handle at the top or bottom of a text object to adjust its height a
alter the spacing between lines of text.

Top Vertical Center Bottom Vertical Full

Text object
.30 FORMATTING TEXT
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Paragraph rules
Paragraph rules are horizontal lines that Canvas draws above a p
graph, below a paragraph, or both. You can select pen type, dash
color, length, and offset for paragraph rules.

To apply paragraph rules

1 Place the insertion point or make a selection in the paragraph
You can highlight multiple paragraphs to select them.The Paragra
Rules command is not available unless a text object is in edit mo

2 Choose Text > Rules. In the Paragraph Rules dialog box, sel
Rule Above or Rule Below. You can select either or both options.
The options for Rule Above and Rule Below can be set indepen-
dently.

3 Select rule options, then click Apply to preview the rules. Clic
OK to apply the rules and close the dialog box.

Paragraph Rules options

When you configure a paragraph rule, a preview of the rule appe
in the box in the Rule Above or Rule Below section of the Paragra
Rules dialog box.

Rule Above and Rule Below Draws rules above or below selected
paragraphs. Both can be selected. The size, placement, and attri
of rules are based on the settings in the dialog box. If a paragraph
rules and you clear the checkboxes, Canvas removes the rules.

Rules can go above and below
paragraphs. Rules can be solid,
dashed, or neon strokes.

Rule above preview

Rule below preview
Paragraph rules 21.31
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Length Use the pop-up menu to choose an option for the length
paragraph rules. 

• Indents sets the rule length based on the values in the Fro
Left and From Right boxes. These values set the distance
from the ends of the rules to the right and left borders of th
text object (independent of paragraph indents).

• Text makes the rule length equal to the first line (for rules 
above) or last line (for rules below) of a paragraph. The Fro
Left and From Right options are not available when the Te
option is selected.

Offset Enter a value in points to space the rule away from the a
cent line of text. The position for rules above is measured from th
descenders of the last line of the previous paragraph. For rules be
the position is measured from the descenders of the last line of th
current paragraph. You can enter a minimum value of -10 points 
move the rule closer to the text. You can enter a maximum value
72 points to move the rule away from the text. 

Pen Select a stroke for the rule from the Pen pop-up palette. Yo
can select a solid pen, neon, or parallel stroke.

Dash To apply a dash to the rule, select a dash style from the D
pop-up palette.

Color Select a color for the rule from the Color pop-up palette.

Adjusting letter and word spacing
Depending on the type of justification you choose, you might want
adjust letter and word spacing to reduce raggedness or eliminate
unusual spacing. For example, left-justified paragraphs might app
too ragged on the right edge, and full-justified paragraphs might h
large spaces between characters and words. 

You can specify a minimum line width for a paragraph to reduce r
gedness. In addition, Canvas has letter- and word-spacing param
to let you specify minimum, maximum, and desired spacing guide
lines.

To adjust letter- and word-spacing

1 Depending on how you want the letter- and word-spacing se
tings to apply, do one of the following:
.32 FORMATTING TEXT
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• To change existing text, select the paragraphs or text 
objects. To set spacing for only one paragraph, place the
insertion point anywhere in the paragraph.

• To set the spacing before typing a new paragraph, place
insertion point at the beginning of the paragraph.

• To apply the spacing settings to the preset format, desele
all objects.

2 If necessary, open the Type palette by choosing Text > Typ

3 To set line-width options, click the Paragraph tab to bring it 
the front, if necessary. 

4 Depending on the type of justification applied to the text, us
the following options on the Paragraph tab: 

• For right-, left-, and center-justified text: To set the “Mini-
mum Width of Lines,” enter a percentage in the text box.
The percentage tells Canvas to adjust letter and word sp
ing so that each line is at least as wide as you specify. Fo
example, if you create a two-inch wide, left-justified para-
graph and set the minimum line width to 75%, Canvas 
adjusts the spacing so that each line is at least 1.5 inche
wide. Only the last line in a paragraph is unaffected by th
“Minimum Width of Lines” setting.

• For full-justified text: To tell Canvas when the last line of 
paragraph is wide enough to be justified (flush with both 
right and left margins), enter a percentage in the “Justify 
Last Line Within” box. For example, you create a two-inc
wide, full-justified paragraph and tell Canvas to justify the
last line within 75%. If the last line is less than 1.5 inches
wide, Canvas does not justify the line. However, if the las
line is wider than 1.5 inches, Canvas justifies the line.

Spacing settings on the 
Paragraph tab
Adjusting letter and word spacing 21.33
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5 To set letter and word spacing parameters, click the Spacin
tab to bring it to the front, if necessary. Set the minimum, desire
and maximum spacing in the Letter and Word areas. Specify ea
setting as a percentage of the current spacing. The desired spa
must be greater than the minimum and less than the maximum. 
maximum spacing cannot be less than the minimum.

Canvas will try to adjust spacing to the desired percentage, but m
not be able to depending on minimum line width and justification s
tings. In these cases, Canvas will then try to adjust the spacing wi
the minimum and maximum percentages you specify. However, i
the minimum and maximum spacing parameters are still in conflic
with minimum line width or full justification settings, Canvas will 
ignore the spacing parameters.

To change the spacing of a paragraph by a set amount, you can s
minimum, desired, and maximum percentages to the same value
This has a similar effect to kerning the entire paragraph.

Note: If you applied kerning to characters within the selection, Ca
vas adjusts the spacing as a percentage of the kerning.

6 Click Apply to implement the settings. 

Automatic hyphenation
Canvas can insert a hyphen in the last word of a line to give text 
objects a more balanced, even appearance. You can also contro
hyphenation properties so that Canvas only hyphenates under sp
cific circumstances.

Note: Hyphenation settings apply to entire paragraphs. To hyphen
a specific word, you can manually insert a hyphen.

To set hyphenation for paragraphs

1 Depending on how you want the hyphenation settings to app
do one of the following:

• To change existing text, select the paragraphs or text 
objects. To set hyphenation for only one paragraph, plac
the insertion point anywhere in the paragraph.

• To allow Canvas to insert hyphens as you type a new pa
graph, place the insertion point at the beginning of the pa
graph.

• To apply hyphenation settings to the preset format, desel
all objects.
.34 FORMATTING TEXT
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2 Configure the hyphenation settings as described below.

Specifying text flow options
You can set text flow options to avoid leaving just a few lines at th
top or bottom of a column of flowed text. The term widow describes 
the first line of a paragraph that appears at the bottom of a colum
and orphan refers to the last line of a paragraph that appears at the
of a column. Canvas can prevent widows and orphans in a text fl
by moving the page or column break higher and sending lines to 
next page or column. In addition, you can specify that all lines in a
paragraph stay together, or that certain pairs of paragraphs alway
remain together in the same column.

To modify a column break in a particular paragraph, keep all lines
a paragraph together, or keep two paragraphs together, you shou
change the text flow settings for the specific paragraph only. In m
cases, you won’t want these settings to apply to every column bre

To prevent widows and orphans

1 Depending on how you want the text flow settings to apply, d
one of the following:

Hyphenation settings

If necessary, open the Type 
palette by choosing Text > 
Type. Click the Hyphens tab to 
bring it to the front. Turn 
hyphenation on and configure 
the following settings.

After word beginning. Speci-
fy the minimum number of let-
ters that must precede a 
hyphen.

Before word ending. Specify 
the minimum number of letters 
that must follow a hyphen.

Smallest word. Specify the 
minimum number of letters 

that a word must have to be 
hyphenated.

Consecutive line limit. Speci-
fy the number of consecutive 
lines that can end in hyphens. 
For example, if four consecu-
tive lines could end in hyphens 
but the limit is three, Canvas 
does not hyphenate the last 
word of the fourth line.

Skip capitalized words. Turn 
this option on to prevent prop-
er names and other words 
beginning with a capital letter 
from being hyphenated.

Click Apply to implement the 
hyphenation settings.
Specifying text flow options 21.35
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• To change existing text, select the text. To change one p
graph, place the insertion point anywhere in the paragrap

• To change the preset format, deselect all objects.

2 If necessary, open the Type palette and click the Spacing ta
Configure the widows and orphans settings (described next).

Note: Although you can specify widow and orphan settings for ind
vidual paragraphs, you should apply these settings to entire objec
This way, as you edit and move paragraphs, the location of the c
umn break can change without causing widows and orphans.

Setting drop caps
Drop caps are large characters that extend below the normal bas
of the first line of an opening paragraph. Canvas indents the text 
below the first line to make room for the drop caps. You can form
drop caps for any selected paragraphs.

Widow and orphan 
settings

Use the Paragraph area of the 
Spacing tab to configure wid-
ows and orphans protection 
properties. If an “X” appears in 
a checkbox, that feature is 
active.

Widow. Turn on to activate 
widow protection. You can 
specify the minimum number 
of lines that can appear in the 
last paragraph of a column.

Orphan. Turn on to activate 
orphan protection.

You can specify the minimum 
number of lines that can 
appear at the top of a column 
in a linked flow.

Keep all lines. To prevent 
Canvas from inserting a col-
umn break in a paragraph, turn 
on this option. This prevents 
widows and orphans, but 
might leave a lot of blank 
space at the bottom of a col-
umn.

Keep with next. To prevent 
two paragraphs from being 
separated by a column break, 
turn on this option. This option 
is useful for keeping a one-line 
paragraph, such as a heading, 
together with its section.

Click Apply to implement the 
text flow settings.
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To set up a drop cap

1 Depending on how you want the drop cap to apply, do one 
the following:

2 Configure the drop cap options described below.

To apply to Do this

First paragraph in a text 
object

Select the object or place the inser-
tion point anywhere in the first para-
graph

All other paragraphs Place the insertion point in a para-
graph, or select a paragraph. You can 
also select multiple consecutive para-
graphs

A new paragraph you are 
about to type

Place the insertion point at the begin-
ning of the paragraph

The preset format Deselect all objects. Canvas will apply 
drop caps to the first paragraph of all 
new text objects you create with the 
Text tool

Drop cap settings

If necessary, open the Type 
palette by choosing Text > 
Type. Click the Indents tab to 
bring it to the front.

Lines. Specify the number of 
lines you want the drop caps to 

occupy. This determines the 
vertical height of the drop cap.

Characters. Specify the num-
ber of characters to enlarge for 
drop caps. Canvas always 
applies this setting beginning 
with the first character in a 
paragraph.

Click Apply to implement the 
drop cap settings.
Setting drop caps 21.37
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USING TYPE STYLES

You can save type formatting settings as named character and p
graph type styles using the Styles tab in the Type palette. Canvas
stores type styles with documents. When you open a document, 
vas loads the associated styles so you can apply them.

Type styles make it easy to apply formats and maintain consisten
throughout a document. You can base styles on each other to for
“family” of styles, so that styles inherit the character and paragrap
attributes of a parent style. Organizing styles in this manner make
global style changes a simple matter of changing the parent style

When you change a style, text using the style also changes. In th
case of style families, when a parent style changes, Canvas upda
the entire style family and all text using styles in the family.

Creating new type styles
You can create two kinds of styles, character and paragraph, whi
incorporate different formatting attributes. After establishing chara
ter and paragraph styles, you can apply them independently to cr
new combinations.

Character style attributes Paragraph style attributes

Font Leading

Type size Indents

Font style Justification

Capitalization style Drop caps

Baseline position Hyphens

Kerning Letter and word spacing

Colors (optional) Text flow settings

Character attributes and colors 
(optional)
22.1
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Using style families
When you base a style on another, the style “inherits” the attribut
of the parent style. When the parent style changes, Canvas also 
updates all related styles. In addition to inherited attributes, the st
possesses its own attributes, which you specify. A style’s own 
attributes always take precedence over attributes inherited from t
parent style.

To create a type style

To save the attributes of exist-
ing text as a style, place the 
insertion point in the text and 
choose Text > Type to open 
the Type palette. You can also 
save current Type palette, Text 
menu, and Text Ruler settings 
as a style, without first applying 
them to text.

After you choose settings for a 
type style, click the Styles tab 
in the Type palette to bring it 
to the front.

Example. Displays a sample of 
text with the current formatting 
settings applied.

Description. Lists the current 
character or paragraph 
attributes. The C and ¶ buttons 
toggle between descriptions 
of character and paragraph 
attributes.

To save a type style, click Cre-
ate to open the Create Type 
Style dialog box. Configure the 
following settings.

Character or Paragraph. Click 
one of these buttons to specify 
what kind of style you want to 
create.

Based on. Choose a style 
name in this pop-up menu to 
base the style you are creating 
on an existing style. To disable 
this feature, choose None. See 
“Using style families,” 
page 22.2, for more informa-
tion.

Include. Select the attributes 
you want to save as part of the 
style. You can include ink set-
tings (fill and stroke attributes 
that have been applied to 
existing text) in character and 
paragraph styles. For para-
graph styles, you can also 

include font attributes and tab 
settings.

If a text selection has more 
than one fill ink, pen ink, or 
stroke, you can’t include these 
attributes in a style. In addi-
tion, when text doesn’t have a 
stroke, you can’t include 
strokes in a style.

Style name. Type a name for 
the style. Click Save to store 
the style and close the dialog 
box.
.2 USING TYPE STYLES
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For example, you create a style, Body2, based on a parent style,
Body1. The fonts are the same, but the type sizes are different. Bo
uses 10 point type, while Body1 uses 12 point. If you change the f
for the parent style, the font also changes for Body2. However, if 
point size changes for the parent style, Body2 does not change, 
because Body2’s own attributes take precedence. To make Body
always use the same point size as Body1, you must set the point 
equal, base Body2 on Body1, and save the style again. 

In addition, if you later change Body2’s font, this style will no longer 
inherit fonts from the parent style. Body2’s font will override 
Body1’s font setting.

Careful planning will save you from time-consuming corrections 
when basing styles on each other. In some cases, changing a pa
style’s attributes may cause unwanted changes throughout the st
family. For example, if you base ten styles on Body1, and later 
decide that you want Body1 (but not the whole family of styles) to 
double spaced, you must first change the leading for Body1, then
remove the leading setting from each of the other ten styles.

Saving and loading type styles
You can save type styles to files on disk and then load them into 
other documents. This feature helps maintain consistency betwee
documents, and lets you share type styles with other Canvas use

◆ To save a type style to disk: Press the triangle at the bottom-
left of the Styles tab and choose Save Style in the pop-up menu. 
the directory dialog box, type a file name and specify a location to
save the file, then click Save.

◆ To load a type style: Press the triangle at the bottom-left of th
Styles tab and choose Load Style in the pop-up menu. In the direc
dialog box, locate and select the style, then click Open.

Copying type styles between documents
You can copy named type styles from one Canvas document to 
another by copying text that uses the style and pasting it into a di
ent document. Canvas transfers the style with the text. When you
save the document, Canvas also stores the transferred style.

A type style based on another style cannot inherit attributes acros
documents. For example, Body2 is based on a parent style, Body
and you copy only Body2 to a new document. Body2 in the new d
Saving and loading type styles 22.3
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ument no longer inherits attributes from Body1, which is still in the
original document. 

However, if you copy both Body1 and Body2 to a new document, 
relationship is preserved, and Body2 will inherit attributes from its
parent style.

Note: When you do this, Canvas changes style names in the new 
ument. For example, a style named “Body 2” will become “Body 2
2.”

Applying type styles
Applying type styles is similar to applying individual character or 
paragraph formats using the Type palette. However, instead of co
figuring settings on each of the tabs in the palette, you can simply
choose style names in the pop-up menu at the bottom-right corne
the Type palette.

The pop-up menu displays the current type style name. The C and ¶ 
indicate if the style is a character or paragraph style, or both. If “++
appears to the right of a style name, the style has been modified 
not saved. If you choose a style in the pop-up menu when “+++” 
appears next to the current style, you will lose the modifications to
the style. Therefore, if you want to use the settings again, you sho
save the modified style with a new name before applying other sty

◆ To apply a style to selected text or text objects: Select the 
text or text object(s) to which you want to apply a style. Choose a
style in the pop-up menu at the bottom-right of the Type palette. 
Click Apply to implement the style. 

If the text you selected already had a style applied, Canvas repla
the style with the style you choose. In addition, if you apply a para
graph style with font attributes to highlighted text, the font attribut
affect the selection only, and the paragraph attributes affect the en
paragraph.

◆ To use a type style as the current format setting: If neces-
sary, deselect all text objects by pressing Enter (Mac) or Esc (Wi
dows). Choose a style in the pop-up menu on the bottom-right cor
of the Type palette and click Apply. Canvas formats new text obje
with the specified style.

Indicates character or 
paragraph style

Style name

Indicates modified style

✔Tip
To set current inks (other than 
black) for new text, save the 
inks as a type style attribute 
and use the type style as the 
current text format. These inks 
don’t affect the current inks for 
vector objects.
.4 USING TYPE STYLES
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Modifying type styles
You can change the attributes of a type style and save the style w
the same name. When you change a style’s attributes, all styles in
family automatically inherit the new attributes and Canvas update
any existing text that uses the family of styles.

To modify a type style

1 In the Type palette, choose the style you want to edit in the 
pop-up menu at the bottom of the palette.

2 Use the Type palette to change the style’s attributes. Canva
displays “+++” after the style name at the bottom of the palette t
indicate that changes were made to the style.

3 Click the Styles tab to bring it to the front, and click Create.

4 In the Create Type Styles dialog box, Canvas displays the c
rent style name in the Based On pop-up menu and Style Name 
To replace the style, do not change these settings.

5 If you want, you can include ink settings. For paragraph style
you can also include font attributes.

6 Click Save. Canvas asks you to confirm that you want to 
replace the existing style with the new style. Click OK.

Deleting type styles
To minimize confusion when choosing styles to apply, you can del
type styles you don’t use. Text using a deleted type style retains 
formatting, but no longer has a named style. In addition, any text 
using a style based on a deleted style also loses its named style.
the illustration below for other effects of deleting a type style that 
part of a style family.
Modifying type styles 22.5
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◆ To delete a style: Click Delete on the Styles tab in the Type 
palette. Choose the style you want to delete in the pop-up menu 
click OK. 

Deleting parent styles

The diagram shows the results 
of deleting type styles on 
which other styles are based. 
Arrows indicate how these 
type styles are based on each 
other.

A Body2 is based on Body1. 
Deleting Body1 makes Body2 
an independent style.

B Body3 is based on Body2, 
which in turn is based on Body1. 
Deleting Body2 makes Body3 
based on Body1.

Body1

Body2

Body1

Body2

Body1

Body2

Body3

Body1

Body3

A

B

Body2

Tips on using type styles

By putting some forethought into the purpose 
and design of type styles, you can ensure that 
you are using this feature effectively. This plan-
ning will be especially useful when editing styles 
and documents, allowing you to make a few 
modifications that update entire documents.

Design a template. If several people need to 
use the styles, you might want to save the styles 
in a template document. This way, everyone 
uses a common source for the styles.

Create a “normal” type style. This will make it 
easy to revert formatted text to a basic style. 
When you apply the normal style, it will have the 
effect of removing or overriding other styles.

Name styles by their function. For example, a 
heading style might consist of boldface type. 

Rather than name this style “Bold,” name it 
“Heading,” or something that similarly 
describes its usage. This will make it easier to 
remember when to use which style.

Always apply a style. If you choose to use 
styles in documents, be sure to use them 
throughout. If you apply styles only sometimes, 
you might encounter difficulties maintaining 
consistency and performing global style chang-
es.

Create style families when possible. You might 
want to use the Based On feature (see “Creat-
ing new type styles” on page 22.1) to create 
style families for styles that share some 
attributes. This will make global changes easier. 
See “Using style families” on page 22.2, for 
more information. 
.6 USING TYPE STYLES
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TYPE EFFECTS

This chapter explains how to apply various effects to type. In Canv
you can wrap text inside objects, repel text from objects, bind tex
the path of an object, and slant the margins of a text object. 

Wrapping and repelling text
You can make text flow around or inside objects by using the Wra
submenu commands.

Wrapping text inside an object
When you wrap text inside a paint or vector object, Canvas adjus
the text object’s margins so that text fits within the boundaries of 
object. A text object can be wrapped inside only one object at a ti

Canvas has two methods of wrapping text inside an object. You c
select an existing text object and a vector or paint object and cho
the Text > Wrap > Inside Shape. You can also select an existing p
or vector object and simply begin typing; the text will stay inside t
boundaries of the object. 

If you wrap text inside an open vector object, such as an arc, the 
wraps between the bounding box and the concave side of the arc

Center-justified text wrapped inside an oval
23.1
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you try to wrap text to a line or a narrow arc, the text will not be vi
ble. If this occurs, choose Text > Wrap > Remove Wrap or choos
Edit > Undo to make the text visible again.

◆ To wrap existing text inside an object: Select an object and a 
text object. Choose Text > Wrap > Inside Shape. Canvas places 
text inside the object.

If there is more text than can fit inside the shape, Canvas inserts a
umn break in the text object and displays an overset symbol. You
resize the object to fit the text, or flow the excess text to another c
umn; see “Flowing overset text into new text columns” on 
page 19.19.

◆ To type new text inside an object: Select a vector or paint 
object and begin typing. Canvas adjusts margins so that text you 
remains within the left and right borders of the object. 

If the object is too small to contain all the text you type, the text 
object extends below the object. You can resize the object to fit th
text. You can also resize the text object to fit the shape, and then 
any excess text to another column. 

Repelling text from objects
To make text flow around an object, you can apply a repel setting
the object. You also can set the amount of space between the ob
and text it repels. 

An object with a repel setting repels all text. You can move the obj
and it will repel text wherever you place it.

You can apply repel settings to objects before any text has been 
ated or placed in a document. You can also apply a repel setting 
text object to make it repel the text in other text objects. To make
text object repel text in other text objects, the repel text object mu
be at the front of the stacking order. Select a text object and choo
Object > Arrange > Bring to Front to put the object in front of all 
other objects on the same layer.

An object can repel text that is contained in text objects. A repel s
ting does not repel text that has been bound to a path with the Pa
Text tool or the Bind Text command.

Repelling text from paint objects

When you repel text from paint objects, the text wraps to dark are
of the image. Off-screen, Canvas converts the image to black and
.2 TYPE EFFECTS
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white; text wraps around areas that are black and overlaps areas
are white.

To make objects repel text

1 Select one or more objects that you want to repel text. 

2 Choose Text > Wrap > Repel. Canvas applies the repel settin
The initial repel amount is zero points.

To set repel space

Use this procedure to set the amount of space between an objec
text that it repels.

1 Select the object that has a repel setting and choose Text > W
> Repel Options.

2 Enter a value from -30 to 30 points in the four boxes. These v
ues specify the amount of space between the top, bottom, left, an
right sides of the object and text that the object repels.

3 Click Apply to view the effect of the current settings. Click OK
to apply the settings and close the dialog box.

To remove a repel setting

Select an object that you do not want to repel text. Choose Text >
Wrap > Remove Wrap. Canvas removes the repel setting from th
selected object.

One object repelling 
text

Two objects repelling 
text

Two objects repelling 
two columns of text

Examples of repelled 
text
Wrapping and repelling text 23.3
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Slanting text columns
The Text > Wrap > Slant Margin command lets you change a tex
column’s margins to form a parallelogram.

To slant right and left margins

1 Select a text object. 

2 Choose Text > Wrap > Slant Margin. The text object’s selec
tion handles change to four corner handles.

3 To slant margins away from the bottom line of text, drag eith
of the text object’s top two selection handles horizontally. 

4 To slant margins away from the top line of text, drag either o
the text object’s bottom two selection handles horizontally.

5 Press Enter (Mac) or Esc (Windows) when you are finished

Removing wrap effects
You can restore text margins to the standard rectangular shape b
choosing Text > Wrap > Remove Wrap. 

◆ To remove a wrap effect: Select a wrapped text object. Choos
Text > Wrap > Remove Wrap.

Setting the column angle

When you choose Text > Wrap 
> Slant Margin, you can drag 
selection handles to specify 
the angle of margins.

A The bottom right handle of 
the text column is dragged to 
specify the angle of the margins 
(shown by the dashed lines).

B Canvas adjusts the margins 
to slant the text column within 
the bounding rectangle. (The 
bounding rectangle is repre-
sented by the eight selection 
handles.)

A B
.4 TYPE EFFECTS
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Binding text to vector objects
You can bind the baseline of text to the path of most types of vec
objects. Canvas adjusts the vertical orientation of each character
match the path. You cannot bind text to objects drawn with the C
centric Circles, Spiral, or Grid tools.

Depending on how you want to bind text, you can use the Bind T
command in the Effects menu or the Path Text tool in the toolbox
The Bind Text command lets you bind existing text to an object, a
the Path Text tool lets you type new text directly on the path of a 
selected object.

Canvas lets you bind multiple text objects to one vector object, bu
text object can bind to only one vector object at a time. Also, you c
bind only one text object to a vector object using the Path Text to
To bind additional text objects to the same vector object after usin
the Path Text tool, you must create a separate text object with the
Text tool and use the Bind Text command.

To bind existing text using a menu command

1 Select a text object and a vector object.

Path Text tool

Position and direction of 
bound text

Whether you use the Bind 
Text command or Path Text 
tool, the location where you 
click the pointer determines 
the alignment position. 

A This text is center-justified. 
The I-beam pointer (which ap-
pears after choosing the Bind 
Text command or the Path Text 
tool) determines where text will 
bind. In the example, the point-
er is clicked in the upper-right 
quadrant of the oval. The inset 
shows the bound text, cen-
tered around the point where 
the pointer was clicked.

B For open-ended objects, 
such as arcs, bound text initially 
flows in the direction the object 
was drawn. In this example, the 

arrows indicate the direction the 
arcs were drawn. Text objects 
bound to these arcs follow the 
direction of the arcs.

A B
Binding text to vector objects 23.5
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2 Choose Effects > Bind Text. When the pointer is on the edge
the selected object, the pointer becomes an I-beam.

3 With the pointer, click to place the selected text on the path
Text aligns to the point where you click. For example, if the text
center-justified, Canvas binds the text so that it is centered arou
the point you click.

4 To change the alignment and position of bound text, see 
“Working with bound text,” next.

To type on a path using the Path Text tool 

1 Select the Path Text tool in the Text tools toolbar. When the
pointer is on the edge of an object, the pointer becomes a cross

2 With the crosshair pointer, click where you want to start typin
on the path. An insertion point appears.

3 Begin typing. Text you type aligns to the location where you
placed the insertion point and follows the path of the object.

4 To change the alignment and position of bound text, see the
procedure below.

Working with bound text
Once you bind text, you can change its starting position, alignme
baseline position, and flow direction. In addition, you can edit the 
shape and location of the vector object to which text is bound, an
Canvas will fit the text to the new path.

You can also edit bound text by selecting the Path Text tool and 
clicking the text object, or by double-clicking a bound text object 
with a Selection tool. However, text editing might be difficult and 
slow while the text is bound to an object; you might want to remo
the text bind, make changes, and re-bind the text.

Bound text and its binding object move together, just like grouped
objects. However, unlike grouped objects, you can select and cha
attributes (such as stroke and ink) individually for the text and the
object.
.6 TYPE EFFECTS
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To position and align bound text

Canvas has three Bind Position handles (shown in color below) th
you can drag to place text anywhere on, above, or below an obje
The handles appear when you select a bound text object.

Bind Position handles

Changing the appearance of bound text
Once you bind text to a path using the Path Text tool or the Bind T
command, you can use the context menu to change the orientatio
the text characters relative to the path, and to make the path visib
not visible. The bound text commands appear in the context men
when a bound text object is selected. To use the context menu, p

Handle Description Example

Reverse Flow handle Click to switch the vertical orienta-
tion of type relative to the object 
path and reverse the flow direc-
tion.

Alignment handle Drag to specify the point where 
you want type to align. For exam-
ple, center-justified text will center 
around the location of this handle.

Canvas spreads full-justified text 
along the entire path or object 
starting at the location of the han-
dle.

Baseline Shift handle Drag to change the elevation of 
the baseline relative to the vector 
object.

Baseline Shift lets you insert space 
between bound type and the 
object.

Text is centered around the
alignment handle
Binding text to vector objects 23.7
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Ctrl and the mouse button (Mac), or press the right mouse button
(Windows).

Bound text commands

The following commands appear in the context menu:

Show Path / Hide Path Choose Show Path to make the path visi-
ble. Choose Hide Path to make the path not visible. 

Vertical Text Choose Vertical Text to keep the baseline of the te
characters horizontal, rather than perpendicular to the path. This 
keeps the vertical axis of each character vertical, rather than angle
follow a curved path. The Vertical Text command is available whe
the text is bound with the Tangent Text option.

Tangent Text Choose Tangent Text to keep the baseline of the t
characters tangent to the path, rather than horizontal. This angles
vertical axis of each character away from vertical as needed to fol
the path. By default, Canvas uses the Tangent Text option when 
first binds text to a path. The Tangent Text command is available
the context menu when the text is bound with the Vertical Text 
option.

Removing a text bind
You can remove a bind effect by selecting a bound text object an
choosing Remove Effects in the Effects menu. Canvas straightens
text baseline and separates it from the vector object.

Binding text to a circle
You can create circular logos with text on top flowing clockwise an
text on the bottom flowing counterclockwise. You can create this 
effect by binding two text objects to a circle and using the Bind Po
tion handles to arrange the text. 

To create a circular logo

1 Create a circular object using the Oval tool in the toolbox.

2 Create two text objects and bind them to the circle. You can
use the Path Text tool to create and bind the first text object, bu
you must then bind the second text object using the Bind Text c
mand.
.8 TYPE EFFECTS
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3 Center the text objects on the top and bottom of the circle b
selecting each one and dragging its Align handle. Centering tex
objects is easier if the text is center-justified.

4 Click the Reverse Flow handle of the bottom text object so t
text reads from left to right inside the circle. 

5 Now shift the bottom text object outside the circle by draggin
its Baseline Shift handle outward from the center of the circle. A
you drag, Canvas displays a circle to show the baseline location

Using text as clipping paths
You can make a pattern, gradient, or image appear to span an en
selection, rather than begin and end within each character. For e
ple, instead of a gradient completing a blend pattern within each 
character of a word, you can make a gradient begin a blend in the
character and finish the blend in the last character.

In Canvas, you create these kinds of “continuous” fills using back
ground objects and foreground text object clipping paths. The inte
section of the background and foreground objects provides the 
appearance of a continuous fill. This method lets you use elabora
background designs, including paint objects, to fill characters. Fo
more information, see “Using clipping paths” on page 18.4.

Binding text to a circle

A The design consists of a cir-
cle and two text objects.

B One text object is bound to 
the top of the circle, the other 
to the bottom of the circle. Text 
initially flows clockwise.

C Clicking the Reverse Flow 
handle (highlighted in inset) 
makes “Ipsum” flow counter-
clockwise inside the circle.

D Dragging the Baseline Shift 
handle (highlighted in inset) po-
sitions “Ipsum” outside the cir-
cle. Removing the circle com-
pletes the design.

A B

DC
Binding text to vector objects 23.9
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To use text as a clipping path

1 Position the text object in front of the object to be clipped, a
then select both objects. 

2 Choose Object > Clipping Path > Make.

Applying vector effects to type
You can apply the following vector effects to text objects:

• Envelope

• Extrude

• Rotate

• Freeform rotate and skew

• Flip

• Shadow

• Path editing

You can use effects to add dimension to type and create striking 
designs. This section describes briefly how to apply each of these
effects. For more information, see “Vector effects” on page 18.1.

Before applying vector effects to type

Depending on the number and kind of effects you apply to type, y
might not be able to edit the text afterwards. For example, you ca
edit text after rotating and skewing, but if you also extrude the typ
Canvas converts the text to vector objects. In addition, depending
the speed of your system, editing rotated and skewed text might 
slow. Therefore, you might want to finish all text editing, formatting
and layout before applying effects.

Clipping path appears filled with gradientText object in front of gradient
.10 TYPE EFFECTS
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Freeform and rotate effects
In Canvas, you can place a text object in freeform mode and then
drag any of the hollow selection handles of the bounding box to 
rotate and skew text. You can also perform exact rotations using 
Rotate command in the Effects menu.

◆ To freeform edit a text object: Select a text object using a 
Selection tool. Choose Effects > Freeform. You can drag a circula
selection handle to rotate the text object, or a square handle to sk
the text.

◆ To rotate a text object an exact amount: Choose Effects > 
Rotate to open the Rotate dialog box. You can specify the degree
rotation and the center of rotation. Click Apply to see the effect of 
settings, or click OK to accept the settings.

Flipping text
You can use the Flip options in the Effects menu to create mirror-
image copies of text. In Canvas, you can flip text horizontally, ver
cally, or both.

◆ To flip text: Select the text object(s) you want to flip. Depend
ing on the direction you want to flip text, choose Horizontal, Vertica
or Both Axes in the Flip submenu in the Effects menu. Canvas im
ments the setting immediately.

This design consists of rotated 
(black) and skewed (color) type. 
Each word was divided into two 
text objects, which were 
arranged to create the effect.

Original

Vertical flip

Horizontal flip

Both axes
Applying vector effects to type 23.11
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Shadow effects
In Canvas, when you apply a shadow to text, the shadow is a sep
text object that you can color, edit, and apply effects to independe
of the original text object. By applying the right combination of 
effects, you can create oblique shadows and other lighting effects

Because Canvas creates a separate text object for the shadow, 
changes to the original text object do not change the shadow. Yo
should finalize text before applying shadows to ensure that the te
the same for both objects.

◆ To create a shadow: Select the text object(s) you want to appl
shadows to. Choose Effects > Shadow to open the Shadow dialo
box. Specify vertical and horizontal offset amounts and a color fo
shadows. Canvas creates the shadows and arranges them behin
original text object(s).

Text shadow effects

By combining Canvas effects, 
you can create different types 
of shadows.

A A standard shadow, slightly 
offset and shaded black.

B The shadow text object was 
skewed to create an oblique 
shadow.

This example consists of three 
objects: the original text, a 
slightly offset shadow, and an 
oblique shadow. To blur the 
shadow, convert the text to a 
paint object with the Area > 
Render option in the Image 
menu. Then, choose Filter > 
Blur > Gaussian Blur in the 
Image menu and set the radius 
to 3.0.

A B

C

.12 TYPE EFFECTS
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Envelope text effects
You can use the Envelope effect to warp and distort type to creat
new character forms and stretch text like rubber. When you apply 
effect to a text object, Canvas lets you drag selection handles to 
reshape text. Depending on the type of envelope you apply, text 
stretches in different ways. Using this effect, you can add perspec
to text or simulate stretching type around a three-dimensional obj

Note: You cannot edit text after applying an envelope effect. In ad
tion, you cannot extrude an object after changing its envelope. Ho
ever, you can change the envelope of an extruded object.

◆ To edit the envelope of a text object: Select a text object and 
choose Effects > Envelope. Choose a type of envelope effect in t
pop-up menu and click Apply. Then, drag the envelope handles t
reshape the text.

Extruding text
You can extrude text and add lighting effects to make text appear
three-dimensional. As with vector objects, you can rotate and sca
extruded text to change the apparent depth, size, and orientation
text, you can use only the Parallel option in the Extrude palette. Y
can also choose a color and position for the light source.

Note: You cannot edit text after extruding it. Also, Canvas remove
stroke and fill attributes before extruding text because they can in
fere with the three-dimensional effect. You can add color to extrud
objects by choosing a fill color in the Inks palette and a color for t
light source in the Extrude palette.

Extruded text with lighting effects
Applying vector effects to type 23.13
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◆ To extrude text: Select a text object and choose Effects > 
Extrude to open the Extrude palette. Choose Parallel in the pop-u
menu, configure the settings and click Apply. Use the extrusion h
dles to shape and rotate the text.

Converting text to paths
Canvas can create path outlines of characters so you can edit the
shape of each character. Once you convert text to paths, Canvas 
the paths as objects. You cannot edit the objects as text (apply fo
to, change the type size of, or spell check, for example).

To edit character paths

1 Select a text object and choose Object > Path > Convert to 
Paths. If the text object contains multiple characters, Canvas gro
the converted text together. 

2 To edit individual character outlines, choose Object > 
Ungroup, or use the Direct Selection tool to select shapes.

3 Double-click a character outline to place it in path edit mode
To put several shapes in path edit mode at the same time, you 
select multiple character outlines and choose Object > Path > E
Path.

4 Use path-editing techniques to change the outline, and then
press Esc to exit edit mode.
.14 TYPE EFFECTS



V
PAINTING & IMAGE EDITING



2



CHAPTER

24

al 
for 
s 
ges. 
age 

e as 

. A 
in 

ans-
 

 

s. 
PAINTING AND IMAGE-EDITING

Canvas provides a full palette of painting tools, including the digit
equivalents of markers, airbrushes, and paintbrushes, plus tools 
creating effects like neon and blends. The toolbar of painting tool
also provides tools to select, retouch, color-correct, and clone ima
This chapter explains how to use these painting tools, choose im
modes, and convert objects into images.

Paint objects and images
A paint object is a special type of Canvas object that contains an 
image. Paint objects are always rectangular and are the same siz
the images they contain. 

An image is a picture made up of many tiny squares, called pixels
scanned photo, a TIFF or Photoshop file, and a picture you paint 
Canvas are examples of images. 

Each pixel in an image is a solid color. Pixels can also be semi-tr
parent or completely clear. You can adjust the color, opacity, and
transparency of pixels by using painting tools and commands. 

At the object level, you can use tools and commands such as the
Selection tool and Align command to affect entire paint objects. 
Almost anything you can do to objects, you can do to paint object

About paint objects and 
images in Canvas 

“Images” are pictures defined 
by tiny dots, called pixels. A 
scanned photo, a TIFF or Pho-
toshop file, and pictures you 
paint in Canvas are all images 
composed of pixels. 

In a Canvas document, an 
image is contained in a paint 
object the same size as the 
image. Painting tools operate 
on the pixels within images, 

while object tools and com-
mands, such as the Selection 
tool or Align command, apply 
to entire paint objects.

You can perform common 
object operations, including 
move, copy, and duplicate, on 
paint objects. For details, see 
the chapter titled “Working 
with objects” on page 10.1.

You can create images entirely 
in Canvas by making a new 
paint object that you can paint 

in, or creating an image from 
vector or text objects, as 
described in this chapter.

You can also import images 
into Canvas documents using 
the following methods:

• Place an existing image in a 
document using the Place, 
Paste, or Acquire commands.

• Scan a photo using the 
Acquire command. See “Using 
scanners to acquire images” 
on page 25.1.
24.1
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This includes selecting, moving, copying, duplicating, deleting, rot
ing, skewing, and flipping. You can assign URLs to them and ma
proxies from them.

Creating paint objects
You can make new paint objects containing blank images. You c
convert objects into images by rendering them. 

To insert existing images into a document, you can use the Place
Paste, and Acquire commands. You can also scan images direct
into a Canvas document. See “To open or place a file” on page 7
“Acquiring images” on page 7.4; and “Using scanners to acquire 
images” on page 25.1.

Creating paint objects with painting tools
The Paint Object Creator tool creates new, blank paint objects. T
tool lets you set the image mode, resolution, and background tran
parency for new paint objects. The Paint Object Creator tool is 
located in the Painting Tools toolbar.

You can use other tools to create new paint objects. You can sele
any painting tool (except Crop) and drag in the document to crea
paint object. The Paint Object Creator tool settings for image mod
resolution, and background are applied to new paint objects you 
ate with any painting tool.

To create a paint object

1 Select the Paint Object Creator tool or another painting tool. 

2 Drag diagonally in the document to create a rectangular pain
object.

• To constrain the height and width proportionally, press Sh
as you drag.

• To constrain the height and width symmetrically from the 
center, press Option (Mac) or Ctrl (Windows) as you drag.

• To constrain the height and width proportionally and sym-
metrically, press Option+Shift (Mac) or Ctrl+Shift (Win-
dows) as you drag.

3 A blank paint object appears in edit mode. You can begin pai
ing in the image. When you finish, press Esc to end edit mode.

Paint Object Creator tool
.2 PAINTING AND IMAGE-EDITING
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Settings for new paint objects

You can specify the image mode, resolution, and background typ
before you create paint objects with painting tools.

◆ To change settings for new paint objects: Press the Paint 
Object Creator tool icon and a menu appears. Choose a mode, re
tion, or background type in the pop-up menu. To change another
ting, repeat the procedure. Check marks in the menu indicate the
current mode, resolution, and background type.

Background You can choose Opaque Background or Transpare
Background in the Paint Object Creator tool’s pop-up menu. Opaq
Background creates an image made of white pixels. Transparent
Background creates an image made of clear pixels. This type of 
image is transparent, so you can see other objects through it. 

You can use a transparent image like a clear overlay. For examp
you can place a transparent paint object in front of a vector graph
and then paint in the image to give the appearance of paint stroke
the graphic.

Image mode You can choose an image mode in the Paint Objec
Creator tool’s pop-up menu. The image mode controls the numbe
colors that can be stored in an image. See “Image modes for Can
paint objects” on page 24.31.

Resolution You can choose several common resolution settings 
the Paint Object Creator tool’s menu. To set any other resolution,
choose Custom. In the dialog box, type a resolution from 1 to 2,5
pixels per inch, and then click OK.

Drag any painting tool (except 
Crop) to create a new paint 
object

A paint object in 
edit mode, 
indicated by crop 
marks at each 
corner.

Black & White
Grayscale

✓ RGB Color
CMYK Color
Lab Color

✓ 72 PPI
150 PPI
300 PPI
Custom...

Opaque Background
✓ Transparent Background

Current settings are checked in 
the Paint Object Creator tool 
menu
Creating paint objects 24.3



24

 size, 

 
cts in 
gh 

edit-

eso-

ew 

 of a 
you 
xes.

size 
ix-
d 

 

Using the Create command
The Create command creates new paint objects using the mode,
resolution, and transparency settings that you specify. 

You can use the Create command to create paint objects that are
opaque or clear. Opaque paint objects are the same as paint obje
previous versions of Canvas. Clear paint objects let you see throu
unpainted areas. They are similar to transparent layers in image-
ing programs such as Photoshop. 

To create a paint object

1 With no objects selected, choose Image > Area > Create.

2 In the Create Image dialog box, set the image mode, type of 
background, background color (for an opaque image), size, and r
lution of the image. 

3 Click OK. The new paint object appears in the center of the vi
and is selected.

Setting paint object dimensions

When you use the Create command, you can set the dimensions
paint object using relative or absolute values, depending on what 
choose in the pop-up menus next to the Width and Height text bo

If you choose pixels to set the dimensions of the paint object, the 
of the object is relative to its resolution; higher resolution makes p
els smaller, so the resulting object is smaller at the same width an
height values. 

If you choose inches, centimeters, picas, or points, you can enter
absolute values for the paint object’s dimensions.
.4 PAINTING AND IMAGE-EDITING
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Adding visibility masks to images
If a paint object has a visibility mask, you can erase to a clear bac
ground. Also, Canvas can protect transparent areas when you pa
edit in the image.

You can add a visibility mask to a paint object that was created w
an opaque background in Canvas or imported from another appli
tion. 

Paint objects can look the same whether they have visibility mask
not. However, a visibility mask changes the way that the Eraser t
works and the effect of deleting or moving a selection.

Create options

The Create Image dialog box 
has options for new images.

File Size. The amount of 
memory required by the paint 
object, based on resolution, 
size, and image mode. Black 
& White mode requires the 
least memory; CMYK Color 
requires the most.

Mode. Choose an image 
mode. See “Image modes for 
Canvas paint objects” on 
page 24.31.

Background. Choose Trans-
parent or Opaque. 

Opaque creates an image 
filled with opaque pixels. You 

can select a color from the 
adjacent palette. To specify a 
custom color, see “Creating 
custom colors in pop-up pal-
ettes” on page 12.15.

Transparent creates a clear 
image with a visibility mask. 
When you choose this 
option, the color palette is 
not available.

Width and Height. Type the 
paint object’s width and 
height. In the adjacent 
menus, choose pixels and 
enter relative dimensions, or 
choose a unit of measure-
ment and enter absolute 
dimensions. 

Res. Enter the image resolu-

tion. Choose pixels per inch 
or pixels per centimeter in the 
adjacent menu. 

Auto. Click Auto to calculate 
the resolution based on half-
tone screen frequency.
Creating paint objects 24.5
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In a paint object that has a visibility mask, you can erase or delete
pixels to reveal a clear background. For example, you can erase a
edge of an image to create faded or torn edges. You can delete o
move selections to create transparent areas. 

If a paint object does not have a visibility mask, areas where you d
the Eraser tool, and selections you delete or move, become filled w
the current background color and are opaque, not clear.

When you create paint objects with painting tools or the Render o
Create commands, you can select an option to include visibility 
masks.

To add a visibility mask

1 Select a paint object that does not have a visibility mask. 

2 Choose Image > Add Visibility Mask. This command is not 
available if a Duotone, Indexed, or Multichannel image is select

Adding a visibility mask does not change the appearance of a pa
object. White pixels do not become transparent, for example. Whe
paint object has a visibility mask, you can select Preserve Visibilit
in the Channels palette. When this option is selected, Canvas pro
clear areas from the effects of painting and image editing.

White areas of the fish image 
erased to a clear background

A rectangle and 
text are blocked 
by an opaque 
paint object in 
front

A transparent 
background lets 
objects show 
through it

Paint object backgrounds

You can create a paint object in 
which the image “background” is 
transparent or opaque. 

An opaque paint object contains 
opaque pixels. If the pixels are white 
and the paint object is on a white 
background, you won’t notice that 
the image is opaque. Still, the rect-
angular paint object will block 
objects behind it (A).

A transparent paint object can have 
a clear background that does not 
block other objects (B).

Painting in an opaque image is like 
painting on a wall. Painting in a 
transparent image is like painting on 
a window. 

A

B

.6 PAINTING AND IMAGE-EDITING
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Rendering objects and images
Rendering converts objects into paint objects. For example, you c
use the Render command to create a paint object from text, and 
use the Airbrush tool to paint highlights on the image of the text.

Rendering is also referred to as “rasterizing” because the process
duces a raster image -- an image composed of pixels arranged in
grid. All paint objects in Canvas contain raster, or pixel-based, 
images.

You can create paint objects by rendering selected vector objects
text objects, and group objects. You can render a paint object to 
ate a new paint object that has different characteristics than the o
nal.

When you use the Render command, you can create a transpare
mask or visibility mask for the resulting paint object. 

When you render a vector object, it’s a good idea to select a visib
mask if you want to isolate an object against a clear background.

To render objects

1 Select one or more objects and choose Image > Area > Rend
If you select multiple objects, they will be rendered as one paint 
object. 

2 The Render Image dialog box lets you specify resolution and
other settings for the resulting paint object. Click OK to render the
selection.

Canvas creates a paint object containing an image of the original
objects. The paint object appears in front. The Render command d
not change the original selected objects. 

To see the original objects, you can drag the paint object away.

Pasting into images

You can render objects by copying them to the Clipboard and the
pasting them into paint objects in edit mode. When an image is in 
mode and you paste into it, the Clipboard content is rendered and
appears as a selection in the image.

If you select the “Anti-aliased Clipboard” option in the Preference
dialog box, Canvas anti-aliases vector and text objects that you p
into paint objects. 
Rendering objects and images 24.7
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Rendering exported files 

If necessary, Canvas renders selected objects or an entire docum
when you use the Save As command to export to a raster file form
For example, if you select vector objects, and then save in GIF fo
mat, Canvas renders the selected objects because GIF files store
ter images. 

When Canvas is saving a file, some options might not be availabl
the Render Image dialog box because the file format doesn’t sup
them.

Render Image settings

When you use the Render 
command, you can specify 
image mode, resolution, and 
other settings in the Render 
Image dialog box.

Dimensions. Displays the 
width and height of the paint 
object Canvas will create.

A Choose the measurement 
for the Width and Height values 
in the Dimension area; inches, 
centimeters (cm), points, or pi-
cas.

Mode. Choose the color mode 
for the resulting image: Black 
& White, Grayscale, Indexed 
Color, RGB Color, CMYK Col-
or, or LAB Color.

Width and Height. Enter the 
pixel dimensions for the paint 
object. When you change a 
value, Canvas adjusts the oth-
ers to maintain the size and 
proportions of the original 
objects. 

Res. Choose pixels per inch or 
pixels per centimeter in the 
pop-up menu. The value 
shown after “Size” is the 

amount of data in the 
image, based on the mode, 
resolution, and dimensions.

Anti-Alias. Blurs edges 
while rendering to make 
the edges of text characters 
and vector objects appear 
smoother in the resulting 
image. Choose Fine, Medi-
um, or Coarse in the pop-
up menu.

Coarse uses 16 shades for 
anti-aliasing and is the fast-
est option. Medium uses 64 
shades for anti-aliasing. 
Fine uses 256 shades for 
anti-aliasing. Fine produc-
es the softest edges and is the 
slowest option.

Mask. Select this option if you 
want the resulting paint object 
to have a visibility mask or a 
channel mask. Then choose 
the type of mask.

Transparency creates a chan-
nel mask. The channel mask is 
based on the silhouette of the 
rendered objects. In other 
words, if there are spaces 
between the objects, the chan-
nel mask will create transpar-

ent spaces.

Visibility creates a visibility 
mask in the paint object. The 
result is a clear background in 
areas not covered by objects. 

If you do not select Mask, 
areas not filled by rendered 
objects within the paint 
object’s bounding rectangle 
will be white and opaque. If 
you select Mask and either 
Transparency or Visibility, 
areas that are not filled by ren-
dered objects will be transpar-
ent.

A

.8 PAINTING AND IMAGE-EDITING
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Rendering with the Camera tool
You can use the Camera tool to create a paint object from 
area in a document. The Camera tool renders the area you

select. You can set the resolution, color mode, and other options 
the rendered image. The Camera tool is located in the Effects too
in the toolbox.

Using the Camera tool is like taking a snapshot of the screen. Yo
simply use the Camera tool to select a rectangular area for rende
You can include all types of objects and parts of objects in the ren
ing, without selecting the objects first.

The Camera tool is useful whenever you need to convert objects t
image, such as for creating web graphics. What the Camera tool d
is similar to the Image > Area > Render command. The Camera t
lets you control the exact area to be rendered, while the Render c
mand renders a rectangular area that includes all selected object

To render with the Camera tool

1 Select the Camera tool.

2 Drag to draw a rectangle around the area you want to rende
You can view the dimensions and coordinates of the rectangle i
the Status bar.

3 A bounding box with handles appears around the area you 
selected. You can adjust the box to select exactly the area you w
to render.

• Drag a handle to change the size and shape of the area t
rendered.

• Drag the border of the box to reposition the box.

4 When the box encloses the area you want to render, click 
inside it.

5 The Render Image dialog box appears. Select the options y
want to use, and then click OK to render the selected area.

After you click OK in the Render Image dialog box, a paint object
containing the rendered image will appear in front of the area you
selected.
Rendering objects and images 24.9
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Using painting tools
Painting tools let you apply color, make selections, edit, retouch, 
color-correct, and clone images. These tools are located in the P
ing toolbar.

For some painting tools, you can adjust opacity, pressure, exposu
or other settings. See the specific tool entries in this chapter for 
details.

To use a painting tool

This general procedure applies to all painting tools.

1 To place a paint object in edit mode, either:

• Double-click the object with the Selection tool. 

• Click the paint object with a painting tool. When you point t
a paint object with a painting tool, the pointer displays a han
If another paint object is in edit mode, press Tab and click
place a paint object in edit mode.

2 Select a foreground or background color to paint with. See th
topics in this chapter for more information.

• To swap the foreground and background colors, press the
ter “X” while using a painting tool. To set the foreground 
color to black and the background color to white, press ‘ 
(open single quote).

3 Select a brush shape in the Brushes palette. You can also ch
a mode or other option for most tools.

4 Click in the image to apply a spot of color, or drag to paint a 
brush stroke, depending on the tool.

• To constrain a brush stroke to horizontal or vertical, press 
Shift as you drag.

• You can start dragging outside an image; a tool’s effect 
begins when the pointer is inside the image.
.10 PAINTING AND IMAGE-EDITING
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Painting options
When you use a painting tool, you can use the context menu to g
quick access to common commands. The commands that are av
able vary, depending on the selected painting tool and whether th
is a selection in the image.

To use the context menu

With a Painting tool selected, press the right mouse button (Win-
dows), or press Control and the mouse button (Mac). When the m
pops up at the pointer, choose a command. Canvas applies the c
mand and hides the menu.

The context menu contains some common commands that are a
able from the regular menus. The following commands are availa
in the context menu only.

Selecting brushes

You can select a brush in the context menu based on the location
the brush in the Brushes palette. 

Next Brush Selects the brush shape in the Brushes palette to the
right of the current brush.

Previous Brush Selects the brush shape in the Brushes palette to
left of the current brush.

First Brush Selects the brush at the upper-left of the palette. 

Last Brush Selects the brush at the lower-right of the palette.

Selected paint object Paint object in edit mode
Using painting tools 24.11
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Brush shape display

The default pointer for painting is a symbol of the selected paintin
tool. You can change the pointer to a cross hair or the current bru
shape. All tools use the pointer you select, not just the current too
To change the pointer, choose an option in the context menu. 

Note: Changing the pointer using the context menu is the same a
changing the pointer using the brush options in the Painting tab of
Preferences dialog box.

Standard Pointer Displays the icon of the selected painting tool. 
This is the default pointer. 

Precise Pointer Changes the pointer to a cross hair. The intersec
tion of the cross hair is the center of the current brush.

Brush Size Pointer Changes the pointer to an outline of the curre
brush.

Fat Bits

The Fat Bits feature displays pixels as individual tiles in a grid at h
magnifications. This display was standard in Canvas 3.5 and earl

◆ To show Fat Bits: Press the Plus key or choose Show Fat Bits
the context menu to display pixels as individual tiles in a grid. 

◆ To hide Fat Bits: Press the Plus key or choose Hide Fat Bits i
the context menu to display pixels without the grid of individual tile

When you choose Show Fat Bits, the resolution and magnificatio
affect the display. Fat Bits are visible when the ratio of magnificati
to resolution is about eight to one. For example, if the image reso
tion is 72 ppi, fat bits appear at 600 percent magnification and high
If the image resolution is 144 ppi, fat bits appear at 1,200 percent
magnification. 

Selecting colors for painting
Painting tools use the foreground or the background color, or bot
Instead of pen and fill ink icons, two brush color icons appear in t
toolbox when you select a painting tool. The top icon shows the fo
ground color and the bottom icon shows the background color.

You can use any solid color for painting. However, you can’t pain
with multi-colored inks, such as gradients, symbols, textures, or 
hatch inks. For example, if the current pen and fill inks (for drawin

The palette icons when a 
painting tool is selected
.12 PAINTING AND IMAGE-EDITING
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objects) are gradients, when you edit an image, the foreground c
is black and the background color is white.

Also, if you choose a spot color and edit pixels with a painting too
Canvas converts the spot color to the image color mode (RGB, 
CMYK, and so on); see “Image modes for Canvas paint objects” 
page 24.31. You can arrange paint objects in a document with ve
and text objects that use spot colors, but only the vector and text 
objects will produce spot color separations.

◆ To select a color for painting: Press the foreground or back-
ground color icon in the toolbox to open the Inks palette; choose 
color on the Color tab. If you tear the Inks palette away from the to
box, it becomes a floating palette you can keep open as you work
When the palette is floating, you can select colors by clicking colo
tiles in the Color tab. You can also create new colors in the Color
manager. See “Creating color inks” on page 12.10.

You can quickly switch the foreground and background painting c
ors by pressing “x” when a paint object is in edit mode. To restore 
foreground color to black and the background color to white, pres
the single open quote key (‘) on the keyboard.

Picking colors from images and objects

You can use the Color Dropper tool to pick up color from an imag
or object. The color you select becomes the current background o
foreground color that you can use for painting.

◆ To select the background color: Select the Color Dropper tool 
in the Effects Tools toolbar in the toolbox and click a color in an 
object or image.

◆ To select the foreground color: Select the Color Dropper tool 
in the Effects Tools toolbar and Option-click (Mac) or right-button
click (Windows) a color in an object or image. 

Note: When a paint object is in edit mode and you change the for
ground or background color, the color you select stays in effect, 
becoming the current color for subsequent drawing and painting. 

Selecting brushes and painting options
The Brushes palette provides brushes and options for painting an
image-editing. You can select preset brushes and create new bru
The Opacity slider lets you adjust opacity for painting. The Mode 

 Color Dropper tool

✔Tip
You can select the Color Drop-
per in image edit mode by 
pressing Option (Mac) or Alt 
(Windows).
Selecting brushes and painting options 24.13
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menu lets you choose painting modes to control color application 
target tonal ranges.

To select a brush

Mac: Select a painting tool and then press the Brushes icon in the
toolbox. A palette of preset brushes appears. Drag to a brush to s
it and the palette closes.

Windows: Select a painting tool and then click the Brushes icon in
the toolbox. A palette of preset brushes appears. Click a brush to
select it and the palette closes. 

Note: The Brushes icon appears in the toolbox in place of the Stro
palette when one of the following painting tools is selected: Erase
Paintbrush, Marker, Airbrush, Neon, Rubber Stamp, Smudge, Blu
Sharpen, Dodge, Burn, Sponge. 

The Brushes icon is not available in the toolbox when one of the 
lowing tools is selected: Crop, Wand, Lasso, Marquee, Oval Mar-
quee, Row Selection, Column Selection, Pencil, Remote Move.

While painting, you can use the context menu to change brushes
select painting options.

Drag the palette away from 
the toolbox to use the 
floating Brushes palette

Current brush
Select a brush in the 
pop-up palette
.14 PAINTING AND IMAGE-EDITING
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Floating Brushes palette

When the Brushes palette is floating you can click brushes to sele
them. You can also use the Opacity slider, select painting modes,
create or delete brushes.

To use the floating Brushes palette, press the Brushes icon in the
toolbox and drag the palette away from the toolbox. You can doc
the Brushes palette on the Docking bar.

Painting opacity
Painting opacity affects the intensity of painting. You can adjust th
setting in the floating Brushes palette for the following painting too
Eraser, Marker, Paintbrush, Bucket, Blend, and Rubber Stamp.

Painting opacity can be set from 1 to 100%. Higher opacity make
the color you apply more opaque. Lower opacity makes color app
more transparent.

Painting opacity works together with painting modes (described 
next). In general, reducing opacity reduces the strength of the pai
color and the effect of a tool. 

For example, if you use the Paintbrush tool to apply black at 100%
opacity in Normal mode, black replaces the original color wherev
you paint. At 50% opacity, the strength of the black is reduced, so
mixes with the underlying color. If you also use a different paintin
mode, the strength of the mode’s effect is reduced.   

◆ To set painting opacity: Select a painting tool that uses the 
painting opacity setting. In the floating Brushes palette, drag the 
Opacity slider or enter a percentage in the text box. 

Canvas remembers each tool’s painting opacity setting. For exam
if you use the Blend tool at 30% opacity and then use the Paintbr
tool at 100% opacity, the setting changes back to 30% when you
select the Blend tool again.

Note: The Opacity slider in the floating Brushes palette affects sub
quent brush strokes by the current painting tool only. It is not the 
same as the Opacity sliders in the toolbox and the Transparency 
ette, which are linked and control overall opacity of selected obje

✔Tip
To quickly change the slider 
setting in the Brushes palette, 
you can press a number key; 
“1” sets the slider to 10%, “2” 
to 20%, and so on. “0” equals 
a setting of 100%.
Selecting brushes and painting options 24.15
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Painting modes 
You can use various painting modes when you paint and edit ima
Painting modes can create special effects and let you control colo
mixing and the tonal range affected by painting. 

Choosing painting modes

When you use a painting tool, choose a mode in the Mode pop-u
menu in the floating Brushes palette, or in the Mode submenu in 
context menu. Not all modes are available for all painting tools. 

Mode options are available when you use the following tools: 
Marker, Paintbrush, Airbrush, Bucket, Blend, Blur, Sharpen, and 
Rubber Stamp.

Some unique options for painting tools are described with the ind
vidual tools in this chapter. Painting modes that are available for 
most painting tools are listed here.

Normal The default painting mode applies color to all pixels uni-
formly. When the painting opacity is 100%, the applied color 
replaces the original color. If you paint in a Black & White or 
Indexed image, Normal mode is labeled Threshold.

Dissolve This mode applies color with a random diffused pattern
within the brush shape. The effect is similar to drawing with chalk
The diffused effect is stronger when the painting opacity is less th
100%.

Multiply Darkens all pixels by multiplying the value of the applie
color and the underlying color. Painting with darker colors intensifi
the effect. Painting with black results in black; painting with white 
does not affect the original color. When you apply a color with mu
ple strokes in the same area, the strokes become darker, similar t
effect of making multiple strokes on paper with an ink marker.

Screen The Screen mode is the opposite of Multiply mode. Scre
mode lightens all pixels by multiplying the inverse values of the 
applied color and the underlying color. Painting with lighter colors
intensifies the effect. Painting with black does not affect the origin
image; painting with white results in white. 

Overlay Applies color without destroying the underlying shadow
and highlights. Overlay mode blends the applied color with the 
underlying color; the amount of blending depends on the lightnes
the underlying color.

Painting modes
.16 PAINTING AND IMAGE-EDITING
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Soft Light Lightens or darkens underlying colors depending on t
lightness value of the applied color. If the lightness of the applied
color is less than 50% gray, painting lightens the image. If the ligh
ness of the applied color is greater than 50% gray, painting darke
the image. Painting with white or black has the most intense effec
but does not completely replace the underlying color. 

Hard Light Paints in Multiply or Screen mode, depending on the
applied color’s lightness value. This mode is similar to Soft Light. 
However, painting with black produces black; painting with white 
produces white.

Darken Compares the underlying color and the applied color, an
the result is whichever color is darker. In other words, pixels in th
image will be painted if the paint color is darker, while pixels that a
darker than the paint color will remain unpainted. 

Lighten The Lighten mode is the opposite of Darken mode. Light
compares the underlying color and the applied color, and the resu
whichever color is lighter. In other words, pixels in the image will b
painted if the paint color is lighter; pixels that are lighter than the 
paint color will remain unpainted.

Difference Compares the brightness of the original and applied 
colors, subtracts the brightness value of the darker pixel from the
lighter one, and applies that value to the original image.

Hue Applies the hue of the paint color without changing the brig
ness and saturation of the underlying image. 

Saturation Changes the saturation of the area painted to match 
saturation of the applied color, without changing the hue or lumi-
nance values. Applying gray does not affect the original image.

Color Changes the hue and saturation of the painted area to the
and saturation of the applied color, without affecting the shadow, 
highlights, or midtones of the original image.

Luminosity Changes the lightness of the underlying color to the 
lightness of the applied color, without affecting the hue or saturati
of the image.

Painting individual pixels with the Pencil
You can use the Pencil tool to apply the foreground color to a sin
pixel or create a one-pixel, freehand line. If the pixel already uses
foreground color, the Pencil applies the background color instead

Pencil tool
Painting individual pixels with the Pencil 24.17
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You can use the Pencil tool for precise image editing at high mag
cations.

◆ To paint a straight line: Shift -drag the Pencil to confine the 
line to 90 degree angles. 

Painting in the background color with the Eraser
You can paint with the background color using the Eraser tool. If 
paint object has a visibility mask, the Eraser clears the pixels it 
touches, revealing a clear background. If the paint object does no
have a visibility mask, the Eraser applies the background color.

Note: Opacity and painting mode options are not available with th
Eraser.

Painting with the Marker
The Marker tool paints with the foreground color, applying a hard
edged stroke. 

1 To configure the Marker tool, double-click the tool to open it
dialog box. 

2 Select the options you want to use in the Fade area. In the 
“Fade within” text box, enter the distance in which Canvas will 
complete the fade.

• To fade the brush size, choose Size.

• To fade the color to transparent, choose Opacity.

3 To make a pressure-sensitive stylus affect the marker size o
opacity, turn on these options under “Pressure Varies.”

4 Click OK and use the procedure “Using painting tools” on 
page 24.10.

Painting with the Paintbrush
The Paintbrush tool applies the foreground color. You can apply a
soft (anti-aliased) brush stroke by choosing a soft-edged brush in
Brushes palette. 

Eraser tool

Marker tool

Paintbrush tool
.18 PAINTING AND IMAGE-EDITING
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1 To configure the Paintbrush tool, double-click the tool to ope
its dialog box.

2 Select the options you want to use in the Fade area. In the 
“Fade within” text box, enter the distance in which Canvas will 
complete the fade.

• To fade the brush size, choose Size.

• To fade the color to transparent, choose Opacity.

3 To make a pressure-sensitive stylus affect the paintbrush si
or opacity, turn on these options under “Pressure Varies.”

4 Click OK and use the procedure “Using painting tools” on 
page 24.10.

Spraying soft strokes with the Airbrush
Using the Airbrush tool, you can apply the foreground color with a
very soft (anti-aliased) stroke. The Airbrush tool paints as long as
you press the mouse button. The Pressure setting in the Brushes
ette controls how fast the Airbrush applies color. 

1 To configure the Airbrush tool, double-click the tool to open
its dialog box. 

2 Select the options you want to use in the Fade area. In the 
“Fade within” text box, enter the distance in which Canvas will 
complete the fade.

• To fade the airbrush size, choose Size.

• To fade the amount of color applied, choose Pressure.

3 To make a pressure-sensitive stylus affect the airbrush size
pressure, turn on these options under “Pressure Varies.”

4 Click OK and use the procedure “Using painting tools” on 
page 24.10.

Filling areas with color
You can use the Bucket tool to pour color on an image. The Buck
applies the foreground color where you click. You can adjust its to
erance so the color covers adjacent pixels of the same color only
adjacent pixels of similar colors.

Airbrush tool

Bucket tool
Spraying soft strokes with the Airbrush 24.19
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1 To configure the Bucket tool, double-click the tool. In the 
Bucket dialog box, adjust the settings as needed.

• To affect only identically-colored pixels, type 0 in the Tol-
erance text box. Type a larger number to affect more pix

• To soften the edge of the filled area, turn on Anti-Aliased

2 Click OK and use the procedure “Using painting tools” on 
page 24.10.

Painting color gradients
You can paint a blend of colors with the Blend tool. By default, dra
ging the Blend tool in an image paints a blend from the foregroun
color to the background color. 

The Blend tool is very useful for creating blends from black to wh
in channels, to make selection masks that fade gradually from ful
selection to no selection. 

1 To configure the Blend tool, double-click the tool to open its
dialog box. For more information, see “Blend options,” next. 

2 Set the Mode and opacity in the Brushes palette; see “Crea
paint objects with painting tools” on page 24.2.

3 Put the image in edit mode, if necessary. Then, select the Bl
tool and drag to apply the blend, depending on the style selecte

• For linear blends, drag in the direction of the blend. Shift-
drag to confine the blend’s direction to a 90- or 45-degree
angle. Canvas fills the remaining area (if any) with the fore
ground color and background color.

• For radial blends, drag from the center of the blend. 

Blend tool

Linear blend Radial blend
.20 PAINTING AND IMAGE-EDITING
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Painting two-toned “neon” strokes 
 You can paint a neon-tube stroke, with the foreground color insid

and the background color outside, with the Neon tool. Use the Gl
setting in the Brushes palette to adjust the color ratio. Painting mo
aren’t available with the Neon tool. 

If you are using a pressure-sensitive tablet, double-click the Neon
tool to open its dialog box. You can make the stylus pressure affe
brush size by turning on the Size in the “Pressure Varies” area an
clicking OK. 

To paint with the Neon tool, follow the basic procedure in “Using 
painting tools” on page 24.10.

Copying areas with the Rubber Stamp tool
You can make a copy (“clone”) of an image area with the Rubber
Stamp tool. This tool is very useful for retouching scanned photo-
graphs, removing lines and scratches, and hiding seams when co
positing images.

Blend options

Style. Choose Radial or Lin-
ear. 

Offset. For Radial style, enter 
a value to set the percentage 
of starting color in the blend. 
To use more of the starting 
color in the blend, enter a 
number from 50 to 100.

Skew. To set the midpoint 
between blend colors, enter a 
number from 13 to 87. The 
default is 50.

Behavior. Choose a blending 
method. Foreground and 
Background refer to the cur-
rent colors in the toolbox. 

Transparent options fade from 
the foreground color to trans-
parency. Spectrum blends cre-
ate rainbow blends in a clock-
wise or counter-clockwise 
direction around the color 
wheel.

A Example of a blend used to 

vignette a photograph. The fol-
lowing Blend options were 
used:

Radial-style blend
Behavior = Transparent to 
Foreground
(Foreground color white)
Offset = 10
Skew = 70

Original A

Neon tool

Rubber Stamp tool
Painting two-toned “neon” strokes 24.21
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1 To configure options for the Rubber Stamp tool, double-clic
the tool to open its dialog box. Adjust the settings and click OK.

• To fade the brush size or opacity of the cloned image, tu
on the appropriate option in the Fade area and enter a nu
ber of pixels in the “Fade within” text box to tell Canvas th
distance in which to complete the effect.

• Select an option in the Style pop-up menu; see “Choosin
cloning style” on page 24.22.

• With a pressure-sensitive tablet, you can make the stylus
pressure affect size and opacity by turning on the approp
ate option in the “Pressure Varies” area.

2 Select the Rubber Stamp tool and click an image with the ha
pointer ( ) to put it in edit mode, if necessary.

3 Choose a brush shape, mode, and opacity setting in the Bru
palette; see “Creating paint objects with painting tools” on 
page 24.2.

4 Option-click (Mac) or Alt-click (Windows) in the image to se
the reference point for sampling an image area.

5 Drag in the image to paint a copy of the sampled area aroun
the reference point. 

Choosing a cloning style

The effect of dragging the Rubber Stamp tool in an image depend
the option you choose in the Style pop-up menu of the dialog box

Clone (aligned) The first time you drag the Rubber Stamp tool in
the image after setting the reference point, Canvas establishes a 
direction and distance from the reference point to the pointer. The
Rubber Stamp tool copies any area of the image that is this dista
and direction from the pointer.

Clone (non-aligned) Dragging the Rubber Stamp tool always 
begins copying the image from the same reference point.

Impressionist This option smears pixels to create an impressioni
tic effect. You don’t need to set a reference point to use this effec

Rubber Stamp pointer 
with Option (Mac) or Alt 
(Windows) pressed

Rubber Stamp pointer 
without modifier key
.22 PAINTING AND IMAGE-EDITING
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Smudging colors
With the Smudge tool, you can pull color from one area of an ima
and drag it into adjacent areas. You can adjust the Pressure setti
the Brushes palette to control the distance that the tool smudges 
color. 

1 Select the Smudge tool and click a paint object to put it in e
mode, if necessary.

2 To configure the Smudge tool, double-click the tool. In the d
log box, adjust the following settings and click OK.

• To gradually diminish the brush size as you drag, turn on
Size; to reduce the smudge effect as you drag, turn on P
sure in the Fade area. For both options, you can also typ
number in the “Fade within” text box to set how quickly th
effect fades.

• To smudge the foreground color into the image, turn on t
Finger Painting option.

• If you use a pressure-sensitive tablet and want stylus pre
sure to affect size and pressure, turn on Size and Pressu
the Pressure Varies area.

3 Select a brush shape in the Brushes palette. For more infor
tion, see “Creating paint objects with painting tools” on page 24

4 Adjust the Pressure setting in the Brushes palette. A setting
1 affects the image slightly; 85 drags the color through many pix

5 Drag the Smudge tool in the image area you want to edit.

Option-click (Mac) or Alt-click 
(Windows) to set the reference 
point for the area you want to 
clone with the Rubber Stamp tool

Clone (aligned) option Clone (Non-aligned) option

Smudge tool
Smudging colors 24.23
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To lighten (‘dodge’) areas
You can lighten specific areas of an image with the Dodge tool. 

1 Select the Dodge tool and click a paint object to put it in edi
mode, if necessary.

2 To configure the Dodge tool, double-click its icon. In the Dodg
dialog box, select the options in the Fade area, if desired, and typ
number in the Fade Within box to set the length of the fade effect

3 If you use a pressure-sensitive tablet, you can make stylus 
pressure affect brush size and exposure by selecting the Size a
Exposure checkboxes in the Pressure Varies area.

4 After configuring the Dodge tool the way you want, click OK

5 Choose a brush shape in the Brushes palette. For more info
mation, see “Creating paint objects with painting tools” on 
page 24.2.

6 Adjust the Exposure setting in the Brushes palette. Increasi
the Exposure increases the lightening effect of the tool. Decreas
the setting decreases the effect.

7 Choose Shadows, Midtones, or Highlights in the Mode pop-
menu. The Dodge tool lightens pixels that fall within the selecte
range only.

8 Drag the Dodge tool in the image area you want to edit.

To darken (‘burn’) areas
You can darken specific areas of an image by dragging the Burn 
over the pixels you want to darken. The tool’s effect can be con-
trolled by your selection of brush and adjustment of the tool’s Fad
setting. 

1 Select the Burn tool and click a paint object to put the image
edit mode, if necessary. To configure the Burn tool, double-click 
icon. 

• Select Fade options, if desired, and type a number in the
Fade Within box to set the length of the fade effect.

• If you use a pressure-sensitive tablet, select the Size and
Exposure checkboxes in the “Pressure Varies” area to va
size and exposure based on stylus pressure.

2 After configuring the Burn tool the way you want, click OK.

Dodge tool

Burn tool
.24 PAINTING AND IMAGE-EDITING
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3 Choose a brush shape in the Brushes palette. For more info
mation, see “Creating paint objects with painting tools” on 
page 24.2.

4 Choose an Exposure setting in the Brushes palette. Increas
the Exposure setting increases the darkening effect of the tool. 
Decreasing the setting decreases the effect.

5 Choose Shadows, Midtones, or Highlights in the Mode pop-
menu. The Burn tool darkens pixels that fall within the selected 
range only.

6 Drag the Burn tool in the image area you want to edit. 

To blur areas
You can soften specific areas in an image with the Blur tool. The 
Blur tool decreases the contrast between pixels the tool drags ov

1 Select the Blur tool and click a paint object to put the image
edit mode, if necessary.

2 To configure the Blur tool, double-click the tool. In the dialog 
box, adjust the following settings and click OK.

• To diminish the brush size gradually as you drag, turn on
Size; to reduce the blur effect as you drag, turn on Press
in the Fade area. For both options, you can also type a n
ber in the “Fade within” text box to set how quickly the 
effect fades.

• If you use a pressure-sensitive tablet and want stylus pre
sure to change size and pressure, turn on Size and Pres
in the Pressure Varies area.

3 Select a brush shape in the Brushes palette. For more infor
tion, see “Creating paint objects with painting tools” on page 24

4 Adjust the Pressure setting in the Brushes palette. A setting
1 affects the image slightly; 85 softens the image greatly.

5 Drag the Blur tool in the image area you want to edit. Canva
applies the effect to pixels touched by the tool.

Blur tool
To blur areas 24.25
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To sharpen areas
You can increase the contrast between specific pixels in an imag
with the Sharpen tool. 

1 Select the Sharpen tool and click a paint object to put the ima
in edit mode, if necessary.

2 To configure the Sharpen tool, double-click the tool. In the dia
log box, adjust the following settings and click OK.

• To gradually diminish the brush size as you drag, turn on
Size; to reduce the sharpening effect as you drag, turn o
Pressure in the Fade area. For both options, you can als
type a number in the “Fade within” text box to set how 
quickly the effect fades.

• If you use a pressure-sensitive tablet and want stylus pre
sure to affect size and pressure, turn on Size and Pressu
the Pressure Varies area.

3 Select a brush shape in the Brushes palette. For more infor
tion, see “Creating paint objects with painting tools” on page 24

4 Adjust the Pressure setting in the Brushes palette. A setting
1 affects the image slightly; 85 dramatically sharpens the image

5 Drag the Sharpen tool in the image area you want to edit. C
vas applies the sharpening effect to pixels touched by the tool.

Saturating and desaturating colors
With the Sponge tool, you can add or remove gray content from s
cific areas of an image. 

1 Select the Sponge tool and click a paint object to put the ima
in edit mode, if necessary.

2 To configure the Sponge tool, double-click the tool to open its
dialog box. 

• To gradually diminish the brush size as you drag, turn on
Size; to reduce the Sponge effect as you drag, turn on P
sure in the Fade area. For both options, you can also typ
number in the “Fade within” text box to set how quickly th
effect fades.

Sharpen tool

Sponge tool
.26 PAINTING AND IMAGE-EDITING
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• If you are using a pressure-sensitive tablet, you can mak
the stylus pressure affect size and exposure by turning o
the appropriate option in the “Pressure Varies” area.

3 After configuring the Sponge tool the way you want, click OK

4 Choose a brush shape in the Brushes palette. For more info
mation, see “Creating paint objects with painting tools” on 
page 24.2.

5 Adjust the Pressure setting in the Brushes palette. Increase
pressure to increase the effect.

6 Choose Saturate or Desaturate in the Mode pop-up menu. S
rate removes gray; desaturate increases the amount of gray.

7 Drag the Sponge tool over the image area you want to edit.

Customizing brushes for painting tools
You can use the Brushes palette to create brushes, save brushes
files on disk, modify existing brushes, and delete unwanted brush

You can add custom brushes to the list of preset brushes in the p
ette. When you exit Canvas, it stores the brush presets. The sam
of brushes are available whether you work with new documents, d
uments you created, or documents created by another Canvas u
Customizing brushes for painting tools 24.27
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To create a new brush

1 Press the right-arrow button in the Brushes palette and cho
New Brush in the pop-up menu. 

2 In the New Brush dialog box, adjust the settings for the brus
For more information, see “New brush options,” page 24.29.

3 After entering the settings you want, click OK. The new brus
shape appears in the Brushes palette.

To delete brushes from the palette

You can permanently remove brush shapes from the Brushes pa
If you think you might want to use the brush shape again, you sho
first store it in a brushes file so you can later load it back into the 
ette. See “Saving and loading brushes,” page 24.29.

◆ To delete a brush: Select the brush you want to delete. Choos
Delete Brush in the Brushes palette pop-up menu, or Command-c
(Mac) or Alt-click (Windows) a brush in the palette to delete it.

Using a selection to define a brush shape

You can make a new brush shape from a selection in an image. T
lets you create non-elliptical brush shapes.

1 Select all or part of an image; see “Selecting pixels in image
page 26.1. 

2 Choose Define Brush in the Brushes palette pop-up menu. T
selection becomes a brush in the Brushes palette. Canvas uses
shape and lightness values of the selection to define the brush.
Brush shapes do not contain color.

Modifying brush shapes
You can edit any brush shape. For brush shapes created from se
tions, you can change only the spacing.

1 In the Brushes palette, double-click the brush shape you wa
to modify.

2 In the Brush Options dialog box, adjust the settings you wan
and click OK; see “New brush options,” next.

Brushes 
palette 
pop-up 
menu

New brushes appear in the 
Brushes palette

You can select image areas to 
make brushes. This image 
contains rendered vector objects.
.28 PAINTING AND IMAGE-EDITING
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Saving and loading brushes
You can save brushes in a file, and load brushes from a saved file
the Brushes palette. Saving brushes to disk lets you customize th
Brushes palette for particular projects or exchange brushes with o
Canvas users. The file format that Canvas uses to save brushes 
disk is also compatible with the file format used by the Photoshop
image-editing program for saving brushes.

To save brushes in a file

1 In the Brushes palette, add or remove brushes until you hav
the collection you want to save.

2 Choose Save Brushes in the Brushes palette pop-up menu.

3 In the directory dialog box, type a name for the brushes file,
select a location, and click Save (Mac) or OK (Windows).

To load brushes from a file

When you load brushes, you can replace the current set of brush
with the contents of the file, or add the brushes to those in the pa

1 In the Brushes palette, choose one of the following comman
in the pop-up menu:

• To replace the current brushes with those in the brushes f
choose Load Brushes.

New brush options

You create brush shapes by 
specifying diameter, hardness, 
spacing, roundness and angle. 
These same options are avail-
able in the Brush Options dia-
log box.

Diameter. Enter the diameter 
in pixels of the new brush.

Hardness. Enter a percentage 
to tell Canvas how much of the 
brush shape is solid. 

Spacing. This percentage sets 

the amount of brush overlap 
when you drag a painting tool. 
Turn off Spacing to make the 
brush velocity-sensitive, so it 
skips pixels when dragged 
fast. 

Roundness. Enter 1 to 100. To 
create a circle, enter 100.

Angle. Enter a number to 
rotate the brush shape.

A Drag to change Roundness.
B Drag to change the Angle.
C Preview of the brush shape. A B C
Customizing brushes for painting tools 24.29
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• To add the presets in the brushes file to those currently i
the palette, choose Append Brushes.

2 In the directory dialog box, locate the brushes file you want 
open and click Open (Mac) or OK (Windows).

Using vector and text tools in paint objects
After placing a paint object in edit mode, you can use vector tools
and the Text tool to add shapes and type to an image. 

When you draw or type text within a paint object in edit mode, Ca
vas rasterizes the objects according to the image mode and resol
of the paint object, and makes a floating selection in the image. 

When you type within a paint object in edit mode, you can modify
the font, size, and style of the type before Canvas rasterizes it. Fo
more information, see “To set type within images” on page 24.31

To set anti-aliasing for objects placed in images

You can set a preference so Canvas softens the edges of objects
draw in an image or paste into an image from the Clipboard. 

1 Choose File > Preferences and click the Painting tab in the 
Preferences dialog box.

2 Set the preferences you want to apply to objects placed in 
images and click OK.

• To soften selections pasted from the Clipboard, select 
“Anti-Aliased Clipboard.” 

• To soften objects or type created in paint objects in edit 
mode, select “Anti-Aliased Canvas Objects.”

For more information, see “Painting preferences” on page 9.4.

To draw objects within images 

You can use any of the drawing tools in a paint object in edit mode
“paint” shapes. When you finish drawing the shape, Canvas raste
izes it, based on its shape and colors.

1 Double-click the paint object with the Selection tool to put it i
edit mode, if necessary, and select a drawing tool.

2 Select ink and stroke settings. For more information, see “In
colors and patterns” on page 12.1 and “Strokes: outline effects”
page 13.1.
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3 Drag the selected tool to draw within the paint object. For mo
information, see “Drawing basics” on page 15.1. The object you
draw becomes a floating selection and you can change its opac
set the mode, or apply filters; see “Changing the opacity of floati
selections” on page 26.12 and “Image filters and effects” on 
page 28.1.

4 When you finish editing the selection, press Enter (Mac) or E
(Mac or Windows) to make the selection part of the image. Pres
Enter (Mac) or Esc (Mac or Windows) again to deselect the area

To set type within images

You can type text within a paint object in edit mode and then mod
the attributes before Canvas converts the type to a floating select

1 Double-click the paint object with the Selection tool to put it i
edit mode, if necessary, and select the Text tool in the toolbox.

2 Click the I-beam pointer in the image and type the text, whic
appears in a white box. 

• You can use the Text menu, Type palette, or Text Ruler 
set typographic attributes.

3 Press Enter (Mac) or Esc (Windows) to make the type a floa
ing selection. 

• You can change the opacity, set the mode, and apply filte
to the selection; see “Changing the opacity of floating sel
tions” on page 26.12 and “Image filters and effects” on 
page 28.1.

4 When you finish, press Enter (Mac) or Esc (Windows) to ma
the type selection part of the image. Press Enter (Mac) or Esc (M
or Windows) again to deselect the area.

Image modes for Canvas paint objects
In Canvas, image modes define the color model and the number 
colors that can be used in images. When you create a new paint 
object in Canvas, you select an image mode: Black & White, Gra
scale, RGB Color, CMYK Color, or LAB Color. When you select a
paint object, Canvas displays the image mode in the information a
at the right end of the Status bar.
Image modes for Canvas paint objects 24.31



24

hen 
 in 

g, 
 
age. 

 

s, or 
 
rs. 
How image modes affect image filters

Filters produce different results depending on the image mode. W
you paint, the opacity setting of a brush acts differently on images
different modes. For the most predictable results with filters and 
paint tools, use RGB Color mode.

How Canvas assigns image modes

When you import an image from another source either by openin
placing or pasting an image file, Canvas assigns an image mode
based on the number of colors and the color model used in the im

The following table shows the image modes that Canvas assigns
when you import images in some common image formats.

Changing image modes
The Mode submenu lets you change the mode of selected paint 
objects.

You might want to change modes so you can use certain feature
to reduce memory requirements. For example, you might want to
convert an Indexed image to RGB Color mode to apply image filte

Imported format Assigned image mode

TIFF RGB Color, CMYK Color, or Grayscale

BMP 256-color image: Indexed
24-bit image: RGB Color

MacPaint Black & White

Photoshop Same as original image mode

Posterizing a LAB image 
introduces color to light areas.

RGB image 
posterized 4 levels

Original LAB image 
posterized 4 levels
.32 PAINTING AND IMAGE-EDITING
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You might want to convert an RGB Color image to Grayscale mo
to save memory when a document is printed without color.

◆ To change image modes: Select one or more paint objects. Or
with a paint object in edit mode, choose the mode you want in the
Image > Mode submenu. 

Some modes are available only if the object’s current mode is co
patible. For example, Black & White mode and Duotone mode ar
available only when Grayscale paint objects are selected.

If the mode you choose does not support an image’s full color ran
a message asks you to confirm the change. Click OK to proceed.

If you choose Duotone mode or Indexed mode, you can select 
options in a dialog box and then click OK to complete the conver-
sion. See “Duotone image mode” on page 24.40 and “Indexed im
mode” on page 24.34.

Black & White image mode
Black & White image mode is used for scanned line art and black
and-white (“bitmap”) images, which contain only black and white 
pixels. Black & White mode images require the least amount of 
memory and disk space.

To convert to Black & White mode

Grayscale mode images and Multichannel mode images are the 
images you can convert to Black & White mode. If an image is no
Grayscale, convert it to Grayscale mode first if you want to conver
to Black & White mode. 

1 Select the paint objects to convert and choose Image > Mode
Black & White. The Select Halftone Method dialog box lets you 
choose a conversion option.

2 Select Pattern Dither, Diffusion Dither, or Threshold, and then
click OK.

• If you choose Pattern Dither or Diffusion Dither, Canvas 
“screens” the image, rendering its tones as patterns of tiny
dots. Pattern Dither screens an image using a fixed patter
similar to a traditional halftone screen. Diffusion Dither 
screens an image using a process that creates a random 
tern effect. 
Changing image modes 24.33
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• If you choose Threshold, Canvas converts the image to a 
high-contrast black-and-white image. Pixels of lightness va
ues from 0 to 128 become black, and pixels of lightness va
ues from 129 to 255 become white.

When you paste a selection into a Black & White image, Canvas u
diffusion dither on the selection.

Grayscale image mode
Grayscale mode is appropriate for images scanned from black an
white photographs, or when the image will never be printed in col
In Grayscale mode, pixels use 256 brightness levels to represent
range of shades from pure black to pure white. Grayscale uses 8
per pixel and requires less memory than most color modes.

If you convert a color image to Grayscale mode, Canvas discards
color information.

Indexed image mode
Indexed color mode uses a palette of 256 colors for images. 
Because it stores fewer colors, it requires significantly less mem
than RGB Color and CMYK Color modes, both of which suppor
millions of colors. Smaller memory requirements make Indexed 
mode especially useful for images used on Internet web pages.

An Indexed image includes a color table, or palette, of colors us
in the image. When you convert an existing image to Indexed 
mode, you can specify the number of colors from the image to 
include in the color table.

Most image filters, effects, and opacity controls aren’t available 
be applied to Indexed images, except the Offset and De-Interlac
filters, as well as some third-party plug-in filters.
.34 PAINTING AND IMAGE-EDITING
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To convert an existing image to Indexed mode

1 Select paint objects with the Selection tool and choose Imag
Mode > Indexed. A dialog box appears.

2 In the Indexed Color dialog box, choose an option for the co
table:

3 Depending on which method you select, the Colors area in 
dialog box displays information about how the color table is com
puted. Choose the option you want, if necessary:

Exact Creates a color table from the colors in the image, if 
the image contains 256 colors or less; otherwise, this 
option isn’t available

Uniform/
System

Creates a color table based on the operating sys-
tem’s palette of 256 colors (System), or a subset of 
these colors (Uniform)

Adaptive Creates a color table from the most frequently used 
colors in the image

Custom Lets you create a color table, load, and save color 
table files.

Previous Applies the last color table used in the Indexed Color 
dialog box during the current Canvas session

Exact If you choose Exact, the Colors area displays the 
number of colors in the selected image

Uniform/ 
System

If you choose System, the Colors area displays the 
number of colors in the operating system’s palette; if 
you choose Uniform, a pop-up menu that lets you 
select 8, 27, 64, 125, 216, or 256 colors appears

Adaptive If you choose Adaptive, the Colors area displays a 
text box that lets you enter a number of colors from 2 
to 256

Custom If you choose Custom, the Colors area displays “Cus-
tom colors”

Previous If you choose Previous, the Colors area displays the 
number of colors in the last color table created by the 
Indexed Color dialog box during the current Canvas 
session
Changing image modes 24.35
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4 Choose a color-distribution option in the Dither area:

5 After choosing the settings you want, click OK. If you select
the Custom option, the Color Table dialog box appears. To use 
dialog box, refer to “Creating custom color tables for Indexed 
images,” next.

Creating custom color tables for Indexed images
You can create a custom color table for an Indexed image in two 
ways. You can select “Custom” in the Indexed Color dialog box. O
with an Indexed image selected, you can choose Image > Mode 
Color Table in the Image menu. If you select “Custom” in the 
Indexed color dialog box, Canvas opens the Color Table dialog b
after you click OK in the Indexed Color dialog box.

In the Color Table dialog box, you can edit individual colors in the
palette, create a blend of colors, and select from several preset c
palettes, including System and Grayscale palettes. You can also 
a palette file, or load a palette file.

None Changes colors to their closest equivalent in the 
selected color table without dithering

Pattern Approximates colors not in the palette by arranging 
palette color in geometric patterns (available for Uni-
form/System method only)

Diffusion Approximates non-palette colors by randomly dither-
ing available colors; creates the most natural effect

Table pop-up menu
.36 PAINTING AND IMAGE-EDITING
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In the Color Table dialog box, a grid of 256 color swatches appea
each swatch represents one color in the palette. By default, the C
tom option appears in the Table pop-up menu, and the color swat
show the last palette used in the dialog box.

The Table pop-up menu lets you choose among preset color tabl

• Black Body is a range of sunset-like colors.

• Grayscale is a ramp from pure black to pure white.

• Macintosh System is the palette of colors supported by th
Mac OS.

• Spectrum is a set of rainbow colors.

• Web Browser is a set of 216 colors that can be displayed
without dithering by nearly all Internet web browsers, run
ning Mac OS or Windows. This option is also referred to a
a “browser safe” palette.

• Windows System is the palette of colors supported by W
dows.

You can also create a custom color table. To do this, refer to the 
tions “To customize individual colors” on page 24.38, and “To cus
tomize a color table by blending colors” on page 24.38.

Saving and loading color tables
By using the Load and Save options in the Color Table dialog box
you can save color tables to your hard disk, or load a saved color
table file into the Color Table dialog box.

To load a custom color table

1 Click Load in the Color Table dialog box. A directory dialog 
box appears (Mac), or a Load Settings dialog box appears (Win
dows).

2 In the directory dialog box, locate the color table file you wa
to load, and then click Open. Canvas replaces the current palet
the Color Table dialog box with the new palette, and its name 
appears in the Table pop-up menu.

To save a custom color table

1 Click Save in the Color Table dialog box. A directory dialog 
box appears (Mac), or a Save Settings dialog box appears (Win
dows).
Changing image modes 24.37
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2 Type a name for the table in the “Save color table in” box 
(Mac), or the “File name” box (Windows). Before you type the fil
name, Canvas adds the extension “.ACT” in the text box. It’s rec
ommended that you keep this extension when naming the file.

3 Specify a location on your hard disk to save the color table, a
then click Save. Canvas saves the color table.

To customize individual colors

After choosing a color table, you can customize individual colors in
using a color picker dialog box

1 Click a color swatch to open a color picker dialog box.

2 In the color picker, select a color to replace the selected swa
in the palette, and then click OK.

To customize a color table by blending colors

Canvas lets you create blends of selected swatches in the color t 
When you do this, the first and last swatches you select don’t affe
the final blend in the color table. How the blend appears in the co
table is determined by the two colors you choose in the Color Pic
in step 2 of this procedure.

1 Drag across multiple color swatches to select them (the mo
you select, the more gradual the blend will be). Selected color 
swatches appear highlighted with a black border, and then the c
picker dialog box opens.

Color selector

Click to choose 
a color

Color Picker (Mac OS)
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2 In the color picker, choose the first color, and then click OK.
The color picker remains open; choose the second color, and th
click OK. Canvas fills the selected color swatches in the Color Ta
dialog box with a ramp of the two colors.

RGB Color image mode
RGB Color mode is used most often when working with high-qual
full-color images, such as those from color scanners and digitized
photographs stored on CD-ROM.

RGB Color mode is the most reliable mode to use for images you
want to modify with painting tools and filters. However, the full 
range of RGB colors exceeds the range that commercial printing 
reproduce, so you should be aware of the limitations of the printin
method that will be used. Also, an RGB Color image is device dep
dent, which means that the same RGB values can look different w
displayed on different monitors.

In RGB Color mode, each pixel has a red, green, and blue compo
nent. Each component, referred to as a color channel, has 256 in

Original Grayscale palette

Drag to select color swatches to replace 
with a blend

Color picker (Windows)

Luminosity 
control

Click to select 
the current color

Color selector
Changing image modes 24.39
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sity levels. The combination of the intensity value in each channe
creates each pixel’s color.

CMYK Color image mode
CMYK Color mode is based on the four color inks used in comme
cial printing (and by some desktop printers): cyan, magenta, yello
and black. Some color scanners can produce CMYK images. 

In a CMYK Color image, each pixel has a cyan, magenta, yellow,
and black component. Each of these color channels has 256 inte
levels. The combination of the intensity value in each channel crea
each pixel’s color. Because monitors are RGB devices, they can’
display CMYK colors directly. However, Canvas attempts to displ
CMYK images as they will appear when printed. 

LAB Color image mode
The Commission Internationale d’Eclairage (CIE) developed the 
LAB Color mode as an international color standard to overcome t
device dependency of the RGB and CMYK modes. In a LAB Colo
mode image in Canvas, each pixel has one lightness and two col
components. The Lightness (L) channel has 256 levels of intensit
The two color channels, labeled A and B, provide a color range fr
red to green and yellow to blue, respectively. 

Some companies sell collections of images in LAB Color mode. 
Editing LAB Color mode images with some filters or painting tools
can have interesting and unpredictable effects. 

Duotone image mode
In traditional graphics arts reproduction, a “duotone” is a graysca
image printed with black and an additional color. Canvas lets you
create duotone images, as well as “monotone,” “tritone,” and “qua
tone” images (printed with one, three, or four colors, respectively)

Printing images as duotones can add interest and increase the to
range reproduced from grayscale photographs, without the additio
expense of printing full-color images. The duotone effect can be s
tle or striking, depending on the color used and the amount adde
the image. In any case, the additional colors are used to reproduc
gray values in the image, rather than to reproduce specific colors

To create a monotone, duotone, tritone, or quadtone in Canvas, y
must convert a Grayscale image to Duotone mode. Unlike other 
.40 PAINTING AND IMAGE-EDITING
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image modes, once an image is converted to Duotone mode, you
not work with individual image channels. Instead, you can adjust 
curves for each color “channel” in the Duotone Options dialog bo

Note: In this section, the term “Duotone” refers to the Duotone ima
mode, not just to images printed with two inks. In Duotone mode,
image can be printed as a monotone, duotone, tritone, or quadton

To create a Duotone image

1 Select paint object and choose Image > Mode > Grayscale 
convert to Grayscale mode. Click OK when Canvas asks to disc
color information. Then choose Image > Mode > Duotone. 

2 In the Duotone Options dialog box, choose Monotone, Duo-
tone, Tritone, or Quadtone in the Type pop-up menu. Depending
the Type setting, the Ink 1, Ink 2, Ink 3, and Ink 4 Curve boxes, 
color pop-up menus, and text boxes become available.

3 Choose ink colors by pressing the color palette icons and 
selecting colors in the pop-up palettes. Note: You must have 
already added the desired colors to the preset colors on the Co
tab in the Inks palette for them to be available in the pop-up pale

• For a monotone image, choose a single color in the Ink 1
area. For a traditional duotone, leave “Process Black” as I
1, and choose a second color in the Ink 2 area. For triton
and quadtones, choose additional colors for Ink 3 and Ink

• Canvas puts the name of the selected ink in the text box.

• To use process colors, type the appropriate name (“Proc
Cyan,” “Process Black,” “Process Magenta,” or “Process 
Yellow,”) so colors appear on the correct plates. If you 
leave the text box blank, Canvas prompts you to enter a 
name for the ink.

• You should specify ink colors in descending order of ligh
ness value. In other words, darker color inks should appe
at the top, and lighter color inks should appear at the bott
of the dialog box.

• You should assign only solid spot colors (PANTONE inks
or individual process colors for duotones. If you assign a
color ink made from CMYK components (including a Tru-
Match color), Canvas treats it like a spot color and prints 
only one plate for the color when you output color separa
tions.

✔Tip
If you plan to export a duotone 
image to another graphics or 
page layout program, be sure 
the color names exactly match 
the color names in the other 
application. Otherwise, you 
might produce more color sep-
arations than necessary.
Changing image modes 24.41
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4 If necessary, click the curve boxes to adjust curves for each 
color. In the Duotone Curves dialog box, drag the curve to adjus
or enter values in the text boxes to map input values to the desi
output values, and then click OK.

5 Click OK to apply the Duotone Options dialog box settings.

Adjusting duotone images

After you convert an image to Duotone mode, you can reopen the
Duotone Options dialog box to adjust the color curves, change in
colors, and use the Load and Save options.

◆ To change duotone options: Select the paint object you want 
to adjust and choose Image > Mode > Duotone Inks. Adjust the s
tings in the Duotone Options dialog box and click OK to implemen
the new settings.

Loading and saving duotone information

Use the Load and Save buttons in the Duotone Options dialog bo
work with files of duotone options information. Canvas uses a file

Duotone Options

You can select and change the 
following ink settings for imag-
es in Duotone mode.

Type. Choose Monotone, 
Duotone, Tritone, or Quad-
tone.

A Inks. Click the palette icons 
and select colors in the pop-up 
palettes for each ink. Type pro-
cess and spot color names in 
the text boxes.

Overprint Colors. Click to 
adjust the screen display of 
the Duotone inks. Because the 
appearance of spot-color com-
binations can’t be predicted 
within Canvas, you can do this 
if you have an accurate printed 
reference for the colors you 

select. Overprint Colors set-
tings do not affect color sepa-
rations, but will change the 
appearance of color compos-
ites printed on desktop color 
printers. In the Overprint Col-

ors dialog box, click the color 
squares to open a color selec-
tor dialog box. Choose the col-
or you want to represent the 
ink combination on screen and 
then click OK.

A
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format compatible with the duotone options files used by the Pho
shop image-editing program, so you can load files saved from Ph
shop, and files saved by Canvas can be loaded into Photoshop.

• Click Save to save the duotone options settings. In the dir
tory dialog box, type a file name and click OK or Save.

• Click Load to use settings from a saved duotone options 
file. In the directory dialog box, select a duotone options fi
and click Open. Canvas will apply the ink and curve settin
saved in the file to the Duotone Options dialog box.

Multichannel image mode
Multichannel image mode lets you work with multiple channels of
grayscale information for a grayscale image. In multichannel mod
each channel contains lightness values as in other image modes
the values do not relate to color components. 

When you convert an image to Multichannel mode, the image da
does not change. For example, if you convert an RGB Color mod
image to Multichannel mode, the Red, Green, and Blue channels
retain the same pixel information, but the channels no longer repr
sent color pixels. The channels in Multichannel mode are labeled
numerically (#1, #2, and so on) in the Channels palette.

The Multichannel mode is not available if you select a paint objec
containing an image in Black & White image mode.
Changing image modes 24.43
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SCANNING, SIZING, AND TRACING 
IMAGES 

This chapter focuses on acquiring and sizing images. It explains h
to scan images into Canvas documents, change the size and res
tion of images, and auto-trace images to create vector objects fro
them. It also describes some basics techniques you can use to 
improve scanned images and photographs imported from Photo C

Using scanners to acquire images 
You can scan images directly into Canvas documents using mos
types of desktop scanners. Canvas supports scanners that work 
Photoshop-compatible plug-in acquire modules. It also lets you u
scanning devices that are compatible with the TWAIN standard.

Using TWAIN-compatible scanners
Scanner manufacturers created the TWAIN interface to standard
interaction between scanners and computer software. Scanners 
comply with the TWAIN standard provide a “source manager” file
which translates scanner information into data that Canvas can u
You must install the TWAIN scanner software on your system befo
you can select the scanner and scan images in Canvas.

If you aren’t sure whether a scanner is TWAIN-compatible, consu
the scanner documentation or contact the manufacturer.

To select a TWAIN scanner

1 Choose Image > Acquire > TWAIN Select Source. In the 
Select Source dialog box, a scrolling list contains the names of al
TWAIN scanners for which Canvas can locate a data source.

2 Select the scanner you want to use and click OK. The Selec
Source dialog box closes and the scanner you selected become
active scanner. 

To acquire images using a TWAIN scanner

1 When you scan an image, it appears in the active Canvas d
ment. Open an existing document or choose the New command
the File menu to create a new document.
25.1
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2 Choose Image > Acquire > TWAIN Acquire. A dialog box for
the scanner you are using appears. Refer to the scanner’s user m
for information on scanner options. 

3 Select the options you want in the scanner dialog box.

• Click Prescan to view a preview of the image. You can ve
ify that the image is aligned and completely visible and 
reposition it if necessary.

• Depending on the available options, you can adjust scali
and brightness of the image.

4 Click Scan to begin scanning. When the scanner finishes, th
scanned image appears in the active Canvas document. 

Using scanners with plug-in acquire modules
Canvas is a plug-in host program, which means that you can use
scanners that work with acquire modules that are Photoshop plug
compatible. You first should install the acquire module for your sc
ner so it is available to Canvas. Once Canvas recognizes an acq
module, its name appears in the Image > Acquire submenu.

To locate the plug-ins folder for Canvas

Canvas looks for plug-ins, including acquire modules, in the Canv
Tools folder. To tell Canvas to look for plug-ins in another location
use the Plug-ins button on the Painting tab in the Preferences dia
box. 

1 Choose File > Preferences.

2 In the Preferences dialog box, click the Painting tab and the
click the Plug-ins button. 

3 In the directory dialog box, navigate to the folder where plug
ins are stored on your hard disk. Click the button labeled Select
“ folder name” (Mac), or select a plug-in module and click Open 
(Windows).

4 Click OK to close the Preferences dialog box.

5 Exit and then re-start Canvas to activate the plug-in module

Acquiring multi-frame GIF files

When you acquire a GIF file with multiple frames, Canvas display
dialog box so you can choose which frames to acquire. Enter a ra
.2 SCANNING, SIZING, AND TRACING IMAGES
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in the text boxes, and then click OK. Canvas places the specified
frames in the document.

To acquire images using plug-ins

1 When you scan an image in Canvas, the image appears in 
active Canvas document. Either open the document you want to
use, or use the New command to create a new document.

2 Choose Image > Acquire and select a plug-in acquire modu
in the Acquire submenu. 

Note: If you do not see your scanning device in the menu, make s
that its acquire module is in the correct folder; see “To locate the 
plug-ins folder for Canvas,” above.

3 After selecting a device, a dialog box with options for your sca
ner appears. Refer to the scanner’s user manual for information o
these options and information on using the scanner; some comm
settings are described below.

4 Adjust the settings in the scanner dialog box and click Scan
Using scanners to acquire images 25.3
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Deciding on a scanning resolution
Digital images are composed of square pixels, and pixel size is a
major factor affecting image quality. The resolution of an image is
expressed as the number of pixels per (linear) inch, abbreviated p
or pixels per centimeter. Smaller pixels result in higher image res
tion, which generally indicates better image quality. With scanned
images, the resolution is also a measure of how much information
been captured from the original artwork.

At relatively low resolution, such as 75 ppi, lines, edges, and cha
ter shapes in an image can appear jagged (see “About digital ima
and resolution” on page 25.5). Scanning at higher resolution pro-
duces smoother images, which also require more memory and di
space.

Use the following questions to help you decide what resolution is
appropriate when you scan images.

Scanning options

Plug-in acquire modules for 
scanners offer various options. 
Some standard scanning 
options are described here.

Scan Mode or Color Mode. 
Choose color, black and white, 
or grayscale. These options 
correspond to the RGB Color, 
Grayscale, and Black & White 
image modes in Canvas. 

Resolution. Specify the scan 
resolution in pixels (or dots) 
per inch. Scanning at higher 
resolution captures more 
image information and results 
in higher memory and disk 
storage requirements.

Scaling. Enter a scaling per-
centage to reduce or enlarge 
the image.

A Use the preview area to 
check the image and make sure 
the area you want to scan is po-
sitioned correctly. 

B Many scanners let you drag 
the corner of a scan rectangle to 
select the area that will be 
scanned. The selected area de-

termines the size of the image 
object in Canvas.

C Most scanners offer bright-
ness or exposure controls. Refer 
to the scanner documentation 
for more information on adjust-
ing exposure settings. 

C

B

A
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Are you scanning line art or text? Line art, such as pen and ink 
drawings, and high-contrast images with sharp edges or type, sh
be scanned at the highest resolution possible. Text scans that wi
processed with character-recognition software should also be 
scanned at high resolution for accurate translation.

What halftone screen frequency will be used for printing? For 
continuous-tone images (photographs), a common rule of thumb i
scan at a resolution of 1.5 or at most 2 times the screen frequenc
For example, for offset printing on newsprint at a screen frequency
85 lines per inch (lpi), an image should be scanned at 128 to 170
For images printed at 133 lpi, scanning resolution should be 200 
266 ppi. 

Talk with service bureaus and commercial printers about the scre
frequency used for your projects. With this information, you can le
Canvas calculate the optimal resolution for an image. See “Resam
pling and sharpening images” on page 25.13.

Will the final image be smaller or larger than the original? If 
you need to enlarge the image, you should scan it at a higher res
tion to retain the most information when you resize it. If you will 
reduce the size of the image, you can scan it at a lower resolution

Note: Because resizing tends to blur an image, you can use the 
Unsharp Mask filter to sharpen it. For more information, see 
“Sharpen filters” on page 27.20. 

About digital images and resolution

Digital images, also known as 
raster and paint images, are 
composed of tiny square pix-
els. 

The number of pixels that fit in 
a linear inch or centimeter is 
the image resolution. The reso-
lution indicates how much 
information is in the image, 
independent of the resolution 

used to display the image on 
screen or to print it.

Low-resolution images have 
larger pixels and look more 
jagged than high-resolution 
images. However, while high-
resolution images look 
smoother, they also require 
more memory and disk space.

Vector 72 ppi

300 ppi 600 ppi
Using scanners to acquire images 25.5
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Changing image size 
You can use several methods to resize or scale paint objects and
images they contain.

Keep in mind that altering the size or resolution of a paint object c
degrade the quality of an image. Canvas uses interpolation to est
mate pixel values when necessary, but this can result in loss of sh
ness or detail when large scaling factors are applied.

The best way to avoid image degradation is to avoid changing im
size or resolution.

• If an image is too big for a particular layout, consider crop
ping the image, rather than resizing or scaling it to fit. 

• If a photographic image requires higher resolution, try re-
scanning the original at a higher resolution, rather than 
increasing the resolution in Canvas.

If you resize, skew, or rotate a paint object, you can restore the o
nal shape and resolution by choosing the Remove Effects comm
in the Effects menu.

Stretching images with the mouse

You can change the size of a paint object by clicking it with the 
Selection tool and dragging a selection handle. Stretching an ima
non-proportionately also stretches the pixels, which can cause 
unwanted distortion to the image. 

Scaling images using the Scale command

You can change the size of a paint object by selecting it and choo
Scale in the Object menu. The Scale command lets you maintain
object’s proportions, or distort an image by scaling it in one directio
Using the Scale command does not add or remove pixels from an
image. For information on using Scale, see “Scaling objects” on 
page 10.31.
.6 SCANNING, SIZING, AND TRACING IMAGES
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Using the Crop command to change image size
You can adjust the overall size of an image using the Crop comm

• When you enlarge an image, Canvas adds white pixels. 

• When you reduce an image, Canvas crops out pixels and
discards the image data.

1 Select a paint object (not in edit mode) and choose Image >
Area > Crop. A dialog box displays the current size, width, and 
height.

2 Under New Size, enter the size you want the image to be. Y
can use percent, pixel, inch, centimeter, point, or pica values.

3 To set the position of the resulting image, click a square in t
Placement grid. For example, to crop the image from the right s
and bottom, click the upper-left square in the Placement grid. To
expand the image on all sides, click the center square.

4 Click OK to resize the image. If you are reducing the image
area, Canvas warns you it will delete pixels; click OK to proceed

Using the Trim command to remove borders
The Trim command lets you remove same-color pixels that are n
the edge of the image area. This feature is useful for removing 
unwanted white space or other borders that are not part of the ma
image. For example, you scan a photo that doesn’t fill the entire s
ner area, and there is a white border around the photo. The Trim c
mand identifies the edges of the image, determines which pixels 
around the border match, and deletes the unwanted border.

Note: Canvas alerts you if the image can’t be trimmed because a 
der can’t be found.

◆ To trim an image: Select one or more paint objects to trim, an
then choose Image > Area > Trim. Canvas removes the border.

Using the Crop tool to change image size
You can use the Crop tool to select a rectangular part of an image
hide the rest. This is called a “soft crop.” When you edit a soft-
cropped image, the cropped area reappears while the image is in
mode. When you finish editing, Canvas re-crops the image.

You can also use the Crop tool to “hard-crop” an image, which ad
or removes pixels, as an alternative to using the Area > Crop com

You can specify relative or 
absolute measurements in the 
Image Crop dialog box

Crop tool 
Changing image size 25.7
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mand. See “To remove pixels when cropping an image” on 
page 25.9, and “To add pixels with the Crop tool” on page 25.9.

To crop without deleting pixels

1 Select the Crop tool in the Painting Tools toolbar and point 
the image you want to crop.

2 With the crop pointer, click the image. Canvas displays a re
angle with hollow handles. This cropping rectangle defines the o
side edges of the image after cropping.

3 Position the cropping rectangle to frame the part of the imag
that you want to keep.

• Drag a corner handle to resize the cropping rectangle.

• Drag a side to move the cropping rectangle. The pointer 
changes to a hand when you point to a side.

4 Press Esc to crop the image, or click in the image. Canvas 
hides the part of the image outside the cropping rectangle.

To restore a cropped image

You can select a paint object and choose Remove Effects in the 
Effects menu to remove a soft crop. Or, use the following procedu

1 Click the image with the Crop tool. Canvas displays the full 
image area and the cropping rectangle. 

2 Drag the corner handles outward so the entire image is insi
the cropping rectangle, and then Press Enter (Mac) or Esc (Win
dows), or click in the image.

A gavel appears in crop 
mode when the pointer is 
in the image. Click to 
complete the crop.

This symbol appears if 
the pointer is outside the 
image in crop mode

A hand appears in crop 
mode when you point to 
a side of the cropping 
rectangle. Drag to move 
the rectangle.

The soft crop pointer 
indicates cropping will be 
temporary

The hard crop pointer 
indicates cropping will be 
permanent

Cropping an image

Adjust the cropping rectangle 
with the Crop tool by 
dragging a handle. Enclose 
the area you want to keep, 
and then press Esc to hide the 
cropped part of the image.

Cropping rectangle
.8 SCANNING, SIZING, AND TRACING IMAGES
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To remove pixels when cropping an image

In hard-crop mode, the Crop tool discards pixels that are outside 
cropping rectangle.

1 Select the Crop tool in the Painting Tools toolbar and Com-
mand-click (Mac) or Ctrl-click (Windows) the image you want to
crop. Canvas displays a cropping rectangle around the boundar
the image. 

2 Position the cropping rectangle so it frames the part of the 
image you want to keep.

• Drag a handle to resize the cropping rectangle.

• To move the cropping rectangle, point to any side, and th
pointer changes to a hand. Drag the cropping rectangle t
reposition it.

3 Press Esc or click in the image to complete the crop.

To add pixels with the Crop tool

1 Select the Crop tool in the Painting Tools toolbar and point 
the image you want to crop.

2 Command-click (Mac) or Alt-click (Windows) the image you
want to enlarge. Canvas displays a cropping rectangle with holl
square handles at the corners.

3 Drag the handles of the cropping rectangle to enlarge it 

4 Press Esc or click in the image to complete the crop.

Note: If the paint object you crop is an Indexed mode object, the 
color of the added pixels is the last color in the color table associa
with the image, which often is black.

✔Tip
You can quickly crop or expand 
a paint object using the Selec-
tion tool. Select the paint 
object (don’t put it in edit 
mode), then Ctrl-drag a handle 
to crop or add pixels to the 
image. When you drag, the 
cropping rectangle and han-
dles appear. When you release 
the mouse, Canvas applies a 
hard crop.
Changing image size 25.9
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To quickly crop an image with the Selection tool

You can quickly crop or expand a paint object with the Selection 
tool. 

1 When a paint object is selected (not in edit mode), point to a
handle, and then press Ctrl and drag the handle. When you dra
cropping rectangle appears.

2 Drag inward to crop (cut away) part of the object. Drag out-
ward to add pixels and expand the object. Release the mouse bu
to complete the operation.

You can constrain the cropping rectangle as you drag.

• To constrain the height and width of the cropping rectang
proportionally, release the Ctrl key, and then press Shift 
while dragging.

• To constrain the height and width of the cropping rectang
symmetrically from the center, release the Ctrl key, and 
then press it again while dragging.

• To constrain the height and width of the cropping rectang
both proportionally and symmetrically, release the Ctrl ke
and then press Ctrl+Shift while dragging.

Changing resolution
You can change the resolution of paint objects in two ways: 

• If you do not want to change an object’s size, you can resa
ple the image. Resampling merges or divides pixels.

Crop rectangle

Adding a white border

When you press a modifier 
key and click with the Crop 
tool, you can expand a paint 
object. This adds a white 
border to an RGB Color or 
CMYK Color image.

New border
.10 SCANNING, SIZING, AND TRACING IMAGES
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• If you want to preserve all the data in an image, you can 
change the object’s resolution and allow its size to change

Decreasing resolution (“down sampling”) decreases file size by d
carding data. This can result in lost detail. However, it’s common 
reduce resolution in some situations. For web pages and other ap
cations where images are displayed on a monitor, 72 ppi is the st
dard resolution.

Rarely, an image is resampled to increase resolution. This should
avoided because additional pixels are created by estimating their
color values, which does not improve an image.

The Resolution dialog box has compact and expanded states. In 
compact state, you can easily change the resolution of multiple p
objects without needing to specify additional options.

Note: When more than one paint object is selected (unless the obj
are the same size and resolution), the button that displays additio
options in the Resolution dialog box is not available.

To change resolution by resampling

This procedure reduces resolution of paint objects for use on a w
page or in a presentation.

1 Select one or more paint objects. These objects can vary in s
and resolution.

2 Choose Image > Area > Resolution. The Image Resolution d
log box appears in its compact state. 

3 To specify resolution, select pixels per inch or pixels per cent
meter and enter the resolution value in the text box.

4 Click OK. Canvas changes the resolution of the selected obje
which remain the same size.

To change resolution without resampling

Use this procedure to change the resolution of paint objects witho
resampling. This changes the size of objects while preserving the
image data.

1 Select one or more paint objects and choose Image > Area >
Resolution.

2 In the Image Resolution dialog box, select Preserve Data. En
the desired resolution in the text box and click OK. Canvas chang
the resolution of the selected paint objects.

Compact dialog box
Changing resolution 25.11
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If you reduce resolution, paint objects become larger because the
individual pixels are larger. If you increase resolution, paint objec
becomes smaller because the individual pixels are smaller.

To calculate resolution

If only one object is selected, you can calculate an appropriate res
tion based on a halftone screen frequency by clicking Auto in the
Image Resolution dialog box. Enter the screen frequency and cho
Draft, Good, or Best. Canvas calculates the resolution by multiply
the screen frequency by 1 (draft), 1.5 (good), or 2 (best). Click OK
enter the calculated resolution in the Image Resolution dialog box

Image resolution settings

You can specify the resolution, width, and height for a selected pa
object when the Image Resolution dialog box is expanded. You c
expand the dialog box when a single paint object is selected; if m
ple objects are selected, they must match in size and resolution.

Depending on the options you select, certain settings in the dialo
box can’t be changed. A bracket and chain icon indicate settings 
are linked and fixed.

Preserve Data Prevents resampling, or interpolation, when resolu
tion or size changes. Selecting Preserve Data also selects Prese
Proportions, so width and height can change only in proportion to
each other. 

Preserve Data means image resolution and size are relative; chan
the resolution will change the object size, and changing the size w
change the image resolution. 

If you select Pixels in the Width and Height menus, you cannot 
change these values, because the number of pixels cannot chan
when Preserve Data is selected.

Width and Height You can specify a size for the paint object by 
entering values in these text boxes. Select measurement units in
adjacent menus. 

The width and height boxes show the size a paint object will beco
if you change the resolution when Preserve Data is selected.

Preserve Proportions This option links the Width and Height val-
ues so that changing one value changes the other and maintains
original proportions of the paint object. Selecting Preserve Data a

Expanded dialog box
.12 SCANNING, SIZING, AND TRACING IMAGES
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selects this option. If you want to stretch a paint object in only one
direction, you must deselect Preserve Proportions.

To specify how Canvas approximates new pixels

When increasing image resolution, Canvas uses one of two meth
to calculate color values for the pixels it adds to an image. To cha
the method, use the Preferences command.

1 Choose File > Preferences. Select the Painting tab in the Pr
erences dialog box. 

2 Select an option under Interpolation and click OK. For more
information, see “Painting preferences” on page 9.4.

Original 300 ppi Resampled down to 150 ppi

150 ppi image with Unsharp 
Mask filter applied
Amount = 80
Radius = 1.6
Threshold = 0

300 ppi image with Unsharp 
Mask filter applied
Amount = 67
Radius = 1.6
Threshold = 0

150 ppi image resampled up 
to 300 ppi

Resampling and 
sharpening images

Resizing and resampling 
causes images to appear 
softer. However, you can 
apply the Unsharp Mask filter 
to bring soft images back 
into focus. For more informa-
tion, see “To apply the 
Unsharp Mask filter” on 
page 27.20.
Changing resolution 25.13
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Auto-tracing images
You can use the Auto Trace command to create vector objects fr
an image.

The Auto Trace command traces any channel of an image. The c
mand is available when a paint object is selected (not in edit mod

Auto-tracing is much faster than tracing an image by hand with th
Polygon or Curve tool, although you might need to edit the resulti
vector paths. 

When Canvas auto-traces a channel, it leaves the original image
unchanged. Canvas applies the current stroke to the resulting ve
objects. When the tracing is complete, you can move the vector 
objects away from the image.

Canvas auto-traces high-resolution images better than low-resolu
images. Auto-tracing an image with a resolution lower than 300 p
can produce jagged paths.

To auto-trace an image 

1 Select a paint object to trace and choose Image > Auto Trace

2 In the Auto Trace dialog box, choose the channel to trace fro
the Channel menu. The menu lists the channels contained in the 
image, including alpha channels. 

3 Select other settings to use for tracing, and then click OK to tra
the selected channel.

To save custom auto-trace configurations

Canvas provides preset configurations that you can choose from 
pop-up menu in the Auto Trace dialog box. You can also save yo
own tracing configurations so you can use the same settings aga

1 Select a paint object and choose Image > Auto Trace. 

2 In the Auto Trace dialog box, configure the options you wan
to save. Choose Save Settings in the pop-up menu. 

3 Type a name for the configuration in the dialog box and clic
Save. The configuration appears in configuration pop-up menu.

To delete custom auto-trace configurations

1 Select a paint object and choose Image > Auto Trace.
.14 SCANNING, SIZING, AND TRACING IMAGES
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2 In the Auto Trace dialog box, select the configuration you wa
to delete from the configuration pop-up menu.

3 Press the arrow pop-up menu and choose Delete Settings. 
the dialog box, click OK to confirm you want to delete the setting

Auto Trace settings

You can choose options and 
preset configurations in the 
Auto Trace dialog box.

A To use a preset configura-
tion, select its name in the 
pop-up menu. Preset configu-
rations and those you save ap-
pear in the menu. 

Channel. Choose a channel of 
the image to trace.

Curves or Polygons. Click an 
option to set the trace meth-
od. Curves creates paths with 
smooth anchor points as 
needed. Polygon creates 
paths without curved seg-
ments. Polygon can be better 
for tracing straight lines, but 
can make jagged shapes. 
Curves makes segments with 
fewer anchor points.

Fixed End. Aligns the trace 
with the end points of the 
image. Available when you 
select the Curves option. 

Corners. Creates corner 
points that let you modify one 
curve segment without affect-
ing the other. Use the Round-
Sharp slider to control the cor-

ner sensitivity. Available 
when you select the 
Curves option.

Smooth. Traces without 
corner points when the 
Corners option is off. If 
Smooth and Corners are 
on, angles within the speci-
fied sharpness are traced 
as corner points. Available 
when you select the 
Curves option.

Centerline. Traces one 
line through the middle of 
large solid areas instead of 
tracing along edges. Available 
when you select the Curves 
and Polygons options.

Filter. Prevents the tracing of 
small, random elements, such 
as tiny lines and dots. Avail-
able when you select the 
Curves and Polygons options.

Invert Map. Inverts lightness 
values (as in a negative image) 
of the channel for tracing. 
Available when you select the 
Curves and Polygons options

Loose-Tight. Drag the slider 
toward Tight for more exact 
tracing with more anchor 

points. Drag the slider toward 
Loose for a looser tracing with 
fewer anchor points.

Round-Sharp. Drag the slider 
toward Round to get rounder 
corners. Drag the slider toward 
Sharp to get sharper corners.

B Choose Save Settings to 
save the current settings as a 
configuration you can select 
later. Choose Delete Settings 
to delete the current configura-
tion. You can delete configura-
tions that you save.

Apply. Click to preview the 
trace.

OK. Click to trace the image.

A
B

Auto-tracing images 25.15



25

rmat 
le. 

 a 
ls 

 
aint 

 

Using Photo CD images in Canvas
Scanned images are available from many sources in Photo CD fo
because it’s widely supported, relatively inexpensive, and versati

When you place or acquire Photo CD images, you can select from
choice of standard dimensions. You can choose 192 by 128 pixe
(Base/16 format), 384 by 256 pixels (Base/4), 768 by 512 pixels 
(Base), or 1,536 by 1,024 pixels (Base * 4). 

Canvas imports Photo CD images as 72 ppi paint objects in RGB
Color mode. You can use the Resolution command to change a p
object’s resolution and dimensions.

To acquire a Photo CD image

1 Choose Image > Acquire > Kodak Photo CD. In the dialog 
box, select the file you want to acquire and click OK. The Kodak
Digital Science Acquire Module dialog box opens. 

Auto-tracing images

Canvas traces an image with 
curves or straight path seg-
ments. Auto-tracing usually 
produces several paths that 
follow various sections of the 
image.

After tracing, you can group 
and edit the resulting paths.

Original scan at 600 ppi resolution Paths created with the Auto Trace command

Selection handles 
(highlighted) surround 
the objects produced 
by auto-tracing the 
sailboat image
.16 SCANNING, SIZING, AND TRACING IMAGES
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2 Use the dialog box to select color correction, resolution, and
rotation options for importing the Photo CD image. 

• You can select source and destination image profiles by 
clicking the Source and Dest buttons. 

• To see details about scanning method and color correctio
click Info. 

• To see a larger preview, click Preview. 

3 To place the image in the current Canvas document, click O

Improving Photo CD images
Photo CD scans are specifically designed to reproduce photograp
images accurately. However, this means that a Photo CD image 
exhibit the same problems, such as soft focus and color casts, tha
be seen in the original photograph. 

Kodak Digital Science Photo CD Acquire Module dialog box
Using Photo CD images in Canvas 25.17
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Some Photo CD collections provide better-quality images than ot
ers, but you can improve almost all images with a few simple step
The following procedure describes how to apply the Unsharp ma
filter to the Lightness (“L”) channel in LAB Color mode to sharpen
Photo CD image.

1 Use the previous procedure to acquire a Kodak Photo CD 
image into a Canvas document.

2 Select the image you just acquired and choose Image > Mod
LAB Color.

3 Double-click the image with the Selection tool to put it in ed
mode.

4 Choose Image > Show Channels to open the Channels pale

5 In the Channels palette, click the Lightness channel to activ
it. For more information, see “Activating channels” on page 26.2

6 Choose Image > Filter > Sharpen > Unsharp Mask. Select t
preview option and adjust the Amount and Radius until the chan
appears significantly sharper. Click OK.

7 If you plan to use special effect filters, choose Image > Mode
RGB Color to convert the image to RGB Color mode.

Lightness (L) channel selected in 
the Channels palette
.18 SCANNING, SIZING, AND TRACING IMAGES
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SELECTIONS AND CHANNELS

Canvas gives you several ways to select pixels in an image. Whe
you select groups of pixels by area or color, you can use painting
tools, filters, and special effects to modify the selected pixels witho
affecting the parts of the image that are not selected. 

This chapter describes how to make selections in images, save s
tions in alpha channels, work with color and alpha channels, and 
ate channel masks, which can make parts of images transparent

Selecting pixels in images
When a paint object is in edit mode, any filters, commands, and 
painting tools that you apply can affect the entire image. When yo
have selected pixels in the image, the effect of a tool, filter, or oth
adjustment is confined to the selected pixels.

You can select areas in an image using painting tools or menu co
mands. For example, you can make rectangular selections by dra
ging the Marquee tool in an image, and you can use the Color Ra
command to select groups of pixels based on color similarity. 

Selection borders

The selected pixels in an image are referred to collectively as a selec-
tion. When you make a selection, Canvas surrounds the selected
els with a moving dashed border. You can hide and display the 
border without affecting the selection. To hide the border, choose
Image > Select > Hide Edges. To display the selection border, cho
Image > Select > Show Edges.

Deselecting an image selection

When you use a selection tool in normal mode, making a new se
tion replaces any existing selection in an image. To deselect pixe
without making a new selection, choose Image > Select > None. Y
can also press Enter or Esc (Mac), or Esc (Windows) to deselect
selection. If a selection is floating, pressing Esc once defloats the
selection; pressing Esc again deselects all pixels. 

A dashed border outlines the 
selected area in a photograph
26.1
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Selecting all pixels in an image

You can apply painting tools and filters to an entire image withou
first making a selection. But you can also select all the pixels in a
image when you want to work with them as a selection. To select
pixels, with a paint object in edit mode, choose Image > Select > A
A selection border appears around the entire image.

Using selection tools
You can use the Marquee, Oval Marquee, Row Selection, Colum
Selection, and Lasso tools to select areas in images. 

The Marquee tool selects rectangular areas. The Oval Marquee t
selects oval areas. The Column Selection tool selects a single ver
column of pixels. The Row Selection tool selects a single horizon
row of pixels. The Lasso tool selects areas that you outline.

The Marquee, Oval Marquee, Row Selection, and Column Select
tools are located in a toolbar that pops out from the Painting toolb
The Lasso tool is a separate icon in the Painting toolbar.    

These selection tools let you select any part of an image, from on
pixel to all the pixels in the image. By using modifier keys with the
tools, you can add to and subtract from selections, and select the
overlapping area of two selections. 

By subtracting a circle from a larger circle, for example, you can 
make a ring-shaped selection with an unselected area inside. Se
“Modifying selections” at the end of this section. 

To select rectangular or oval areas

1 Select the Marquee tool or the Oval Marquee tool. If the pain
object isn’t in edit mode, click it. 

2 Drag diagonally in the image; a selection rectangle or oval 
expands as you drag away from the starting point. When you rele
the mouse button, a dashed border outlines the selected area.

◆ To make a square selection: If no selection exists, press Shift 
and drag the Marquee tool in an image. If a selection exists in the
image, pressing Shift adds to the selection. 

◆ To make a circular selection: If no selection exists, press Shift 
and drag the Oval Marquee tool in an image. If a selection exists 
the image, pressing Shift adds to the selection.

A B C D

A Marquee
B Oval Marquee
C Row Selection
D Column Selection
.2 SELECTIONS AND CHANNELS
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◆ To expand a selection marquee from the center: If no selec-
tion exists, press Ctrl and drag the Marquee or Oval Marquee tool
Mac, press Ctrl after you begin dragging). You can press Ctrl+Sh
to constrain the selection marquee and expand it from the center

To select single rows or columns

1 Select the Row Selection tool or the Column Selection tool. If
the paint object isn’t in edit mode, click it. 

2 Click a single pixel to select all pixels in the same row or colum
in the image. A dashed border outlines the selected row or colum
Or, press and hold the mouse button to see a selection outline, a
move the pointer to position the selection outline. Release the mo
button to set the selection, and a dashed border outlines the sele
row or column.

When working in high-resolution images, you can zoom to 400% 
magnification or higher to see the pixels you want to select.

To select areas with the Lasso

1 Select the Lasso tool. If the paint object isn’t in edit mode, clic
it. 

2 Drag in the image to outline a selection. Canvas connects the
starting and ending points with a straight line. A dashed border ou
lines the selected areas.

◆ To define a polygon selection: Press Option (Mac) or Alt 
(Windows) as you click several points around the area you want t
select. Canvas connects the points you click with straight segmen

Lasso options

To set options before using the Lasso tool, double-click the Lasso
tool icon. In the dialog box, choose from the following options and
click OK.

Feather Radius To soften the edge of selections made with the 
Lasso tool, enter the feather range in pixels in the Feather Radius
box.

Anti-Aliased To slightly soften the edge of selection made with th
Lasso tool, select the Anti-Aliased checkbox.

Omit Background Color To keep pixels that match the current 
background color from being selected by the Lasso tool, select th
Omit Background Color checkbox. This option can help you isola

Lasso tool
Selecting pixels in images 26.3
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an image that is surrounded by a solid color background. Use the
Color Dropper tool to pick up the background color before you us
the Lasso tool to make the selection.

Modifying selections

After you make a selection using any selection technique, you ca
use modifier keys to alter the selection with the Marquee, Oval M
quee, Row Selection, Column Selection, and Lasso tools.

◆ To add to a selection: Press Shift when you use a selection 
tool. A “+” symbol indicates that the tool will add the new selectio
to the existing selection. 

◆ To subtract from a selection: Press Command (Mac) or Ctrl 
(Windows) when you use a selection tool. A “-” symbol indicates 
that the tool will subtract the new selection from the existing selec
tion.

◆ To select part of a selection: Press Shift+Command (Mac) or 
Shift+Ctrl (Windows) when you use a selection tool. An “x” symbo
indicates that the area you select in the existing selection will rem
selected. If none of the new selection is part of the existing select
Canvas deselects all pixels.

You can also use Shift or Ctrl to constrain a selection when you a
subtract, or intersect a selection. To do this, press the keys to add
subtract, or intersect and begin dragging. While still pressing the 
mouse button, release the keys and then press the constraint key
continue dragging.

Selecting areas based on color
You can use the Wand tool and the Color Range command to se
pixels in an image according to color. To select a contiguous area
similarly colored pixels, use the Wand tool. To select all pixels of 
particular color, use the Color Range command.

To use the Wand tool

1 Select the Wand tool in the Paint Tools toolbar and point to t
object you want to edit. If the paint object is not in edit mode, th
pointer becomes a hand ( ). Click the object to put the image
edit mode. The pointer becomes a wand.

2 Click the color area you want to select.

Wand tool
.4 SELECTIONS AND CHANNELS
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◆ To add to a selection: Shift-click the Wand in the image. The 
pointer displays a ‘+’ to show that it adds to the current selection.

◆ To subtract from a selection: Command-click (Mac) or Ctrl-
click (Windows) the Wand in the image. The pointer displays a wa
with a ‘-’ to show that it subtracts from the current selection.

To adjust the tolerance of the Wand tool

You can broaden or narrow the range of colors the Wand tool sel
by adjusting its tolerance. A tolerance of zero, for example, selec
pixels that exactly match the color of the pixel you click.

◆ To configure the Wand tool: Double-click the Wand tool icon. 
In the Wand dialog box, type a tolerance value from zero to 255. 
smooth the edges of the selection, turn on the Anti-Aliased option

Selecting a color range
You can use the Color Range command to select all areas of sim
color in an image. The command creates a grayscale selection m
similar to an alpha channel. 

You can use the Load and Save buttons in the dialog box to work
with color range selection files. The file format that Canvas uses f
these files is compatible with Photoshop Color Range files. On W
dows, these files use the extension AXT.

To select a color range interactively

1 With a paint object in edit mode, choose Image > Select > 
Color Range.

2 In the Color Range dialog box, choose Sampled Colors in th
Select pop-up menu.

3 Adjust the Fuzziness setting. To select pixels of exactly the 
same color, set the Fuzziness to zero. Increase the Fuzziness t
widen the range of colors to be selected.

4 Click a color in the preview image in the dialog box. Canvas
selects a range of similarly colored pixels, depending on the Fu
ness setting.

• To add colors to the selection, click the ‘+’ dropper icon, 
then click a color in the image in the dialog box.

• To subtract colors from the selection, click the ‘-’ dropper
icon, then click in the image in the dialog box.
Selecting areas based on color 26.5
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5 To view the selected pixels, click the Selection option. Gray
areas indicate pixels that the Color Range command selects at 
reduced opacity. Filters and painting tools affect these areas to 
lesser degree than areas that are 100 percent selected. Click O
apply the selection to the image.

Selecting unselected areas
You can use the Inverse command to simultaneously select all pi
not in the current selection while deselecting the current selection

◆ To select areas not included in the current selection:
Choose Image > Select > Inverse.

Color Range options

Use this dialog box to select 
image areas based on color.

A Select. In the pop-up 
menu, choose the color (red, 
green, blue, cyan, magenta, 
yellow), or tonal range (shad-
ows, midtones, highlights) you 
want to select. 

To select a color interactively 
by clicking in the preview win-
dow, choose Sampled Colors.

B Fuzziness. When using the 
Sampled Colors option, enter a 
low value to select a narrow col-
or range; enter a higher value 
to select a wider range. 

C Choose Selection to pre-
view the selection, with white 
representing selected pixels, in 
the preview window. Choose 
Image to see the actual image 
so you can sample colors with 
the dropper.

D With Sampled Colors cho-
sen (A), click the dropper in the 

preview window to select col-
ors. Use the ‘+’ dropper to add 
to the selection; use the ‘-’ drop-
per to subtract from it.

E Selection Preview. Choose 
an option to preview the selec-
tion in the image itself (or 
choose None for no preview). 
Grayscale shows the selection 
as it would appear in a channel, 

with white for selected pixels 
and black showing non-select-
ed areas. 

The Matte and Mask options 
show the original colors in 
selected areas. In non-selected 
areas, Black Matte shows 
black, White matte shows 
white, and Mask shows trans-
parent red. 

D

E

A

B

C

.6 SELECTIONS AND CHANNELS
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Expanding selections with Grow and Similar 
The Grow and Similar commands let you expand selections to 
include similar colors in an image. These commands compare th
colors outside a selection to the colors in the selection. Colors tha
in a specified range of similar colors are added to the selection.

The Grow and Similar commands are available for all image mod
except Black & White. 

The Grow command selects similar colors that are contiguous to 
current selection. The Similar command selects similar colors any
where in the image. 

The range of colors selected by Grow and Similar is based on the
Tolerance setting in the Wand dialog box. 

◆ To select colors contiguous to the current selection: Choose 
Image > Select > Grow. 

◆ To select colors throughout an image: Choose Image > 
Select > Similar.

You can repeat the Grow and Similar commands to continue exp
ing a selection. As more colors are added to the selection, more c
ors are in the range of colors similar to the selection. Therefore, e
though the Tolerance doesn’t change, repeating Grow or Similar 
expand a selection incrementally. 

Grow and Similar can help you isolate elements in an image, suc
dark objects against a light background. Select part of one dark ob
with the Marquee tool. Choose Grow to expand the selection to th
entire object. Choose Similar to expand the selection to all simila
colors in the image.

A moving dashed 
edge surrounds 
the black star, a 
selected area/ 

When the 
selection is 
inversed, the 
gray background 
becomes 
selected
Selecting areas based on color 26.7
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Converting paths to selections
You can use vector objects and text to make selections in images
The Path to Selection command makes a selection in an image f
the shape of a vector, text, or group object. 

With this command, you can outline irregular areas in images wit
drawing tools to make selections. You can make selections shap
like starbursts and other complex shapes that are easy to create 
drawing tools. You can make selections from text characters with
first converting the text to paths.

The area selected by a vector or text object depends on whether 
object has a visible fill ink and stroke.

• A filled object will select the area covered by the fill. If the
object also has a visible stroke, the selection will include t
area covered by the stroke.

• An unfilled object will select the area covered by just the 
stroke of the object.

• An object without a visible fill or stroke will not select any
thing.

The type of fill ink or pen ink applied to an object is not significant
for the selection it will make. However, the shape of the stroke is 
nificant. A visible pen, dash, parallel, or neon stroke will affect the
shape of the resulting selection. Also, the end caps, line joins, an
arrows applied to a stroke will affect the selection.

To convert a path to a selection

1 Draw or position a vector or text object on a paint object whe
you want to make a selection. 

Note: If you want to preserve the vector or text object, make a cop
of it; the object will be deleted when it is converted to a selection.

2 Select both the vector object and the paint object.

3 Choose Image > Path to Selection.

4 The vector or text object is replaced by a selection. The pai
object is in edit mode and the selection is outlined by a dashed 
der.
.8 SELECTIONS AND CHANNELS
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Converting objects to paths

Most objects drawn with vector tools are paths that can be used t
create selections in images. However, some objects must be con
verted to paths first.

If an object does not create a selection when you choose Path to
Selection, you might need to convert the object to a path by selec
the object and choosing Object > Path > Convert to Paths.

Working with image selections

After you make a selection, you can clear it, soften its edges, mak
floating, move it, and change its opacity. 

Clearing and copying a selection
You can replace the pixels in a selection with the current backgro
color by pressing the Delete key, or by choosing Cut in the Edit 
menu. (The Cut command also transfers the selection to the Clip
board.) Canvas replaces the selected pixels with the color curren
displayed in the background color icon. Keep in mind that “deletin
a selection doesn’t leave a hole or transparent area in the paint ob
unless the paint object has a visibility mask, as described later in 
chapter. 

To place a copy of a selection on the Clipboard without clearing t
area in the original image, choose Edit > Copy. When a selection
been placed on the Clipboard, you can paste it into another paint
object in edit mode, where it will become a floating selection, or 
paste it into the document to create a new paint object.

Feathering the edges of a selection
You can feather (soften) the edges of a selection so that it blends
more naturally into the original image. You can use the Feather c
mand to soften the hard edge of a selection and spread the selec
over a larger area.

1 With a paint object in edit mode, make a selection and choo
Image > Select > Feather. 

2 In the Feather dialog box, enter the number of pixels to feath
the selection in the Radius text box. The larger the Radius value
the more Canvas softens the selection edge.

3 Click OK to feather the selection. 

✔Tip
If you want Canvas to recall a 
selection, be sure to save it 
before leaving edit mode. See 
“Saving and loading selections 
in channels” on page 26.16.
Working with image selections 26.9
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Pasting into selections
The Paste Into command pastes the Clipboard contents into a se
tion in an image. This includes a selection in an image channel o
channel mask attached to an object.

The Paste Into command pastes anything that you copy to the Cl
board, including a vector, text, or paint object, an image selection
a segment of a vector object.

You can use Paste Into to composite images and create effects t
would otherwise be difficult to produce. For example, to simulate 
picture on a television screen in a photograph, you can select the
screen area and paste an image into the selection. You can move
pasted image within the selection to adjust the area that you see.

You can paste transparent objects into opaque images, or opaqu
objects into transparent images. The background of the image de
mines the opacity of the pasted selection.

To paste into a selection

1 Place an object or selection on the Clipboard by choosing Ed
Copy or Edit > Cut.

2 Make a selection in an image (or a channel mask), and choo
Edit > Paste Into. The Clipboard contents appear in the selection

3 You can drag the pasted item or press the arrow keys on the 
board to move it, to display the areas you want to see. When you
ish adjusting the selection, deselect it to merge it into the image.

Object with a symbol fill ink Feathered selection Object pasted into selection
.10 SELECTIONS AND CHANNELS
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Floating and moving selections
You can move and manipulate a selection without affecting the or
nal image by making it a floating selection. 

When a selection is floating, it sits on an invisible plane above the
original image. When you type text in an image, or paste an objec
from the Clipboard, Canvas makes the text or pasted item a float
selection. 

Moving a selection that is part of the original image creates a float
selection, but also leaves behind an area filled with the backgrou
color.

◆ To float a copy of a selection: Make a selection in an image 
and choose Image > Select > Float. 

Deselecting and defloating selections

Deselecting a floating selection makes it part of the original image
To deselect a floating selection, press Esc or Enter twice (Mac) o
Esc twice (Windows), or choose Image > Select > None.

To make the floating selection part of the image but still retain the
selection, you can press Esc or Enter (Mac) or Esc (Windows), o
choose Image > Select > Defloat.

Moving selections 

To move a selection, you can press the keyboard arrow keys or d
the selection with the Marquee, Lasso, or Wand tools. If a selectio
not floating, it becomes floating when you move it. 

To keep the pointer from interfering with your view of a small sele
tion, select the Remote Move tool in the Painting toolbar and drag
anywhere in the drawing area. Canvas moves the selection in the
direction you move the pointer.

✔Tip
To float a selection and fill 
behind it with the background 
color, hold down Option (Mac) 
or Alt (Windows) and choose 
Image > Select > Float. 

Dragging a selection floats it and 
leaves an area filled with the 
current background color (A).

A

Remote Move tool
Working with image selections 26.11
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Changing the opacity of floating selections
You can change the opacity of a floating selection and make the 
els behind it partially visible. You can also change the mode to pr
duce different effects. Note: You cannot make selections partially 
transparent in Indexed or Black & White image modes.

1 With a paint object in edit mode, select part of the image.

2 From the background color palette icon in the toolbox, selec
color to use behind the floating selection. This color will start to 
appear when you make the selection transparent.

3 Hold down the Option key (Mac) or Ctrl key (Windows) and 
choose Image > Select > Float. Canvas floats the selection and
behind it with the background color.

4 Choose Image > Show Channels to open the Channels pale
Set the Floating Opacity value to less than 100 percent to make
selection become transparent and reveal the background color 
behind the selection.

5 To change the mode, choose a new mode from the Mode p
up menu.

Modifying selections
You can use the Expand, Contract, Smooth, and Border command
modify selections in images. 

These commands make it easy to fine-tune a selection by expan
or contracting the selection border by a specified number of pixels
by adding or subtracting pixels based on color.

Expanding a selection

You can expand a selection by adding a specified number of pixel
the selection border.

To modify an active selection, choose Image > Select > Modify >
Expand. Type a value in the Radius text box and click OK. Canva
adds the specified area to the selection. 

Contracting a selection

You can shrink a selection by subtracting a specified number of p
els from the selection border.

To modify an active selection, choose Image > Select > Modify >
Contract. Type a value in the text box and then click OK. Canvas

Floating Opacity slider in the 
Channels palette

✔Tip
To use the Floating Opacity 
slider in the Channels palette to 
lighten a floating selection, fill 
behind the selection with white 
or a light color.
.12 SELECTIONS AND CHANNELS
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subtracts the specified area from the selection and the dashed bo
contracts.

Smoothing a selection

The Smooth command is useful after you have made a color-bas
selection that has left stray pixels inside or outside of the selected
area. The Smooth command includes or eliminates the stray pixe
even out the selection. The value you type in the text box determ
which pixels will be included or excluded in the selection at the bo
der.

To modify an active selection, choose Image > Select > Modify >
Smooth. Type a value in the text box and then click OK. Canvas a
or subtracts pixels to the perimeter of the selection based on the 
radius number of pixels you specified.

Bordering a selection

After you define a selection, you can select the area at the borde
the selection by specifying an offset in pixels from the selection ed

To modify an active selection, choose Image > Select > Modify >
Border. Type a value in the text box and click OK. Two dashed bo
ders indicate the selected border.

Once you make a selection, you can use the Grow command or t
Similar command to expand the selection to include similar colors

Creating objects from selections
You can make new paint objects from image selections with the N
Image from Selection command. This command converts a selec
in an image into a new paint object in the same position on the im
you are editing. This can be useful for “layering” image composi-
tions.

The result of New Image from Selection is similar to moving a sel
tion to a transparent “layer,” a procedure used in some image edi
programs. In Canvas you can use separate transparent paint obje
create “layered” image compositions.

Note: This operation doesn’t affect the Clipboard contents.

◆ To create a paint object from a selection: With a selection in 
an image, choose New Image from Selection in the context menu
display the context menu, right-click (Windows) or Ctrl-click (Mac
in the document. 
Working with image selections 26.13
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New images from selections and floating selections

When you choose New Image from Selection, Canvas removes t
selection from the image or deselects the selection in the image. 
selection appears as a new paint object in the same location. 

Whether a selection is removed from an image depends on whet
the selection is floating. The opacity of the resulting object also di
fers for floating and non-floating selections.

If a selection is not floating, Canvas deselects it but otherwise doe
change the original image when you create an object from the se
tion. The selected pixels keep their original opacity in the new obj

If a selection is floating, Canvas removes the selection. The effec
the same as deleting a selection: the background color replaces t
selected pixels, or, if the object has a visibility mask, a clear back
ground replaces the selected pixels. In the new object, the pixels
opaque, regardless of their original opacity.

Clear backgrounds in new paint objects

A paint object created from a selection always has a clear, rather 
opaque background, and a visibility mask. 

Paint objects are rectangular. If a selection is not rectangular, Can
places the selection on a clear background. This is why creating 
paint object from a selection is like transferring the selection to a 
clear overlay on the original image. 

If you select Preserve Visibility in the Channels palette, a visibility
mask preserves the transparency of all pixels in the image. You c
paint or use filters without affecting clear areas.

If Preserve Visibility is not selected, you can erase to a clear back
ground and affect all pixels by painting and editing.

Converting selections to paths
Canvas can trace a selection in an image to create a path (vector
object) from the selection border. The Selection to Path comman
traces the active image selection border using the settings you sp
ify. This is useful if you want to convert a selection border to a vec
object that can be used as a clipping path, for example. 

The accuracy of a path made from a selection depends on the set
you specify and the complexity of the selection border. A very com
.14 SELECTIONS AND CHANNELS
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plex selection border can result in a path with hundreds of ancho
points, which can cause problems in printing and other operation

Paths created from selections have no fill ink, black pen ink, and 
current stroke setting.

To convert a selection to a path

1 Make a selection in an image.

2 Choose Image > Selection to Path.

3 In the dialog box, choose the settings you want and click OK
The dialog box options are described below.

4 The selection in the image is deselected and a new vector 
object (or group of vector objects) appears in front of the paint 
object.

Selection to Path options

A dialog box presents the following options when you use the Se
tion to Path command.

Mask Set Threshold If a selection edge is feathered, this value 
defines the edge of the selection for tracing based on selection m
opacity. Enter a value from 1 (nearly transparent) to 255 (opaque
These values correspond to the lightness of pixels for a selection
saved as a mask in a channel.

Pixels in the selection mask that are more opaque (lighter) than t
threshold value are treated as opaque and part of the selection. P
that are less opaque (darker) than the threshold value are treated
transparent and outside the selection. At a threshold of 1, the ent
feathered edge will be part of the selection. At 255, only the com-
pletely opaque part of the selection will be included.

If a selection is not feathered, this value has no effect.

Curves / Polygons Choose Curves to create paths with smooth 
anchor points and curve segments as appropriate. Choose Polyg
to create paths with straight segments only. The Curves option ca
result in smoother paths with fewer anchor points when the selec
border has curves.

Loose /Tight Drag the slider to set the tolerance for tracing irregu
larities in the selection border. Loose follows the selection border l
precisely (more smoothly) and creates fewer anchor points. Tight
Working with image selections 26.15
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lows the selection border more precisely (less smoothly) and crea
more anchor points.

Round /Sharp Drag the slider to set the tolerance for tracing cor-
ners in the selection border. Round creates rounder corners, Sha
creates sharper corners.

Saving and loading selections in channels
When you have made a selection in an image, you can create an
alpha channel from the selection. An alpha channel preserves the
shape and opacity of a selection, so you can use it to make the s
selection in the image again. 

You can think of an alpha channel as a mask that selects some a
and protects other areas from painting and image editing. Becaus
alpha channels make precise selections of varying intensities, alp
channels let you control which areas in an image will be affected 
painting tools and filters, and the intensity of the effects.

When you view an alpha channel, you see a grayscale image. W
the channel is made from a selection, it contains white areas repr
senting fully selected pixels, black areas representing unselected
els, and gray areas representing pixels that are partially selected,
the gray lightness values corresponding to the selection opacity.

This section describes how to save a selection in a channel, and 
to load a channel to make a selection in an image, using dialog bo
You can also use shortcuts in the Channels palette, as described
under “Channels palette options” on page 26.21.

To save a selection in a channel

1 With an active selection in an image, choose Image > Selec
Save.

2 In the Operation area of the Save Selection dialog box, sele
New Channel and click OK.

You can also click the Selection button ( ) in the Channels pale
to save the current selection in a new channel.

To load a selection from a channel

1 With a paint object in edit mode, choose Image > Select > 
Load. 
.16 SELECTIONS AND CHANNELS
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2 In the Load Selection dialog box, choose a channel name in
Channel pop-up menu. To invert the selection, click Invert. 

3 Choose an option in the Operation area and click OK.

Preserving channels in exported images
Canvas image channels are compatible with the alpha channels 
in other image-editing programs, including Adobe Photoshop. Ho
ever, you must use the correct procedure to preserve alpha chan
when you export an image into Photoshop format.

If you want to export an image into Photoshop format and preserv
the image’s alpha channels, be sure to use the Export command i
Image menu, rather than the Save As command.

If you use the Save As command and choose Photoshop format,
resulting file will not contain the alpha channels associated with th
image.

To export an image with alpha channels

1 Select the paint object in the Canvas document.

2 Choose Image > Export > Photoshop. A directory dialog bo
appears.

3 Specify a location to save the file, type a file name, and clic
Save to export the selected image as a Photoshop file.

Understanding image channels
Canvas uses up to 24 channels to store the digital information tha
makes up the image in a paint object. 

Option Result

New Selection Removes any current selections and cre-
ates a new selection

Add to Selection Preserves the current selection and selects 
additional pixels based on the channel

Subtract from Selection Removes pixels from the current selection 
based on the channel

Intersect with Selection Creates a new selection composed of pix-
els that appear in both the current selec-
tion and the channel you are loading
Saving and loading selections in channels 26.17
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There are three types of channels: color or image channels, alph
channels, and channel masks. All images have at least one chan
An image can also contain one or more alpha channels and a sin
channel mask, if you create them.

The Channels palette displays the channels of an image. Whene
an image is in edit mode, you can use the Channels palette to se
and edit channels. To display the Channels palette, choose Imag
Show Channels.

Vector objects and text objects do not have color or image chann
However, you can create a channel mask for any object. If an obj
has a channel mask, you can place the channel mask in edit mod
and use the Channels palette to work with the channel mask and
ate alpha channels. Alpha channels are stored with an object as 
as the object has a channel mask.

Color channels

Images in RGB Color, CMYK Color, and LAB Color mode have 
separate color channels. A color channel stores one component o
image. For example, in CMYK Color mode, the Magenta channel
stores the magenta parts of the image. This channel contains the
image that would appear on the magenta plate if you output color
separations.

A paint object’s image mode determines the number of color cha
nels. RGB Color images have Red, Green, and Blue color chann
CMYK Color images have Cyan, Magenta, Yellow, and Black cha
nels. LAB Color images have Lightness, A, and B channels.

In the Channels palette, a composite channel appears above the 
channels. The composite channel represents the complete image
the composite of the image’s color channels. The composite chan
is labeled RGB, CMYK, or LAB, depending on the image mode.

Other image modes do not have separate color channels. Image
Black & White, Duotone, Indexed, and Grayscale mode have a sin
image channel.

Alpha channels

Alpha channels are channels you can use to store and edit selec
in any image. Because alpha channels are used for image select
they are also referred to as “selection masks.” 
.18 SELECTIONS AND CHANNELS



n in 
me 

d res-
n-

e of 

 pix-
ter 

n 
el 

lays 
en 

; to 
nels.

 
, 
 

 
ask 

-
 an 
s. 
or 
han-
After you make a selection in an image, you can save the selectio
an alpha channel. Later, you can load the channel to make the sa
selection.

An alpha channel is a grayscale channel that is the same size an
olution as the paint object in which it is stored. Pixels in alpha cha
nels can range in lightness from 0 (black) to 255 (white). The 
lightness levels of pixels in an alpha channel correspond to a rang
selection levels.

Black pixels in an alpha channel correspond to masked, or non-
selected, pixels in an image. White pixels correspond to selected
els. Gray pixels correspond to various levels of selection, with ligh
grays corresponding to greater selection than darker grays. 

Note: If you want black pixels to correspond to selected, rather tha
masked pixels, click Selected Area in the New Channel or Chann
Options dialog box.

Using the Channels palette
The Channels palette displays the channels contained in a paint 
object when the paint object is in edit mode. The palette also disp
the channels contained in any object that has a channel mask wh
you edit the mask.

You can use the palette to create, duplicate, and delete channels
change channel options; and to make selections by loading chan

◆ To open the Channels palette: Choose Image > Show Chan-
nels.

Composite channel Select the first channel in the palette to make
all color channels visible and active. Paint objects in CMYK Color
RGB Color, and LAB Color modes have composite channels. The
channel is labeled “CMYK” for a CMYK Color image, “RGB” for 
an RGB Color image, and “LAB” for a LAB Color image.

Paint objects in Indexed, Grayscale, Black & White, and Duotone
modes have single channels. A vector object that has a channel m
has an “object channel.”

Color channels Color channels appear below the composite chan
nel in the Channels palette. Color channels store the color data in
image. The image mode determines the number of color channel
CMYK Color images have Cyan, Magenta, Yellow, and Black col
channels. RGB Color images have Red, Green, and Blue color c
Using the Channels palette 26.19
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nels. LAB Color images have “A” and “B” color channels and a 
Lightness channel. Multichannel images have numbered channe
that contain grayscale pixels only.

Alpha channels Alpha channels contain grayscale pixels which 
can represent a selection. You can use alpha channels to create 
nel masks. Any paint object can have alpha channels. However, p
objects in Black & White mode must have a channel mask before
they can contain alpha channels.

Channel mask 

A special channel you can add to any object, a channel mask cont
grayscale pixels that represent transparency. Drag a color or alpha
channel to the channel mask slot to create a channel mask. You ca
drag a channel mask into the channel list to create a new alpha cha

Viewing previews in the Channels palette

To view previews in the Channels palette, choose Palette Option
the palette’s pop-up menu. Click the size of the preview you want
display, or click None. Click OK to close the dialog box.
.20 SELECTIONS AND CHANNELS
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Channel palette pop-up menu

The following commands appear in the Channel palette’s pop-up
menu. 

Palette Options Lets you select the channel preview size.

New Channel Creates a new alpha channel and lets you select 
channel options.

Duplicate Channel Creates a new alpha channel from a single 
active color or alpha channel. This command isn’t available if a co
posite channel or more than one channel is active.

Delete Channel Deletes the active alpha channel. You can’t dele
color channels or a composite channel.

Channels palette options

Use the Channels palette to 
work with channels when a 
paint object is in edit mode.

Active channels are shaded. 
Editing affects the active chan-
nels only. To make a channel 
active, click the channel name.

A Composite channel. Select 
this channel to make all color 
channels visible and active.

B Color channels. Color 
channels appear below com-
posite channels. 

C Alpha channels. Alpha 
channels contain grayscale pix-
els which represent a selection.

D Channel mask. A special 
channel you can add to any ob-
ject, a channel mask contains 
grayscale pixels that represent 
transparency.

E An eye indicates that a 
channel is visible. If a channel is 

not visible, click or drag in 
the column to make it vis-
ible.

F Drag to resize the 
Channels palette.

G Click to make a new 
alpha channel with de-
fault settings. Drag an al-
pha channel here to du-
plicate it.

H Click to save the cur-
rent selection in an alpha 
channel. Drag a channel 
here to make a selection 
in the image from the 
channel.

Floating Opacity. If a 
selection is floating, drag 
the slider to change the 
opacity of the selection.

Mode. If a selection is floating, 
select a mode from the menu. 
The default mode is Normal.

I Drag channels to the trash 
to delete them. You cannot de-

lete color channels.

Preserve Visibility. Select this 
option to preserve the transpar-
ency of clear and partially trans-
parent pixels when you edit an 
image.

F

G H I

A

B

C

D

E

Using the Channels palette 26.21
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Channel Options Lets you specify options for the active channel.
You can change the name, mask tint color, and opacity of an alph
channel. You also can double-click a channel to set options for it.

Working with alpha channels

To add to the current selection, Shift-drag a channel to the button

To subtract from the current selection, Command-drag (Mac) or C
drag (Windows) a channel to the button. 

To select the intersection of a channel and the current selection, p
Command+Shift (Mac) or Ctrl+Shift (Windows) and drag a chann
to the button.

Creating and deleting channels
You can create and delete channels in the Channels palette. To d
play the Channels palette, choose Image > Show Channels. 

To create an alpha channel

1 With a paint object in edit mode, choose New Channel in the
pop-up menu at the lower-right corner of the Channels palette.

2 In the New Channel dialog box, select options for the new ch
nel and click OK. See “To specify channel options” on page 26.23

Deleting alpha channels 

Although Canvas can store up to 24 channels in an image, you m
want to delete unnecessary ones to save memory and disk space
can delete alpha channels and channel masks, but you cannot de
color channels.

◆ To delete an alpha channel: With an object in image edit 
mode, drag the alpha channel you want to delete to the trash can
at the bottom of the Channels palette

Alpha channel; white 
indicates selected area

Alpha channel loaded 
as selection (in color)

Applied blend affects 
selected area only

Original image

Channels pop-up menu
.22 SELECTIONS AND CHANNELS
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Customizing alpha channels
You can change an alpha channel’s name, color indication, and m
tint opacity in the Channel Options dialog box. By default, Canvas
numbers alpha channels, sets the mask tint opacity to 50%, and 
assigns a mask color.

Note: Canvas provides the mask color and opacity settings in the
Channel Options dialog box as visual aids only. These settings do
affect the original image or channel.

To specify channel options

1 With a paint object in edit mode, choose Image > Show Cha
nels to open the Channels palette.

2 Click an alpha channel and select Channel Options in the pop
menu, or double-click the channel you want to edit to open the 
Channel Options dialog box.

3 To rename the channel, type a new name in the Name text b

4 The options in the Color Indicates area control whether whit
or black pixels in the channel will select pixels in the image whe
you load the channel. 

• If you want white pixels in the channel to indicate selecte
pixels, choose Masked Area. 

• If you choose Selected Area, the normal operation of the
channel will be inverted, so that black pixels in the chann
will select pixels when the channel is loaded. If you use th
option, keep in mind that the channel will make selection
that are the inverse of normal channel selections.

5 To change the mask tint color for the channel, select a colo
from the Color pop-up menu. Canvas displays the tint when an 
alpha channel and at least one other channel are visible. To chan
the opacity of the tint color, enter a value from 1 to 100% in the 
Opacity text box.

6 After entering the settings you want, click OK.

Activating channels
To edit a channel, click the channel name in the Channels palette
make it active. Canvas uses shading to indicate that a channel is
active. Painting tools and filters affect active channels only.
Customizing alpha channels 26.23
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• You can make more than one channel active by Shift-clic
ing the names of the channels in the palette. 

• To make a channel visible but not active, click the left co
umn to make an eye icon appear. 

• You can make more than one channel visible by dragging
the left column in the Channels palette.

To make all color channels in an image both visible and active, cl
the composite channel in the Channels palette. The composite ch
nel always appears first at the top of the Channels palette.

Editing an alpha channel
You can apply painting tools, filters, and effects to the image in an
alpha channel. By editing the image, you can adjust what the cha
will select when you load it as a selection.

1 With an image in edit mode, choose Image > Show Channe

2 Create a new channel to use as a selection mask by doing 
of the following:

• If you have a selection in the image that you want to cus-
tomize by editing in a channel, use the Save command to
create a channel from the selection; see “To save a selec
in a channel” on page 26.16.

• To start with a “blank” alpha channel, use the New Chann
command. Be sure to choose the Masked Area option un
Color Indicates in the New Channel dialog box.

3 In the Channels palette, click the new channel to activate it.
The channel appears shaded in the palette and the image chang
show only the channel. Now click in the left column of the first 
(composite) channel. The original image appears with a transpa
colored “mask” on the image. The color mask indicates the area
that will be masked — not selected — by the channel.

4 Use painting tools or filters to edit the image in the channel.
The changes you make affect the active channel only. 

5 To make a selection with the channel, load the channel by 
choosing Image > Select > Load. Choose the channel name in 
pop-up menu and then click OK.

Canvas displays a shaded mask 
representing an alpha channel 
when the alpha channel and the 
composite channel are visible

Shaded mask
.24 SELECTIONS AND CHANNELS
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Channel masks
Channel masks apply transparency effects to objects, including p
objects, vector objects, text objects, and group objects. A channe
mask creates transparency in proportion to the luminance of its 
image. 

A channel mask is a grayscale image channel. Black pixels in a c
nel mask produce 100% transparency in corresponding areas of 
masked object. White pixels in a channel mask produce 0% trans
ency in the masked object. Gray pixels in a channel mask produc
partial transparency in the masked object. Darker grays produce 
greater transparency than lighter grays.

Channel masks are powerful because they let you use painting a
image-editing techniques to create transparency effects, and bec
a channel mask can be applied to any type of object. An object’s 
channel mask is the same size as its bounding box. You can deta
delete an object’s channel mask to eliminate the transparency eff

Creating channel masks
You can use the mouse, the New Channel Mask command, the 
Transparency palette, or the Channels palette to make channel m

To create a channel mask

Do one of the following:

• Option+double-click (Mac) or Ctrl+double-click (Windows)
the object to be masked. (If the object already has a chann
mask, Canvas places the channel mask in edit mode.) 

• Select the object to be masked and choose Object > Trans
ency > New Channel Mask. 

• Select the object to be masked. In the Transparency palet
choose Channel in the Mask pop-up menu. 

Canvas creates the channel mask and puts the new mask in edit
mode.

• If the object is a paint object, Canvas creates a channel m
with the same resolution as the paint object.

• If the object is a vector, text, or group object, the New Mas
dialog box appears. Type the resolution you want for the 
channel mask and click OK. Canvas creates the channel m
with the specified resolution. 
Channel masks 26.25
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To use the Channels palette

You can create a channel mask for a paint object from an existing
alpha channel or color channel.

With a paint object in edit mode, drag an alpha channel into the ch
nel mask slot in the Channels palette. If the slot already contains 
channel mask, the channel you drag there replaces the existing c
nel mask.

Editing channel masks
You can edit an object’s channel mask to change the transparenc
effects it produces. Generally, you can do anything that you can 
when editing a color channel, alpha channel, or grayscale image:
painting tools, filters, and image-adjustment commands, make se
tions, and paste selections into a channel mask.

To edit a channel mask

Do any of the following to place a channel mask in edit mode:

• Option+double-click (Mac) or Ctrl+double-click (Windows)
the masked object. 

• Select the masked object and choose Object > 
Transparency > Edit Channel Mask.

• Select the masked object and click Edit in the Transparenc
palette.

When you finish editing a channel mask, press Esc to leave edit 
mode.

Detaching and deleting channel masks
If an object has a channel mask, the channel mask controls the tr
parency of the object. You might want to detach or delete the chan
mask to eliminate the transparency effects from the object. 

When you delete a channel mask, it no longer exists in the docum
When you detach a channel mask, it appears in the document as
separate grayscale paint object.

◆ To detach a channel mask: Select the masked object. Choose
Object > Transparency > Detach Mask. 

When you detach a channel mask, Canvas removes the channel 
from the object and places it in the document as a separate grays
paint object. If the channel mask was detached from a vector obje
.26 SELECTIONS AND CHANNELS
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the resulting paint object will contain any alpha channels that wer
contained in the vector object.

To delete a channel mask

1 Select the masked object. 

2 In the Transparency palette, choose None in the Mask pop-u
menu.

Note: Deleting the channel mask of a vector, text, or group object
also deletes any alpha channels that were contained in the objec
Also, if you ungroup a group object that has a channel mask, Can
deletes the channel mask.

You can delete a paint object’s channel mask when the paint obje
in edit mode by dragging the channel mask to the trash can icon a
bottom of the Channels palette.

Transparency effects with channel masks 
Channel masks let you add transparency to images without alteri
them permanently. A channel mask creates transparency without
changing any pixels in an image. You can remove a channel mas
eliminate the transparency effect at any time.

To make an image transparent

To make parts of an image transparent — to eliminate the back-
ground in a photograph, for example — you can create a channe
mask from a selection. This procedure explains how to transfer a
selection into a channel mask to make selected areas transparen

1 Choose Image > Show Channels to open the Channels palet
Double-click the paint object to put it into edit mode. You can use
various techniques to select the areas you want to be transparen

• You can click the Wand tool to select similar colors throug
out the image. If a photograph has a colored background, 
example, click the background to select it. You can also us
the Color Range command to make a selection.

• To soften the edges of the selection, you can use the Imag
Select > Feather command.

2 Click the Selection button in the Channels palette to save the
selection in a new alpha channel. In the alpha channel, white pixe
correspond to the selection. (A partial selection produces gray pix
in the channel). Black pixels in the channel correspond to unselec
Transparency effects with channel masks 26.27
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areas of the image. To create transparent areas from the selectio
you need to invert the channel.

3 Press Esc to deselect the selection in the image. Then, click 
alpha channel in the Channels palette to make it active. Choose 
Image > Adjust > Invert. This reverses the white and black areas 
the channel.

4 Drag the alpha channel into the Channel Mask slot in the Cha
nels palette. Black areas in the channel mask produce transparen
areas in the image. White areas in the channel mask produce op
areas in the image. 

5 Press Esc to exit image edit mode. The selection you made i
now transparent. If you place the paint object on a background in
your document, the background will be visible through the transp
ent areas of the image.

To create a transparency fade

You can create a transparent fade effect using a channel mask. T
procedure explains how to create a blend in an alpha channel, an
then create a channel mask to make an image fade to transparen

1 Choose Image > Show Channels to open the Channels palet
Double-click a paint object to put it in edit mode.

2 Click the New Channel button in the Channels palette. A new
alpha channel appears in the palette. Click the channel to make i
active. 

3 Select the Blend tool. With the foreground color set to white a
the background color set to black, drag vertically from top to botto
in the channel. This creates a blend from white to black. 

• You can change the distance that you drag the Blend tool 
the channel to adjust the length and position of the fade to
transparency.

• You might need to use the Blend dialog box to select the L
ear option for the Blend tool before you create the blend in
the alpha channel. You can also set other options for the 
Blend tool to fine-tune blends.

4 Drag the alpha channel into the channel mask slot in the Cha
nels palette. White pixels at the top of the channel produce opaqu
areas. Black pixels produce completely transparent areas. Gray p

Drag a channel into the Channel 
Mask slot
.28 SELECTIONS AND CHANNELS
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in the channel mask correspond with partially transparent areas in
image.

To create a channel mask by rendering

Canvas can create a channel mask when you render a vector, gr
paint, or text object. To create the mask, choose the Mask and Tr
parency options in the Render dialog box. Canvas will create a ch
nel mask that makes blank areas around and inside the objects 
transparent.

When you make a new paint object by pasting a non-rectangular
selection copied from an image, Canvas makes a channel mask 
hide white pixels surrounding the selection.

Preserving transparency in images
You can select the Preserve Visibility checkbox in the Channels p
ette to preserve transparency when you paint or apply filters to an
image. The Preserve Visibility checkbox is available when you ed
paint object that has a visibility mask. A paint object has a visibilit
mask if it was created with a transparent background, or if you 
applied a visibility mask with the Add Visibility Mask command. 

If a paint object has an opaque background, the Preserve Visibilit
checkbox is dimmed and can’t be selected.

To preserve transparency while editing an image

When a paint object is in edit mode, select Preserve Visibility in th
Channels palette. When the option is selected, you can paint and
the image without affecting clear areas or reducing the transpare
of partially transparent pixels.

Note: If an image is completely clear (contains no colored pixels),
you cannot alter the image when Preserve Visibility is selected.

Channel mask from alpha channelOriginal Vignette
Transparency effects with channel masks 26.29
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The Preserve Visibility option affects all aspects of image editing.
When Preserve Visibility is selected, pasted selections do not affe
clear areas. Also, a pasted selection will match the transparency 
the existing pixels when you defloat the selection. 

You must deselect Preserve Visibility to paint in clear areas of an
image. Then, if you want to edit the painted areas, select Preserv
Visibility again. 

For example, you can deselect Preserve Visibility and paint airbru
strokes in a clear image. Then, select Preserve Visibility and you 
paint over the airbrush strokes to change their color, without losin
the soft edge or “spilling” color into clear areas.

When Preserve Visibility is selected and you use the Eraser tool,
els you “erase” are painted with the current background color; the
are not erased to clear. 

Also, when you use any painting tool to apply color, you cannot 
make pixels more or less transparent. This is why you cannot app
any color in clear areas when Preserve Visibility is selected. 

When you select Preserve Visibility, you can paint and apply filter
to modify pixels that are less than 100% transparent. You can cha
the hue, saturation, and intensity of pixels but can’t change their 
transparency.

To paint or apply filters to an entire image, deselect Preserve Vis
ity. This turns off the visibility mask and lets painting tools and filte
affect the entire image.
.30 SELECTIONS AND CHANNELS
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IMAGE ADJUSTMENT AND 
CORRECTION

You can adjust images in Canvas using built-in filters and third-pa
plug-ins. For example, you can use the Levels filter to adjust imag
highlights and shadows, and sharpen scanned photos with the 
Unsharp Mask filter.

This chapter describes the commands you can use to adjust ima
color and brightness. It also describes commands for sharpening
softening, and refining images. 

Applying image-editing commands
You can apply most image-editing commands to a single paint ob
if it’s selected or in edit mode.You can also apply most commands
multiple selected paint objects. You can set image modes, apply 
ters, and adjust settings for multiple paint objects at the same tim

In most cases, a command affects an active selection, or an entir
image if nothing is selected in edit mode.

Note: When you apply an image-editing command to more than o
selected paint object, you can’t use the Preview option if the dialo
box has it. Preview is available when a single image is in edit mo

The following summarizes how image-editing commands can be 
applied. 

• Mode commands let you set the image mode for one or m
selected paint objects.

• You can convert multiple objects to image proxies.

• The Crop command and the Proxy Info command can’t be
applied to multiple objects.

• The Resolution command sets the resolution for one or m
selected objects.

• The Trim command trims one or more selected paint objec

• You can apply filters to one or more selected paint objects
a single paint object is in edit mode, a filter applies to the 
entire image or an active selection.
27.1
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• The Histogram command can be applied to paint objects i
edit mode only.

• Many commands in the Adjust submenu can be used to u
formly adjust one or more selected paint objects, or a pain
object in edit mode.

Working with image-adjustment dialog boxes
Some dialog boxes for image-editing commands include histogra
and preview options to help you achieve the effect you want.

Understanding histograms

A histogram plots the relative number of pixels in each brightness
level in an image.

In the histogram above, shorter bars on the left indicate that the 
image doesn’t contain large areas of very dark pixels. Higher bar
toward the right of the graph show that the image does contain la
areas of medium and very bright pixels. 

◆ To view an image’s histogram at any time: With an image in 
edit mode, choose Filter > View > Histogram.

Using the Preview option

Most dialog boxes for image-adjustment commands include a Pre
view check box. Select the Preview option to see how settings af
the image. Preview is available only when a single paint object is
edit mode.

Consolidating colors
The Threshold and Posterize commands let you consolidate colo
values in an image or selection. Besides producing interesting eff

Brightness levels

Amount of pixels

Minimum (0) Maximum (255)

More

Fewer

✔Tip (Mac OS only)
When working with large imag-
es, you can improve speed by 
using video LUT animation 
instead of previews; see “Paint-
ing preferences” on page 9.4.
.2 IMAGE ADJUSTMENT AND CORRECTION
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with these commands, you can use them in alpha channels to he
isolate areas within an image.

If you select an area within an image, Canvas applies the adjustm
only to that area. Otherwise, Canvas adjusts the selected paint 
objects.

Setting a brightness threshold
You can use the Threshold command to convert any image to bla
and white. The Threshold command compares each pixel’s brigh
ness value to a threshold value that you set. It changes brighter p
to white and darker pixels to black. The threshold setting is based
a scale of brightness values from 0 (black) to 255 (white). You ca
use the Threshold command on images in Black & White or Index
mode.

For example, if you set a threshold value of 128, pixels that are 
brighter than medium gray become white, while pixels darker tha
medium gray become black.

To map an image to black and white

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image is 
affected.

2 Choose Image > Adjust > Threshold. 

3 In the Threshold dialog box, enter the threshold value by dr
ging the slider or typing a number in the text box. If you want Ca
vas to convert half the pixels to black and half to white, click Au

4 After entering the setting you want, click OK.

To isolate selections, you can apply the Threshold command in c
junction with the High Pass filter to an image in an alpha channel
See “Isolating areas using the High Pass filter” on page 28.10.

Creating high-contrast ‘posterized’ images
You can condense the brightness variations in an image with the 
terize command. If you apply the Posterize command to a photo-
graph, it creates a high-contrast image by compressing hundreds
brightness levels into only a few. You set the number of brightnes
levels you want to retain, and Canvas reduces each color channe
that number of values.
Consolidating colors 27.3
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The Posterize command’s effect depends on the mode of the ima
you posterize. 

For example, if you apply the Posterize command with a setting o
levels to a grayscale-mode image, the image becomes black and
white. If you apply the same setting to an RGB-mode image (eve
it contains only grays), the command converts each pixel’s red, 
green, and blue value to either zero or full color, reducing the ima
to eight colors — red, green, blue, red-green, red-blue, blue-gree
black, and white. You can’t use the Posterize command on image
Black & White or Indexed mode.

To posterize an image

1 Select one or more paint objects to posterize all the images
You can select an area in one image in edit mode to posterize t
selected area only. If you don’t make a selection, the entire imag
affected.

2 Choose Image > Adjust > Posterize.

3 Enter a level from 2 to 255. Higher numbers produce subtle
effects. Lower numbers produce high-contrast images.

4 After you enter the Levels setting, click OK.

Changing color and contrast 
You can use the Invert, Desaturate, and Brightness/Contrast com
mands to create special effects and correct lightness levels in ima
These commands apply changes equally to all color values. 

Original RGB image Posterize 4 levelsPosterize 8 levels Posterize 2 levels
.4 IMAGE ADJUSTMENT AND CORRECTION
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If you select an area of an image, Canvas applies the command to
area only. Otherwise, Canvas applies the command to the entire 
image in a paint object.

Inverting colors in images
You can use the Invert command to reverse the colors in an imag
in a photographic negative. The command converts each pixel’s c
into its opposite hue in the color spectrum. It does this by invertin
the brightness value of each pixel in each color channel.

For example, if a pixel is pure red, its brightness levels are 255, 0
in RGB mode. When inverted, this pixel’s brightness values beco
0, 255, 255, changing it to pure blue-green, its opposite in hue.

The Invert command can be particularly useful in channel editing,
colored pixels can denote either masked or selected areas.

To invert an image

1 Select one or more paint objects to invert all the images. Yo
can select an area in one image in edit mode to invert the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected. This command doesn’t work with paint objects
Indexed mode.

2 Choose Image > Adjust > Invert.

Desaturating image colors 
You can use the Desaturate command to remove color from imag
completely, while retaining the relative brightness levels of shadow
midtones, and highlights. The command converts an entire image
shades of gray without changing the image mode.

To desaturate an image

1 Select one or more paint objects to desaturate all the image
You can select an area in one image in edit mode to desaturate

Invert filter 
examples
Changing color and contrast 27.5
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selected area only. If you don’t make a selection, the entire ima
in edit mode is affected. This command works with paint objects
RGB Color mode, CMYK Color mode, and LAB Color mode.

2 Choose Image > Adjust > Desaturate.

Adjusting brightness and contrast
You can adjust the brightness and contrast of an entire image or 
cific channels with the Brightness/Contrast command. Brightness
refers to the lightness of an image. Contrast is the difference in 
brightness between two pixels. 

Because the Brightness/Contrast command adjusts all pixels equ
you should avoid using it to lighten an image that appears too da
because the image can lose shadow detail. To preserve shadows
highlights when adjusting the brightness of an image, you can use
Levels or Curves commands. See “Levels” on page 27.7 and 
“Adjusting brightness curves” on page 27.9.

To use the Brightness/Contrast command

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected. This command doesn’t work with paint objects
Black & White mode or Indexed mode.

2 Choose Image > Adjust > Brightness/Contrast. 

3 Enter a Brightness value from -100 to 100. Higher values ca
wash out midtones and shadows. Lower values can dull highligh

4 Enter a Contrast value from -100 to 100. Increasing contras
moves the color values of pixels to the extremes of the brightne
spectrum. Decreasing contrast moves color values toward med
gray.

5 After entering the settings you want, click OK.

Color balance
The Color Balance command lets you adjust color in shadows, m
tones, and highlights. You can use it with paint objects in CMYK 
Color or RGB Color modes.
.6 IMAGE ADJUSTMENT AND CORRECTION



u 
ted 
 

ge 
 

hat 

rse, 

ly 

 by 
) to 
 in 

 

 

els.

 

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected.

2 Choose Image > Adjust > Color Balance.

3 Click Shadows, Midtones, or Highlights to select the tonal ran
you want to adjust. You can set the color levels independently for
each tonal range.

4 Drag a slider toward a color label to increase the amount of t
color. The letters indicate the primary color values: Cyan, Red, 
Magenta, Green, Yellow, and Blue. 

When you increase the amount of a color, you also reduce its inve
which is the color labeled at the other end of the slider.

5 Click Preview to preview the color adjustments. Preview is on
available if a single paint object is in edit mode.

6 Click OK to apply the settings. 

Levels
You can adjust the brightness of shadows, highlights, or midtones
using the Levels command. Brightness values range from 0 (black
255 (white). For colored pixels, brightness is the brightness value
each color channel.

The Levels command works with all image modes except Black &
White and Indexed.

To adjust levels

1 Select a paint object to adjust. You can select an area in the
image to adjust the selected area only.

2 Choose Image > Adjust > Levels.

3 Select a channel or combination of channels in the pop-up 
menu. The Levels command will affect only the specified chann

4 Do one or more of the following

Lighten highlights: Enter a positive number less than 255 in 
the right Input Levels box, or drag the white slider under the
histogram. Canvas assigns the maximum output level to all 
pixels on the right of the slider.
Levels 27.7
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Lighten shadows: Enter a positive number in the left Output 
Levels box, or drag the black slider under Output Levels to 
increase the minimum output level. This value becomes the
darkest value allowed in the image.

Darken highlights: Enter a positive number less than 255 in 
the right Output Levels box, or drag the white slider under O
put Levels to set the maximum output value. This is the brig
est value allowed in the image. You can darken highlights in
one color channel to bring brighter colors back into the printab
color range.

Darken shadows: Enter a number greater than zero in the lef
Input Levels box, or drag the black slider under the histogra
Canvas assigns the minimum output level to all pixels on th
left of the slider.

Adjust midtones: Enter a value in the center Input Levels bo
or drag the gray slider under the histogram. To lighten mid-
tones, enter a value from 1.01 to 9.99 or drag the slider to th
left. All pixels on the right of the slider will be brighter than 
medium gray. To darken midtones, enter a value from 0.1 to
1.00 or drag the slider to the right. All pixels on the left of th
slider will be darker than medium gray.

5 Click OK.

Saving and loading Levels settings

You can save Levels settings on disk to use again. For example, 
correcting a scanned photo, you can save the settings and use th
correct other images scanned from the same source. 

◆ To save Levels settings: In the Levels dialog box, click Save. 
Type a name for the settings file, select a location, and click Save

◆ To load previously-saved Levels: In the Levels dialog box, 
click Load. A directory dialog box opens. Locate the settings file y
want to open, and click Open. 
.8 IMAGE ADJUSTMENT AND CORRECTION
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Adjusting brightness curves
You can adjust the tonal range of an image with the Curves com-
mand. Unlike the Levels command, which can set the minimum, 
maximum, and median values, Curves adjusts the entire range o
ues. It lets you map input values to output values according to a l
(“curve”) on a graph. Curves provides the most control over the to
range of an image.

This command is not available when a paint object in Black & 
White mode or Indexed mode is selected.

In the Curves dialog box, brightness values range from 0 (black) 
255 (white), or 0 percent (white) to 100 percent (black). To switch
between these scales, click the grayscale bar under the graph.

A typical setting is a gentle S-curve (or inverted S-curve, dependi
on the scale you use), which adds contrast to an image without 
appearing too harsh.

Levels dialog box

You can use the Levels dialog 
box to control different 
aspects of brightness levels. 

A Choose an individual color 
channel or the composite chan-
nel.

B Type values in the Input 
Levels boxes or drag the slider 
under the histogram to set the 
minimum input level, midtone 
ratio, and maximum input level.

C Enter numbers in the text 
boxes or drag the sliders to set 
the minimum and maximum 
output levels. D The histogram graphs 

brightness levels for the select-
ed channel.

E Click Auto for Canvas to 
map the darkest values in the 
selection to black and the light-
est value to white. 

E

D 

B 

A 

B 

C 
Adjusting brightness curves 27.9
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To adjust brightness curves

1 Select one paint object to adjust. The paint object can be in e
mode. You can select an area in the image. If you don’t make a
selection, the entire image is affected.

2 Choose Image > Adjust > Curves.

3 In the Channel pop-up menu, select the composite channel
an individual channel to adjust. To adjust multiple channels, sel
the channels in the Channels palette first.

4 To change the shape of the existing curve, make sure the cu
button at the bottom-left is selected. 

• Click points that you want to keep the same

• Drag points on the curve that you want to change. Or, en
values in the Input and Output boxes. For example, to ke
midtones the same, click the center of the curve, then dra
other areas of the curve. To adjust midtones without affe

Curves dialog box

The graph shows how Canvas 
maps input brightness values 
to output values. Select Pre-
view to see the effect on the 
image.

A Choose a channel to adjust.

B The grayscale ramp shows 
the lightness scale, either 0-255 
(dark to light) or 0-100 percent 
(light to dark). Click the ramp to 
reverse the scale and the curve.

C Type brightness values in 
the Input and Output boxes. 
Or, drag the pointer (circled) to 
specify brightness values. Here, 
pixels of 157 brightness are 
lightened to 171.

D Click this icon and drag a 
point on the curve to reshape 
the curve. Click the curve to add 

up to 19 control points. Drag 
points off the curve to delete 
them.

E To draw a disconnected 
segment, click this icon and 

drag in the graph.

F With the pencil (E) select-
ed, click to smooth the curve.

D E

F

A

C

O
ut

p
ut

 

Input
B

✔Tip
To redraw the curve complete-
ly, or to create sharp changes 
in brightness for a tonal range, 
click the pencil and draw a new 
curve or segment.
.10 IMAGE ADJUSTMENT AND CORRECTION



k 

r 
to 

ther 

 
t a 

lor 

 
lor 

or 
ing highlights and shadows, click the quarter and three-
quarter points of the curve, and drag the middle.

5 If you draw disjointed segments with the pencil, you can clic
Smooth to create one continuous curve.

6 Click OK to apply the current settings to the image.

Saving and loading Curves dialog box settings

You can save Curves dialog box settings on disk to use again. Fo
example, after correcting the brightness curve for a particular Pho
CD image, you can save these settings and later apply them to o
images from the same source.

◆ To save Curves settings: In the Curves dialog box, click Save.
In the directory dialog box, type a name for the settings file, selec
location, and click Save.

◆ To load Curves settings: In the Curves dialog box, click Load. 
In the directory dialog box, locate the settings file and click Open.

Hue/Saturation
You can modify the tint and purity of specific colors with the Hue/
Saturation command. In terms of image editing, saturation refers to 
the amount of gray in colors. 

The Hue/Saturation dialog box varies slightly depending on the co
mode. For RGB Color and CMYK Color images, you can modify 
red, yellow, green, cyan, blue, or magenta color ranges. For LAB
mode images, you can modify blue, magenta, yellow, or green co
ranges. 

The Hue/Saturation command is available when you work with 
CMYK, RGB, or LAB Color mode images. Before choosing the 
Hue/Saturation command, make the composite channel active. F
more information, see “Activating channels” on page 26.23.
Hue/Saturation 27.11
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To adjust the hue of a color range

1 Select a paint object to adjust. You can select an area in the
image to adjust the selected area only.

2 Choose Image > Adjust > Hue/Saturation.

3 On the left of the dialog box, click the color range to adjust, 
click Master to affect all colors equally. 

4 To change the selected color, enter the amount of the color
shift, from -180 to 180 degrees, in the Hue text box. Negative va
ues indicate a counter-clockwise shift around the color wheel; p
tive values indicate a clockwise shift. For example, with the Mas
option selected, setting Hue to 60 changes red to magenta, mag
to blue, blue to cyan, and so on.

5 To apply the current settings to the image, click OK.

To adjust the saturation of a color range

1 Select a paint object to adjust. You can select an area in the
image to adjust the selected area only.

2 Choose Image > Adjust > Hue/Saturation.

3 Click the option button of the color you want to adjust, or clic
the Master option button to affect all colors equally.

4 Enter a value from -100 to 100 in the Saturation text box or 
drag the slider. Positive values decrease the amount of gray in 
selected colors. Negative values increase the amount of gray.

Hue/Saturation dialog box

A Choose the color to adjust. 
Click Master to affect all colors.

B Enter numbers in the text 
boxes or drag the sliders to ad-
just hue, saturation, and light-
ness.

C The color wheel illustrates 
changes made in the settings. 

D Turn on to add the same 
hue to the entire image.

A C

B

D

Color wheel
.12 IMAGE ADJUSTMENT AND CORRECTION
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5 To apply the current settings to the image, click OK.

To adjust the brightness of a color range

1 Select a paint object to adjust. You can select an area in the
image to adjust the selected area only.

2 Choose Image > Adjust > Hue/Saturation.

3 Choose a specific color range or choose Master to affect all
colors equally.

4 Enter a value from -100 to 100 in the Lightness text box or 
drag the slider. Positive values increase the amount of white in 
color range. Negative values decrease the amount of white.

5 To apply the current settings to the image, click OK. 

For more control of brightness adjustments, use the Levels or Cu
command. For more information, see “Levels” on page 27.7 and 
“Adjusting brightness curves” on page 27.9.

To colorize an image

You can use the Colorize option in the Hue/Saturation dialog box
tint an image. This applies the same hue and saturation to all pix
that are not 100 percent black or white. The Colorize option doe
not affect the lightness levels of pixels.

1 Select a paint object. You can select an area in the image to
adjust only the selection.

2 Choose Image > Adjust > Hue/Saturation.

3 Select the Colorize option. 

4 Enter a value from -180 to 180 degrees in the Hue text box.
Positive values shift counter-clockwise around the color wheel, 
negative values shift clockwise around the color wheel. For exa
ple, Hue 120 creates a green-toned image.

5 Enter a value in the Saturation text box or drag the slider. 

6 After entering the settings you want, click OK.

Color Equalization
You can graphically adjust the saturation of different color ranges
with the Color Equalization command. You can add or remove gr
Color Equalization 27.13
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from various color ranges in images in RGB Color mode, CMYK 
Color mode, and LAB Color mode.

To use the Color Equalization command

1 Select a paint object to adjust. You can select an area in the
image to adjust only the selected area. 

2 Choose Image > Adjust > Color Equalization.

3 Drag the handles in the window to change the saturation of 
color ranges. To increase saturation, drag upward. To decrease
uration, drag downward.

4 To increase the saturation of all colors, click Saturate. To 
decrease the saturation of all colors, click Desaturate. Click Nor
malize to return all colors to their original saturation. 

5 Click OK to apply the settings.

Blur filters 
Blur filters soften images by decreasing contrast between neighb
ing pixels. These commands work with all image modes except 
Indexed and Black & White.

To use Blur and Blur More

Blur slightly modifies an image. Blur More is about four times stro
ger than Blur. Both commands work with all image modes except
Black & White and Indexed.

1 Select one or more paint objects to blur. You can select an a
in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Blur or Blur More.

Gaussian and Average blur
You can create a softening effect by using the Gaussian Blur or A
age blur filters. Their effects are similar, but the Gaussian Blur filt
creates a more diffused effect than the Average blur filter.

Color Equalization window
.14 IMAGE ADJUSTMENT AND CORRECTION
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The Gaussian Blur filter changes the color value of each pixel by 
applying a weighted average based on the color values of pixels 
within a specified distance. Color values at the edge of the specif
distance influence the final color value less than closer pixels. 

The Average filter determines the new color value for each pixel b
equally averaging all color values within the specified radius. 

To apply Gaussian Blur or Average blur

1 Select one or more paint objects to blur. You can select an a
in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Gaussian Blur or Average.

3 Specify a radius value from 0.1 to 250.0 in the Gaussian Blu
dialog box, or 1 to 16 in the Average dialog box. Smaller radius 
values produce more subtle effects than larger ones.

4 Click OK.

Depending on the size of the radius, applying a Gaussian or Aver
blur can take longer than other Blur filters.

Motion Blur
The Motion Blur filter can create the effect of linear movement. Yo
can specify the direction and magnitude of the effect. This comma
works with all image modes except Black & White, Indexed, and
Duotone.

To apply motion blur

1 Select one or more paint objects to blur. You can select an a
in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Motion Blur. Adjust the set-
tings in the Motion Blur dialog box, and then click OK to apply th
filter and close the dialog box. 

Blur Blur More Average Gaussian
Blur filters 27.15
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Motion Blur settings
Direction Establishes the angle of the blur and the object “move
ment.” Enter a value from -90 to 90 degrees. You can drag the sl
or drag the solid dot inside the circle to set the Direction value. A 
value of 0 degrees creates a horizontal blur; 90 degrees creates 
tical blur.

Distance The magnitude of the blur. Enter a number from 1 to 99
or drag the slider to set the Distance. A lower number creates les
blurring.

Phase Establishes the apparent direction of movement by creatin
blurred trail that follows the object. Enter a number from -100 to 1
or drag the slider to set the Phase. Negative numbers create app
movement up and to the right. Positive numbers create apparent 
movement down and to the left.

Preview Displays the effect of the current settings.

Grayscale paint object Motion Blur: Direction = 0, Distance = 30, Phase = 12
.16 IMAGE ADJUSTMENT AND CORRECTION
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Radial Blur
The Radial Blur filter can create the effect of circular movement in 
image. This command works with all image modes except Black
White, Indexed, and Duotone.

To apply radial blur

1 Select one or more paint objects to blur. You can select an a
in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Radial Blur. Adjust the setting
in the dialog box, and then click OK to apply the filter.

Drag to set 
blur direction

Original Spin 5 Spin 20 Spin 50

Radial Blur
Blur filters 27.17
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Radial Blur settings

Spin Controls the magnitude of the apparent rotation in the imag
Type a number from 1 to 100 or drag the slider to set the value. O
drag the solid area inside the circle. Drag clockwise to simulate 
slower rotation; drag counterclockwise to simulate faster rotation a
produce more blurring.

Quality Higher quality creates a smoother image but takes more
time. The quality differences become more pronounced when the
image is enlarged or printed on standard size paper.

Select Draft for the fastest redraw. Select Good for average redra
speed and quality. Select Best when image quality is most import

Centering options These options let you set the rotation origin. 
Center In Image sets the origin at the center of the image. Center
Selection sets the origin at the center of a selection. “Offset from 
Center in Pixels” lets you type values to offset the origin from the 
center of the image or selection. Type vertical and horizontal offs
amounts in pixels in the text boxes. Negative horizontal offsets mo
the center to the left. Negative vertical offsets move the center up
Positive horizontal offsets move the center to the right. Positive ve
cal offsets move the center down.

Preview Displays the effect of the current settings.

Zoom Blur
The Zoom Blur filter can create the effect of movement in an imag
as if the scene were moving rapidly toward or away from the 
observer. The filter blurs along an axis perpendicular to the image
You can specify the depth, direction, and smoothness of the blur 
effect. This command works with all image modes except Black &
White, Indexed, and Duotone.

To apply zoom blur

1 Select one or more paint objects to blur. You can select an a
in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Zoom Blur. Adjust the setting
in the dialog box, and then click OK to apply the filter. 

Zoom Blur settings
Span Sets the depth, (length) of the zoom effect. Type a numbe
from 1 to 100 or drag the slider to set the value. A larger number s
ulates a greater zoom depth and a more blurred effect. 
.18 IMAGE ADJUSTMENT AND CORRECTION
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Zoom In/Out Establishes the direction of the blur effect toward o
away from the viewer. Type a number from -100 to 100 or drag th
slider to set the value. Negative numbers make the image appea
move closer; positive numbers make the image appear to move a

Smoothness Controls the quality of the transition of the blur effec
Type a number from 1 to 10 or drag the slider to set the value. A 
smaller number creates a smoother blur with fine color blending.

Centering options These options let you set the zoom origin. Ce
ter In Image sets the origin at the center of the image. Center in 
Selection sets the origin at the center of a selection. “Offset from 
Center in Pixels” lets you type values to offset the origin from the 
center of the image or selection. Type vertical and horizontal offs
amounts in pixels in the text boxes. Negative horizontal offsets mo
the center to the left. Negative vertical offsets move the center up
Positive horizontal offsets move the center to the right. Positive ve
cal offsets move the center down.

Preview Displays the effect of the current settings.

Zoom Blur applied to area
selected around center

Span: 25
Zoom In/Out: 25

Smoothness: 5
Blur filters 27.19
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Sharpen filters
Sharpen filters increase the contrast between adjacent pixels, wh
can make an image appear more distinct. These commands work
with all image modes except Black & White, Indexed, and Duoto

• The Sharpen filter modifies an image slightly. The effect o
the Sharpen More filter is about four times greater.

• The Sharpen Edges filter affects only high-contrast areas

• The Unsharp Mask filter provides additional control over 
the sharpening effect.

To sharpen an image

1 Select one or more paint objects to sharpen. You can selec
area in one image to sharpen the selected area only. 

2 Choose Image > Filter > Sharpen, and then choose a filter fr
the Sharpen submenu.

To apply the Unsharp Mask filter

1 Select one or more paint objects to sharpen. You can selec
area in one image to sharpen the selected area only. 

2 Choose Image > Filter > Sharpen > Unsharp Mask.

3 Enter 1 to 500 percent for Amount. Enter less than 100 perc
to sharpen the image slightly.

4 Enter 0.1 to 250 pixels for Radius. This is the size of the are
used to determine new color values for the original pixels. Smal
values focus the sharpening effect on high-contrast edges. 

5 Enter 0 to 255 levels for Threshold. Enter 0 to filter all pixels
Enter a larger value to filter only high-contrast edges.

✔Tip
Although the Sharpen and Blur 
filters have opposite effects, 
they do not negate each other. 
To reverse the effects of a 
Sharpen filter, choose Undo in 
the Edit menu.

Original Sharpen More 
applied 5 times 

Sharpen Edges 
applied 8 times 

Unsharp Mask 
Amount = 113
Radius = 4.5
Threshold = 0
.20 IMAGE ADJUSTMENT AND CORRECTION
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6 Click OK to apply the filter.

Adding and removing noise
In images, “noise” refers to randomly-colored pixels. Noise can b
good or bad. For example, you can apply noise to computer-gene
ated graphics to make them appear more photographic. You can
use a filter that removes noise to minimize the appearance of tiny
scratches or other artifacts present in the source material or intro
duced during digitizing. Noise commands work with all image 
modes except Black & White and Indexed.

To add noise to selections

1 Select one or more paint objects to adjust. Select an area in
image to adjust the selected area only. 

2 Choose Image > Filter > Noise > Add Noise.

3 Enter 1 to 999 for Amount to specify how far the color of the
noise can vary from the original color. 

4 Choose the Uniform or Gaussian distribution option:

• Choose Uniform to apply colors randomly picked within th
Amount specified. Canvas evenly distributes the color of 
the noise across a range of colors. This option gives the 
smoothest effect.

• If you want the noise to favor lighter and darker colors 
within the specified range, choose the Gaussian option. T
option creates a more pronounced effect than Uniform.

5 If you want to add noise of different brightness levels of the 
original color, select Monochromatic. 

6 Click OK to apply the noise settings.

Removing noise from selections
You can remove noise from an image or selection using the Med
Despeckle, or Dust & Scratches filters. The Median filter removes
noise by averaging the color of pixels. The Despeckle and Dust &
Scratches filters remove noise by selectively blurring regions of th
selection. 
Adding and removing noise 27.21
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To use the Median filter

On a pixel-by-pixel basis, the Median filter applies the median co
value of all pixels within the specified radius. Although the filter 
ignores extreme values in its computations, higher radius values 
still wash out an image. 

1 Select one or more paint objects to adjust. You can select a
area in one image to adjust the selected area only. 

2 Choose Filter > Noise > Median in the Image menu. 

3 Type a value from 1 to 16 in the Radius text box, or drag the
slider. Smaller radius values produce subtler effects.

4 Click OK.

To use the Despeckle filter 

The Despeckle filter can remove defects such as dust and other 
speckling in images. The filter blends pixels with the lightness valu
of neighboring pixels. It’s a good idea to select areas that need co
rection before applying the filter.

1 Select an area in an image to adjust. If you don’t make a se
tion, the entire image is affected. 

2 Choose Image > Filter > Noise > Despeckle.

3 Drag the slider or type a number in the text box to set the 
Threshold value. Higher values produce greater blending of pixe

To reduce dust and scratch marks

The Dust and Scratches filter can remove dust specks by replacin
pixel’s value with a median value. The filter does not change a 
pixel’s value unless the absolute value of the difference of its gray
value and the median gray value of its neighborhood is greater th
the Threshold. Larger numbers of pixels are replaced by the med
value when the Threshold is low.The practical effect of this is that
larger pixels regions (larger “specks”) are reduced or removed wit
lower Threshold. Therefore, you can use the Threshold to control
size of the artifacts you want to remove.

1 Select an area to adjust in an image. If you don’t make a se
tion, the entire object is affected. 

2 Choose Image > Filter > Noise > Dust & Scratches.
.22 IMAGE ADJUSTMENT AND CORRECTION



me-

 fil-
 

n 

 
-
n 
3 Enter a value from 1 to 16 in the Radius text box. Smaller 
radius values produce a subtler effect than larger ones.

4 Type a value from 0 to 255 in the Threshold text box. After 
entering the settings you want, click OK.

Smoothing video images
Because video images contain two interlaced pictures, you can so
times see a slight banding effect in images acquired from video-
recording devices. You can correct this by using the De-Interlace
ter and then applying the Unsharp Mask filter. De-Interlace works
with all image modes except Black & White.

To smooth video images

1 Select one or more paint objects to adjust. You can select a
area in one image to de-interlace the selected area only. 

2 Choose Image > Filter > Video > De-Interlace. 

3 Click Odd fields or Even fields to select bands to eliminate.

4 Choose a replacement method for the eliminated pixels: 

• Click Duplication to fill the area by inserting a copy of an 
adjacent band. 

• Click Interpolation to fill the area by inserting intermediate
color values based on the color values of neighboring pix
els. This option creates a smoother, more accurate fill tha
Duplication.

5 After entering the settings you want, click OK.
Adding and removing noise 27.23
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IMAGE FILTERS AND EFFECTS

Canvas provides commands that you can use to transform image
a variety of effects. These commands can be used to alter entire 
images or only selected areas, as well as image channels.

The commands in the Filter submenu are often called “filters” 
because they “filter” images or selections pixel-by-pixel. This cha
ter explains how to use these filters as well as other commands in
Image menu.

Applying effect filters
You can use the Render, Stylize, and Offset filters to transform 
images. The filters in the Render submenu apply forms or texture
an image. The Stylize filters apply a conceptual effect to an imag
Stylize filters include Emboss, Trace Contour, and Solarize. The O
set filter shifts the pixels within an image.

Rendering clouds
You can apply texture to areas in an image, such as skies or walls
applying the Clouds filter. The Clouds filter renders soft swirls of 
color using the foreground and background colors. 

Note: The Clouds filter completely replaces the original image or 
selection.

To apply a swirl of color to an image

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected. This command doesn’t work with paint objects
Black & White mode, and Indexed mode. 

2 Choose Image > Filter > Render > Clouds. 

To render translucent clouds

You can use alpha channels to render translucent clouds.

1 With a paint object in edit mode, choose Select All in the Ed
menu and then choose Copy in the Edit menu to copy the imag

Image with translucent clouds
28.1
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the Clipboard. The paint object in edit mode cannot be Black & 
White mode or Indexed mode.

2 Choose Show Channels in the Image menu to open the Ch
nels palette. Choose New Channel in the palette’s pop-up menu
Make sure you select “Masked Area” in the “Color Indicates” are
and then click OK.

3 Click the new channel in the Channels palette to make it acti
Choose Paste in the Edit menu to paste the image into the chan

4 In the areas where you want clouds to replace the original 
image, apply white using the Paintbrush or Eraser. In areas whe
you want a translucent effect, apply gray. The darker the shade,
less the clouds will obscure the original image.

5 In the Channels palette, click the first item listed to make the
composite channel active.

6 Choose Image > Select > Load. In the dialog box, select the
channel you edited in step 4.

7 Choose Image > Filter > Render > Clouds. The filter render
clouds in the selections made by loading the channel.

Rendering a color wheel 
You can fill a selection with a radial blend of colors by choosing 
Image > Filter > Render > Wheel. The rendered effect looks like t
color wheel preview in the Hue/Saturation dialog box. The Whee
filter works with paint objects in RGB Color and CMYK Color.

Unless you make a selection in the image, the Wheel filter replac
the entire image. If you want to apply a translucent wheel effect, f
low the steps for the procedure “To render translucent clouds” on
page 28.1, but in the seventh step, choose the Wheel command.

Completed alpha channel
.2 IMAGE FILTERS AND EFFECTS
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Embossing an image
You can make an image appear raised with the Emboss filter. Th
filter converts low-contrast areas to gray and accentuates high-co
trast areas with color (or black and white if the image is Grayscale
mode) according to the placement of a theoretical light source. 

To apply the Emboss filter

1 Select one or more paint objects to emboss. To apply the 
emboss filter to a limited area in one image, select the area. Th
Emboss filter doesn’t work with paint objects in Black & White 
mode, and Indexed mode.

2 Choose Image > Filter > Stylize > Emboss.

3 Enter an Angle from 0 to 360. An angle of 0 is straight right 
with higher numbers going counter-clockwise.

4 Enter a height from 1 to 32 pixels to set the height of the effe

5 Enter a number from 1 to 500 in the Amount text box. To 
retain more color along high-contrast borders, increase this valu

Solarizing images
You can create surrealistic effects in an image by applying the So
ize filter. The Solarize filter mimics a photographic darkroom proc
dure that exposes film to light during development.

You can solarize CMYK Color, RGB Color and Grayscale mode 
images. If you make a selection, Canvas filters only selected pixe

To solarize an image

1 Select one or more paint objects to solarize. To apply the 
Solarize filter to a limited area in one image, select the area. 

2 Choose Image > Filter > Stylize > Solarize. 

Embossed Angle = 163
Height = 5, Amount = 260

Original 

You can adjust the 
Angle, Height, and 
Amount 
individually by 
dragging the 
sliders...

...or drag the 
handle to set the 
Angle, Height, and 
Amount values 
simultaneously
Applying effect filters 28.3
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Outlining areas based on color value
With the Trace Contour filter, you can outline image areas that bo
der a particular color. This filter makes color outlines if you are 
working with a color image, and black outlines if you are working 
with a Grayscale mode image.

To use the Trace Contour filter

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected. This command doesn’t work with paint objects
Black & White mode, and Indexed mode.

2 Choose Image > Filter > Stylize > Trace Contour.

3 Enter a Level value from 0 to 255. The Trace Contour filter 
uses this color brightness value to determine the areas to trace.

4 Select Upper or Lower in the Edge area. To outline areas w
higher brightness levels than the one specified, choose Upper. 
Choose Lower to outline areas with lower brightness levels.

5 To see the effect of the settings, turn on Preview. When the 
tings are correct, click OK.

Original Solarized

Original Level =169 
Edge = Lower

Level =169 
Edge = Upper
.4 IMAGE FILTERS AND EFFECTS
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Offsetting selections
You can shift an image area with the Offset filter. Canvas fills the
vacated area with color, duplicated pixels, or parts of the offset ar

To offset image areas

1 With an image in edit mode, select an image area. 

2 Choose Image > Filter > Other > Offset.

3 Enter horizontal and vertical offset amounts in pixels. Positi
values result in offsets to the right and down; use negative numb
(preceded by a minus sign) to offset up and left.

4 Choose an option under Undefined Areas. 

5 To see the effect of the settings, turn on Preview. When the 
tings are correct, click OK.

Ripple effects
With the Ripple filter you can create the impression of ripples in a
image, like the ripples made by dropping a stone into smooth wat
By varying the controls in the Ripple dialog box, you can produce
range of effects in an image, from slight rippling to extreme distor
tion. 

Choose this option For this effect

Set to Background Fills area with the background color 

Repeat Edge Pixels Duplicates edge pixels until they fill 
the area vacated by the offset 

Wrap Around Moves pixels cut off by the offset 
into the vacated area 

Original Set to 
Background

Repeat Edge 
Pixels

Wrap Around
Ripple effects 28.5
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To apply the Ripple filter

1 Select a paint object. To limit the effect to a particular area, 
select the area where you want to apply the filter. If you don’t mak
selection, the filter affects the entire image.

2 Choose Image > Filter > Other > Ripple. Adjust the settings in
the Ripple dialog box, and then click OK to apply the settings and
close the dialog box. To close the dialog box without changing th
image, click Cancel. 

Ripple settings

You can adjust the following settings in the Ripple dialog box.

Spin The Spin value controls the effect of swirling the image 
around its center point. Type a number from -100 to 100 or drag t
slider to set the amount and direction of spin. Positive numbers g
erate a clockwise spin; negative numbers generate a counter-clo
wise spin. Larger values (positive or negative) increase the amoun
swirling. If Spin is zero, the filter creates no ripples in the image a
none of the other controls produces an effect.

Frequency The Frequency value affects the number of “waves” 
created in the image. Type a number from 0 to 50. A large numbe
creates more small waves; a small number creates fewer large wa

Clustering The Clustering option can create interesting interferen
patterns in combination with some Frequency values. In general, 
quency values of 15 to 50 and Spin values of 25 and higher are m
effective. You can enter a Clustering value of 0 to 30. The higher 
Clustering value, the more interference ripples appear between th
main waves.

Wave Decay The Wave Decay value softens the effect of the Fre
quency setting by dampening or stretching the waves away from 
center of the image. The closer a wave is to the center of the ima
the less it is stretched. Wave Decay creates the impression of ble
ing the waves farthest from the center of the disturbance, especia
when Include Corners is selected. 

Enter a Wave Decay value of 0 to 100. The higher the value, the 
more the waves appear stretched toward the edge of the image.

High Frequency The High Frequency option causes an approxi-
mate doubling of the effect of the Frequency setting.

Bullseye Mode Selecting Bullseye Mode leaves rings of 
unchanged original image area between the wave distortions. Th
.6 IMAGE FILTERS AND EFFECTS
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creates a pattern of concentric rings like those surrounding the bu
eye of a target. This mode can provide a means of integrating a r
ognizable version of the image with its distortion.

Include Corners This option spreads the filter’s effects to the cor-
ners of an image or selection. If Include Corners is not selected, t
effects are confined to a circular area at the center of the image o
selection. 

Preview Select Preview to see the effects of the current settings
before applying the filter to the image.

Original

Original

Spin = 30
Frequency = 8
Clustering = 0

Wave Decay = 9

Same settings
(above) with

Bullseye Mode

Ripple examples

Ripple filter applied in area selected 
with the Oval Marquee tool
Ripple effects 28.7
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Twirl effects
The Twirl filter twists an image around its center to create interest
spiral distortions. 

To apply the Twirl filter

1 Select a paint object. To limit the effect to a particular area, 
select the area where you want to apply the filter. If you don’t mak
selection, the filter affects the entire image.

2 Choose Image > Filter > Other > Twirl. Adjust the Angle set-
tings in the Twirl dialog box. The Angle value specifies the directio
and extent of the effect. Type a number in the box or drag the slid
to set the Angle value. Higher numbers (positive or negative) crea
more twists around the center. A positive number twirls clockwise
negative number twirls counter-clockwise. Select No Anti-Alias to turn 
off smoothing of edges in the image. 

3 Click OK to apply the settings and close the dialog box. Selec
Preview to see the effects of the current settings before applying 
filter to the image. To close the dialog box without changing the 
image, click Cancel. 

Spherical distortion
The Spherize filter can distort an image to simulate a reflection on
curved surface.

To apply the Spherize filter

1 Select a paint object. Make a selection if you want to limit the
effect to a selected area. If you don’t make a selection, the filter 
affects the entire image.

Original Twirl Angle 90 Twirl Angle 180
.8 IMAGE FILTERS AND EFFECTS
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2 Choose Image > Filter > Other > Spherize. Adjust the settings
the dialog box, and then click OK to apply the filter.

Spherize settings

Amount The extent of the distortion. Type a number from 1 to 10
or drag the slider to set the value. A higher number simulates a s
ger curve.

Projection Mode The shape of the distortion. Select Spherical/
Ellipsoid to simulate reflection on a spherical surface like a globe.
Select Cylindrical to simulate reflection on a cylinder, such as a c
Select Horizontal to make cylindrical distortion horizontal. Select 
Vertical to make cylindrical distortion vertical. Select Hyperboloid t
simulate reflection on a concave hyperboloid surface.

Vignette Isolates the shape of a spherical distortion from the re
of the image. If the image has a visibility mask, the areas of the im
that fall outside of the distorted area will be transparent. If the ima
does not have a visibility mask, the areas are filled with the curren
background color. You can use this option when Spherical/Ellipso
is selected.

No Anti-Alias Turns off smoothing of edges in the image. Desele
this option for a smoother effect. 

Preview Displays the current effect before you apply the filter to 
the image.

Using the High Pass, Maximum, and Minimum filters
This section describes how you can create selections in alpha ch
nels and resize bright areas in color channels. You can isolate are
an image using the High Pass filter and Threshold command. Yo

Original paint object Spherize: Amount = 5  Vignette option selected
Using the High Pass, Maximum, and Minimum filters 28.9
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can use the Maximum and Minimum filters to spread color areas y
might need to trap for commercial printing. 

Isolating areas using the High Pass filter
The High Pass filter isolates high-contrast edges in an image by 
removing low-contrast detail. The filter makes pixels located in low
contrast areas gray. In color images, the High Pass filter outlines 
high-contrast edges in color. Otherwise, it outlines these edges in
dark gray.

To apply the High Pass filter

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected. This command doesn’t work with paint objects
Black & White mode, and Indexed mode.

2 Choose Image > Filter > Other > High Pass.

3 Enter a radius from 0.1 to 250.0 pixels. To retain more of th
original image surrounding high-contrast edges, enter a high nu
ber. If you enter a low number, the filter makes more of the imag
gray. 
.10 IMAGE FILTERS AND EFFECTS
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Maximizing and minimizing bright areas in an image

You can increase or decrease light areas in an image with the Ma
mum and Minimum filters. The Maximum filter adds light to shad-
ows. The Minimum filter shrinks light areas.

When you apply these filters, Canvas compares each pixel to its 
neighbors within the radius you specify, then replaces it with the 
lightest or darkest pixel in the group. 

Isolating images with the 
High Pass filter

1 With an image in edit mode, 
choose Select All and then 
choose Copy in the Edit 
menu.

2 Choose Show Channels in 
the Image menu. Create a 
new channel by clicking the 
button in the lower-left cor-
ner of the Channels palette. 

3 Click the new channel and 
choose Paste in the Edit 
menu.

4 Choose Image > Filter > 
Other > High Pass and enter 
a radius value. Click OK.

5 Choose Image > Adjust > 
Threshold. Adjust the thresh-
old until you outline the ar-
eas you want. 

6 Paint areas white to include 
them in the selection. Fill the 
rest of the image with black.

7 Click the composite channel. 
Choose Image > Select > 
Load to load the channel 
and select an area. 

8 In this example, the image 
was finished by choosing Im-

age > Select > Inverse and 
applying a Gaussian blur of 
3.0 pixels.

Original Image High Pass filter Threshold filter

Editing with 
painting tools

Finished alpha 
channel

Isolated subject

✔Tip
To apply a choke or spread to 
an image manually, use the 
Maximum or Minimum filters in 
a color channel.

Original Maximum 4 pixels Minimum 4 pixels
Using the High Pass, Maximum, and Minimum filters 28.11
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To use the Minimum and Maximum filters

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected. This command doesn’t work with paint objects
Black & White mode, and Indexed mode.

2 To maximize the light areas in an image, choose Image > 
Filter > Other > Maximum and enter a radius from 1 to 16 pixels

3 To minimize the light areas in an image, choose Image > 
Filter > Other > Minimum and enter a radius from 1 to 16 pixels.

4 Turn on Preview to check the settings and then click OK. 

Filling selections with color
The Image > Filter > Other > Fill command lets you quickly and u
formly fill a selection with the foreground or background color, 
black, white, or gray. In addition, you can select an opacity level a
transfer mode for application of the color.

To fill a selection with a color

1 With an area of an image selected, choose Image > Filter >
Other > Fill. The Fill dialog box opens.

2 In the Use pop-up menu, choose a fill option. To make the 
color appear transparent, set the Opacity level to less than 100%
To use a mode effect, choose an option in the Mode pop-up me

3 Click OK to fill the selection.

Creating custom image filters
You can create your own special-effect and image-correcting filte
using the Custom command. You can also save custom filters an
use them in future Canvas documents. 

Filters work with an image one pixel at a time. Using a mathemati
formula and the color values of pixels within a specified radius, fil
ters assign each pixel a new color value. In a custom filter, you su
ply the numbers the filter uses to calculate the new color values.

The same filter can produce different effects in other images. To 
the most out of custom filters, spend time experimenting.
.12 IMAGE FILTERS AND EFFECTS
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To use Custom filters

1 Select one or more paint objects to adjust all the images. Yo
can select an area in one image in edit mode to adjust the selec
area only. If you don’t make a selection, the entire image in edit
mode is affected. This command doesn’t work with paint objects
Black & White mode, and Indexed mode.

2 Choose Image > Filter > Other > Custom. In the Custom dial
box, type values from -999 to 999 in the boxes in the grid. Canv
ignores blank boxes.

3 Enter a Scale value from 1 to 9,999. To retain the general 
appearance of the original image, the scale should equal the su
the entries in the configuration grid. For example:

Grid entries Sum Scale

2  2  1  -1  -1  3 2+2+1-1-1+3=6 6

-15 7 4 -3 2 8 -15+7+4-3+2+8=3 3

Custom filter Blurred image Custom filter Embossed 
image

Original

These boxes represent the pixels 
surrounding a target pixel

This box represents the 
target pixel in an image
Creating custom image filters 28.13
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4 Enter an Offset value from -9,999 to 9,999. Positive values 
increase the brightness of the final outcome while negative valu
decrease the brightness.

5 Turn on the Preview option to check the filter effect. When th
settings are correct, click OK.

◆ To save a custom filter: In the Custom dialog box, enter the fil
ter settings and click Save. Enter a name and location for the filte
and click Save. 

◆ To load a custom filter: In the Custom dialog box, click Load. 
In the directory dialog box, select the filter file and click Open. 

Combining image channels
The Calculate command lets you combine channels to create sel
tion masks for effects like embossing text in an image. By adding
subtracting, and multiplying channels, you can also enhance shad
and highlights.

The Calculate command combines corresponding pixels from two
channels by the method you choose. You can place the result in a
or existing channel. 

To combine channels

1 With an image in edit mode, choose Calculate in the Image
menu.

2 Choose the first channel in the Source 1 pop-up menu. If yo
want to invert the channel, turn on Invert. For more information,
see “Inverting colors in images” on page 27.5.

3 In the Source 2 pop-up menu, choose the channel you wan
combine with the first channel. If you want to invert the channel,
turn on Invert. 

4 In the Blending area, choose an option in the Use pop-up 
menu. See “Descriptions of Calculate blending options,” next. 

5 Enter an opacity from 0 to 100 percent for Source 1. Other 
options are available for some Blending methods.

6 If you want to mask Source 1, turn on Mask in the Blending
area and choose a channel in the pop-up menu. To invert the m
turn on Invert in the Blending area.
.14 IMAGE FILTERS AND EFFECTS
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7 Choose the name of a destination channel or choose New in
Result pop-up menu. If you select an existing channel, Canvas 
replaces the channel with the results of the Calculate operation.

8 Click OK to calculate the channel using the current settings

Descriptions of Calculate blending options

You can select various blending 
methods in the Calculate Image 
dialog box. 

Normal. Places Source 1 over 
Source 2 at the specified opaci-
ty. 100 percent opacity replaces 
Source 2 with Source 1.

Multiply. Creates a darker 
channel than the source chan-
nels. Black areas in either source 
create black areas in the result-
ing channel. White areas do not 
affect the result. 

Screen. Creates a lighter chan-
nel than the source channels. 
White areas in either source cre-
ate white areas in the resulting 
channel. Black areas do not 
affect the result.

Overlay. Places Source 1 over 
Source 2 without destroying the 
shadows or highlights of Source 
2. 

Soft Light. Lightens or darkens 
pixels in Source 2 depending on 
the brightness value of the cor-
responding pixels in Source 1. 
Pixels in Source 1 that are light-
er than 50% black lighten 
Source 2. Pixels in Source 1 that 
are darker than 50% black dark-
en Source 2.

Hard Light. Lightens or darkens 
pixels in Source 2 depending on 
the brightness value of the cor-
responding pixels in Source 1. 
Hard Light works similarly to 
Soft Light. However, black in 
Source 1 produces black in the 
resulting channel and white pro-
duces white.

Darken. Replaces pixels in 
Source 2 with the correspond-
ing pixels in Source 1, if the pix-
els in Source 1 are darker.

Lighten. Replaces pixels in 
Source 2 with the correspond-
ing pixels in Source 1, if the pix-
els in Source 1 are lighter.

Add. Creates a lighter channel 
than the source channels. Add 
is similar to Screen but usually 
produces a higher-contrast 
image. 

If you select the Add option, 
you can enter a Scale value 
from 1 to 2 with a precision of 
three decimal places. To calcu-
late the average brightness val-
ue of two channels, choose Add 
and enter a Scale of 2.

You can brighten or darken the 
resulting channel by specifying 
an Offset value. To lighten the 

overall image, enter an offset 
from 1 to 255. To darken the 
image, enter an offset from -1 
to -255. 

Subtract. Creates a darker 
channel than the source chan-
nels. Subtract is similar to Multi-
ply. However, corresponding 
pixels of the same color pro-
duce black in the resulting chan-
nel. 

If you select the Subtract 
option, you can enter a Scale 
value from 1 to 2 with a preci-
sion of three decimal places. 

You can brighten or darken the 
resulting channel by specifying 
an Offset value. To lighten the 
overall image, enter an offset 
from 1 to 255. To darken the 
image, enter an offset from -1 
to -255. 

Difference. Compares the color 
value of each pixel in Source 1 
with the corresponding pixel in 
Source 2, subtracts the darker 
value from the lighter, and then 
uses this difference in the result-
ing channel.
Combining image channels 28.15
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Examples of Calculate blending options

Source 1 Source 2 Multiply

Screen Overlay Soft Light

Hard Light Darken Lighten

Add Subtract Difference
.16 IMAGE FILTERS AND EFFECTS
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IMAGE PROXIES

Proxies are low-resolution images you can use in Canvas docume
A proxy is a placeholder that is linked to an original image. The or
inal high-resolution image is stored in a Canvas Image File on dis

Proxies are most useful for conserving time and memory when yo
use large, high-resolution color images in documents.

Using proxies can significantly reduce the time required to redraw
the screen while you work. Also, a Canvas document that contain
proxies requires much less disk storage space than one containin
high-resolution images (although the space required to store the 
ument and the linked image files is approximately the same as for
document containing high-resolution images). 

Replacing an image with a proxy
The procedure described in this section lets you replace an imag
contained in a Canvas document with a low-resolution proxy. Wh
you do this, Canvas exports the original image to a Canvas Imag
File, and links the Canvas Image File to the proxy. 

Proxy
A high-resolution image 
stored in a Canvas Image File 
on disk.

A low-resolution proxy replaces the image in a 
Canvas document. The proxy is linked to the 
Canvas Image File.
29.1
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If you later double-click the proxy for editing, Canvas loads the or
inal image from the Canvas Image File. You can edit the original 
image as you would any other Canvas paint object. When you lea
image-editing mode, Canvas stores the changes in the Canvas Im
File and then displays the proxy again.

To create a proxy linked to a Canvas Image File

1 In the Canvas document, select the image object you want 
replace with a proxy.

2 Choose Image > Proxy > Make Proxy. A directory dialog bo
appears.

3 Select a location on disk and type a name for the Canvas Im
File that Canvas will create. 

4 Click Save. The Make Proxy dialog box appears.

5 Type a value in the “Make...Times Smaller” box. The larger 
this number, the lower the proxy resolution and the less memor
required by the proxy in the document. The value must be from 1
1,000.

6 Click OK. Canvas replaces the image with a proxy and crea
a file containing the original image on disk. The proxy is linked t
the Canvas Image File on disk. 

If you click Cancel, Canvas closes the dialog box without replacin
the original image, placing the proxy, or storing the image file on 
disk.

Final output with proxies and Canvas Image Files

To produce final high-resolution output from a document, you ma
need to copy the Canvas document from your disk to another sto
media, such as a Zip disk. When you copy a document that conta
image proxies, you need to copy the linked high-resolution Canva
Image File also, to be able to print the high resolution images.

Make sure when you copy the documents to another disk, that yo
maintain the original folder structure. It is a good idea to open the
Canvas document that you copied, and check that the links have
been broken. See “To verify proxy links” on page 29.6 for more 
information.

You can also replace a proxy with its linked image to eliminate th
need to copy the Canvas Image File. To learn how to do this, see
replace a proxy with its linked image” on page 29.5. 
.2 IMAGE PROXIES
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To create a proxy by acquiring a file

You can use the Acquire command to create a proxy that is linke
a TIFF, JPEG, or CVI file. 

You can edit acquired proxies the same as other proxy images. H
ever, some changes you might make, such as adding image chan
are not supported by JPEG or TIFF files. In this case, when you s
the file, Canvas asks whether to save the image in Canvas Image
mat to preserve the changes.

1 To acquire an image from a file, choose Image > Acquire and
choose a file format in the Acquire submenu. 

2 In the directory dialog box, select the Acquire As Proxy option
Select the image files to acquire and click Done. 

3 The Make Proxy dialog box appears. Type the proxy resoluti
in the “Make…Times Smaller” box. The larger the number, the 
lower the resolution of the proxy image in the document.

4 Click OK. Canvas places the proxy images in the document.

Make Proxy dialog box

You use the Make Proxy dialog 
box to create proxies linked to 
Canvas Image Files.

A Width and height of the im-
age.

B Size of the Canvas Image 
File you are about to create.

C Resolution of the image.

D Memory required by the 
proxy. The memory required 
changes if you enter values in 
the “Make...times smaller” text 
box.

E Type the proxy reduction 
factor in this text box. The larger 
this value, the lower the proxy 
resolution and the less memory 
required by the proxy.

F Location of the file on disk.

G Click to change the location 
that Canvas will store the 
Canvas Image File.

H Click OK to replace the im-
age with the proxy and create 
the Canvas Image file.

E D 

F

B

G H

A

C

29.3



29

the 
 
not 

s 
f 

an-
hen 

ge 
els 

s 
y is 

s-
ca-
Editing proxies
Object editing

Changes you make to a proxy when you do not edit the pixels in 
image are object-level edits. You can skew and scale proxies like
other objects. Skewing, scaling, and other object-level editing do 
affect the Canvas Image File to which the proxy is linked. 

Pixel editing

When you place a proxy object in image-edit mode, Canvas load
and displays the linked Canvas Image File in place of the proxy. I
the original image has changed, you see the changes.

Changes you make in image-edit mode are saved in the linked C
vas Image File on disk when you exit image-edit mode. Canvas t
displays an updated proxy.

Editing an image linked to a proxy is the same as editing any ima
in Canvas: You can use painting tools and commands to alter pix
in the original image.

Displaying proxy information
When you select a proxy object, the information area of the Statu
bar displays the data for the Canvas Image File to which the prox
linked in italic type. To display information on the proxy object, 
choose Image > Proxy > Proxy Info. The Proxy Info dialog box di
plays the dimensions and resolution of the proxy object and the lo
tion of the linked original image on disk.

A paint object in image-
edit mode
.4 IMAGE PROXIES
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Removing proxies
To remove a proxy object easily, without replacing it with an origin
image, select the proxy object and press Delete, or use the Cut o
Clear commands in the Edit menu.

To replace a proxy with its linked image

1 Select the proxy you want to replace.

2 Choose Image > Proxy > Unlink Proxy. Canvas asks if you a
sure you want to remove the link between the Canvas Image Fi
and the proxy.

3 Click OK to replace the proxy and remove the link to the Ca
vas Image File.

Maintaining proxies
If someone changes the name or location of a Canvas Image File
is linked to one or more proxies, Canvas alerts you that the file co
not be found when you try to edit, unlink, or update any of the pro
ies.

Height of the image
Width of the image

Size of the Canvas Image File
Resolution of the image

Memory required by of the proxyThe factor by which 
the proxy is reduced

Location of the Canvas 
Image File on disk

Click to link the proxy to 
another Canvas Image File Click to close the dialog box
Maintaining proxies 29.5
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You can check proxies in a document at any time to verify that th
links are valid. If Canvas detects unlinked proxies, you can re-link
them to existing Canvas Image Files.

To verify proxy links

To determine if any proxy links are broken, choose Image > Prox
Check Proxies.

If Canvas finds an unlinked proxy, it displays selection handles 
around the proxy and centers it in the document window. Canvas
plays a message telling you that the proxy has a problem becaus
image file could not be found. 

Note: When it finds an unlinked proxy, Canvas displays the proxy
name, if you have assigned a name to the proxy object. You can 
this by typing a name in the Object Name box on the Data tab in 
Object Specs palette.

When Canvas tells you that a proxy has a problem, you should fol
the procedure “To re-link a proxy,” next. If a proxy does not have 
valid link to a Canvas Image File, Canvas prints the low-resolutio
proxy when you print the document.

If all proxies in the document have valid links to Canvas Image Fil
Canvas displays the message: “No problems found.” Canvas also
plays this message if the document contains no proxies.

To re-link a proxy

If you are using the Check Proxies command and Canvas finds a
unlinked proxy, you can link the proxy to a Canvas Image File.

✔ Important
You should always verify the 
proxy links in a document 
before final output. If you pro-
duce final high-resolution out-
put from a document with 
unlinked or broken proxy 
objects, the associated images 
will not print correctly.
.6 IMAGE PROXIES
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1 After Canvas identifies an unlinked proxy, click Fix in the 
message box. The Proxy Info dialog box appears.

• If you click OK, Canvas skips the proxy and continues 
checking other proxies. If you click Cancel, the check end

2 In the Proxy Info dialog box, click File. A directory dialog box
appears.

3 In the directory dialog box, select a Canvas Image File to lin
to the proxy, and then click Open. Canvas returns to the Proxy I
dialog box, which shows the path to the linked image file. 

4 Click OK. Canvas closes the Proxy Info dialog box and cont
ues to check for unlinked proxies.

5 If Canvas finds another unlinked proxy in the current docu-
ment, Canvas again selects the unlinked proxy and displays a m
sage that the proxy has a problem. Repeat the procedure from 
1 above to re-link unlinked proxies that Canvas selects.

When Canvas doesn’t find any unlinked proxies, it ends the Chec
Proxies procedure and returns to the document.

To change the file linked to a proxy

Use the following procedure to link a proxy to a different Canvas 
Image File.

1 Select the proxy object.

2 Choose Image > Proxy > Proxy Info. The Proxy Info dialog 
box appears. Click File and a directory dialog box appears.

3 Select the Canvas Image File you want linked to the proxy a
click Open. The Proxy Info dialog box appears, and shows the n
path and the name of the linked image file.

4 Click OK to close the Proxy Info dialog box.

Updating proxies
Use the Update Proxies command to update all proxies in a docum
so they match the image data in their linked Canvas Image Files. 
Update Proxies command is not available if any objects are selec
in the document.

◆ To update all proxies in the active document: Choose 
Image > Proxy > Update Proxies. 
Maintaining proxies 29.7
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◆ To update a specific proxy: Select the proxy object you want 
to update and choose Image > Proxy > Update Proxy.

Exporting Canvas Image Files
You can export any image from a Canvas document to create a C
vas Image File on disk. You can then create proxies linked to the
Canvas Image File.

This procedure creates a Canvas Image File, but does not link th
image file to the document, or replace the image with a proxy in t
document.

To export an image to a Canvas Image File

1 Select the paint object in the document and choose Image >
Export > Canvas Image File.

2 A directory dialog box appears. Select a location and type a
name for the image file, and then click Save. Canvas creates a 
vas Image File on disk.
.8 IMAGE PROXIES
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ACTIVATE To make a window active by clicking anywhere in it.

ACTIVE WINDOW The window with the program’s focus, usually in
front. Tools and commands work in the active window.

ALPHA CHANNELS A grayscale duplicate of an image on which yo
can store masks and selections.

ANCHOR POINT The starting or ending point of a path segment. 
Anchor points appear only when an object is in edit mode. When 
selected, anchor points of curve segments display one or two dire
tion lines.

ANSI  American National Standards Institute; one of the standard
available to specify dimension object properties. 

ANTI-ALIAS To soften the edges of an applied brush stroke, effect
selection. When something is anti-aliased, the color on the edges
fades to transparency instead of stopping abruptly. 

ASCII American Standard Code for Information Interchange (pro-
nounced “ASK-ee”); used for representing text inside a computer a
for transmitting text between computers.

BASELINE An imaginary line on which a line of text rests. The 
descenders of characters such as g, j, and p extend below the base-
line.

BEVEL JOIN A style of connection between two segments in a vec
object, in which the stroke lines appear to be trimmed diagonally.

BÉZIER CURVE A curve, named after French mathematician Pierre
Bézier, defined by the position of anchor points and tangent lines.

BIND To align the baseline of text so it follows the contours of a 
path.

BITMAP A digital image composed of pixels; technically, an imag
containing only black and white. See also Image.

BITMAPPED FONT A font made up of characters composed of pixel
rather than vector data. Fonts displayed on a computer screen ar
mapped fonts, for example, and usually aren’t suitable for printing

Anchor point

Anti-aliased line

b a s e l i n e

Bevel join

Vector (left) and bitmapped 
fonts

R
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BLACK AND WHITE A method of digital imaging that uses pure blac
and pure white pixels. The frequency of black or white pixels crea
the illusion of shades.

BLEND A smooth transition of shape and color between two vect
objects through intermediate objects created by Canvas.

BOUNDING BOX An invisible rectangle that defines the boundarie
of an object. Canvas displays an object’s bounding box when the
object is selected.

BULLET A special text character, usually a filled circle (•), availabl
in many fonts, especially symbol fonts.

BUTTON A pushbutton-like image in dialog boxes where you click
to designate, confirm, or cancel an action.

CANVAS TEMPLATE A Canvas document that includes options and
settings and is used as the basis for new documents. 

CCITT Consultative Committee on International Telegraphy and 
Telephony; its standards include data transmission formats.

CENTER EXTENSION The distance that Center dimension lines 
extend beyond the dimensioned object.

CENTER GAP The space between a Center dimension crosshair a
the lines that extend from it.

CENTER LENGTH The Center dimension crosshair length.

CHANNEL In digital images, a layer of primary color in a full-color
image. For example, an RGB image has at least three color chan
(one each for red, green, and blue) and a composite channel, wh
adds the three channels together to create a full-color image.

CHANNEL MASK A channel that creates transparency based on th
the luminance of pixels in the channel. It can be applied to any ty
of object.

CHARACTER Any symbol, such as letters, numbers, and punctuatio
that can convey information. Some characters can be displayed o
the monitor screen and printed on a printer.

CHARACTER STYLE A set of attributes, such as color, typeface, and
style, that can be applied as a group to text characters.

CLICK (v.) To position the pointer on something, and then press a
quickly release the mouse (or other pointing device) button. (n.) T
act of clicking.

CLIP ART Electronic pictures that you can use in documents. The
term comes from using scissors to clip pictures on paper.

A bounding box of a circle

Center length, center gap, 
center extension 
BLACK AND WHITE / CLIP ART
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CLIPBOARD A holding place in system memory for the last inform
tion cut or copied from a document. You can paste information fro
the Clipboard into a document. Information remains on the Clipbo
until replaced by another cut or copied selection.

CLIPPING PATH A vector or text object used to “clip” (hide) areas o
another object that are outside of the clipping path.

CLOSED PATH A vector path that does not have separate starting a
ending points.

CMYK COLOR A color system based on the four colors used in col
printing: cyan, magenta, yellow, and black. Also, a color mode us
to define colors in a digital image. See Process Color.

COLOR PALETTE A collection of colors used in a document, from 
which you can select colors to apply.

COLOR SEPARATIONS Computer files, printed output, or film, in 
which the colors in a document are divided into their primary or c
tom color components. Color separations are used to produce pr
ing plates for commercial color printing. See Process Color and Spot
Color.

COLOR WHEEL A two-dimensional view of color showing hue and 
saturation. Hue is the position of a color on the circumference of 
wheel. Moving clockwise and starting at twelve o’clock, the colors
are yellow, red, magenta, blue, cyan, and green. Colors toward th
center of the wheel have more gray than those near the edge.

COLUMN GUIDES Non-printing lines that define text columns and 
gutters in a section.

COMMAND KEY On Mac OS system keyboards, a key (usually wi
a propeller symbol and sometimes labeled “Command”) that mod
fies an action when pressed.

COMPOSITE CHANNEL The combination of all color channels in an
image. In the Channels palette, the first channel listed, identified 
RGB, CMYK, LAB, or Black, depending on the image mode.

CONTROL KEY A keyboard key, usually marked “Ctrl,” that modi-
fies an action when pressed.

CONTROL PANEL A Mac OS or Windows system program that lets
you change features of the operating system, such as settings fo
display, keyboard, and networking.

Text used as a clipping 
path on a photo 
CLIPBOARD / CONTROL PANEL G.3
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CORNER POINT An anchor point where path segments meet at an
angle, rather than with a smooth transition.

CROP To trim an image to a specified rectangular area.

CROP MARKS Small lines placed at the page edge that mark wher
printed material will be trimmed.

CURRENT INK The ink, or color, that applies to new objects you 
draw, set by applying an ink when no objects are selected; this se
does not change when you set the ink for a specific object. For ex
ple, if you set the current fill ink to red, new objects you draw will b
filled with red; if you then change an object’s color from red to gree
however, the current ink remains red.

CURRENT STROKE The stroke that applies to new objects you draw
set by applying a stroke when no objects are selected; this setting
does not change when you set the stroke for a specific object. Fo
example, if you set the current stroke to a 5-point pen, new objec
you draw will have a 5-point pen width; if you then change an 
object’s stroke from 5 to 10 points, however, the current pen widt
remains 5 points.

CUSTOM VIEW A recording of a screen position and magnification
level in a Canvas document. 

DECIMAL TAB A tab, represented by a decimal tab marker, that 
aligns columns of numbers at the decimal point position.

DESATURATE To increase the gray content of a color.

DIALOG BOX A box that an application displays to request informa
tion or to report that it is waiting for a process to complete. 

DIMENSION OBJECT Object created with the Dimensioning tool.

DIMENSION TEXT GAP The space between the dimension text and
arrow.

DIN STANDARD Deutches Institut für Normung standard; one of 
several used to specify the properties of dimension objects.

DIRECTORY DIALOG BOX A type of dialog box you use to navigate a
computer file system when you save or open a file.

DITHER To arrange pixels of several colors into patterns to give th
appearance of a broader range of colors.

DOCUMENT The container for information and objects you work 
with in Canvas. Canvas has four types of documents — Illustratio
Presentation, Publication, and Animation.

DOT GAIN In commercial printing, the amount of size increase of 
halftone dots caused by ink spreading on the printed medium.

DOUBLE-CLICK (v.) To press and release the button on a mouse (
other pointing device) twice in quick succession.

Corner point

 0.37 ' 

 1.00 ' 

Dimension objects
CORNER POINT / DOUBLE-CLICK
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DPI Dots per inch; the unit of measurement of the resolution of a
printing device.

DRAG To press and hold down the button on a mouse (or other 
pointing device), move the device, and then release the button.

EMULSION Photosensitive coating on film or paper.

ENCAPSULATED POSTSCRIPT (EPS) A format for storing graphics and
text in a file using the PostScript language. An EPS file can includ
preview image. See PostScript.

ESC KEY A keyboard key that lets you stop a procedure. 

EXTERNAL TOOLS Individual program modules that provide fea-
tures, tools, and commands in the Canvas program.

FADE Gradual decrease of a painting tool effect until there is no 
noticeable change in the image. For example, if “Fade Size within
steps” is selected in the Paintbrush manager, the brush becomes
smaller as you drag. 

FILE Any named, ordered collection of information stored on a di

FILL INK The ink that Canvas applies to the inside, as opposed to
outline, of objects and text.

FLAT END CAP A style of stroke end in which the stroke end is 
squared off, perpendicular and flush to the end of the stroke.

FLOATING SELECTION An image area that “floats” above an image
You can move and edit the floating selection without changing the
underlying image until you defloat, or “drop,” the selection on the 
image.

FONT A complete set of characters in one design, size, and style
typography, a font can be restricted to a particular size and style (s
as 10-point Helvetica) or can comprise multiple sizes, or multiple 
sizes and styles, of a typeface design.

FOLDER A container for documents, applications, and other folde
in the Mac OS and Windows file systems.

FRAME (1) One illustration “page” in an animation. An Animation 
document contains a series of frames which are displayed in 
sequence to make an animation. (2) A technical term for the outli
of an object or text, to which Canvas applies stroke settings, such
dashes.

GAMUT The range or extent of a color model’s spectrum. 

GRADIENT A gradual transition or blend between two or more col
ors. The direction and shape of a gradient can be radial, linear, el
cal, or shape-derived.

Flat end cap
DPI / GRADIENT G.5
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GRAYSCALE An image mode that uses eight bits of information pe
pixel for up to 256 brightness levels, from black to white through 
shades of gray.

GROUP (v.) To associate two or more objects so they behave as 
unified object; (n.) the resulting object.

GUIDES Non-printing lines to which objects can be aligned.

HALFTONE A pattern of tiny black and white dots that appear to th
human eye as shades of gray; a photograph or other image conv
to such a pattern for commercial printing.

HANDLES (1) Small squares, usually at the corners and midpoints
an object’s bounding box, displayed when an object is selected; y
can drag handles to resize the object. (2) Small circles at the end
tangent lines; you can drag a handle to change the length or angle
tangent line.

HATCH PATTERN Object-based fill pattern made of line groups.

HIGHLIGHT To make something visually distinct. For example, 
when you select a block of text in Canvas, the selected text appe
against a colored background.

HUE A color’s main characteristic; its name, as in blue, red, or 
orange, defined by its position on the color wheel.

I-BEAM A type of pointer shaped like the capital letter “I.” 

IMAGE A picture composed of pixels; referred to as a “raster 
image,” “paint image” or “bitmap.” See Image Mode.

IMAGE MODE The system used to define colors in an image. Canv
image modes include Black and White, RGB Color, CMYK Color,
Grayscale, Indexed, and LAB Color.

IMPORT To use any of several techniques to move graphics or te
from another program into a Canvas document.

INDEXED A digital image mode that lets you specify a palette of u
to 256 colors used in the image. Usually used for on-screen displ
and electronic distribution of images, because it requires less me
ory than RGB or CMYK color modes.

INK Colors, symbols, hatch patterns, textures, and gradients tha
can be applied to objects.

INSERTION POINT A blinking vertical line where text you type will 
appear in a text object or dialog box.

ISO STANDARD International Organization for Standardization; on
of several standards used to specify the properties of dimension 
objects.

JIS STANDARD Japanese Industrial Standard; one of several used
specify the properties of dimension objects.

Tangent line handles

Insertion point
GRAYSCALE / JIS STANDARD
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JUSTIFICATION The method used to align paragraphs of text within
text object’s margins, either left, right, center, or full.

KERNING Adjusting the normal space between characters in text;
also, the amount of the adjustment.

LAB COLOR An image mode in which the color components are 
divided into a lightness channel and A and B color channels.

LANDSCAPE Orientation of an illustration or page that is wider tha
it is tall.

LAYER A level in a Canvas document used to organize parts of ill
trations so they can be easily selected.

LAYOUT AREA The rectangular area on screen in a Canvas docu-
ment, which represents the extent of the layout and may cover m
ple printed pages, depending on the size of paper used for printin

LEADER CHARACTER A character, usually a period (“.”) used to fill 
space between the character before a tab space and the charact
immediately following the tab space.

LEADER CHARACTER LENGTH The length of the horizontal portion 
of the witness line of a dimension object.

LEADING Space between lines of text, measured in points from th
baseline of one line to the next.

LENS A special object which applies effects such as filters and m
nification to an area in a document.

LIGHTNESS The amount of black or white in a color.

LINE GROUP A set of parallel lines in a hatch pattern that have ide
tical properties.

LINE CAP The shape of the end of a pen stroke.

LINE JOIN The shape of the pen stroke where two path segments
meet. 

LPI Lines per inch; a measure of halftone screen resolution.

MAC OS The Apple Computer operating system used on Macinto
and on compatible personal computers.

MACRO OBJECT A vector object that can be used to place copies 
itself in documents; the copies remain linked to the original.

MARQUEE A selection in an image defined by a rectangular flashi
border; also, the tool used to make a marquee selection.

MASTER PAGE A special page in a Publication, Presentation, or A
mation document. Items on the master page, slide, or frame are v
ble and print on every page in the document.

Text without kerning (top) and 
with kerning applied (bottom)

 2.30  pica 

Leader character length
JUSTIFICATION / MASTER PAGE G.7
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MASK A general term for objects or channels that limit that visibilit
of other objects, or that protect areas in an object or image from 
changes.

MASTER SLIDE A special slide in a Presentation document. Items 
the master slide are visible and print on every slide in the docume

MEGABYTE (MB) A unit of measurement equal to 1024 kilobytes, o
1,048,576 bytes.

MEMORY A hardware component of a computer system that can 
store information for later retrieval.

MITER JOIN A style of connection between two segments in a vec
object in which the stroke lines come together at a point.

MODIFIER KEY A general term for a key that changes the meaning
other keys or mouse actions; for example, Command, Control, 
Option, and Shift.

NTSC National Television Standards Committee; also, the standa
video format defined by the NTSC, also called composite becaus
combines all the video information, including color, into a single s
nal.

OBJECT A discrete vector path, block of text characters, or raster
image, contained within an invisible rectangular frame. You can 
select an object and perform standard operations on it, including 
move, copy, delete, cut, rotate, flip, and skew.

OPACITY An attribute of all objects. Opacity with a value of 100% i
non-transparent. Opacity values can be set from 1 to 100%.

OPEN PATH A path defined by separate starting and ending point

OPTION KEY A Mac OS keyboard modifier key, usually labeled 
“Option.”

OUTSIDE LINE LENGTH Dimension object arrow length, when the 
Arrows Inside option is not selected.

OVERPRINT A technique where two or more colors are printed on
top of each other. For example, if you overprint yellow on blue, th
combination appears green.

PAINT OBJECT An object that contains a raster image. The term is
synonymous with image object.

PAINTING TOOL Any of several tools used to create or edit a paint
object.

PALETTE A type of dialog box that can remain open on screen. A
palette contains tools, attributes, or options for commands.

PALETTE ICON A toolbox icon that opens a palette.

PARAGRAPH STYLE A set of attributes, such as font, leading, indent
and tab settings, that can be applied to a paragraph of text.

Miter join

 0.50 ' 

Outside line length
MASK / PARAGRAPH STYLE
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PATH One or more connected segments, generally created with 
drawing tool, within a vector object. The path itself is invisible unle
it has visible fill ink, or pen ink and stroke, applied to it.

PEN INK The colors and patterns applied to an object’s stroke.

PICA A unit of measurement equal to 12 points or 1/6 of an inch,
abbreviated “pc.”

PIXEL Short for picture element; a single tiny dot of a raster image o
a computer display.

PLUG-IN A program module that can be used by Canvas to prov
an additional image-editing function.

POINT A unit of measurement for type equal to 1/72 inch; abbrev
ated “pt.”

POINTER A small shape that follows the movement of the mouse 
screen or shows where your next action will take place. The poin
can be an arrow, an I-beam, or other shapes.

PORTRAIT The orientation of a page or illustration so that the heig
is larger than the width.

POSTSCRIPT® (1) An Adobe Systems, Inc. computer language tha
defines the appearance of printed type and images. (2) A type of 
that relies on PostScript to be printed.

POSTSCRIPT PRINTER DESCRIPTION (PPD) A text file that provides 
information about a specific printer to the operating system and 
application programs.

PPI Pixels per inch; a measure of the resolution of an image.

PRESS (1) To point to an item on screen and press and hold dow
the mouse button without moving the mouse. (2) To push a key do
and then release it; you hold a key down only when using a modi
key with another key, for example, when instructed to press Ctrl+A.

PRINTER DRIVER A program that controls the exchange of informa
tion between the computer and a specific type of printer.

PROCESS COLOR The method for printing a full range of colors 
using only cyan, magenta, yellow, and black; also, any one of the
colors. Compare to Spot Color.

RANDOM-ACCESS MEMORY (RAM) The part of the computer’s mem
ory that stores information temporarily while you’re working.

RASTER IMAGE A picture made up of a matrix of pixels, created by
digitizing or scanning an image, which is contained in a paint obje

REGISTRATION MARK A small mark, several of which are used 
together to align films and plates for commercial printing.

Registration mark
PATH / REGISTRATION MARK G.9
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RGB COLOR Method of defining colors, based on combinations of
the primary colors red, green, and blue. Also, a color mode for dig
images.

RESOLUTION A measure of the amount of information in a digital 
image, expressed in pixels per inch (ppi); also, a measure of the 
smallest dot or pixel that can be used by a computer display or ou
device, expressed in dots per inch (dpi).

ROUND END CAP A style of stroke end, in which the end of the 
stroke is capped with a semicircle.

SATURATE To increase color intensity by removing gray.

SCANNER Any input device that converts printed matter, such as 
photographic print or transparency, into digital data.

SECTION A rectangular area that arranges text in columns.

SHIFT KEY A key that, when pressed, causes the subsequent lette
you type to appear in uppercase or the top symbol on a two-chara
key to be produced. The Shift key can also modify mouse actions

SEGMENT A line or curve between two endpoints in a path.

SELECTION The information or items that will be affected by the 
next command, including objects or a series of characters.

SELECTION BOX A dashed rectangle that appears as you drag a 
Selection tool over objects to select them.

SEPARATIONS See Color Separations.

SLIDE SHOW The display of different screens of information — 
“slides” — in sequence. Canvas changes the screens after a set 
interval or when you click the mouse.

SMART POINTER A pointer symbol representing the Smart Mouse 
constraint that is in effect.

SMOOTH POLYGON A polygon with rounded segments and corner

SNAP GRID A grid of horizontal and vertical lines you can display.
The pointer can snap into alignment with the snap grid.

SOURCE LINE Dotted line that points to the part of the object defin
ing a Smart Mouse constraint that is in effect.

SPACEBAR The long, unlabeled bar in the bottom row of keys on 
computer keyboard that you press to insert space between chara

SPOT COLOR Customized color representing a particular ink that 
will be used to print the color. Compare to Process Color.

SPRITEEFFECTS A Canvas technology that lets image-editing effect
such as blur and curves, be applied to any type of object.

SPRITELAYER A Canvas technology that provides transparency 
effects, including opacity and transparency masks.

Round end cap

Segment
0 RGB COLOR / SPRITELAYER
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SQUARE END CAP A style of stroke end, in which the end of the 
stroke is squared off and extends half the line width beyond the e
point of the path.

STATUS BAR The area at the bottom of the Canvas window or the
screen that displays information on tools, the position of the point
and selected objects.

SYMBOL INK A repeating pattern, created from vector objects, tha
can be applied to vector objects and text as a fill ink or stroke ink.

TAB KEY A keyboard key that moves the insertion point to the ne
tab marker, or to the next place to enter information in a dialog bo
The Tab key is also used as a modifier key.

TANGENT LINE Line passing through an anchor point on a vector 
path; visible when the path is in edit mode and an anchor point w
tangent lines is selected. Its angle and length affect the shape of 
cent segments.

TEMPLATE See Canvas Template.

TEXT BACKGROUND INK An ink applied to the background of a tex
object or text selection.

TEXT FRAME INK An ink applied to the bounding box of a text objec
or a box around a text selection.

TEXT FRAME STROKE A stroke applied to the bounding box of a tex
object or a box around a text selection. The text frame ink appear
the text frame stroke.

TEXT OBJECT An object containing text.

TEXT BOX A place in a dialog box where you can type information

TEXT FILE A file that contains information stored in the form of 
readable characters encoded in ASCII format.

TEXTURE INK A repeating pattern, created from a raster image, th
can be applied as a fill ink or pen ink.

TILING Dividing a large illustration into multiple pages, or “tiles,” 
for printing on a desktop printing device.

TOLERANCE In image editing, a value that sets the threshold for s
ilarity between colors before an effect occurs. For example, if the
Wand tool tolerance is set to 0, it selects only pixels of the exact sa
color. If the tolerance is set higher, the tool selects pixels of simila
colors.

TOLERANCE DOWNSPACE Amount of space (leading) between tol-
erance text in dimensions with two tolerance measurements.

TOLERANCE TEXT SCALE  Size of tolerance text in a dimension in 
proportion to the dimension text.

Square end cap

Tangent lines

Tiling
SQUARE END CAP / TOLERANCE TEXT SCALE G.11
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TRANSFER MODE Method by which a color blends with a back-
ground color. Transfer modes include Dissolve, Multiply, Screen,
Lighten, and Saturation.

VECTOR MASK A SpriteLayer effect that applies transparency to a
object based on a gradient from opaque to transparent.

VECTOR OBJECT An object defined by anchor points and a path. Th
Line, Rectangle, Oval, Arc and similar tools draw vector objects. 

WINDOWS (1) The brand name of a family of Microsoft operating
systems, including Windows 95, Windows 98, and Windows NT. (
The separate areas on screen in which programs display informa

WITNESS EXTENSION Witness line part extending past dimension 
arrows.

WITNESS GAP Space between an object and dimension witness 
lines.

WRAP To change text margins so text flows around or remains 
inside a vector object.

X-HEIGHT The height of a lowercase x in a given font; the height, 
measured from the base line, of the main portion of most lowerca
letters in a font, excluding ascenders and descenders.

ZOOM To increase or decrease the magnification of a document

 0.38 ' 

 0.80 ' 

Witness extensions
2 TRANSFER MODE / ZOOM
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Numerics
1 Side command 18.1
2 Sides command 18.1
3D effects 18.15

A
About Canvas command 3.1
absolute paths 8.10
absolute Smart Mouse 

constraints 17.11
Acquire as Proxy option 7.5
Acquire command 25.1, 29.3
Acquire commands 7.3-7.4
acquire modules 7.4
acquire modules, plug-in 25.2
acquiring

CVI files 7.5
files as proxies 29.3
from scanners 7.4
from TWAIN devices 7.4
images 7.4-7.5
JPEG files 7.5
Photoshop files 7.19
proxies 7.5
TIFF files 7.5

Acrobat (PDF) files 7.7
activating channels 26.23
Adaptive indexed mode 

palette 24.35
add, combining objects 18.8
Add Effect command 2.3
adding

anchor points 16.12, 16.14
dictionary words 20.13
tangent line handles 16.13
Toolbar buttons 9.17

Add Noise filter 27.21
Add Visibility Mask command 24.6, 

26.29

Adobe FrameMaker 10.15
Adobe Photoshop file format 7.19, 

26.17
Again command 3.12
Airbrush tool 24.19
Align command 10.23
aligning

objects 10.23
text 21.27
text vertically 21.29

alignment guides and objects 5.11
Align palette 10.23
Align To Object (inks) 12.22, 12.24
All (image selection) command 26.2
alpha channels 26.18

see channels
Alt key 1.2
anchor points 16.24

adding 16.14
corner 16.18
deleting 16.14
selecting 10.2, 16.13
smooth 16.18
tangent lines 16.19

Angle dimensioning tool 17.5
Angle preference 9.6
angular measurements 9.3
Animated GIF tool 8.17-8.18
Animation documents 5.3
Animations

onion-skinning 5.3
Anti-Aliased

slide shows 6.14
Anti-aliased Canvas Objects 

preference 9.4
Anti-aliased Clipboard 

preference 9.4
apostrophes, typographical 9.8
Appearance control panel 3.8
Append Brushes command 24.27
appending inks 12.7
Arc 3 Points tool 15.3
Arc Radius tool 15.3
Arc tool 15.1-15.2, 15.8

Area dimensioning tool 17.5
Arrange Icons command 4.7
Arrange submenu commands 10.22
arranging

objects 10.22
Toolbar buttons 9.18

Arrow manager 13.14
arrows

customizing 13.14
presets 13.6
removing 13.7

Arrow tab 13.6
Attach command 2.3
Attach Mask command 14.10, 14.17
attributes

changing text 20.6
finding text 20.6
pasting 10.12
Toolbar buttons 9.16

attributes of objects 10.1
Auto Cache Images option 4.15
Auto Curve tool 16.1, 16.5
Auto Levels option 27.9
Auto-scroll to selection 

preference 9.4
Auto Trace command 25.14
Auto Word Select preference 9.7
Average (Blur) command 27.14
Average command 27.14

B
background color 24.12
background color icon 26.9
background inks 21.11
background updates, preventing 9.2
backup documents 9.2
Baseline dimensioning tool 17.5
baseline position, text 21.17
Basic Smart Lines tool 15.19
bevel line joins 13.14
Bézier curve paths 16.24
INDEX I.1
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Bézier curves
see paths

Bézier envelope effect 18.15
Bilinear interpolation method 9.4
Bind Group command 18.24
binding text 23.5

removing bind 23.8
to a circle 23.8

Bind Text command 23.5
bind to path object blends 18.11
Black & White image mode 24.33
Black Body palette 24.37
Blend command 18.10

bind to path 18.11
creating borders 18.12
dynamic 18.11
point to point 18.11
rainbow 18.11

blending
colors 12.15
gradient inks 12.16

Blend tool 24.20, 26.28
Blur filter 27.14
Blur More filter 27.14
Blur tool 24.25
bold character style 21.16
Bold font style 21.16
Border command 26.13
borders

creating with Blend 
command 18.12

trimming image borders 25.7
Both Axes (flip) command 23.11
bounding box 10.25

described 10.3
restoring after rotation 10.30

Break Composite command 16.23
breaking

composite paths 16.22
paths 16.12

Brightness/Contrast command 27.6
Bring to Front command 10.22
Browse button 8.8
brushes 24.14

creating 24.27
defining with selection 24.28

deleting 24.28
editing 24.28
loading from disk 24.29
modifying 24.28
saving to disk 24.29

Brushes palette 3.7, 24.13
Brush Options command 24.27
Bucket tool 24.19
Burn mode 14.21
Burn tool 24.24
butt end cap

see flat end cap
buttons, web 8.13-8.16

C
Cache Object command 4.14-4.15
Cache options 4.15
Calculate command 28.14
Calligraphic option 13.12
Camera tool 24.9
cancelling actions

see Undo command
Cancel Publisher command 7.27
Cancel Subscriber command 7.28
Canvas clip art 11.1
Canvas Clip Art and URW Font 

Library 11.1
Canvas Dictionary 20.11
Canvas Drawing format (OLE) 7.23
Canvas Image File 29.1, 29.8
Canvas Settings file 3.10, 12.7
Canvas Tool Settings file 8.16
Canvas Tools folder 25.2
capitalization 21.17
center, drawing objects from 15.1
Center dimensioning tool 17.5
Center-justification command 21.27
center of rotation 10.29
centerpoint, skewing 10.27
Center Snap option 15.8
Chain dimensioning tool 17.5
channel masks 14.2, 14.7-14.13, 

18.5, 26.18, 26.20, 26.25-26.27

Channel Options dialog box 26.23
channels

activating 26.23
alpha 14.8, 26.18, 26.20
auto tracing 25.14
calculations with 28.14
channel masks 26.20, 26.27
color 26.18-26.19
composite 26.19
composite channels 26.18
creating 26.22
deleting 26.22
displaying a single 

channel 26.23
display options 9.4
isolating a selection 28.11
mask options 26.23
options 26.23
renaming 26.23
saving selections in 26.16

Channels palette 14.12, 
26.18-26.19, 26.22, 26.26-26.27, 
26.29

character formatting 21.12-21.22
fonts 21.13
font styles 21.16
horizontal and vertical 

scaling 21.21
kerning 21.18
preventing changes to 21.21
special characters 19.5
type size 21.15
type styles 22.1

Check Proxies command 29.6
Chinese fonts 9.9
choke trap 10.39
Circle 3 Points tool 15.3
Circle Radius tool 15.3
circles, drawing 15.2
Clean Up By Name command 3.9
Clean Up command 3.9
Clean Up Palettes command 3.8
Clear command 10.7
clearing

inks 12.8
clip art 4.5, 11.1-11.4
INDEX



placing 11.3
searching 11.2

Clip Art command 11.1
Clip Art palette 11.1
Clipboard 7.23, 10.7-10.8, 10.16

pasting into selections 26.10
clipping paths

applying effects to 18.6
creating 18.4
defined 18.4
editing 18.5
from text 23.10
removing 18.5
showing and hiding 18.5

cloning options
see Rubber Stamp tool 24.19

Close box and button 4.6
closed paths 16.15
closing

documents 4.6
palettes 3.8

Clouds (render) command 28.1
CMYK color 12.11, 12.14
CMYK Color mode 24.40, 26.18
color

applying 12.3
blends 12.15
CMYK 12.11, 12.14
Color Dropper tool 12.3, 24.13
Color Editor dialog box 12.16
Color Range files 26.5
color systems 12.11
commercial systems 12.12
custom colors in pop-up 

palettes 12.15
defining 12.11
Dither Colors preference 9.2
finding reference system 

colors 12.14
gamut warning 12.13
gradient inks 12.16
Grayscale 12.11
HSL 12.11
identifying inks 12.14
inks 12.1
ink tile size 12.8

mixing two colors 18.20
models 24.31
of layout area 3.4
outside of Canvas 12.4
painting with 24.12
PANTONE 12.14
pen inks 12.1
printing options 4.21
reference color names 12.14
Registration ink 4.24
RGB 12.11
saturation 27.13
selecting 12.3
selecting in images 26.7
separations 10.38
Spot Color option 12.10
tints 12.12
Toyo 12.14
transfer mode effects 14.22
Trumatch 12.14
wheel 27.12

Color Balance command 27.6
color channels 26.18
Color Channels preference 9.4
Color Dropper tool 12.3, 24.13
Color Editor dialog box 12.16
Color Equalization command 27.13
Colorize command 18.20
Colorize option 27.13
Color Range command 26.1, 26.4, 

26.6
color separations 9.5, 12.11

previewing 4.19
Color Table command 24.36
color tables, saving and 

loading 24.37
color Wheel filter 28.2
Column Guides command 9.10, 

19.10
Column Guides dialog box 9.10
columns

controlling breaks 21.36
creating 19.7
flowing text 19.20
guides 19.9
layout 19.9

margins 19.7
modifying 19.11
settings 19.12
Vertical checkbox 9.10
width 21.33

Column Selection tool 26.3
Combine command 18.6
Command key 1.2
commands

1 Side 18.1
2 Sides 18.1
About Canvas 3.1
Acquire 7.3-7.4, 29.3
Add Effect 2.3
Add Noise 27.21
Add Visibility Mask 24.6, 26.29
Again 3.12
Align 10.23
All (image selection) 26.2
Arrange Icons 4.7
Attach 2.3
Attach Mask 14.10, 14.17
Auto Trace 25.14
Average 27.14
Bind Group 18.24
Bind Text 23.5
Blend 18.10
Blur 27.14
Blur More 27.14
Border 26.13
Both Axes (flip) 23.11
Break Composite 16.23
Brightness/Contrast 27.6
Bring to Front 10.22
Cache Object 4.14-4.15
Calculate 28.14
Cancel Publisher 7.27
Cancel Subscriber 7.28
Check Proxies 29.6
choosing 1.2
Clean Up 3.9
Clean Up By Name 3.9
Clean Up Palettes 3.8
Clear 10.7
Clip Art 11.1
INDEX I.3
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Clouds (render) 28.1
Color Balance 27.6
Color Equalization 27.13
Colorize 18.20
Color Range 26.4
Column Guides 9.10, 19.10
Combine 18.6
Comments 10.41
Configure Fine Kern 21.19
Contents 1.3
Contract 26.12
Convert to Lens 2.12
Convert To Paths 10.30, 23.14
Convert to Paths 16.21
Copy 10.7, 10.16
Copy As Image 10.15
Copy at 4X 10.15
Copy at 8X 10.15
Copy Options 10.8
Copy to Layers 10.23
Copy With EPS 10.14
Create 24.4
Create Publisher 7.26
Crop 25.7
Curves 27.9
Custom (filter) 28.12
Customize 9.15-9.20
Cut 10.7, 26.9
Date 19.9
Date Stamp 19.9
Defloat 26.11
De-Interlace 27.23
Delete 6.7
Delete View 4.11
Deneba Home Page 1.3
Desaturate 27.5
Despeckle 27.22
Detach 2.3, 26.26
Detach Mask 14.13-14.14, 

14.19
Disperse 6.10
Display Options 3.15, 4.15
Dock All Palettes 3.9
Document Layout 6.2
Document Setup 5.4, 9.21
Duplicate 10.7, 10.16

Dust and Scratches 27.21
Edit 10.4-10.5
Edit > Object 2.5
Edit Channel Mask 14.11, 

26.26
Edit Path 10.4, 16.11
Emboss 28.3
Envelope 18.12, 23.13
Exit 3.1
Expand 26.12
Export 7.3, 26.17
Extrude 18.15, 23.13
Feather 26.9, 26.27
Fill 28.12
Find 10.6
Fit Bézier 16.24
Fit to Objects 4.11
Fit to Selection 4.11
Fit to Window 4.11
Flip Both Axes 10.30
Flip Horizontal 10.30
Flip Vertical 10.30
Float 26.11
Footer 19.8
Fractalize 18.21-18.22
Freeform 10.26
Gamut Warning 4.13
Gaussian Blur 27.14
Get All Now 7.28
Get Edition Now 7.28
Grids 5.9-5.10
Group 10.19
Grow 26.7
Guides 5.11
Header 19.8
Hide Clipboard 10.7
Hide Edges 26.1
Hide Grids 5.9
Hide Page Breaks 5.5
Hide Printable Area 5.7
Hide Rulers 5.8
Hide Size 17.2
Hide Spelling Errors 20.12
Hide Text Boxes 19.7
Hide Text Invisibles 20.4
Hide Text Ruler 21.5

High Pass 28.10
Histogram 27.2
Home View 4.11
Horizontal (flip) 23.11
Hue/Saturation 27.11
in context menus 3.14
Increase (text size) 21.15
Insert 6.6
Insert Object 7.23-7.24
Insert Picture 19.16
Inside Shape (wrap) 23.2
Inverse 26.6
Invert 27.5
Join (paths) 16.17
Levels 27.7
Links 7.25
Live Curve Editing 16.7
Load (image selection) 26.16
Lock 10.23
Loose (kerning) 21.19
Loosen (kerning) 21.19
Loosen (leading) 21.23
Loosen Fine Kerning 21.19
Macros 11.4
Make Composite 16.22
Make Proxy 29.2
Maximum 28.11
Median 27.21
Minimum 28.11
Motion Blur 27.15
Move 10.21
Navigator 4.12
New 5.1, 9.21
New Channel Mask 14.9, 26.25
New Image from 

Selection 26.13
None (selection) 26.1
Normal (kerning) 21.19
Object Specs 10.32
Offset 28.5
Offset Path 18.3
Open 4.1, 7.1
Output Resolution 14.23
Overprint 10.40
Page # 19.9
Page Setup 4.19, 5.5
INDEX



Paste 9.3, 10.7, 10.16
Paste and Place 10.7, 10.11
Paste Attributes 2.4, 10.12
Paste Into 26.10
Paste Link 7.24
Paste Special 7.24, 20.15
Path to Selection 26.8
Place 4.3, 7.1, 19.15
Posterize 27.3
Preferences 9.1, 9.21
Print 4.19-4.23
Printer Setup 5.5
Print Preview 4.19
Properties 4.16
Proxy Info 29.4, 29.7
Publisher Options 7.27
Put Away Palettes 3.8
Quit 3.1
Radial Blur 27.17
Redo 3.12
Reduce (text size) 21.15
Reduce Points 16.23
Refresh 4.8
Remove Effects 10.26, 18.3
Remove Wrap 23.2
Render 24.7-24.8
repeating 3.12
Repel 23.3
Repel Options 23.3
Replicate 10.16
Resolution 25.10
Revert 4.6
Ripple 28.6
Rotate 10.29, 23.11
Rulers 3.11, 5.8, 9.10
Rules 21.31
Save 4.5
Save (image selection) 26.16
Save As 4.5, 7.2, 9.21, 26.17
Scale 10.31, 25.6
Select 10.5
Select All 10.3
Selection to Path 26.14
Send All Now 7.28
Send Edition Now 7.27

Send to Back 10.22
Send to Guide Layer 5.11
Send to Layers 10.23
Set Tab Length 3.9
Shadow 18.22, 23.12
Sharpen 27.20
Sharpen Edges 27.20
Sharpen More 27.20
Show (SpriteEffects) palette 2.5
Show/Hide Docking Bar 3.8
Show/Hide Guides 5.11
Show/Hide Status Bar 3.10
Show/Hide Text Flow 

Bars 19.20
Show/Hide Toolbar 3.6
Show/Hide Transparency 14.1
Show/Hide Transparency 

Preview 14.7
Show Added Words 20.14
Show Channels 26.18-26.19, 

26.27
Show Clipboard 10.7
Show Edges 26.1
Show Grids 5.9
Show Page Breaks 5.5
Show Printable Area 5.7
Show Rulers 5.8
Show Size 17.2
Show Spelling Errors 20.12
Show Text Boxes 19.7
Show Text Invisibles 20.4
Show Text Ruler 21.5
Show Toolbox 3.5
Shuffle Down 10.22
Shuffle Up 10.22
Similar 26.7
Slant Margin 23.4
Slide Show 6.13
Smart Mouse 17.11
Smart Mouse (snap) 17.12
Smooth 26.13
Smooth (paths) 16.2
Solarize 28.3
Spell Check Document 20.13
Spell Check Selection 20.13
Spherize 28.8

Spread 10.40
Stack 4.7
Subscriber Options 7.28
Subscribe To 7.27
Threshold 27.3
Tight (kerning) 21.19
Tighten (kerning) 21.19
Tighten (leading) 21.23
Tighten Fine Kerning 21.19
Tile 4.7
Tile Across 4.7
Tile Down 4.7
Time 19.9
Time Stamp 19.9
Trace Contour 28.4
Transform 18.24
Transparency 10.4
Trim 25.7
Twirl 28.8
Type 21.10
Uncache Object 4.14
Unchache Object 4.16
Undo 3.12, 9.1
Ungroup 10.19
Unlink Proxy 29.5
Unlock 10.23
Unsharp Mask 27.20
Unsmooth (paths) 16.2
Update Proxies 29.7
Vanishing Point 15.8, 18.1
Vertical (flip) 23.11
Very Loose (kerning) 21.19
Very Tight (kerning) 21.19
View Fonts 21.15
Wheel (render) 28.2
Wireframe 4.14
Zoom Blur 27.18
Zoom In 4.9
Zoom Out 4.9

commands, choosing 1.2
Comments command 10.41
composite channels 26.18-26.19
composite paths 16.22
Computer Graphics Metafile (CGM) 

format 7.8
concentric circles
INDEX I.5
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converting to paths 16.21
drawing 15.13

Concentric Circles tool 15.13-15.14
configuration managers

Inks 12.7
Strokes 13.8

Configure Fine Kern 
command 21.19

constraint range, Smart Mouse 17.13
constraints

see Snap options 15.6
Contents command 1.3
context menu 3.14, 10.4, 14.7, 

16.12, 24.14
Continue Spell Check 

command 20.14
Contract command 26.12
contrast

adjusting 27.6
creating high-contrast 

images 27.3
Control key 1.2
Convert to Lens command 2.12
Convert To Paths command 10.30, 

16.11, 16.21, 23.14
coordinate system 10.22
Coordinate System preference 9.3
Copy As Image command 10.15
Copy at 4X command 10.15
Copy at 8X command 10.15
Copy command 10.7, 10.16
copying

anti-aliasing 10.9
as images 10.9
attributes 10.12
attributes of objects 10.12
by dragging 10.21
into selections 26.10
objects 10.7
objects to layers 10.23
text objects 19.7
with PostScript 

information 10.9
Copy Options command 10.8
Copy to Layers command 10.23
Copy With EPS command 10.14

corner anchor points 16.12, 
16.18-16.19

corner radius, rounded 
rectangle 15.6

Create Absolute URLs option 8.9
Create backup when saving 

preference 9.2
Create command 24.4
Create Image dialog box 24.5
Create Publisher command 7.26
creating

basic shapes 15.1
channel masks 14.9, 26.25
channel masks from 

selections 26.27
channels 26.22
composite paths 16.22
dimension objects 17.2
lenses 2.12
new documents 5.1
new inks 12.7
objects from selections 26.13
paint objects 24.2, 24.4
proxies 29.1
sections 19.10
text objects 19.1
transparency effects 26.25
transparency fades 26.28
vector masks 14.15
vector objects 10.33, 15.1

crop, combining objects 18.8
Crop command 25.7
crop marks 4.24
cropping

constraining 25.10
with the selection tool 25.10

Crop tool 25.7
Ctrl key 1.2
cubes, drawing 15.13
Cube tool 15.13, 15.15
current inks 12.2
current strokes 13.2, 13.4
curves

adding anchor points 16.14
adding segments 16.14
closing and opening 16.15

deleting segments 16.14
drawing 16.3

Curves command 27.9
Curve tool 16.1, 16.3
cusp anchor points 16.12
custom

color tables 24.36
filters 28.12
inks in pop-up palettes 12.15
keyboard shortcuts 9.15
Toolbar buttons 9.15
views 4.11

Custom (filter) command 28.12
Customize command 9.15-9.20
Cut command 10.7, 26.9
cutting and pasting

into selections 26.10
objects 10.7
text 20.4
text objects 19.7

cv7tool.set file 8.16
CVI (Canvas Image File) format 29.1

D
Darken mode 14.21
dashes

customizing 13.16
presets 13.6
removing 13.7

Dash manager 13.16
Data pop-up menu 3.11
date, inserting in documents 19.8
Date command 19.9
Date Stamp command 19.9
DCS format 7.10
decimal precision preference 9.14
default

for new documents 5.1
inks 12.2
strokes 13.2
type attributes 21.4

Define Brush command 24.27
Defloat command 26.11
INDEX



De-Interlace filter 27.23
Delete Brush command 24.27
Delete command 6.7
Delete key 10.7
Delete View command 4.11
deleting

anchor points 16.12, 16.14
channel masks 26.26
channels 26.22
dictionary words 20.14
macro objects 11.4
objects 10.7
path segments 16.14
preset inks 12.7
preset strokes 13.10
sections 19.12
Smart Mouse constraints 17.14
tangent lines 16.12
text 20.4

Deneba Home Page command 1.3
density, fractals 18.22
Desaturate command 27.5
deselecting

in images 26.1
objects 10.2
text 20.4

Despeckle filter 27.22
Destination folder 8.9
Detach command 2.3
detaching channel masks 26.26
Detach Mask 

command 14.13-14.14, 14.19, 
26.26

dialog balloons 15.9
Diameter dimensioning tool 17.5
dictionary, spelling 20.11
Difference mode 14.21
Diffusion dithering option 24.36
dimensioning tools 17.2

customizing 17.6
types described 17.4

dimension objects
attributes 17.5
editing 17.6
extensions 17.10
gaps 17.10

standards 17.10
text properties 17.6
text styles 17.9
tolerance 17.10
units 17.10

dimensions, displaying while 
drawing 17.2

dimension standards, saving and 
deleting 17.10

Directories command 8.8
directory path 8.8
Direct Selection tool 10.3
Disk Drive preference 9.15
Disperse command 6.10
displaying

flow bars 19.20
gamut warnings 4.13
rulers 5.8
selected object type 10.3
slide shows 6.14
spelling errors 20.12
wireframe views 4.14

display modes 4.13
Display Options command 3.15, 

4.15
distort

see Envelope command and 
skewing objects

distributing objects 10.23
dithering color 9.2
Dithering options 24.36
divide, combining objects 18.9
Dock All Palettes command 3.9
document

paper color 5.6
Document Layout command 6.2
Document Layout palette 6.2-6.12
documents

activating document 
windows 4.7

applying section settings 19.14
Canvas 5 format 14.8
Canvas Illustration 5.1-5.3
Canvas Presentation 5.1-5.3
Canvas Publication 5.1-5.3
closing 4.6

columns 19.9
comments 10.41
creating 5.1
discarding changes 4.6
display modes 4.13
formatting text 21.5
GIF Animation 5.3
keywords 4.17
layout 6.1-6.12
margins 5.5
moving objects in 10.23
navigation controls 3.4
New Document Wizard 5.2
opening 4.1
orientation 5.2, 5.5
page layout 5.5
placing 4.3-4.4
printing 4.18, 4.20-4.23
properties 4.16
rulers and scale 5.7
saving as web pages 8.18
scrolling 4.8
setting up 5.4
size 5.2
spell checking 20.11
statistics 4.16
substituting fonts 4.2
templates 5.3, 9.21
two-sided 5.2, 5.6
types of 5.2
units 5.2
viewing 4.7, 4.11
windows 4.7
zooming 4.9-4.11

Document Setup command 5.4, 
9.21

Document size 5.2
Dodge mode 14.21
Dodge tool 24.24
dots per inch 25.5
double cusp, envelope effect 18.14
double spacing lines of text 21.23
Drag & Drop Text preference 9.7
drawing

arcs 15.1-15.2
by numbers 15.8
INDEX I.7



I.8
circles 15.2-15.3
concentric circles 15.13-15.14
cubes 15.13
curves 16.4
EasyShapes 15.9-15.12
freehand shapes 16.3
from center of objects 15.1
grids 15.13, 15.16
lines 15.1-15.2
multigons 15.17
objects 10.33
objects within images 24.30
ovals 15.1-15.2
paths 16.4
polygons 16.1
rectangles 15.1
rounded rectangles 15.2
rounded squares 15.2
setting options for 9.3
Smart Lines 15.19
spirals 15.13, 15.16
squares 15.2
stars 15.13
with Snap options 15.6
with snap points 5.10

Drawing (preferences) tab 9.3
Drawing Interchange file format 7.9
drawing scale 5.7
drawing vector objects 15.1
Draw text as Béziers preference 9.8
Draw with Cache option 4.15
drop caps 21.36
drop shadows 18.22
Duotone Curves dialog box 24.42
Duotone image mode 24.40
Duotone Inks command 24.42
Duotone Options dialog box 24.41

loading and saving duotone 
information 24.42

Duplicate command 10.7, 10.16
preference 9.3

duplicating
by dragging 10.17
using modifier keys 10.17
while rotating 10.18
while skewing 10.18

Dust and Scratches filter 27.22
DXF export options 7.9
Dynamic Disk Allocation 

preference 9.15
Dynamic Link Libraries (DLLs) 3.2
dynamic object blends 18.11

E
EasyShapes 15.9-15.12
Edit > Object command 2.5
Edit Channel Mask command 14.11, 

26.26
Edit command 10.5
Edit commands 10.4
editing

arcs 15.5
channel masks 14.11, 26.26
clipping paths 18.5
comments 10.42
concentric circles 15.14
context menus 3.14
cubes 15.15
dimension objects 17.6
EasyShapes 15.11
finding text 20.6
grids 15.16
macro objects 11.5
masks 14.2
multigons 15.18
object data 10.33
objects 10.3
paint objects 24.10
paragraph rules 21.31
pasting attributes 10.12
pasting into selections 26.10
paths 16.7, 16.11, 16.19
preserving visibility 26.30
proxies 29.4
resizing 15.4
rotated objects 10.30
Smart Lines 15.20
specialized objects 16.11
spirals 15.16

SpriteEffects 2.5
tabs 21.9
text 20.1, 21.5
vector masks 14.17
vector objects 16.11

edition file 7.27
edit mode 10.3

paint objects 24.10
paths 16.11
proxies 29.4
text 20.1

Edit Path command 10.4, 16.11
effects

Blend command 18.10
clipping paths 18.6
Colorize command 18.20
Combine command 18.6
drop shadows 18.22
Envelope command 18.12
extrusion 18.15
Fractalize command 18.21
lenses 2.12
Offset Path command 18.3
perspective 18.1
SpriteEffects 2.1-2.18
three-dimensional 18.11

embedding (OLE) 7.25
Emboss command 28.3
Enable two-byte script 

preference 9.9
end caps 13.14
endpoints of paths 16.15
Engineering coordinate system 9.3
English measurement units 5.8
Enter key 1.2
Envelope command 18.12

enveloping text objects 23.13
EPS (Encasulated PostScript 

Format) 7.9-7.13
Equivalent Root folder 8.9
Eraser tool 24.18, 26.30
Exact indexed mode palette 24.35
Exit command 3.1
Expand command 26.12
Export commands 7.3
exporting
INDEX



Canvas Image Files 29.8
files 24.8
text 20.16

Export submenu 26.17
extensions (Mac OS) 3.2
extensions, dimension objects 17.10
Extrude command 18.15

extruding text objects 23.13

F
facing pages 6.1
Faster Text/Poor Color 

preference 9.9
favorites, Internet 7.6
Feather command 26.9, 26.27
feet measurement units 5.8
file formats

Acrobat (PDF) 7.7
Canvas Image File 29.1
Computer Graphics Metafile 

(CGM) 7.8
Drawing Interchange 

Format 7.9
EPS 7.9-7.13
GIF 7.7
Graphics Interchange Format 

(GIF) 7.14
HTML 8.18
Internet formats 7.5
JPEG 7.7, 7.14
QuickDraw 3D Metafile 7.19
QuickTime Movie 7.20
Tag Image File Format 

(TIFF) 7.22
Text 7.22

File Transfer Protocol (FTP) 7.6, 8.2
Fill command 28.12
fillet 16.13
filling objects 12.2
fill ink icon 12.1
fill inks 12.2, 21.10

customizing shortcuts 9.18
filter effects 2.1-2.18
filters

Add Noise 27.21
applying SpriteEffects 2.2
Average 27.14
Blur 27.14
Blur More 27.14
Clouds 28.1
Custom 28.12
De-Interlace 27.23
described 28.1
Despeckle 27.21
Dust and Scratches 27.21
Emboss 28.3
Fill 28.12
Gaussian Blur 27.14
High Pass 28.10
Histogram 27.2
Maximum 28.11
Median 27.21
Minimum 28.11
Motion Blur 27.15
Offset 28.5
plug-ins 2.2, 9.4
Radial Blur 27.17
Ripple 28.6
Sharpen 27.20
Sharpen Edges 27.20
Sharpen More 27.20
Solarize 28.3
Spherize 28.8
Trace Contour 28.4
Twirl 28.8
Unsharp Mask 27.20
Wheel 28.2
Zoom Blur 27.18

Filters submenu 9.4
Find command 10.6
finding

objects 10.6
text 20.6

Find palette
Objects tab 10.6
Text tab 20.5

Fit Bézier command 16.24
Fit to Objects command 4.11
Fit to Selection command 4.11
Fit to Window command 4.11

Fit to Window preference 9.2
Fixed Angle Smart Lines tools 15.19
Fixed Length Smart Lines tool 15.19
flat end caps 13.14
Flip Both Axes command 10.30
Flip Horizontal command 10.30
flipping

objects 10.30
text 23.11

flipping objects 10.25
Flip Vertical command 10.30
Float command 26.11
flow bars 19.20
flow chart boxes 15.9
fonts

applying 21.7
Chinese 9.9
finding and changing 20.8
including in EPS files 7.13
installation tips 21.14
Japanese 9.9
Korean 9.9
preventing changes to 21.21
selecting 21.7
specifying 21.13
styles 21.16
substituting 4.2
Toolbar buttons 9.16
type size 21.15
western languages 9.9

Fonts folder 21.14
foot and inch marks 9.8
Footer command 19.8
foreground color 24.12
Fractalize command 18.21-18.22
fractions preference 9.14
frame inks 21.12
frames 5.3, 8.17
frame strokes 21.12
Freeform command 10.26

selection preference 9.2
freeform image selections 10.27
freeform mode

rotating and skewing objects 
in 10.26

text 23.11
INDEX I.9



I.1
vector objects 10.26
Freehand tool 16.1, 16.3
From Printer option 5.6
FTP 8.2
Full-justification command 21.27

G
gamut warning 12.13
Gamut Warning command 4.13
gaps, dimension objects 17.10
Gaussian Blur filter 27.14
Get All Now command 7.28
Get Edition Now command 7.28
GIF file format 7.7
gradient inks 14.14

applying 12.16, 12.19
creating 12.16
customizing 12.16
Gradient Vector tool 12.19
modifying 12.19
rainbow 12.17
styles 12.17, 12.19

Gradient manager 12.17
Gradient Vector tool 12.18
Graphics Interchange Format 

(GIF) 7.14
Grayscale colors 12.11
Grayscale image mode 24.34
Grayscale palette 24.37
greeking text 9.8
grid layers 6.11
GridMaker tool 15.13, 15.16
grids

converting to paths 16.21
drawing 15.13

Grids command 5.9-5.10
Group command 10.19
Grow command 26.7
guide layers 6.11
guides 5.11

columns 19.9
setting position 

numerically 5.12

Guides command 5.11

H
Halftone Frequency preference 9.6
Halftone preferences 9.6
halftone screens 25.12
Hand tool 4.8
Hard Light mode 14.21
hatch inks 12.21
Hatch manager 12.21
Hatch tab 12.20
Header command 19.8
Help system 1.3
Hide Clipboard command 10.7
Hide Edges command 26.1
Hide Grids command 5.9
Hide Page Breaks command 5.5
Hide Printable Area command 5.7
Hide Rulers command 5.8
Hide Size command 17.2
Hide Spelling Errors command 20.12
Hide Text Boxes command 19.7
Hide Text Flow Bars command 19.20
Hide Text Invisibles command 20.4
Hide Text Ruler command 21.5
Hide Toolbar command 3.6
High Pass command 28.10
Histogram command 27.2
Home View command 4.11
Horizontal (flip) command 23.11
Horizontal dimensioning tool 17.5
horizontal skewing 10.27
HSL color model 12.11
HTML file format 8.18
HTML format 7.7
HTTP addresses 8.2
HTTP Protocol 7.6
Hue/Saturation command 27.11
hyperlinks

absolute paths 8.10
complete URLs 8.11
defined 8.1
Destination folder 8.9

Equivalent Root folder 8.9
hypertext 8.5
invalid characters 8.7
relative paths 8.2, 8.10
root directory 8.8
text styles 8.5
to e-mail 8.2
to FTP addresses 8.2
to HTTP addresses 8.2

hypertext 8.1-8.2, 8.5
HyperText Transport Protocol 

(HTTP) 7.6
Hypertext Transport Protocol 

(HTTP) 8.2
hyphenation 21.34

I
illustration area 14.3
Illustration documents 5.2-5.3

placing 4.3
setting up 5.4

Illustrator, exporting EPS files to 7.11
image channels 26.17
image modes 24.31

Black & White 24.32
changing 24.32
CMYK Color 24.40
Duotone 24.40
Grayscale 24.34
Indexed 24.34
LAB Color 24.40
Multichannel 24.43
RGB Color 24.39

image proxies 29.1
images

acquiring 7.4
acquiring proxies 29.3
adding visibility masks 24.5
auto tracing 25.14
Black & White mode 24.33
changing modes 24.32
changing resolution 25.11
channels 26.18
0 INDEX



clearing selections 26.9
copying selections 26.9
creating 24.2, 24.4, 24.9
cropping 25.6, 25.10
distorting 28.8
feathering selection edges 26.9
floating selections 26.11
freeform selections 10.27
in texture inks 12.23
moving selections 26.11
pasting into selections 26.10
preserving visibility 26.30
printing proxies 4.22
proxies 29.1
resampling 25.10
Ripple filter 28.6
rotating and skewing 

selections 10.27
scanning 25.1
scanning resolution 25.4
screening 24.33
selecting areas 26.2
selections 26.7, 26.18
size and resolution 25.6
trimming borders 25.7
Twirl filter 28.8

image selections 10.27
importing

animations 8.18
EPS linked files 7.10
Photoshop files 7.19
see also acquiring
text 20.15

inches measurement units 5.8
Included Snap option 15.8
Increase (text size) command 21.15
indenting text

Text Ruler 21.25
Type palette 21.26

Indexed color palettes 24.37
Indexed image mode 24.35
Information area 3.11
inks

appending 12.7
applying 12.4
arranging 12.8

blends 12.15
clearing presets 12.8
color 12.1
Color Editor dialog box 12.16
color tile size 12.8
creating 12.7
current 12.2
default 12.2
default for text 12.2
fill 12.2
gamut warning 12.13
gradients 12.16
gradient styles 12.18
hatch 12.20
hatch line group 12.21
loading 12.7
naming 12.10
pen 12.1
Registration color 4.24
saving 12.7
selecting 12.3
Spot Color option 12.10
symbol 12.22
text 21.10
texture 12.23
Toolbar buttons 9.18

Inks palette 12.1
Color tab 12.1
configuration managers 12.7
Gradient tab 12.16
Hatch tab 12.20
Symbol tab 12.22
Texture tab 12.23

Inline (preferences) tab 9.13
insert

date 19.8
page numbers 19.8
time 19.8
total page count 19.8

Insert command 6.6
insertion point 20.2
Insert Object command 7.23-7.24
Insert Picture command 19.16
Inside Shape (wrap) command 23.2
interlacing in GIF files 7.18

Internet 8.2
accessing files 7.5
favorites 7.6
file exchange 7.5-7.7
HTTP protocol 7.6
Internet button 7.5
Internet Protocol (IP) 

addresses 7.6
protocols 7.6

Internet graphics 24.34
Interpolation preference 9.4
intersect, combining objects 18.8
Inverse command 26.6
Invert command 27.5
Italic font style 21.16

J
Japanese fonts 9.9
Japanese Language Kit 9.9
Join (paths) command 16.17
joining curves 16.12
JPEG 7.14
JPEG file format 7.7
justification

last line of paragraph 21.33
vertical 21.29

justification commands 21.27

K
Keep with next paragraph 

option 21.36
kerning 21.18
keyboard keys 1.2
keyboard shortcuts 9.17
Kinked Smart Lines tool 15.20
Knife tool 16.16
knock outs and overprinting 10.38
Korean fonts 9.9
INDEX I.11



I.1
L
LAB Color mode 24.40, 26.18
Lasso tool 10.27, 26.3
launching Canvas 3.1
layers 6.1

grid 6.11
guide 6.11
options 6.7
placing 4.4
sending objects to 10.23
sharing 6.9
Status bar symbols 3.11
unsharing 6.10

layout, document 6.1
Layout area 3.4
Layout area color 3.4
leader characters 21.7
leading 21.23
Leading Character in dimension 

objects 17.7
Left-justification command 21.27
lenses

creating 2.12
frozen 2.16
selecting 10.6
using 2.12
viewpoints 2.14

letter spacing 21.32
Levels command 27.7
Lighten mode 14.21
lighting effects in extrusions 18.17
line group in hatch inks 12.21
line joins 13.13
lines

dashes 13.16
drawing 15.2
editing 15.19
painting 24.17
rules in text 21.31
transforming 18.25

Line tool 15.2, 15.8
linked text flows 19.20
Link Info tool 19.21
linking

(OLE) 7.25
hypertext 8.5
to pages 8.6
to sounds 8.17
web buttons 8.16

Links command 7.25
Live Curve Editing command 16.7
Load (image selection) 

command 26.16
Load Brushes command 24.27
loading

buttons 8.16
clip art 11.2
ink presets 12.7
inks 12.8
macro sets 11.6
shortcut configurations 9.18
stroke presets 13.10

Lock command 10.23
Locked Smart Lines tool 15.20
locking

character attributes 21.21
objects 10.23

Loose (kerning) command 21.19
Loosen (kerning) command 21.19
Loosen (leading) command 21.23
Loosen Fine Kerning 

command 21.19
lowercase character style 21.17
Lowercase command 21.16
luminance 14.8

M
Macintosh System palette 24.37
macro objects 11.1, 11.4-11.6

converting to paths 16.21
creating 11.4
deleting 11.4
editing 11.5
replacing 11.6
sets 11.6

Macros command 11.4
Macros tool 11.4

Magic Wand tool
see Wand tool

magnification in lenses 2.13
magnification of documents 4.9
Magnifying Glass tool 4.9
mailto tag 8.2
Make...times smaller option 29.2
Make Composite command 16.22
Make Proxy command 29.2
managers

Inks 12.7
Strokes 13.8

margins 5.5
text objects 21.26

Marker tool 24.18
Marquee tool 10.27, 26.1-26.2
masks

attaching 14.10, 14.16
channel masks 14.7-14.13
detaching 14.13, 14.19
paint objects as 14.10
SpriteEffects selection 

masks 2.7
transparency 14.6
vector masks 14.14-14.19
vector objects as 14.16

Master pages 6.2
Master slides 6.13
Maximize on opening preference 9.2
maximizing document windows 9.2
Maximum command 28.11
measurements

specifying units 3.13
using expressions 3.12
using fractions 3.12

measurement units 5.8, 9.10
measuring

objects 17.2
Show Size display 17.2

Median filter 27.21
meta data 4.16
metric measurement units 5.8, 9.10
Microsoft Word 10.15
Microsoft Word, pasting into 10.8
Minimum command 28.11
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Minimum disk space after allocation 
preference 9.15

miter joins 13.13
mix, combining objects 18.9
modes

CMYK Color 24.40
display 4.13
Duotone 24.40
for Color Dropper tool 12.5
Grayscale 24.34
images 24.32
Indexed 24.34
LAB Color 24.40
Multichannel 24.43
RGB Color 24.39

modifier keys 1.3
Motion Blur filter 27.15
mouse

modifier keys 1.3
Move command 10.21
moving

anchor points 16.18
dragging objects 

preference 9.3
objects 10.20, 18.25
segments 16.18
selections 26.11

Multichannel image mode 24.43
multigons

converting to paths 16.21
Multigon tool 15.13, 15.17
Multiply mode 14.20

N
navigation controls 3.4
Navigator command and 

palette 4.12
Nearest Neighbor interpolation 

method 9.4
Neon manager 13.17
Neon strokes 13.17-13.18
Neon tab 13.17
Neon tool 24.21
New Brush command 24.27

New Channel Mask command 14.9, 
26.25

New command 5.1, 9.21
New Image from Selection 

command 26.13
New Mask dialog box 26.25
No Background Updates 

preference 9.2
noise

Add Noise filter 27.21
Dust and Scratches filter 27.22
removing noise 27.21

None (selection) command 26.1
Normal (kerning) command 21.19
Normal mode 14.20
Number form preference 9.14
numbering pages 19.8

O
Object Linking and 

Embedding 7.23, 10.16
Canvas Drawing format 7.23
text files 20.15

objects
aligning 10.23
alignment 10.23
alignment guides 5.11
appearance when 

selected 10.3
arcs 15.2
caching 4.15
circles 15.3
comments 10.41
converting EPSF objects 7.13
converting EPS to Canvas 7.10
copying 10.7
creating 10.33
cutting and pasting 10.7
deleting 10.7
dispersing 6.10
distributing 10.23
dragging 10.21
EasyShapes 15.9-15.12
editing 10.3

editing data 10.33
editing rotated 10.30
edit mode 16.11
embedding 7.24-7.25
extruding 18.15
filleting 16.13
fill inks 12.2
finding 10.6
flipping 10.25
fractalizing 18.22
from auto tracing 25.14
getting inks from 12.10
group 14.19
grouping and 

ungrouping 10.19
group transparency 14.5
linking 7.24-7.25
locking and unlocking 10.23
macros 11.1, 11.4-11.6
moving 10.20
offsetting paths 18.3
paint 14.19
paint objects 24.3
pasting 10.7
pasting attributes 10.12
pasting into selections 26.10
path editing 16.7
paths 26.9
repelling text 23.2
resizing rotated 10.25
rotating 10.25
rotating and skewing 10.26
selecting 10.1
selecting by type and 

attributes 10.6
send or copy to layers 10.23
skewing 10.25
slicing 16.16
SpriteEffects 2.1-2.18
stacking order 10.22
styles 10.36
text 14.19, 21.5
transforming 18.25
trimming 18.7
types described 10.1
vector 14.19
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I.1
vertical text 9.9
Object Side dimensioning tool 17.5
Object Specs command 10.32
Object Specs palette

Data tab 10.34
Styles tab 10.36

objects within, Smart Mouse 
constraint 17.13

Oblique dimensioning tool 17.5
Offset command 28.5
Offset Path command 18.3
Offset submenu 28.1
OLE

see Object Linking and Embed-
ding

onion-skinning 3.4, 5.3, 6.9
opacity 14.2-14.5, 26.12

defined 14.3
Opacity slider 14.1
Open command 4.1, 7.1, 20.15
opening

clip art files 11.1
documents 4.1
Photo CD images 25.16

Option key 1.2
orientation, document layout 

area 5.2
orphan and widow lines 21.35
outline, combining objects 18.8
Outline font style 21.16
Output Resolution command 14.23
Output to maximum resolution 

preference 9.5
Oval Marquee tool 26.2
ovals, drawing 15.2
Oval tool 15.2, 15.8
Overlay mode 14.21
Overprint command 10.40
Overprint Object option 10.38
overset text 19.20
overset text indicator 19.19

P
Page # command 19.9

page breaks 5.5
page icons 5.3
PageMaker, pasting into 10.8
page numbering 19.8
pages

adding and deleting 6.6
defined 6.1
facing 6.1
From Printer option 5.6
hyperlinks to 8.6
master pages 6.10
moving 6.6
options 6.7
placing 4.4
printable 6.4
selecting 6.5
sending objects to 10.23

Page Setup command 4.19, 5.5
Paintbrush tool 24.18
painting

brush pointers 9.5
colors 24.12
creating objects 24.2
edit mode 26.18
Eraser tool 26.14
modes 24.16-24.17
opacity 24.15
options 24.13
preferences 9.4, 24.30
selections 26.13, 26.18
with vector objects 24.30

Painting (preferences) tab 9.4
painting modes

Add 28.15
Darken 28.15
Difference 28.15
Hard Light 28.15
Lighten 28.15
Multiply 28.15
Normal 28.15
Overlay 28.15
Screen 28.15
Soft Light 28.15
Subtract 28.15

painting tools
Airbrush 24.19

Blend 24.20
Blur 24.25
Bucket 24.19
Burn 24.24
Column Selection 26.2
Crop 25.7
Dodge 24.24
Eraser 24.18
Marker 24.18
Marquee 26.1
Neon 24.21
Oval Marquee 26.2
Paintbrush 24.18
Paint Object Creator tool 24.2
Pencil 24.17
Remote Move 26.11
Row Selection 26.2
Rubber Stamp 24.21
Sharpen 24.26
Smudge 24.23
Sponge 24.26
Wand 26.5

Paint Object Creator tool 24.2
paint objects 14.10, 14.19

adding visibility masks 24.5
backgrounds 24.6, 26.14
creating 24.2, 24.4, 24.9
cropping 25.10
defined 24.2
described 24.1
image modes 24.32
resolution 25.10
visibility masks 26.14

palettes 3.7
Black Body (color table) 

option 24.37
blending colors 12.15
browser safe 24.37
Clean Up Palettes 

command 3.8
color tables 24.37
color tile size 12.8
commands 3.7
docking 3.9
Docking bar 3.8
icons 3.7
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Object Specs 10.32
Put Away Palettes 

command 3.8
Transform 18.24

PANTONE colors 12.12, 12.14
in duotone images 24.41

Paper Color option 5.6
paragraph formatting 21.22-21.37

column breaks 21.36
hyphenation 21.34
indents 21.25
justification (alignment) 21.27
justifying last line 21.33
leading 21.23
letter spacing 21.32
line width 21.33
rules 21.31
spacing before and after 

paragraphs 21.25
text columns

see columns
type styles 22.1
word spacing 21.32

Parallel manager 13.18
Parallel Snap option 15.7
Parallel tab 13.18
Paste and Place command 10.7, 

10.11
Paste Attributes command 2.4, 

10.12
Paste command 9.3, 10.7, 10.16
Paste Into command 26.10
Paste Link command 7.24
Paste Special command 7.24, 20.15
pasting

attributes 10.12
attributes of objects 10.12
into image selections 26.10
text 19.16

paths
adding anchor points 16.14
adding segments 16.14
advanced editing 16.20
changing angle and 

length 16.21
closing and opening 16.15

converting text to 23.14
converting to selections 26.9
deleting segments 16.14
editing 16.7
filleting 16.13
from selections 26.14
joining 16.17
offsetting 18.3
pop-up menu for editing 16.12
reducing points 16.23
simplifying 16.23
slicing 16.16
straightening 16.20
tangent lines 16.19
text 19.4

Path Text tool 9.8, 19.4
Path tools 16.1
Path to Selection command 26.8
Pattern dithering option 24.36
patterns, creating with Blend 

command 18.12
Pencil tool 24.17
pen ink icon 12.1
pen inks 12.1

customizing shortcuts 9.18
Pen manager 13.13
pens

calligraphic 13.12
customizing 13.12
presets 13.4

Pen tab 13.4, 13.13
Perimeter dimensioning tool 17.5
Perpendicular dimensioning 

tool 17.5
Perpendicular Snap option 15.8
Perspective effects 18.1
Photo CD

acquiring images 25.16
Photoshop, exporting EPS files 

to 7.11
Photoshop file format 24.1
pica measurement units 5.8
pixel measurement units 5.8
pixels 24.1
Place command 4.3, 7.1, 19.15
placeholders 29.1

placing
documents 4.4
files 4.3
images 24.2
layers 4.4
pages 4.4
text 19.15

placing files
clip art 11.3
macro objects 11.5
Photo CD images 25.16
text files 20.15

Plain font style 21.16
plug-in acquire modules 25.1-25.2
plug-in host message 9.5
plug-ins

acquire modules 7.4
plug-ins, Photoshop-compatible 9.4
pointers, Smart Mouse 17.13
point size, type 21.15
point-to-point object blends 18.11
polygons

converting to Bézier 
curves 16.24

drawing 16.1
smoothing 16.2

Polygon tool 16.1, 16.24
Posterize command 27.3
PostScript 10.9
PostScript fonts 21.14
preferences

Angle 9.6
Anti-aliased Canvas 

Objects 9.4
Anti-aliased Clipboard 9.4
Anti-alias text 9.8
Auto-scroll to selection 9.4
Auto Word Select 9.7
Background Preview 9.6
Color Channels 9.4
Coordinate System 9.3
Create backup when saving 9.2
decimal precision 9.14
Disk Drive 9.15
Display tab 9.6
Dither Colors 9.2
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I.1
Drag and Drop Text 9.7
drawing 9.3
Draw Quality 9.7
draw text as Béziers 9.8
Dynamic Disk Allocation 9.15
Enable two-byte script 9.9
Faster Text/Poor Color 9.9
Fit to Window 9.2
For text from 9.13
Freeform Selection 9.2
Halftone 9.6
Halftone Frequency 9.6
Inline tab 9.13
Interpolation 9.4
Maximize (documents) on 

opening 9.2
Minimum disk space after 

allocation 9.15
Never 9.13
No Background Updates 9.2
No Preview 9.6
Number form 9.14
Object Caching 9.7
Output to maximum 

resolution 9.5
painting 9.4, 24.30
painting pointers 9.5
Pen size units 9.14
Plug-ins 9.4
Printing tab 9.5
Retain Selected Tool 9.2
Screen Compositing 14.22
Select across visible layers 9.2
Separate grayscales as 

black 9.5
Show original objects 9.3
Smart Copy 9.8
Snap text to single column 9.8
Total Preview 9.6
Type tab 9.7
Undo levels 9.1
Units tab 9.14
Use available system 

memory 9.15
Use Greeked text 9.8
Use printer’s default 9.6

User Info 9.15
Use Smart Quotes 9.8
Video LUT Animation 9.4
Virtual tab 9.14
When duplicating objects 

offset 9.3
When moving objects 

offset 9.4
Preferences command 9.1, 9.21
Presentation documents 5.2-5.3

placing 4.3
saving as QuickTime 

movies 7.21
presentations 6.12-6.14
preserving visibility 26.29
preset inks 12.7
preset strokes 13.3
preview image, EPSF 7.11
previews

transparency 14.6
printable area 5.7
Print command 4.19-4.23
Printer Setup command 5.5
printing 4.18-4.23

colors as grays 4.21
color separations 10.38
crop marks 4.24
documents 4.20
halftone preferences 9.6
preferences 9.5
previewing 4.19
printable option 6.4
proxies 29.6
scaled pages 4.20
SpriteEffects 2.9
thumbnail previews 4.20
Tile option 4.19
transparency effects 14.5, 

14.22
transparency rendering 

options 4.22
unlinked proxies 29.6

Printing (preferences) tab 9.5
Print Preview command 4.19
priority of Smart Mouse 

constraints 17.13

Properties command 4.16
proxies 29.1

acquiring files as 29.3
printing 4.22

Proxy Info command 29.4, 29.7
Publication documents 5.2-5.3

placing 4.3
Publish and Subscribe 7.26
Publisher borders 7.27
Publisher Options command 7.27
punch, combining objects 18.8
Push tool 16.1, 16.9
Put Away Palettes command 3.8

Q
Quadtone image mode 24.40
QuickDraw 9.5
QuickDraw 3D file format 18.15
QuickDraw 3D graphics 7.19
QuickDraw 3D Metafile file 

format 7.19
QuickDraw 3D tool 7.19
QuickTime Movie file format 7.20
QuickTime tool 7.20
Quit command 3.1
quotation marks, using 

typographical 9.8

R
Radial Blur filter 27.17
Radius dimensioning tool 17.5
rainbow object blends 18.11
rectangles, drawing 15.1
Rectangle tool 15.2, 15.8
Redo command 3.12
Reduce (text size) command 21.15
Reduce Points command 16.23
reference point 18.25
Refresh command 4.8
Registration ink 4.24
relative path 8.10
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relative Smart Mouse 
constraints 17.11

Remote Move tool 26.11
Remove Effects command 10.26, 

18.3, 25.6, 25.8
Remove Wrap command 23.2
Render command 24.7-24.8
Render Image dialog box 24.8
rendering

images 24.7-24.8
objects 24.7-24.8
selected areas 24.9
SpriteLayer and 

SpriteEffects 7.12
rendering options 28.1
Render submenu 28.1
repeating actions

see Undo command 3.12
Repel command 23.3
Repel Options command 23.3
replacing

text 20.6
Replicate command 10.16
Reset Brushes command 24.27
Reshape tool 16.1, 16.8
resizing

paint objects 25.6, 25.11
text objects 19.7
using the Transform 

palette 18.25
vector objects 15.4

resolution
Auto function 25.5
changing 25.6
choosing 25.4
defined 25.4
described 25.5
for scanned images 25.4
of new paint objects 24.3
SpriteEffects 2.10

Resolution command 25.10
Retain Selected Tool preference 9.2
Return key 1.2
reversing actions

see Undo command
Revert command 4.6

RGB color 12.11
RGB Color mode 24.39, 26.18
Right-justification command 21.27
Ripple filter 28.6
root directory 8.8
Rotate command 10.29, 23.11
rotating

bounding box 
orientation 10.30

center of rotation 10.29
freeform selections 10.28
objects 10.16, 18.26
text objects 23.11

rotating objects 10.25
rounded rectangles

adjusting corner radius 15.6
drawing 15.2

Rounded Rectangle tool 15.2, 15.8
round end caps 13.14
round line joins 13.14
Row Selection tool 26.3
Rubber Stamp tool 24.21
rulers

defining 5.7
displaying 5.8
tear-off 5.9

Rulers command 3.11, 5.8, 9.10
rules, paragraph 21.31
Rules command 21.31

S
saturation of colors

Hue/Saturation 
command 27.11

Sponge tool 24.26
Save (image selection) 

command 26.16
Save As command 4.5-4.6, 7.2, 

9.21, 26.17
Save Brushes command 24.27
Save command 4.5
Save Entire Document option 4.5
Save Layers option

saving

layers 4.6
Save Selection option 4.5
saving

animations 8.17
backup documents 9.2
buttons 8.16
image files 7.3
inks 12.7
macro objects 11.4
macro sets 11.6
preset inks 12.8
selected objects 4.5
shortcut configurations 9.18
stroke presets 13.10
templates 9.21
web pages 8.18

saving and loading color 
tables 24.37

Scale command 10.31, 25.6
scaling

freeform selections 10.28
objects 10.16, 10.31, 18.26
when replicating objects 10.19

scanning
determining resolution 25.4
images into Canvas 25.1

Scissors tool 16.15
scrap file 7.24
screen frequency 25.12
Screen mode 14.20
scrolling 9.4
scrolling documents 4.8
searching

clip art 11.2
for macros 11.5
text 20.6

sections 19.9
applying 19.14
deleting 19.12
modifying 19.11

Section tool 19.11
segments

see paths
Select across visible layers 

preference 9.2
Select All command 10.3
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I.1
Select command 10.5
selecting

anchor points 16.13
brushes 24.2
Canvas documents 10.8
columns of pixels 26.3
fonts 21.7
group objects 10.2
in paint objects 10.2
in text 10.2
linked text 21.3
named objects 10.6
objects 10.1
objects by type and 

attributes 10.6
objects on other layers 9.2
parts of objects 10.2
pixels in images 26.1
rows of pixels 26.3
selection indicators 10.3
selection sets 10.6
text 20.2, 21.5
text objects 10.2
text with keyboard keys 20.2
tools 3.5
vector objects 10.2
with modifier keys 10.2
with the Lasso tool 26.3

selections
borders 26.13
contracting 26.12
converting to paths 26.14
expanding 26.12
freeform 10.27
from paths 26.8
Grow and Similar 

commands 26.7
in images 26.2
modifying 26.12
pasting into 26.10
smoothing 26.13

selections in images
adding to 26.5
clearing 26.9
Color Range command 26.5
copying 26.9

defloating 26.11
deleting 26.9
deselecting 26.1
feathering 26.9
floating 26.11
floating selections 26.1
hiding and showing edges 26.1
inverse 26.6
moving 26.11
opacity 26.12
pasting 26.9
selecting all pixels 26.2
selection border 26.1
subtracting from 26.5

Selection tool 10.3, 25.6
Selection to Path command 26.14
Select submenu 26.1
Send All Now command 7.28
Send Edition Now command 7.27
Send to Back command 10.22
Send to Guide Layer command 5.11
Send to Layers command 10.23
Separate grayscales as black 

preference 9.5
separations

color 10.38
grayscale separation 

preference 9.5
Set Tab Length command 3.9
Shadow command 18.22, 23.12
Shadow font style 21.16
Sharpen Edges filter 27.20
Sharpen filters 27.20
Sharpen More filter 27.20
Sharpen tool 24.26
sheet icons 5.3
sheets

placing 4.4
Shift key 1.2
shortcuts 9.17
Show (SpriteEffects) Palette 

command 2.5
Show/Hide Docking Bar 

command 3.8
Show/Hide Guides command 5.11

Show/Hide Status Bar 
commands 3.10

Show/Hide Transparency 
command 14.1

Show/Hide Transparency Preview 
command 14.7

Show Added Words 
command 20.14

Show Channels 
command 26.18-26.19, 26.27

Show Clipboard command 10.7
Show Edges command 26.1
Show Grids command 5.9
Show original objects preference 9.3
Show Page Breaks command 5.5
Show Printable Area command 5.7
Show Rulers command 5.8
Show Size command 17.2
Show Spelling Errors 

command 20.12
Show Text Boxes command 19.7
Show Text Flow Bars 

command 19.20
Show Text Invisibles command 20.4
Show Text Ruler command 21.5
Show Toolbar command 3.6
Show Toolbox command 3.5
Shuffle Down command 10.22
Shuffle Up command 10.22
Similar command 26.7
simplifying paths 16.23
single cusp envelope option 18.14
size of paint objects 25.11
skewing

freeform selections 10.29
objects 10.26, 18.26

skewing objects 10.25
Slant Margin command 23.4
slice, combining objects 18.9
slide icons 5.3
slides

options 6.13
placing 4.4
transitions 6.13

Slide Show command 6.13
slide shows 6.12-6.14

Progressive Build option 6.14
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setting up 6.13
small caps character style 21.17
Small Caps command 21.16
Smart Copy preference 9.8
Smart Lines tool 15.13

drawing 15.19
editing 15.20

Smart Mouse 17.11
absolute constraints 17.11
activating constraints 17.13
adding and deleting 

constraints 17.14
deactivating constraints 17.13
relative constraints 17.11

Smart Mouse (snap) 
command 17.11-17.12

Smooth (paths) command 16.2
smooth anchor points 16.12, 

16.18-16.19, 16.24
Smooth command 26.13
Smudge tool 24.23
Snap options 15.6
snap points 5.10
Snap text to single column 

preference 9.8
Soft Light mode 14.21
Solarize command 28.3
sounds 8.16
source lines, Smart Mouse 17.13
special characters, typing 19.5
Spectrum palette 24.37
Spell Check Document 

command 20.13
spell checking 20.11
Spell Check Selection 

command 20.13
spelling dictionary 20.14
spelling menu 20.12
Spherize command 28.8
spirals

converting to paths 16.21
drawing 15.13

Spiral tool 15.13, 15.16
Sponge tool 24.26
spot color inks 12.10, 12.13
spot colors in duotone images 24.41

Spread command 10.40
spread trap 10.39
SpriteEffects 2.1-2.18

applying 2.2, 2.8
attaching 2.3
duplicating 2.9
effects area size 2.10
lenses 2.12
Mode 2.9
palette 2.13
pasting 2.4
printing 2.9, 4.22
removing 2.8
resolution 2.10
saving and loading 2.4
selecting 10.6
selection masks 2.7
transferring 2.3
transferring between 

objects 10.14
with plug-ins 2.2

SpriteLayers
printing 4.22
selecting 10.6

Sprite tool 10.4
square end caps 13.14
squares, drawing 15.2
Stack command 4.7
stacking

lenses 2.16
stacking order 10.22
stacking windows 4.7
Standard coordinate system 9.3
stars, drawing 15.13
starting Canvas 3.1
Status bar 3.10, 4.7, 10.3
straightening curves 16.13, 16.20
straight line envelope option 18.14
Strikethrough font style 21.16
strokes

applying custom settings 13.9
arrows 13.6
colors, pen inks 13.5
configuration managers 13.8
custom settings 13.10
dashes 13.6, 13.16

deleting presets 13.10
described 13.1
neon 13.3
no pen ink setting 13.5
no stroke settings 13.8
parallel 13.3
pen width 13.4
presets 13.3
presets based on objects 13.10
removing 13.7
saving and loading 

presets 13.10
text 13.2, 21.12

Strokes palette
Arrow tab 13.14
configuration managers 13.8
Dash tab 13.16
Neon tab 13.17
Parallel lines tab 13.18
Pen tab 13.4

styles, object
creating 10.36
deleting 10.37
editing 10.37

styles, text
applying to text 22.4
basing styles on others 22.6
character styles 22.1
copying from other 

documents 22.3
deleting 22.5
finding and changing 20.8
modifying 22.5
paragraph styles 22.1

styles, Toolbar buttons 9.16
Styles command (font styles) 21.16
Stylize submenu 28.1
submenu commands 1.2
Subscribe, Publish and 7.26
Subscriber Options command 7.28
Subscribe To command 7.27
subscript character style 21.17
Subscript command 21.16
substituting fonts 4.2
subtract back, combining 

objects 18.8
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I.2
subtract front, combining 
objects 18.8

superscript character style 21.17
Superscript command 21.16
Symbol tab 12.22
System indexed mode palette 24.35

T
tabs

center 21.9
comma 21.9
decimal 21.9
editing 21.9
left 21.9
right 21.9
tab button 21.9

Tag Image File Format (TIFF) 7.22
tangent lines 16.19

adding and removing 16.13, 
16.19

Tangent Snap option 15.8
tear-off rulers 5.9
templates 5.3, 9.21

envelope effect 18.13
text 21.7

alignment 21.27
apostrophes 9.8
as clipping paths 23.10
attributes 21.7
background color 21.7
baseline position 21.17
binding to a circle 23.8
binding to paths 23.5
binds, removing 23.8
capitalization styles 21.17
changing 20.6
changing attributes 20.6
character 

attributes 21.12-21.22
character styles 21.7, 22.1
checking text flows 19.21
color 21.7
column breaks 21.36
columns 19.7, 19.9

column width 21.33
converting to paths 16.21, 

23.14
copying 20.5
copying text objects 19.7
default inks 12.2
deleting 20.4
drop caps 21.36
editing 20.1
edit mode 20.1
envelope effect 23.13
exporting 20.16
extrude effect 23.13
finding 20.6
flipping 23.11
flow 19.14
flow bars 19.20
flowing 19.5
fonts 21.7
fonts, specifying 21.13
font styles 21.16
foot and inch marks 9.8
footers 19.8
formatting text flows 21.3
frame inks 21.7
freeform mode 23.11
greeking preference 9.8
headers 19.8
horizontal and vertical 

scaling 21.21
hyphenation 21.34
importing 20.15
indents 21.8, 21.25
in dimension objects 17.6
inks 21.7
inks and strokes 21.10
in layouts 19.7
insertion point 20.2
in EasyShapes 15.11
in symbol inks 12.22
justification 21.7, 21.27
justifying last line of 

paragraph 21.33
kerning 21.7, 21.18
layout 19.9
leader characters 21.9

leading 21.7, 21.23
letter spacing 21.32
linked flows 19.20
moving insertion point 20.2
overset indicator 19.19
overset text 19.20
page numbering 19.8
paragraph 

attributes 21.22-21.37
paragraph rules 21.31
paragraph spacing 21.25
paragraph styles 21.7, 22.1
pasting 19.16, 20.5
pasting attributes 10.12
pen size 21.7
placing 19.15
positioning text objects 19.7
preferences 9.7
preset formats 21.4
preventing format 

changes 21.21
quotation marks 9.8
repelling 23.2
replacing 20.5-20.6
resizing text objects 19.7
rotating 23.11
Ruler 21.7
scaling 10.31
searching 20.6
sections 19.9
selecting 10.2, 20.2, 21.1, 21.5
selecting linked text 21.3
setting tabs 21.8
shadow effects 23.12
skewing 23.11
slanting margins 23.4
special characters 19.5
spell checking 20.11
strokes 13.2
styles 21.7
subscript 21.17
superscript 21.17
tab position 21.7
tab types 21.7
Text menu commands 21.4
Text Ruler 21.4, 21.10
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Text tool 19.3
trapping selected 10.40
Type palette 21.4
type size 21.15
typing on paths 19.4
vector effects 23.10-23.14
vertical justification 21.29
Vertical option 9.10
Vertical Text Object tool 9.13
Vertical Text tool 9.12
word spacing 21.32
wrapping inside objects 19.4, 

23.1
wraps, removing 23.4

Text file format 7.22
Text Link tool 19.1, 19.5, 19.20
Text Object tool 19.7
Text Ruler 21.5, 21.7-21.10

indents 21.25
Styles mode 21.6
Type mode 21.6

Text tool 9.8, 19.3
Text Unlink tool 19.1, 19.21
texture inks 12.23
Texture tab 12.23
three-dimensional effects 18.11
Threshold command 27.3
thumbnail previews, printing 4.20
Tight (kerning) command 21.19
Tighten (kerning) command 21.19
Tighten (leading) command 21.23
Tighten Fine Kerning 

command 21.19
Tile Across command 4.7
Tile command 4.7
Tile Down command 4.7
Tile option 4.19
time, inserting in documents 19.8
Time command 19.9
Time Stamp command 19.9
tinting

Colorize command 18.20
tints 12.12
title capitalization style 21.17
Title command 21.16
tolerance, dimension text 17.10

Toolbar 3.6, 9.16
toolbox 3.5, 3.7
tool palettes 3.6
tools

Airbrush 24.19
Angle dimensioning 17.5
Animated GIF 8.17-8.18
Arc 15.2
Arc 3 points 15.3
Arc Radius 15.3
Area dimensioning 17.5
Auto Curve 16.1, 16.5
Baseline dimensioning 17.5
Blend 24.20, 26.28
Blur 24.25
Bucket 24.19
Burn 24.24
Camera 24.9
Canvas Tools folder 25.2
Center dimensioning 17.5
Chain dimensioning 17.5
Circle 3 Points 15.3
Circle Radius 15.3
Color Dropper 12.3, 24.13
Column Selection 26.3
Concentric Circles 15.14
Crop 25.7
Cube 15.15
Curve 16.1, 16.3
Diameter dimensioning 17.5
Direct Selection 10.3
Dodge 24.24
EasyShapes 15.9
Eraser 24.18, 26.30
Freehand 16.1, 16.3
Gradient Vector 12.18
GridMaker 15.13
Hand 4.8
Horizontal dimensioning 17.5
Knife 16.16
Lasso 10.27, 26.3
Line 15.2
Link Info 19.21
Macros 11.4
Magnifying Glass 4.9

Marker 24.18
Marquee 10.27, 26.1-26.2
Multigon 15.17
Neon 24.21
Object Side dimensioning 17.5
Oblique dimensioning 17.5
Oval 15.2
Oval Marquee 26.2
Paintbrush 24.18
Paint Object Creator 24.2
palettes 3.6
Path Text 9.8, 19.4
Pencil 24.17
Perimeter dimensioning 17.5
Perpendicular 

dimensioning 17.5
Polygon 16.1, 16.24
Push 16.1, 16.9
QuickDraw 3D 7.19
QuickTime 7.20
Radius dimensioning 17.5
Rectangle 15.2
Remote Move 26.11
Reshape 16.1, 16.8
Rounded Rectangle 15.2
Row Selection 26.3
Rubber Stamp 24.21
Scissors 16.15
Section 19.11
Selection 10.3, 25.6
selection preference 9.2
Sharpen 24.26
Smart Lines 15.19
Smudge 24.23
Spiral 15.16
Sponge 24.26
Sprite tool 10.4
Text 9.8, 19.3
Text Link 19.1, 19.5, 19.20
Text Object 19.7
Text Unlink 19.1, 19.21
Toolbar buttons 9.16
Vector Transparency 14.15
Vertical dimensioning 17.5
Vertical Text 9.12
Vertical Text Object 9.13
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I.2
Wand 26.4, 26.27
Total Page # command 19.9
Toyo colors 12.12, 12.14
Trace Contour command 28.4
tracking

see letter spacing
transfer modes 14.1, 14.19-14.22, 

26.12
transferring attributes

see Paste Attributes 10.12
Transform command 18.21, 18.24
transforming

using the Transform 
palette 18.25

Transform palette 18.24
transparency 14.1-14.24

channel masks 14.7-14.13
combining objects 18.9
defined 14.3
opacity 14.2
paint object background 24.3
preserving visibility 26.29
preview 14.6
preview options 9.6
printing 14.5, 14.22
printing options 4.22
scope 14.1, 14.5, 14.10, 14.16, 

14.20
transfer modes 14.19-14.22
vector masks 14.14-14.19
visibility masks 24.5, 26.29

Transparency command 10.4
transparency masks 18.5
Transparency palette 14.1-14.2, 

14.13, 14.18, 26.25
Trap Object option 10.40
Trap options 10.38
trapping

trap size 10.40
Trim command 25.7
trimming objects 18.7
Tritone image mode 24.40
TrueType fonts 21.14
Trumatch colors 12.12, 12.14
TWAIN 7.4
TWAIN Acquire command 25.1

TWAIN devices 25.1
TWAIN Select Source 

command 25.1
Twirl filter 28.8
two-byte fonts and text 9.9
two-sided documents

see facing pages
type

see text
Type (preferences) tab 9.7
Type command 21.10
Type palette 9.10

Hyphen tab 21.34
Options tab 21.26
Position tab 21.24, 21.33
Spacing tab 21.34
Styles tab 22.1
Vertical option 9.11

type size 21.15

U
Uncache Object command 4.14, 

4.16
Underline font style 21.16
Undo command 3.12, 9.1

setting levels of 9.1
Undo preference 9.1
Ungroup command 10.19-10.20
ungrouping objects converted to 

paths 16.22
Uniform indexed mode 

palette 24.35
Uniform Resource Locator (URL) 8.1
units 5.2

document units 5.4
units of measurement 5.8, 9.10, 9.14
unlinked proxy 29.6
Unlink Proxy command 29.5
Unlock command 10.23
unlocking objects 10.23
Unsharp Mask command 27.20
Unsmooth (paths) command 16.2
Update Proxies command 29.7
uppercase character style 21.17

Uppercase command 21.16
URL Attachment palette 8.2-8.12
URLs

assigning 8.2
finding in a document 8.4
invalid characters in 8.7
palette menu 8.6
removing 8.4

URL Search dialog box 8.4
Use available system memory 

preference 9.15
Use Compression option 4.6
Use Extensions option 4.6
Use Greeked text preference 9.8
Use Preview Icon option 4.6
Use printer’s default preference 9.6
User Dictionary 20.11, 20.14
User Info preferences 9.15
Use Smart Quotes preference 9.8

V
Vanishing Point command 15.8, 

18.1
vanishing points 18.1
Vanishing Point Snap option 15.8
vector

path texts 19.4
perspective effects 18.1

vector drawing tools 16.1
vector effects

Blend command 18.10
Colorize command 18.20
Combine command 18.6
Envelope command 18.12
fractalizing 18.21
in text 23.10-23.14
three-dimensional 18.11

vector masks 14.14-14.19
vector objects

drawing 15.1
resizing 15.4
scope 14.5

Vector Transparency tools 14.15
Vertical (flip) command 23.11
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Vertical dimensioning tool 17.5
vertical justification 21.29
Vertical option 9.10
vertical skewing 10.27
Vertical Text Object tool 9.13
Vertical Text tool 9.12
Very Loose (kerning) 

command 21.19
Very Tight (kerning) command 21.19
video images 27.23
video LUT animation 9.4
View Fonts command 21.15
viewing

clip art 11.2
view magnification 4.9
viewpoints of lenses 2.14
views

custom 4.11
Views submenu 4.11
Virtual memory preferences 9.14
visibility masks 24.5, 26.29

W
Wand dialog box 26.5
Wand tool 26.4, 26.27
warp envelope option 18.14
Web Browser palette 24.37
web buttons 8.13-8.16
web pages 8.1-8.20

animations 8.17
buttons 8.13
Destination folder 8.9
Equivalent Root folder 8.9
rendering graphics 24.9
root directory 8.8
saving 8.18
sounds 8.16

Wheel (render) command 28.2
When duplicating objects offset 

preference 9.3
When moving objects offset 

preference 9.4
widow and orphan lines 21.35
wiggle, fractals 18.22

windows
arranging 4.7

windows, document 4.7
window size 9.2
Windows operating systems 1.1, 9.8
Windows System palette 24.37
Wireframe command 4.14
Wizard, New Document 5.2
word spacing 21.32
Wrap commands 23.1
wrapping text

indent from object 21.27
inside objects 19.4, 23.1
removing text wraps 23.4

Z
Zoom bar 4.9, 4.12
Zoom Blur filter 27.18
Zoom In command 4.9
zooming documents 4.9, 4.12
Zoom Out command 4.9
Zoom palette 4.9
images

see also paint objects
see also painting
INDEX I.23
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