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Introduction
Cinepak® Toolkit™ is an easy-to-use compression toolthat delivers consistently
high-quality compressed digital movies for the Web, CD-ROM, DVD-ROM, Kiosk,
intranet and game environments. Cinepak Toolkit has been optimized to work with
the NEW Cinepak®Pro™ compressor, achieving precise data rate control for flawless playback.
Cinepak Toolkit can prepare any QuickTime™-compatible files for compression,
including QuickTime movies, QuickTime composites, or multiple PICT files. Use
any QuickTime-compatible video capture, editing, or special effects software to
capture and edit your QuickTime movies, and then use Cinepak Toolkit to optimize
these movies for playback on your target platform.
Cinepak Toolkit provides a monitor window for each stage of the processing. This
feature allows you to view the effects of your settings and make adjustments, if necessary, before starting the final processing. Cross-platform support, audio interleaving, and the ability to combine multiple source files into a single output file are
additional features that you can select.
CinepakPro is compatible! Movies compressed with CienapkPro can be played
back on any existing Cinepak decoder including Macintosh, MacOS, Windows 3.x,
Windows 95, Windows 98, Windows NT, NeXT, Silicon Graphics, Sun Java Media
Tools, 3DO, Sega Saturn, and XWindows with XAnim.

System Requirements
Cinepak Toolkit requires a Mac™OS-compatible PowerPC based computer.
Cinepak Toolkit requires System 7.5 or later and QuickTime 2.5 or later.
Cinepak Toolkit has been optimized to take maximum advantage of the new
CinepakPro compressor. However, Cinepak Toolkit can control image processing
and compression using any QuickTime-compatible compression method (codec).

Introduction
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Chapter 1
Installing Cinepak Toolkit
Follow these instructions to install Cinepak Toolkit and CinepakPro on your startup
disk:
1.

If you have anti-virus software installed on your system, make sure you disable
it before you begin the installation.

2.

Double-click the Install CinepakPro & Toolkit file icon. The license agreement
and late breaking information about Cinepak Toolkit and CinepakPro are
shown. If you agree with the license agreement, click OK to continue.

3.

The Easy Install dialog box appears. If the name of your startup disk does not
appear in this dialog box, click the Switch Disk button until it does.

4.

You may choose the name of the folder into which Cinepak Toolkit is installed
using the Select Folder button. Note: The CinepakPro compressor will be
installed on the currently selected startup disk.

5.

Click Install.

6.

When prompted, click Restart to restart your system and enable the system
extensions included with Cinepak Toolkit.

7.

Restore any anti-virus software you disabled prior to the installation.

8.

The first time you run Cinepak Toolkit you will be prompted for a serial number to enable the Cinepak Toolkit and the CinepakPro compressor. Use the
serial number that was e-mailed to you when you purchased Cinepak Toolkit
with CinepakPro.

Cinepak Toolkit and CinepakPro are now ready to use.
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Chapter 2
Using Cinepak Toolkit
Choosing a Source and Output File
This procedure describes how to choose a single movie or PICT file to be processed
and compressed, and how to specify the output file. For instructions on how to set
up batch processing of multiple movies or PICTS, see page 14.
To define source and output files:
1.

Open Cinepak Toolkit.

2.

Click Set Source (or choose Set Source from the File menu).
A standard file search dialog box appears. Choose the movie you wish to compress. You can use the Show Preview and Create buttons to look at the poster
frames for movies to help you determine which movie to compress.

Choose the file you want to compress. This is your video source file. You can
choose a QuickTime movie or a PICT file. Cinepak Toolkit automatically
enters the video source file name into the Compressed File text box, and
appends the suffix “.MOV.”
3.

To save the output to a different file name, enter the new name in the Compressed File text box. To save the output to a different folder, click Set Output
and open the folder where you want the compressed file to be saved.
Note: If your final video will be played back on the Windows platform, make
sure the Compressed File name is no greater than 8 characters, plus a threecharacter suffix.

Using Cinepak Toolkit
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You are now ready to change or confirm the Video Settings that define the way your
video source file is processed.

Choosing Video Settings
1.

From the Edit menu, choose Video Settings. The following dialog box appears:

2.

Compressor: From the Compressor menu, choose CinepakPro by CTi. The
CinepakPro Options button will appear to the right of the Compressor menu.
To “Fine-Tune” CinepakPro’s internal options, see “CinepakPro Options” on
page 19.

3.

Data Rate/Quality: Enter the desired data rate for the video track, in kilobytes
per second (kbps). The default setting is a data rate of 240 kbps, which is a
high-quality setting for a Macintosh with a double-speed CD-ROM drive. If
you are more familiar with using settings on the standard QuickTime Quality
slider, click the Quality button and use the slider to select a Quality setting.
The optimum data rate/Quality setting depends on the content of your video,
and the capabilities of the platform on which the finished video will be shown.
A good range to try is 190 to 240 kbps; 190 kbps for video to be shown on the
Windows platform, up to 240 kbps for the fastest Macintosh/Power Macintosh
models.
For Web, inter- or intranet delivery, a good range is 24 to 56 kbps with video
frame sizes (see #8 below) of 160 by 120 or smaller.
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4.

Frame Rate: The default output Frame Rate shown in the Video Settings dialog box will be the same as the frame rate of your video source. To specify a
different frame rate for the final, compressed video, enter a new rate in the text
box, or choose a rate from the pull-down menu.

5.

Key Frame Insertion: Determine the frequency of inserting “forced” key
frames. You may need to experiment to get the best key frame rate: too many
key frames may lower the overall quality of the compressed movie. If the
change in the content of the video image differs significantly from frame to
frame, CinepakPro will insert additional “natural” key frames, as needed, to
compress your video.
If you need the ability to skip to certain times or indices within the movie for
you particular application, set this value so that key frames are at or near these
time values. For example, if you need to seek to time values near half seconds,
and the final frame rate (#4 above) is 30 frames/second, use a setting of 15.
For Web, inter- or intranet delivery where data rate minimization is critical, set
the key frame rate to 0 or a very large number. This will allow CinepakPro to
determine where key frames are most efficient and only those will be inserted.
This keeps the data rate as low as possible while maximizing video quality.

6.

Cropping: To crop your video, check Crop, then click the Crop tool button.
The Crop
dialog box appears.

A rectangle defines the image area. Drag the handle(s) on the rectangle to
crop your image. There are eight handles; one at each comer of the rectangle, and one at the midpoint of each side.

Using Cinepak Toolkit
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Use the constrain aspect controls to preserve either the source (original) or
final aspect ratio of the crop box while you adjust it.
To see how your cropping is applied to each frame of your video, drag the
slider at the bottom of the image area.
Or use the control buttons for starting and stopping video playback, and
for adjusting the sound level.

7.

Frame Size: The default output frame size is the same as the frame size of
your video
source. To resize the video before compression, enter a new
frame size in the text box, or choose a size from the pull-down menu.

8.

Noise Filtering: If your video has noise (such as light spots on dark areas)
check Noise Filter and adjust the slider.

If the noise is concentrated at the top or bottom of each frame (“head noise” is
a common cause), it is better to crop the area rather than to apply a noise filter
to the entire image.

Crop noise at
top and bottom
of image rather
than using the
noise filter

9.
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Blurring: To soften jagged edges, check Blur, and then adjust the Blur slider.
If your images have a lot of high-contrast areas, you should apply a slight blur
(10% - 20%) to soften the transitions. This helps the CinepakPro codec process
the video more efficiently.
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10. Deinterlacing: Check the Deinterlace Source check box to enable deinterlacing of full-sized source video frames. Cinepak Toolkit will eliminate and
reconstruct the appropriate field based on your setting of field dominance in the
Other Settings (see below) and the desired output frame rate. Cinepak Toolkit
uses the field that is closest to the sampled instant of time from the original
video. If the source video is not full-sized, no deinterlacing will be done.
11. Click the Other Settings button to choose additional settings for your video
output.

Choosing Other Settings
The “Other Settings” dialog box provides options for making a file that can be
played on either the Macintosh or Windows platform, for interleaving audio and
video, and for selecting field dominance when compressing NTSC or PAL movies.
It will also direct the output of multiple source files to each generate a separate
QuickTime movie, or concantenate them into a contiguous QuickTime movie by
appending them to a single movie file.
To select these other settings:
1.

To combine the resource and data forks used in the standard Macintosh file format into a single fork file that can be read on both the Macintosh and Windows
platforms, make sure the Make Cross-Platform option is checked.

2.

To interleave a movie’s audio and video files, select the Interleave Audio
option. This is required if you want the finished compressed file to be readable
on both the Windows platform and the Macintosh platform. Even if the output
is intended only for the Macintosh, interleaving the audio can produce
smoother playback on the slower Macintosh models. Different platforms play
movies best with specific interleaving settings. Cinepak Toolkit allows you to
specify the interleave ratio by frame or by second.

3.

If you are processing multiple files, and you want the output to be combined
into a single movie file, click Append. If the output movie exists, the newly
compressed output will be added to the end of the output movie when this
check box is checked.

4.

Click OK to activate your settings and close the dialog box.

5.

Choose Save from the File menu to save your control file.

Using Cinepak Toolkit
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Checking Your Video Settings —Monitor Windows
Cinepak Toolkit provides a series of monitor windows that allow you to view the
frames of video as they go through successive stages of processing. The windows
update as processing occurs, so you can compare the effect of each video setting
you chose with the output that results.
■

The Selected Frame window shows the frame that is about to be processed.
The image in this window remains unchanged while the frame is processed, to
allow you to compare the unprocessed frame to the results produced by cropping, resizing, filtering, and compressing the image. If you specified an output
frame rate that is lower than your input frame rate, this window (and all other
status windows) show only the frames that will appear in the final output.

■

The Deinterlaced window shows the effects of the deinterlacing filter when
active.

■

The Cropped window shows the effects of any cropping you have applied.

■

The Noise window shows the effects of any cropping and noise filtering that
has been applied to the frame.

■

The Resized window shows the combined effects of cropping, noise filtering,
and frame resizing. (Resizing occurs only if you have specified an output frame
size that is different from the input frame size.)

■

The Blurred window shows the combined effects of cropping, noise filtering,
frame resizing, and Blur that you have applied to the input video.

■

The Compressed window shows how the final processed, compressed frame
will appear.

Opening and Closing Status Windows
To open a status window, choose Show <Window Name> from the Window menu.
The menu selection changes to Hide <Window Name>. You also can open and
close the status windows by pressing the following key combinations:
Show/Hide Selected Frame
Show/Hide Deinterlaced Frame
Show/Hide Cropped Video
Show/Hide Noise Filtered Video
Show/Hide Resized Video
Show/Hide Blur Results
Show/Hide Compression Results
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Command-I
Command-2
Command-3
Command-4
Command-5
Command-6
Command-7
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Viewing the Processing
The status windows are useful only when processing is taking place. To view the
progress of the Cinepak Toolkit processing:
1.

Open the status windows you want to view. If you are resizing the video, but
not cropping it or applying the Noise or Blur filter, for example, you may want
to open only the Selected Frame, Resized, and Compression windows.

2.

In the main window, click the Step or Start button. The Step button processes
one frame each time you click it. This may be the best option when you have
just begun to experiment with the video settings.
The Start button initiates continuous processing. To pause processing, press the
Start button again. To discontinue processing, press the Stop button.

3.

When you are satisfied with your settings, close the status windows (optional)
and then press Start. The entire Source file will be processed.

The following example shows three status windows from a frame that was cropped
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and resized:

Conforming Your Source Movies
Cinepak Toolkit conforms its output movies, making each frame occur regularly,
and of a consistent duration. When compressing unconformed movies, (including
movies recorded with VideoVision Studio or Telecast) this process may shorten the
length of the video track, while leaving the audio track unchanged. To avoid cutting
off the last few audio samples, Cinepak Toolkit will insert extra video frames.
These appear as white frames at the end of the movie.
To prevent this, you should conform your source movies before you process them
with Cinepak Toolkit. Radius Edit conforms movies automatically, by matching the
video track to the audio track. Because the audio track is sampled regularly and
consistently, the frames of the video track also become regular and consistent.
If you use Adobe Premiere, you must conform the movie manually. Be aware that
Adobe Premiere adjusts both the video and audio tracks to a new, calculated timebase. Refer to the user’s manual included with Adobe Premiere (or any other
QuickTime application you are using) for the procedure for conforming movies.
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For other ways to prepare your movies for Cinepak Toolkit processing, see “Tips
for Success” on page 39.

Using Cinepak Toolkit
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Chapter 3
CinepakPro Options
Cinepak Toolkit includes CinepakPro by CTi, a NEW version of the Cinepak compressor. This compressor has several new options for customizing the video output.
1.

To adjust these options, choose Video Settings from the Edit menu. The Video
Settings dialog box appears:

2.

From the Compressor menu, choose CinepakPro by CTi. An Options button
appears to the right of the Compressor menu.

CinepakPro Options
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3.

Click Options. The CinepakPro options dialog box appears:

This appendix describes these options.

Natural Keyframe Insertion Threshold
In the Video Setting dialog box, you specified the interval you want CinepakPro to
insert a keyframe. This is the forced keyframe rate. At times, for efficiency, CinepakPro will insert keyframes between these forced keyframes (for example, if a cut
occurs during an interval between forced keyframes). The keyframes that automatically are inserted by CinepakPro are the natural keyframes.
The Natural Keyframe Insertion Threshold controls the sensitivity of CinepakPro to
changes in the data. When you set the slider closer to the left, for a lower number,
CinepakPro will look for smaller changes in data between frames before inserting a
keyframe. When you set the slider toward the right and larger numbers, CinepakPro
will less readily insert natural keyframes between the forced keyframes. That is,
CinepakPro will require greater changes in the images before inserting a keyframe.
The best setting depends on your content. Because the data rate is fixed, when more
keyframes are inserted, less data is available for the interframes. This may result in
keyframe pulsing, where the keyframes are of noticeably better quality than the
interframes. When the threshold is set too far toward the left end of the scale, compression is less efficient, and keyframes may be of noticeably poorer quality than
the interframes.
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You may have to experiment to find the best threshold for your movie. The numeric
value for this threshold allows you to accurately reproduce your chosen setting.

Initial Keyframe to Interframe Size Ratio
CinepakPro inserts natural keyframes based on its experience with the data in your
movie. The Initial Keyframe to Interframe Size Ratio controls the insertion of natural keyframes for the interval before CinepakPro has adapted to the data patterns in
your movie. If the first keyframe in your movie looks significantly better than the
first interframe, reduce the Initial Keyframe to Interframe Size Ratio. If the first
keyframe looks significantly worse, increase the Size Ratio. The numeric value in
the box next to this slider allows you to accurately reproduce your setting.
Leave Use Adaptive K/I Ratio unchecked. This option works well only in very specialized cases. With this option unchecked, CinepakPro will use the Initial Keyframe to Interframe Size Ratio to control the relative sizes of key- and inter-frames
throughout the session.

Using CinepakPro in Applications other than Cinepak Toolkit
Cinepak Toolkit is necessary for CinepakPro to run. However, for your convenience, you can use CinepakPro in other applications. To do so, simply leave
Cinepak Toolkit running while you use other QuickTime applications.

CinepakPro Options
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Chapter 4
Using Control Files
About Cinepak Toolkit Control Files
Cinepak Toolkit provides the most common operations you need to prepare your
movies for Cinepak compression and playback. All the settings you choose for
these operations are stored in a single, integrated control file, which can then be
used to process your movies in unattended batch mode.
The control file can even monitor a folder on a network, and process all material
deposited into this folder automatically. Network users can send new material to the
designated source folder, and retrieve processed material from an output folder.
Users also can send updated movies to the folder (without changing the movie
names), and to have the updates processed without further action on their parts.

Creating and Saving Control Files
When you have set all the options you wish, simply choose Save from the File
menu to save all the current settings into a control file. All the settings including the
source and output file names and locations will be saved.

Stationery Control Files
You can create default control setting files that have all the processing settings but
none of the file names (however, the locations of the files are saved). This can be
handy when creating a set of basic defaults that will be used as a basis for later customization.
To create a stationery control file, switch to the Finder and choose Get Info… from
the File menu when a control file is selected. Check the stationery check box. This
will delete the references to any specific files, but leave all the other settings intact.
When you later open this stationery file, it will open as untitled.

Using Control Files
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Setting Defaults
The preset defaults in Cinepak Toolkit work well for delivery of movies on CDROM. However, you may wish to change these defaults for your particular application. To do this, create a control file with the settings you wish to use, convert it to a
stationery file as described above, then place the stationery file the Preferences
folder inside the System Folder of your Startup Disk. The settings in this stationery
control file will now be used as defaults when creating any new control files.
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Chapter 5
Batch Processing
Setting Up Batch Processing
Cinepak Toolkit was designed especially for the unattended batch processing of
multiple QuickTime movies and for processing and combining individual PICT
files to create CinepakPro-compressed QuickTime movies.
There are three ways to batch process files:
■

Drop Folder Method — Create a drop folder that processes any QuickTime
movie or PICT files that are placed in this folder into individual CinepakProcompressed output files. This method uses a single control file.

■

Concatenation Method — Place individual PICT files into a folder, then use the
Append feature (page 13) in the control file to process the files into a single
QuickTime movie, under the direction of a single control file. You can also use
this method to process individual QuickTime movies into a single cuts-only
movie, or to mix PICT files and QuickTime movies.

Drop Folder Method
To process a folder of Source files into individual Output files:
1.

Double-click the Cinepak Toolkit icon to launch the application. A new,
untitled window appears:
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2.

Hold down the Option key and click Set Source. A file search dialog box
appears. (If you don’t hold down the Option key, you can select a source file
only.)
You also can open this dialog box by choosing Set Source from the File menu,
then dragging to select Folder.

3.

Choose the folder that contains the QuickTime movies and/or PICT files you
want to process, then click the Select “<folder name>” button:

Cinepak Toolkit enters an asterisk in the Input text box, indicating that all files
in the folder are selected for processing. The Output text box shows the entry
*.MOV, indicating that output files will named with the corresponding Source
filename, appended with the extension “.MOV.”

If you only want to process a select group of files in the folder, enter additional
characters in the source name to more narrowly define the input, by matching
those additional characters. For example, “Ad*” will direct Cinepak Toolkit to
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process only those files whose filenames begin with “Ad,” like “AdClip43
comp”, “Ad Client Approved.mov”, and “AdTest1.MOV” would all be processed, whereas “Final Ad for Client.mov” would not be processed.
4.

Click the Settings button, or choose Video Settings from the Edit menu. The
Video Settings dialog box appears:

5.

Select your preferred settings. These settings will be used to process all the
files in your source folder. (See Chapter 2 for complete instructions.)

6.

Click the Other Settings button. The Other Settings dialog box appears:
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7.

Under Batch Mode Options, make sure Overwrite is selected, then click OK to
return to the Video Settings dialog box.

8.

Set the location to receive the compressed movies using the Output button.

9.

Click OK to return to the main window., then click the Go button to begin
processing.

While this file is running, Cinepak Toolkit will continually monitor the folder and
process all files placed in this folder that meet the Input name criteria.
Tip: You can use multiple computers running Cinepak Toolkit in batch mode, all
monitoring the same source folder, but with different settings and output folders to
quickly create different samples of movies at a variety of resolutions, frame rates,
data rates, etc.

Append Method
To process a folder of Source files into a single QuickTime movie:
1.

Double-click the Cinepak Toolkit icon to launch the application. A new,
untitled window appears:

2.

Hold down the Option key and click Set Source. A file search dialog box
appears. (If you don’t hold down the Option key, you can select a source file
only.)
You also can open this dialog box by choosing Set Source from the File menu,
then dragging to select Folder.
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3.

Choose the folder that contains the QuickTime movies and/or PICT files you
want to process, then click the Select “folder name” button:

Cinepak Toolkit enters an asterisk in the Input text box, indicating that all files
in the folder are selected for processing. The Output text box shows the entry
*.MOV, indicating that output files will named with the corresponding Source
filename, appended with the extension “.MOV.”

If you only want to process a select group of files in the folder, enter additional
characters in the source name to more narrowly define the input by matching
characters in the files you wish to process. For example, “Final*” will direct
Cinepak Toolkit to process only those files whose filenames begin with “Final.”
That is, the movies “Final Ad - approved” and “FinalSub.MOV” will be processed, while “Ad Final” will not.
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4.

Click the Settings button, or choose Video Settings from the Edit menu. The
Video Settings dialog box appears:

5.

Select your preferred settings. These settings will be used to process all files in
your source folder. (See Chapter 2 for complete instructions.)

6.

Click the Other Settings button. The Other Settings dialog box appears.

7.

Under Batch Mode Options, choose Append.

Click Append to
combine Source
movies into one
Output movie.
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8.

Click OK to return to the main window, then click the Go button to begin
processing. Cinepak Toolkit will process the files in alphanumeric order and
will stop after processing the last name on the list.
If you add a file to the folder after processing begins, the new file will be
processed only if Cinepak Toolkit has not yet reached the position in the
alphabetical list that corresponds to the filename of the late addition.
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Chapter 6
Process Control
The main window of each control document has buttons for controlling Cinepak
Toolkit processing:

■

Go initiates processing of the selected Source. When processing begins, the
Start button changes to a Pause button:

■

Pause temporarily stops the processing after the current frame is completed. When pressed, this button changes to a Start button. When you press
the Start button again, processing resumes at the point at which it stopped
when the Pause button was pressed.

■

Stop terminates processing. If you press the Start button, processing will start
over at the beginning of the file.

■

Step starts the processing of the next frame only. To process additional frames,
you must press the Step button for each frame.

The main window provides indicators that let you monitor the progress of Cinepak
Toolkit processing:
An activity indicator shows when Cinepak Toolkit is processing the file. The center
display shows the time until completion in the format H:MM:SS, where H is hours,
MM is minutes and SS is seconds.

Process Control
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Frame-by-Frame Editing
You can use the Step button to apply different video settings to successive frames in
the same input file. For example, if you have a “talking head” video where the subject moves from side to side, you can crop each frame individually to place the
speaker in the center of the frame.
To do this:
1.

Choose your Video Settings.

2.

Press the Step button to begin processing of the first frame. Processing
will stop after the first frame is compressed.

3.

Go to the Video Settings dialog box and select the settings for the next frame to
be processed.

4.

Press the Save button in this dialog box.

5.

Press the Step button to begin processing the next frame.

6.

Repeat Steps 3 through 5 to process additional frames.
You also can press the Start button when Cinepak Toolkit is not processing a
frame to automatically begin processing the rest of the input file, using the current settings. (Check the activity indicator to see when processing has stopped.)
You can press the Pause button, then press the Step button, to resume frameby-frame editing.
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